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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows/Linux

Mac equivalent

Effect

Tools → Options menu
selection

LibreOffice → Preferences

Access setup options

Right-click

Control+click

Open context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open Styles & Formatting window
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What is Impress?
Impress is LibreOffice’s presentations (slide show) program. You can create slides that contain
many different elements, including text, bulleted and numbered lists, tables, charts, clip art, and a
wide range of graphic objects. Impress also includes a spelling checker, a thesaurus, prepackaged
text styles, and attractive background styles.
This chapter includes instructions, screenshots, and hints to guide you through the Impress
environment while designing your presentations. Although more difficult designs are mentioned
throughout this chapter, explanations for creating them are in the Impress Guide. If you have a
working knowledge of how to create slide shows, we recommend you use the Impress Guide for
your source of information.
To use Impress for more than very simple slide shows requires some knowledge of the elements
which the slides contain. Slides containing text use styles to determine the appearance of that text.
Graphic objects are created the same way that drawings are created in Draw. For this reason, we
recommend that you also see Chapter 3 (Using Styles and Templates) and Chapter 7 (Getting
Started with Draw) in this book. You may also wish to consult the Draw Guide for details.

Starting Impress
You can start Impress in several ways:

• From the LibreOffice Start Center, if no component is open.
• From the system menu or the LibreOffice Quickstarter. Details vary with your operating
•

system; see Chapter 1 (Introducing LibreOffice) for more information.
From any open component of LibreOffice. Click the triangle to the right of the New icon on
the main toolbar and select Presentation from the drop-down menu or choose File → New →
Presentation from the menu bar.

When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose
from the following options:

• Empty presentation, which gives you a blank document
• From template, which is a presentation designed with a template of your choice
• Open existing presentation
If you prefer not to use the wizard in future, you can select Do not show this wizard again.
Click Create to open the main Impress window.
For detailed instructions about how to use the wizard, see “Creating a new presentation” on page
13.

Parts of the main Impress window
The main Impress window (Figure 1) has three parts: the Slides pane, Workspace, and Tasks
pane. Additionally, several toolbars can be displayed or hidden during the creation of a
presentation.

Parts of the main Impress window
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Figure 1: Main window of Impress; ovals indicate the Hide/Show markers

Tip

You can remove the Slides pane or Tasks pane from view by clicking the X in the
upper right corner. You can also show or hide these panes using View → Slide
Pane or View → Tasks Pane.
You can also hide these panes in order to maximize the Workspace area by
clicking the Hide/Show marker in the middle of the vertical separator line and
restore them by clicking again on the same area.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation, in the order they will
be shown (unless you change the slide show order). Clicking a slide in this pane selects it and
places it in the Workspace. When a slide is in the Workspace, you can apply to it any changes
desired.
Several additional operations can be performed on one or more slides simultaneously in the Slides
pane:

•
•
•
•
•

6

Add new slides to the presentation.
Mark a slide as hidden so that it will not be shown as part of the presentation.
Delete a slide from the presentation if it is no longer needed.
Rename a slide.
Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut
and paste).
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It is also possible to perform the following operations, although there are more efficient methods
than using the Slides pane:

• Change the slide transition following the selected slide or after each slide in a group of
slides.
Change the sequence of slides in the presentation.

•
• Change the slide design.
• Change slide layout for a group of slides simultaneously.

Tasks pane
The Tasks pane has five sections. To expand the section you wish to use, click on the rightpointing triangle to the left of the caption. Only one section at a time can be expanded.
Master Pages
Here you define the page style for your presentation. Impress contains prepackaged Master
Pages (slide masters). One of them—Default—is blank, and the rest have a background.

Tip

Press F11 to open the Styles and Formatting window, where you can modify the
styles used in any slide master to suit your purpose. This can be done at any time.

Layout
The prepackaged layouts are shown here. You can choose the one you want, use it as it is or
modify it to your own requirements. At present it is not possible to create custom layouts.
Table Design
The standard table styles are provided in this pane. You can further modify the appearance of a
table with the selections to show or hide specific rows and columns, or to apply a banded
appearance to the rows and columns.
Custom Animation
A variety of animations for selected elements of a slide are listed. Animation can be added to a
slide, and it can also be changed or removed later.
Slide Transition
Many transitions are available, including No Transition. You can select the transition speed
(slow, medium, fast), choose between an automatic or manual transition, and choose how long
the selected slide will be shown.

Workspace
The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These five
tabs are called View buttons. The Workspace below the View buttons changes depending on the
chosen view.

Figure 2: Workspace tabs

Toolbars
Many toolbars can be used during slide creation; they can be displayed or hidden by clicking View
→ Toolbars and selecting from the menu.
Parts of the main Impress window

7

You can also select the icons that you wish to appear on each toolbar. For more information, refer
to Chapter 1 (Introducing LibreOffice) in this book.
Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for
details on the functions available and how to use them.

Status bar
The Status bar, located at the bottom of the Impress window, contains information that you may
find useful when working on a presentation. For details on the contents and use of these fields, see
Chapter 1 (Introducing LibreOffice) in this book and Chapter 1 (Introducing Impress) in the Impress
Guide.

Note

The sizes are given in the current measurement unit (not to be confused with the
ruler units). This unit is defined in Tools → Options → LibreOffice Draw →
General, where you can also change the scale of the page. Another way to
change the scale is to double-click on the number shown in the status bar.

Figure 3: Left end of the Impress status bar

Figure 4: Right end of Impress status bar

Navigator
The Navigator displays all objects contained in a document. It provides
another convenient way to move around a document and find items in
it. To display the Navigator, click its icon
on the Standard toolbar,
choose View → Navigator on the menu bar, or press Ctrl+Shift+F5.
The Navigator is more useful if you give your slides and objects
(pictures, spreadsheets, and so on) meaningful names, instead of
leaving them as the default “Slide 1” and “Slide 2” shown in
Figure Error: Reference source not found.
Figure 5: Navigator

Workspace views
Each of the workspace views is designed to ease the completion of certain tasks; it is therefore
useful to familiarize yourself with them in order to quickly accomplish those tasks.
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Normal view
Normal view is the main view for working with individual slides. Use this view to format and design
and to add text, graphics, and animation effects.
To place a slide in the slide design area (Normal view), click the slide thumbnail in the Slides pane
or double-click it in the Navigator.

Outline view
Outline view contains all the slides of the presentation in their numbered sequence. It shows topic
titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in
the default text boxes in each slide is shown, so if your slide includes other text boxes or drawing
objects, the text in these objects is not displayed. Slide names are also not included.

Figure 6: Outline view
Use Outline view for the following purposes.
1) Making changes in the text of a slide:
•
Add and delete the text in a slide just as in the Normal view.

•
•
•

Move the paragraphs of text in the selected slide up or down by
using the up and down arrow buttons (Move Up or Move Down)
on the Text Formatting toolbar.
Change the outline level for any of the paragraphs in a slide using the left and right
arrow buttons (Promote or Demote).
Both move a paragraph and change its outline level using a combination of these four
arrow buttons.

2) Comparing the slides with your outline (if you have prepared one in advance). If you notice
from your outline that another slide is needed, you can create it directly in the Outline view
or you can return to the Normal view to create it.

Notes view
Use the Notes view to add notes to a slide.
1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.
•
Click the slide in the Slides pane, or

•

Double-click the slide’s name in the Navigator.

3) In the text box below the slide, click on the words Click to add notes and begin typing.
You can resize the Notes text box using the green resizing handles which appear when you click
on the edge of the box. You can also move the box by placing the pointer on the border, then
clicking and dragging. To make changes in the text style, press the F11 key to open the Styles and
Formatting window.

Workspace views
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Figure 7: Notes view

Handout view
Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab
in the workspace, then choose Layouts in the Tasks pane. You can then choose to print 1, 2, 3, 4,
6, or 9 slides per page.

Figure 8: Handout layouts
Use this view also to customize the information printed on the handout. Refer to Chapter 10 of the
Impress Guide for instructions on printing slides, handouts, and notes.
Select from the main menu Insert → Page Number or Insert → Date and Time and in the dialog
box that opens click on the Notes and Handouts tab (see Figure 9). Use this dialog to select the
elements you want to appear on each handout page and their contents. More details on how to use
this dialog are provided in the Impress Guide.
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Figure 9: Dialog to set the page information for handouts and notes

Slide Sorter view
Slide Sorter view contains all of the slide thumbnails. Use this view to work with a group of slides or
with only one slide.

Figure 10: Slide Sorter view

Workspace views
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Customizing Slide Sorter view
To change the number of slides per row:
1) Check View → Toolbars → Slide View to make the Slide View toolbar visible.

Figure 11: Slide Sorter and Slide View toolbars
2) Adjust the number of slides (up to a maximum of 15).

Moving a slide using Slide Sorter
To move a slide in a presentation in the Slide Sorter:
1) Click the slide. A thick black border is drawn around it.
2) Drag and drop it to the location you want.
•
As you move the slide, a black vertical line appears to one side of the slide.

•

Drag the slide until this black vertical line is located where you want the slide to be
moved.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

• Use the Control (Ctrl) key: Click on the first slide and, while keeping the Control key
•
•

pressed, select the other desired slides.
Use the Shift key: Click on the first slide, and while pressing the Shift key, click on the final
slide in the group. This selects all of the other slides in between the first and the last.
Use the mouse: Click slightly to the left of the first slide to be selected. Hold down the left
mouse button and drag the mouse pointer to a spot slightly to the right of the last slide to
be included. (You can also do this right to left.) A dashed outline of a rectangle forms as you
drag the cursor through the slide thumbnails and a thick border is drawn around each of the
selected slides. Make sure the rectangle includes all the slides you want to select.

To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. A vertical black line appears to show you
where the group of slides will go.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.
To make changes, right-click a slide and choose any of the following from the pop-up menu:

•
•
•
•

Add a new slide after the selected slide.
Rename or delete the selected slide.
Change the slide layout.
Change the slide transition.

–
–

For one slide, click the slide to select it. Then add the desired transition.
For more than one slide, select the group of slides and add the desired transition.

• Mark a slide as hidden. Hidden slides will not be shown in the slide show.
• Copy or cut and paste a slide.
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Renaming slides
Right-click on a thumbnail in the Slides pane or the Slide Sorter and choose Rename Slide from
the pop-up menu. In the Name field, delete the old name of the slide and type the new name. Click
OK.

Creating a new presentation
This section describes how to start a new presentation using the Presentation Wizard.
When you start Impress, the Presentation Wizard appears.

Tip

If you do not want the wizard to start every time you launch Impress, select the Do
not show this wizard again option. You can enable the wizard again later under
Tools → Options → LibreOffice Impress → General → Wizard, and select the
Start with wizard option.
Leave the Preview option selected, so templates, slide designs, and slide
transitions appear in the preview box as you choose them.

Figure 12. Choosing the type of presentation
1) Select Empty Presentation under Type. It creates a presentation from scratch.
•
From template uses a template design already created as the basis for a new
presentation. The wizard changes to show a list of available templates. Choose the
template you want.
•
Open existing presentation continues work on a previously created presentation. The
wizard changes to show a list of existing presentations. Choose the presentation you
want.
Both of these options are covered in the Impress Guide.

Creating a new presentation
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2) Click Next. Figure 13 shows the Presentation Wizard step 2 as it appears if you selected
Empty Presentation at step 1. If you selected From template, an example slide is shown in
the Preview box.

Figure 13. Selecting a slide design
3) Choose a design under Select a slide design. The slide design section gives you two
main choices: Presentation Backgrounds and Presentations. Each one has a list of choices
for slide designs. If you want to use one of these other than <Original>, click it to select it.
•
The types of Presentation Backgrounds are shown in Figure 13. By clicking an item,
you will see a preview of the slide design in the Preview window. Impress contains
three choices under Presentations: <Original>, Introducing a New Product, and
Recommendation of a Strategy.
•
<Original> is for a blank presentation slide design.

•

Note

Both Introducing a New Product and Recommendation of a Strategy have their own
prepackaged slide designs. Each design appears in the Preview window when its
name is clicked.
Introducing a New Product and Recommendation of a Strategy can also be used to
create a presentation by choosing From template in the first step (Figure 12).

4) Select how the presentation will be used under Select an output medium. Most often,
presentations are created for computer screen display. Select Screen. You can change the
page format at any time.

Note
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The Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not suitable
for modern widescreen displays. You can change the slide size at any time
switching to Normal view and selecting Format → Page.
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5)

Click Next. The Presentation Wizard step 3 appears.

Figure 14. Selecting a slide design

•
•

Choose the desired slide transition from the Effect drop-down menu.
Select the desired speed for the transition between the different slides in the
presentation from the Speed drop-down menu. Medium is a good choice for now.

6) Click Create. A new presentation is created.

Tip

Note

Caution

You might want to accept the default values for both Effect and Speed unless you
are skilled at doing this. Both of these values can be changed later while working
with Slide transitions and animations. These two features are explained in more
detail in Chapter 9 of the Impress Guide.
If you selected From template on step 1 of the Wizard, the Next button will be active
on step 3 and other pages will be available. These pages are not described here.
Remember to save frequently while working on the presentation, to prevent any
loss of information should something unexpected occur. You might also want to
activate the AutoRecovery function (Tools → Options → Load/Save → General).
Make sure Save AutoRecovery information every is selected and that you have
entered a recovery frequency.

Creating a new presentation
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Formatting a presentation
A new presentation contains only one empty slide. In this section we will start adding new slides
and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.

• Insert → Slide.
• Right-click on the present slide, and select Slide → New Slide from the pop-up menu.
• Click the Slide icon in the Presentation toolbar.

Sometimes, rather than starting from a new slide you want to duplicate a slide you have already
inserted. To do so select the slide you want to duplicate from the Slides pane and then choose
Insert → Duplicate Slide.

Selecting a layout
In the Tasks pane, select the Layout drawer to display the available layouts. The Layouts differ in
the number of elements a slide will contain, spanning from the empty slide (Blank Slide) to a slide
with 6 contents boxes and a title (Title, 6 contents).

Figure 15: Available slide layouts

Note

Text and graphic elements can be readjusted at any time during the preparation of
the presentation, but changing the layout of a slide that already contains some
contents can have a dramatic effect. It is therefore recommended that you pay
particular attention to the layout you select. If you do need to change the layout after
contents have been added, the contents are not lost though they may need to be
reformatted.

The Title Slide (which also contains a section for a subtitle) or Title Only are suitable layouts for the
first slide, while for most of the slides you will probably use the Title, Contents layout.
16
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If you do not know the names for the prepackaged layouts position the cursor on
an icon in the Layout section and its name will be displayed in a small rectangle.

Tip

The small rectangle is called tooltip. If the tooltips are not enabled select Tools →
Options → LibreOffice → General → Help and mark the Tips checkbox. If the
Extended tips checkbox is also marked, you will get more detailed tooltip
information, but the tooltip names themselves will not be provided.

Several layouts contain one or more content boxes. Each of these boxes can be configured to
contain one of the following elements: Text, Media clip, Picture, Chart or Table.
You can choose the type of contents by clicking on the corresponding icon that is displayed in the
middle of the contents box as shown in Figure 16. If instead you intend to use the contents box for
text, just click anywhere on the box to get a cursor.

Figure 16: Selecting the desired contents type for a contents box
To select or change the layout, place the slide in the work area and select the desired layout from
the layout drawer in the Task Pane.
If you have selected a layout with one or more contents boxes, this is a good time to decide what
type of contents you want to insert.

Modifying the slide elements
At present each slide will contain only the elements that are present in the slide master you are
using such as background images, logos, header, footer and so on. It is however unlikely that the
predefined layouts will suit all your needs. Although Impress does not have the functionality to
create new layouts, it allows you to resize and move the layout elements. It is also possible to add
slide elements without being limited to the size and position of the layout boxes.
To resize a contents box, click on the outer frame so that the 8 resizing handles are displayed. To
move it place the mouse cursor on the frame so that the cursor changes shape. You can now click
the left mouse button and drag the contents box to its new position on the slide.
Formatting a presentation
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Caution

Changes to any of the pre-packaged layouts can only be made using View →
Normal, which is the default. Attempting to do this by modifying a slide master,
although possible, may result in unpredictable results and requires extra care as
well as a certain amount of trial and error.

At this step you may also want to remove unwanted frames. To do this:

• Click the element to highlight it. (The green resizing handles show it is highlighted.)
• Press the Delete key to remove it.

Adding text to a slide
If the slide contains text, click on Click to add an outline in the text frame and then type your text.
The Outline styles from 1 to 10 are automatically applied to the text as you insert it. You can
change the outline level of each paragraph as well as its position within the text using the arrow
buttons on the Text Formatting toolbar. See “Adding and formatting text” on page 18 for more
information.

Modifying the appearance of all slides
To change the background and other characteristics of all slides in the presentation, it is best to
modify the slide master or choose a different slide master as explained in the section Working with
slide masters and styles on page 25.
If all you need to do is to change the background, you can take a shortcut:
1) Select Format → Page and go to the Background tab.
2) Select the desired background between solid color, gradient, hatching and bitmap.
3) Click OK to apply it.
A dialog box will open asking if the background should be applied to all the slides. If you click yes,
Impress will automatically modify the slide master for you.

Note

Inserting and correctly formatting a background is beyond the scope of this
chapter, but you can find all the information you need in Chapter 4 of the Draw
Guide or in Chapter 6 of the Impress Guide.

Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide
sorter, without any transition between slides, and you need some keyboard or mouse interaction to
move from one slide to the next.
You can use the Slide Show menu to change the order of the slides, choose which ones are
shown, automate moving from one slide to the next, and other settings. To change the slide
transition, animate slides, add a soundtrack to the presentation, and make other enhancements,
you need to use functions in the Task pane. See the Impress Guide for details on how to use all of
these features.

Adding and formatting text
Many of your slides are likely to contain some text. This section gives you some guidelines on how
to add text and how to change its appearance. Text in slides is contained in text boxes.
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There are two types of text boxes that you can add to a slide:

• Choose a predefined layout from the Layouts section of the Tasks pane and do not select
•

any special contents type. These text boxes are called AutoLayout text boxes.
Create a text box using the text tool in the Drawing toolbar.

Using text boxes created from the Layout pane
In Normal view:
1) Click in the text box that reads Click to add text, Click to add an outline, or a similar
notation.
2) Type or paste your text in the text box.

Using text boxes created from the text box tool
In Normal view:
1) Click on the Text icon
on the Drawing toolbar. If the toolbar with the text icon is not
visible, choose View → Toolbars → Drawing.
2) Click and drag to draw a box for the text on the slide. Do not worry about the vertical size
and position—the text box will expand if needed as you type.
3) Release the mouse button when finished. The cursor appears in the text box, which is now
in edit mode (gray hashed border with green resizing handles shown in Figure 17).
4) Type or paste your text in the text box.
5) Click outside the text box to deselect it.

Figure 17: Selected text box showing the green resizing handles
and text toolbar
You can move, resize, and delete text boxes. For more information, see Chapter 3 in the Impress
Guide.

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to
insert text boxes where the text is aligned vertically. This choice is available only when
Asian languages are enabled in Tools → Options → Language Settings →
Languages.

Adding and formatting text

19

Click on the
button in the drawing toolbar to create a vertical text box. Note that
when editing the contents, the text is displayed horizontally.

Quick font resizing
Impress has convenient buttons on the Formatting toolbar to increase or decrease font size of
selected text
. The amount by which the font size changes depends on the standard sizes
available for the font in use.

Pasting text
You can insert text into a text box by copying it from another document and pasting it into Impress.
However, the pasted text will probably not match the formatting of the surrounding text or that of
the other slides in the presentation. This may be what you want on some occasions; however in
most cases you want to make sure that the presentation does not become a patchwork of different
paragraph styles, font types, bullet points and so on. There are several ways to ensure
consistency; these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste
without formatting, either press Control+Shift+V and then select Unformatted text from the dialog
that appears, or click on the small black triangle next to the paste symbol in the standard toolbar
and select Unformatted text. The unformatted text will be formatted with the outline style at
the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.

Formatting pasted text
If you are pasting the text into an AutoLayout area, you need to apply the appropriate outline style
to the text to give it the same look and feel as the rest of the presentation.
1) Paste the text in the desired position. Do not worry if it does not look right; it will in a
minute.
2) Select the text you have just pasted.
3) Select Format → Default formatting from the menu bar.
4) Use the four arrow buttons in the Text Formatting toolbar
to move the text
to the appropriate position and give it the appropriate outline level. The button with the
arrow pointing left promotes the list entry by one level (for example from Outline 3 to
Outline 2), the right arrow button demotes the list entry by one level, the up and down
arrow buttons move the list entry.
5) Apply manual formatting as required to sections of the text (to change font attributes, tabs,
and so on).
If you are pasting text in a text box, you can still use styles to quickly format the text. Note that one
and only one graphic style can be applied to the copied text. To do that:
1)
2)
3)
4)
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Paste the text in the desired position.
Select the text you have just pasted.
Select the desired graphic style.
Apply manual formatting as required to sections of the text.

Getting Started with Impress

Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is quite different depending on the type of text
box used, although the tools to manage the list and customize the appearance are the same.
In text boxes created automatically by Impress (called AutoLayout), the outline styles available are
by default bulleted lists, while for normal text boxes an additional step is required to create a
bulleted list.

Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as a bulleted list, therefore to
create a bulleted list the only necessary steps are:
1) From the Layout pane, choose a slide design that contains a text box. Those are easily
recognizable from the thumbnail.
2) Click in the text box that reads Click to add an outline.
3) Type the text, then press Enter to start a new bulleted line.
The methods for switching between bulleted and numbered lists are explained in “Changing the
appearance of the list” on page 22.

Tip

Press Shift + Enter to start a new line without creating a new bullet or number. The
new line will have the same indentation of the previous line. To switch off bullets
altogether, click the bullets button on the text formatting toolbar. If the text
formatting toolbar is not showing, enable it selecting View → Toolbar →
Formatting in the menu bar.

Creating lists in other text boxes
To create a list in a text box, follow these steps:
1) Place the cursor in the text box.
2) Click the Bullets On/Off button
on the text formatting toolbar. If the text formatting
toolbar is not showing, enable it by selecting View → Toolbar → Formatting from the menu
bar.
3) Type the text and press Enter to start a new bulleted line.
4) The default list type is a bulleted list. Methods for changing the appearance of the list are
explained on page 22.

Creating a new outline level
1) If necessary, press Enter to begin a new line.
2) Press Tab. Each time you press Tab the line indents to the next outline level. Pressing
Enter creates a new line at the same level as the previous one. To return to the previous
level, press Shift+Tab.
In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a
different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline
3 style, and so on.

Note

Do not try to change the outline level by selecting the text and then clicking the
desired outline style as you would in Writer. Due to the way that presentation
styles work, it is not possible to apply them in this way.

Adding and formatting text
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Changing the appearance of the list
You can fully customize the appearance of a list, changing the bullet type or numbering for the
entire list or for single entry. All of the changes can be made using the Bullets and Numbering
dialog, which is accessed by selecting Format → Bullets and Numbering or by clicking on the
Bullets and Numbering icon on the text formatting toolbar.
For the entire list:
1) Select the entire list or click on the gray border of the text box so that the green resizing
handles are displayed.
2) Select Format → Bullets and Numbering or click on the Bullets and Numbering icon

.

3) The Bullets and Numbering dialog contains five tabs: Bullets, Numbering type, Graphics,
Position, and Customize.

•
•
•

If a bullet list is needed, select the desired bullet style from the default styles available
on the Bullets page.
If a graphics style is needed, select one from those available on the Graphics page.
If a numbered list is needed, select one of the default numbering styles on the
Numbering type page.

For a single line in the list:
1) Click anywhere in the line to place the cursor in it.
2) Follow steps 2–4 of the previous instruction set.
If the list was created in an AutoLayout text box, then an alternative way to change the entire list is
to modify the Outline styles. Changes made to the outline style will apply to all the slides using
them. Sometimes this is what you want; sometimes it is not, so some care must be taken.

Adding pictures, tables, charts and media
As we have seen, besides text a contents box can contain also pictures, tables, charts or media
clips. This section provides a quick overview of how to work with these objects, however for a more
detailed description you are invited to consult the Impress Guide.

Adding pictures
To add a picture to a contents box:

• Click the Insert Picture icon.
• Use the file browser to select the picture file you want to include. To see a preview of the
•

picture, check Preview at the bottom of the Insert picture dialog.
Click Open.

The picture will resize itself to fill the area of the contents box. Follow the directions in the Caution
note below when resizing it by hand.

Note
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You can easily add a picture to a slide outside a contents box. Just select from the
main menu Insert → Picture → From File and follow the same procedure as
above. You will also need to move the picture to the desired location.
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Caution

When resizing a graphic, right-click the picture. Select Position and Size from the
context menu and make sure that Keep ratio is selected. Then adjust the height or
width to the size you need. (As you adjust one dimension. both dimensions will
change.) Failure to do so will cause the picture to become distorted. Remember
also that resizing a bitmap image will reduce its quality; better by far to create an
image of the desired size outside of Impress.

Adding tables
For displaying tabular data, you can insert basic tables directly into your slides by choosing the
Table contents type. It is also possible to add a table outside a contents box in a number of ways:

• Choose Insert → Table from the menu bar
• With the Table button on the main toolbar
• With the Table Design button on the table toolbar
• Select a Style option from the Table Design section of the Tasks pane.
Each method opens the Insert Table dialog. Alternatively, clicking on the black arrow next to the
Table button displays a graphic that you can drag and select the number of rows and columns for
your table.

Figure 18. Creating a table with the Insert Table dialog

Note

Selecting from any of the styles in the Table Design section of the Tasks pane
creates a table based on that style. If you create a table by another method, you
can still apply a style of your choice later.

With the table selected, the Table toolbar should appear. If it does not, you can access it by
selecting View → Toolbars → Table. The Table toolbar offers many of the same buttons as the table
toolbar in Writer, with the exception of functions like Sort and Sum for performing calculations. For
those functions, you need to use a spreadsheet inserted from Calc (discussed below).
After the table is created, you can modify it in much the same ways as you would modify a table in
Writer: adding and deleting rows and columns, adjusting width and spacing, adding borders,
background colors and so on. Detailed information on working with tables and the Table Properties
dialog can be found in Chapter 9 of the Writer Guide.
By modifying the style of the table from the Table Design section of the Tasks pane, you can
quickly change the appearance of the table or any newly created tables based on the Style options
you select. You can choose to add emphasis to a header and total row as well as the first and last
columns of the table, and apply a banded appearance to the rows and columns.

Adding pictures, tables, charts and media
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Having completed the table design, entering data into the cells is similar to working with text box
objects. Click in the cell you wish to add data to, and begin typing. To move around cells quickly,
use the following key options:

• The arrow keys move the cursor to the next table cell if the cell is empty, otherwise they
•

move the cursor to the next character in the cell.
The Tab key moves to the next cell, skipping over the contents of the cell; Shift+Tab move
backwards in this manner.

Adding charts
To insert a chart in a slide you can either use the Insert Chart feature or select Chart as type for
one of the contents box. In both cases Impress will insert a default chart. To modify the chart type,
insert your own data and change the formatting refer to the Impress Guide.

Adding media clips
You can insert various types of music and movie clips into your slide by selecting the Insert Movie
button in an empty contents box. A media player will open at the bottom of the screen and you can
preview the media. In case of an audio file, the contents box will be filled with a loudspeaker
image.

Caution

In Linux-based systems such as Ubuntu, media do not work straight out of the box.
You need to download the Java Media Framework API (JMF) and add the path to
jmf.jar to the Class Path in Tools → Options → LibreOffice → Java.

Adding graphics, spreadsheets, and other objects
Graphics such as shapes, callouts, arrows, and so on are often useful to complement the text on a
slide. These objects are handled much the same as graphics in Draw. For more information, see
Chapter 7 (Getting Started with Draw), the Draw Guide, or Chapters 4, 5, and 6 in the Impress
Guide.
Spreadsheets embedded in Impress include most of the functionality of spreadsheets in Calc and
are therefore capable of performing extremely complex calculations and data analysis. If you need
to analyze your data or apply formulas, these operations are best performed in a Calc spreadsheet
and the results displayed in an embedded Impress spreadsheet or even better in a native Impress
table.
Alternatively, choose Insert → Object → OLE Object from the menu bar. This opens a spreadsheet
in the middle of the slide and the menus and toolbars change to those used in Calc so that you can
start adding data, though you may first need to resize the visible area on the slide. You can also
insert an already existing spreadsheet and use the viewport to select the data that you want to
display on your slide.
Impress offers the capability of inserting in a slide various other types of objects such Writer
documents, Math formulas, or even another presentation. For details on using these objects, refer
to Chapter 7 of the Impress Guide.
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Working with slide masters and styles
A slide master is a slide that is used as the starting point for other slides. It is similar to a page style
in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than
one slide master.

Note

LibreOffice uses three terms for a slide that is used to create other slides: master
slide, slide master, and master page. This book uses the term slide master, except
when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers
and footers; placement and size of text frames; and the formatting of text.

Styles
All of the characteristics of slide masters are controlled by styles. The styles of any new slide you
create are inherited from the slide master from which it was created. In other words, the styles of
the slide master are available and applied to all slides created from that slide master. Changing a
style in a slide master results in changes to all the slides based on that slide master, but you can
modify individual slides without affecting the slide master.
Slide masters have two types of styles associated with them: presentation styles and graphic
styles. The prepackaged presentation styles can be modified, but new presentation styles cannot
be created. In the case of graphic styles, you can modify the prepackaged ones and also create
new ones.
Presentation styles affect three elements of a slide master: the background, background objects
(such as icons, decorative lines, and text frames), and the text placed on the slide. Text styles are
further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are
used for the different levels of the outline to which they belong. For example, Outline 2 is used for
the subpoints of Outline 1, and Outline 3 is used for the subpoints of Outline 2.
Graphic styles affect many of the elements of a slide. Notice that text styles exist in both the
presentation and graphic style selections.

Slide masters
Impress comes with several prepackaged slide masters. They are shown in the Master Pages
section of the Tasks pane. This section has three subsections: Used in This Presentation, Recently
Used, and Available for Use. Click the + sign next to the name of a subsection to expand it to show
thumbnails of the slides, or click the – sign to collapse the subsection to hide the thumbnails.
Each of the slide masters shown in the Available for Use list is from a template of the same name.
If you have created your own templates, or added templates from other sources, slide masters
from those templates will also appear in this list.

Working with slide masters and styles
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Figure 19: Available master pages (slides)

Creating a slide master
Creating a new slide master is similar to modifying the default slide master.
To start, enable editing of slide masters by View → Master → Slide Master.

On the Master View toolbar, click the New Master icon.
A second slide master appears in the Slides pane. Modify this slide master to suit your
requirements. It is also recommended that you rename this new slide master: right-click on the
slide in the Slides pane and select Rename master from the pop-up menu.
When you are done, close the Master View toolbar to return to normal slide editing mode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages section is showing.
To apply one of the slide masters to all slides in your presentation, click on it in the list.
To apply a different slide master to one or more selected slides:
1) In the Slide Pane, select the slides you want to change.
2) In the Tasks Pane, right-click on the slide master you want to apply to the selected slides,
and click Apply to Selected Slides on the pop-up menu.
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Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong
to different templates. For example, you may need a completely different layout for the first slide of
the presentation, or you may want to add to your presentation a slide from a different presentation
(based on a template available on the hard disk).
The Slide Design dialog makes this possible. Access this dialog either from the menu bar (Format
→ Slide design) or by right-clicking on a slide in the Slides pane.
The main window in the dialog shows the slide masters already available for use. To add more:
1) Click the Load button.
2) Select in the new dialog the template containing the slide master. Click OK.
3) Click OK again to close the slide design dialog.
The slide masters in the template you selected are now shown also in the Master Pages section of
the Tasks pane in the Available for use subsection.

Figure 20: Loading slide masters from a presentation template
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Note

Tip

The slide masters you have loaded will also be available the next time you load the
presentation. If you want to delete the unused slide masters, click the
corresponding checkbox in the Slide Design dialog. If the slide master was not
used in the presentation, it is removed from the list of available slide masters
anyway.
To limit the size of the presentation file, you may want to minimize the number of
slide masters used.

Modifying a slide master
The following items can be changed on a slide master:

•
•
•
•

Background (color, gradient, hatching, or bitmap)
Background objects (for example, add a logo or decorative graphics)
Size, placement, and contents of header and footer elements to appear on every slide
Size and placement of default frames for slide titles and content

Before working on the slide master, make sure that the Styles and Formatting window is open.
To select the slide master for modification:
1) Select View → Master → Slide Master from the menu bar. This unlocks the properties of the
slide master so you can edit it.
2) Click Master Pages in the Tasks pane. This gives you access to the pre-packaged slide
masters.
3) Click on the slide master you want to modify among the ones available (Figure 16).
4) Make changes as required, then click the Close Master View icon on the Master View
toolbar. For details, see Chapter 2 of the Impress Guide
5) Save the file before continuing.

Caution

Any changes made to one slide when in Master View mode will appear on all
slides using this slide master. Always make sure you close Master View and return
to Normal view before working on any of the presentation slides. Select View →
Normal from the menu bar, or click Close Master View in the Master View toolbar
to return to the normal slide view.

The changes made to one of the slides in Normal view (for example changes to the bullet point
style or the color of the title area and so on...) will not be overridden by subsequent changes to the
slide master. There are cases, however, where it is desirable to revert a manually modified element
of the slide to the style defined in the slide master: to do that, select that element and choose
Format → Default Formatting from the menu bar.

Using a slide master to add text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects
to the master page for your slides to act as a header or a footer.
1) Choose View → Master → Slide Master from the menu bar.
2) On the Drawing toolbar, select the Text icon.
3) Click once and drag in the master page to draw a text object, and then type or paste your
text into the object or add fields as described below.
4) Choose View → Normal when you are finished.
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The Impress slide master comes with three pre-configured areas for date, footer and page number.

Select Insert → Page Number or Insert → Date and Time to open a dialog box where you can
configure these three areas.

Figure 21: Configuring the slide footer areas

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number
field, choose Format → Page and then select a format from the list in the Layout
Settings area.
To change the paragraph style modify the Background Objects Presentation style.

To add a other information, such as the Author of the presentation or the name of the file, choose
Insert → Fields. and select the required field from the submenu. If you want to edit a field in your
slide, select it and choose Edit → Fields.
The fields you can use in Impress are:

•
•
•
•
•
•

Date (fixed)
Date (variable)—updates automatically when you reload the file
Time (fixed)
Time (variable)—updates automatically when you reload the file
Author—First and last names listed in the LibreOffice user data
Page number (slide number)

Working with slide masters and styles
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• File name
Tip

To change the author information, go to Tools → Options → LibreOffice →
User Data.

Adding comments to a presentation
Impress supports comments similar to those in Writer and Calc.
In Normal View, choose Insert → Comment from the menu bar. A small box containing your initials
appears in the upper left-hand corner of the slide, with a larger text box beside it. Impress
automatically adds your name and the current date at the bottom of the text box.

Figure 22: A comment
Type or paste your comment into the text box. You can optionally apply some basic formatting to
parts of the text by selecting it, right-clicking, and choosing from the pop-up menu. (From this
menu, you can also delete the current comment, all the comments from the same author, or all the
comments in the document.)
You can move the small comment markers to anywhere you wish on the page. Typically you might
place it on or near an object you refer to in the comment.
To show or hide the comment markers, choose View → Comments.
Select Tools → Options → User Data to configure the name you want to appear in the Author field
of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated a different
background color.
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Setting up the slide show
As mentioned in “Modifying the slide show” on page 18, Impress allocates reasonable default
settings for slide shows, while at the same time allowing for customizing many aspects of the slide
show experience. This section covers only some aspects; advanced techniques are explained in
Chapter 9 (Slide Shows) in the Impress Guide.
Most of the tasks are best done in Slide Sorter view where you can see most of the slides
simultaneously. Choose View → Slide Sorter from the menu bar or click the Slide Sorter tab at the
top of the workspace.

One slide set – multiple presentations
In many situations, you may find that you have more slides than the time available to present them
or you may want to provide a rapid overview without dwelling on the details. Rather than having to
create a new presentation, you can use two tools that Impress offers: hiding slides and custom
slide shows.
To hide a slide, right-click on the slide thumbnail either in the Slide pane or in the work area if you
are using the Slide Sorter view and choose Hide Slide from the pop-up menu. Hidden slides are
marked by a slashed slide number.
If you want to reorder the presentation, choose Slide Show → Custom Slide Show. Click on the
New button to create a new sequence of slides and save it.
You can have as many slide shows as you want from a single slide set.

Slide transitions
Slide transition is the animation that is played when a slide is changed. You can configure the slide
transition from the Slide Transition drawer in the Tasks pane. Select the desired transition, the
speed of the animation, and whether the transition should happen when you click the mouse
(preferred) or automatically after a certain number of seconds. Click Apply to all slides unless you
prefer to have different transitions in the presentation.

Tip

The Slide transition section has a very useful choice: Automatic preview. Select its
checkbox. Then when you make any changes in a slide transition, the new slide is
previewed in the Slide Design area, including its transition effect.

Automatic slides advance
You can set the presentation to automatically advance to the next slide after a set amount of time
(for example kiosk mode or carousel) from the Slide Show → Slide Show Settings menu or to
advance automatically after a pre-set amount of time different for each slide. To set up the latter,
choose Slide Show → Rehearse Timings. When using this tool, start the slide show; a small timer
is displayed in the bottom left corner. When you are ready to advance to the next slide, click on the
timer. Impress will memorize the timings and at the next slide show will advance automatically after
the timer expires.

Running the slide show
To run the slide show, do one of the following:

• Click Slide Show → Slide Show.
• Click the Slide Show button on the Presentation toolbar.
Running the slide show
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• Press F5 or F9 on the keyboard.
If the slide transition is Automatic after x seconds, let the slide show run by itself.
If the slide transition is On mouse click, do one of the following to move from one slide to the next:

• Use the arrow keys on the keyboard to go to the next slide or to go back to the previous
one.
Click the mouse to move to the next slide.

•
• Press the spacebar on the keyboard to advance to the next slide.
Right-click anywhere on the screen to open a menu from which you can navigate the slides and set
other options.
To exit the slide show at any time including at the end, press the Esc key.
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