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What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. You can create slides 
that contain many different elements, including text, bulleted and numbered lists, tables, charts, 
and a wide range of graphic objects such as clipart, drawings, and photographs. Impress also 
includes a spelling checker, a thesaurus, and styles for drawings, text, and backgrounds.

This chapter includes instructions to guide you through the Impress environment while designing 
your presentations. Although more difficult designs are mentioned in this chapter, explanations 
for creating them are in the Impress Guide. If you have a working knowledge of how to create 
slide shows, we recommend you use the Impress Guide for your source of information.

To use Impress for more than very simple slide shows requires some knowledge of the elements 
which the slides contain. Slides that contain text use styles to determine the appearance of that 
text. Creating drawings in Impress is similar to the Draw component of LibreOffice. For more 
information, refer to Chapter 3, Using Styles and Templates, and Chapter 7, Getting Started with 
Draw, in this guide. You may also wish to consult the Draw Guide for more details on how to use 
the drawing tools.

Starting Impress

Start Impress using any of the methods described in Chapter 1, Introducing LibreOffice.

When you start Impress for the first time, the main Impress window opens, as default, with the 
Select a Template dialog displayed (Figure 1). 

Templates included with Impress are designed to fit the two standard sizes of presentation slides:
4:3 and 16:9 ratios. However, templates will adapt to other available sizes, which can be selected
by going to Slide > Properties > Paper Format on the Menu bar or Format in the Slide section 
in the Properties deck on the Sidebar.

Figure 1: Select a Template dialog
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Tip

To start Impress without the Select a Template dialog (Figure 1), deselect Show this 
dialog at startup in the lower left of the dialog.

In Windows or Linux, go to Tools > Options > LibreOffice Impress > General on 
the Menu bar and deselect Start with Template Selection under New Document.

In macOS, LibreOffice > Preferences > LibreOffice Impress > General on the 
Menu bar and deselect Start with Template Selection under New Document.

Main Impress window

The main Impress window (Figure 2) has three main sections: Slides pane, Workspace, and 
Sidebar. At the top is a menu bar and toolbars. Toolbars can be displayed, hidden, locked in 
position, or floating during the creation of a presentation.

Tip

You can close the Slides pane or Sidebar by clicking the X in the upper right corner 
of each pane or go to View > Slides Pane or View > Sidebar on the Menu bar to 
deselect the pane. To reopen a pane, select View > Slides Pane or View > Sidebar 
on the Menu bar.

Figure 2: Impress main widow

Tip

You can maximize the Workspace area by clicking on the Hide/Show marker in the 
middle of the vertical separator line (highlighted in Figure 2). Using the Hide/Show 
marker hides, but does not close, the Slides pane or Sidebar. To restore a pane, click
again on its Hide/Show marker.
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Menu bar
The Impress Menu bar, at the top of the main window, provides several menus common to all 
LibreOffice modules. The commands may differ between the modules for File, Edit, View, Insert, 
Format, Tools, Window, and Help. Impress has two extra menus for Slide and Slide Show. When 
you select one of the menus, a submenu drops down to show commands. The Menu bar can be 
customized, for more information, see Chapter 14, Customizing LibreOffice.

Workspace
The Workspace (normally the center of the main window) opens in Normal view. It has four 
standard views selected using tabs: Normal, Outline, Notes, and Slide Sorter (Figure 3). For 
more information, see page 10.

Figure 3: Workspace view tabs

Slides pane
The Slides pane contains thumbnail images of slides in a presentation in the order in which they 
will be shown. Clicking on a slide image in the Slides pane selects it and places the slide in the 
Workspace where you can make changes to the displayed slide.

• To display or close the Slides pane, go to View > Slides Pane on the Menu bar.

• To close the Slides pane, click on the X in the right top corner of the Slides Pane.

• To display or hide the Slides pane, use the Hide/Show marker on the left of the 
Workspace (Figure 2 on page 6).

Several additional operations can be carried out on one or more slides in the Slides pane. These 
additional operations are available from a context menu when you right-click in the Slides pane.

• Add new slides to a presentation.

• Hide a slide so that it will not show in a presentation.

• Delete a slide from a presentation.

• Rename a slide.

• Duplicate a slide (copy and paste).

• Move a slide to another position in the slide order by dragging and dropping it to the 
desired position.

You can also perform the following operations, although there are more efficient methods than 
using the Slides pane:

• Change the slide transition following the selected slide or after each slide in a group.

• Change the sequence of slides in the presentation.

• Change the slide design.

• Change slide layout for a group of slides simultaneously.
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Sidebar
The Impress Sidebar, normally located on the right side of the Workspace. It is similar to the 
Sidebar in the other LibreOffice modules. It consists of seven decks, as described below. To open
a deck, use one of the following methods:

• Click on its icon on the right side of the Sidebar.

• Click on Sidebar Settings at the top of the Sidebar and select a deck from the drop-
down list.

• Go to View on the Menu bar and select the deck required from the drop-down menu.

Properties
The Properties deck has nine sections in two panels allowing you to change slide layout 
and the format of any objects on a slide. You can choose a slide layout and use it, or 
modify it to meet your requirements. However, it is not possible to save customized layouts.
See “Slide layout” on page 14.

– When a slide is selected and appears in the Workspace, the slide panel appears 
allowing you to change the slide format in Slide and the slide layout in Layouts.

– When an object on a slide is selected, the properties panel appears allowing you to 
change the object formats for Character, Paragraph, Area, Lists, Shadow, Line, and 
Position and Size.

Slide transition
The Slide Transition deck provides a selection of slide transitions available in Impress, 
transition speed, automatic or manual transition, and how long a selected slide is shown 
(automatic transition only). For more information, see “Slide transition” on page 41.

Animation
The Animation deck provides an easy way to add, change, or remove animations to 
different elements or objects on a slide and how they appear during a slide show. For more 
information, see “Animation effects” on page 43.

Master Slides
On the Master Slides deck, you define the slide style for your presentation, Impress 
includes several designs of master slides. The default master slide is blank, but the 
remaining master slides have backgrounds and styled text. For more information, see 
“Working with master slides” on page 28.

Styles
On the Styles deck, you can quickly apply drawing and presentation styles to a selected 
object, create new styles for drawing and presentation, and modify both types of styles. 
When you save changes to a style, the changes are applied to all of the elements 
formatted with that style in the presentation. For more information, see “Styles” on page 28.

Gallery
On the Gallery deck, you can insert an object into your presentation either as a copy or as 
a link. A copy of an object is independent of the original object. Changes to the original 
object have no effect on the copy. A link remains dependent on the original object. Changes
to the original object are also reflected in the link. See the Impress Guide for more 
information.

Navigator
On the Navigator deck, you can quickly move between slides in your presentation or select 
an object on a slide. It is recommended to give slides and objects in your presentation 
meaningful names so that you can easily identify them when using the Navigator. For more 
information, see the Impress Guide.
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Status bar
The Status bar (Figure 4), located at the bottom of the Impress window, contains information that 
you may find useful when working on a presentation. For details on the contents and use of 
these fields, see Chapter 1, Introducing LibreOffice, and the Impress Guide.

You can hide the Status Bar by going to View on the Menu bar and deselecting Status Bar.

Figure 4: Status Bar

Slide number
The slide number currently displayed in the Workspace and the total number of slides in the
presentation.

Note

The sizes are given in the current measurement unit and might not be the same as 
the ruler units. The measurement unit on the Status Bar is defined in Tools > 
Options > LibreOffice Impress > General.

Information area
This changes depending on the object selected on the slide. Examples are shown in the 
following table.

Example selection Examples of information shown

Text area Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets Embedded object (OLE) “ObjectName” selected

Graphics Bitmap with transparency selected

Master slide name
The master slide associated with the slide, or notes page currently displayed in the 
Workspace. Right-click to pop up a list of available master slides and select one to apply it 
to the selected slide. For more information, see “Working with master slides” on page 28 
and the Impress Guide.

Cursor position/Object size
Shows different information depending on whether objects are selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

– When an object is selected and being resized with the mouse, the object size 
numbers show the size of the object (width and height).

– If an object is selected, the position numbers shows X and Y coordinates of the upper-
left corner and the object size number pair displays the size of the object. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible parts of the object.

– When an object is selected, clicking in either of these areas opens the Position and 
Size dialog.
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Unsaved changes
Indicates if there are any unsaved changes in your presentation.

Digital signatures
Indicates if your presentation has a digital signature.

Text language
Indicates the language used for any text on your presentation.

Fit slide
When this icon is clicked on, the slide in the workspace zooms to fit in the Workspace.

Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.

Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom 
percentage opens the Zoom & View Layout dialog where you adjust the settings for zoom 
factor and view layout.

Toolbars
Many toolbars can be used during slide creation. They can be displayed or hidden by going to 
View > Toolbars on the Menu bar and selecting from the submenu. For more information on 
toolbars and how to use them, see Chapter 1, Introducing LibreOffice, and the Impress Guide.

Note

The icons that are used on toolbars vary depending on your operating system and 
the selection of icon size and style in Tools > Options > LibreOffice > View.

Workspace views

The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes, 
and Slide Sorter. These tabs are normally displayed the top of the Workspace (Figure 3 on 
page 7). If the tabs are not displayed, then go to View > Views Tab Bar on the Menu bar. You 
can also select the different Workspace views by going to View on the Menu bar and selecting a 
view from the drop-down menu.

Each of the workspace views is designed to ease the completion of certain tasks. It is therefore 
useful to familiarize yourself with them in order to accomplish those tasks quickly.

Note

Each workspace view displays a different set of toolbars when selected. To 
customize these toolbar sets, go to View > Toolbars on the Menu bar, then check or
uncheck the toolbars you want to add or remove.

Normal view
Normal view is the main view for creating individual slides in a presentation. In Normal view you 
can design slides, add and format any text or graphics, and add any animation effects to text or 
graphics.

To place a slide in Normal view of the Workspace (Figure 2 on page 6), either click on the slide 
thumbnail in the Slides pane or click on the slide name in the Navigator.
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Outline view
Outline view in the Workspace (Figure 5) contains all of the slides of the presentation in their 
numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in 
outline format. Only the text contained in the default text boxes in each slide is shown. If you 
have added text boxes or graphic objects to the slides, then these objects are not displayed. 
Slide names are not included.

• Use Outline view for the following:

– Make changes in the text of a slide:

– Add or delete text in a slide as in Normal view.

– Move a paragraph in a slide up or down by using the movement arrows on the Outline
toolbar (Figure 6).

– Change the outline level of a paragraph in a slide using the left and right arrow 
buttons on the Outline toolbar (Figure 6).

• Compare slides with your outline (if you have prepared one in advance). If you notice 
from your outline that another slide is needed, you can create it directly in Outline view, 
or you can return to Normal view to create it.

Figure 5: Outline view in the Workspace

Figure 6: Outline toolbar

Notes view
Use Notes view in the Workspace (Figure 7) to add notes to a slide. These notes are not seen 
when the presentation is shown to an audience using an external display connected to your 
computer. Click on the words Click to add Notes and begin typing.

You can resize the Click to add Notes text box using the resizing handles which appear when you
click on the edge of the box. You can also move or change the size of the box by clicking and 
dragging on the box border.
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When text is inserted in the Click to add Notes text box, it is automatically formatted using the 
predefined Notes style that you can find in Presentation Styles in the Styles deck on the Sidebar. 
You can format the Notes style to suit your needs. For more information on editing styles, see 
Chapter 3, Styles and Templates, in this guide and the Impress Guide.

Figure 7: Notes view in the Workspace

Slide Sorter view
The Slide Sorter view in the Workspace (Figure 8) contains all the thumbnails of slides used in 
your presentation. Use this view to work with one slide or a group of slides.

Figure 8: Slide Sorter view in the Workspace

Customizing Slide Sorter view
To change the number of slides per row in Slide Sorter view:

1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar 
(Figure 9).

2) Adjust the number of slides, up to a maximum of 15, in the Slides per Row box.

Figure 9: Slide View toolbar

Changing slide order
To change the slide order of one or a group of slides in a presentation using Slide Sorter view:

1) Select a slide or a group of slides.

2) Drag and drop the slide or group of slides at the location you want.
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Selecting a group of slides
To select a group of slides, use one of these methods:

• Using the Ctrl key – click on the first slide and, while holding the Ctrl key, select the other 
slides. The selected slides do not have to be next to each other.

• Using the Shift key – click on the first slide, and while holding the Shift key, select the final
slide for the group. This selects all of the slides between the first and the last slide 
selected.

• Using the mouse – position the cursor slightly to one side and outside the first slide, then 
click and hold the left mouse button and drag the cursor until all of the slides you want in 
the group are selected.

Working in Slide Sorter view
You can work with slides in Slide Sorter view just as you can in the Slides pane. To make 
changes, right-click on a slide and choose one of the following from the context menu:

• Cut – removes the selected slide and saves it to the clipboard.

• Copy – copies the selected slide to the clipboard without removing it.

• Paste – inserts a slide from the clipboard after the selected slide.

• New Slide – adds a new slide after the selected slide.

• Duplicate Slide – creates a duplicate of the selected slide and places the new slide 
immediately after the selected slide.

• Rename Slide – allows you to rename the selected slide.

• Hide Slide – any slides that are hidden are not shown in the slide show.

• Delete Slide – deletes the selected slide.

• Layout – allows you to change the layout of the selected slide.

• Move – allows you to move or reposition the slide in the slide show order.

Creating presentations

New presentation
When you create a new presentation, Impress shows only one slide in the Slides pane and 
Workspace (Figure 2 on page 6).

By default, Impress opens with the Select a Template dialog displayed (Figure 1 on page 5) 
where you can select a template to use in your presentation. To create a new presentation 
without using a template, click Cancel in the Select a Template dialog and a blank slide appears 
in the Workspace and Slides pane.

Inserting new slide
To insert a new slide into a presentation, use one of the following methods.

• Go to Slide >  New Slide on the Menu bar.

• Right-click in the Slides pane and select New Slide from the context menu.

• Use the keyboard shortcut Ctrl+M.

• Go to Slide Sorter view in the Workspace, right-click on a slide and select New Slide 
from the context menu.

• Click on the New Slide icon in the Presentation toolbar (Figure 10). If the Presentation 
toolbar is not visible, go to View > Toolbars on the Menu bar and select Presentation 
from the drop-down list.
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Note

A new slide is inserted after the selected slide in the presentation. If a slide is not 
selected, then the new slide is inserted as the last slide in the presentation.

Figure 10: Presentation toolbar

Duplicate slide
To duplicate a slide, select the slide you want to duplicate in the Slides pane and use one of the 
following methods. A duplicate slide is inserted after the selected slide in the presentation.

• Right-click on a slide in the Slides pane and select Duplicate Slide from the context 
menu.

• Go to Slide Sorter view in the Workspace, right-click on a slide and select Duplicate 
Slide from the context menu.

• Go to Slide >  Duplicate Slide on the Menu bar.

• Click on the Duplicate Slide icon in the Presentation toolbar (Figure 10).

Slide layout
By default in Impress, the Title Slide layout is used for the first slide when you create a new 
presentation. The layouts included in Impress range from a blank slide to a slide with six contents
boxes and a title. You can use either a blank layout or one of the title layouts as your title slide.

For more information on slide layouts ands slide contents, see the Impress Guide.

Figure 11: Properties deck on Sidebar - Layouts section

Selecting slide layout
The available layouts are shown in the Layouts section in the Properties deck on the Sidebar. 
After selecting a slide, you can select the slide layout using one of the following methods:

• Go to the Properties deck on the Sidebar to open the Layouts section (Figure 11).
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• Click on Slide Layout on the Presentation toolbar (Figure 10) to open the Layouts 
section on the Properties deck on the Sidebar.

• Click on Slide > Layout on the Menu bar to open a drop-down list showing the layouts by
name.

• Right-click on the selected slide and select Layouts from the context menu.

Tip

To view the names for slide layouts, position the cursor on a layout in the Layout 
section in the Properties deck on the Sidebar and its name will be displayed in a 
small rectangle.

Changing slide layout
Change the slide layout for a slide in your presentation as follows:

1) Select a slide in your presentation.

2) Select a new layout for the slide using one of the methods described in “Slide layout” on 
page 14.

Note

Text and graphic elements can be readjusted at any time during the preparation of a 
presentation, but changing the layout of a slide that already contains some contents 
can have a dramatic effect. It is therefore recommended that you pay particular 
attention to the layout you select. If you do need to change the layout after contents 
have been added, the contents are not lost, but they may need to be reformatted.

Modifying slide elements
When a slide is inserted into a presentation, it contains elements that were included in the 
selected slide layout. However, it is unlikely that predefined layouts will suit all your needs for 
your presentation. You may want to remove elements that are not required or insert objects such 
as text or graphics.

Impress does not have functionality to create custom layouts. However, you can resize and move
the different elements in a slide layout to suit your requirements for slide layout. It is also possible
to add slide elements without being limited to the size and position of content boxes.

Note

It is recommended that changes to slide elements in the layouts included in Impress 
are only made using Normal view, which is the default. Attempting any changes to a 
slide element when in Master view is possible, but may produce unpredictable 
results and requires extra care as well as a certain amount of trial and error.

Moving contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.

2) Place the mouse cursor on the frame so that the cursor changes shape. This is normally 
a clenched hand, but depends on your computer setup.

3) Click the left mouse button and drag the contents box to its new position on the slide, the 
release the mouse button.
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Resizing contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.

2) Place the mouse cursor on a selection handle of the frame so that the cursor changes 
shape.

3) Click the left mouse button and drag the selection handle on the frame to resize the 
contents box, then release the mouse button.

– Top and bottom selection handles change the height of a contents box.

– Left and right selection handles change the width of a contents box.

– Corner selection handles change width and height of a contents box.

Removing elements
1) Click a contents box or an element to highlight it and the selection handles are displayed.

2) Press the Delete or Backspace key to remove the contents box or element.

Adding text
To add text to a slide that contains a text frame, click on Click to add text in the text frame and 
then type your text. Impress outline styles are automatically applied to the text as you insert it. 
You can change the outline level of each paragraph as well as its position within the text by using
the arrow buttons on the Outline toolbar (see Figure 6 and “Outline view” on page 11), or position
the cursor at the beginning of a paragraph and press the Tab key. For more information, see 
“Adding and formatting text” on page 17 and the Impress Guide.

Adding images or objects
To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or 
spreadsheet, click on Insert on the Menu bar and select from the drop-down menu the image or 
object type you require. For more information, see “Inserting images, tables, charts, or media” on
page 23 and the Impress Guide.

Modifying slide appearance
To change the background and other characteristics of all slides in the presentation, you need to 
modify the master slide or choose a different master slide as explained in “Working with master 
slides” on page 28.

A master slide has a specified set of characteristics that acts as a template and is used as the 
starting point for creating other slides. These characteristics include slide background, objects in 
the background, formatting of any text used, and any background graphics.

Impress has a range of master slides, which are found in the Master Slides deck of the Sidebar. 
You can also create and save additional master slides or add more from other sources. See the 
Impress Guide for more information.

For example, if all you need to do is to change a slide background, you can use a shortcut:

1) Select a slide in Normal or Slide Sorter view on the Workspace.

2) Go to Slide > Properties on the Menu bar to open the Slide Setup dialog (Figure 12).

3) Click on the Background tab.

4) Select the desired background from Color, Gradient, Bitmap, Pattern, or Hatch.

5)  Click OK to save the change and close the dialog.
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Note

For more information on inserting, formatting, and changing a background, see the 
Impress Guide or Draw Guide.

Figure 12: Slide Setup dialog - Background page

Adding and formatting text

Most of your slides are likely to contain some text. This section gives some guidelines on how to 
add text and change its appearance. Text used in slides is contained in text boxes. For more 
information on adding and formatting text, see the Impress Guide.

Two types of text boxes are available in Impress for use on slides. You can move, resize, and 
delete text boxes of both types.

• Choose a predefined layout from the Layouts section of the Sidebar and do not select 
any special content type. These text boxes are called AutoLayout text boxes.

• Use the Insert Text Box tool that is available on the Standard toolbar (Figure 13), 
Drawing toolbar (Figure 14) or Text toolbar (Figure 15) to create text boxes on a slide.

• Use the keyboard shortcut F2 to create text boxes on a slide (Windows and Linux only).

Figure 13: Standard toolbar

Figure 14: Drawing toolbar

Figure 15: Text toolbar

Figure 16: Text Formatting toolbar
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Note

When adding and formatting text, the Text Formatting toolbar (Figure 16) normally 
opens, automatically providing you with a range of tools to add and format text to 
your requirements.

Note

If the toolbars are not visible, go to View > Toolbars on the Menu bar and select the 
required toolbars from the drop-down list.

AutoLayout text boxes
1) Make sure Normal view is selected in the Workspace.

2) Select the slide where you want to add text into an AutoLayout text box.

3) Click in the AutoLayout text box and start typing your text. An AutoLayout text box is 
indicated by the text Click to add Title or Click to add text.

Text boxes
1) Make sure Normal view is selected in the Workspace.

2) Select the slide where you want to add text.

3) On the selected slide, create a text box in edit mode using one of the following methods:

– Insert Text Box tool in Windows, Linux and macOS: select Insert Text Box, click on 
the slide and then type or paste your text to create a single line text box. The width of 
a single line text box increases as you add text.

– Keyboard shortcut F2 in Windows and Linux only: press F2, click on the slide and then
type or paste your text to create a single line text box.

– Insert Text Box tool, or keyboard shortcut F2 in Windows, Linux and macOS: click on
the slide and drag to the approximate width required for the text box, then type or 
paste your text to create a multiple line text box. The height of the text box increases 
automatically as you add text creating multiple lines.

4) Release the mouse button and the cursor appears in the text box, which is now in edit 
mode and indicated by a colored border (Figure 17). The width and final position of the 
text box can be adjusted after you have finished adding text into the text box.

5) Click outside the text box to deselect it.

Figure 17: Example text box in edit mode

Note

When creating single line text boxes, multiple lines of text can be created by creating
a new paragraph inside the text box using the Enter key, or entering a line break in 
the text using Shift+Enter.
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Vertical text
In addition to normal text boxes where text is horizontally aligned, it is possible to insert text 
boxes where the text is vertically aligned. Vertical text is available only when Asian languages are
enabled in Tools > Options > Language Settings > Languages.

Creating vertical text boxes is similar to creating horizontal text boxes. Use the Insert Vertical 
Text tool on the Text toolbar (Figure 15 on page 17) to create a vertical text box with single or 
multiple lines. The width of a vertical text box increases automatically as you add text to a multi-
line text box.

Quick font resizing
You can quickly increase or decrease the font size of selected text using the tools Increase Font 
Size (Ctrl+]) and Decrease Font Size (Ctrl+[) on the Text Formatting toolbar (Figure 16 on 
page 17). The amount by which the font size changes depends on the standard sizes available 
for the font in use.

Note

AutoLayout text boxes automatically adjust font size of any text inserted into the 
AutoLayout text box. For example, if you insert a long piece of text into an 
AutoLayout text box, the font size may decrease in size to fit into the box.

Pasting text
You can insert text into an AutoLayout or normal text box by copying it from another document 
and pasting it into Impress. However, the text will probably not match the formatting of the 
surrounding text or that of the other slides in the presentation. This may be what you want on 
some occasions. However, you may want to make sure that the presentation style is consistent 
and does not become a patchwork of different styles, font types, bullet points, and so on.

Unformatted text
It is good practice to paste text without formatting and apply the formatting later reducing the risk 
of errors in your presentation.

1) Highlight and copy the text from another document or slide.

2) Create a text box on your slide and make sure the text cursor is flashing in the text box. 
See “Text boxes” on page 18 and the Impress Guide for more information. Alternatively, 
select an AutoLayout text box on your slide. See “AutoLayout text boxes” on page 18 and
the Impress Guide for more information.

3) Paste unformatted text into the text box using one of the following methods:

– Go to Edit > Paste Special > Paste Unformatted Text on the Menu bar.

– Click on the small downward arrow ▼to the right of the Paste tool on the Standard 
toolbar (Figure 13 on page 17) and select Unformatted Text from the context menu.

– Use the keyboard shortcut Ctrl+Shift+V and select Unformatted text from the dialog 
that opens.

Text is pasted at the cursor position in the text box formatted using the Default Drawing 
Style or the Presentation Style if text was pasted into an AutoLayout text box.

4) Format the text to your requirements using the tools on the Text Formatting toolbar 
(Figure 16 on page 17) or the options in Format on the Menu bar.
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Note

You cannot change a presentation style used in AutoLayout text boxes by selecting 
another presentation style. Make sure the AutoLayout text box uses the presentation 
style you want to use. Change outline levels and outline styles using the Tab key or 
Shift+Tab key combination. See the Impress Guide for more information.

AutoLayout text box formatting of pasted text
If you are pasting the text into an AutoLayout text box, you may need to apply the appropriate 
outline style to the text to give it the same look and feel as the rest of the presentation.

1) Highlight and copy the text from another document or slide.

2) Paste formatted text into the AutoLayout text box.

3) Select the text you have just pasted.

4) Select Format > Clear Direct Formatting on the Menu bar to make sure any formatting 
is removed from the pasted text.

5) Use the four arrow buttons on the Outline toolbar (Figure 6 on page 11) to move the text 
to the appropriate position and give it the appropriate outline level.

– Left arrow promotes a list entry by one level (for example from Outline 3 to Outline 2). 
You can get the same result by placing the cursor at the beginning of the paragraph 
and pressing the Shift+Tab keys.

– Right arrow demotes a list entry by one level. You can get the same result by placing 
the cursor at the beginning of the paragraph and pressing the Tab key.

– Up arrow moves a list entry up in the list order.

– Down arrow moves a list entry down in the list order.

6) If necessary, modify the presentation style to format the text to your requirements o 
change font attributes, tabs, and so on. See the Impress Guide for more information. 
Alternatively, apply any necessary manual or direct formatting to the text to change font 
attributes, tabs, and so on.

Text box formatting of pasted text
Pasting formatted text into a text box overwrites any formatting and replaces the text box style.

1) Highlight and copy the text from another document or slide.

2) If necessary, create a text box on your slide and make sure the text cursor is flashing in 
the text box. See “Text boxes” on page 18 and the Impress Guide for more information.

3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box 
and the text formatting of the pasted text overwrites any style formatting of the text box.

4) Select Format > Clear Direct Formatting on the Menu bar to make sure any formatting 
is removed from the pasted text.

5) Select the required drawing style to format the text from the drawing styles that are 
available in Impress.

6) If necessary, modify a drawing style or create a new drawing style to format the text to 
your requirements. See the Impress Guide for more information.

Note

You can create your own drawing styles in Impress. These drawing styles are only 
available for the Impress presentation in which you have created and saved them. 
You can also create templates that include any drawing styles that you have created.
For more information, see the Impress Guide.

20 | Chapter 6 Getting Started with Impress



Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is slightly different depending on the type of 
text box used, although the tools to manage the list and customize the appearance are the same.
In AutoLayout text boxes, the outline styles use bulleted lists. For normal text boxes, an 
additional step is required to create a bulleted list. In both cases, you can create numbered lists 
or change bulleted lists to numbered. Methods for changing the appearance of a list are 
explained in “Changing list appearance” on page 22.

Figure 18: Example of outline bulleted lists

AutoLayout text boxes
In AutoLayout text boxes, the outline styles available are formatted as bulleted lists. An example 
of these outline styles is shown in Figure 18. These outline styles are presentation styles and 
cannot be deleted, but can be modified or updated to your requirements. See the Impress Guide 
for more information.

Create a slide using an AutoLayout text box with a bulleted list as follows:

1) Go to View > Normal on the Menu bar to make sure you are in Normal view.

2) Select a layout for the slide using one of the following methods:

– Right-click in a blank area on the slide and select a layout from the context menu.

– Go to Slide > Layout on the Menu bar and select a layout from the drop-down list.

– Select a layout in the Layouts section in the Properties deck on the Sidebar.

3) Click on the text ●Click to add Text and start typing your first list item.

4) Press Enter when you have finished typing the first list point creating a new list point.

Tip

Use the keyboard combination Shift+Enter to start a new line without creating a new 
list point. This new line will have the same indentation as the text in the list point. To 
switch off bullets altogether, click on Toggle Bulleted List on the Text Formatting 
toolbar (Figure 16 on page 17).

Changing outline level
In AutoLayout text boxes, change the outline level as follows:

1) To demote the outline level of a list point, use one of the following methods:

– Press the Tab key.

– Click on Demote on the Outline toolbar (Figure 6 on page 11).
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– Click on Demote on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Demote from the submenu.

2) To promote the outline level of a list point, use one of the following methods:

– Use the keyboard shortcut Shift+Tab.

– Click on Promote on the Outline toolbar (Figure 6 on page 11).

– Click on Promote on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Promote from the submenu.

3) To move a list point lower or higher in the list order without changing the outline level, use
one of the following methods:

– Click on Move Down or Move Up on the Outline toolbar (Figure 6 on page 11).

– Click on Move Down on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Move Down or Move Up from the 
submenu.

Note

In AutoLayout text boxes, promoting or demoting an item in the list corresponds to 
applying a different outline style. The second outline level corresponds to Outline 2 
style, the third outline level to Outline 3 style, and so on. A change in level and style 
produces other changes, for example, to font size, bullet type, and so on.

Text boxes
Create a bulleted or numbered list in a text box as follows:

1) Create a text box on a slide and make sure the cursor is flashing in the text box. See 
“Text boxes” on page 18 on how to create a text box.

2) Create a list using one of the following methods:

– Click on Toggle Bulleted List or Toggle Numbered List in the Text Formatting 
toolbar (Figure 16 on page 17)

– Click on Toggle Bulleted List or Toggle Numbered List in the Lists section in the 
Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Bullet List or Numbered List from
the submenu.

3) Type the text and press Enter to start a new list point.

4) Use the keyboard combination Shift+Enter to start a new line without creating a new list 
point. The new line will have the same indentation as the list point.

5) To increase or decrease the indent level of a list point, or move a list point up or down, 
see “Changing outline level” on page 21.

Changing list appearance
The list appearance can be changed for a bullet or numbered type for the entire list or for only a 
single point.

1) Select a single point in a list, or select the entire list or click on the border of the text box 
so that the resizing handles are displayed to select the entire list.

2) Change the list type from bullet to number, or number to bullet as described in “Text 
boxes”.
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3) If required, change the type of bullet or number used for a list as follows.

a) Click on the down pointing triangle ▼ to the right of the Toggle Bulleted List or 
Toggle Numbered List on the Text Formatting toolbar (Figure 16 on page 17) or the 
Lists section in the Properties deck on the Sidebar.

b) Select a bullet or number type from the options available in the drop-down window as 
shown in Figure 19.

Figure 19: More Bullets and More Numbering options

c) If necessary, click on More Bullets or More Numbering in the drop-down window to 
open the Bullets and Numbering dialog for further options to change the list 
appearance. See the Impress Guide for more information.

Note

The Bullets and Numbering dialog can also be opened by going to Format > Bullets
and Numbering on the Menu bar, or by right-clicking on a list point and selecting 
Bullets and Numbering from the context menu.

Note

If the list was created in an AutoLayout text box, then an alternative way to change 
the list appearance is to modify the Outline styles. Changes made to an Outline style
will apply to all the slides that use that style. For more information on modifying 
styles, see the Impress Guide.

Inserting images, tables, charts, or media

A contents box on a slide can contain images, tables, charts or media as well as text. This 
section provides a quick overview of how to work with these objects. For more information on 
inserting images, tables, charts or media, see the Impress Guide.

Inserting images
1) Open the slide in Normal view on the Workspace where you want to insert an image.

2) Open the Insert Image file browser using one of the following methods:

– Go to Insert > Image on the Menu bar.

– Click on Insert Image on the Insert toolbar (Figure 20).

– Click on Insert Image on the Standard toolbar (Figure 13 on page 17).
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3) Navigate to the location of the file and select the image file you want to insert.

4) Click Open to place the image file in the center of the slide and close the Insert Image file
browser.

5) Reposition and resize the image to your requirements.

Figure 20: Insert toolbar

Inserting tables
When a table is inserted into a slide, the Table toolbar (Figure 21) automatically opens. In 
Impress, this toolbar offers the same functions as the Table toolbar in Writer, with the exception 
of the calculation functions Sort and Sum. To use Sum and Sort in your presentation, you have to
insert a Calc spreadsheet.

Entering data into table cells is similar to working with text box objects. Click in a cell and begin 
typing. To move around cells quickly, use the following keyboard options:

• Use the arrow keys to move the cursor to another cell if the cell is empty, or to the next 
character if the cell already contains text.

• Press the Tab key to move to the next cell on the right and press Shift+Tab to move to the
next cell on the left.

Figure 21: Table toolbar

Figure 22: Insert Table dialog

Using the Menu bar
1) Open the slide in Normal view on the Workspace where you want to insert a table.

2) Go to Insert > Table on the Menu bar to open the Insert Table dialog (Figure 22).

3) Select the Number of columns and the Number of rows required for your table.

4) Click on OK to place the table in the center of the slide and close the Insert Table dialog.

5) The Table Design section in the Properties deck on the Sidebar opens (Figure 23). Select
a table design, the type of rows, and the type of columns from the options available.

6) If necessary, reposition and format the table on the slide to your requirements.
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Figure 23: Table Design section in Properties deck 
on Sidebar

Using Insert or Standard toolbar
1) Open the slide in Normal view on the Workspace.

2) Click on Table on the Insert toolbar (Figure 20 on page 24) or the Standard toolbar 
(Figure 13 on page 17) to open the Insert Table grid (Figure 24).

Figure 24: Insert Table grid

3) Click and drag the cursor to create the number of columns and rows required.

4) Click the mouse button to place the table in the center of the slide and the Insert Table 
grid closes.

Note

Selecting More Options at the bottom of the Insert Table grid (Figure 24) opens the 
Insert Table dialog (Figure 22) where you can select the number of rows and 
columns required.

Inserting images, tables, charts, or media | 25



5) The Table Design section in the Properties deck on the Sidebar opens (Figure 23). Select
a table design, the type of rows, and the type of columns from the options available.

6) If necessary, reposition and format the table on the slide to your requirements.

Inserting charts
To insert a chart into a selected slide in Normal view on the Workspace, do one of the following:

• Go to Insert > Chart on the Menu bar..

• Click on Insert Chart on the Insert toolbar (Figure 20 on page 24).

• Click on Insert Chart on the Standard toolbar (Figure 13 on page 17).

Impress switches to chart view, the Formatting toolbar (Figure 25) automatically opens, and the 
Chart Type section on the Properties deck in the Sidebar opens (Figure 26). To change the chart 
type, insert your own data, and change the formatting, see the Impress Guide and the Calc 
Guide.

Figure 25: Formatting toolbar

Figure 26: Chart Type section on Properties deck in the Sidebar

Inserting audio or video

Using file browser
1) Go to Insert > Audio or Video on the Menu bar, or click on Insert Audio or Video on the

Insert toolbar (Figure 20 on page 24) and the Insert Audio or Video file browser opens.

2) Navigate to the folder where the file is located and select the audio or video file you want 
to insert onto a slide. Only the audio and video files that are compatible with Impress will 
be highlighted in the file browser.

26 | Chapter 6 Getting Started with Impress



3) Click on Open to place the audio or video file in the center of the slide and close the 
Insert Audio or Video file browser. The Media Playback toolbar opens while the audio or 
video file is selected.

4) Reposition and/or resize the audio or video file. See the Impress Guide for more 
information.

Using the Gallery
1) If the Gallery deck (Figure 27) is not already open, use one of the following methods:

– Go to View > Sidebar on the Menu bar to open the Sidebar, then select Gallery.

– Go to View > Gallery on the Menu bar.

2) Browse to a category containing media files, for example Sounds.

3) Click on the audio or video file required and drag it onto the slide. The Media Playback 
toolbar automatically opens.

4) Reposition and/or resize the audio or video file.

Figure 27: Gallery deck on Sidebar

Inserting graphics, spreadsheets, and OLE objects

Graphics
Graphics, such as shapes, callouts, and arrows, are often useful to complement the text on a 
slide. These objects are handled much the same way as graphics in Draw. For more information 
on inserting graphics, see Chapter 7, Getting Started with Draw in this guide, the Impress Guide, 
or the Draw Guide.

Spreadsheets
Spreadsheets embedded in Impress include most of the functionality of Calc spreadsheets and 
are capable of performing complex calculations and data analysis. If you need to analyze your 
data or apply formulas, these operations are best performed in a Calc spreadsheet and the 
results displayed in an embedded Calc spreadsheet or in an Impress table. For more information 
on spreadsheets, see the Impress Guide and the Calc Guide.
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OLE objects
Object Linking and Embedding (OLE) is a software technology that allows linking and embedding
of spreadsheets, charts, drawings, formulas, and text files into an Impress presentation.

The major benefit of using OLE objects is that it provides a quick and easy method of editing the 
object using tools from the software used to create the object. These file types can all be created 
using LibreOffice and OLE objects can be created from new or from an existing file.

When you insert a new OLE object into a presentation, it is only available in that presentation and
can only be edited using Impress. For more information on inserting and formatting OLE objects, 
see the Impress Guide.

Working with master slides

A master slide is a slide that is used as the starting point for other slides. It is similar to a page 
style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A 
presentation can have more than one master slide.

A master slide has a defined set of characteristics, including the background color, graphic, or 
gradient. It also can include objects (for example, logos, decorative lines) in the background; 
headers and footers; placement and size of text frames; and text formatting.

Styles
All of the characteristics of master slides are controlled by styles. The styles of any new slide you
create are inherited from the master slide from which it was created. In other words, the styles of 
the master slide are available and applied to all slides created from that master slide. Changing a
style in a master slide results in changes to all the slides based on that master slide. It is possible
to modify each individual slide without affecting the master slide.

Note

It is highly recommended to use the master slides whenever possible. However, 
there are occasions where manual changes are needed for a particular slide.  For 
example, you could edit an individual slide to enlarge the chart area when the text 
and chart layout is used.

Master slides have two types of styles associated with them: presentation styles and drawing 
styles. The presentation styles included with Impress can be modified, but new presentation 
styles cannot be created or deleted. The drawing styles included with Impress can be modified, 
but cannot be deleted. However, you can create new drawing styles and these drawing styles 
you create can be deleted.

Master slides
Impress comes with a collection of master slides. These master slides are shown in the Master 
Slides deck of the Sidebar (Figure 28). This deck has three sections: Used in This Presentation, 
Recently Used, and Available for Use. Click the expand marker next to the name of a section to 
expand it and show thumbnails of the master slides, or click the collapse marker to collapse the 
section to hide the thumbnails.

Each of the master slides shown in the Available for Use section is from a template of the same 
name. These presentation templates are included when LibreOffice is installed on your computer.
If you have created your own templates, or added templates from other sources, master slides 
from those templates will also appear in this list. 
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If you have decided to create a new presentation without using one of the templates available, 
then a default master slide is available. This default master slide is a good starting point for 
creating master slides. An example of the default master slide is shown in Figure 29.

Figure 28: Master Slides deck on Sidebar

Figure 29: Default master slide

Creating master slides
1) Go to View > Master Slide on the Menu bar to open Master view in the Workspace. The 

Master View toolbar also opens (Figure 30). If the Master View toolbar does not open, go 
to View > Toolbars on the Menu bar and select Master View.

Figure 30: Master View toolbar

Working with master slides | 29



2) Create a new master slide using one of the following methods. The new master slide 
appears in the Slides pane:

– Click on New Master in the Master View toolbar.

– Right-click on a master slide in the Slides pane and select New Master from the 
context menu.

– Go to Slide > New Master on the Menu bar.

3) Rename the new master slide using one of the following methods to open the Rename 
Slide dialog:

– Click on the Rename Master icon in the Master View toolbar.

– Right-click on the new master slide in the Slides Pane and select Rename Master 
from the context menu.

4) Enter a memorable name for the new master slide, then click OK to save your changes 
and close the dialog.

5) Make sure your new master slide is selected in the Slides pane and add all the text, 
graphics and master elements that you want to use for it. For more information on adding,
editing, formatting and managing the different types of objects on a master slide, see the 
Impress Guide.

6) When finished creating your new master slide, use one of the following methods to return 
to Normal view:

– Click Close Master View on the Master View toolbar.

– Go to View > Normal on the Menu bar.

7) Save your presentation file before continuing.

Applying master slides
To apply a master slide to all slides or selected slides in your presentation:

1) Click on the Master Slides icon to open the Master Slides deck on the Sidebar 
(Figure 28 on page 29).

2) Right-click on the master slide you want to use in the Used in This Presentation section. 

3) Select Apply to All Slides or Apply to Selected Slides from the context menu.

Loading additional master slides
In a presentation, you may need to mix multiple master slides that may belong to different 
templates (for more information on templates, see the Impress Guide). For example, you may 
want a completely different layout for the first slide of the presentation, or want to add a slide 
from a different presentation to your current presentation.

1) Select the slide or slides in the Slides pane where you want to change the master slide.

2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides
dialog (Figure 31).

3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 32).

4) In the Load Master Slide dialog, select the template category and the template from 
which to load the master slide

5) Click OK to close the Load Master Slide dialog and the master slides from the selected 
template appear in the Available Master Slides dialog.

6) Select the master slide you want to use in Select a Slide Design box.

7) To apply the selected master slide to all slides in your presentation, select the Exchange 
background page check box.
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8) To apply the slide design to the selected slides only, deselect the Exchange background 
page check box.

9) Click OK to apply your selection to the slides and close the dialog.

Figure 31: Available Master Slides dialog

Figure 32: Load Master Slide dialog

Note

The master slides in the template you selected are now shown in the Available for 
use section of the Master Slides deck in the Sidebar.
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Modifying master slides
The following items can be changed on a master slide. For more information, see the Impress 
Guide:

• Background (color, gradient, hatching, or bitmap).

• Background objects (for example, adding a logo or decorative graphics).

• Text attributes for the main text area and notes.

• Size, placement, and contents of header and footer elements to appear on every slide.

• Size and placement of default frames for slide titles and content.

To modify a master slide, follow these steps:

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar 
(Figure 30 on page 29).

2) Select a master slide you want to edit in the Slides pane so that it appears in the 
Workspace (Figure 33).

3) Go to Slide > Properties on the Menu bar or right-click in the Workspace and select 
Properties from the context menu to open the Slide Setup dialog (Figure 34).

4) Use the various options in the Slide, Background, and Transparency pages in the Slide 
Setup dialog to make changes to the format of the master slide.

5) Click OK to save your changes and close the Slide Setup dialog.

6) Select an object on the master slide, then right-click on the object to open a context 
menu.

7) Select one of the options from the context menu to edit the object. Selecting an option 
may open another context menu, a dialog, an application or file browser window so you 
can make the necessary changes to the selected object. 

8) Click Close Master View on the Master View toolbar (Figure 30 on page 29) or go to 
View > Normal on the Menu bar to exit from editing master slides.

9) Save your presentation file before continuing.

Figure 33: Editing Master Slide view in Workspace
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Figure 34: Slide Setup dialog

Note

Any changes made to one slide when in Master Slide mode will appear on all slides 
using this master slide. Always make sure you close Master Slide and return to 
Normal view before working on any of the presentation slides.

Note

The changes made to one of the elements on a slide in Normal view will not be 
overridden by subsequent changes to the master slide. There are cases, however, 
where it is desirable to change a manually modified element of a slide to the style 
defined in the master slide. To change to default formatting, select the element and 
select Format > Clear Direct Formatting from the Menu bar.

Adding text, footers, and fields to master slides
You can add text, footers, or fields to a master slide so those elements appear on every slide in 
your presentation. Headers are not normally added to slides.

Text
1) Go to View > Master Slide on the Menu bar to open Master View as shown in the 

example in Figure 29 on page 29.

2) Insert a text box on the master slide, see “Text boxes” on page 18 for more information.

3) Type or paste your text into the text box.

4) Click outside the text box when finished adding text.

5) Go to View > Normal on the Menu bar or click Close Master View on the Master View 
toolbar (Figure 30 on page 29) when you have finished.

Default footers
By default, a slide footer consists of three sections, each containing a default field as follows:

• Left section – date and time, labelled Date Area. Field name is <date/time>.

• Center section – footer text, labelled Footer Area. Field name is <footer>. This section 
could be the presentation title, file name, or other information.

• Right section – slide number, labelled Slide Number Area. Field name is <number>.

Working with master slides | 33



The default footer fields are set up as follows using the Header and Footer dialog (Figure 35):

1) Go to View > Master Slide on the Menu bar to open Master View.

2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer 
dialog.

3) Click on the Slides tab to open the options available for inserting footers onto a slide.

4) Select Date and Time for the date and time to appear in the left section of the footer.

– For a fixed date and time, select Fixed and enter the date you want to use in the 
Fixed text box.

– For a variable date and time, select Variable, then select the format and language 
from the Format and Language drop-down lists. Using a variable date and time means
that each time the presentation is opened, the date and time are updated.

5) To place text in the footer center section, select Footer and then type or paste your text 
into the Footer text input field.

6) To place the slide number in the right section of the footer, select Slide number.

7) If you do not want the footer to appear on the first slide of a presentation, select Do not 
show on the first slide. The first slide is normally the title slide of a presentation.

8) Click Apply to save your changes and close the Header and Footer dialog.

9) To format the text used for the default footer fields, see the Impress Guide.

10) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed setting up the default footer fields.

Figure 35: Header and Footer dialog – Slides page

Note

The default sections in a footer can be formatted, resized and repositioned. See 
“Adding and formatting text” on page 17 for more information.
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Custom footers
The default fields in a footer section can be replaced with text or manual fields as follows:

1) Go to View > Master Slide on the Menu bar to open the master slide view.

2) Highlight the default field in the footer section and press the Delete or Backspace key. A 
flashing text cursor will appear in the footer section and the Text Formatting toolbar 
(Figure 16 on page 17) automatically opens replacing the Line and Filling toolbar.

3) Type in your text or insert a manual field into the footer section. For more information, see
“Manual fields” on page 35.

4) Format the text or manual field placed in the footer section. See “Adding and formatting 
text” on page 17 and the Impress Guide or more information.

5) Click outside the footer section to close the Text Formatting toolbar and reopen the Line 
and Filling toolbar.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed setting up a custom footer section.

Manual fields
Manual fields can be added as text objects on a master slide or replace one of the default footer 
fields. The fields you can use in a slide are as follows:

• Date (fixed)

• Date (variable) – updates automatically when you open the presentation again.

• Time (fixed)

• Time (variable) – updates automatically when you open the presentation again and each 
time you open a slide more than once during a presentation.

• Author – first and last names listed in the LibreOffice user data.

• Slide number – the sequence number of the slide, without the word “Slide”.

• Slide Title – defaults to Slide 1, Slide 2, and so on if you have not renamed the slides

• Slide Count – the number of slides in the presentation.

• File Name

Tip

To change the author information, go to Tools > Options > LibreOffice > User Data
on the Menu bar.

Adding comments

Impress supports comments similar to those in Writer and Calc.

1) In Normal View, go to Insert > Comment on the Menu bar or use the keyboard shortcut 
Ctrl+Alt+C to open a blank comment (Figure 36).

A small box containing your initials appears in the upper left-hand corner of the slide, with 
a larger text box beside it. Impress automatically adds your name and the current date at 
the bottom of the text box.

If more than one person edits the document, each person is automatically allocated a 
different background color.

2) Type or paste your comment into the text box.
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Figure 36: Adding comments

3) Move the small comment markers anywhere you wish on the slide. Typically you might 
place it on or near an object you refer to in the comment.

4) To show or hide the comment markers, choose View > Comments on the Menu bar.

5) Select Tools > Options > LibreOffice > User Data to configure the name and initials you
want to appear in the comment.

Printing handouts

Handouts are used when you want to distribute a copy of the presentation slides to each member
of your audience. Handouts are only available in View > Handout on the Menu bar and are 
printed using the printing options in Impress.

Note

The printing of handouts depends on the printer, computer operating system, and 
how a computer is setup. The following printing procedure for handouts is only an 
example of how to print handouts.

1) Go to View > Master Handout on the Menu bar to set up the layout of slides for printing 
handouts. An example handout is displayed in the Workspace (Figure 37).

2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer 
dialog (Figure 38).

3) Click on Notes and Handouts tab.

4) Select the required header and footer options as follows:

– Select Header and then enter text in the Header text: text box.

– Select Date and time and then select either Fixed or Variable for the date and time.

– If a fixed date and time was selected, enter the date and/or in the text box.

– If a variable date and time was selected, select the Format for the date and time from 
the drop-down list.

– If a variable date and time was selected, select the Language to set the options for 
the date and time format from the drop-down list.

– Select Footer and then enter text in the Footer text: text box.

– Select Page Number if you want the handout pages numbered.

5) Click on Apply to All to save your options for the handouts and close the Header and 
Footer dialog.
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Figure 37: Example handout in Workspace

Figure 38: Header and Footer dialog - Notes and Handouts page
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6) Go to File > Print on the Menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog (Figure 39).

7) Click on the LibreOffice Impress tab to open the page for printing options of handouts.

Figure 39: Print dialog - LibreOffice Impress page

8) In Document, select the required options from the drop-down lists as follows:

– Type: – select Handouts from the drop-down list.

– Slides per page: – select how many slides are printed on a sheet of paper.

– Order: – select the order in which the slides are printed on a sheet of paper.

9) In Contents, select Slide name, Date and time, and /or Hidden pages if you want these 
items printed.

10) In Color, select how the handouts are printed.

11) In Size, select the size for how the handouts are printed.

12) Click on Print to print the handouts and close the Print dialog.

Creating photo album

Impress can create a photo album from a set of images, usually with one photo per slide. This 
photo album can be a multimedia show with graphics and images or your latest vacation pictures 
as a presentation file.

1) Create a new presentation or open an existing presentation.

2) Select the slide that is going to precede the photo album. In a new presentation, this will 
be the first slide.

3) Go to Insert > Media > Photo Album on the Menu bar to open the Create Photo Album 
dialog (Figure 40).

4) Click on Add to open a file browser and navigate to the folder where your images are 
located.

5) Select the images you want to use and click Open. This closes the file browser and the 
selected files appear in the Create Photo Album dialog.
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6) Select the number of images per slide in the Slide layout: drop-down list.

7) If required, select Add caption to each slide. This inserts a text box on each slide allowing
you to add a caption to the images.

8) If required and there is only one image per slide, select Fill Screen for each image to fill 
the entire slide.

9) Create the required sequence of photos or pictures by moving image files up or down in 
the list of images.

Figure 40: Create Photo Album dialog

10) When the sequence of images is ready, click Insert Slides to create the number of slides
required for your photo album. The sequence can be changed later.

11) If required, you can copy and paste images between slides as you can with any other 
elements that can be placed on a slide.

12) If required, you can setup your presentation and run as a presentation. See “Slide shows”
on page 39, “Running slide shows” on page 44, and the Impress Guide for more 
information.

Slide shows

Impress allocates reasonable default settings for slide shows, while at the same time allowing for 
customizing many aspects of the slide show experience. This section provides an introduction to 
slide shows. For more information on creating, formatting and running slide shows, see the 
Impress Guide.

Most of the tasks are best done in Slide Sorter view in the Workspace where you can see the 
majority of the slides in a presentation. Go to View > Slide Sorter on the Menu bar or click on 
the Slide Sorter tab at the top of the Workspace.

Multiple presentations – single set of slides
You may find that you have more slides than the time available for a presentation or you may 
only want to provide a brief overview first and then a more detailed slide show at a later date. In 
Impress there are two tools that help you do this: hiding slides and custom slide shows.
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Hiding slides
1) Select the slide you want to hide in the Slide pane or Slide Sorter view in the Workspace.

2) Hide the selected slide using one of the following methods. Hidden slides are greyed out 
in the Slide pane or Slide Sorter view in the Workspace.

– Go to Slide > Hide Slide on the Menu bar.

– Right-click on the slide thumbnail and select Hide Slide from the context menu.

– Click on Hide Slide in the Slide View toolbar (Figure 9 on page 12).

3) To show a hidden slide, use one of the following methods.

– Go to Slide > Show Slide on the Menu bar.

– Right-click on the hidden slide thumbnail and select Show Slide from the context 
menu.

– Click on Show Slide in the Slide View toolbar (Figure 9 on page 12).

Custom slide shows
1) Select the slides you want to use for a custom slide show in the Slide pane or Slide Sorter

view in the Workspace.

2) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 
Shows dialog (Figure 41).

Figure 41: Custom Slide Shows dialog

3) Click on New and the Define Custom Slide Show dialog opens (Figure 42).

4) Type a name for the new custom slide show in the Name text box.

5) In the Existing slides list, select the slides to include in the show.

6) Click the >> button to include the slides in the Selected slides list. You can select and 
include several slides at the same time. Hold down the Shift key and click the first and 
last slide in a group to select that group, or hold down the Ctrl key and click on individual 
slides to select them.

7) If required, rearrange the slide order in the Selected slides list. Click on a slide name 
and drag it to a new position in the list, then release the mouse button.

8) Click OK to save the custom slide show and return to the Custom Slide Shows dialog.

9) To activate a custom show, select it in the list in the Custom Slide Shows dialog and then 
select the Use custom slide show option.
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10) Click Start to test the custom slide show or click OK to close the Custom Slide Shows 
dialog.

Figure 42: Define Custom Slide Show dialog

Slide transition
Slide transitions are effects and/or sounds that take place between slides when slides change in 
a slide show. Transitions can add a professional look to a slide show, smoothing the change over 
between slides. For more information on how to setup slide transitions, modify slide transitions, 
and to advance slides in a presentation, see the Impress Guide.

1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 43).

2) Open the presentation file where you want to add slide transitions.

3) In the Slides pane or Slide Sorter view in the Workspace, select the slides where you 
want to apply slide transitions.

4) Click on a transition to apply it to the selected slide.

5) To apply the same transition to all slides in the presentation, click Apply Transition to All
Slides at the bottom of the Slides Transition deck.

6) To check how the transition looks, click Play at the bottom of the Slides Transition deck.

Alternatively, to automatically preview how the transition looks when it is applied, select 
Automatic Preview at the bottom of the Slides Transition deck.

7) In the Advance Slide section, select how the slides change in a presentation.

– On mouse click – each time the mouse is clicked, the presentation advances to the 
next slide.

– Automatically after – enter a time in box to elapse before the next slide in the 
presentation advances into view.
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Figure 43: Slide Transition deck on Sidebar

Playing sounds or music
You can play sound or music during a slide show as a transition effect. When using music in a 
slide show, make sure you not infringing any musical copyright or licensing for the music.

1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 43).

2) Open the presentation file where you want to add slide transitions.

3) In the Slides pane or Slide Sorter view in the Workspace, select the slide where you want 
to add sound or music.

4) In the Modify Transition section, select a sound from the Sound drop-down list.

5) To play music, use the following steps to select a music file:

a) Select Other sound from the Sound drop-down list.

b) In the file browser window that opens, navigate to where the music file is located.

c) Select the music file you want to use and click Play to check if the music is suitable.

d) If the music is suitable, click Open to add the music to the selected slide and close 
the file browser window.

6) To play a sound or music file continuously in the slide show, select the option Loop until 
next sound. The sound or music file restarts once it is finished until the next sound or 
music file that is inserted in the slide show.
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Note

Do not select the Apply Transition to All Slides option, otherwise the selected music 
file restarts at every slide.

Note

The music file is linked to a slide show rather than embedded. If you plan to display 
the slide show on a different computer, remember that you also have to make the 
music file available on the computer where the slide show will be played and 
establish the link to the music file before starting the slide show.

Animation effects
Slide animations are similar to transitions, but they are applied to individual elements in a single 
slide, such as title, chart, shape, or individual bullet point. Animations can make a presentation 
more lively and memorable. However, as with transitions, heavy use of animations can be fun, 
but distracting and even annoying for an audience expecting a professional presentation.

Animations are best applied using Normal view in the Workspace so that you can easily select 
individual objects on a single slide.

On a slide, an element such as a graphic or an entire text box has selection handles around it 
when selected. If you select only a portion of the text in a text box, you may not see any selection
handles. For more information on animation effects, see the Impress Guide.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) Select the slide and element you want to animate.

3) On the Sidebar, select Animation to open the Animation deck (Figure 44).

4) Click on Add Effect (+ plus sign) to open the animation options on the Animation deck.

5) Select an animation category from the Category drop-down list.

6) Select an animation effect from the available options in the Effect list.

7) Select how the animation starts from the Start drop-down list.

8) Select the direction of the animation from the Direction drop-down list.

9) Enter a time for the duration of the animation in the Duration box.

10) Enter a time for the delay of when the animation starts in the Delay box.

11) If required, select Automatic Preview so you can automatically check how the animation 
looks when applied to a slide element.

12) Click Play to check how the animation looks when applied to a slide element.
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Figure 44: Animation deck in Sidebar

Running slide shows
1) Open your presentation and start the slide show using one of the following methods:

– Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the 
current slide.

– Go to Slide Show > Start from First Slide or Start from Current Slide on the Menu 
bar.

– Click on Start from First Slide on the Slide Sorter toolbar.

2) If the slide transition is set to Automatically after x sec, the slide show starts and runs 
after the set time has elapsed.

3) If the slide transition is set to On mouse click, click the left mouse button, or press the 
down arrow key, the right arrow key, the page down key, or the spacebar.

4) To navigate backwards through a slide show one slide at a time, press the up arrow key, 
the left arrow key, or the page up key.
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5) During a slide show, more navigation options are available when you right-click on a slide 
and use the options available in the context menu.

6) When the last slide has displayed, the message Click to exit presentation... is displayed 
on screen. Press the Esc key or click the left mouse button to exit the slide show.

7) To exit the slide show and return to the Impress workspace at any time, press the Esc key
during the slide show.

Note

During the slide show, any animations on a slide are run in the specified order as the
slide is displayed.

Presenter Console
The Presenter Console provides extra control over slide shows when using dual displays, such 
as a laptop for yourself and large display or projector for your audience. The view you see on 
your computer display includes the current slide that can be seen by the audience, the next slide 
in your presentation, any slide notes, and a presentation timer.

Note

The Presenter Console only works with operating systems that support two displays. 
When two displays are being used, one display can be a laptop.

The Presenter Console has to be enabled in Impress before use. Go to Tools > Options > 
LibreOffice Impress > General (Figure 45) and select Enable Presenter Console in 
Presentation.

The Presenter Console provides the following views to assist you when making a presentation:

• Default view – displays the current slide, including any effects and the next slide in the 
presentation (Figure 46). Click on the Previous and Next arrows to navigate through a 
presentation.

• Notes view – click on Notes to switch to display any notes that accompany each slide in 
the presentation (Figure 47). Click on Notes again to return to the default view.

• Slides view – click on Slides to switch to display the slide thumbnails that are being used
for the presentation (Figure 48). Click on Slides again to return to the default view.

• Exchange – click on this icon to switch the Presenter Console between displays.

Figure 45: Options – LibreOffice Impress – General dialog
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Figure 46: Presenter Console – Default view

Figure 47: Presenter Console – Notes view
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Figure 48: Presenter Console – Slides view
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