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Introduction

Earlier chapters of the Draw Guide have dealt only with vector graphics. However, Draw also 
contains a number of functions for handling raster graphics (bitmaps) such as photographs and 
scanned pictures, including import, export, and conversion from one format to another.

Draw can read all the usual graphics file formats. It has a subset of the same capabilities as 
specialized raster graphics programs like Adobe Photoshop or The Gimp.

Importing raster and vector graphics

To import stored graphics files, choose Insert > Picture > From File on the menu bar or click the 

 icon on the Draw toolbar. Draw possesses import filters for many different vector and raster 
graphics formats. If your file has a nonstandard extension, you must choose the format explicitly 
when importing it. 

If you select the Preview option in the Insert picture dialog (Figure 1), Draw shows a preview of the 
picture in the box on the right-hand side. This makes it much easier to choose the picture you want 
and to see whether Draw can import a file of this format.

Figure 1: Inserting a picture; notice Link and Preview options in lower left of dialog

To link or to embed?
If you select the Link option in the Insert picture dialog, the graphic is linked rather than 
embedded. It is not actually inserted into the document; instead, a link to the graphic is created. 
This link is relative to the folder where the document is stored, even though it shows up in the Edit 
Links dialog (see Figure 2) as an absolute link. If you store the document and the graphic in the 
same folder, and transport the folder as a whole to another computer, the graphic will show up in 
the document as before.
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Linked graphics are not changed as a result of any actions carried out within LibreOffice. Such 
changes affect only the view of the graphic in the document and not the graphic itself. In particular, 
the format of a linked graphic remains unchanged. In contrast, when a raster graphic is embedded 
in a LibreOffice document, it is converted into PNG format.

Linking keeps the file size of the Draw document small. The picture can be edited or even replaced 
by another and the link will still function. As long as the new picture is given the same name as the 
old one, links will be re-established and updated when the document containing the link is next 
opened. However, some actions do not last beyond the current session (for example, Filter) or are 
simply not possible on a linked graphic (for example using the Color Replacer to exchange colors).

Links can easily be removed. The linked picture will then be embedded in the document. To break 
a link, choose Edit > Links from the menu bar. In the Edit Links dialog (see Figure 2), choose the 
link to be broken and then click on the Break Link button.

Figure 2: Editing links to documents

Scanning
With most scanners you can directly insert a scanned picture into a document. Scanned images 
are embedded in the document in PNG format.

Make sure that the scanner is supported by the SANE system if you are running a Linux (or other 
UNIX-like) operating system, or TWAIN if you are using Windows, and that it is already configured 
on the machine on which LibreOffice is running. If more than one scanner or equivalent device is 
present, you can select the source from Insert > Picture > Scan > Select Source.

To insert an image from the scanner:

1) Prepare the image in the scanner and make sure that the scanner is ready.

2) Choose Insert > Picture > Scan > Request.

3) The rest of the procedure depends on the scanner driver and interface. You will normally be 
required to specify the resolution, a scan window, and other options. Consult the scanner’s 
documentation for more information.

4) When the image is scanned, Draw places it on the page. At this point it can be edited like 
any other image.
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Pasting from the clipboard
The clipboard offers another way to insert graphics. Depending on the source and the operating 
system, figures may be in different formats. You can obtain an overview by choosing Edit > Paste 
Special from the menu bar or by clicking on the Paste icon’s drop-down menu on the main toolbar. 
The choices on the list vary with the type of graphic on the clipboard.

Dragging and dropping
Drag and drop is also possible in many cases. The exact way that drag and drop works is 
determined by the operating system in use and the source of the graphic, regardless of whether 
the graphic is to be embedded or linked. The behavior can be controlled by the use of the Ctrl or 
Ctrl+Shift keys together.

Draw objects and images which are used frequently can be stored in the Gallery. Objects can be 
dragged from the Gallery to the Draw surface quite simply. Working with the Gallery is dealt with in 
Chapter 10, Advanced Draw Techniques.

Inserting from a file
With this option, you can insert complete pages or single objects from existing Draw or Impress 
documents into your Draw document. In addition you can insert text in Rich Text Format (RTF), 
HTML format or plain text. The text will be contained within a text frame. The usual paragraph and 
character formatting options are available for this text.

Choosing Insert > File brings up the File selection dialog. Select the required file and click Insert. 
If the file is a Draw or Impress document, the Insert Slides/Objects dialog (Figure 3) opens.

Figure 3: Inserting complete pages or objects on a page

To access single pages or slides of the document, click on the expansion symbol (usually a + or a 
small triangle, depending on your operating system) to the left of the file name in the selection 
area. The same method is used to display single objects within slides. Raster graphics (for 

example, photos) and Metafiles are marked with a , drawing objects with a , and OLE 

objects with a .

Choose the slides or objects you want to insert; for multiple selections, press the Control or Shift 
key while clicking on the items. Click OK to insert the selected items.
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If the inserted object was named in the source document, it keeps its original name unless the 
name already exists in the current document. In that case you must give the object a new name 
before it is inserted. To rename an inserted object, right-click and choose Name from the pop-up 
menu. Renaming has the advantage that the object is then listed in the Navigator.

You can choose whether to embed or link the selected page or object.

Exporting graphics

Draw saves drawings by default in the *.ODG format. Some programs cannot open these files. To 
use the drawings in other programs, you can export the graphics in various formats. Choose File > 
Export and then in the File format pull-down list select the desired format (see Figure 4).

Figure 4: Lower part of the Export dialog

Exporting the entire file
The file format options in the upper area of the File format box (HTML, XHTML, PDF, and Flash) 
always apply to the complete file. Use of Flash or HTML format causes each page of the Draw 
document to be exported as a raster graphic. You will no longer be able to access individual 
objects on the page. 

To export a multi-page Draw document as a series of web pages, choose File > Export and select 
HTML Document as the file type. The HTML Export wizard opens. Follow the prompts to create 
the web pages. If you wish, the wizard can generate a navigation aid to help in moving from page 
to page.

If you want to use the objects in other applications, select one of the Metafile formats (JPEG, PNG, 
TIFF, BMP and so on) in the lower part of the File format list (see Figure 5). With this type of 
export, only the currently active page is exported.

Figure 5: Section of the file selection list
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Exporting single objects
In order to export individual drawing objects, you first need to select them. A selection can include 
more than one object. Take care to choose the Selection option on the Export dialog.

Exporting as a vector graphic
The choice of vector formats is still limited. An export to a DXF format file (Autocad) is not yet 
possible. Even the export of a graphic to a SVG format file is not yet fully implemented: 2D graphic 
objects are exported as paths and 3D objects only as preview images. Best supported are the 
Metafile formats and exporting to one of these is usually successful.

Exporting as a raster graphic
The choice of formats for export as a raster graphic is large enough to support most other 
applications. In case of doubt, test different formats to see which gives the best results; some 
programs behave differently depending on the format of the image imported into them.

After typing in a name for the exported file and selecting the file format, you may be able to set 
options for the exported image—compression, color format, version of Metafile—depending on the 
format chosen. Some examples of the various option dialogs are shown in Figure 6.

Where the export dialog allows you to specify the image resolution, this does not affect the number 
of raster points in the image. Rather it inserts information into the picture that tells other programs 
the dimensions to be used in displaying the image. This means that, among other things, missing 
raster points can be interpolated when the graphic is opened in the other program.

The actual number of pixels used is determined by the screen resolution set up by the operating 
system and the Drawing scale factor set in Tools > Options > LibreOffice Draw > General. This 
is a limitation of the current user interface; it is possible to set other resolutions using macros.

Embedded raster graphics, or objects that have been converted to a bitmap or Metafile (from the 
context menu Convert > To Bitmap / To Metafile) may subsequently be saved as a picture; from 
the context menu choose Save as Picture. This saves the picture without Draw-specific additions 
such as text elements, borders, or shadows and without the possibility of setting any of the options 
available when exporting.

Draw objects can easily be imported into Writer, Calc, or Impress documents. For objects used 
often, this is most simply done by storing them in the Gallery or by using the clipboard. As Writer 
and Calc do not possess the same range of tools available within Draw, it makes sense to use 
Draw to produce a complex drawing and then to copy it into the other OOo application. A link to 
single drawing objects is not possible, but you can incorporate Draw documents in the other 
modules as linked OLE objects.

Tip
To avoid problems when scaling Draw objects containing text after importing them 
into Writer, convert the object to a polygon before storing it in the Gallery or copying 
it to the clipboard. See “Convert to a polygon” on page 19.
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Figure 6: Adjusting format specific properties prior to export

Modifying raster object properties

As with other objects, the properties of a raster graphic can be modified. You can format the 
graphic using the Format menu or the context menu. Use the Picture toolbar to add or change 
filters using the Graphic Filter Bar; adjust the Lines, Areas and Shadows properties. The 
Transparency property in the Format menu does not relate to the transparency of the raster 
graphic itself but to the background area. To set the transparency of the graphic, you must use the 
Picture toolbar.

Graphics can also have a text element. For more on text, see Chapter 10, Advanced Draw 
Techniques.

You can change the position and size of graphics, or rotate them, using the methods described in 
Chapter 3, Working with Objects and Object Points. Raster graphics can be flipped (Modify > 
Flip), but some Metafile formats might have problems flipping text.

Graphics included as a member of a group behave like other drawing objects when the properties 
of the group are modified.

It is a good idea to (re-)name the graphic using Name from the Modify menu or the context menu. 
Only named objects are visible in the Navigator and only named objects can be directly imported 
from another file.

The picture (editing) toolbar

The Picture toolbar will automatically appear on the screen whenever you select a picture (see 
Figure 7). It appears either directly under the menu bar in place of the formatting toolbar or as a 
floating toolbar elsewhere on the screen.

Figure 7: The Picture toolbar

The picture (editing) toolbar 9



The following table explains the individual functions on the Picture toolbar and illustrates their use 
with examples.

Filter  
Opens the Filter toolbar, which is described in “The graphic filter toolbar” on 
page 12.

Graphics Mode Use the Graphics mode menu to change the display of the graphic from 
normal color to grayscale, black and white, or a watermark. This setting 
affects only the display and printing of the picture; the picture itself remains 
unchanged.

Default: The graphic is displayed unaltered in color.

Grayscale: The graphic is displayed in 256 shades of gray.

Black/White: The graphic is displayed in black and white.

Watermark: The brightness and contrast of the graphic are reduced to the extent that 
the graphic can be used as a watermark (background).

Color  
Use the Color tool to adjust the values of the three RGB colors, the 
brightness, contrast and the Gamma value. These adjustments do not 
affect the original picture but the values are stored in Draw as a separate 
formatting set.

You can select values from between –100% (no color) to +100% (full 
intensity); 0% represents the original value of the property.

The brightness can be adjusted between –100% (totally black) and +100% 
(totally white).

The contrast can be adjusted between –100% (minimum) and +100% 
(maximum).

The Gamma value affects the brightness of the middle color tones. Values 
can range from 0.10 (minimum) to 10 (maximum)

Hint: Try adjusting this value if changing brightness /contrast does not give 
you the result you want.

Transparency
The degree of transparency of the picture can be adjusted between 0% 
(opaque) and 100% (fully transparent).

Line  

Opens the Line dialog. In this context, line refers to the outline of the 
border. See also Chapter 4, Changing Object Attributes.

Area  

Opens the Area dialog. Here you can edit color, gradient, hatching and fills 
of the background area that contains the graphic—not the graphic itself. To 
see the background, you must set the transparency of the graphic to a 
suitably high value.

Shadow  
Use this tool to set a shadow effect around the graphic.
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Crop  
Use this function to crop (trim) an image. When you click on this icon, crop 
marks appear on the image (Figure 8). Drag one or more of these marks to 
crop the picture to your desired size. For more accurate cropping, see 
“Cropping” below.

Figure 8: Interactive crop marks on an image

Cropping

More control and accuracy over cropping functions is available. Click Format > Crop Picture, or 
right-click the image and select Crop Picture from the context menu, and the dialog in Figure 9 will 
appear.

Figure 9: The Crop dialog

In the Image size section, the size of the source image is given above the Original Size button. 
Pressing this button and then clicking OK sets the inserted image to the source image size. The 
Width and Height fields show the size of the image in the document. In the Scale section, the 
Width and Height fields show the ratio of the inserted image to the original as percentages. In the 
Crop section, the fields Left, Right, Top, and Bottom  establish the amount to be trimmed off the 
appropriate edge. In addition to cropping, you can also enlarge or reduce the size of the graphic by 
changing the percentage scaling values. The new dimensions of the graphic are shown in the 
Image Size Width and Height boxes, which can also be directly adjusted.
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In Figure 9 you can see that 2 cm from each side will be trimmed from the inserted object. The 
preview pane shows the location of the new edges of the graphic. You can see that the inserted 
image has been scaled to 58% on insertion into the document.

• If you choose Keep Scale, the graphic will be cropped to the scales shown in the width and 
height boxes and the picture reduced in size accordingly.

• If you choose Keep image size, the graphic will be cropped and then enlarged to the 
original image size. With equal amounts set in the Crop section's dimension boxes, the 
effect will be to zoom in or out.

Take care with these operations: in the Crop dialog the width and height are treated as totally 
independent values. Changing one without the other can result in significant distortion of the 
image; this might not be what you want.

As an alternative to cropping, the Position and Size dialog on the context menu has an option for 
keeping the width:height ratio fixed while changing one of the two dimensions. Changing values in 
one area (Scale or Image Size) will show up correspondingly in the other area.

Caution Any changes made in the Crop dialog change only the view of the picture. The 
original picture is not changed. If you want to export a cropped graphic, you must 
do it through File > Export. If you use the option Save as Picture from the context 
menu, the changes are not exported.

The graphic filter toolbar

Click the Filter icon  to open the Filter toolbar. Draw offers eleven filter effects. Filters work on 
the current view of an object and they can be combined. Filters always apply to the entire graphic; 
it is not possible to use filters to edit only a part of the object.

Invert reverses (inverts) the colors of an image so that it appears as a color negative 
of the image.

  

Smooth reduces the contrast between neighboring pixels and produces a slight lack 
of sharpness. If you use the filter several times in a row, the effect will be 
strengthened.
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Sharpen increases the contrast between neighboring pixels, emphasizing the 
brightness difference. This will accentuate the outlines. The effect will be strengthened 
if you apply the filter several times in a row.

    

Remove noise compares every pixel with its neighbors and replaces the extreme 
values (those that deviate in color by a large amount from a mean value) by a pixel 
with a mean color value. The amount of picture information does not increase, but 
because there are fewer contrast changes our brains can better recognize the 
resulting graphic. This filter tends to make the picture a little smoother.

     

Solarization was originally a photochemical effect. If the location of a photograph is 
extremely highly lit, you can experience a reversal of color and brightness. Similarly, 
entry of light during the developing process reverses the brightness values. These 
phenomena were used for artistic production of pictures.

With this filter you input a threshold brightness value, above which the color values 
are reversed (middle picture, threshold value 70%). With the Invert option the whole of 
the resulting picture is inverted in color (right picture).

    

Aging lends pictures a certain “look” resembling that of old photos. The process first 
produces a grayscale picture from the original and then reduces the intensity of the 
blue and green color values, so that the final picture appears darker and redder. In the 
middle example, the aging degree was set to 0%, on the right it was set to 15%.

     

The graphic filter toolbar 13



Posterize reduces the number of colors in the picture. The fewer colors, the more flat 
the picture appears. In the right hand picture below the number of colors was reduced 
to 8. The results of this filter are not always good.

   

The Pop-Art filter is supposed to change the colors of the picture to a pop-art format, 
but unfortunately it does not seem to function correctly at present.

  

Charcoal sketch makes the picture appear as if it had been drawn with charcoal. The 
outlines are in black and the original colors are suppressed.

  

The Relief filter calculates the edges in relief of the picture and produces a picture as 
if illuminated by a light source, the position of the illuminating light being selectable 
and producing shadows that differ in direction and magnitude.
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Mosaic takes groups of pixels and converts them into a single color rectangular tile. 
The whole picture appears to be a mosaic. The center and right pictures below had an 
element resolution of 5 pixels. The picture on the right also had the Enhance edges 
option selected; with the greater contrast at the edges, it appears to be a little sharper.

    

Caution

If your picture is linked, filters are applied only to the current view. The stored 
picture is not changed. When you close the document, all filtering is lost. You 
should ensure that you export the picture to create a copy with all the filters applied 
(File > Export).

If you have embedded the graphic in the document, all filters are applied directly 
on the embedded graphic and cannot be undone in a subsequent session. If you 
do not want to retain a filter, you must use Edit > Undo to return to an earlier state 
of editing. After you save and close the document, the filter effects are permanent.

Changing colors using the Color Replacer

Use the Color Replacer to change one color in a picture for another or set the color as 
transparent. Up to four colors can be replaced at once. The tool always works on the entire picture; 
you cannot select only a single region for editing.

The changes are carried out on the graphic itself and therefore require it to be embedded. Attempts 
to use the Color Replacer tool on a linked graphic results in the following message: This graphic is  
linked to a document. Do you want to unlink the graphic is order to edit it?

The tool can be used on all bitmap graphic formats and with many—but not all—Metafile formats.

Practical example: Changing wrong colors to transparency
Some applications, which cannot correctly handle transparency, show transparent areas with the 
color Magenta and then store the graphic  with this color and without the correct transparency 
information.

   

Bitmap graphic with area in magenta, which actually should be shown 
transparent. On the left is the original picture, right is the picture after saving 
it with MS Paint.

If you receive such a picture, you can recreate the transparency with the Color Replacer tool.
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Open the Color Replacer dialog with Tools > 
Color Replacer and click on the picture to 
be edited.

Now click on the pipette icon  to activate 
the color selection mode. Once outside the 
dialog, the cursor changes to a hand. The 
field next to the icon shows the color 
immediately under the hand cursor.

Click on the color to be changed. The check 
box is now marked and the color selected 
appears in the Source color box. In the 
Replace with selection list, the option 
Transparent is already selected. Click on the 
Replace button at the top right of the box to 
carry out the changes to the picture.

There is no preview of the effect. If the result 
is not what you wanted, choose Edit > 
Undo.

The dialog does not close automatically, so you can carry out further color replacements. First 
mark the checkbox for the Source color and then choose the color with the eyedropper. Close the 
dialog with Esc or the Close icon on the window border. Draw uses a separate Alpha channel for 
transparency so that pixels of different colors can be made transparent.

It is also possible to carry out the operation in reverse to change a transparent area to a color. 
Select nothing in the graphic but choose the Transparency option at the lower left of the dialog and 
the replacement color at the lower right.

The selection list for replacement colors shows all the available colors in the current color palette of 
the document. You cannot define any new colors here but you can add colors to the available 
palette before using the Replace Color tool. For more on this topic, see Chapter 8, Tips and Tricks.
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Effect of the tolerance parameter
The tolerance parameter describes how closely a color value in the picture must agree with the 
source color in order to be replaced. In the figure below, the red color tone at the left edge of the 
rectangular color palette is used as the source color and a pure blue as the replacement color with 
several different tolerances. The original is a rectangle drawing with color gradient from red to 
green. Because the Replace Color tool is not usable on drawings, the rectangle on the left side is 
the drawing converted into a raster graphic (Convert > Bitmap). The picture was then exported in 
an Enhanced Metafile format and inserted on the right for comparison.

Note
As shown, the application of transparency and color replacement effects on raster 
graphics and Metafiles leads to quite different results. This is a known problem, which 
will be corrected in a future version.

Color depth
It is possible to reduce the color depth in LibreOffice. The tools are available but you must create a 
separate menu and add the tools to the menu if you wish to have them available. To create the 
menu, click on Tools > Customize, select the Toolbars tab, then New in the LibreOffice Draw 
Toolbars section. Name your menu in the dialog which opens and click OK. Click the Add button in 
the Toolbar Content section. Select Modify in the Category list; the commands are at the top of the 
Commands list. Select each command you want, and click Add to put them onto your menu.

Reducing color depth

Original with a 24 bit pixel depth (=8 bits per channel)

1 bit dithered

The impression of grayscale is produced by a raster. In 
reality there are only two colors.

Changing colors using the Color Replacer 17

Original

0% smallest value

99% largest value

80%

40%

20%



1 bit threshold

The threshold determines which pixels are black and 
which are white. You cannot set it directly but you can 
influence which part of the image is set to black by 
varying color settings on the picture toolbar—red, green, 
and blue levels, brightness, contrast, and/or gamma 
value—to see what works best for your image. You must 
export and save the modified image with File > Export 
and then reopen it, before you finally change the color 
depth.

4 bit color palette

With 4 bits a total of 16 colors can be produced. The color 
steps are quite fine, because the process does not use 
the 16 RGB basic colors, but selects from the palette 
those that best match the colors in the image.

4 bit grayscale palette

8 bit color palette

With 8 bits a total of 256 colors can be produced. The 
image at left is at first glance very difficult to distinguish 
from the original. A big difference is that the picture file is 
only one third of the size of the 24 bit version.

8 bit grayscale palette
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Conversion

Convert to a contoured image
Select the picture so you see the green handles. From the context menu or from the Modify menu 
choose Convert > to Contour. This command creates from the original image a polygon or group 
of polygons, with four corner points and the image set as a background graphic. In this state you 
are not able to further edit the graphic. All your modifications must be completed before this point.

The polygon is in fact a vector graphic but the picture remains as a bitmap image. Using a polygon 
offers possibilities for further change; for example, you can modify the shape or define a 
transparency gradient.

Convert to a polygon
Select the picture so you see the green handles. From the context menu or from the Modify menu, 
choose Convert > to Polygon. This command converts areas of the same color into small filled 
polygons. The total image becomes a vector graphic and can be resized with no loss of image 
quality or distortion of text. The resulting format will be a Metafile.

Figure 10: Conversion of a picture to polygons

The Convert to Polygon dialog has a number of settings which can be tested using the Preview 
button. Because graphics conversion can take some time, depending on the picture and the 
computer, a progress bar is included at the bottom of the dialog.

Number of colors
Draw considers between 8 and 32 colors in the conversion. The picture can, however, contain 
fewer colors than 8. For every color occurring in the picture, Draw creates a polygon, which may 
consist of several disconnected parts. These polygons are then filled with the relevant color.
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The algorithm used to reduce the number of colors in the picture to the number specified is not yet 
optimal. For this reason you may prefer to try reducing the number of colors by changing the color 
depth or with the Posterize filter (page 14) from the Graphic Filter toolbar (page 12).

Point reduction
Polygons will only be created if they have a size greater than the value given in this setting. The 
section of the picture below, highly magnified, shows that with a larger point count small flecks of 
color—typical of irregular color patterns—simply disappear.

2 Pixel 3 Pixel 

Fill holes
Point reduction can result in small areas or “holes” which are not covered by a polygon. If the Fill 
holes option is marked, additional square, tiled areas are created with a background color the 
same as the hole. The Tile size option allows the width in pixels of the width of these square areas 
to be preset.

Original picture Original picture with 16 colors and 0 Pixel point 
reduction vectorized

Original picture transformed with the 
Poster filter and 64 colors …

… and then with 16 colors and 0 pixel point reduction 
vectorized.
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Here the picture is transformed with the 
Poster filter, but this time with a point 
reduction of 4 pixels and a tile size of 
16 pixels.

The effect below was generated from the picture to the 
left (posterized and vectorized); the polygons were 
split with Modify > Break, and a number (in this case 
6) of the (foreground) polygons were deleted until the 
resulting background was achieved.

Note: To select polygons for deletion, click on a curved 
colored area (the text in the status bar shows “Polygon 
nnn corners selected”, where nnn is the number of 
corners of the polygon) and a frame with green 
handles encloses the area of the polygons selected. 
Press Delete to delete the polygons. Repeat until you 
have achieved the desired effect, (which here is to 
have only the background showing).

If you next ‘split’ the existing Metafile (Modify > Split), access is gained to individual polygons. To 
be able to operate on these together you should immediately group them after splitting.

With this vectorized form of the image, you can carry out operations familiar from classic drawing 
programs, for example a curved warping operation. For such transformations, it is much less effort 
to use a conversion with background tiles so that the edges of the picture are straight.

Using the graphic generated in the posterize and vectorize process above, Break and Split it, and 
then try out some operations using the tools on the Effects toolbar.
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To use this tool to vectorize the first letter of a chapter in a special font,  convert the graphic to a 
polygon, using no point reduction or background tiling. Use Modify > Break to generate two 
polygons. An example is shown below.

 

Original polygon, converted from a Metafile. Break the 
graphic into two polygons.

After the conversion there are two polygons, one with the 
visible letter and another polygon, not visible because the 
lines and area filling are all in white. You can select this 
“invisible” polygon by pressing the Tab key(click on the 
visible letter first, then press Tab; this moves the current 
selection to the next object). In the example at the left, 
the invisible polygon has been moved to the side. If you 
have Display Grid active and the grid points set to display 
behind objects, you can see where this invisible polygon 
is, since it obscures the grid points behind it. 

This invisible polygon encloses the letter. After changing 
lines and/or area to a different color, the polygon 
becomes visible.

Convert to bitmap
All drawing objects are vector graphics. Use the command Convert > To Bitmap from the context 
menu to convert a vector graphic to a raster graphic. Draw creates the raster graphic in PNG 
format with a color depth of 24 bits. Unfortunately any transparency effects which were created in 
the vector graphic are lost in this conversion, although the PNG format used in Draw does support 
transparency. Only if you use the Replace Color tool to set transparency will an Alpha channel also 
be produced.

To determine the height and width of the converted graphic (number of pixels), Draw considers the 
dpi setting of the operating system for the screen and the percentage scaling factor set under 
Tools > Options > LibreOffice > View in the section User Interface.

Example:

Width of vector graphic: 1.5 inch
Monitor setting of operating system: 96 dpi ( = 96 dots per inch)
Scaling 130 %

Calculation: 1.5 inch x 96 dpi *130% = 187 pixels

The actual number of pixels will vary somewhat from this value due to rounding. When the format 
permits, Draw uses a dpi value (in this case 125 dpi) which permits the calculation to be reversed 
and the picture with this pixel value reproduced with the correct width of 1.5 inch.
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Print options with raster graphics

If you have only a black and white printer or are experiencing problems with printing, you should 
have a look at the following settings.

You can set up printing so that all text and all graphics are printed in grayscale or black and white. 
The general settings are in Tools > Options > LibreOffice Draw > Print in the section Quality 
(see Figure 11). To set these for the current document only, use Options in the Print dialog (File > 
Print). With both Black/white printing and Grayscale printing, no background is printed.

Figure 11: Options - LibreOffice Draw - Print

Other options are in Tools > Options > LibreOffice > Print (see Figure 12). They relate to page 
options (scaling) and other printing variables. They affect the size of the print file and the time 
taken to print the document. With most modern systems you can simply accept the defaults. As 
different operating systems and printers have their own requirements, you need to tailor the 
settings to your particular site conditions. Refer to the Help file for more information.

Figure 12: Options - LibreOffice - Print dialog
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