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detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection
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Control+click or right-click
depending on system setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5
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Connectors and glue points
Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This
section describes them in more detail and how to use them.
Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an
object. Connectors are useful when drawing, for example, flowcharts and organization charts. The
connecting lines between objects remain intact even when objects are moved or rearranged. Also, if
you copy an object with a connector, the connector is also copied.

Connectors
Draw has a comprehensive selection of connectors on a Connectors toolbar (Figure 1) to help you
connect objects in, for example, a flowchart or organization chart. To open this toolbar, click the
small triangle to the right of the Connector icon
on the Drawing toolbar. Note that this icon
changes shape depending on the last connector tool used.
The Connector toolbar shown in Figure 1 displays a default set of connectors. If the connector you
want to use is not displayed, then use one of the following methods to select the connector you
want to use.

• Click on the small triangle on the right of the title bar and select your connector from the
drop down list.

• Right click in a blank area on the toolbar and select Visible Buttons from the context
menu. Click the connector you want to use and it is added to the Connectors toolbar.

Figure 1: Connector toolbar

Note

This toolbar can become a floating toolbar by clicking on the bottom of the pop-up
toolbar and dragging it into your workspace.

Types of connectors
Connectors fall into four type groups:

• Standard connectors (Figure 2) – the line segments run vertically and horizontally. Draws a
connector with one or more 90-degree angle bends. Click on an object glue point on an
object, drag to a glue point on another object, then release.

Figure 2: Standard connectors
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• Line connectors (Figure 3) – consist of a line segment with two smaller segments at the

ends. Draws a connector that bends near a glue point. Click on an object glue point, drag
to a glue point on another object, then release. To adjust the length of the line segment
between a bend point and a glue point, click the connector and drag the bend point.

Figure 3: Line connectors

• Straight connectors (Figure 4) – consist of a single line. Draws a straight line connector.
Click on an object glue point, drag to a glue point on another object, then release.

Figure 4: Straight connectors

• Curved connectors (Figure 5) – are based on Bézier curves and curve around objects.
Draws a curved line connector. Click on an object glue point, drag to a glue point on
another object, then release.

Figure 5: Curved connectors

Adding connectors
When you select a connector and move the mouse pointer over a filled object or the edge of an
unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector
line. You can also add custom glue points to an object, see “Glue points” on page 7 for more
information.
To draw a connector, select the connector type and click on a glue point on an object. Drag the
cursor to a glue point on another object and then release. Figure 6 shows a line connector drawn
between two objects. Remember not to drag the connector so that it overlaps or touches any
objects and creates a confusing drawing. If this does happen, see “Modifying connectors” below on
how to change the connector route to avoid any objects the connector crosses over.
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Figure 6: Connector between two objects
You can also drag a connector to an empty part of your document. When you release the mouse
button, the unattached end of the connector is locked into place until you drag the end to a different
location.

Modifying connectors
To detach or reposition a connector, click and drag either end of the connector line to a different
location.
To change the connector route between objects avoiding any objects on the route, click on a
control point on the connector line and drag it to a new position. In Figure 6, the control points are
shown as small red squares at the point where the connector changes direction.
To modify a connector, right-click on the connector and select Connector from the context menu to
open the Connector dialog (Figure 7). Use this dialog to change connector type and its properties.

• Line skew – defines the skew of the line and the dialog preview displays the result.
• Line spacing – sets the spacing for the connectors.
– Begin horizontal – enter the amount of horizontal space you want at the beginning of
the connector.

–

Begin vertical – enter the amount of vertical space you want at the beginning of the
connector.

–

End horizontal – enter the amount of horizontal space you want at the end of the
connector.

–

End vertical – enter the amount of vertical space you want at the end of the connector.

Figure 7: Connector dialog
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Note

You cannot swap the ends of the connector using this dialog, that is start point
becomes the end point and the end point becomes the start point. To swap the
ends of a connector, you have to draw a new connector.

Glue points
Glue points are not the same as the selection handles of an object. The selection handles are for
moving or changing the shape of an object; see Chapter 3 Working with Objects and Object Points
for more information. Glue points are used to fix or glue a connector to an object so that when the
object moves, the connector stays fixed to that object.
All Draw objects have glue points, which normally are not displayed and only become visible when
the Connectors icon
on the Drawing toolbar is selected. Note that the Connectors icon
changes shape depending on the last connector tool used.
To add, customize or delete glue points to an object, go to View > Toolbars > Gluepoints on the
main menu bar to open the Gluepoints toolbar (Figure 8). This toolbar only becomes active after
you click on the Glue Points icon
on the Drawing toolbar or select Edit > Glue Points on the
main menu bar, or right click on a selected connector and select Edit Points from the context
menu.

Figure 8: Gluepoints toolbar

Types of glue points
When the Gluepoints toolbar opens, only the six tools on the left of the toolbar are active. The
remaining six tools on the right of the toolbar only become active when the Glue Point Relative
icon is deselected.
With reference to Figure 8, the following briefly describes the function of each tool on the Gluepoint
toolbar.

• Insert Glue Point – inserts a glue point where you click in an object.
• Exit Direction Left – connector attaches to the left edge of the selected glue point.

Connectors and glue points
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•
•
•
•

Exit Direction Top – connector attaches to the top edge of the selected glue point.
Exit Direction Right – connector attaches to the right edge of the selected glue point.
Exit Direction Bottom – connector attaches to the bottom edge of the selected glue point.
Glue Point Relative – maintains the relative position of a selected glue point when you
resize an object. This tool is selected by default when the Gluepoint toolbar opens. The
following six tools only become active when this tool is deselected.

• Glue Point Horizontal Left – when the object is resized, the current glue point remains
fixed to the left edge of the object.

• Glue Point Horizontal Center – when the object is resized, the current glue point remains
fixed to the center of the object.

• Glue Point Horizontal Right – when the object is resized, the current glue point remains
fixed to the right edge of the object.

• Glue Point Vertical Top – when the object is resized, the current glue point remains fixed
to the top edge of the object.

• Glue Point Vertical Center – when the object is resized, the current glue point remains
fixed to the vertical center of the object.

• Glue Point Vertical Bottom – when the object is resized, the current glue point remains
fixed to the bottom edge of the object.

Note

Each glue point you have added can have only one horizontal position and one
vertical position. Only one of the horizontal position tools and one of the vertical
position tools can be selected and used at any one time.

Adding glue points
By default, most objects normally have four glue points. To add extra glue points to an object or to
an object that does not have glue points, proceed as follows:
1) Make sure no objects are selected and click on the Glue Points icon
or select Edit >
Glue Points on the main menu bar, or right click on a selected connector and select Edit
Points from the context menu.
2) If the Gluepoints toolbar (Figure 8 on page 7) does not open, go to View > Toolbars >
Gluepoints on the main menu bar.
3) Select the object and then the Insert Glue Point icon
, or right click on a glue point you
have previously inserted and select Insert Point from the context menu.
4) Move your cursor to a position where you want the glue point on an object and click to
insert the glue point.
5) To move a glue point to another position, click on the glue point and drag it to its new
position.

Tip

When adding, moving or customizing glue points, it is recommended to use the
zoom function to make it easier to work with glue points. See Chapter 3 Working
with Objects and Object Points for more information.

Customizing glue points
Only glue points that have added to an object can be customized. The default glue points included
with an object cannot be customized.

Connectors and glue points
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1) Make sure no objects are selected and click on the Glue Points icon
or select Edit >
Glue Points on the main menu bar, or right click on a selected connector and select Edit
Points from the context menu.
2) If the Gluepoints toolbar (Figure 8 on page 7) does not open, go to View > Toolbars >
Gluepoints on the main menu bar.
3) Make sure the object is not selected and double-click on a glue point that you have added
to select the glue point.
4) Select the exit directions you want to use for connectors and double-click again on the glue
point to customize the glue point.
5) To use horizontal and vertical positioning, click on the Glue Point Relative icon or rightclick on the glue point and select Adapt Position to Object from the context menu to
deselect this tool.
6) Select the horizontal and vertical positioning tools you want to use and double-click on the
glue point to customize the glue point. Only one horizontal positioning tool and one vertical
positioning tool can be used at any one time.

Deleting glue points
Only glue points that have added to an object can be deleted. The default glue points included with
an object cannot be deleted.
1) Make sure no objects are selected and click on the Glue Points icon
or select Edit >
Glue Points on the main menu bar.
2) Make sure the object is not selected and double-click on a glue point that you have added
to select the glue point.
3) Right-click on the glue point and select Cut from the context menu, or press the Delete key
on the keyboard, or go to Edit > Cut on the main menu bar.

Connector text
Text can be easily added to connectors, then formatted or edited to make, for example, your
flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter
9 Adding and Formatting Text for more information on working with text.

Adding text
1) Select the connector.and the control points become active.
2) Click on the Text icon
or Text Vertical icon
on the Drawing toolbar and a flashing
text cursor appears close to the connector. The Text Formatting toolbar replaces the Line
and Filling toolbar.
3) Use the Text Formatting toolbar or Format and Tools on the main menu bar to change the
default format of the text.
4) Type the text and, when you have finished typing the text and using the text tools, move the
cursor away from the objects and connector and click to end the text mode. The Line and
Filling toolbar then replaces the Text Formatting toolbar.

Formatting and editing text
1) Click on the connector text to enter text editing mode. The Text Formatting toolbar replaces
the Line and Filling toolbar under the menu bar.

Connectors and glue points
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Figure 9: Text dialog
2) Perform any changes to the text using the text tools provided on the Text Formatting
toolbar or Format and Tools on the main menu bar. You can also right-click on the text and
select text tools from the context menu.
3) Right-click on the connector text and select Text from the context menu or go to Format >
Text to open the Text dialog (Figure 9) where you can change the Text anchor and
Spacing to borders.

Note

A connector has an invisible rectangle around it. Text anchor will position the text
within this invisible rectangle and Spacing to borders will create margins between
the text and the borders. These options are in addition to the standard text tools.

4) Click on the Text Animation tab where you can animate the text. However, this is not
recommended unless you are going to display the drawing as part of a presentation. See
the Impress Guide for more information on text animation.
5) When you have finished formatting and editing your text, move the cursor away from the
objects and connector and click to end the text mode. The Line and Filling toolbar then
replaces the Text Formatting toolbar.

Flowcharts
For drawing flowcharts (also known as flow diagrams), Draw has a Flowchart toolbar that includes
a large selection of flowchart tools to help you to easily draw a flowchart.(Figure 10). Click on the
small triangle to the right of the Flowchart icon
on the Drawing toolbar to open the Flowchart
pop up toolbar. Note that this icon changes shape depending on the last flowchart tool used.

Note

Flowcharts

This toolbar can become a floating toolbar by clicking on the bottom of the pop-up
toolbar and dragging it into your workspace.
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Figure 10: Flowchart toolbar
1) When adding objects to your flowchart, see Chapter 2 Drawing Basic Shapes for
information on how to draw and resize object shapes.
2) Add text to each flowchart shape to make it easily identified in the flowchart. See Chapter 2
Drawing Basic Shapes and Chapter 11 Advanced Draw Techniques for more information.
3) Use connections lines in your flowchart. This allows repositioning of an object in your chart
while maintaining connections with the other objects in the chart. See “Connectors” on
page 4 for more information.
4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See
Chapter 3 Working with Objects and Object Points for more information.

Flowcharts
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5) Use the alignment and distribution functions to give your flowchart a more professional
look. See Chapter 5 Combining Multiple Objects for more information.
6) Duplicate objects when you require more than one of the same shape and size. See
Chapter 5 Combining Multiple Objects for more information.

Organization charts
Draw does not have a toolbar for organization charts, but these charts are easily created using
basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an
organization is easily indicated using shading and/or color. When using shading and color in an
organization chart, make sure that your selection provides a good contrast between the text and
the shading or color to make the chart easy to read on a computer display or in a printed
document.
An example of an organization chart is shown in Figure 11. This was drawn using the process
shape from the Flowchart toolbar and connection lines.
1) When adding objects to your chart, see Chapter 2 Drawing Basic Shapes for information on
how to draw and resize object shapes.
2) Add text to each object in the organization chart to make it easily identified in the chart. See
Chapter 2 Drawing Basic Shapes and Chapter 11 Advanced Draw Techniques for mare
information.
3) Use connections lines in your organization chart. This allows repositioning of an object in
your chart while maintaining connections with the other objects in the chart. See
“Connectors” on page 4 for more information.
4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See
Chapter 3 Working with Objects and Object Points for more information.
5) Use the alignment and distribution functions to give your organization chart a more
professional look. See Chapter 5 Combining Multiple Objects for more information.
6) Duplicate objects when you require more than one of the same shape and size. See
Chapter 5 Combining Multiple Objects for more information.

Figure 11: Example organization chart
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