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Designing a presentation

In addition to careful planning of the content, as discussed in Chapter 1 Introducing Impress, you 
need to plan the appearance of the presentation. It is best to do this after you have developed an 
outline, because the outline will determine some of the requirements for the appearance of the 
slides. For example:

• What color combinations (background and text) will look good and also be easy for your 
audience to read?

• Would a picture help your audience understand the contents better?

• Do you want particular text and a picture to appear on all the slides? For example a 
company name and logo.

• Would the audience benefit from having the slides numbered so that they can quickly refer 
to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that does
not interfere or clash with content such as the colors used in charts.

• Will you need one slide master or more than one? Will one slide design suit all of the 
content?

You can change the appearance of slides as you develop the presentation, but planning ahead will 
save you time in the long run.

What are slide masters?

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style
in Writer: it controls the basic formatting of all slides based on it. A slide presentation can have 
more than one slide master.

Note
LibreOffice uses three terms for one concept: slide master, master slide, and master 
page. All refer to a slide which is used to create other slides. This book uses the term
slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers 
and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you 
create are inherited from the slide master from which it was created. In other words, the styles of 
the slide master are available and applied to all slides created from that slide master. Changing a 
style in a slide master results in changes to all the slides based on that slide master. It is, however, 
possible to modify each individual slide without affecting the slide master.

Note
Although it is highly recommended to use the slide masters whenever possible, there
are occasions where manual changes are needed for a particular slide, for example 
to enlarge the chart area when the text and chart layout is used. 

Slide masters have two types of styles associated with them: presentation styles and image styles. 
The prepackaged presentation styles can be modified, but new presentation styles cannot be 
created. For image styles, you can modify the prepackaged styles and also create new styles.

Presentation styles are discussed in detail in Chapter 3 Adding & Formatting Text. The use of 
image styles is covered in Chapter 6 Formatting Graphic Objects. See also “Working with styles in 
Impress” on page 17.
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Working with slide masters

Impress comes with a collection of slide masters. These slide masters are shown in the Master 
Pages section of the Sidebar (Figure 1). This section has three subsections: Used in This 
Presentation, Recently Used, and Available for Use. Click the expand marker next to the name of a
subsection to expand it and show thumbnails of the slides, or click the collapse marker to collapse 
the subsection to hide the thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same name. 
If you have created your own templates, or added templates from other sources, slide masters 
from those templates will also appear in this list. See “Working with templates” on page 17 for more
information about templates.

Figure 1: Sidebar Master Pages section

Creating slide masters
You can create a new slide master which is similar to modifying the default slide master.

1) Enable editing of slide masters by selecting View > Master > Slide Master on the main 
menu bar and the Master View toolbar opens (Figure 2). If the Master View toolbar does 
not appear, go to View > Toolbars and select Master View.

2) Alternatively, right-click on a slide master you want to use in the Master Pages section of 
the Sidebar that and select Edit Master from the context menu to open the Master View 
toolbar.

3) On the Master View toolbar, click the New Master icon .

4) A new slide master appears in the Slides pane. Modify this slide master to suit your 
requirements.
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Figure 2: Master View toolbar

5) It is recommended that you rename this new slide master. Right-click on the slide in the 
Slides pane and select Rename master from the context menu.

6) When finished creating a slide master, click Close Master View on the Master View toolbar
and return to normal slide editing mode.

Applying a slide master
To apply a slide master to all the slides in your presentation:

1) In the Sidebar, click on the Master Pages icon  to open the Master Pages section 
(Figure 1).

2) To apply one of the slide masters to all slides in your presentation, right-click on the slide 
master you want to use and select Apply to All Slides on the context menu.

To apply a different slide master to one or more selected slides:

1) In the Sidebar, click on the Master Pages icon  to open the Master Pages section 
(Figure 1).

2) In the Slide Pane, select the slide or slides where you want to use a new slide master.

3) In the Sidebar, right-click on the slide master you want to apply to the selected slides and 
select Apply to Selected Slides on the context menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong 
to different templates (the use of templates is explained in “Working with templates” on page 17). 
For example, you may need a completely different layout for the first slide of the presentation, or 
you may want to add a slide from a different presentation to your current presentation.

1) Go to Format > Slide Design on the main menu bar or right-click on a slide in the Slides 
Pane and select Slide Design from the context menu to open the Slide Design dialog 
(Figure 3). This dialog shows the slide masters already available for use.

2) To add more slide masters, click Load to open the Load Slide Design dialog (Figure 4).

3) Select in the Load Slide Design dialog the template from which to load the slide master and
click OK.

4) Click OK again to close the Slide Design dialog.

5) The slide masters in the template you selected are now shown in the Available for use 
subsection of Master Pages.

Note

The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog. If the slide master was not used in the 
presentation, it is removed from the list of available slide masters.
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Figure 3: Slide Design dialog

Figure 4: Load Slide Design dialog

Tip
To limit the size of the presentation file, you may want to minimize the number of 
slide masters used.

Modifying slide masters
The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, adding a logo or decorative graphics)

• Text attributes for the main text area and notes

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

To select the slide master for modification:

1) Select View > Master > Slide Master from the main menu bar. This opens the master view
and unlocks the properties of a slide master.

2) Select a slide master you want to modify in the Slide Pane
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Figure 5: Example master view

3) Right-click in the Workspace on your selected slide master that you want to modify so you 
can edit the slide master (Figure 5).

4) Select an object on the slide master, then right-click on the object and make any necessary
changes using the options available in the context menu that opens. Selecting one of the 
options in the context menu may open a dialog where you can make the necessary 
changes to your selected object.

5) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar to exit from editing slide masters.

6) Save your presentation file before continuing.

Note
Any changes made to one slide when in Master View mode will appear on all slides 
using this slide master. Always make sure you close Master View and return to 
Normal view before working on any of the presentation slides.

The changes made to one of the slides in Normal view (for example, changes to the bullet point 
style, the color of the title area, and so on) will not be overridden by subsequent changes to the 
slide master. There are cases, however, where it is desirable to revert a manually modified object 
of the slide to the style defined in the slide master: to do that, select that object and choose Format
> Default Formatting from the main menu bar, or right-click on an object and select Default from 
the context menu.

Sometimes, depending on the contents of the slide, you may want to apply a different layout. The 
title and text boxes will inherit the properties of the slide master, but if you have changed the 
position of these text boxes in the slide master, the layout may appear corrupted and you may 
need to re-position some of the layout elements manually.

Selecting and applying backgrounds
Backgrounds can be applied to a number of elements in Impress: a slide, a default text area, an 
image and so on. The procedures to apply a background are always the same and the following 
procedure is used to apply a background to the slide.

1) Select Format > Page on the main menu bar, or right-click on the slide and select Slide 
>Page Setup from the context menu to open the Page Setup dialog.
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Figure 6: Background types in Page Setup dialog

Figure 7: Presentation Styles

2) Select the Background tab and then type of Fill from the drop down list (Figure 8). The 
options available for backgrounds will depend on the fill type selected.

3) Alternatively, select Format > Styles and Formatting from the main menu bar, or press 

F11, or click the Styles and Formatting icon  on the Line and Filling toolbar to open the
Styles and Formatting dialog (Figure 7). Alternatively, click on the Styles and Formatting 

icon  on the Sidebar to open the Styles and Formatting section.

4) Select the Presentation Styles icon  and right-click Background style and select Modify 
from the context menu. This opens the Background dialog, which has one tab (Area) and 
offers the same options as the Background tab in the Page Setup dialog.

5) Select the type of fill you want for your background from the five options in the drop-down 
menu: None, Color, Gradient, Hatching, or Bitmap. A list of options for the selected fill type 
then appears. Figure 8 shows the options available if you select a bitmap for your 
background.

6) Select one of the options on the Fill list and click OK. The option you have selected is 
added to the slide master, replacing any previously selected fill.

Tip

You can make custom additions to each type of background, with the obvious 
exception of None. After you create new fills, they are listed in the Background dialog
along with the fills provided with LibreOffice, see Chapter 6 Formatting Graphic 
Objects for more information.
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Figure 8: Selecting a bitmap background in the Background dialog

Adding image objects
When you want the same image to appear on every slide of your presentation, the easiest and 
quickest solution is to use the slide master. It saves time while creating the presentation and when 
you want to modify or reposition the image on all the slides. If the same image is added to each 
slide manually, these operations have to be performed on each individual slide in the presentation. 
LibreOffice supports a large number of image formats.

For example, one of the most common actions in preparing a presentation is to add an image to 
the slide master. To insert an image already available on the computer, follow these steps:

1) Select View > Master > Slide Master on the main menu bar to open the master view.

2) Select the slide master where you want to add an image.

3) Select Insert > Image > From File on the main menu bar to open the file browser.

4) Navigate to the directory where your image is located and select it. If you want to see a 
preview, select the Preview checkbox in the file browser dialog.

5) Click Open and the image is placed into your slide.

Once the image is inserted onto your slide, you have to move it to the background so that any 
information you add to the slide when creating a presentation appears over the background image.

1) With the image selected, right-click on the image and select Arrange > Send to Back from
the context menu.

2) If necessary, reposition the image and modify its size. See Chapter 4 Adding and 
Formatting Images for more information.

In addition to images you can add a number of other objects in the background, for example 
decorative lines, text, and shapes.
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Note

LibreOffice offers the option to insert an image as a link to the file rather than 
embedding it in your presentation. This can be useful when a presentation is not 
intended for distribution onto other computers, but where it will remain in the same 
computer and directory structure. For example, it could be created on a notebook 
computer, which is to be used to give the presentation to a group of clients.

However, if the presentation file is to be distributed onto other computers, the image 
must be embedded to avoid the “missing image” syndrome when the presentation is 
given using a different computer.

Tip

If you want the image to blend with the background, you can set the background color 
of the image as transparent. Select the image, then go to Tools > Color Replacer on 
the main menu bar. Select the first checkbox, move the mouse cursor onto the picture 
and click on the color you want to make transparent. This color appears next to the 
checkbox. Make sure that Replace with... is set to Transparent and click Replace.

Tip

An easy way to make the image lighter so that the text stands out better against its 
background, is to increase the transparency of the image or change the gamma 
luminance of the image. Both these adjustments can be quickly made from the Picture
toolbar.

Slide master styles
Within the slide master you can define a complete set of styles for the default appearance of text 
and images inserted in slides based on that background. If for example your slide master has a 
dark background, you may want to set the font color of the title and text areas to be light. Rather 
than manually changing the font color for every new slide you create, a time-consuming operation 
prone to errors and omissions, simply modify the style in the slide master. Changes made to styles 
in the slide master only apply to the slides based on that particular slide master.

Styles in Impress are sub-divided into two main categories: presentation styles and image styles.

Figure 9: Image styles

To work on the slide master styles,  press F11, or select Format > Styles and Formatting from the

main menu, or click the Styles and Formatting icon  on the Line and Filling toolbar to open the
Styles and Formatting dialog (Figure 7 on page 9 for Presentation styles and Figure 9 for Image 
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styles). Alternatively, click on the Styles and Formatting icon  on the Sidebar to open the Styles 
and Formatting section.

Presentation styles
Presentation styles (Figure 7) affect three elements of a slide master: the background, background 
objects (such as icons, decorative lines, and text frames), and the text placed on the slide. Text 
styles are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline 
styles are used for the different levels of the outline to which they belong. For example, Outline 2 is
used for the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.

The presentation styles can be modified, but new presentation styles cannot be created.

Image styles
Image styles (Figure 9) apply to lines, shapes and text boxes created using the Impress drawing 
tools and define the formatting of such objects. You can create additional styles or modify the 
included styles.

Note

The presence of text and title styles both in the Presentation and Image styles may 
seem confusing. This apparent duplication is because Impress uses special text 
boxes when adding structured text to slides where Presentation styles apply 
(AutoLayout boxes). The title and other text styles in Image styles continue to apply to 
other text boxes you may want to add, or to text associated with shapes or lines.

Tip
At the bottom of the Styles and Formatting dialog is a drop-down list where you can 
choose to show either Hierarchical, All Styles, Hidden Styles, Applied Styles or 
Custom Styles.

Modifying default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 5 on page 8.

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area

Position and size
Click with the left mouse button on any of these areas to display the selection handles around the 
rectangle. Use these handles to modify the size and position of the area.

• To change the position, move the mouse towards one of the edges, not on a selection 
handle, and click the left mouse button. The cursor changes shape which is dependent on 
your computer setup (normally a clenched hand).

• To modify the shape and size of one of the rectangular areas, use one of the selection 
handles. The corner handles modify the height and width of the rectangle simultaneously 
while the side handles modify only one dimension at a time. The shape of the mouse cursor
usually changes shape when over a handle, giving a clear visual indication of how it will 
affect the shape of the rectangular area.
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Tip

To keep the shape of the rectangular area constant, move the mouse to one of the 
four corner handles and keep the Shift key pressed while dragging the handle with 
the mouse. The rectangle maintains the ratio between the width and height 
dimensions of the rectangle.

To accurately control the shape and size as well as the position of the default text area, it is better 
to use the Position and Size dialog than the mouse.

1) Select the rectangular area by clicking on the border.

2) Press F4, or go to Format > Position and Size on the main menu bar, or right-click on the 
border and select Position and Size from the context menu to open the Position and Size 
dialog (Figure 10).

3) Alternatively, click on the Properties icon  on the Sidebar and open the Position and 
Size subsection.

Note
Clicking on the More Options icon on the Position and Size subsection on the 
Sidebar will open the Position and Size dialog.

Figure 10: Position and Size dialog

The functions of the Position and Size dialog are explained in the Draw Guide, so only short 
descriptions of the most important fields are provided in this chapter.

• Use the Position section to specify the X (horizontal) and Y (vertical) position of the 
rectangular area. The values represent the distance of the selected base point and the 
default position is the top left corner of the slide.

• Use the Size section to specify the width and height of the rectangular area. In the Base 
point section, select a point on the rectangular area that you do not want to move while 
resizing. The default setting of top left corner means that the position of the top left corner 
of the area will not change after resizing.

Working with slide masters 13



• Use the Rotation page of the dialog to rotate the default text area. For example, you can 
place the footer area on the side by rotating each text area by 90 degrees and obtain a 
more modern-looking layout. In general it is preferable to use only right angles for ease of 
editing, although the program does not impose restrictions on the values that can be used.

Background, border, arrangement and alignment
Besides the shape, size and position, it is also possible to modify other aspects of the editable 
areas on the slide master, such as the background, border, alignment relative to the slide, and 
position relative to other objects.

• To edit the background of an object, go to Format > Area on the main menu bar, or right-
click on the object and select Area from the context menu. This opens the Area dialog 
where you can change the type of fill used for object backgrounds. Alternatively, click on 

the Properties icon  on the Sidebar and open the Area subsection. See Chapter 6 
Formatting Graphic Objects for more information.

• To edit the borders of an object, go to Format > Line on the main menu bar, or right-click 
on the object and select Line from the context menu. This opens the Line dialog where you
can change the type and color of the line used for object borders. Alternatively, click on the 

Properties icon  on the Sidebar and open the Line subsection. See Chapter 6 
Formatting Graphic Objects for more information.

• To change the alignment of an object on a slide or the alignment between two or more 
objects, right-click on the object and select Alignment then the type of alignment from the 

context menu, or click on the small triangle to the right of the Alignment icon  on the 
Line and Filling toolbar and select the type of alignment from the options available. See 
Chapter 5 Managing Graphic Objects for more information.

• To arrange the position of an object on a slide in relation to other objects on a slide, right-
click on the object and select Arrange then the object position from the context menu, or 

click on the small triangle to the right of the Arrange icon  on the Line and Filling 
toolbar and select the object position from the options available. See Chapter 5 Managing 
Graphic Objects for more information.

Adding text and fields to all slides
Adding text and fields to a master slide allows you to place information that you want to appear on 
all the slides in your presentation, for example presentation title, company, date and slide number.

Text
Text objects can be placed anywhere on the master page so that it appears on every slide in your 
presentation. Text objects can also be placed in the footer if you do not want to use the footer 
default fields in your presentation.

1) Select View > Master > Slide Master from the main menu bar to open Master View.

2) To add text to the main area of the slide, select the Text icon  on the Drawing toolbar, or 
press the F2 key.

3) Click once in the master page and drag to draw a text object, then type or paste your text 
into the text object.

4) To add text to the slide footer, click in one of the footer areas of the slide and highlight the 
text field, then type of paste your text into the footer area.
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5) To format the text after placing it on your master page, see Chapter 3 Adding and 
Formatting Text for more information.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar when you are finished.

Footer default fields
By default, the footer used in an Impress slide consists of three sections with each section 
containing a default field as follows:

• Left section – date and time. The field name is <date>.

• Center section – footer text, for example this could be the presentation title, file name and 
so on. The field name is <text>.

• Right section – slide (page) number. The field name is <number>.

Figure 11: Date and Time dialog

The default footer fields are set up as follows:

1) Select View > Master > Slide Master from the main menu bar to open Master View.

2) Go to Insert > Page Number or Date and Time to open the Date and Time dialog (Figure 
11) and make sure the Slides tab is selected.

3) For a fixed Date and time in the left section of the footer, select Fixed and enter the date 
you want to use in the text box.

4) For a variable Date and time in the left section of the footer, select Variable, then select 
the Format and Language from the drop down lists that you want to use. Using a variable 
date and time means that each time the file is opened, the date and time are updated.

5) To place text in the center section of the footer, select Footer and then type or paste your 
text into the Footer text box.

6) To place the slide number in the right section section of the footer, select Slide number.

7) If you do not want the footer to appear on the first slide of your presentation, then select Do
not show on the first slide. The first slide is normally the title slide of your presentation.

8) Click Apply to All to close the dialog.
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9) To format the text used for the default fields, see Chapter 3 Adding and Formatting Text for 
more information.

10) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar when you are finished.

Note

The default fields in the footer can be replaced with text or manual fields. For more 
information, see “Text” on page 14 and “Manual fields” on page 16. These default 
sections in a footer can also be formatted, resized and repositioned. See “Modifying 
default text areas” on page 12 for more information.

Manual fields
Manual fields, for example date or page number (slide number), can be added as text objects on a 
slide master or replace one of the default footer fields. The fields you can use in Impress are:

• Date (fixed)

• Date (variable): updates automatically when you reload the file

• Time (fixed)

• Time (variable): updates automatically when you reload the file

• Author: first and last names listed in the LibreOffice user data

• Page number (slide number)

• File name

To place a field on your slide master:

1) Select View > Master > Slide Master from the main menu bar to open Master View.

2) Click anywhere on the slide master.

3) Go to Insert > Fields on the main menu bar and select the required field from the 
submenu.

4) By default the field is placed in the center of the slide master. Reposition the field text box 
to the desired position on your slide master.

5) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more 
information.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar when you are finished.

To replace a default field in the footer on your slide master:

1) Select View > Master > Slide Master from the main menu bar to open Master View.

2) Highlight all of the characters used in the default field you want to replace in the footer.

3) Go to Insert > Fields on the main menu bar and select the required field from the 
submenu.

4) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more 
information.

5) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar when you are finished.

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the slide number, go to 
Format > Page on the main menu bar and select a format from the list in the Layout 
Settings area.

To change the author information, go to Tools > Options > LibreOffice > User Data 
on the main menu bar.
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Working with styles in Impress

If you are familiar with styles in Writer, you will find both similarities and differences in Impress. The
presentation styles are comparable to paragraph styles in Writer and are used in a similar fashion. 
You cannot create new presentation styles but you can fully configure the existing ones. Note that, 
as with the Heading styles in Writer, the Outline styles are hierarchically linked, so that a change in 
the Outline 1 will cascade through all the other Outline levels.

In Impress you will also find the image styles very useful. They define the characteristics of graphic
objects (including text objects). For example, if you need to create an organization chart diagram in
one of the slides of your presentation, you will probably want all of the objects to have a consistent 
appearance, such as line style, font type, shadow, and so on. The easiest way to achieve this 
result with the minimum effort is to create an image style for the objects and apply it to each object.
The major benefit is that if you decide to change, say, the background color of objects, all you need
to do is modify the style rather than each individual object.

Presentation styles are discussed in more detail in Chapter 3 Adding and Formatting Text and 
image styles are discussed in detail in Chapter 6 Formatting Graphic Objects. More information on 
styles can also be found in the Getting Started Guide Chapter 3 Using Styles and Templates.

Working with templates

A template is a special type of document that you use as a basis to create other documents from. 
For example, you can create a template for business presentations so that any new presentations 
has your company logo and name on the first slide and the remaining slides in your presentation 
only show the company name.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents created using LibreOffice are based on templates. You can create a specific 
template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a 
template when you start a new document, then the document is based on the default template for 
that type of document. If you have not specified a default template, LibreOffice uses the blank 
template for that type of document that is installed with LibreOffice. This default template can be 
changed, see “Setting default template” on page 19 for more information.

However, Impress is a little different from other LibreOffice components, in that it starts with the 
Presentation Wizard, unless you have decided to turn off this wizard. When you choose File > 
New > Presentation from the menu bar and, if the wizard is active, it opens offering several 
choices for a new presentation, one of which is From template.

If you have turned off the Presentation Wizard, when you start a new presentation by choosing File
> New > Presentation from the menu bar, LibreOffice uses the default presentation template. If 
you have not defined your own default template, LibreOffice uses the blank template supplied with 
Impress.

Any slide masters created from a template created by yourself or created from imported templates 
will appear in Available for Use in the Master Pages section of the Sidebar.

For more information on templates, see the Getting Started Guide Chapter 3 Using Styles and 
Templates.
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Templates supplied with LibreOffice
Impress comes with a set of predefined templates and these are located in the Presentation 
backgrounds folder. These templates only contain backgrounds and background objects providing 
you with a starting point to create your own templates. Any templates that you create from this 
default set will be located in the My Templates folder after you have saved your presentation as a 
template. Create a new presentation from a presentation template as follows:

1) Click on Templates in LibreOffice start up window or go to File > New > Templates on the 
main menu bar to open the Template Manager dialog (Figure 12).

2) Click on the Presentations tab to open the page containing all the templates for use in 
Impress.

3) Navigate to the folder that contains the selection of presentation templates you want to use.

4) Select the template you want to use.

5) Click on the Open icon  on the Template Manager toolbar or double-click on the 
template and a new presentation will be created using the selected template.

Figure 12: Template Manager dialog for presentations

Templates from other sources
You can download templates for LibreOffice from many sources, including the official template 
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites 
you may find collections of templates that have been created using open document format (.OTP 
file extension) that Impress uses as its default format. These templates from other sources are 
installed using the Extension Manager, as described in “Importing template collections” on page
23.

Some of these templates are free of charge; others are available for a fee. Check the descriptions 
to see what licenses and fees apply to the ones that interest you. To import individual templates, 
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see “Importing templates” on page 22 for more information and to import a template collection, see 
“Importing template collections” on page 23 for more information.

Creating your own templates
To create a template from a presentation and save it to My Templates folder or a folder of your own
choosing:

1) Open the presentation that you want to use for a template, or open a template that you 
want to use as a basis for your template.

2) Add any extra content and styles to your presentation.

3) Go to File > Templates > Save As Template on the main menu bar to open the Template 
Manager dialog (Figure 13).

4) Open the My Templates or your own template folder as your destination folder to activate 

the Save icon , then click the Save icon.

5) Type a name for the new template in the Enter template name text box.

6) Click OK to save the new template in the destination folder.

7) Close the Template Manager dialog.

8) To use the template for a new presentation, follow the procedure in “Templates supplied 
with LibreOffice” on page 18 and select your newly created template.

Figure 13: Saving a new template in the Template Manager dialog

Setting default template
If you create a presentation by using File > New > Presentation on the main menu bar and do not 
select a template, LibreOffice creates the presentation from the default Impress template, which is 
normally a blank template. However, you can set any presentation template to be the default 
template, even a template that you have created, so long as it is located in a folder displayed in the
Template Manager dialog. You can always reset to the default template back to the blank template 
later if you choose.

Setting a custom template as default
To set a template that you have created or imported as default instead of using the Impress default 
template:

1) Click on Templates in LibreOffice start up window or go to File > New > Templates to 
open the Template Manager dialog and select the Presentations tab (Figure 12 on page
18).

2) Double-click on the My Templates folder or the folder that contains the template you want 
to use to open the folder.
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3) Select the template you want to use as the default template.

4) Click the Set as default icon  and your selected template becomes the default 
template. The next time that you create a new presentation using Impress, the presentation
will be created from the default Impress template.

Note

By default, the Presentation Wizard will have From template selected if the default 
template has been changed. If you select Empty presentation in the Presentation 
Wizard and then click Create, an empty presentation will be created and the default 
template will not be used.

Resetting default template
To reset the default template for a new presentation to use the Impress default template:

1) Click on Templates in LibreOffice start up window or go to File > New > Templates to 
open the Template Manager dialog.

2) Select the Action Menu icon  and choose Reset Default Template from the drop-
down menu (Figure 14). This command does not appear unless the default template has 
been previously changed to a template of your choosing.

3) Select Presentation from the drop down list to reset the default template. If other modules 
in LibreOffice have had their default template changed, then these modules will also appear
in this drop down list.

4) The next time that you create a new presentation using Impress, the presentation will be 
created from the default Impress template.

Figure 14: Resetting the default template

Editing a template
You can edit template styles and content, and then, if you wish, you can reapply the template 
styles to presentations that were created from that template. 

Note You can only reapply styles. You cannot reapply content.
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Editing
1) Click on Templates in LibreOffice start up window or go to File > New > Templates to 

open the Template Manager dialog (Figure 12 on page 18).

2) Navigate to the folder where the template you want to edit is located and click once on it to 
activate the file handling controls.

3) Select the Edit icon  and the template opens in Impress. Edit the template just as you 
would any other presentation.

4) To save your changes, go to File > Save on the main menu bar.

Updating a document from a changed template
The next time that you open a presentation that was created from the changed template, the 
following message appears (Figure 15).

Click Update Styles to update any styles in the template that have been changed in the document.
Click Keep Old Styles if you do not want to update any styles in the template that have been 
changed in the document. Whichever option you choose, the message box closes and the 
presentation opens in Impress.

Figure 15. Update styles message

Note

If you select Keep Old Styles in the message box shown in Figure 15, then this 
message will not appear again the next time you open the document after changing 
the template it is based on. You will not get another chance to update the styles from
the template.

Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, separate 
template folders for different projects or clients. You can also import and export templates.

Tip
The location of LibreOffice template folders varies with your computer operating 
system. To learn where the template folders are stored on your computer, go to 
Tools > Options > LibreOffice > Paths.

Creating template folders
To create a template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 12 on page
18).

3) Click the New Folder icon  and enter a name for the new folder in the Enter folder 
name box, then click OK.
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4) Alternatively, click on the template you want to move to a new folder and the file handling 
controls are displayed.

5) Click the Move to folder icon  and select New folder from the drop list that appears.

6) Type a name for the new folder in the Enter folder name box, then click OK. The selected 
template is then moved to the new folder you have just created.

Deleting template folders
You cannot delete the template folders supplied with LibreOffice or installed using the Extension 
Manager. You can only delete folders that you have created.

To delete a template folder that you have created:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 12 on page
18).

3) In the Template Management dialog select the folder that you want to delete.

4) Select the Delete icon  and a message box appears and asks you to confirm the 
deletion. Click Yes.

Moving templates
To move a template from one template folder to another template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 12 on page
18).

3) Navigate to the template that you want to move and then select it.

4) Click the Move to folder icon  and select the folder from the drop down list to move 
your selected template.

Deleting templates
You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager. You can only delete templates that you have created or imported.

To delete a template:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 12 on page
18).

3) Navigate to the template that you want to delete and then select it.

4) Click the Delete icon  and a message box appears and asks you to confirm the 
deletion. Click Yes.

Importing templates
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.
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To import a template into a template folder:

1) In the Template Manager dialog, select the folder into which you want to import the 
template.

2) Click the Import icon  and a standard file browser dialog opens.

3) Navigate to the template on your computer that you want to import, select it and click 
Open. The file browser window closes and the template appears in the selected folder.

4) Alternatively, click the Get more templates from LibreOffice icon  on the right of the 
Template Manager toolbar to open your web browser at the LibreOffice template page.

5) Locate the template you want to import and select it.

6) Download the template to your computer, then repeat Steps 1 to 3 above to import the 
template into LibreOffice.

Importing template collections
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. For more about the Extension Manager, see the Getting Started Guide 
Chapter 14 Customizing LibreOffice.

1) Download the extension package (.OXT file) and save it anywhere on your computer. You 
can find several templates at http://templates.libreoffice.org/template-center that have been
developed for use with LibreOffice.

2) Go to Tools > Extension Manager on the main menu bar to open the Extension Manager 
dialog (Figure 16).

3) Click Add to open a file browser window.

4) Find and select the template package you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

5) When the package installation is complete, the templates are available for use through File
> New > Templates and the extension is listed in the Extension Manager.

Figure 16: Extension Manager
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Exporting templates
To export a template from a template folder to another location:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 12 on page
18).

3) Navigate to the template that you want to export and then select it.

4) Click the Export icon  and a standard file browser dialog opens.

5) Navigate to the folder into which you want to export the template and click OK.
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