
Getting Started Guide

Chapter 9  
Getting Started with Math
LibreOffice's Equation Editor



Copyright

This document is Copyright © 2010–2011 by its contributors as listed below. You may distribute it 
and/or modify it under the terms of either the GNU General Public License 
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution 
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Ron Faile Jr.
Jean Hollis Weber

Feedback
Please direct any comments or suggestions about this document to: 
documentation@libreoffice.org

Acknowledgments
This chapter is based on the OpenOffice.org 3.3 Math Guide. The contributors to that book are:

Daniel Carrera Agnes Belzunce TJ Frazier
Peter Kupfer Ian Laurenson Janet M. Swisher
Jean Hollis Weber Michele Zarri

Publication date and software version
Published 11 December 2011. Based on LibreOffice 3.4.4.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Opens a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Opens the Navigator

F11 z+T Opens the Styles and Formatting window

Documentation for LibreOffice is available at www.libreoffice.org
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What is Math?

Math is LibreOffice’s component for writing mathematical equations. It is most commonly used as 
an equation editor for text documents, but it can also be used with other types of documents or 
stand-alone. When used inside Writer, the equation is treated as an object inside the text 
document.

Note
The equation editor is for writing equations in symbolic form, as in equation 1. If you 
want to evaluate a numeric value, see the Calc Guide.

df (x )
dx

=ln ( x)+tan−1( x2)  (1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Elements window may 
appear. You will also see a small box with a gray border in your document, where the formula will 
be displayed, as shown in Figure 1.

Figure 1: Equation Editor, Elements window, and location of resulting equation
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Entering a formula

The equation editor uses a markup language to represent formulas. For example, %beta creates 
the Greek character beta (  ). This markup is designed to read similar to English whenever 

possible. For example, a over b produces a fraction: 
a
b

.

You can enter a formula in three ways:

• Select a symbol from the Elements window.

• Right-click on the equation editor and select the symbol from the context menu.

• Type markup in the equation editor.

The context menu and the Elements window insert the markup corresponding to a symbol. This 
provides a convenient way to learn the LibreOffice Math markup.

Note
Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Elements window
The simplest method for entering a formula is the Elements window.

Figure 2: Symbols are divided into categories

The Elements window is divided into two main parts.

• The top shows the symbol categories. Click on these to change the list of symbols.

• The bottom shows the symbols available in the current category.

Tip You can hide or show the Elements window with View > Elements.

Example 1: 5×4
For this example we will enter a simple formula: 5×4 . On the Elements window:

1) Select the top-left button of the categories (top) section.
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2) Click on the multiplication symbol.

Figure 3: Selecting the multiplication symbol

When you select the multiplication symbol on the Elements window, two things happen:

• The equation editor shows the markup: <?> times <?>
• The body of the document shows a gray box like this: ×

Figure 4: Result of selecting the multiplication symbol

The <?> symbols shown in Figure 4 are placeholders that you can replace by other text, for 
example 5 and 4. The equation will update automatically, and the result should resemble Figure 5.

Tip
To keep the equation from updating automatically, select View >AutoUpdate display. 
To update a formula manually, press F9 or select View > Update.

Figure 5: Result of entering 5 and 4 next to the times operator
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Right-click (context) menu
Another way to access mathematical symbols is to right-click on the equation editor. This pops up 
the menu shown in Figure 6. The items in this menu correspond exactly to those in the Elements 
window.

Figure 6: Right-click (context) menu

Markup
You can type the markup directly in the equation editor. For example, you can type 5 times 4 to 
obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.

Tip The formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a = b  a sqrt {a}

a2 a^2 an
a_n

∫ f x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y
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Greek characters

Greek characters (  , , , , etc) are common in mathematical formulas. These characters are 
not available in the Elements window or the right-click menu. Fortunately, the markup for Greek 
characters is simple: Type a % sign followed by the name of the character, in English.

• To write a lowercase character, type the name of the character in lowercase.

• To write an uppercase character, type the name of the character in uppercase.

A complete table of Greek characters is provided in the Math Guide. See the table below for some 
examples.

Lowercase Uppercase

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma   %GAMMA  
%psi    %PSI   
%phi    %PHI   
%theta   %THETA  

Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools > 
Catalog. This window is shown in Figure 7. Under Symbol set, select Greek and double-click on a 
Greek letter from the list. The markup name of the character is shown below the list window.

Figure 7: Symbols catalog, used for entering Greek characters and some special symbols

Example 2:  ≃ 3.14159
For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal places).

• We know the name of the Greek character (pi).

• But we do not know the markup associated with the ≃  symbol.
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Step 1: Type % followed by the text pi. This displays the Greek character  .

Step 2: Open the Elements window (View > Elements).

Step 3: The ≃  symbol is a relation, so we click on the Relations button. If you hover the mouse 
over this button you see the tooltip Relations (Figure 8). 

Figure 9 shows the Selection window after clicking the Relations button. The symbol we want is 
circled.

Figure 8: Tooltip indicates the 
Relations button

Figure 9: After selecting Relations

Step 4: Click on the a ≃ b symbol. The equation editor now shows the markup  %pi<?> simeq 
<?>.

Step 5: Delete the <?> text and add 3.14159 at the end of the equation. We end up with the 
markup  %pi simeq 3.14159. The result is shown in Figure 10.

Figure 10. Final result
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Customizations

Formula editor as a floating window
The formula editor can cover a large part of the Writer window. To turn the formula editor into a 
floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 11.

2) Hold down the Control key and double-click.

Figure 11: Turning the formula editor into a floating window

Figure 12 shows the result. You can dock the floating window again by using the same steps. Hold 
down the Control key and double-click the window frame.

Figure 12: Formula editor as a floating window

How can I make a formula bigger?
This is one of the most common questions people ask about LibreOffice Math. The answer is 
simple, but not intuitive:

1) Start the formula editor and choose Format > Font size.

Figure 13: Changing the font size for a formula
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2) Select a larger font size under Base size (top-most entry)

Figure 14. Edit Base size (top) to make a formula bigger

The result of this change is illustrated in Figure 3.

Figure 15. Result of changing the base font size

Formula layout

The most difficult part of using LibreOffice Math comes when writing complicated formulas. This 
section provides some advice.

Brackets are your friends
LibreOffice Math knows nothing about order of operation. You must use brackets to state the order 
of operations explicitly. Consider the following example.

Markup Result

2 over  x + 1
2
x
1

2 over {x + 1}
2

x1

Equations over more than one line

Suppose you want to type an equation covering more than one line. For example:
x=3
y=1
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Your first reaction would be to simply press the Enter key. However, if you press the Enter key, 
though the markup goes to a new line, the resulting equation does not. You must type the newline 
command explicitly. This is illustrated in the table below.

Markup Result

x = 3

y = 1 x=3 y=1

x = 3 newline

y = 1
x=3
y=1

How do I add limits to my sum/integral?
The sum and int commands can (optionally) take the parameters from and to. These are used for 
lower and upper limits respectively. These parameters can be used singly or together. Limits for 
integrals are usually treated as subscripts and superscripts.

Markup Result

sum from k = 1 to n a_k ∑
k=1

n

a k

int from 0 to x f(t) dt

or 

int_0^x f(t) dt
∫
0

x

f t dt  or  ∫0
x

f  t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Note For more details on integrals and sums, see page Error: Reference source not found.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command.

Markup Result

matrix { a # b ## c # d } a b
c d

Note Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not scale with the matrix:
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Markup Result

(  matrix { a # b ## c # d }  ) a b
c d



LibreOffice Math provides scalable brackets. That is, the brackets grow in size to match the size of 
their contents. Use the commands left( and right) to make scalable brackets.

Markup Result

left(  matrix { a # b ## c # d }  right) a b
c d 

Tip Use left[ and right] to obtain square brackets.

How do I make a derivative?
Making derivatives essentially comes down to one trick: Tell LibreOffice it’s a fraction.

In other words, you have to use the over command. Combine this with either the letter d (for a total 
derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.

Note Notice that we have to use braces (squiggly brackets) to make the derivative.

Markup Result

{df} over {dx}
df
dx

{partial f} over {partial y}
∂ f
∂ y

{partial^2 f} over {partial t^2}
∂2 f

∂ t2

How do I align my equations at the equals sign?
LibreOffice Math does not have a command for aligning equations on a particular character, but 
you can use a matrix to do this, as shown below.

Markup Result

matrix{

   alignr x+y # {}={} # alignl 2 ##

   alignr x   # {}={} # alignl 2-y

}

x y = 2
x = 2−y

The empty braces around = are necessary because = is a binary operator and thus needs an 
expression on each side.
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You can reduce the spacing around = if you change the inter-column spacing of the matrix:

1) With the equation editor open, choose Format > Spacing from the menu bar.

2) In the Spacing dialog (Figure 2), click the Category button and select Matrices in the drop-
down menu.

3) Enter 0% for Column spacing and click OK.

Figure 16: Changing spacing in a matrix formula

Numbering equations

Equation numbering is one of LibreOffice Math’s best hidden features. The steps are simple, but 
obscure:

1) Start a new line.

2) Type fn and then press F3.

The fn is replaced by a numbered formula:

E=mc2  (2)

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta function:

z =∑
n=1

∞ 1

nz

 
(3)

You can reference an equation (“as shown in Equation (2)”) with these steps:

1) Choose Insert > Cross-reference from the menu bar.

2) On the Cross-references tab (Figure 17), under Type, select Text.

3) Under Selection, select the equation number.

4) Under Format, select Reference.

Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the 
equations will automatically renumber and the cross-references will update.

Tip
To insert the equation number without parentheses around it, choose Numbering 
instead of Reference under Format.
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Figure 17. Inserting a cross-reference to an equation number 

Math commands reference

For a full list of the commands available in Math, please see the LibreOffice Math Guide.

• Unary / binary operators

• Relational operators

• Set operations

• Functions

• Operators

• Attributes

• Miscellaneous

• Brackets

• Formats

• Characters – Greek

• Characters – Special
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