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Introduction

This chapter provides information about printing, exporting, and e-mailing documents from 
LibreOffice Impress.

Quick printing

Click the Print File Directly icon  on the Standard toolbar to send the entire document to the 
default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to 
the printer defined for the document instead of the default printer for the computer. 
Go to Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing

Impress provides many options for printing a presentation: with multiple slides on one page, with a 
single slide per page, with notes, as an outline, with date and time, with page name, and more.

For more control over printing a presentation, choose File > Print to display the Print dialog 
(Figure 1). The Print dialog has four tabs, from which you can choose a range of options, as 
described in the following sections.

Figure 1. Print dialog

Note

The options selected on the Print dialog box apply to this printing of this document 
only. To specify default printing settings, go to Tools > Options > LibreOffice – Print 
and Tools > Options > LibreOffice Impress – Print. See “Error: Reference source 
not found” on page Error: Reference source not found for more information.
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General printing options
On the General tab of the Print dialog (Figure 1), you can select:

• The printer from the printers available.

• Which slides to print, the number of copies to print, and whether to collate multiple copies 
using the Range and copies section.

• Whether to print slides, notes, handouts, or an outline of the presentation using the 
Document drop-down list in the Print section.

• For handouts, how many slides per printed page and in what order (see “Printing handouts, 
notes, or outlines” on page 7 for details).

Click the Properties button to display a dialog (Figure 8) where you can choose portrait or 
landscape orientation, which paper tray to use, and the paper size to print on.

Figure 2: Properties dialog for General page in the Print dialog

The Options page of the Print dialog provides other options for printing your presentation, as 
shown in Figure 3.

Figure 3: Options page of Print dialog

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 4).

2) In the Layout section, select from the drop-down list the number of pages to print per sheet. 
The preview panel on the left of the Print dialog shows how the printed document will look.

3) When printing more than two pages per sheet, you can select the order in which they are 
printed across and down the paper.

4) In the Page sides section, select whether to print all pages or only some pages.

5) Click the Print button.
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Figure 4: Page Layout page of Print dialog

Selecting slides to print
In addition to printing a full presentation, you can choose to print individual slides, ranges of slides, 
or a selection of slides, using the Ranges and copies section in the General page of the Print 
dialog (Figure 5). Make sure Slides is selected in the Document box in the Print section.

Figure 5: Ranges and copies section of Print dialog

To print an individual slide or several slides, do either of the following:

• Open the Print dialog, select the Slides option in the Ranges and copies section, type the 
slide number, and click Print. Multiple slides may be represented by a list (for example 
1,3,7,11) or as a range (for example 1-4).

• Select the slide in the Slides pane or the Slide Sorter view, then open the Print dialog and 
select Selection in the Ranges and copies section, then click Print.

Selecting other information to print
On the LibreOffice Impress page of the Print dialog (Figure 6), you can select:

• What to print in addition to the slides: Slide name, Date and time, and Hidden pages 
(slides).

• Whether to print in Original colors, Grayscale, or Black and white (on a color printer).

• What size to print slides.
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Figure 6: Selecting other information to print

Printing handouts, notes, or outlines
The Print section on the Print dialog (Figure 7) also gives you the option of printing Slides, 
Handouts, Notes, or an Outline.

• Handouts prints the slides in reduced size on the page, from one to nine slides per page. 
The slides can be printed horizontally (landscape orientation) or vertically (portrait 
orientation) on the page.

• Notes prints a single slide per page with any notes entered for that slide in Notes View.

• Outline prints the title and headings of each slide in outline format.

Figure 7: Printing handouts

To print handouts, notes, or outlines:

1) Choose File > Print from the main menu.

2) In the Print section of the Print dialog, select the required option from the Document drop-
down list.

3) For Handouts, you can then choose how many slides to print per page, and the order in 
which they are printed.

4) Click the Print button.

Selecting default print options
Selections in the Print dialog over-ride any default settings. To specify default settings for printing, 
use Tools > Options > LibreOffice Impress > Print.

Other printer settings are found in Tools > Options > LibreOffice > Print. Use these settings to 
specify quality settings for printing, and whether to have Impress warn you if the paper size or 
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orientation of your document does not match the printer settings. See Chapter 11, Setting Up and 
Customizing Impress for details.

Printing a brochure

You can print a presentation with two slides on each side of a sheet of paper, arranged so that 
when the printed pages are folded in half, the slides are in the correct order to form a booklet or 
brochure.

To print a brochure on a printer that can only print single sided pages:

1) Choose File > Print.

2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 4 on page 6).

5) Select the Brochure option.

6) In the Page sides section, select Back sides / left pages option from the drop-down list.

7) Click the Print button.

8) Take the printed pages out of the printer, turn the pages over, and put them back into the 
printer in the correct orientation to print on the blank side. You may need to experiment a bit 
to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from 
the Include drop down box. Click the Print button.

To print a brochure on a printer that can print double sided pages:

1) Choose File > Print.

2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 4 on page 6).

5) Select the Brochure option.

6) In the Page sides section, select All pages option from the drop-down list.

7) Click the Print button.

Exporting to PDF

Impress can export presentations to PDF (Portable Document Format). This industry-standard file 
format for file viewing is ideal for sending the file to someone else to view using Adobe Reader or 
other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  on the Standard toolbar to export the entire presentation 
using the default PDF settings. You are asked to enter the file name and location for the PDF file, 
but you do not get a chance to select a page range or the print quality.
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Controlling PDF content and quality
For more control over the content and quality of the PDF produced, use File > Export as PDF to 
open the PDF Options dialog (Figure 8). This dialog has five pages, described in this section. Make 
your selections, and then click Export. You are then asked to enter the location and file name of 
the PDF to be created. Click Save to export the file.

Figure 8: General page of PDF Options dialog

General page of PDF Options dialog
On the General page, you can select which pages (slides) to include in the PDF, the type of 
compression to use for images (this affects the quality of images in the PDF), and other options.

Range section
• All: exports the entire document.

• Pages: exports a range of slides. Use the format 3-6 for example to export a range of 
pages. Use the format 7;9;11 for example to export several individual slides. You can also 
export a combination of slide ranges and single slides by using a format like 3-6;8;10;12.

• Selection: exports whatever material is selected.

Images section
• Lossless compression: images are stored without any loss of quality. Tends to make 

large files when used with photographs and is not recommended for this type of graphic 
files.

• JPEG compression: allows for varying degrees of quality. A setting of 90% tends to work 
well with photographs (small file size, little perceptible loss).

• Reduce image resolution: lower-DPI (dots per inch) images have lower quality. For 
viewing on a computer screen generally a resolution of 72DPI (Windows) or 96DPI 
(GNU/Linux/Mac OS) is sufficient. For printing it is generally preferable to use at least 
300DPI or 600DPI, depending on the capability of the printer. Higher DPI settings greatly 
increase the size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.
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General section
• Embed OpenDocument File: allows the PDF file to be exported containing two file 

formats: PDF and ODF. The PDF format allows the file to be opened using PDF viewers. 
The ODF format allows the file to be easily edited using LibreOffice.

• PDF/A-1: this is an ISO standard for long-term preservation of documents. It embeds all 
the information necessary for faithful reproduction (such as fonts) while preventing other 
elements, for example forms, security, and encryption. PDF tags are written. If you select 
PDF/A-1, the elements not allowed are grayed-out (not available).

• Tagged PDF: a tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form - Submit format: select the format of submitting forms from within the 
PDF file. This setting overrides the URL property control that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

• Export bookmarks: exports slide names as bookmarks (a table of contents list displayed 
by some PDF readers, including Adobe Reader).

• Export comments: exports comments as PDF notes.

• Export notes pages: exports a set of Notes as pages after the set of slides.

• Export automatically inserted blank pages: not used in Impress and is normally grayed 
out.

• Embed standard fonts: normally the 14 standard PostScript fonts are not embedded in a 
PDF file because PDF reader software already contains these fonts. However, you can 
choose to embed these fonts in all PDF documents created by LibreOffice to enhance 
display accuracy in PDF viewers. Font embedding may also be required by some printers.

Initial View page of PDF Options dialog
On the Initial View page (Figure 9), you can select how the PDF file opens by default in a PDF 
viewer. The selections are self-explanatory.

Figure 9: Initial View page of PDF Options dialog
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If you have Complex Text Layout enabled (in Tools > Options > Language settings > 
Languages), an additional selection is available under Continuous facing: First page is left. 
Normally, the first page is on the right when using the Continuous facing option.

User Interface page of PDF Options dialog
On the User Interface page (Figure 10), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a PDF 
for use in a presentation or kiosk-type display.

Figure 10: User Interface page of PDF Options dialog

Window options section
• Resize window to initial page. makes the PDF viewer window resize to fit the first page of 

the PDF.

• Center window on screen. makes the PDF viewer window center on the computer screen.

• Open in full screen mode. makes the PDF viewer open full-screen instead of a window.

• Display document title. makes the PDF viewer display the document title in the title bar.

User interface options section
• Hide menubar. makes the PDF viewer hide the menu bar.

• Hide toolbar. makes the PDF viewer hide the toolbar.

• Hide window controls. makes the PDF viewer hide all other window controls.

Transitions section
• Use transition effects: includes Impress slide transition effects as PDF effects.

Bookmarks section
• All bookmark levels: displays all the bookmarks created in the presentation if Export 

bookmarks is selected on the General page.

• Visible bookmark levels: selects how many heading levels are displayed as bookmarks if 
Export bookmarks is selected on the General page.
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Links page of PDF Options dialog
On the Links page (Figure 11), you can choose how links are exported to PDF.

Figure 11: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this 
option exports them as “named destinations” allowing web pages and PDF documents to link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as 
.ODT, .ODS, and .ODP), this option converts the files name extensions to .PDF in the exported 
PDF document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog
On the Security page (Figure 12), you can set PDF export options to encrypt a PDF file so that it 
can only be opened using a password and also apply digital rights management (DRM) features. 
Click on the Set passwords button to open the Set passwords dialog (Figure 13).

Note Security settings are effective only if another PDF viewer respects the settings.

• Creating a Set open password (Figure 13), the PDF can only be opened with the 
password. Once opened, there are no restrictions on what the user can do with the 
document (for example, print, copy, or change it).

• Creating a Set permission password (Figure 13), the PDF can be opened by anyone, but 
its permissions can be restricted using the options in Figure 12. These permissions only 
become available when this password is set. These selections are self-explanatory.

• With both of these passwords set, the PDF can only be opened with the correct password, 
and its permissions can be restricted.
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Figure 12: Security page of PDF Options dialog

Figure 13: Setting passwords to encrypt a PDF

Exporting as a Flash file

Macromedia Flash file format (.swf) was created to store animation for web pages. With most 
browsers able to play Flash movies these files can be viewed by the majority of users. If a browser 
cannot play Flash movies, then Adobe Flash Player is available as a free download from Adobe at 
http://www.adobe.com/products/flashplayer/.

Note Saving in Flash format does not retain animation and slide transitions.

Using LibreOffice, you can export your Impress slide show as a Flash file in .swf format as follows:

1) Choose File > Export.

2) Select the location where you want the file saved and type a name for the file.

3) Under File Format, choose Macromedia Flash (SWF) (.swf) and click Save.
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Exporting as web pages (HTML files)

You can export presentations as a series of web pages that can be viewed in any browser.

Note Saving as web pages (HTML format) does not retain animation and slide transitions.

Figure 14: HTML Export wizard – selecting a design

1) Select File > Export and choose HTML Document as the file type.

2) If necessary, create a folder for the files, then give a name for the resulting HTML file and 
click Save. The HTML Export wizard opens (Figure 14).

3) Select a design for all of the pages, either from an existing design or by creating a new 
one. If you have not previously saved a design, the Existing Design choice is not available.

Figure 15: HTML Export – selecting publication type
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4) Click Next to select the type of web pages to create (Figure 15). The available options will 
change depending on publication type selected.
1) Standard HTML: one page for each slide with navigation links to move from slide to slide.
2) Standard HTML with frames: one page with a navigation bar on the left-hand side; 

uses slide title as navigation links. Click on links to display pages in right-hand side.

3) Automatic: one page for each slide, with each page set with the refresh meta tag so a 
browser automatically cycles from one page to the next.

4) WebCast: generates an ASP or Perl application to display the slides. Unfortunately 
LibreOffice has no direct support for PHP yet.

Figure 16: HTML Export – selecting graphics type

Figure 17: HTML Export – title page information
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5) Click on Next to decide how the images will be saved (PNG, GIF or JPG) and what 
resolution to use (Figure 16). When choosing a resolution, consider what the majority of 
your viewers may have. For example, if you use a high resolution, then a viewer with a 
medium-resolution monitor will have to scroll sideways to see the entire slide.

6) If Create title page was selected in step 4, supply the information for it on the next page 
that appears after clicking on Next (Figure 17). The title page contains name of the author, 
e-mail address and home page, along with any additional information you want to include. 
This page of the Wizard does not display if Create title page was not selected.

7) Click on Next to select the style of navigation buttons to use when moving from one page 
to another (Figure 18). If you do not choose a navigation style, LibreOffice will create a text 
navigator.

Figure 18: HTML Export – selecting navigation style

Figure 19: HTML Export – selecting color scheme
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8) Click on Next to select the color scheme for the web pages (Figure 19). Available schemes 
include the existing scheme for the presentation, one based upon browser colors, and a 
user-defined scheme. You can save a new scheme so that it will appear on the first page of 
the HTML export wizard.

9) Click Create to generate the HTML files. If this is a new design, a small dialog pops up 
(Figure 20). If you want to reuse this design, you can give it a name and save it. Otherwise, 
click Do Not Save.

Figure 20: Naming the design

E-mailing a presentation

LibreOffice provides several ways to quickly and easily send a presentation as an e-mail 
attachment in one of three formats: .ODP (OpenDocument Presentation, LibreOffice default 
format), .PPT (Microsoft PowerPoint format), or as a PDF file.

To send the presentation in .ODP format:

1) Choose File > Send > Document as E-mail or File > Send > E-mail as OpenDocument 
Presentation. LibreOffice opens a new e-mail in your default e-mail program. The 
document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to add, then send 
the e-mail.

If you select E-mail as Microsoft PowerPoint Presentation, LibreOffice first creates a .PPT file 
and then opens your e-mail program with the .PPT file attached. This .PPT file is not saved on your 
computer.

Similarly, if you select E-mail as PDF, LibreOffice first creates a PDF using your default PDF 
settings (similar to using the Export Directly as PDF icon in the standard toolbar) and then opens 
your e-mail program with the .PDF file attached. This PDF file is not saved on your computer.

Tip
If you want to keep a copy of the .PPT or .PDF file as well as e-mailing it to someone, 
first save or export the presentation into the required format, then attach it to an e-mail 
in the usual way.

Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document contents plus your personal key. The checksum and your public key are stored together 
with the document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
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the program can show you the public key information from the certificate. You can compare the 
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On 
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For 
a more detailed description of how to get and manage a certificate, and signature validation, see 
“Using Digital Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message appears. Click Yes 
to save the file.

3) After saving, you see the Digital Signatures dialog box. Click Sign Document to add a 
public key to the document.

4) In the Select Certificate dialog, select your certificate and click OK.

5) You see again the Digital Signatures dialog box, where you can add more certificates if you 
want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view the 
certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDF files from 
them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) 
you when files contain certain information and remove personal information automatically when 
saving the file or when creating a PDF.

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset button. This removes any names in the created 
and modified fields, deletes the modification and printing dates, and resets the editing time to zero, 
the creation date to the current date and time, and the version number to 1. Make sure you click 
OK to save the changes.

Opening and saving a PowerPoint file

The file format of LibreOffice Impress is highly compatible with the format used by Microsoft 
PowerPoint. You can open a PowerPoint presentation in Impress, edit it, then save it in its original 
PowerPoint format or in OpenDocument Presentation format used by Impress. You can also create 
a new presentation in Impress and save it as a PowerPoint file.

Caution There are some differences between OpenDocument (.odp) and PowerPoint (.ppt, 
.pptx) files in text and graphics formatting, animations, transitions, and fields. For 
best results, avoid using features that are not fully supported in both formats.

Saving an Impress file as a PowerPoint file
1) Select File > Save As from the main menu.
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2) Select the location where you want the PowerPoint file saved and type a name for the file.

3) Under File type, select a Microsoft PowerPoint format (.ppt or .pptx) from the available 
drop-down list.

4) Click Save. If you have the “Warn when not saving in ODF or default format” option set in 
Options > Load/Save > General, the message shown in Figure 21 appears. Click on the 
button showing the Microsoft PowerPoint format to confirm that you want to save the file in 
that format. You can deselect the Ask when not saving in ODF format checkbox to not show 
the message again unless you re-enable it in the Options.

Figure 21: Warning message when saving in Microsoft PowerPoint format

Tip

Always save your work in Impress OpenDocument format (.odp) before saving in 
Microsoft format. Keep the Impress file as your working copy: if you need to change 
the presentation, change it in the Impress version and then save it again as 
PowerPoint. You are much less likely to have problems than if you open a file 
previously saved in PowerPoint format, edit it, and save it again.

Opening a PowerPoint file in Impress
If you receive a file from someone in PowerPoint format and need to edit it in Impress, here is how:

1) In LibreOffice, choose File > Open from the menu bar.

2) Under File type, choose All files (*.*) or Presentations or Microsoft PowerPoint from the 
drop-down list.

3) Navigate to the PowerPoint file, select it, and click Open.

The PowerPoint file can now be edited and saved as an Impress file or a PowerPoint file. To save 
the file as an Impress file, choose OpenDocument Presentation (.odp) as the File Type.
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