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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools - Options menu LibreOffice — Preferences  Access setup options

selection

Right-click Control+click Opens a context menu

Ctrl (Control) 0 (Command) Used with other keys

F5 Shift+0+F5 Opens the Navigator

F11 0+7 Opens the Styles & Formatting window

Documentation for LibreOffice is available at www.libreoffice.org
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Introduction

You can enhance functionality of LibreOffice with Extensions.

Just install these small programs into LibreOffice and after restart of office suit you can enjoy the
new abilities.

If you are an extension developer, you can use several languages to develop LibreOffice
extensions. Supported programming languages are Basic, Python, JavaScript and Java. For the
higher level of integrity and possibilities you can use C++, Python and Java languages to develop
UNO complements based extensions.

As a UNO components you can provide new implementations of existing functionality or
specialized components like Calc Add-Ins, Add-Ons, DataPilots, Chart Add-Ins, or linguistic
components: Spellchecker, Hyphenator or Thesaurus.

Also you can pack extensions for additional Templates, Gallery and Autotexts.
These extensions are free of charge.

This how to describes the basic steps for publishing an extension in LibreOffice official extension
repository, located at http.//extensions.libreoffice.org/.

We recommend to read this document before starts to publish your extension. Specially to gather
the basics information to fill the mandatory fields.
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http://extensions.libreoffice.org/

Create a Software Project

First of all, you need to register yourself at the Extensions website. Open the Extensions web site
in your browser and click on the Register button, in the right upper corner. Fill the Registration

form and click Register.

LibreOffice Exten

Arquivo Editar Exibir Histérico Favoritos Ferramentas Ajuda

Enter full name, e.g. John Smith.
John Smith

User Name =
Enter a user name, usually something like jsmith’. No spaces or special characters. Usernames
and passwords are case sensitive, make sure the caps lock key is not enabled. This is the name
used to log in.

E-mail w
Enter an email address. This is necessary in case the password is lost. We respect your privacy,
and will not give the address away to any third parties or expose it anywhere.

jsmith@test.com

A URL will be generated and e-mailed to you; follow the link to reach a page where you can
change your password and complete the registration process.

You are here: Home

LibreOffice

LibreOffice offers a
templates that add thi
can develop more exi
http:/itemplates-test.li

Type the code m
Type the code from the picture shown below.

= | shade

Extensions
LibreOffice Extensions are

your copy of LibreOffice, or

LibreOffice remains committs
are published under free softwal

Concluido

| be extensions and

“a ~ & #% [D|http:,!,!extensions—test.lihreofﬁce.nrg/ VI [!:lV‘G(\(IEIS @L]
| O3 Libreoffice Extensions | &+ v
Search Site Search ~
‘ L 0 frent sectior
LIOI'E Registration form
The Docunll . name

ople, maybe you,
tes go to

add new functionality to

extensions and templates

You should receive and e-mail containing a link to set your password and complete your

registration process. You may set the password before the deadline date

indicated in the e-mail.

After this date, you may use the “Forgot your password” link to get a nerw password.

LibreOffice Extensions - Mozilla Firefox
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« v O &

O | http://extensions-test.libreoffice.org/

¥l

g~ |Google

| O3 Libreoffice Extensions | &

Welcome!

‘You have been registered.
‘You will receive an e-mail shortly containing a URL that will allow you to set your password.

When you receive this e-mail, please follow the link to complete your registration process. NOTE:
The password reset URL will expire on Aug 18, 2011 03:15 PM. If your password reset request
expires, you may use the "Forgot your password” link to generate another password reset
request.

You are here: Home

&
LibreOffice Extensions

Search

frent sectior

LibreOffice offers a wide variety of features, and when you look for additional functionality, there may well be extensions and
templates that add that! This site offers a wide range of extensions to satisfy your needs. What's more: people, maybe you,
can develop more extensions and offer them for the collecting on this site. If you are searching for templates go to
http:/itemplates-test.libreoffice.org or http:/itemplates.libreoffice.org.

Extensions

LibreOffice Extensions are tools that can be added or removed independently from your installation of the main program. Extensions may add new functionality to
your copy of LibreOffice, or may make existing functionality easier to use.

LibreOffice remains committed to providing users with quality software authored under free software licenses, and, as such, our catalogue of extensions and templates
are published under free software licenses.

Concluido

[<]

After your registration process complete, you be able to login and create a new extension project.
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In the right upper corner, click on Log in to start.
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o« v w 4 | | O3 nttp/jextensions-test.libreoffice.org/ VI [-ﬂv | Google 5{]
| 0§ Libreoffice Extensions | & v
English Francais Deutsch Italiano Portugués Espafiol Log in Register

\Search|

. (x) R o
Y Libr ognname [

The Docu
e
Home B N
Forgot your password?
If you have forgotten your password, we can send you a new one.
You are here: Home New user?
If you do not have an account here, head over to the registration form.
LibreOffice

LibreOffice offers a wide variety of features, and when you look for additional functionality, there may well be extensions and
templates that add that! This site offers a wide range of extensions to satisfy your needs. What's more: people, maybe you,
can develop more extensions and offer them for the collecting on this site. If you are searching for templates go to
http:/itemplates-test.libreoffice.org or http:/itemplates.libreoffice.org.

Extensions

LibreOffice Extensions are tools that can be added or removed independently from your installation of the main program. Extensions may add new functionality to
your copy of LibreOffice, or may make existing functionality easier to use.

[<]

Concluido

Next, click on Extension Center and, after, on Submit your Extension, on the right green block.

Extension Cente|
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| 3 Extension Center — Libreoffice... | 4

[ http:/fextensions-test libreoffice.org/extension-center VI [!:'v | Google ﬁ{l

v
Search Site

Qe . "“TEN S | ON S & D0 only in current section
[ ] LibreOffice | 205 RTES

Home Extension Center Help-Downloads

You are here: Home » Extension Center

Contents Edit  Sharing ACHONS =

Extension Releases

| Al categories ¢ || LibreOffice 3.4.1 % | Sorton

[ Highest Rated || | | | searcn|

No results were found.

=) Submit your Extension

Concluido
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The Add Software Project form will appear.

In this form, you have some mandatory fiels at Default tab: Title, Categories, Project Summary,
Full Project Description and Contact address. Each one has a short description below the field
name.

@ ]2 Libreoffice Extensions HMozillalFirefox EE
Arquivo Editar Exibir Historico Favoritos Ferramentas Ajuda

] v 2 # [B http://extensions-test.libreoffice.org/extension-center/portal_ V] [-‘]v ‘-‘Q]
| [§ [-] — LibreOffice Extensions | ok

B

Home [SLEHE T Il Help-Downloads

You are here: Home > Extension Center =[]

Add Software Project

L w ]

Default =«  Metadata Distutls  Review
Title w

[Fixed values for Calc

Categories =
Categories that this item should appear in. %

Extensions for all program modules
Gallery Contents for all program modules

Language Tools for all program modules
Writer-Extensions

Imnress. Fytensinns

Project Summary =
A short summary of the project.

This extension creates two menu items in Calc to insert current date or current time in the selected cell as a fixed value.

&
Concluido
In Categories, you can select more than one option by pressing Ctrl.
Categories Description Example

All modules Extensions for all program modules |Extensions that could be used with all
program modules.

Gallery Contents | Extensions for all program modules | Pictures, Backgrounds, ...

Language Tools | Extensions for all program modules | Dictionaries and similar

Writer Extensions for Writer Extensions that could be used to extend the
word processor module.

Calc Extensions for Calc Extensions that could be used to extend the
spreadsheet program module.

Impress Extensions for Impress Extensions that could be used to extend the
presentation program module.

Draw Extensions for Draw Extensions that could be used to extend the
drawing program module.

Base Extensions for Base Extensions that could be used to extend the
database program module.

Math Extensions for Math Extensions that could be used to extend the
program module for formula.
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In Contact address, Use mailto: prefix for e-mail contact or http:// prefix for a external web site.

Field Description
Title Title of the software project.
Categories Categories that this item should appear in.

Project Summary

A short summary of the project.

Full Project Description

The complete project description.

Contact address

Contact address for the project. Use mailto: or http:// prefix
depending on what contact method you prefer.

Home page

If the project has an external home page, enter its URL.

URL of documentation repository

If the project has externally hosted documentation, enter its
URL.

URL of version control repository

If the project has a code repository, enter its URL.

Issue tracker URL

If the project has an external issue tracker, enter its URL.

Support mailing list or forum URL

URL of mailing list information page/archives or support
forum, if the project has one.

Logo Add a logo for the project (or organization/company) by
clicking the 'Browse' button. Max 150x75 pixels (will be
resized if bigger).

Logo link The URL the logo should link to, if applicable.

Screenshot Add a screenshot by clicking the 'Browse' button. Max

800x600 (will be resized if bigger).

After fill the form, click Save.
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Your Extension project will be created. However, at this time, you can not add releases,
documentation or feature proposals. Before, you need Submit your project for approval.

To do this, click on State: Submit for approval link, in the right side of the green bar.

Arquivo Editar Exibir Historico Favoritos Femamentas Ajuda

« v 2 &

| [ Fixed values for Calc — Libreof... | <

W
4]
Home Extension Center Help-Downloads

N BT e You are here: Home » Extension Center » Fixed values for Calc
2

¥ | http:/fextensions-test.libreoffice.org/extension-center/fixed-y V] ['_-']V '35"\]

¥ Releases

Actions v Display v Add new... v State: Unapproved project v

Fixed values for Calc

by Gustavo Pacheco — last modified Aug 11, 2011 (. Like
This extension creates two menu items in Calc to insert current date or £ L Q
current time in the selected cell as a fixed value.

0 likes, 0 dislikes

You can not add releases, documentation or feature proposals until the project itself is approved, make sure you submit it
for approval when the relevant project information has been entered.

Project Description b

After the installation, just go to Insert > Fixed Values menu and choose Date or Hour. The date or hour should be put on
the selected cell, with the default format defined by the cument language

Current Release
No stable release available yet

All Releases

Version Released Description Compatibility License Status

(]

Concluido

The status of your project will be changed to State: Pending approval, until the approval by a
reviewer.

After approval, the status should be changed to State: Public and you can add releases,
documentation and feature proposals.
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Adding a Release section

After approval, go to Add new > Release section to create a new worspace for your releases
information and files.

ed values for Calc — LibreOffice Exten:

Arguive Editar Exibir Historico Favoritos Femamentas Ajuda

@ v = W &% |0 | http://extensions-test.libreoffice.org/extension-centerffixed-\ V] [-;]V|G(mg e @]
[ﬁ Fixed values for Calc — LibreOf... | <=

Home xie n Center Help-Downloads

B Fixed values for Calc You are here: Home » Extension Center » Fixed values for Calc

# Releases Contents Edit  Sharing Actions v Display v Add new... v

Fixed values for Calc

by Gustavo Pachecn — last modified Aug 11, 2011

State: Unapproved project v

¥ Documentation Section

# Releases Section k

PM © Roadmap Section

This extension creates two menu items in Calc ¥
current time in the selected cell as a fixed value.

. ¢ e €
0 likes, 0 dislikes

You can not add releases, documentation or feature proposals until the project itself is approved, make sure you submit it
for approval when the relevant project information has been entered.

Project Description
After the installation, just go to Insert > Fixed Values menu and choose Date or Hour. The date or hour should be put on
the selected cell, with the default format defined by the cument language

Current Release

No stable release available yet

All Releases

Version Released Description Compatibility License Status

Concluido

At the Add Releases Section form, just click on Save button.

Releases — LibreOffice Extensions - Mozilla Firefox
Arquivo Editar Exibir Historico Favoritos Femamentas Ajuda

@ v & [B|http:{jextensions-test.libreofﬁce.orgfextension-centenﬁxed-\. V] [::'V|C1CICIQ e Q]
[ﬁ Releases — LibreOffice Extensi... ‘ ap

Home
& Fixed values for Cale You are here: Home » Extension Center » Fixed values for Calc » Releases
# Releases .

Add Releases Section

Folder type for holding releases.

Default  Metadata

Tite
Enter a title for the container

Releases

Description
Enter a description of the container

Existing and upcoming releases for this project.

http:/fextensions-test.libreoffice.org/extension-center
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The Releases folder will be created and you can add a new release clicking on Add new >
Software Release.

Releases — LibreOffice Extensions - Mozilla Firefox
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@ v B g &% [B|http:,fjextensions-test.libreofﬁce.orgfextension-centermxed-\. V] [',-:]V|-j1c:c:f_.\ e Qf,]
rﬁ Releases — LibreOffice Extensi... | <=

Home Extension Center Help-Downloads

@ Fixed values for Cale You are here: Home » Extension Center » Fixed values for Calc » Releases

¥ Releases

Contents

m Changes saved

Releases
Existing and upcoming releases for this project.

Edt  Sharng Actions v Display v Add new... v

¥ Releases

# Software Releasel

« Back to project page

You can not add releases, documentation or feature proposals until the project itself is approved, make sure you submit it
for approval when the relevant project information has been entered.

N

Experimental Releases
Stable Releases

Site Map Accessibility Contact

<]

http:/fextensions-test.libreoffice.org/extension-center/fixed-values-for-calc/pscreleasefolder.2011-08-11.8232724833/folder_facto...

Now, you need to fill the Add Software Release form.

Releases 1.0/ (Unreleased) Mozilla Firefox

Arquivo Editar Exibir Histdrico Favoritos Ferramentas Ajuda

* ~ z x ﬂ 0 \ http:/fextensions-test.libreoffice.org/extension-cen VI [-;] v |n::1c:c:g| e 9{]
[ Releases 1.0 (Unreleased) — Li... | & v
E
B Fixed values for Cal You are here: Home » Extension Center » Fixed values for Cale » Releases » Releases 1.0 (Unreleased) [
¥ heeases Add Software Release B

A release of a software i er final of In progress

Default »  Metadata

Version =

This field is also used in the URL of the item, so please don't use spaces and special characters. Also, please do
NOT include the alpha, beta, or release candidate state as this is handled by the workflow. Example: 0.1

1.00

Release Summary =

A short description of the most important focus of this release. Mot a version history, but in plain text what the main
henefit of this release is.

First release of Fixed Values for Calc.

Format | HTmL| &
Codename
Codename for this release, if you have one.

]

Full Release Description
The complete release text.

Concluido

= el

Some fields on Default tab are mandatory: Version, Release Summary, License and
Compatibility.
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Field

Description

Version

This field is also used in the URL of the item, so please don't use
spaces and special characters. Also, please do NOT include the
alpha, beta, or release candidate state as this is handled by the
workflow. Example: '0.1".

Release Summary

A short description of the most important focus of this release.
Not a version history, but in plain text what the main benefit of
this release is.

Codename

Codename for this release, if you have one.

Full Release Description

The complete release text.

Changelog

A detailed log of what has changed since the previous release.

Release Manager

Release manager for this release.

Release Manager Contact E-mail

Contact e-mail for Release Manager.

Proposals freeze date

Date after which no more Improvement Proposals will be
associated with the release

Feature freeze date

Date after which no new features will added to the release

(Expected) Release Date

Date on which a final release is expected to be made or was
made

License Release License: Please examine carefully which license you
choose for your contribution. You can't change it after the
release. The options are:

GPL - GNU General Public License
LGPL - GNU Lesser General Public License
BSD License (revised)
Public Domain
Other OSI Approved
Compatibility Tested and working with the selected versions

Associated feature proposals

Related improvement proposals for features going into this
release.

Repository branch

URL of version control repaository branch for this release.

After fill the Add Software Release form, click Save.

12
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Adding files

Now, after created the Release folder, you have two options for the files of the release: add a
donwloadable file or add a link for an externally hosted file. This options are detailed in the next

two sections.

Adding a donwloadable file

For the first option, click Add new > Donwloadable File on the green bar.

Arquivo Editar Exibir Historico Favoritos Ferramentas Ajuda
@ v = 4 | | | [3/http:/extensions-test.libreoffice.org/extension-cen . v I [-ﬁ]v |Google \?&]
| [ Fixed values for Calc 1.0.0 (unr... | < v
1~
Home Extension Center Help-Downloads
@ Fixed values for Calc ‘You are here: Home » Extension Center > Fixed values for Cak » Releases » Fixed values for Cak 1.0.0 (Unreleased) |
# Releases Contents [RYCUM Edt  Shanng Actions v Display v Add new_.. v State: Unreleased v
# Releases O D File k
m LT SR “ Extemally Hosted File
Fixed values for Calc 1.0.0 (Unreleased)
This is not a final release. Experimental releases should only be used for testing and development. Do not use these on
production sites, and make sure you have proper backups before installing.
First release of Fixed Values for Calc.
For additional information about this project, please visit the oveniew page
Available downloads
There are no avaiabie software fles in fis release yet Use the Add menu 10 add sohware fles
Site Map Accessibiity Contact
]
Concluido :

At Add Downloadable File form, you just have chose your extension file in File field and define the
operating system in Plataform field.

€« v 2 ®

Arquive Editar Exibir Historico Favoritos Ferramentas Ajuda

B|http:,ifextensions-test.libreofﬁce.org,fextension-cen VI [:!lv "Eli ogle

& Fixed values for Cak

# Releases

Concluido

E [-] — LibreOffice Extensions | &

Home Extension Center Help-Downloads

You are here: Home > Extension Center s Fixed values for Calc » Releases s Fixed values for Calc 1.0.0 (Unreleased) s [--]
Add Downloadable File
Conains the downloadable e for he Release.

Default =  Metadata

File Description
File description. Normally something like "Product Package”, Windows Installer, - or ‘Events subsystem’ if you have
several separate modules. The actual file name will be the same as the file you upload

File =
Click "Browse’ to upload a release file

|hame/gbpacheco/Area de Trabalho/Anot | Enviar arquivo .

Platform = b
List of platforms available for selection

All platforms <

Cancel

[«

At the end of the form, click Save.

Publishing Extensions in LibreOffice
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Adding a link for an externally hosted file

To add an externally hosted file, just click Add new > Externally Hosted File on the green bar and
fill the Add Externally Hosted File form. Only Plataform and URL for externally hosted file fields
are mandatory.

Cancel -
@ |
Concluido E
Click Save to finish.

Arquivo Editar Exibir Histérico Favoritos¥ Ferramentas

[:-:] — LibreOffice Extensions -

Mozilla Firefox

Ajuda

€« Vg &%

0 | http://extensions-test.libreoffice.org/extension-c =~ v

[';',l v | Google gq

[§ [-~1 — LibreOffice Extensions | e
=
¥ Releases
Contains a fnkio a downloadable fe for a Releass.
Default = Metadata

File Description

Add Externally Hosted File

File description. Normally something like "Product Package’, ‘Product Installer, or "Product Bundle” - if you have
several packages in one archive. The uploaded filename will not be changed.

|

Platform =
List of platforms available for selection

All platforms &

URL for externally hosted file =

Please enter the URL where the file is hosted.

[

]

File size

Please enter the size of the extemally hosted file, if known. Include the notation kB or MB.

[

]

14
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Publishing a release

After added a donwloadable file or a link for an externally hosted file for the release, you will see
the Extension release and the file(s).

Fixed_Values_for_Calc.oxt — LibreOffice Extensions - Mozilla Firefox
Arquivo Editar Exibir Histdrico Favoritos Ferramentas Ajuda

v £ [~ . | [§ http:/fextensions-test.libreoffice.orgfextension-cen = v | |~ |Googe @
By
[ﬁ Fixed_values_for_Calc.oxt —Li... | =

»

[>

Home Extension Center Help-Downloads

. You are here: Home » Extension Center » Fixed values for Cale » Releases » Fixed values for Calke 1.0.0 (Unreleased) »
& Fixed values for Calc Fixed_Values, for_Caic.oxt
¥ Releases

» Releases Edit Properties  Sharng

Translate into... »  Actions »

m Changes saved. |

m Remember to publish your release once all files have been added by going back to the release page . |

+, Fixed values for Calc 1.0.0 (Unreleased) -
Fixed Values for Calc.oxt

by Gustavo Pacheco — last modified Aug 11, 2011 04:22 PM
First release of Fixed Values for Calc.

¥ Download (18.3 kB)

Site Map Accessibility Contact

Privacy Policy | Impressum (Legal Info) | Copynight information: Unless otherwise specified, all text and imapes on this website are licensed under the Creative Commaons
Concluido

= +]

Click on going back to the release page link to change the release status. To publish the release, go to
State: Unreleased menu and define the new state, for example, Release final release.

|' ) Fixed values for Calc 1.0.0/ (Unreleased) — LibreOffice Extensions - Mozilla Firefox BEE
Arquivo Editar Exibir Histérico Favoritos Ferramentas Ajuda

ﬁ v e X ﬂ |0 \ http:/fextensions-test.libreoffice.org/extension-cen Vl [-;] v |-::1c:c:g| e Q{l
[ Fixed values for Calc 1.0.0 (Unr... ‘ aF v
~
Home Extension Center Help-Downloads
B Fixed values for Cal You are here: Home » Extension Center » Fixed values for Cale » Releases » Fixed values for Cak 1.0.0 (Unreleased) I
# Releases Contents Edit  Sharing Actions v Display v Add new... v State: Unreleased v
¥ Releases Hide release
Fixed values for Calc 1.0.0 (Unreleased) Release aipha
This is not a final release. Experimental releases should only be used for testing and development. B=EEREEE
production sites, and make sure you have proper backups betore instaliing o eToE
First release of Fixed Values for Calc.
Advanced... 3
ity S Poiicy.
For additional information about this project, please visit the overview page .
Available downloads
Fixed_Values_for_Calc.oxt
For All platiorms (183 kB)
Site Map Accessibility Contact
Concluido

= [&]

Finally, log out and go to the new extension page to see your extension published!

Publishing Extensions in LibreOffice 15



	Copyright
	Note for Mac users
	Introduction
	Create a Software Project
	Adding a Release section
	Adding files
	Adding a donwloadable file
	Adding a link for an externally hosted file

	Publishing a release

