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What is a template?

A template is a document model that you use to create other documents. For example, you can 
create a template for business reports that has your company’s logo on the first page. New 
documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create a specific template for any 
document type (text, spreadsheet, drawing, presentation). If you do not specify a template when 
you start a new document, then the document is based on the default template for that type of 
document. If you have not specified a default template, LibreOffice uses the blank template for that 
type of document that is installed with LibreOffice. See “Setting a default template” on page 19 for 
more information.

LibreOffice 4.0 supplies one user-selectable text template, MediaWiki, as an alternative to the 
default in documents (Writer). Note that German is the default document language in the 
MediaWiki template. This can be changed on the Languages page in Tools > Options > 
Language Settings.

Ten colored backgrounds are supplied for presentations (Impress). No alternative templates are 
supplied for drawings (Draw) or spreadsheets (Calc).

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and other elements in 
your document to quickly change their appearance. When you apply a style, you apply a whole 
group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their 
documents without paying any attention to styles. They are used to writing documents according to
physical attributes. For example, you might specify the font family, font size, and any formatting 
such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New 
Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to 
have those characteristics. In other words, styles means that you shift the emphasis from what the 
text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. 
For example, you may decide to change the indentation of all paragraphs, or change the font of all 
titles. For a long document, this simple task can be prohibitive. Styles make the task easy.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. 
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table 
of contents. Some common examples of style use are given in “Examples of style use” on page 22.

LibreOffice supports the following types of styles:

• Page styles include margins, headers and footers, borders and backgrounds. In Calc, page 
styles also include the sequence for printing sheets.

• Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment, 
tab stops, line spacing, and borders, and can include character formatting.

• Character styles affect selected text within a paragraph, such as the font and size of text, or 
bold and italic formats.
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• Frame styles are used to format graphic and text frames, including wrapping type, borders, 
backgrounds, and columns.

• Numbering styles apply similar alignment, numbering or bullet characters, and fonts to 
numbered or bulleted lists.

• Cell styles include fonts, alignment, borders, background, number formats (for example, 
currency, date, number), and cell protection.

• Graphics styles in drawings and presentations include line, area, shadowing, transparency, 
font, connectors, dimensioning, and other attributes.

• Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 1.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them, 
or create new styles, as described in this chapter.

Table 1. Styles available in LibreOffice components

Style Type Writer Calc Draw Impress

Page X X

Paragraph X

Character X

Frame X

Numbering X

Cell X

Presentation X X

Graphics (included in
Frame styles)

X X

Applying styles

LibreOffice provides several ways for you to select styles to apply.

Using the Styles and Formatting window
1) Click the Styles and Formatting icon located at the left-hand end of the formatting toolbar, 

or click Format > Styles and Formatting, or press F11. The Styles and Formatting window 
shows the types of styles available for the LibreOffice component you are using. Figure 1 
shows the window for Writer, with Page Styles visible.

You can move this window to a convenient position on the screen or dock it to an edge 
(hold down the Ctrl key and drag it by the title bar to where you want it docked).

2) Click on one of the icons at the top left of the Styles and Formatting window to display a list 
of styles in a particular category.

3) To apply an existing style, position the insertion point in the paragraph, frame, page or 
word, and then double-click on the name of the style in one of these lists. To apply a 
character style to more than one word, select the characters first.
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Tip

At the bottom of the Styles and Formatting window is a drop-down list. In Figure 1 
the window shows Automatic, meaning the list includes only styles applied 
automatically by LibreOffice. You can choose to show all styles or other groups of 
styles, for example only custom styles.

Figure 1: The Styles and Formatting window for Writer, showing paragraph styles

Using Fill Format Mode
Use Fill Format to apply a style to many different areas quickly without having to go back to the 
Styles and Formatting window and double-click every time. This method is quite useful when you 
need to format many scattered paragraphs, cells, or other items with the same style.

1) Open the Styles and Formatting window and select the style you want to apply.

2) Click the Fill Format Mode icon .

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or 
frame and click. To apply a character style, hold down the mouse button while selecting the 
characters, Clicking on a word applies the character style for that word. Repeat step 3 until 
you have made all the changes for that style.

4) To quit Fill Format mode, click the Fill Format Mode icon again or press the Esc key.

Caution When this mode is active, a right-click anywhere in the document undoes the last Fill 
Format action. Be careful not to accidentally right-click and thus undo actions you 
want to keep.

Using the Apply Style list
After you have used a style at least once in a document, the style name appears on the Apply Style 
list at the left-hand end of the Formatting toolbar, next to the Styles and Formatting icon.

You can open this list and click once on the style you want, or you can use the up and down arrow 
keys to move through the list and then press Enter to apply the highlighted style.

Tip
Select More at the bottom of the Apply Style list to open the Styles and Formatting 
window.
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Figure 2: The Apply Style list on the Formatting toolbar

Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies 
the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You 
can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for 
instructions.

Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot 
get rid of the manual formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Clear Direct 
Formatting from the context menu, or use Ctrl+M after selecting the text.

Modifying styles

LibreOffice provides several ways to modify styles (both the predefined styles and any custom 
styles that you create):

• Changing a style using the Style dialog

• Updating a style from a selection

• Use AutoUpdate (paragraph and frame styles only)

• Load or copy styles from another document or template

Note
Any changes you make to a style are effective only in the current document. To 
change styles in more than one document, you need to change the template or copy 
the styles into the other documents as described on page 11.
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Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on the required style in the Styles and 
Formatting window and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each style dialog has several 
tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection
To update a style from a selection:

1) Open the Styles and Formatting window.

2) In the document, select an item that has the format you want to adopt as a style.

Caution Make sure that there are unique properties in this paragraph. For example, if there 
are two different font sizes or font styles, that particular property will remain the 
same as before.

3) In the Styles and Formatting window, select the style you want to update (single-click, not 
double-click), then click on the arrow next to the New Style from Selection icon and click 
on Update Style.

Figure 3: Updating a style from a selection

Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the 
Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a 
paragraph or frame using this style in your document automatically updates the style itself.

Tip
If you are in the habit of manually overriding styles in your document, be sure that 
AutoUpdate is not enabled.

Updating styles from a document or template
You can update styles by copying or loading them from a template or another document. See 
“Copying styles from a template or document” on page 11.
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Creating new (custom) styles

You may want to add some new styles. You can do this in two ways:

• Creating a new style using the Style dialog

• Creating a new style from a selection

Creating a new style using the Style dialog
To create a new style using the Style dialog, right-click in the Styles and Formatting window and 
select New from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-
click and select New.

If you link styles, then when you change the base style (for example, by changing the font from 
Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you 
want; other times you do not want the changes to apply to all the linked styles. It pays to plan 
ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. 
See the chapters on styles in the user guides for details.

Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to 
this document; it will not be saved in the template.

1) Open the Styles and Formatting window and choose the type of style you want to create.

2) In the document, select the item you want to save as a style.

3) In the Styles and Formatting window, click on the New Style from Selection icon.

4) In the Create Style dialog, type a name for the new style. The list shows the names of 
existing custom styles of the selected type. Click OK to save the new style.

Figure 4: Naming a new style created from a selection

Dragging and dropping to create a style
You can drag and drop a text selection into the Styles and Formatting window to create a new 
style.

Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are 
active, the paragraph style will be added to the list. If Character Styles are active, the character 
style will be added to the list.
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Calc
Drag a cell selection to the Styles and Formatting window to create cell styles.

Draw/Impress
Select and drag drawing objects to the Styles and Formatting window to create graphics styles.

Copying styles from a template or document

You can copy styles into a document by loading them from a template or from another document:

1) Open the document you want to copy styles into.

2) In the Styles and Formatting window, click on the arrow next to the New Style from 
Selection icon, and then click on Load Styles (see Figure 3).

3) Select the categories of styles to be copied. Select Overwrite if you want the styles being 
copied to replace any styles of the same names in the document you are copying them 
into.

4) On the Load Styles dialog (Figure 5);

• To copy the styles from a template, find and select the template.

• To copy the styles from another document, click the From File button to open a window 
from which you can select the required document.

Figure 5. Copying styles from a template into the open document

4) Click OK to copy the styles. You will not see any change on screen.

Caution If your document has a table of contents, and if you have used custom styles for 
headings, the heading levels associated with outline levels in Tools > Outline 
Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you 
load styles. You will need to change these back to your custom heading styles.

Deleting styles

You cannot remove (delete) any of LibreOffice’s predefined styles from a document or template, 
even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the 
styles are not in use in the current document. If an unwanted style is in use, you will want to 
replace it with a substitute style.
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To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting window 
and click Delete on the context menu.

If the style is not in use, you receive a confirmation message; click Yes to delete the style. If the 
style is in use, you receive a warning message asking you to confirm deletion.

Caution
Make sure the style is not in use before deletion. Otherwise, all objects with that 
style will return to the default style and retain their formatting as manual formatting.

Using a template to create a document

To use a template to create a document:

1) From the main menu, choose File > New > Templates. The Template Manager dialog 
opens.

2) From the tabs at the top of the dialog, select the category (type) of template you want to 
use. Folders containing templates are listed in category page of the dialog. If no folders are 
visible, there are no templates available.

3) Double-click the folder that contains the template that you want to use. All the templates 
contained in that folder are listed on the page (as shown in Figure 6).

Figure 6: Template Manager dialog

4) Select the template that you want to use. If you wish to view the template’s properties, click 
the Properties button above the list of templates. The template’s properties appear in a 
pop-up window. Click Close to close this pop-up window.

5) Double-click on the required template. A new document based on the selected template 
opens in LibreOffice.
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Creating a template

Note

In a new installation, only the MediaWiki folder in Documents, and the Presentation 
Backgrounds folder in Presentations are visible. Other folders become visible only 
when content is added (My Templates, for example). If this is the case when you 
come to save your template, follow the instructions in Saving a template to a hidden 
folder on page 14, to save your template to one of these folders, or to another user 
folder. In an upgrade, other folders will be visible if you had other than the default 
installation templates saved.

You can create your own templates in two ways: from a document or using a wizard.

Creating a template from a document
To create a template from a document and save it to My Templates:

1) Open a new or existing document of the type you want to make into a template (text 
document, spreadsheet, drawing, or presentation).

2) Add the content and styles that you want.

3) From the Menu bar, choose File > Save As Template. The Template Manager dialog 
opens at the Documents page.

4) If the My Templates folder is visible, select it. If it is not, from the tabs at the top of the 
dialog, select a category in which the folder is visible and select it.

Note

It does not matter which tab is selected. The object is to select a My Documents 
folder. The template will be automatically saved into the My Documents folder in the 
correct page (tab), according to the meta-data stored in the properties of the file.

To learn more about template folders, see “Organizing templates” on page 20.

5) Click Save.

6) In the dialog that opens, type a name for the new template and click Accept. You can view 
the My Templates folder on the relevant page to confirm the template is correctly located.

7) Close the Template Manager dialog.

Figure 7: Saving a new template
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Any settings that can be added to or modified in a document can be saved within a template. For 
example, below are some of the settings (although not a full list) that can be included in a Writer 
document and then saved in the template for later use:

• Printer settings: which printer, single-sided or double-sided printing, paper size, and so on

• Styles to be used, including character, page, frame, numbering and paragraph styles

• Format and settings regarding indexes, tables, bibliographies, table of contents

Templates can also contain predefined text, saving you from having to type it every time you create 
a new document. For example, a letter template may contain your name, address, and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing 
LibreOffice, for more information.

Saving a template to a hidden folder
This procedure is for an installation that has yet to have any user installed templates in place. 
Because empty template folders are hidden in the Template Manager, a work-around is necessary 
to save the first template into a My Templates folder.

Tip You can also import a template into a hidden folder by using a similar technique.

It does not matter what document type you are saving as a template, text, spreadsheet, drawing or 
presentation, follow this procedure. In this example we will save a drawing document which we will 
title Floor Plan, as a template. Selecting the Drawings tab before starting shows a completely 
empty category listing (this is our first save).

1) Choose File > Save As Template. The Template Manager Save dialog opens at the 
Documents page. Click once on the MediaWiki folder to select it.

2) Click Save, specify the template name in the pop-up dialog (for example, Floor Plan), and 
click Accept. The template is saved into the MediaWiki folder. This appears in the 
MediaWiki folder in the category of the file type being saved (in our example Drawings).

Figure 8: Saving into MediaWiki in Documents

3) Close the Template Manager Save dialog. Open the Template Manager and select the 
category tab of the template type just saved (Drawings in the example). Double-click the 
MediaWiki folder to open it. Select the template you just added. The file handling controls 
are displayed.
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Figure 9: Moving a file to My Templates

4) Click on Move to folder to open a menu of destination folders. Select a destination folder 
for the template. In the example above, My Templates is selected. The file is moved.

5) Now click on All Templates. The My Templates folder is no longer hidden and shows the 
Floor Plan template file in the folder.

Figure 10: My Templates folder is no longer hidden

Note
The procedure outlined above could also have been carried out using the 
Presentations Backgrounds folder as the starting folder.

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, agendas, and to create presentations, 
and Web pages.

For example, the Fax Wizard guides you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax), salutation, and 
complementary close

• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)
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To create a template using a wizard:

1) From the main menu, choose File > Wizards > [type of template required].

Figure 11. Creating a template using a wizard

2) Follow the instructions on the pages of the wizard. This process is slightly different for each 
type of template, but the format is very similar.

3) In the last section of the wizard, you can specify the template name which will show in the 
Template Manager, and also the name and location for saving the template. The two 
names can be different but may cause you confusion if you choose two different names. 
The default location is your user templates directory, but you can choose a different 
location if you prefer.

4) Selecting the Path button to set the file name, and perhaps change the directory, causes 
the Save As dialog to open. Setting the file name and clicking Save closes the dialog.

5) Finally, you have the option of creating a new document from your template immediately, or 
manually changing the template by clicking Finish. For future documents, you can re-use 
the template created by the wizard, just as you would use any other template.

You may have to open the Template Manager and click Refresh on the Action menu to have any 
new templates appear in the listings.

Note
Clicking Finish reopens the Save As dialog in which you set the file name. Clicking 
Save at this point causes the file to be saved and the template to open. It was not 
saved in Step 4.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to documents that were created from that template. (Note that you can only reapply styles. 
You cannot reapply content.)

To edit a template:

1) From the main menu, choose File > New > Templates. The Template Manager dialog 
opens.

2) Navigate to the template that you want to edit. Click once on it to activate the file handling 
controls (see Figure 9). Click Edit. The template opens in LibreOffice.

16 Using Styles and Templates



3) Edit the template just as you would any other document. To save your changes, choose 
File > Save from the main menu.

Updating a document from a changed template
The next time you open a document that was created from the changed template, the following 
message appears.

Figure 12. Update styles message

Click Update Styles to apply the template’s changed styles to the document. Click Keep Old 
Styles if you do not want to apply the template’s changed styles to the document (but see the 
Caution notice below).

Caution 
If you choose Keep Old Styles in the message box shown in Figure 12, that 
message will not appear again the next time you open the document after 
changing the template it is based on. You will not get another chance to update the 
styles from the template, although you can use the macro given in the Note below 
to re-enable this feature.

Note

To re-enable updating from a template:

1) Use Tools > Macros > Organize Macros > LibreOffice Basic. Select the 
document from the list, click the expansion symbol (+ or triangle), and select 
Standard. If Standard has an expansion symbol beside it, click that and select a 
module.

2) If the Edit button is active, click it. If the Edit button is not active, click New.

3) In the Basic window, enter the following:
Sub FixDocV3 
' set UpdateFromTemplate 
 oDocSettings = ThisComponent.createInstance( _ 
  "com.sun.star.document.Settings" ) 
 oDocSettings.UpdateFromTemplate = True 
End Sub 'FixDocV3

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

The next time you open this document, you will be prompted to update the styles 
from the modified template.

Adding templates obtained from other sources

You can download templates for LibreOffice from many sources, including the official template 
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites 
you may find collections of templates that have been packaged into extension (OXT) files. These 
are installed a little differently, as described below.
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Installing individual templates
To install individual templates:

1) Download the template and save it anywhere on your computer.

2) Import the template into a template folder by following the instructions in “Importing a 
template“ on page 22.

Tip

(For advanced users) If you know the location of LibreOffice template folders, you 
can manually copy new templates into them. The location varies with your 
computer’s operating system. To learn where the template folders are stored on 
your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. Follow these steps:

1) Download the extension package (.OXT file) and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension 
Manager dialog (Figure 13), click Add to open a file browser window.

Figure 13: Newly-added package of templates

3) Find and select the package of templates you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, the templates are available for use through File 
> New > Templates and the extension is listed in the Extension Manager.
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See Chapter 14, Customizing LibreOffice, for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, 
Presentation, or Drawing) from the main menu, LibreOffice creates the document from the default 
template for that type of document. You can, however, set a custom template to be the default. You 
can reset the default later if you choose.

Note for
Windows

users

You may know that Microsoft Word employs a normal.dot or normal.dotx 
file for its default template and how to regenerate it.

LibreOffice does not have a similar default template file; the “factory defaults” are 
embedded within the software.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the 
Template Manager dialog.

To set a custom template as the default:

1) From the main menu, choose File > New > Template.

2) In the Template Management dialog, open the folder containing the template that you want 
to set as the default, then select the template.

3) Click the Set as default icon above the list of templates (see Figure 9).

The next time that you create a document by choosing File > New, the document will be created 
from this template.

Although many important settings can be changed in the Tools > Options dialog (see Chapter 2) 
for the default template, for example default fonts and page size, more advanced settings (such as 
page margins) can only be changed by replacing the default template with a new one.

Resetting the default template
To re-enable LibreOffice’s default template for a document type as the default:

1) In the Template Manager dialog, click the Action Menu icon on the right

2) Point to Reset Default Template on the drop-down menu, and click Text Document (or 
other template type).

These choices do not appear unless a custom template has been set as the default, as 
described in the previous section.

The next time that you create a document by choosing File > New, the document will be created 
from the default template for the document type.
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Figure 14: Resetting the default template for text documents

Associating a document with a different template

At times you might want to associate a document with a different template, or perhaps you are 
working with a document that did not start from a template.

One of the major advantages of using templates is the ease of updating styles in more than one 
document, as described on page 17. If you update styles by loading a new set of styles from a 
different template (as described on page 11), the document has no association with the template 
from which the styles were loaded—so you cannot use this method. What you need to do is 
associate the document with the different template.

Note
In LibreOffice 3.x, you could use the Template Changer extension to simplify this 
process. Unfortunately, this extension does not work in LibreOffice 4.0.

For best results, the names of styles should be the same in the existing document and the new 
template. If they are not, you will need to use Edit > Find & Replace to replace old styles with new 
ones. See Chapter 4, Getting Started with Writer, for more about replacing styles using Find & 
Replace.

1) Use File > New > Templates. In the Template Manager dialog, double-click the template 
you want to use. A new document opens, containing any text or graphics that were in the 
template. Delete any unwanted text or graphics from this new document.

2) Open the document you want to change. (It opens in a new window.) Press Ctrl+A to select 
everything in the document. Click in the blank document created in step 1. Press Ctrl+V to 
paste the content from the old document into the new one.

3) Update the table of contents, if there is one. Use Save As to save this file with the name of 
the file from which content was taken. Close the old file without saving.

Organizing templates

LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, you might 
have one template folder for report templates and another for letter templates. You can also import 
and export templates.
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To begin, choose File > New > Templates to open the Template Manager dialog.

Figure 15: Template file handling icons

Creating a template folder
To create a template folder:

1) In the Template Manager dialog, doube-click any folder, then click any template to activate 
the row of icons above the list of templates (see Figure 15).

2) Click the Move to folder button and choose New folder from the drop-down menu.

3) In the pop-up dialog, type a name for the new folder and click Accept.

Deleting a template folder
You cannot delete template folders supplied with LibreOffice or installed using the Extension 
Manager; you can only delete template folders that you have created.

To delete a template folder that you have created:

1) In the Template Manager dialog, select the folder that you want to delete.

2) In the row of icons above the list of folders, click the Delete button. A message box 
appears, asking you to confirm the deletion. Click Yes.

Caution
Folders which contain no files are hidden. If the folder is visible, ensure that you 
want to delete the files that are inside. You may have to put a dummy template into 
an empty folder in order to delete it (just select File > Save As Template for any file 
you have opened, move it into the folder to be deleted, and then delete the folder; 
see Figure 15).

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to move.

2) Click the template that you want to move and click the Move to folder button above the list 
of templates (see Figure 15).
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Deleting a template
You cannot delete templates supplied with LibreOffice or installed using the Extension Manager; 
you can only delete templates that you have created or imported.

To delete a template:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to delete.

2) Click the template that you want to delete.

3) Click the Delete button above the list of templates. A message box appears and asks you 
to confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.

To import a template into a template folder:

1) In the Template Manager dialog, select the folder into which you want to import the 
template.

2) Click the Import button above the list of template folders. A standard file browser window 
opens.

3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected folder.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to export.

2) Click the template that you want to export.

3) Click the Export button above the list of template folders. The Save As window opens.

4) Find the folder into which you want to export the template and click Save.

Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There 
are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other 
pages in the document. For example, the first page of a letterhead typically has a different header, 
or the first page of a report might have no header or footer, while the other pages do. With 
LibreOffice, you can define the page style for the first page and specify the style for the following 
pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with LibreOffice.
Figure 16 shows what we want to happen: the first page is to be followed by the default page, and 
all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting 
Pages, in the Writer Guide.
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Figure 16: Flow of page styles

Dividing a document into chapters
In a similar way, you can divide a document into chapters. Each chapter might start with the First 
Page style, with the following pages using the Default page style, as above. At the end of the 
chapter, insert a manual page break and specify the next page to have the First Page style to start 
the next chapter, as shown in Figure 17.

Figure 17: Dividing a document into chapters using page styles

Changing page orientation within a document
A Writer document can contain pages in more than one orientation. A common scenario is to have 
a landscape page in the middle of a document, whereas the other pages are in a portrait 
orientation. This can also be done with page breaks and page styles.

Different headers on right and left pages
Page styles can be set up to have the facing left and right pages mirrored or only right (first pages 
of chapters are often defined to be right-page only) or only left. When you insert a header on a 
page style set up for mirrored pages or right-and-left pages, you can have the contents of the 
header be the same on all pages or be different on the right and left pages. For example, you can 
put the page number on the left-hand edge of the left pages and on the right-hand edge of the right 
pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically
Writer automatically flows text from one page to the next. If you do not like the default settings, you 
can change them. For example, you can require a paragraph to start on a new page or column and 
specify the style of the new page. A typical use is for chapter titles to always start on a new right-
hand (odd-numbered) page.
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Compiling an automatic table of contents
To compile an automatic table of contents, first apply styles to the headings you want to appear in 
the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which 
level in the table of contents. See Chapter 4 for more information.

Defining a sequence of styles
You can set up one paragraph style so that when you press Enter at the end of that paragraph, the 
following paragraph automatically has the style you wish applied to it. For example, you could 
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example 
would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text 
Body. By setting up these sequences, you can avoid manually applying styles in most cases.

24 Using Styles and Templates


	Copyright
	Contributors
	Feedback
	Acknowledgments
	Publication date and software version

	Note for Mac users
	What is a template?
	What are styles?
	Applying styles
	Using the Styles and Formatting window
	Using Fill Format Mode
	Using the Apply Style list
	Using keyboard shortcuts

	Modifying styles
	Changing a style using the Style dialog
	Updating a style from a selection
	Using AutoUpdate
	Updating styles from a document or template

	Creating new (custom) styles
	Creating a new style using the Style dialog
	Creating a new style from a selection
	Dragging and dropping to create a style

	Copying styles from a template or document
	Deleting styles
	Using a template to create a document
	Creating a template
	Creating a template from a document
	Saving a template to a hidden folder
	Creating a template using a wizard

	Editing a template
	Updating a document from a changed template

	Adding templates obtained from other sources
	Installing individual templates
	Installing collections of templates

	Setting a default template
	Setting a custom template as the default
	Resetting the default template

	Associating a document with a different template
	Organizing templates
	Creating a template folder
	Deleting a template folder
	Moving a template
	Deleting a template
	Importing a template
	Exporting a template

	Examples of style use
	Defining a different first page for a document
	Dividing a document into chapters
	Changing page orientation within a document
	Different headers on right and left pages
	Controlling page breaks automatically
	Compiling an automatic table of contents
	Defining a sequence of styles


