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Note for Mac users
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Windows or Linux Mac equivalent Effect
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Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the 
functions apply to a selected object or a group of selected objects, which can be distinguished by 
selection handles on a rectangular frame that is large enough to contain the object. Where several 
objects are selected, the frame around the objects corresponds to the smallest rectangle that can 
contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles will change depending on the tool and 
function that has been selected to change the object properties. The color of the 
selection handles may also depends on the computer operating system and how the 
computer has been set up.

Object selection

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. One click selects; a second click deselects. To select or deselect 
more than one object, hold the shift button down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. This 
cursor dragging draws a rectangle around the objects and only objects that lie entirely within the 
rectangle will be selected.

To select multiple objects by framing, the Select icon  on the Drawing toolbar must be active.

Note
When dragging the mouse cursor to select multiple objects, the selection rectangle 
being drawn is also known as a marquee.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the 
Alt key and click on the object at the front of where the hidden object is located, then click again to 
select the hidden object. If there are several hidden objects, keep holding down the Alt key and 
clicking until you reach the object you want. To cycle through the objects in reverse order, hold 
down the Alt+Shift keys and click.

When you click on the selected object, its outline will appear briefly through the objects covering it.

Note
Using the Alt key method works on computers using a Windows or Mac operating 
systems. On a computer using a Linux operating system the Tab key method, 
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle 
through the objects, stopping at the object you want to select. To cycle through the objects in 
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be 
practical if there a large number of objects in a drawing.
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. To rearrange the 
stacking order by moving an object forward or backward, select an object, click Modify > Arrange 
on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the 
object, select Arrange from the context menu, then Bring Forward or Send Backward.

The Arrange options are also available by clicking on the small triangle or arrow to the right of the 

Arrange icon  on the Drawing toolbar. This opens the Position toolbar giving access to the 
various arrangement options.

Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the 
bottom of the Draw window (Figure 1). The area on the left of the Drawing toolbar, from left to right, 
shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the 
object. The units of measurement are those selected in Tools > Options > LibreOffice Draw > 
General.

Figure 1: Left end of status bar when moving or adjusting an object

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold 
down the left mouse button while dragging the mouse. During movement, the shape of the object 
appears as dotted lines to help with repositioning (Figure 2). To locate the object at its new 
location, release the mouse button.

Figure 2: Moving an object

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to 
one of the selection handles. The mouse cursor will change shape to indicate the direction of 
movement for that selection handle. As you change the size of the object, a ghosted outline of the 
object appears (Figure 3). When you have reached the desired size of the object, release the 
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side handle. To resize along both axes, use a corner handle.
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Figure 3: Adjusting object size

Note

If you press the Shift key while resizing an object, the change in size will be carried 
out symmetrically with respect to the two axes so that the aspect ratio of the object  
remains the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is the aspect ratio will be preserved unless 
the Shift key is pressed.

Modifying an arc
The size of an arc can be changed by adjusting position of the start and end points of an arc. 

Select an arc and click on the Points icon  on the Drawing toolbar. Two larger handles appear 
at the start and end of the arc (Figure 4). When the mouse cursor hovers over one of these larger 
handles, the cursor changes shape allowing you to adjust the position of either the start or end 
points of the arc.

Figure 4: Modifying an arc

Rotating and slanting an object

Rotating an object
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of 
the following methods:

• Click on the object again. Do not double click as this will cancel object selection.

• Click on the Rotate icon  on the Drawing toolbar.

• Go to View > Toolbars > Mode and select the Rotate icon .
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Figure 5: Rotating an object

The selection handles will change shape and color (Figure 5). Also a center of rotation point will 
appear in the center of the object. As you move the mouse cursor over the handles the cursor 
changes shape. The corner handles are for rotating an object and the top, bottom and side handles 
are to shear or slant an object.

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an 
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the 
object. A dotted outline of the object being rotated appears and the current angle of rotation is 
shown in the status bar.

Note
Rotation works in a slightly different way for 3D objects because rotation occurs in a  
three dimensional plane and not in a single plane. See Chapter 7 Working with 3D 
Objects for more information.

The rotation point is normally located at the center of an object. To change the position of the 
rotation point, click on the object with the mouse cursor and drag the object until the rotation point 
is at the desired position. This rotation point can even be outside of the object.

Note

If you press the Shift key while rotating an object, rotation will be restricted to 15° of 
movement.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is rotation will be restricted to 15° of 
movement unless the Shift key is pressed.

Slanting an object
To slant an object, use the handles located at the midpoints on the top, bottom and sides of a 
selected object. The mouse cursor changes when it hovers over one of these midpoint handles. 
The axis used for slanting an object is the object edge directly opposite the midpoint handle being 
used to slant the object. This axis stays fixed in location while the other sides of the object move in 
relation to it as you drag the mouse cursor.

Click and hold the mouse button, then start to move the cursor to shear the object. A dotted outline 
of the object being slanted appears (Figure 6) and the current angle of slanting is shown in the 
status bar.
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Figure 6: Shearing an object

Note

If you press the Shift key while slanting an object, slanting will be restricted to 15° of 
movement.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is slanting will be restricted to 15° of 
movement unless the Shift key is pressed.

Setting exact size and position

You can position and resize objects with the mouse, but this method is not exact. If you want to 
accurately position and size an object, go to Format > Position and Size on the main menu bar, 
or right-click on an object and select Position and Size from the context menu, or press the F4 
key. This will open the Position and Size dialog (Figure 7).

Figure 7: Position and Size dialog
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Position and Size
Open the Position and Size dialog and click on the Position and Size tab (Figure 7) to set the 
appropriate values.

Position is defined using X/Y coordinates relative to a base point. You change the X/Y coordinates 
using the text boxes in the Position section.

Width and height of an object are also defined relative to a base point. You change the width and 
height of an object using the text boxes in the Size section. To keep the ratio of width to height, 
select the Keep ratio option.

The units of measurement used for X//Y coordinates and the width and height of the object are set 
by going to Tools > Options > LibreOffice Draw > General.

The default location of the base points for position and size is the upper left corner of the drawing 
area. You can temporarily change this base point to make positioning or dimensioning simpler by 
clicking on a radio button corresponding to the location of the base point you want to use. This 
change in base point is only valid for single use and the base point is reset to the standard position 
of top left corner when you close the Position and Size dialog.

To prevent either or both size and position from being inadvertently changed, select the appropriate 
options in the Protect section.

Rotating objects
To accurately rotate an object, click on the Rotation tab of the Position and Size dialog (Figure 8). 
This dialog lets you define the rotation angle, as well as the location of the pivot point.

Figure 8: Rotating an object

The pivot point is positioned using X/Y coordinates that are relative to the position of the pivot 
point. The default setting for the pivot point is the center of an object. This pivot point can be 
moved by checking on of the radio buttons in Default settings.

The rotation angle can be accurately set using the text box in the Rotation angle section. To quickly 
rotate an object in increments of 45deg, check one of the radio buttons in the Default settings. The 
default setting for rotation is zero degrees.
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Changing the pivot point and/or rotation angle of an object is only valid for single use. The pivot 
point and rotation angle are reset to their default settings when you close the Position and Size 
dialog.

Slant and corner radius
To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius 
tab of the Position and Size dialog (Figure 9).

Figure 9: Setting slant angle and corner radius

A corner radius can be applied to any object that has sharp corners, such as rectangles, squares, 
or text boxes. If the Corner radius section is grayed out, then you cannot set a corner radius. The 
larger the value for corner radius set in the Radius text box, the rounder the corners of an object 
become.

Slant angle relates to how much an object inlines or slants from its normal vertical position on a 
drawing. To accurately change the slant angle of an object, enter the number of degrees in the 
Slant Angle text box.

Changing form of regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the 
selection handles when an object is selected. When the mouse cursor hovers over one of these 
dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the 
object. For example, you can increase the corner radius of a rounded rectangle or square, change 
the angles of an arc, and so on.

These dots perform a different function according to the shape selected and these functions are 
listed in the following sections.

Basic Shapes

• Rounded rectangles and squares: use the dot to change the radius of the curve that 
replaces the angled corners of a rectangle or square.

• Circle pie: use the dots to change the size of the filled sector.

• Isosceles triangle: use the dot to modify the triangle type.

• Trapezoid, parallelogram, hexagon, or octagon: use the dot to change the angle between 
the sides.

• Cross: use the dot to change the thickness of the four arms of the cross.

• Ring: use the dot to change the internal diameter of the ring.

• Block arc: use the dot to change both internal diameter and size of the filled area.

• Cylinder and cube: use the dot to change the perspective.

• Folded corner: use the dot to change the size of the folded corner.

• Frame: use the dot to change the thickness of the frame.
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Symbol Shapes

• Smiley face: use the dot to change the smile on the face.

• Sun, moon, heart: use the dot to change the shape of the symbol.

• Prohibited symbol: use the do to change the thickness of the ring and the diagonal bar.

• Double bracket, left bracket, right bracket, double brace: use the dot to change the 
curvature of the bracket.

• Left brace, right brace: use the dots to change the curvature of the brace and the position 
of the point.

• Square bevel, octagon bevel, diamond bevel: use the dot to change the thickness of the 
bevel.

Block Arrows

• Arrows: use the dot to change the shape and thickness of the arrows.

• Pentagon, chevron: use the dot to change the angle between the sides.

• Arrow callouts: use the dots to change the shape and thickness of the callouts.

• Circular arrow: use the dots to change the thickness and area of the arrow.

Callouts

• Callouts: use the dots to change the length, position and angle of the pointer.

Stars

• 4-point star, 8-point star, 24-point star: use the dot to change the thickness and shape of 
the star points.

• Vertical scroll, horizontal scroll: use the dot to change the width and shape of the scroll.

• Doorplate: use the dot to change the inward curvature of the corners.

Curves and polygons

Bézier curves

The editing of curves depends on the mathematics of Bézier curves1. Explaining Bézier curves 
goes beyond this scope of this guide and only the basics are covered here. See Chapter 10 
Advanced Draw Techniques for more information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through 
these points. Each tangent has one control point at each end and a junction point where it meets 
the curve. The relative angle and distance between the control points determine the shape of the 
curve. Figure 10 shows what happens starting from a basic circle and changing only one point on 
the circle.

You can create many different shapes by moving either the junction point itself, or one or both of 
the round handle points at either end of the tangent. Draw offers more possibilities when you use 
the functions on the Edit Points toolbar.

1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, 
who developed the technique in the 1960s. The technology was intended to make modeling the surface 
of vehicles easier.
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Figure 10: Creating different shapes by changing the tangent

Converting to a curve or polygon
Before modifying the points on an object, it must first be converted to a curve or a polygon, 
depending on what kind of effect you want to produce.

After selecting an object, go to Modify > Convert and select either To Curve or To Polygon. 
Alternatively, right click on an object and then select Convert > To Curve or Convert > To 
Polygon from the contextual menu that pops up.

After converting an object to a curve or polygon and the Points icon  on the Drawing toolbar is 
active, the Edit Points toolbar opens and become active when selected in View > Toolbars > Edit 
Points on the main menu bar..

You will notice that after the conversion, the handles located in the corners of the selection 
rectangle have disappeared. This behavior is normal because the handles used with the tools on 
the Edit Points toolbar are located along the outline or trace of the object.

Edit Points toolbar
Open the Edit Points toolbar (Figure 11) by going to View > Toolbars > Edit Points on the main 
menu bar. It will then appear whenever you select an object that is a curve or polygon and the Edit 

Points icon  on the Drawing toolbar. Available tools on the Edit Points toolbar will depend on 
the object selected and which object point has been selected.

Figure 11: Edit Points toolbar

Curves and polygons 9



Tangents

Note
Tangents are only used on curves. If an object has been converted to a polygon and 
a tangent is added, the object is automatically converted to a curve.

Symmetric transition

Click on the Symmetric Transition icon  to work with a symmetrical tangent (Figure 12). Any 
movement of one tangent handle is carried over symmetrically to the other handle.

Figure 12: Symmetric transition

Smooth transition

Click on the Smooth Transition icon  to separately adjust the lengths on each side of a 
tangent to make a curve flatter or steeper. This creates an asymmetric tangent and the curve is 
flatter on the longest side of the tangent (Figure 13).

Figure 13: Smooth transition

Corner point
It is possible to independently change the angle on each side of a tangent using the central point of 

the tangent as a corner point. Select a point on the curve, then click on the Corner Point icon  
to create a corner point from the selected point (Figure 14). When a corner point is created, you 
can change the angle on each tangent side to create spikes and troughs in curves.

Figure 14: Corner point

Tangent rotation
You can alter the angle of how a tangent relates to curve by clicking on one of the end points of a 
tangent and rotating it with the mouse cursor. As you change the angle of the tangent, the shape of 
the curve changes in response to the rotation of the tangent (Figure 15).
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Figure 15: Tangent rotation

Points

Moving Points

Click on the Move Points icon  to move any of the points when an object has been converted 
to a curve or polygon. When Move Points is active, the mouse cursor changes shape when it 
hovers over a point. Moving a point is an easy manipulations to do. Figure 16 illustrates an ovoid 
shape was created from a circle by dragging the right hand side point to the right.

Figure 16: Moving points

Inserting points

Click on the Insert Points icon  to add an extra point to an existing curve or polygon. Click on 
the object border at the spot where you want to insert a point. The tangent type associated with the 
new point depends on where the point has been added to the object border. Figure 17 shows a 
new point has been added to the top right of an ovoid shape.

Figure 17: Inserting points
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Deleting points

Click on the Delete Points icon  removes a point from the border of an object. The resulting 
curve automatically changes shape around the remaining points after deleting a point. Figure 18 
shows what happens when the right point was deleted from a circle. You can select several points 
by holding down the Shift key, then click on the Delete Points icon. You can also delete selected 
points by pressing the Del key on the keyboard.

If a curve has been converted to a line (see “Converting curves or lines” on page 13) and selected 
points are deleted, a straight line is formed between the two points on either side of the now 
deleted points.

Figure 18: Deleting points

Figure 19: Eliminating points
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Eliminating points

The Eliminate Points icon  only functions on lines with multiple points. These lines are created 

when a curve is converted to a line using the Convert to Curve icon  on the Edit Points toolbar 
(see “Converting curves or lines” on page 13).

Referring to Figure 19, eliminating points from a line and creating a straight line is as follows:

1) Select a line with multiple points and click on the Points icon on the Drawing toolbar. The 
Edit Points toolbar will open. If it does not open, then go to View > Toolbars > Edit Points 
on the main menu bar to open it.

2) Select the point on the line you want to eliminate with the mouse cursor. The selected point 
will be emphasized.

3) Make sure the Eliminate Points icon is active. The area around the icon becomes shaded 
when active. If not active, click on the Eliminate Points icon.

4) Accurately position the mouse cursor over the selected point, then click and hold the 
mouse button and start dragging the selected point. As you drag the selected point a dotted 
line forms between the two neighboring points.

5) When this dotted line appears to be a straight line between the two neighboring points, 
release the mouse button. The selected point has been eliminated and a straight line is 
formed between the two neighboring points.

Converting curves or lines
Curves or lines can be easily converted from a curve to a line or a line to a curve using the 

Convert to Curve icon  on the Edit Points toolbar. When a curve is converted to a line, a 
straight line is created between selected points on a curve. When a line is converted to a curve, a 
curve is created between selected points on a line.

Select a curve or line, then select the points on the curve or line where you want to do the 
conversion. Click on the Convert to Curve icon and the curve or line is converted (Figure 20).

Figure 20: Converting curves and lines

Splitting curves

Click on the Split Curve icon  to split or cut a curve at the location of the selected point. If the 
object is filled, it will be emptied because the curve that represented the object border is no longer 
closed (Figure 21).

The point where you split the curve is now larger than the remaining points visible on the curve, 
with the exception of the curve start point as this is also larger than the other points.
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You can separate a curve at several points simultaneously. Keep the Shift key pressed down and 
select all of the points at which the cut should occur, then click on the Split Curve icon. Deselect 
the curve, then you can then drag and drop segments with the mouse to move them from the 
original curve.

Figure 21: Splitting curves

Closing curves
To close an open and existing curve, first select the open curve, then select the start point of the 
curve. The start point is larger than the other points visible on the curve. Click on the Close Bézier 

icon  to close the curve (Figure 22).

If the open curve was originally a closed and filled curve, when the curve is closed the original 
color will fill the curve.

Figure 22: Closing curves

Rotating and distorting curves

To rotate and distort a curve, first select the curve then click on the Rotate icon  on the Mode 
toolbar. If the Mode toolbar is not open, go to View > toolbars > Mode or click on the small 
triangle or arrow to the right of the Rotate icon on the Drawing toolbar. The points on the curve 
change color and shape (Figure 23).

Select one of the points on the curve and move it by dragging the mouse cursor. Movement will be 
restricted to the original border of the curve.

Select one of the control points at the end of the tangent line and rotate the distorted curve by 
dragging the mouse cursor. The distorted curve will rotate about the center of rotation.
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Figure 23: Rotating and distorting curves
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