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What is Math?

Math is OpenOffice.org (O00)’'s component for writing mathematical equations. It is most
commonly used as an equation editor for text documents, but it can also be used with other types
of documents or stand-alone. When used inside Writer, the equation is treated as an object inside
the text document.

The equation editor is for writing equations in symbolic form, as in equation 1. If you

Note want to evaluate a numeric value, see the Calc Guide.

=In(x)+tan"' (x%) @

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Elements window (called
“Selection” before Math 3.2 and “Formula Elements” in Math 3.2) may appear. You will also see a
small box with a gray border in your document, where the formula will be displayed, as shown in
Figure 1.

[E] Untitled 1- LibreOffice Writer [=Jlax]
File Edit View Format Tools Window Help
BB H= B & B o .
L C1- 202-:0-3.4.05...6-+-7-.-8--9..10 . 11: 1 12, 13 . 14 .15 . 16 *
‘[§ Elements B
,_| asb asA £ T
; i N 7
'-.| (1] ] -
- )
r B
: +4 -4 +a Fa g g
+ r Ed
a+b a-b axb asb asb F =
a-b % azb a/b avb
aeob
< = ¥ -

Figure 1: Equation Editor, Elements window, and location of resulting equation
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Entering a formula

The equation editor uses a markup language to represent formulas. For example, %beta creates
the Greek character beta ( 8 ). This markup is designed to read similar to English whenever

. . a
possible. For example, a over b produces a fraction: b

You can enter a formula in three ways:
* Select a symbol from the Elements window.
* Right-click on the equation editor and select the symbol from the context menu.
* Type markup in the equation editor.

The context menu and the Elements window insert the markup corresponding to a symbol. This
provides a convenient way to learn the OOo Math markup.

Click on the document body to exit the formula editor.

etz Double-click on a formula to enter the formula editor again.

The Elements window

The simplest method for entering a formula is the Elements window.

[§ Elements

asb act f(x) 2a

i (2) .i;

+4 -d a4 F4 -a

Symbols

a+b a-b axb axb asb

a-b % azb a/b avb

fab

Figure 2: Symbols are divided into categories

The Elements window is divided into two main parts.
* The top shows the symbol categories. Click on these to change the list of symbols.
* The bottom shows the symbols available in the current category.

Tip You can hide or show the Elements window with View > Elements.

Example 1: §X4

For this example we will enter a simple formula: 5 X4 . On the Elements window:
1) Select the top-left button of the categories (top) section.

Entering a formula



2) Click on the multiplication symbol.

‘[ Elements

Unary/binary +a E
Qperatﬁrﬁ asb aeh -F[::} zl.'l

N (W %

Multiplicatione,] +a -a *a Fa -

Figure 3: Selecting the multiplication symbol

When you select the multiplication symbol on the Elements window, two things happen:
* The equation editor shows the markup: <?> times <7>
* The body of the document shows a gray box like this: dxU

=2

0 B9 E3

4 *

<?> times <?> | »

+ k3

Figure 4: Result of selecting the multiplication symbol

The <?> symbols shown in Figure 4 are placeholders that you can replace by other text, for
example 5 and 4. The equation will update automatically, and the result should resemble Figure 5.

To keep the equation from updating automatically, select View >AutoUpdate display.

Tip To update a formula manually, press F9 or select View > Update.
534t
B
3]
£ ¥
5 times 4 L
£ > .

Figure 5: Result of entering 5 and 4 next to the times operator
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Right-click (context) menu

Another way to access mathematical symbols is to right-click on the equation editor. This pops up
the menu shown in Figure 6. The items in this menu correspond exactly to those in the Elements
window.

5 times 4| . &
Unary/Binary Operators » +a
Relations ’ -8
Set Operations r +-a »
* ] Functions ’ -+a £
Operators , a+b I
Attributes C a-b
Brackets 3 a cdot b
Formats ’ a times b
Others v a*b S
aoverb
adivb
alb
acirch
a wideslash b
a widebslash b
neg a
aandb
aorb

Figure 6: Right-click (context) menu

Markup

You can type the markup directly in the equation editor. For example, you can type 5 times 4to
obtain 5X 4 . If you know the markup, this can be the fastest way to enter a formula.

Tip The formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command
a=h a=b Ja sqrt {a}
e an2 a, an
J' f(x)dx int f(x) dx Z a, suma_n
a<b a<=b 00 infinity
aXh atimesb Xy x cdoty

Entering a formula




Greek characters

Greek characters (x, B,y , 0, etc) are common in mathematical formulas. These characters are
not available in the Elements window or the right-click menu. Fortunately, the markup for Greek
characters is simple: Type a % sign followed by the name of the character, in English.

* To write a lowercase character, type the name of the character in lowercase.
* To write an uppercase character, type the name of the character in uppercase.

A complete table of Greek characters is provided on page 25. See the table below for some
examples.

Lowercase Uppercase

%alpha — (x %ALPHA — 4
%beta — %BETA — B
%gamma — vy %6GAMMA — T
%psi - Y %PSI 4
%phi - ¢ %PHI - ¢
%theta — %THETA — @®

Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools >
Catalog. This window is shown in Figure 7. Under Symbol set, select Greek and double-click on a
Greek letter from the list. The markup name of the character is shown below the list window.

[§ symbols
Symbol set l — l
Greek e
l Close l
ABT AEZH®I K AM?®
NEOQIIFZTTH$AY R l Edit... l
ﬂﬁ’?’@‘egnﬁcmaﬁt
v Eompe oo v ug X
w g e 0 p ¢
alpha

Figure 7: Symbols catalog, used for entering Greek characters and some special symbols

Example 2: Tt ~ 3.14159

For this example we will suppose that:
* We want to enter the above formula (the value of pi rounded to 5 decimal places).
* We know the name of the Greek character (pi).
* But we do not know the markup associated with the ~ symbol.
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Step 1: Type % followed by the text pi. This displays the Greek character 1t .
Step 2: Open the Elements window (View > Elements).

Step 3: The =~ symbol is a relation, so we click on the Relations button. If you hover the mouse
over this button you see the tooltip Relations (Figure 8).

Figure 9 shows the Selection window after clicking the Relations button. The symbol we want is
circled.

1

Elements [§ Elements Ed|

n ﬁ ash i) Za % aEA £ix)
m[ﬂ Gt a (8) ﬁf

+4 -0 ta Fa -a a=b a=b axb alb atb
a+b a-b axb axb arb a<b a>b||b alb
a-b % azb a/b avb asb azb a~b asb
asb azb azb asb a=b

Figure 8: Tooltip indicates the 6=b asb a=b

Relations button

Figure 9: After selecting Relations

Step 4: Click on the a ~ b symbol. The equation editor now shows the markup %pi<?> simeq
<?>.

Step 5: Delete the <?> text and add 3.14159 at the end of the equation. We end up with the
markup %pi simeq 3.14159. The result is shown in Figure 10.

LS 3._14159:

0 B8 D

pl simeg 3.14159

Figure 10. Final result
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Customizations

Formula editor as a floating window

The formula editor can cover a large part of the Writer window. To turn the formula editor into a
floating window, do this:
1) Hover the mouse over the editor frame, as shown in Figure 11.
2) Hold down the Control key and double-click.

=mc™?

§m 2

L]

Figure 11: Turning the formula editor into a floating window

Figure 12 shows the result. You can dock the floating window again by using the same steps. Hold
down the Control key and double-click the window frame.

[ commands

E=mc”™2

+

Ead

Figure 12: Formula editor as a floating window

How can | make a formula bigger?

This is one of the most common questions people ask about OO0 Math. The answer is simple, but
not intuitive:

1) Start the formula editor and choose Format > Font size.

[£] Untitled 1 - LibreOFffice Writer

File Edit View Format Tools

Window Help

=

F_ﬂnts. &

&Qnt Size...

Spacing...
Alignment...

Text Mode

H= B &

Figure 13: Changing the font size for a formula
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2) Select a larger font size under Base size (top-most entry)

[Y Font Sizes

Base size |12pt |:| oK

Relative sizes Cancel
Text 100% 2]
Indexes |50% |:| Default
Functions |1[}[}% |3|
Operators |10[}% 2]
Limits |50% B

Figure 14. Edit Base size (top) to make a formula bigger

The result of this change is illustrated in Figure 15.

Before: =23 4] 59
Adfter: m=3.14159

Figure 15. Result of changing the base font size

Formula layout

The most difficult part of using OO0 Math comes when writing complicated formulas. This section
provides some advice.

Brackets are your friends

000 Math knows nothing about order of operation. You must use brackets to state the order of
operations explicitly. Consider the following example.

Markup Result
2
2 over x + 1 =+1
X
2
2 over {x + 1}
x+1

Equations over more than one line
Suppose you want to type an equation covering more than one line. For example: i?

X
y

Formula layout 11



Your first reaction would be to simply press the Enter key. However, if you press the Enter key,
though the markup goes to a new line, the resulting equation does not. You must type the newline
command explicitly. This is illustrated in the table below.

Markup
X =3
y=1
X = 3 newline
y=1

Result
x=3y=1
x=3
y=1

How do | add limits to my suml/integral?

The sum and int commands can (optionally) take the parameters from and to. These are used for
lower and upper limits respectively. These parameters can be used singly or together. Limits for
integrals are usually treated as subscripts and superscripts.

Markup

sum from k =1 to n a k

Result

n
Zak
k=1

int from 0 to x f(t) dt x N
. | feyar o [ (1)
int_0rx f(t) dt v
int from Re f f S
R
sum to infinity 2/{-n} Z 9"
Note For more details on integrals and sums, see page 20.
Brackets with matrices look ugly!
For background, we start with an overview of the matrix command.
Markup Result
matrix { a # b ## c # d } a b
c d
Note Rows are separated by two #'s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not scale with the matrix:

12
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Markup Result

( matrix { a# b ## c #d } )

OO0 Math provides scalable brackets. That is, the brackets grow in size to match the size of their
contents. Use the commands left( and right) to make scalable brackets.

Markup Result

a b

left( matrix { a # b # c # d } right) J
c

Tip Use left[ and right] to obtain square brackets.

How do | make a derivative?
Making derivatives essentially comes down to one trick: Tell OOo it’s a fraction.

In other words, you have to use the over command. Combine this with either the letter d (for a total
derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.

Note Notice that we have to use braces (squiggly brackets) to make the derivative.

Markup Result
{df} over {dx} ﬁ
dx

_ . of
{partial f} over {partial y} —
dy

. . o f
{partial”r2 f} over {partial t"2} >
ot

How do | align my equations at the equals sign?

OO0 Math does not have a command for aligning equations on a particular character, but you can
use a matrix to do this, as shown below.

Markup Result
matrix{
alignr x+y # {}={} # alignl 2 ## xt+y = 2
alignr x # {}={} # alignl 2-y x = 2—y
}

The empty braces around = are necessary because = is a binary operator and thus needs an
expression on each side.

Formula layout 13



You can reduce the spacing around = if you change the inter-column spacing of the matrix:

1) With the equation editor open, choose Format > Spacing from the menu bar.

2) In the Spacing dialog (Figure 16), click the Category button and select Matrices in the
drop-down menu.

3) Enter 0% for Column spacing and click OK.

[§ Spacing w
Matrix =
Line spacing ‘3% |:| —
Column spacing p% B [QHC
b d Category ~
Default

Figure 16: Changing spacing in a matrix formula

Numbering equations

Equation numbering is one of OO0 Math’s best hidden features. The steps are simple, but
obscure:

1) Starta new line.
2) Type fn and then press F3.

The fn is replaced by a numbered formula:
2
E=mc (2

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta function:

C(Z)Ziiz 3)

n=1 N

You can reference an equation (“as shown in Equation (2)") with these steps:
1) Choose Insert > Cross-reference from the menu bar.
2) On the Cross-references tab (Figure 17), under Type, select Text.
3) Under Selection, select the equation number.
4) Under Format, select Reference.

Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the
equations will automatically renumber and the cross-references will update.

To insert the equation number without parentheses around it, choose Numbering

Tip instead of Reference under Format.
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[§ Fields
Document Cross-references Functions | Doclnformation | Variables Database
Type Selection
Set Reference (1
Insert Reference (2
Headings (3
Numbered Paragraphs
Text
| Figure
Bookmarks
Footnotes
Insert reference to Name
Page ‘:;‘_
Chapter
Reference Value
Above/Below
As Page Style ‘
Category and Number
Caption Text
Numbering
Insert l Close ] [ Help l

Figure 17. Inserting a cross-reference to an equation number

Numbering equations
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Math commands - Reference

Unary | binary operators

Operation Command Display
+sign +1 +1
—sign -1 —1
+/— sign +-1 *1
—/+ sign —+1 *1
Boolean not neg a -a
Addition + a+b a+b
Dot product acdotb a-b
Multiplication (X) atimes b axb
Multiplication (asterisk) a*b ax*b
Boolean ‘and’ aandb anb
Subtraction (-) a-b a—b
Division (as a fraction) aoverb %
Division (as an operator) adivb a+b
Division (with a slash) alb alb
Boolean ‘or’ aorb aVvb
Concatenation acircb a’b
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Relational operators

Operation Command Display
Is equal a=b a=b
Is not equal a<>b a#?2
Approximately a approx 2 a=?2
Divides a divides b alb
Does not divide a ndivides b ath
Less than a<2 a<?2
Greater than a>?2 a>?2
Similar to or equal asimeqg b a=b
Parallel a parallel b allb
Orthogonal to aorthob alb
Less than or equal to aleslant b a<b
Greater than or equal to a geslant b a=b
Similar to asimb a~b
Congruent aequivb a=b
Less than or equal to a<=b a<b
Greater than or equal to a>=b a=b
Proportional apropb ach
Toward atoward b a—b
Arrow left adlarrow b a<b
Double arrow left and right a dlrarrow b a=b
Arrow right a drarrow b a=b

Math commands - Reference
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Set operations

Operation Command Display
Is in ainB a€B
Is not in a notin B a¢B
Owns Aowns b A>b
Empty set emptyset 9
Intersection Aintersection B ANB
Union A union B AUB
Difference A setminus B A\B
Quotient Aslash B AlB
Aleph aleph N
Subset A subset B ACB
Subset or equal to A subseteq B ASB
Superset A supset B ADB
Superset or equal to A supseteq B A2B
Not subset A nsubset B AZ B
Not subset or equal A nsubseteq B AZB
Not superset A nsupset B ADB
Not superset or equal A nsupseteq B AZB
Set of natural numbers setN IN
Set of integers setZ Z
Set of rational numbers setQ Q
Set of real numbers setR R
Set of complex numbers setC C
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Functions

Operation Command Display
Exponential func e*a} e’

Natural logarithm In(a) In(a)
Exponential function exp(a) exp(a)
Logarithm log(a) log(a)
Power a™b} a®

Sine sin(a) sin(a)
Cosine cos(a) cos(a)
Tangent tan(a) tan(a)
Cotangent cot(a) cot (a)
Square root sqrt{a} Ja
Arcsine arcsin(a) arcsin (a)
Arc cosine arccos(a) arccos(a)
Arctangent arctan(a) arctan (a)
Arc cotangent arccot(a) arccot(a)
n" root nroot{a}{b} b
Hyperbolic sine sinh(a) sinh (a)
Hyperbolic cosine cosh(a) cosh(a)
Hyperbolic tangent tanh(a) tanh(a)
Hyperbolic cotangent coth(a) coth (a)
Absolute value abs{a} d

Arc hyperbolic sine arsinh(a) arsinh (a)
Arc hyperbolic cosine arcosh(a) arcosh(a)
Arc hyperbolic tangent artanh(a) artanh(a)
Arc hyperbolic cotangent arcoth(a) arcoth(a)
Factorial fact{a} a!l

Math commands - Reference

19



Operators

All operators can be used with the limit functions (“from” and “to”).

Upper and lower bounds shown with
integral

Integral
Double integral

Triple integral

Lower bound shown with summation
symbol

Contour integral
Double curved integral

Triple curved integral

Upper bound shown with product
symbol

int from {r_O}to {r_t} a

int{a}

iint{a}

iiint{a}

sum from{3}b
linta

llint a

lllint a

prod to{3}r

Operation Command Display
Limit lim{a} lima
Sum sum{a} Z a
Product prod{a} [la
Coproduct coprod{a} H a

20
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Attributes

Operation Command Display
Acute accent acute a a
Grave accent grave a a
Reverse circumflex check a a
Breve breve a a
Circle circle a a
Vector arrow vec a a
Tilde tilde a a
Circumflex hat a a
Line above bar a a
Dot dot a a
Wide vector arrow widevec abc abc
Wide tilde widetilde abc abc
Wide circumflex widehat abc abc
Double dot ddot a a
Line over overline abc abc
Line under underline abc abc
Line through overstrike abc acb
Triple dot dddot a a
;ir\:;lg:p:iazrs)nt (useful to get a placeholder of a phantom a

Bold font bold a a
Italic font1 ital “a” a
Resize font size 16 qv qv
Following item in sans serif font2 font sans qv qv
Following item in serif font font serif qv qv
Following item in fixed font font fixed qv qv
Make color of following text cyan3 color cyan qv qv

Unquoted text that is not a command is considered to be a variable. Variables are, by default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non-proportional).
To change the actual fonts used for custom fonts and the fonts used for variables (unquoted text),
numbers and functions, use Format > Fonts.

3 For all coloring, the color will apply only to the text immediately following the command until the next
space is encountered. In order to have the color apply to more characters, place the text you want in color
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Operation Command Display

Make color of following text yellow color yellow qv

Make color of following text white color white qv

Make color of following text green color green gqv qv

Make color of following text blue color blue qv qv

Make color of following text red color red qv qv

Make color green returns to default color black color green X qv Xqv

i?é{rfe items to change color of more than one color green {X qu} Xqv
Miscellaneous

Operation Command Display

Infinity infinity 00

Partial partial 0

Nabla nabla Vv

There exists exists 3

For all forall \v/

H bar hbar 7]

Lambda bar lambdabar X

Real part re R

Imaginary part im 3

Weierstrass p wp %)

Left arrow leftarrow —

Right arrow rightarrow —

Up arrow uparrow T

Down arrow downarrow 4

Dots at bottom dotslow

Dots at middle dotsaxis

Dots vertical dotsvert

Dots diagonal upward dotsup

Dots diagonal downward dotsdown

in curly brackets.

22

LibreOffice 3 Math Guide




Brackets

Operation Command Display
Round Brackets (a) (a)
Square Brackets [b] [b]
Double Square Brackets Idbracket c rdbracket lc]
Single line line a rline la|
Double line dline a rdline ||al|
Braces Ibrace w rbrace {w}
Angle Brackets langle d rangle (d)
Operator Brackets langle a mline b rangle (alb)
Group brackets (used for program {a} a
control)

Scalable round brackets left ( stack{a # b # z} right ) a
(add the word “left” before a left b
bracket and “right” before a right

bracket) z
Square brackets scalable left [ stack{ x # y} right ] ]
(as above) V]
Double square brackets scalable left Idbracket c right rdbracket M
Line scalable left lline a right rline \a\
Double line scalable left Idline d right rdline H dH
Brace scalable left Ibrace e right rbrace e]
Angle bracket scalable left langle f right rangle ( f)
Operator brackets scalable left langle g mline h right rangle \g|h

Over brace scalable

Under brace scalable

{The brace is above} overbrace a

{the brace is below}underbrace {f}

The braceis above

the braceis below
f

Math commands - Reference
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Formats

Operation Command Display
Left superscript a Isup{b} b4
Center superscript a csup{b} Cbl
Right superscript aNb} ab
Left subscript a Isub{b} »a
Center subscript a csub{b} ‘Z
Right subscript a_{b} a,
Align character to left (text is aligned _ Helloworld
center by default) stack { Hello world # alignl (a) } (a)
, stack{Hello world # alignc(a)} Helloworld
Align character to center (a)
stack { Hello world # alignr(a
Align character to right ¢ gnr(@)} Helo wozia;
Vertical stack of 2 binom{a}b} Z
a
Vertical stack, more than 2 stack{a # b # z} b
z
matrix{ a b
. a#b##
Matrix iy c d
}
matrix{
Equations aligned at '=' (using a#"="# align{b} ## a =b
'matrix’) {} #"="# align{c+1} =c+1
}
stack{
Equations aligned at '=' (using align{a} =b # a =
'‘phantom’) align{phantom{a} = c+1} =c+1
: , . , asldkfjo
New line asldkfjo newline sadkfj sadkfj
No gap nospace { x +y } x+y
Normal X+y x+ty
Small gap (grave) stuff “stuff stuff stuff
Large gap (tilde) stuff~stuff stuff  stuff

24
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Caution

A

In localized versions of Writer, the markup names of Greek and special characters
are localized. If this document is not localized to the same language, then the names

below may not work for input. You may still use the Symbol catalog (Figure 7) to

select the desired character by its glyph. This will also display the character's
localized markup name.

Once entered, the characters will display properly in any language.

Characters - Greek

%ALPHA A| Y%BETA B | %GAMMA I' | %DELTA A | %EPSILON E
%ZETA Z | %ETA H| %THETA ®| %IOTA I | %KAPPA K
%LAMBDA A | YoMU M| %NU N| %XI = | %OMICRON 0
%PI I1, %RHO P | %SIGMA S| %TAU T | %UPSILON Y
%PHI ® | %CHI X| %PSI ¥ | %OMEGA Q

%alpha « | %beta B | %gamma y | %delta 5 | %epsilon €
%varepsilon e | Y%zeta T | %eta n | %theta 0 | %vartheta 9
%iota L | Y%kappa k | %lambda A | Y%omu p | %nu v
%xXi € | %0micron o | Yopi 1t | Y%varpi w| %rho p
%varrho o | %sigma g | Y%varsigma ¢ | %tau T | Y%upsilon )
%phi ¢ | Yovarphi @ | %chi ¥ | Yopsi Y | Y%oomega W
Characters — Special

%and A %angle < %element € %identical =
%infinite oo %noelement & %notequal # %or V
%perthousand %o %strictlygreaterthan > %strictlylessthan < %tendto —
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