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Qu’est-ce que Math ?

Math est le module de LibreOffice pour écrire des équations mathématiques et chimiques. Il est en
général utilisé comme éditeur d’équation pour les documents texte, mais il peut étre utilisé avec
d’'autres types de documents ou comme module en soi. Lorsqu'il est utilisé dans Writer, I'équation
est considérée comme un objet a I'intérieur du document texte.

Note

ou

L'éditeur d’équation est utilisé pour écrire des équations sous forme symbolique
comme dans I'équation 1. Si vous cherchez & évaluer une valeur numeérique,
consultez le Guide Calc.

df(x)Zln(x)+ tan~!(x?) 1)

+ p—
NH3+ HZO# NH4+ OH

Pour commencer

Vous pouvez créer une équation (formule) comme un document séparé ou vous pouvez l'insérer
dans un document Writer ou dans un autre module LibreOffice.

Créer une équation comme un document séparé
Pour créer une équation en tant que document séparé, ouvrez le module Math de LibreOffice avec
une de ces méthodes :
* Dans la barre de menu, sélectionnez Fichier > Nouveau > Formule.
* Dans la barre d'outils standard, cliquez sur le triangle a gauche de I'icbne Nouveau et
sélectionnez Formule.
e A partir du centre de démarrage, cliquez sur Formule.

Un document formule vide s’ouvre comme sur la Figure 1.

r Sans nom 3 - LibreOffice Math | = | B i:hl
Eichier I-fgition Affichage Format QOutils Fepétre Aide
‘e Q .8 Q e iB-Bl= B & g (7
Eléments (8]
- :22 asb a=A £ Za |E
N ON

+8 -4 a4 ¥4 -a

a+b a«b axb axb aab

a T 1| a-b % azb a/b avb

100% ash

L —

Figure 1 : Un document formule vide
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La zone supérieure est la fenétre de visualisation, ou I'équation va apparaitre pendant et apres
I'écriture. La zone inférieure est I'éditeur d’équation, ou le code de I'équation est tapé. La fenétre
flottante E/éments va aussi apparaitre.

Insérer une formule dans un document Writer

Pour insérer une formule dans un document Writer, ouvrez le document et sélectionnez dans la
barre de menu Insertion > Objet > Formule.

Par defaut, I'éditeur d’équation apparait en bas de la fenétre Writer, ainsi que la fenétre flottante
Eléments. Une boite avec une bordure grise va également apparaitre dans votre document, a
I'endroit ou la formule sera affichée, comme le montre la Figure 2.

[£] Sans nom 1 - LibreOffice Writer | =NNCh X
Fichier Edition Affichage Format Outils Fepétre Aide Eléments @
e B-BEd= @& (7] asbaEA f0 Za
I B I I R R - S R I TR BEREES [ ERES s RS - I -+ p
- i A&

+4 -4 4 F4 -4

a+b a-b axb axb asb

o ma

. a-b % azb a/b avb

b

Figure 2: Editeur d’équation, fenétre Eléments et placement de I'équation dans Writer

Astuce Si la fenétre Eléments est absente, faites-la apparaitre avec Affichage > Eléments.

Quand vous avez fini de taper la formule, vous pouvez fermer I'éditeur en appuyant sur la touche
Echap. ou en cliquant hors de la formule dans le document principal. Un double-clic sur I'équation
ouvrira a nouveau I'éditeur, pour pouvoir modifier la formule.

Les formules sont insérées en tant qu'objets OLE. Dans un document Writer, la formule est ancrée
par défaut comme caractére. Elle est ainsi incluse dans la continuité du texte. Comme pour tout
objet OLE, vous pouvez modifier 'ancrage et rendre la formule flottante. Dans les documents Calc,
Impress et Draw, les formules sont insérées comme objets OLE flottants.

Si vous avez régulierement besoin d'insérer des formules, il est conseillé d’ajouter le bouton
Formule a la barre d’outils Standard ou de créer un raccourci clavier (voir Ajouter un bouton a une
barre d’outils ou Ajouter un raccourci clavier page 31).

Ecrire une formule

L'éditeur d’équation utilise un langage de balisage pour afficher les formules. Par exemple, %béta
créer le caractére grec béta (3 ). Ce balisage est congu pour étre lu comme de I'anglais (ou du
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francais pour les caractéres grecs et spéciaux) autant que possible. Par exemple, a over b

. a N :
donne une fraction : 5 (over signifiant au-dessus en anglais).

Vous pouvez écrire une formule de trois maniéres :
e Sélectionnez un symbole de la fenétre Eléments.

* Cliquez-droit dans I'éditeur d’équation et sélectionnez le symbole a partir du menu
contextuel.

* Tapez le balisage dans I'éditeur d’équation.

Le menu contextuel et la fenétre Eléments insérent le balisage correspondant & un symbole. Cela
permet d’apprendre simplement le balisage de LibreOffice Math.

Cliquez sur le corps du document pour quitter I'éditeur de formule.

Note .
Double-cliqguez sur une formule pour retourner dans une formule.

La fenétre Eléments

La méthode la plus simple pour écrire une formule est la fenétre Eléments.

Eléments @
+a N
A asb a=A fix) 2a
- Catégories
PO | N et

L/

'\5\
+4 -4 *a Fa -a
a+b a-b axb axb aab

pe Symboles

a-b % azb a/b avb
feb

L/

Figure 3 : Les symboles sont répartis en catégories

La fenétre Eléments est divisée en deux parties principales :

* Le haut présente les catégories de symboles. Cliquez sur celles-ci pour changer de liste
de symboles.

* Le bas présente les symboles disponibles dans la catégorie courante.

Astuce Vous pouvez masquer ou afficher la fenétre Eléments avec Affichage > Eléments.

Exemple1: 5X4

Dans cet exemple, nous allons entrer une formule simple : 5X4 . Dans la fenétre Eléments :
1) Sélectionnez le bouton en haut & gauche de la section des catégories (haut).
2) Cliquez sur le symbole multiplication.
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Elements |E|

[ —

Operateurs sb ach fi 2a

unaires/binaires

i & oW

+6 -4 *a Fa -a

ﬁ-..-.
a+D .@1 anb

a-b {% a=b a/b avb

Multiplication

dab

Figure 4 : Sélection du symbole multiplication

Quand le symbole multiplication est sélectionné dans la fenétre Eléments, deux actions ont lieu :

e L'éditeur d’équation affiche le balisage : <?> times <?>

* Le corps du document affiche une boite grise comme ceci: xOl

s

<

0 03 23 [

<?> times <?> | A

hd
+

Figure 5 : Résultat de la sélection du symbole multiplication

Les symboles <?> affichés Figure 5 sont les emplacements que vous pouvez remplacer par

d’autres textes, par exemple 5 et 4. L'équation va se mettre a jour automatiqguement, et le résultat
devrait ressembler a la Figure 6.

Lors de I'édition d’une formule, les places réservées sont marquées par des carrés
dans les formules et des <?> dans la fenétre de commande. Utilisez F4 et Maj+F4
pour naviguer entre ces emplacements.

Astuce

2]

5 times 4 L]

b
+

Figure 6 : Résultat aprés avoir tapé 5 et 4 a cété de I'opérateur multiplication
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Pour éviter la mise a jour automatique de I'équation, sélectionnez Affichage
Astuce >Rafraichir automatiquement I’affichage. Pour rafraichir une formule
manuellement, appuyez sur F9 ou sélectionnez Affichage > Actualiser.

Menu clic-droit (contextuel)

Une autre fagcon d'accéder aux symboles mathématiques est de faire un clic-droit dans I'éditeur
d’équation. Un menu contextuel s’affiche alors comme sur la Figure 7. Les entrées de ce menu
correspondent a ceux de la fenétre Eléments, avec quelques commandes supplémentaires.

5 times 4|
Opérateurs unaires/binaires » +3

4 [m]|»

Relations
Opérateurs d'ensemble

Fonctions

Opérateurs
Attributs

Parenthéses

a+b
a-b
acdoth
atimes b
a*hb
aoverb
adivhb
alb

acirch

Formats

v v v v w v wv v

Autres

a wideslash b
a widebslash b
neg a

aand b

aorb

Figure 7 : Menu contextuel par clic-droit

Ni la fenétre Eléments, ni le menu contextuel ne contiennent la liste compléte des
Note commandes. Quelques commandes non usuelles nécessitent de taper leurs balises.
L'annexe page 43 de ce manuel propose une liste compléete des commandes.

Balisage

Vous pouvez taper directement le balisage dans I'éditeur d’équation. Par exemple, vous pouvez
taper 5 times 4 pour obtenir 5X4 . Si vous connaissez le balisage, c’est la méthode la plus
rapide pour entrer une formule.

Astuce Le balisage correspond a I'écriture en anglais des formules.

Le tableau ci-dessous présente une liste rapide des équations communes et leur balisage
respectif.

Affichage Commande Affichage Commande
a=bh a=b Va sart {a}
a an2 a, a_n
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Affichage Commande Affichage Commande
ff(x)dx int f(x) dx Zan sum a_n
a<b a<=b 00 infinity
axb a times b Xy x cdot y

Caracteres grecs

Les caractéres grecs (o, p,y, 0, etc.) sont courants dans les formules mathématiques. Ces
caractéres ne sont pas disponibles dans la fenétre Eléments ou par le menu contextuel.
Heureusement, le balisage des caractéres grecs est simple : tapez un symbole % suivi par le nom
du caractere en francais.

* Pour écrire un caractére en minuscule, tapez le nom du caractére en minuscule.
* Pour écrire un caractére en majuscule, tapez le nom du caractére en majuscule.

* Pour écrire le caractére en jtalique, insérez un i entre le % et le nom du caractére.

Un tableau complet des caractéres grecs est fourni page 53. Le tableau ci-dessous présente
guelques exemples.

Minuscule Majuscule Minuscule italique Majuscule italique
%alpha = « %ALPHA > A %ialpha =2 « %iALPHA > A
%béta > P %BETA = B %ibéta > f %iBETA = B
%gamma => Yy %GAMMA = T %igamma => Yy %iGAMMA = I’
%psi > P %PSI > W %ipsi > Y %iPSI > W
%phi > @ %PHI > @ %iphi = @ %iPHI = @
%théta = 0O %THETA > O %ithéta > 60 %iTHETA > O

Une autre facon d’entrer des caractéres grecs est d'utiliser la fenétre du catalogue de symboles.
Sélectionnez Outils > Catalogue. Cette fenétre est présentée Figure 8. Sous Jeu de symboles,
sélectionnez Grec et double-cliquez sur la lettre grecque de la liste. La balise du nom du caractére
est indiquée sous la fenétre de liste.

Symbaoles —
s e
Grec IZH

Fermer
A BT AEZHG®G® * _
I KAMNZEZOTI®= Editer...
PIZITY X W¥YQ
Bc o s::no a
L K A uw v E oo
P ot oY -
alpha

Figure 8 : Catalogue des symboles utilisés pour entrer les caractéres grecs
et quelques symboles spéciaux
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Exemple2: . =~ 3,14159

Pour cet exemple nous supposerons que :
* Vous voulez entrer la formule ci-dessus (la valeur de pi arrondie a 5 décimales).
* Vous connaissez le nom du caractére grec (pi).
* Mais vous ne connaissez pas la balise associée avec le symbole = .

Etape 1 : Tapez % suivi du texte pi. Le caractére grec n s'affiche.

Etape 2 : Ouvrez la fenétre Eléments (Affichage > Eléments).

Etape 3: Le symbole =~ est une relation, donc cliquez sur la catégorie Relations. En maintenant
la souris sur ce bouton, vous voyez I'info-bulle Relations (Figure 9).

La Figure 10 montre la fenétre Eléments aprés avoir cliqué sur le bouton Relations. Le symbole
recherché est entouré.

[ Elements s [§ Elements }
n ‘Eg ash {() 2a 7 ﬂE"“' fi Za
d [Reramonslt) 2 & a2

+0 -0 *a Fa -a n=b a=b azb alb atb
a+b a-b axb axb asb a<b a>b||b alb
a-b % azb a/b avb asb azb a~b a=b
asb azb azb aeb a=b

Figure 9 : L’info-bulle indique le 4=b asb a=b

bouton Relations

Figure 10 : Aprés sélection de Relations

Etape 4: Cliquez sur le symbole a =~ b. L'éditeur d’équation montre maintenant le balisage
%pi<?> simeq <?>.

Etape 5 : Effacez le texte <?>, appuyez sur F4, puis tapez 3,14159. Le balisage complet est %pi
simeq 3,14159. La Figure 11 présente le résultat.

s 1=314150 49

“@][m] 4

—
Fl (] 3

%¥pi =imeq 3,14155

4 (m »

Figure 11 : Résultat final
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Modifier une formule

Vous pouvez modifier une formule a tout moment. Pour basculer en mode édition, double-cliquez
sur une formule.

Choisir la région a modifier
Pour atteindre la section appropriée du balisage, vous pouvez :
* Dans I'éditeur d’équation, cliquer sur la position.
e Sélectionner une zone du balisage que vous souhaitez modifier.

¢ Cliquer sur un élément de la zone d’'apercu ; le curseur va automatiquement se positionner
au point correspondant de I'éditeur d’équations.

* Double-cliquer sur un élément de la zone de I'apergu ; la section correspondante dans
I'éditeur d’égquations sera sélectionnée.

Dans la fenétre du module Math indépendant (Figure 1), pour pouvoir travailler dans la zone du
dessus (apercu), le curseur de formule doit étre activé. Utilisez le bouton Curseur de formule dans
la barre d’outils Outils.

& & .9 Q @z

Effectuer des changements

Vous pouvez modifier une équation en écrasant le texte sélectionné ou en insérant des nouveaux
codes de balisage a la position du curseur.

LibreOffice fournit également une nouvelle maniére de modifier une formule en
apportant les modifications directement dans la zone d’apercu. Cette fonctionnalité
est encore en développement et est donc considérée « expérimentale ». Pour
l'utiliser, vous devez tout d’abord effectuer ce changement de configuration :

Astuce sélectionnez le menu Outils > Options > LibreOffice > Général et cochez Activer
les fonctions expérimentales (non stabilisées).

L'activation de cette option rend impossible, par clic sur un élément de formule,
d’atteindre le code de balisage correspondant.

Attention L 'utilisation des fonctionnalités expérimentales peut conduire & des arréts brutaux du
programme ou des pertes de données. Ne faites les modifications ci-dessus que si
vous en acceptez le risque.
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Positionnement dans les formules

La partie la plus difficile lors de l'utilisation de LibreOffice Math provient de I'écriture de formules
complexes. Cette section donne quelques conseils.

Les accolades sont vos amies

LibreOffice Math n’a aucune connaissance de la priorité des opérateurs. Vous devez utiliser des
accolades ou des parenthéses pour fixer I'ordre des opérations explicitement. Voyez les exemples
suivants :

Balisage Résultat Balisage Résultat
2 2

2 over x + 1 =+1 2 over {x + 1}
X x+1
-1 1

- 1 over 2 > - {1 over 2} 3

Dans le premier exemple, Math a reconnu que le 2 avant et le x aprés le over appartiennent a la
fraction et les a représentés ainsi. Si vous voulez x+1 plutét que x au dénominateur, vous devez
les encadrer d'accolades de facon a les placer ensemble.

Dans le second exemple, Math a reconnu le signe moins en tant que préfixe de 1 et I'a ainsi placé
au numeérateur de la fraction. Si vous voulez montrer que la fraction entiére est négative, avec le
signe moins devant la fraction, vous devez encadrer la fraction d’accolades pour signifier & Math
gue la fraction est un ensemble.

Les accolades appartiennent uniquement au balisage du code et ne sont pas visibles. Si vous
souhaitez utiliser des accolades dans une formule, utilisez les commandes Ibrace et rbrace.

Comparez les exemples suivants :

Balisage Résultat Balisage Résultat

X X over lbrace -x + 1 X
—x+1l rbrace [—x+1}

x over {-x + 1}

Faire de grandes parenthéses (pour les matrices)

Commencons par présenter la commande pour les matrices : matrix.

Balisage Résultat
matrix { a # b ## c # d } a b
c d
Note Les lignes sont séparées par deux # et chaque élément d’une ligne par un #.

Le premier probléme rencontré avec les matrices est que les parentheses ne s'adaptent pas a la
taille de la matrice :
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Balisage Résultat
@

( matrix { a# b ## c #d } )
c d

LibreOffice Math dispose de parenthéses ajustables : les parenthéses s’agrandissent pour
s'adapter a la taille de leur contenu. Utilisez les commandes left( et right) pour obtenir les
parenthéses ajustables.

Balisage Résultat

. : a b

left( matrix { a # b # c # d } right) ( d)
c

Utilisez left[ et right] pour obtenir des crochets. La liste des parenthéses utilisables

Astuce est donnée page 49.

Si vous préférez avoir toutes les parenthéses ajustables, sélectionnez le menu
Astuce Format > Espacement. Puis dans le dialogue, sélectionnez la catégorie
Parenthéses et cochez I'option Ajuster toutes les parenthéses.

Ces parenthéses ajustables sont bien sir utilisables avec n’'importe quel élément autre que les
matrices : fraction, racine, etc.

Parenthéses isolées ou dépareillées

Math s’attend que pour chaque parenthése ouvrante, il y aura une parenthése fermante. Si vous
oubliez une parenthese, Math insére un point d’interrogation rouge a I'envers ¢ pour la parenthése
manquante. Celui-ci disparait des que les parenthéses sont appariées. Parfois I'oubli d’'une
parenthése détruit toute la structure de la formule. Cependant, une parenthése dépariée est
parfois nécessaire. Deux options sont alors possibles :

Avec des parenthéses non ajustables, faites précéder par une barre oblique inversée (backslash)
\ pour indiquer que le caractére suivant ne doit pas étre considéré comme une parenthése mais
un caractére littéral. Ainsi l'intervalle semi-ouvert [a;b[ est représenté par \[a;b\[ — vous
pouvez comparer avec le balisage [a;b[. Vous pouvez aussi mettre entre guillemets droits les
parenthéses pour qu’elles soient considérées comme du texte : "["a;b"[".

Les parenthéses ajustables peuvent aussi étre dépariées. Le méme intervalle semi-ouvert est
représenté par :
left [ a; b right [

Pour les parentheses ajustables, vous pouvez également utiliser la balise none pour remplacer la
seconde parenthése non existante :

xpour x >0

|+ =
—x pour x<0
peut étre représenté par :

abs x = left lbrace stack {x "pour" x >= 0 # -x "pour" x < 0} right
none

Positionnement dans les formules 15



Reconnaissance des fonctions dans Math

Dans l'installation par défaut, Math affiche les variables en italique. Si vous tapez une fonction,
Math habituellement la reconnait et I'affiche normalement. Si Math ne reconnait pas une fonction
(une liste des fonctions reconnues démarre page 46), vous pouvez forcer Math a la reconnaitre.
Tapez la balise func avant la fonction, et le texte qui suit sera connu comme une fonction.

Certaines fonctions reconnues par Math nécessitent d’étre suivies de nombres ou de variables. S'il
n'y en a pas, Math affiche un point d’interrogation rouge a I'envers ¢ a leur place, que vous pouvez
supprimer en corrigeant la formule : tapez une variable ou un nombre, ou une paire d’'accolades
vide {}.

Astuce Pour naviguer entre les différentes erreurs, utilisez F3 et Maj+F3.

Equations sur plusieurs lignes

x=3
y=1
Votre premiére réaction serait de simplement appuyez sur la touche Entrée. Cependant en
appuyant sur la touche Entrée, bien que le balisage passe a la ligne suivante, I'équation résultante

ne le fait pas. Vous devez taper la balise newline explicitement, comme lillustre le tableau
suivant :

Supposez gue vous voulez écrire une équation sur plusieurs lignes, par exemple :

Balisage Résultat

X =3

y =1 x=3y=1
X = 3 newline x=3
y=1 y=1

Si vous souhaitez poursuivre le calcul sur une nouvelle ligne sans écrire une nouvelle équation
compléte, cela n'est pas possible directement, car Math attend un terme de part et d’autre du signe
€gal. Vous pouvez les remplacer par :

* des guillemets vides "". Cela va automatiquement aligner la ligne a gauche ;
* des accolades vides { }. La ligne suivante sera centrée.

L'alignement des signes égal les uns au-dessus des autres est décrit page 18.

De méme l'espacement entre les éléments d'une formule n’'est pas géré par les espaces tapés
dans le code. Il faut pour cela utiliser les balises d’'espace : = (accent grave) pour une petite
espace, ~ pour une grande espace. Une autre solution est d’ajouter les espaces entre guillemets
droits pour étre comme du texte. Les balises d’espace en fin de formule sont par défaut ignorées
(voir Espace a la fin d'une formule page 34)

Ajouter des limites aux sighes somme ou intégrale

Les balises de type sum et int (voir la liste compléte page 47) peuvent (de fagon optionnelle)
utiliser les paramétres from et to. Ces derniers sont utilisés pour les limites inférieure et supérieure
respectivement. Ces paramétres peuvent étre utilisés séparément ou ensemble.
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Balisage Résultat

sum from k = 1 to n a_k Zak

int from 0 to x f(t) dt x

ou ff(t)dt ou fof(t)dt
0

int_eAx f(t) dt

int from Re f

sum to infinity 2A{-n}

Note Pour plus de détails sur les intégrales et les sommes, voir page 47.

Ecrire une dérivée
Ecrire des dérivées se résume principalement a : dites a LibreOffice que c’est une fraction.

Autrement dit, vous devez utiliser la commande over. Combinez ceci avec la lettre d (pour une
dérivée totale) ou la commande partial (pour une dérivée partielle) pour obtenir I'effet d'une
dérivée.

Note Notez I'utilisation des accolades pour écrire les dérivées partielles.
Balisage Résultat
{df} over {dx} a
dx
{partial f} over {partial y} %L
y
2
{partialnr2 f} over {partial tAr2} %é
t

Pour écrire les noms de fonction avec les primes, comme habituellement en notation scolaire, vous
devez d’abord ajouter ces signes au catalogue. L'utilisation de l'apostrophe ou des guillemets
droits est inesthétique. Voir la section Personnaliser le catalogue page 32.

Caracteres du balisage en tant que caractéres normaux

Les caracteres utilisés comme balise ne peuvent pas étre tapé directement comme caractéres
normaux. Les caractéeres concernés sont: %, {, }, &, |, _, A et . Par exemple vous ne pouvez pas
taper 2% = 0,02 ou 1" = 2,56cm. Deux méthodes sont disponibles pour dépasser cette limitation :

e Utiliser les guillemets droits pour marquer le caractére comme texte, par exemple 2"%"=
0,02. Cela n’est bien sdr pas utilisable pour les guillemets droits eux-mémes.

* Ajouter le caractere au catalogue comme indiqué a la section Personnaliser le catalogue
page 32.
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Dans quelques cas, vous pouvez utiliser des commandes :
* Ibrace et rbrace donnent des accolades | }.
 mline donne une ligne verticale, par exemple (2 mline 3) pour (2[3)

La conversion avec une référence de caractere comme dans le langage html ou ['utilisation d'un
caractere d'échappement n’est pas possible avec Math.

Texte dans une formule

Pour inclure un texte dans une formule, il suffit de I'entourer de guillemets droits :

abs x = left lbrace matrix {x # "pour " x >= 0 ## -x # "pour " x < 0}
right none

Ix]=] * pour x>0

—x pour x<0

Tous les caracteres, a l'exception des guillemets droits, sont autorisés dans un texte.
Malheureusement la boite de dialogue d'insertion des caractéres spéciaux n'est pas disponible
dans Math. En cas de nécessité, il est possible d'écrire le texte dans Writer et de le copier dans
I'éditeur d’équation par le presse-papier. De cette maniére, des guillemets francais peuvent étre
insérés comme ci-dessous :

Sans nom 17 - LibreOffice Math =
Eichier Egition Affichage Format Outils  Fenétre  Aide
6 9Q Sl BF-EH= &@d B - (7]

Un exemple d’application des « guillemets francais ».

"Un exemple d'application des « guillemets francgais »." -

+ m 3

100% | k=

h

Figure 12 : Guillemets francais insérés par copier-coller depuis Writer.

Le texte s’affiche dans la police sélectionnée par la liste Texte dans le dialogue Polices (voir infra
la section Modifier la police page 20). Pour utiliser une police du bas de la fenétre de la Figure 16,
utilisez un balisage font serif, font sans ou font fixed avant le texte.

Par défaut le texte est aligné & gauche. Vous pouvez changer I'alignement avec alignc ou alignr.
(voir Modifier I'alignement page 23)

Les balises ne sont pas interprétées a l'intérieur d’un texte. Utilisez les guillemets pour interrompre
le texte et pour utiliser du balisage de formatage.

"Dans les triangles " color blue bold "isocéles" ", les angles de la
base sont égaux"

Dans les triangles isoceles, les angles de la base sont égaux

Alignement des équations sur leur signe égal

LibreOffice Math ne dispose pas d’'une commande pour aligner les équations sur un caractere
particulier, mais vous pouvez utiliser une matrice pour le faire, comme dans cet exemple :
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Balisage Résultat
matrix{
alignr x+y # {}={} # alignl 2 ## x+y = 2
alignr x # {}={} # alignl 2-y x = 2—y
}

Les accolades vides autour des = sont nécessaires car = est un opérateur binaire et nécessite une
expression de chaque coté.

Vous pouvez réduire I'espace autour des = si vous changez I'espacement inter-colonne de la
matrice :

1) Dans 'éditeur d’équation, sélectionnez Format > Espacement dans la barre de menu.

2) Dans le dialogue d'espacement (Figure 13), cliquez sur le bouton Catégorie et
sélectionnez Matrices dans menu déroulant.

3) Entrez 0% pour I'espacement entre les colonnes et cliquez sur OK.
Espacement @
Interligne 39

ac
bd

Ak

Espacement entre les cold p3g

4|k

e

Figure 13 : Modification de 'espacement dans une matrice

Modification de I'apparence des formules

Modifier la taille de police

C’est une des questions les plus courantes au sujet de LibreOffice Math. La réponse est simple,
mais peut-étre pas si intuitive :

1) Dans I'éditeur de formule, sélectionnez le menu Format > Taille de police.
2) Sélectionnez une taille de police plus grande avec Taille de base (entrée tout en haut).

r

Tailles de police

Tailledebase  |j12pt = OK

Tailles relatives Annuler

Texte 100%

1

i,

Par défaut
Index 60% = araeiad

Fonctions 100%

L1l

Opérateurs 100%

LIIRIEL

Limites 60%

e

Figure 14 : Modifier la taille de base (en haut) pour agrandir la formule
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Le résultat de ce changement est illustré sur la Figure 15.

Avant : n~3,14159
Aprés : n~3,14159

Figure 15 : Résultat du changement de la taille de base de la police

Le changement de taille de police ne s’applique que pour la formule courante. Pour
changer la taille de fagon permanente, cliquez sur le bouton Par défaut puis OK. Un
changement de la taille par défaut pourra, par exemple, rendre votre travail bien plus
facile lorsque vous préparez une présentation longue et que vous voulez toutes les
Note formules en taille de base 28pt. Cependant, n'oubliez pas de ramener la taille de
base a sa valeur originale a la fin de votre travail.
Attention : cela n’'affecte que la formule courante et les prochaines formules que
vous créerez. Pour modifier toutes les formules déja créées dans un document, il
faut utiliser une macro (voir annexe page 41).1

La taille d’un sous ensemble de caracteres dans une formule peut se changer avec la commande

size. Exemple: b size 5{a}: b. .Avec lafenétre Eléments, I'avant derniére icone & de
'onglet Attributs permet d’'obtenir la commande size. La valeur aprés size peut étre absolue
(une valeur numérigue) ou relative par rapport au contexte (par défaut la taille de base) : +6, -3,
/2, ou *2 par exemple. L'emploi de valeur numérique décimale nécessite d'utiliser un point
comme séparateur décimal.

Modifier la police

Les polices utilisées dans Math peuvent étre modifiées a I'aide du menu Format > Polices. La
section Polices des formules (Figure 16) fait référence aux quatre éléments de formule spécifiés.
La police pour les opérateurs, les relations et les parenthéses n’est pas affectée, car ces éléments
viennent normalement de la police OpenSymbol. De la méme facon, les éléments issus du
catalogue (cf. Personnaliser le catalogue page 32) continuent d'étre affichés dans la police
spécifiée.

Paolices @
Polices des formules
Vanables
|
Eenctions |Times MNew Roman |E||
Nombres  [Tmes e Fomn 5
Texte |Times Mew Roman |E||

Polices personnalisées

serif |Time5 Mew Roman IE“
Sans |Arial E"
Fixe |C|:uurier Mew IE"

h

Figure 16 : Dialogue des polices
1 http://wiki.documentfoundation.org/FR/FAQ/Math/102
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La section Polices personnalisées sélectionne la police qui sera utilisée lorsque le balisage font
serif, font sans ou font fixed est spécifié.

Pour modifier une police, cliquez d’abord sur le bouton Modifier :

Yariables
Fonctions
MNombres
Texte
Sernf

Sans

Fixe

Figure 17 : Bouton Modifier

Sélectionnez le type de police a modifier. Le dialogue Polices s’ouvre, montrant toutes les polices
disponibles dans le systéme.

i |
Polices 3
o
Liberation Senf .
Liberation Mono L lﬂ

Liberation Sans
Liberation Sans Narrow =
Liberation Serif m
Ligurino
L i Cend - &2
Attributs [ Gras
Italique
Liberation Serif

Figure 18 : Dialogue des polices

Si vous tapez un premier caractére dans la boite d’entrée du haut, la liste va sauter directement
jusqu’a cette lettre. Avec quelques caractéeres supplémentaires, vous pouvez spécifier la police
exacte recherchée. Si vous ne connaissez pas son nom, utilisez I'ascenseur pour balayer la liste.
Cliquez sur un nom pour avoir un apercu dans la zone du bas.

Comme les variables devraient étre en italique, assurez-vous que la case ltalique est bien cochée.
Pour les autres éléments, il convient de laisser la forme basique (Roman). Le style peut étre
facilement modifié dans la formule elle-méme a l'aide des balises italic ou bold (gras) pour activer
ces caractéristiques et nitalic ou nbold pour les annuler.

Quand une nouvelle police est sélectionnée pour une formule, I'ancienne police reste disponible
dans la liste avec la nouvelle, et peut étre a nouveau sélectionnée. Ceci ne dure que le temps de
la session ; I'ancienne police n'est pas stockée de fagon permanente.

Vous pouvez choisir n'importe quelle police, mais si vous échangez des documents, vous devriez
choisir des polices également présentes sur I'ordinateur de votre collegue.
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Ajuster I'’espace dans les formules

Pour augmenter ou diminuer I'espace dans les formules, suivez cette procédure :
1) Sélectionnez le menu Format > Espacement.

2) Dans le dialogue Espacement, cliquez sur le triangle & coté de Catégorie, et sélectionnez
une entrée dans la liste.

3) Sélectionnez les valeurs d’espacement appropriées (les types d’espacement dépendent de

la catégorie) et cliquez sur OK.

Note

-

e

Espacement
Espacernent QK
Espacement 0% 2
Annuler
Interligne 5% =

Espacermnent de la racine |03

a+b

Catégorie | v

Par défaut

1

Figure 19 : Dialogue pour I'espacement

Par défaut puis OK.

Les changements de I'espacement ne s’appliquent que pour la formule courante.
Pour changer I'espacement des futures formules également, cliquez sur le bouton

Les changements d'espacement sont possibles pour les catégories présentées dans le tableau

suivant.
Catégorie Ajustement possible
Espacement
S JT
Entre les caractéres Interligne Espacement de la
racine
Index
Exposant Indice
Fractions L x
—_— R
y Numérateur r Dénominateur
Barre de
fraction x x
j Longueur en exces y Epaisseur de ligne
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Catégorie Ajustement possible
Limites ! 1
i=N.
i=07
Z_' Espacement en haut Espacement en bas
Parenthéses IIX flx
-V Dépassement vertical V Ecartement horizontal
Matrices
{ac i cC
[bid] [bHd]
Interligne Espacement entre les
colonnes
Symboles
% oo
Hauteur primaire Espacement minimum
Opérateurs ?[
Dépassement Ecartement
Bordures I
g g g
HE=ma E=maH| E=ma E=ma
A gauche A droite En haut En bas

Modifier I’alignement

Le réglage de l'alignement détermine comment les éléments de la formule situés les uns au-
dessus des autres sont alignés horizontalement relativement les uns aux autres. Utilisez le menu
Format > Alighement pour choisir entre A gauche, Centré ou A droite.

-

Alignement @1
Horizontal [ = l
(71 A gauche
o Cantie [ Annuler |
A droite ’ —— ]

Figure 20 : Dialogue d’alignement
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Ici & nouveau vous pouvez utiliser le bouton Par défaut pour appliquer le changement a toutes les
futures formules, et non plus seulement a la formule courante. Le tableau suivant montre I'effet
dans différentes situations :

Alignement Exemples
2 2 2
) c’=a’+b —2abcosy
A gauche X9 (;00) c’—a’—b’
cosy=————
X ¥ —2ab
2_ 2,12
, , -9 100 c’=a+b ) 2a2bcozsy
Centré (par défaut) 7 c’—a —b
cosy=————
X ¥ —2ab
2 2 2
2 c’=a’+ b —2abcosy
A droite X' —9 (10(;) B
cosy=——""—
X Y —2ab

Il n'est pas possible d’aligner les formules sur un caractére particulier.

Les réglages par défaut d’'alignement ne s’appliquent pas aux éléments de texte ; ils sont toujours
alignés a gauche. Dans les exemples suivants, I'alignement par défaut est A droite mais le premier
exemple commence la seconde ligne avec un texte (bien que ce soit un texte vide) et est de ce fait
aligné a gauche.

Balisage Résultat
{1+2+3+4} over 5 + 2 over {60+70+80+90} 1+2+43+4 2
newline 5 60+70+80+90
1
— :2+_
""=2+1 over 150 150
{1+2+3+4} over 5 + 2 over {60+70+80+90} 1+2+3+4, 2
newline 5 60+ 70+ 80+ 90
1
{}=2+1 over 150 :2+1—50

Indépendamment de I'alignement par défaut, il est possible d'aligner explicitement les formules en
utilisant les balises alignl, (2 gauche), alignc (centré) et alignr (a droite). Ce balisage fonctionne
aussi pour les éléments de texte.

Modifier la couleur

La commande color permet de changer la couleur d’une sous formule : color red ABC donne
ABC . ll'y a 8 couleurs différentes a choisir parmi : white, black, cyan, magenta, red, blue,
green, yellow (pour blanc, noir, bleu clair, violet, rouge, bleu, vert, jaune).

Vous pouvez attribuer une couleur a une sous-formule entiére si vous la regroupez avec { } ou
autres parentheses. Par exemple : A B color green {C D} Epouravoir ABCDE .

Quand plusieurs couleurs sont appliquées, celles qui sont le plus a I’intérieur prennent le dessus
comme dans cet exemple : color blue {A B color yellow C D} pouravoir 4B D

Vous ne pouvez pas sélectionner la couleur du fond, il est toujours transparent dans une formule
Math. La couleur de fond de la formule compléte est donc la couleur de fond du document ou du
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cadre (par exemple un document texte). Dans Writer, les propriétés d'objet (clic droit > Obijet)
permettent de choisir une couleur d'arriere-plan pour I'ensemble de la formule (voir Arriere-plan,
bordures et taille page 27).

Les formules dans Writer

Numérotation des équations
La numérotation des équations est une des meilleures fonctionnalités cachées de LibreOffice. Les
étapes sont simples mais peuvent paraitre obscures :

1) Dans Writer, démarrez une nouvelle ligne, ou laissez une espace a la fin de votre texte.

2) Tapez nf et appuyez sur F3.

Les caractéres nf sont remplacés par une équation humérotée :
2
E=mc 2)

Vous pouvez maintenant double cliquer sur la formule pour I'éditer. Par exemple, voici la fonction
zéta de Riemann :

_y 1

tz)=2 = 3)
n=1 N

Vous pouvez faire référence a cette équation (« comme le montre I'équation (2) ») en suivant ces

étapes dans Writer :

1) Sélectionnez le menu Insertion > Renvoi.

2) Dans l'onglet Renvois (Figure 21), sous Type de champ, sélectionnez Texte.
3) Sous Sélection, sélectionnez le numéro d’équation.

4) Sous Insérer une référence a, sélectionnez Référence.

5) Cliquez sur Insérer.

C'est fait! Si par la suite, vous insérez de nouvelles équations dans votre document avant
I'équation référencée, toutes les équations vont étre automatiquement renumérotées et les renvois
seront mis a jour.

Pour insérer le numéro d’équation sans les parentheses, sélectionnez Numérotation

Astuce a la place de Référence sous Insérer une référence a.

L'AutoTexte inséré a la suite de la procédure décrite ci-dessus consiste en un tableau 1x2. La
cellule de gauche contient la formule et celle de droite le numéro. Le numéro est un compteur
auto-incrementé nommeé Texte. Vous pouvez éditer cet AutoTexte si par exemple vous préférez
des crochets plutdét que des parenthéses ou si vous préférez que la formule et le numéro soient
séparés par une tabulation plutdt que dans un tableau. Reportez-vous a la section Utilisation des
AutoTextes au chapitre 3 du Guide Writer (Travail avec du texte).
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rChamps ﬁ1

|Document Renvois |Fu-nctions|1nfo docurment |‘u"ariables | Base de données |
Type de champ Sélection
Définir une référence
Insérer une référence ()
Titres 3)
Paragraphes numérotés
Repéres de texte
Insérer une référence a Mom
Page 1]
Chapitre
Suprafinfra
D'aprés le style de page
Catégeorie et numéro
Texte de légende
Mumérotation
Insérer l ’ Fermer ] ’ Aide

b

Figure 21 : Insertion d’un renvoi d’'un numéro d’équation

Position

Par défaut une formule est ancrée Comme caractére dans un document Writer. Mais comme pour
tout autre objet OLE, vous pouvez modifier le mode d’ancrage pour positionner la formule ou vous
voulez. Pour plus de détails, voir le chapitre 11 du guide Débuter avec LibreOffice (Les graphiques,
la Gallery et I'outil Fontwork).

Par défaut, les objets formules ancrés Comme caractére, sont automatiquement alignés
verticalement sur la ligne de base du texte les entourant. Pour aligner manuellement la formule,
sélectionnez le menu Outils > Options > LibreOffice Writer > Aide au formatage et décochez
I'option Alighement sur la lignhe de base Math. Ce paramétrage est enregistré dans le document
courant et s’applique a toutes les formules de ce document. Les nouveaux documents utilisent le
réglage courant de ce dialogue.

Espacement

Un objet Math inséré a des marges a gauche et a droite pour le séparer du texte I'entourant. Si
vous n’en voulez pas, il est préférable de modifier le style de cadre pour les formules, car cela
s'appliquera simultanément sur toutes les formules existantes du document, ainsi que celles qui
seront insérées. Suivez ces étapes :

1) Affichez le styliste par la touche F11. Le dialogue Styles et formatage s’ouvre.

2) Cliquez sur le bouton Styles de cadre.

3) Cliquez-droit sur le style de cadre Formule.

4) Sélectionnez Modifier dans le menu contextuel. Le dialogue Style de cadre s’ouvre.
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5) Cliquez sur 'onglet Adaptation du texte. Modifiez & 0 les valeurs pour A gauche et A droite
dans la section Espacement.

6) Cliquez sur OK pour fermer le dialogue.

Ceci permet de changer I'espacement pour toutes les formules qui n'ont pas leur espacement
modifié manuellement. Pour plus de détails sur comment utiliser les styles, voir la section Mise en
forme par défaut avec style page 35.

Mode Texte

Les grandes formules doivent toujours étre dans leur propre paragraphe, séparées du reste du
texte. Lors de I'emploi d’éléments de formule dans le coeur du texte, ils risquent souvent d'étre plus
grand que la hauteur du texte.

Cependant, s'il est nécessaire de placer une formule dans le cceur du texte, entrez dans I'éditeur
d’équation et sélectionnez le mode Format > Mode Texte. Math essaiera de réduire la taille de la
formule pour correspondre a la hauteur du texte. Les numérateurs et dénominateurs de fractions

sont réduits et les limites des intégrales et des sommes sont placées a c6té du signe
intégrale/somme.

Exemple :
Une formule dans un paragraphe séparé :

5
2
21

i=2

et la méme formule insérée en mode texte : Zfzz i2

Arriere-plan, bordures et taille

A propos du formatage, les formules sont traitées comme des objets de type cadre utilisant le style
de cadre Formule. La couleur d’arriere-plan et les bordures peuvent étre choisies a 'aide du style
ou modifiées manuellement pour chaque formule par le menu Format > Cadre/Objet, ou par clic-
droit sur la formule et sélection de Objet dans le menu contextuel. Par défaut les formules ont un
arriere-plan transparent et pas de bordure. La taille des formules ne peut pas étre modifiée
directement : dans Writer cela dépend directement de la fagon dont la formule a été construite (voir
Modifier la taille de police page 19).

Créer une bibliotheque de formules

Si vous utilisez le module Math de LibreOffice directement avec Fichier > Nouveau > Formule,
vous créez des documents avec le suffixe .odf (OpenDocument Formula), chacun contenant une
seule formule. Vous pouvez les utiliser pour vous constituer une bibliotheque des formules les plus
utilisées. Les formules insérées dans un document peuvent également étre enregistrées comme
des documents Math séparés en cliquant-droit sur la formule et en sélectionnant dans le menu
contextuel Enregistrer la copie sous. Pour insérer un document Math dans un document Writer,
sélectionnez le menu Insertion > Objet > Objet OLE. Sélectionnez |'option Créer a partir d’'un
fichier et entrez le chemin du fichier ou cliquez sur le bouton Rechercher pour parcourir votre
systeme de fichiers.

Vous ne pouvez pas insérer le document par glisser-déposer avec la souris, ni a

Note I'aide du menu Insertion > Fichier.
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Les formules ne peuvent pas étre stockées dans la Gallery car elles ne sont pas dans un format
graphique. Vous pouvez cependant enregistrer une formule en tant qu’AutoTexte. Ecrivez la
formule dans un paragraphe séparé, sélectionnez-la, et sélectionnez le menu Edition >
AutoTexte. Pour plus d'information, reportez-vous a la section Utilisation des AutoTextes du
chapitre 3 du Guide Writer (Travail avec du texte).

Insertion rapide de formule
Si vous connaissez le balisage de votre formule, une méthode rapide pour I'insérer consiste a :

e écrire le code de la formule dans Writer,
¢ sélectionner ce code,

e appeler linsertion de formule aussi bien par le bouton que par le menu ou le raccourci
clavier (voir Ajouter un raccourci clavier page 31).

Ceci évite I'ouverture des fenétres d'insertion de formule et permet un gain de temps correct.

Les formules dans Calc, Impress, et Draw

Propriétés graphiques

Les objets formule ont des propriétés similaires dans Calc, Impress et Draw. lls sont toujours
insérés avec un arriere-plan transparent et sans bordure. Dans Draw et Impress, le style graphique
Standard leur est assigné ; il n'y a pas de style assigné dans Calc et les propriétés doivent étre
spécifiées manuellement. Les propriétés accessibles par le styliste, le menu contextuel ou le menu
Format > Image sont limitées si ce n’est indisponibles.

Ligne, Remplissage, Ombre
Vous pouvez fixer des valeurs, mais elles sont complétement ignorées.

Attributs de texte

Tous les attributs de texte, tels que la police ou I'alignement, ne font pas référence au texte de la
formule, mais a I'élément texte présent dans tout objet graphique. Pour un objet sélectionné, ce
texte est accessible avec la touche F2. Pour plus d’'information, référez-vous a la section Travailler
avec du texte dans Draw au chapitre 10 (Technigues avancées de Draw) du Guide Draw.

Position

Une formule peut étre positionnée a I'endroit de votre choix. Utilisez la souris, les touches fleches
ou le dialogue Position et taille du menu Format > Position et taille.

Taille

Dans les documents, une formule n’est pas représentée directement, mais remplacée par un
graphique. La taille de ce graphique est protégée. Pour changer la taille, ouvrez le dialogue
Position et taille et dans le premier onglet Position et taille, dans la section Protéger, décochez la
case Taille. Ceci rend active la section Taille juste au-dessus. Entrez vos modifications. A la
fermeture du dialogue, la taille va étre immédiatement protégée a nouveau.

Modifier la taille n’affecte pas la formule elle-méme mais seulement sa représentation graphique.
En particulier la taille de base de police (cf. Modifier la taille de police page 19) n’est pas modifiée.
Pour revenir a la taille définie par la formule elle-méme, utilisez la commande Taille d’origine
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accessible par le menu contextuel. Ceci permet de corriger les erreurs de taille parfois introduites
par l'insertion d’'une formule d’un module différent.

Rotation, cisaillement, réflexion

Les effets de rotation, cisaillement et réflexion (création d’image miroir) ne sont pas possibles ; les
options correspondant dans les dialogues ne sont pas activées. Si vous avez besoin de ces effets,
vous devez d'abord convertir la formule en graphique Métafichier GDI. Une fois cette conversion
effectuée, ce ne sera plus une formule mais une image. Pour cela, copiez la formule dans le
presse-papier. Sélectionnez le menu Edition > Collage spécial ou, dans la barre d'outils
Standard, utilisez le menu Coller (disponible a I'aide du petit triangle a droite de I'icbne Coller) et
sélectionnez I'option Métafichier GDI.

Combiner des formules avec du texte

Comme une formule est un objet OLE, vous ne pouvez pas l'insérer dans le contenu d’une cellule
d’'une feuille de calcul, un graphigue ou un objet de présentation. Ainsi, contrairement a Writer,
VOus ne pouvez pas intégrer une formule a l'intérieur d’un texte. Voici quelques alternatives :

Mettre les éléments de texte a I’intérieur de la formule
Vous pouvez écrire le texte directement a I'intérieur de la formule. Par exemple :

L'illustration d'un parallélogramme suggere la

relation AB=CD < AC=BC .

Mais cela ne constitue pas une démonstration.
Le balisage correspondant est :

"L'illustration d'un parallélogramme suggere la" newline
"relation " widevec AB = widevec CD dlrarrow widevec AC = widevec BC "." newline
"Mais cela ne constitue pas une démonstration."

Les lignes n'ont pas de renvoi automatique ; vous devez utiliser la balise newline.

Vous pouvez utiliser le menu Format > Polices pour faire correspondre le formatage avec celui du
texte environnant. Voir la section Modifier la police page 20.

Grouper les formules avec les objets graphiques

Les formules peuvent facilement étre combinées avec d’autres objets en groupe, ce qui n’est pas
possible dans les documents Writer. Dans I'exemple suivant, les boites de texte sont combinées
avec des formules et des rectangles sont utilisés pour mettre en évidence des éléments de la
formule.

Maintenant, le complément quadratique est inséré
=x"—6x+3"=3"-7

et ensuite les éléments sont rassemblés

x’—6x+37| |=3°=7

=(x-3]-16
Figure 22 : Exemple de regroupement d'objets
rectangles, formules et textes
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Insérer des objets OLE Writer contenant les formules

Pour disposer des mémes fonctionnalités que dans les documents Writer, vous pouvez créer les
formules et leurs textes dans Writer. Choisissez une taille de page qui corresponde approximative-
ment & ce que vous voulez obtenir. N'écrivez pas plus d’'une page car la sélection de page posera
des problémes lors de l'insertion. Enregistrez votre document dans Writer.

Dans Impress (ou Draw ou Calc), sélectionnez le menu Insertion > Objet > Objet OLE et
choisissez l'option Créer a partir d’'un fichier. La formule est insérée en tant qu'objet OLE a
l'intérieur d'un document qui est lui-méme un objet OLE. La conséquence est que la formule n'est
pas modifiable dans Impress. C’est pour cette raison que vous devriez toujours cocher I'option Lier
au fichier. Par la suite, si vous avez besoin de faire une modification, ouvrez le document texte
avec Writer, modifiez la formule et enregistrez le document. Dans Impress, sélectionnez le menu
Edition > Liens puis le bouton Actualiser. N'essayez pas de modifier la formule dans Impress,
vous rendriez la représentation défectueuse.

Formules dans les diagrammes

Un diagramme est lui-méme un objet OLE. Il n’est donc pas possible d’appeler I'éditeur d’équation
a lintérieur du diagramme. Il n'y a pas de module indépendant de LibreOffice pour créer des
diagrammes. Il n'est donc pas possible d'utiliser la méthode décrite ci-dessus avec Writer.
Cependant vous pouvez créer une formule a I'extérieur de I'éditeur de diagramme, la copier dans
le presse-papier, entrer dans le diagramme et coller la formule a partir du presse-papier. Ceci
convertira automatiqguement la formule en un graphique Métafichier. Si vous souhaitez modifier par

la suite la formule, vous devez la supprimer et recommencer la procédure.

Personnalisations

L’éditeur de formules comme fenétre flottante
L'éditeur de formules peut occuper une grande partie de la fenétre Writer. Pour transformer
I'éditeur de formules en fenétre flottante :

1) Déplacez le souris sur le cadre de I'éditeur, comme sur la Figure 23.

2) Maintenez enfoncé la touche Ctrl et double-cliquez.

=mc™2

Figure 23 : Transformer I'éditeur de formules en fenétre flottante

La Figure 24 montre le résultat. Vous pouvez ancrer la fenétre flottante a nouveau en utilisant les
mémes étapes : maintenez enfonceé la touche Ctrl et double-cliquez sur le cadre de la fenétre.
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Commandes |£|

E=mc"2 -

Figure 24 : L'éditeur de formules en tant que fenétre flottante

Ajouter un bouton a une barre d’outils &

Par défaut, le bouton est présent dans la barre d'outils Insérer des modules Writer et Impress.
Vous pouvez cependant ajouter cette icbne a d’'autres barres d’outils :

* Affichage>Barre d'outils>Personnaliser ou clic-droit sur le début d’une barre de menu >
Personnaliser la barre d’outils. Choisir I'onglet Barres d'outils et la barre d’outils
souhaitée.

e Sélectionner la position ou insérer le bouton.
* Cliquer sur Ajouter.

* Choisir la catégorie Insérer, puis la commande Formule, celle correspondant a I'icone Y&
(la commande jfx correspond a I'équivalent d’'une formule du tableur).

s 5
Personnaliser Ajouter des commandes . [&J
Clavier| Barres d"outils Pour ajouter une commande & une barre d'outils, sélectionnez la
catégaorie, puis la commande. Ensuite, faites glisser la commande vers la
Barres d'outils LibreOffice Writer ]| liste Commandes de I'onglet Barres d'outils dans la boite de dialogue
Personnaliser.
Barre d'outils Standard .
Catégorie Commandes
Application - Entrée de bibliographie - Ajouter
o Modeles Enveloppe
Contenu de la barre d'outils — {\f‘fi_chage  Espace insécable
Commandes | [J]  cccooeeo__] Edition %] Fichier =
Options £ -
@ Rétablir inséred B3 Gallep
--------------- E;:::;ents Heur{ Insére une formule dans le
@ Hyperlien Naviguer ?);p document actif.
E22] Contrdles ndex et tables
. Tableau Insérer -
i Afficher les fo .
Dessin % o Ll 5
_______________
[7] @ Rechercher & Description
&) Navigateur Insére une formule dans le document actif.

Figure 25 : Ajout d’un bouton pour l'insertion de Formule

* Cliquer sur Ajouter puis continuer a ajouter des boutons ou cliquer sur Fermer.

e Utiliser les boutons fleches vers le haut et vers le bas pour déplacer éventuellement des
boutons, avant de valider par OK.

Ajouter un raccourci clavier
Vous pouvez affecter un raccourci clavier de votre choix pour l'insertion de formule :

* Menu Outils>Personnaliser, onglet Clavier.

e Sélectionner le niveau du raccourci : LibreOffice pour en disposer dans tous les modules
(si le raccourci n’est pas déja affecté dans ce module) ou uniquement dans le module en
cours.
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Choisir la catégorie Insérer, puis la commande Formule ne correspondant pas au
raccourci F2 (cette commande correspond a I'équivalent d’'une formule du tableur).

Sélectionner le raccourci a affecter, puis cliquer sur Modifier.
Procéder de la méme fagon pour d’autres raccourcis du méme niveau, puis valider par OK.

Si votre raccourci déclenche I'apparition d’une barre de formule du type Calc, c’est que vous avez
choisi la mauvaise fonction Formule.

r ~
Personnaliser [iE-J
|Menus|Clavier |Barres d'outils |E\rénements |
Raccourcis clavier @ LibreOffice
Ctrl+Maj+E Formule - o
Ctrl+Maj+F - Writer
Ctrl+Maj+G
Crl+ Maj+ H Modifier
Ctrl+Maj+1 =
Ctrl+Maj+K
Ctrl+Maj+L
Ctrl+Maj+M
Ctrl+Maj+ N Neouveau document 3 partir d'un modé
Ctrl+Maj+0
Ctrl+Maj+Q Interrompre I'exécution de la macro -
el hdais R -
] Tl b Rétablir
Fonctions
LCatégorie Fonction Touches
Application » | |En-téte PRI Ctrl+ Maj+E
Modéles Entrée
Affichage Entrée de bibliographie =
Edition £ |Enveloppe =
Options Espace insécable
BASIC Fichier
H Formule
Documents -]
Format Gallery
MNaviguer Heure v
Contréles - T b
[ ok [ Annuer |[  aide | [ Reinttialiser

Figure 26 : Ajout d'un raccourci clavier

Personnaliser le catalogue

Si vous avez besoin d’'un symbole qui n’est pas disponible dans Math, vous pouvez I'ajouter vous-
méme au catalogue. L'exemple suivant montre la procédure :

1)

2)
3)

4)

5)

6)

Sélectionnez le menu Outils > Catalogue ou cliquez sur le bouton du catalogue Z pour
ouvrir le catalogue de symboles (Figure 8).

Cliquez sur le bouton Editer. La fenétre d’Edition des symboles (Figure 27) s’ouvre.

Les symboles sont organisés en jeux de symboles. Dans la partie basse de la fenétre,
sélectionnez un jeu disponible pour votre nouveau symbole dans la liste des Jeux de
symboles, par exemple le jeu Spécial. Ou vous pouvez taper directement le nom du
nouveau jeu de symboles dans la boite.

Dans la liste des Polices, sélectionnez la police contenant le symbole souhaité.

Lorsque vous avez sélectionné une police, ses caracteres apparaissent dans la fenétre
d’apercu de la police. Vous pouvez la parcourir a I'aide de I'ascenseur sur le coté, ou
utiliser la liste Plage pour aller directement a I'endroit recherché.

Pour suivre cet exemple, sélectionnez la police DejaVu Sans et la plage Ponctuation
générale.

Cliguez sur le symbole souhaité (ici Ux2032). Il apparait agrandi dans la boite d’apercu a
I'extréme droite (Figure 28). Assurez-vous que le jeu de symboles est Spécial.

Dans le champ Symbole, entrez un nom pour le symbole, par exemple prime.
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7) Sile nom n’est pas utilisé actuellement, le bouton Ajouter devient actif. Cliguez dessus.

8) Vous pouvez immédiatement ajouter d’autres symboles. Pour I'exemple, les symboles
U+2033, nommé dblprime, et U+2034, nomme triprime, sont ajoutés (Figure 29).

9) Cliquez sur OK pour fermer le dialogue.

Edition des symboles l-s-:hj
Symbole précédent | ALPHA |E| Jeu précédent Grec |z|
- ‘ - - - Al B r A | E z H | ® I E | o = Annules
M| N = o | om| P 3 T| vy |le|x|v|ale B y [E
b E t m B L K A u W E o b n g o
T v -] W W t 3 T T ™ ) £ - — ‘ !
" t 1 . e | %o : : C @ E £ B
W od € - c £ 2 & x | = | ¢ N e o | =
R ™ z fa g F oo = T = + — 1 7 N =
- = = = | q S| T Y g8 3 i vV -
Symbaole ALPHA I~
Jeu de symboles Grec |E| ALPHA ALPHA
Police |Open5}rmhol |E|| ! !
E|age |GFEC E| é
Standard
Style andar |E| Grec Grec
Supprimer Modifier Ajouter

Figure 27 : Dialogue d’édition des symboles

Symbole prime [~]
Jeu de symboles Spécial E| ALPHA prime
Police |DejaVu Sans -] ’
Plage |Ponctuation générale [] A kfC>
Style Standard I~ e cpeci
| Supprimer | |  Modifier | |  Ajouter |

Figure 28 : Dialogue d’édition des symboles : nommage du nouveau symbole

Maintenant la zone d’apergu du jeu de symboles montre les nouveaux symboles. lls peuvent étre
sélectionnés comme les autres symboles, soit a partir de ce dialogue, soit en écrivant directement
leur nom dans I'éditeur d’équation sous la forme %prime.

Il'y a de nombreuses polices gratuites contenant un grand nombre de symboles mathématiques.
La police STIX2 mérite une attention particuliére ici. Elle a été développée spécialement pour
écrire des textes mathématiques et techniques. Les polices DejaVu3 et Lucida4 disposent
également d’'une large gamme de symboles.

2 Les fichiers pour la police STIX sont disponibles sur http://www.stixfonts.org
3 Les fichiers de la police DejaVu Sans sont disponibles sur http://www.dejavu-fonts.org
4 Lucida Sans est inclus dans le paquet JRE, qui est probablement déja sur I'ordinateur.
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Attention : = .
j Contrairement aux commandes, les symboles (grecs ou spéciaux) doivent respecter

la casse (majuscule/minuscule) pour étre reconnus.

rS}'mbGE‘S &1
leu de symboles [ Insérer l
'Spécial -] | — |
%ac - T 3 g m 4

& ! Vo= = o Y 4 | Editer.. |
prime

Figure 29 : Catalogue Spécial avec les nouveaux symboles

Beaucoup de symboles sont disponibles dans plus d'une police. Si vous échangez
Note des documents, faites attention d'utiliser une police installée sur les machines de
VOS partenaires.

Dans la configuration par défaut de LibreOffice, seuls les symboles définis par I'utilisateur qui sont
effectivement utilisés dans le document, sont stockés avec lui. Parfois il peut étre utile d’'inclure
tous les symboles définis par I'utilisateur, par exemple quand le document va étre édité par la suite
par une autre personne. Sélectionnez Outils > Options > LibreOffice Math > Paramétrages, et
décochez l'option Incorporer uniquement les symboles utilisés (taille de fichier inférieure).
Ce paramétrage est uniquement accessible lors de [I'utilisation de Math comme module
indépendant.

Personnaliser un opérateur

Pour qu’'un nom soit reconnu comme un nom de fonction, c’est-a-dire qu’il soit écrit en fonte droite
et non italique, il faut faire précéder le nom du mot clé func.

Pour qu'un opérateur soit agrandi et accepte des bornes, comme les sommes ou intégrales, il faut
le faire précéder du mot clé oper. Il est possible d'utiliser une lettre, un hom ou un symbole

personnel (voir Personnaliser le catalogue page 32). Ainsi ' 4, s'écrit oper F from {i in
i€l
I} A_i.

Vous pouvez modifier le comportement d’un opérateur, ou attribuer un comportement d’'opérateur a
un de vos symboles personnels, a I'aide des mots boper pour faire un opérateur binaire, et uoper
pour faire un opérateur unaire.

Espace a la fin d’une formule

L'accent grave ~ (et non I'apostrophe) insére un petit espace supplémentaire dans la formule ; le
tilde ~ insére un espace plus grand. Dans linstallation par défaut, ces symboles sont ignorés
lorsqu’ils sont inclus a la fin d’'une formule. Cependant, pour des formules incluses dans le coeur
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du texte, il peut étre nécessaire de prendre en compte I'espace également a la fin des formules.
Ce paramétrage est seulement accessible avec le module Math indépendant et pas avec un objet
Math inclus dans un document.

Créez un nouveau document Math avec Fichier > Nouveau > Formule. Ouvrez le dialogue des
options avec Outils > Options > LibreOffice Math > Paramétrages. Décochez I'option Ignorer ~
et "~ en fin de ligne.

Mise en forme par défaut avec style

] I_-F-‘p'l_.,' HE] &Elv

Dans Writer, les formules sont mises en forme en suivant le

style de cadre Formule. Dans la fenétre du styliste E;‘flfeﬁeg
(affichage par F11), cliguez sur le 3° bouton Styles de FiliErane

cadre. Cliquez droit sur Formule et sélectionnez Modifier. [ 0°=  nouveau..
Vous pouvez modifier ainsi directement toutes les formules | |Neteenr  Modifier..
du document en ce qui concerne I'espacement (page 26) |

ou larriere-plan (page 27), sauf si vous avez modifi¢ le Flgurel30 : Modification du style
format manuellement. Formule

Pour que cette mise en forme soit appliquée a tous les nouveaux documents Writer, vous devez
intégrer le style Formule dans le modéle par défaut. Pour cela, créez un nouveau document et
modifiez le style Formule comme souhaité. Enregistrez le document par Fichier > Modéles >
Enregistrer. Pour le définir comme modéle par défaut, sélectionnez Fichier > Modéles > Gérer ;
double-cliguez sur Mes modeéles : votre modeéle doit apparaitre juste en dessous. Cliquez droit
dessus et sélectionnez Définir comme modeéle par défaut. La commande Rétablir le modéle
par défaut, permet de revenir au modele par défaut fourni lors de I'installation de LibO.

Les nouveaux documents texte suivront ce modéle.

Application aux formules chimiques

Math a été congu pour écrire des formules mathématiques, mais il peut aussi servir a écrire des
formules chimiques. En chimie, les formules ressemblent & H,O : les noms des éléments sont
habituellement en majuscule droite. Pour écrire les formules chimiques avec Math vous pouvez
commencer en sélectionnant le style droit pour les variables (voir Maodifier la police page 20).

Voici quelques exemples de formules chimiques :

Construction Exemple Entrée

Molécules H,SO, H_2 SO0_4 (notez I'espace !)
Isotopes U U 1sub 92 1lsup 238

lons SO;~ S0_4n{2-{}} ou SO_4n{2"-"}

Notes : 1sub ou 1lsup sont les abréviations de left subscript et left superscript. Les accolades
vides apres 2- sont nécessaires pour éviter une erreur car il n’y a pas de membre apres le moins.

Pour les réactions chimiques réversibles, il N’y a pas de double fleches satisfaisantes dans Math.
Si vous disposez d’une police de caractére comportant un symbole satisfaisant, vous pouvez
utiliser la méthode décrite a la section Personnaliser le catalogue page 32. Par exemple la police
Wingdings 3 fournie par certaines applications de Microsoft comporte la double fleche s.

Sinon, il faut récupérer le caractére spécial d’'un document et le copier, par exemple a partir de
cette formule : C+0=CO "=". Vous trouverez dautres double fleches sur
http://dev.w3.org/html5/html-author/charref a partir du caractere x021C4.
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Exporter et importer

Exporter au format MathML

En plus de I'export au format PDF, comme présenté au chapitre 10 Imprimer, exporter, envoyer par
courrier électronique du Guide de mise en route, Math offre la possibilité d’exporter les formules au
format MathML. Malheureusement les navigateurs ne suivent pas le standard parfaitement. En cas
d’erreur d’affichage, la faute repose sur votre navigateur !

Prenons comme exemple cette formule :

Balisage Résultat
> 1
tlz)=) =
n=1 N
%z€ta (z) = sum from {n = 1} to infinity {1 over a b
{n7"z}} newline left(matrix {a # b ## c # d}right) c d
newline "Texte" newline int_OAx f(t) dt newline x =
3y =1 Texte
[ fle)de
x=3y=1

Cette formule combine plusieurs possibilités offertes par Math, ce qui la rend utile pour les tests.

Si vous travaillez avec Math en tant que module indépendant, sélectionnez le menu Fichier >
Enregistrer sous. Sélectionnez MathML dans la liste des formats de fichier disponibles.

Type: lMathML 1.01 {.rmml) F.miml)
Formule QDF (.odf) (*.odf)

GEent‘ﬁce.Dri 1.0 Formule (som) (*.50m)

Figure 31 : Export MathML

Pour une formule incluse dans un document, sélectionnez Enregistrer la copie sous a partir du
menu contextuel.

Résultats
Cette formule a été successivement testée dans divers navigateurs.

- ¥ 1 _ 1
= 2w SCORI N
n=1
a b
[c (J 1@
lc d |
Texte
Texte
Jof(t)dt Frceyd
x=3y=1 x=3v=1
Firefox 14 Opera 12.00
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<?xml verzion="1.0" encoding="UILF-8"7?>

<math xmlns="http://www.w3.org/1998/Math/ MathML">
<semantics>
<mtableX
<mtri-
<mtd>
<Mrow>
<mo 3tretchy=”fa;3e">f§<!mo>
<Mrow>

Internet Explorer 9

This XML file does not appear to have any style information associated with it. The document tree is shown below.

v<math xmlns="http://www.w3.org/1998/Math/MathML">
v<semantics>
v<mtable>
w<mtr>
w<mtd>
¥ <IMEQW>
<mo stretchy="fal=se">{</mo>
¥ <IMTOW>

Chromium 13 et Google Chrome 20.0

Safari 5.1 ne fait qu’ouvrir le gestionnaire de fichiers pour enregistrer le fichier.

Formats de fichier Microsoft

Les options dans le menu Outils > Options > Chargement/enregistrement > Microsoft Office
contrdlent comment I'import et I'export des formats de fichier de Microsoft Office est effectué par
rapport aux formules.

Chargement

Si [C] est coché, LibreOffice convertit les formules Microsoft au format natif lorsqu’'un document
est chargé. Ceci est possible si les formules ont été créées avec MathTyped (jusqu’a la version
3.1) ou I'éditeur d’équation de Microsoft. Ce dernier est une ancienne version de MathType aux
fonctionnalités réduites sous licence Microsoft et inclus dans le pack Microsoft Office.

Les formules créées par des versions plus récentes de MathType ou par le nouvel éditeur
d’équations de Microsoft OMML6 (Microsoft Office Suite 2010 et en partie 2007) ne peuvent pas
étre converties.

Si un document créé dans Microsoft Office 2010 et contenant une formule OMML est enregistré au
format .doc, Microsoft Office convertit la formule en graphique. Seul ce graphique est alors
accessible a LibreOffice.

Si vous ouvrez un document .docx qui contient des formules OMML, LibreOffice échoue dans la
conversion, que [C] soit coché ou non.

Dans Microsoft Office, les formules créées avec MathType ou I'éditeur d’équation de Microsoft
sont traitées comme des objets OLE. Si [C] n'est pas coché, LibreOffice maintient cet état.
Double-cliquer sur I'objet lance alors MathType et de nouvelles formules peuvent étre insérées via
le menu Insertion > Objet > Objet OLE. Ce réglage est a recommander si vous avez installé
MathType et souhaitez I'utiliser pour créer et éditer des formules.

5 http://www.dessci.com/en/
6 Office Math Markup Language
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Enregistrement

Si [E] est coché, LibreOffice convertit la formule dans une forme lisible et modifiable par I'éditeur
d’équation de Microsoft et MathType. Si [E] n’est pas coché, la formule est considérée comme un
objet OLE au moment de la conversion au format .doc, et reste reliée a LibreOffice. Un double-clic
sur un objet formule dans Word tentera alors de lancer LibreOffice Math.

Si vous enregistrez au format .docx, les formules ne sont pas converties, que vous ayez cocher [E]
ou non.

Ouverture de texte OpenDocument dans Microsoft Word 2010

Dans Microsoft Office 2010, il est possible d'ouvrir des fichiers texte au format OpenDocument
.odt. Microsoft Office 2010 indique une erreur & I'ouverture mais affiche néanmoins un document
« réparé ». Dans ce document toutes les formules originales sont converties au format OMML. Si
Vous enregistrez a nouveau au format .odt, Microsoft Office 2010 convertit les formules en
MathML, et ces formules peuvent étre éditées dans LibreOffice. Prenez soin d'entourer les
symboles qui doivent étre ensemble avec des accolades, méme si elles ne sont pas nécessaires
pour I'affichage dans LibreOffice. Cela permet a LibreOffice de traduire correctement la formule en
MathML. Par exemple, écrivez sum from {i=1} to n {iAN2} plutdét que sum from i=1 to
n in2.

Avec cette procédure, I'élément d’annotation utilisé par LibreOffice pour conserver le balisage
original de la formule est perdu. La conséquence c’est que LibreOffice n’affiche plus le balisage de
Math original dans I'éditeur d’équation, mais génére a la place un nouveau balisage a partir de la
notation interne MathML.

XHTML

Dans les modules autres que Math, le format de fichier XHTML n’est disponible que pour I'export.
C’est la raison pour laquelle I'option se trouve dans le menu Fichier > Exporter plutét que Fichier
> Enregistrer sous. Si cette option est absente de votre configuration, vous pouvez installer le
filtre nécessaire (exécutez I'utilitaire d’installation de LibreOffice, sélectionnez Modifier, puis
Composants optionnels > Filtres pour exemple XSLT). Le graphique de remplacement de la
formule est inclus dans le fichier, mais le balisage original de Math, inclus comme un élément
d’annotation dans MathML, est absent dans ce cas (comparez avec la section Exporter au format
MathML page 36).

Le rendu correct du document dépend du navigateur. Firefox affiche correctement le document, y
compris les formules. Opera et Internet Explorer ont des soucis avec les graphiques inclus.

L'ancien filtre Document HTML (OpenOffice.org Writer)(.html) n’enregistre pas les formules, mais
les remplace par des fichiers au format .gif de faible résolution.

Flat XML

Ce format peut a la fois étre lu et enregistré par LibreOffice. Si I'option n'est pas présente sous
Fichier > Enregistrer sous, vous pouvez installer le filtre nécessaire comme au paragraphe
précédent. Dans ce format, la totalité du contenu du document, y compris le modéle, est enregistré
dans un document XML. En d’autres mots, ce n’est pas un répertoire compressé, comme c’est le
cas normalement pour les fichiers OpenDocument. Chaque formule est incluse en tant qu’élément
MathML, similaire au résultat de I'export au format MathML. Cependant les formules ne sont pas
enregistrées individuellement, mais la totalit¢é du document y compris les formules. Ce format
convient comme entrée directe dans un systéme de contrdle de version externe.
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Extensions pour Math

Si vous utilisez régulierement le module Math, il peut étre intéressant d’'installer une de ces deux
extensions facilitant I'édition de formules. Les deux développeurs ne se concurrencent pas mais
s'aident mutuellement quand c'est possible. Cependant, Dmaths et CmathOOo ne peuvent pas
étre installées simultanément. Ces deux extensions étant complémentaires, il est donc proposé
de les installer dans deux comptes utilisateurs différents, pour les tester avant de choisir.

Dmaths - une extension pour taper plus rapidement les formules mais
pas seulement

Dmaths est une extension pour LibreOffice Writer de macros mathématiques. Elle est
téléchargeable sur le site des extensions : http://extensions.libreoffice.org.

Aprés installation de Dmaths, fermez et relancez LibreOffice. Writer comporte maintenant un
nouveau menu (Figure 32), une nouvelle barre d’outils (paramétrable) avec 36 boutons (Figure
33), une nouvelle barre d'outils avec 26 boutons pour Gdmath (Figure 34), une nouvelle barre
d’outils avec 10 boutons pour AHmath3D (Figure 35), et deux petites barres d'outils pour
activer/désactiver les barres précédentes et accéder a quelques fonctions supplémentaires (Figure
36).

Qutils | Dmaths | Fenétre Aide

swnload 2 Aide sur Dmaths [
Fid FEA r
[=] |1 = E
E5  Références E
O E & Addons » |
GO % o Désintaller Dmaths !
() Choisir les options de Dmaths [Control+Maj+0] [~
= &' Chercher les mises a jour L
i A propos de Dmaths
Figure 32 : Menu Dmaths
Dmaths * X

FEMIBALEITAATFCOFAFRED
P rFrFED /YD -BE#oGemB 1 2 3

Figure 33: Barre d’outils Dmaths paramétrable

Gdmath * X
RAAK S LAw 00000
O O»> @@ @ I fii 2F

Figure 34: Barre d’outils Gdmath
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AHmath3D e

Figure 35: Barre d’outils AHmath3D

Dmat... ¥ X 0O0oTep-Gdmath = =
D Gb o oo PELOER G=

Figure 36: Barre d’outils pour activer/désactiver d’autres fonctions

Dmaths fournit de nombreux outils pour créer des documents mathématiques :

e Créer en 1 clic des formules Math a partir d’entrée texte (boutons orange)

* Créer des formules Math a 'aide d’'une boite de dialogue (boutons violets)

* Etiqueter le texte (boutons bleus)

* Modifier les propriétés des formules existantes (boutons verts)

* Dessiner des graphiques, des grilles, des diagrammes statistiques et des figures
géomeétrigues (boutons cyan)

* Dessiner et modifier des objets géométriques (barre d'outils grise Gdmath, également
disponible dans LibreOffice Draw)

* Dessiner des objets 3D (barre d’outils AHmath 3D avec les modéles en fil de fer)

Le menu permet d’accéder a des add-ons supplémentaires, a la configuration et au guide détaillé
d’Aide sur Dmaths.

L'extension Dmaths a été créée initialement par le mathématicien francais Didier Dorange, mais
est maintenant disponible en allemand, anglais et espagnol, en plus du francais. Le site web
original est www.dmaths.org.

CmathOOo0 et CmathOOO0CAS pour le calcul formel

CmathOOQo est un programme qui permet, via un traitement de texte, de taper des expressions
mathématiques en utilisant a peu pres la méme syntaxe que sur une calculatrice de type lycée.
Avec l'extension CmathOOO0CAS, il est possible d'effectuer des calculs formels comme dans
Xcas? directement depuis le traitement de texte et la mise en forme du résultat est assuré par
CmathOOQo. Cette extension peut étre téléchargée sur le site officiel des extensions :
http://extensions.services.openoffice.org/fr/project/ CmathOOo et
http://extensions.services.openoffice.org/fr/project/CmathOO0CAS ou sur le site de Christophe
Devalland http://cdeval.free.fr a la page http://cdeval.free.fr/spip.php?article85.

7 http://www-fourier.ujf-grenoble.fr/~parisse/giac_fr.html
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Renseignements techniques

Format OASIS Open Document pour la bureautique

La spécification ODF ne propose pas un standard complétement nouveau pour les formules Math
mais reprend le Standard Mathematical Markup Language (MathML) développé par le World Wide
Web Consortium (W3C) pour représenter les formules sur les sites web (voir
http://www.w3.0rg/TR/2003/REC-MathML2-20031021). Des deux types fournis, le balisage de
présentation et le balisage de contenu, ODF utilise le premier. De ce fait, il décrit la représentation
de la formule, plutét que son sens mathématique.

Le langage de balises MathML se différencie de celui utilisé dans I'éditeur d’équations. Ainsi par
exemple, dans la formule int from {i=1} to 3 {f(t) {nitalic d}t}, les éléments
from... to... ne sont pas traduits mais convertis en langage MathML équivalent int_{i=13}/3.
La formulation originale de I'éditeur d’équation est le codage de StarMath8 5.0. Pour éviter qu'il ne
soit perdu, il est enregistré comme élément d’annotation. D’autres applications n’ont pas besoin
d’évaluer ni d’enregistrer cet élément, et ne le créent pas.

Dans LibreOffice une formule est toujours associée avec un graphigue de remplacement. Dans les
formats de contenu — .odf, .odt etc. — ces graphiques sont enregistrés dans un répertoire séparé et
sont liés en interne a leur document. Cependant, si vous utilisez le format “Open Document (Flat
XML)” ou exportez en XHTML, ces graphiques doivent étre inclus. Pour cela, ils sont encodés en
BASEG64.

Manipulation de formules en Basic

Cette section n’est pas une introduction au Basic, mais décrit simplement des aspects spécifiques
des formules. Vous trouverez davantage d’'informations au sujet des types et services a I'adresse :
http://api.libreoffice.org/common/ref/com/sun/star/module-ix.html. Si vous recherchez les notations
employeées ici, I'index vous donnera les descriptions pertinentes.

Formules dans un document Writer

Dans un document Writer, tous les objets OLE, y compris les formules, appartiennent a la
collection de type SwXTextEmbeddedObjects :
oCurrentController = ThisComponent.getCurrentController ()

oTextDocument = oCurrentController.Model
oEmbeddedObjects = oTextDocument.EmbeddedObjects

Cette collection est numérotée en continu depuis 0. Vous pouvez trouver un objet donné avec :

nEndIndex = oEmbeddedObjects.Count-1
for nIndex=0 to nEndIndex
oMathObject = oEmbeddedObjects.getByIndex (nIndex)

Pour déterminer si un objet est effectivement une formule, testez s'il supporte un service
spécifique aux formules :

oModel = oMathObject.Model

if oModel.supportsService ("com.sun.star.formula.FormulaProperties") then
Une autre solution est de tester si le CLSID, que chaque objet OLE posséde, appartient a un objet
Math :

if oMathObject.CLSID = "078B7ABA-54FC-457F-8551-6147¢776a997" then
En utilisant le modéle, vous pouvez modifier les propriétés de la formule, par exemple la taille de
police de base :

oModel .BaseFontHeight = 12

8 LibreOffice est basé sur la suite StarOffice, développée par StarDivision.
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Pour rendre ce changement visible, vous devez redessiner la formule. La propriété
ExtendedControlOverEmbeddedObject fournit des méthodes qui s’appliquent aux objets
OLE:

0oXCOEO = oMathObject.ExtendedControlOverEmbeddedObject
0XCOEO.update ()

A titre d'illustration, voici une macro permettant de modifier le formatage de toutes les formules
déja écrites d’'un document.

Sub ChangeFormatFormule

oCurrentController = ThisComponent.getCurrentController ()
oTextDocument = oCurrentController.Model
oEmbeddedObjects = oTextDocument.EmbeddedObjects
nEndIndex = oEmbeddedObjects.Count-1
for nIndex=0 to nEndIndex

oMathObject = oEmbeddedObjects.getByIndex (nIndex)

oModel = oMathObject.Model

if (not isNull (oModel)) then

if (not isEmpty (oModel)) then
if oModel.supportsService ("com.sun.star.formula.FormulaProperties") then

oModel .BaseFontHeight = 11
policeCommune= "Liberation Serif"

oModel .FontNameVariables= policeCommune
oModel .FontVariablesIsItalic=true
oModel .FontVariablesIsBold=false

oModel .FontNameFunctions = policeCommune
oModel .FontFunctionsIsItalic=false
oModel .FontFunctionsIsBold=false

oModel .FontNameNumbers= policeCommune
oModel .FontNumbersIsItalic=false
oModel . FontNumbersIsBold=false

oModel .FontNameText= policeCommune
oModel .FontTextIsItalic=false
oModel .FontTextIsBold=false

0XCOEO = oMathObject.ExtendedControlOverEmbeddedObject
oXCOEO.update ()
endif
endif
endif
next nindex
ThisComponent.reformat ()
End Sub

Consultez la page d'aide?9 sur FormulaProperties pour connaitre les autres propriétés modifiables.

Formules dans un document Draw/Impress/Calc

Dans un document Draw, Impress ou Calc, les objets OLE sont traités de la méme maniére que
les graphiques. Aprés avoir accédé a un objet particulier, testez si c’est un objet OLE, puis si c’est
une formule. Le coeur de votre macro doit ressembler a :
if oShape.supportsService ("com.sun.star.drawing.OLE2Shape") then
if oShape.CLSID = "078B7ABA-54FC-457F-8551-6147¢776a997" then

oModelFormula = oShape.Model
oModelFormula.BaseFontHeight = 12

Dans ce cas, une mise a jour explicite n’est pas nécessaire.

9 http://api.libreoffice.org/common/ref/com/sun/star/formula/FormulaProperties.html
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Commandes Math - Référence

Opérateurs unaires / binaires

Opération Commande Affichage
Signe + +1 +1

Signe — -1 -1

Signe +/— +-1ou plusminus 1 +1 ou =1
Signe —/+ -+1 ouminusplus 1 ¥l ou FI
Addition + a+b a+b
Soustraction (-) a-»b a—b
Multiplication point a cdot b a-b
Multiplication (X) a times b axb
Multiplication (étoile) a*b axb
Division (en fraction) a over b %

Division (avec opérateur) a div b a+b
Division (avec petite barre) a/b alb
Concaténation a circ b aoh

Division (avec grande barre)

Barre inversée

Non booléen
Et booléen

Ou booléen
Barre inversée

Somme directe

Produit tensoriel

Opérateur unaire personnalisé

Opérateur binaire personnalisé

a wideslash b

a widebslash b

neg a
a and boua & b
a or boua | b
a bslash b

a oplus b

a ominus b

a otimes b

a odot b

a odivide b
uoper monOp b

a boper monOp b

—a
anb ou aAnb
avb ou avb
a\b

a®b

adb

a®b

a®b

a@b
monOp b

a monOp b
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Relations

Opération Commande Affichage
Est égal a=~>b a=b
N’est pas égal a <> boua neq b a#b ou a#b
Plus petit a<boua lt b a<b ou a<b
Plus petit ou égal as<=b a=b
a leslant b as<b
Tres petit all boua << b a<<b ou a<kb
Plus grand a >boua gt b a>b ou a>b
Plus grand ou égal a>=b azb
a geslant b a=b
Tres grand a gg boua >> b a>b ou a>b
Approximativement a approx b a~b
Similaire a sim b a~b
Similaire ou égal a simeq b a~b
Congruent a equiv b a=b
Proportionnel a prop b aoch
Paralléle a parallel b al|b
Orthogonal a ortho b alb
Divise a divides b alb
Ne divise pas a ndivides b atb
Fleche droite a toward b a—b
Double fleche gauche a dlarrow b a<=b
Double fleche gauche et droite a dlrarrow b a=bh
Double fléeche droite a drarrow b a=b
Précede a prec b a<b
Succéede a succ b a>b
Précéde ou équivaut a preccurlyeq b a<b
Succéde ou équivaut a succcurlyeq b axzb
Précede ou équivaut a precsim b a<b
Succéde ou équivaut a succsim b axb
Ne précéde pas a nprec b a+tb
Ne succede pas a nsucc b aFb
Définition a def b a¥p
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Opération Commande Affichage
Correspondance image de a transl b asob
Correspondance origine de a transr b a>b
Opérateurs d’ensemble
Opération Commande Affichage
Appartient ain B a€elB
N’appartient pas a notin B a¥B
Comprend A owns bouA ni b A>b ou A>3b
Intersection A intersection B ANB
Union A union B AUB
Différence A setminus B A\B
Quotient A slash B AlB
Sous-ensemble A subset B AcCB
Sous-ensemble ou égal A subseteq B A<B
Sur-ensemble A supset B A>B
Sur-ensemble ou égal A supseteq B ADB
N’est pas sous-ensemble A nsubset B AZ B
N’est pas sous-ensemble ou égal A nsubseteq B AZB
N’est pas sur-ensemble A nsupset B ADB
N’est pas sur-ensemble ou égal A nsupseteq B A2B
Ensemble vide emptyset J7}
Aleph aleph INY
Ensemble des entiers naturels setN IN
Ensemble des entiers setz Z
Ensemble des rationnels setQ Q
Ensemble des réels setR R
Ensemble des complexes setC C
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Fonctions

Opération Commande Affichage
Valeur absolue abs{a} 4l
Factoriel fact{a} a!

Racine carrée sqrt{a} Va
Racine n®™ nroot{n}{a} Ya
Puissance an{b} a’
Exponentiel func en{a} e’
Logarithme naturel 1In(a) In(a)
Exponentiel exp(a) exp(a)
Logarithme log(a) log(a)
Sinus sin(a) sin(a)
Cosinus cos(a) cos(a)
Tangente tan(a) tan(a)
Cotangente cot(a) cot(a)
Sinus hyperbolique sinh(a) sinh (a)
Cosinus hyperbolique cosh(a) cosh(a)
Tangente hyperbolique tanh(a) tanh (a)
Cotangente hyperbolique coth(a) coth (a)
Arc sinus arcsin(a) arcsin (a)
Arc cosinus arccos(a) arccos(a)
Arc tangente arctan(a) arctan (a)
Arc cotangente arccot(a) arccot (a)
Argument sinus hyperbolique arsinh(a) arsinh (a )
Argument cosinus hyperbolique arcosh(a) arcosh(a)
Argument tangente hyperbolique artanh(a) artanh(a)
Argument cotangente hyperbolique arcoth(a) arcoth (a)
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Opérateurs

Tous ces opérateurs peuvent étre utilisés avec les bornes from (depuis) et to (jusqu’a).

Opération Commande Affichage
Limite lim{a} lim a
Limite inférieure liminf{a} lim inf a
Limite supérieure limsup{a} lim sup a
Somme sum{a} > a
Produit prod{a} 11«
Coproduit coprod{a} [1a
Intégrale int{a} f a
Intégrale double iint{a} ﬂ a
Intégrale triple iiint{a} ﬂf a
Intégrale ronde lint a gﬁ a
Double intégrale ronde 1lint a # a
Triple intégrale ronde 11lint a #jﬁ a

Borne inférieure avec opérateur
somme

Borne supérieure avec opérateur
produit

Bornes supérieure et inférieure avec
intégrale

sum from {3} b
prod to {3} r

int from {r_0} to {r_t}
a

Opérateur personnalisé oper Op from @ to 1 a Opa
0
Attributs
Opération Commande Affichage
Accent aigu acute a a
Accent grave grave a a
Circonflexe inversé check a a
Arrondi breve a a
Cercle circle a a
Point au-dessus dot a a
Double point ddot a a
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Opération Commande Affichage
Triple point dddot a 7}
Ligne au-dessus bar a a
Petite fleche vecteur vec a a
Tilde tilde a a
Accent circonflexe hat a a
Longue fléche widevec abc abe
Long tilde widetilde abc abc
Long circonflexe widehat abc abc
Longue ligne au-dessus overline abc abc
Longue ligne en dessous underline abc abc
Longue ligne au travers overstrike abc acb
Transparent (utiI? pour'disposer’de phantom a

'emplacement d'une taille donnée)

Police gras bold a a
Police non gras nbold a a
Police italiquel0 ital "a" ouitalic "a" a ou a
Police non italique nitalic a a
Tallle police size 16 qv qv
Taille police size +12 qv qv
Taille police size *1.5 qv qv
Police sans serif11 font sans qv qv
Police serif font serif qv qv
Police fixe font fixed qv qv
Couleur cyan12 color cyan qv qv
Couleur jaune color yellow qv

Couleur blanc color white qv

Couleur vert color green qv qv

10 Tout texte non compris entre guillemets droits qui n'est pas une commande, est considéré comme étant
une variable. Par défaut, les variables sont en italique.

11 Il'y a trois polices personnalisées : sans serif (sans empattement), serif (avec empattement) et fixed (non
proportionnel). Pour changer les polices actuellement utilisées (polices personnalisées et polices pour les
variables, nombres et fonctions), utilisez le menu Format > Police (voir page 20).

12 Pour toutes les couleurs, la couleur ne s’applique qu’au texte qui suit immédiatement la balise jusqu’a la
prochaine espace. Pour appliquer la couleur a plusieurs éléments, placez le texte entre accolades.
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Opération Commande Affichage
Couleur bleu color blue qv qv
Couleur rouge color red qv qv
Couleur noir color black qv qv
Couleur magenta color magenta qv qv
Retour a la couleur par défaut color green X qv Xqv
Accc_)lades,p/our changer la couleur de color green {X qv} X qv
plusieurs éléments

Parentheses
Opération Commande Affichage
.Pa_re.nthéses_ Qe, regroupement {a} a
invisibles (utilisées pour le balisage)
Parenthéses rondes (a) (a)
Crochets [b] [5]
Crochets doubles ldbracket c rdbracket lc]
Accolades lbrace w rbrace [w}
Parenthéses d’angle langle d rangle (d)
Parenthéses opérateurs langle a mline b rangle (alb)
Semi-crochets hauts lceil a rceil [a]
Semi-crochets bas 1floor a rfloor la|
Barres simples lline a rline |a|
Doubles barres ldline a rdline llall
Parentheses ajustables a
(ajouter lef_t avant la parenthése lgft ( stack{a # b # z} b
gauche et right avant la right ) .

parenthéese droite)

Crochets ajustables
(comme ci-dessus)

Doubles crochets ajustables

Accolades ajustables

Parentheses d’angle ajustables

left [ a over b right ]

left ldbracket a over b
right rdbracket

left lbrace a over b
right rbrace

left langle a over b
right rangle

SRS

/\ rm— F 1
! SR o a
\/ — _ | I
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Opération

Commande

Affichage

Parenthéses opérateurs ajustables

Semi-crochets hauts ajustables

Semi-crochets bas ajustables

Lignes ajustables

Doubles lignes ajustables

Parentheses dépareillées

(ajouter 1left avant la parenthése
gauche et right avant la
parenthese droite)

Parenthése isolée

Accolade supérieure ajustable

Accolade inférieure ajustable

left langle a over b
mline c¢ right rangle

left lceil a over b
right rceil

left 1floor a over b
right rfloor

left 1lline a over b
right rline

left 1dline a over b
right rdline

left langle a over b
right rfloor

left lbrace stack
{a=2#b=3} right none

{accolade au dessus}
overbrace a

{accolade en dessous}
underbrace {f}

oy,
|

ISTESS AR
—

SHES

SR

a

— —

accolade au dessus

accolade en dessous
;
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Formats

Opération Commande Affichage

Exposant droite an{b} a’

Indice droite a_{b} a,

Exposant gauche a lsup{b} ’

Indice gauche a lsub{b} »a

Exposant centre a csup{b} 2

Indice centre a csub{b} a

Retour & la ligne abcdefghij newline sadkfj abedefghij
sadkfj

Petit espace (grave)
Grand espace (tilde)
Pas de vide

Normal

Pile verticale de 2

Pile verticale, plus que 2

Matrice
Aligné a gauche (le texte est aligné

par défaut au centre)

Aligné au centre

Aligné a droite

Aligné sur le '=' (avec matrice)

Aligné sur le '=' (avec vide)

objet “objet
objet~objet
nospace { x + vy }

X+y

binom{a}{b}

stack{a # b # z}

matrix{
a # b ##
c #d

}

stack{Bonjour # alignl(a)}

stack{Bonjour # alignc(a)}

stack{Bonjour # alignr(a)}

matrix{

a # "=" # alignl{b} ##
{} # "=" # alignl{c+1}
}

stack{

alignl{a} = b #
alignl{phantom{a} = c+1}
}

objet objet
objet objet
x+y

x+y

a
b

>

N

a b

c d

Bonjour

(a)

Bonjour
(a)

Bonjour

(a)

a =b
=c+ 1

a =b
=c+ 1
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Autres

Opération Commande Affichage
Infini infinity ou infty 0 ouU ®©
Dérivée partielle partial 0
Nabla nabla V

Il existe exists 3

Il n’existe pas notexists A
Pour tous forall Y

H bar (constante de Planck sur ) hbar 7
Lambda bar lambdabar A
Partie réelle d'un complexe re R
Partie imaginaire d’'un complexe im 3
Fonction elliptique de Weierstrass wp %)
Epsilon inversé backepsilon E)
Fleche gauche leftarrow —
Fléche droite rightarrow —
Fleche haut uparrow T
Fleche bas downarrow 1
Points en bas dotslow

Points au milieu dotsaxis

Points verticaux dotsvert

Points en diagonale croissant dotsup ou dotsdiag ou

Points en diagonale décroissant

dotsdown
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Le nom des balises des caractéres grecs et spéciaux sont localisés dans la langue
de l'interface. Le tableau ci-dessous les donne pour le frangais. Pour I'anglais, vous
pouvez vous référer au guide officiel anglais. Vous pouvez toujours utiliser le
catalogue de symboles (Figure 8, page 11) pour sélectionner le caractére souhaité a
partir de sa forme. Le nom localisé du caractere sera alors affiché.

Attention

A

Une fois entré, les caractéres s’afficheront correctement quelle que soit la langue.

Contrairement aux mots réserveés, les caractéres spéciaux sont sensibles a la casse.

Caracteres grecs

Les caractéres italiques sont obtenus en ajoutant un i juste aprés le pour cent. Par exemple %iPI

Il  aplace de %PI 11

%ALPHA A | %BETA
%ZETA 7 | %ETA
%LAMBDA A | MU

%P I IT| %RHO
%PHI d | %BKHI
%alpha a | %béta
o .

ﬁvarepsﬂo e | %zéta
%iota L | %kappa
%x1 E | %omicron
%varrho 0 | %sigma
%phi ® | %varphi

%GAMMA
%THETA
%NU
%SIGMA
%PST

%gamma

%eta

T X W 2 T W

K | %lambda
0 | %pi
O | %varsigma

o | %khi

< g M zZz ©

=

X v 3 >

%DELTA A | %EPSILON
%I0TA I | %KAPPA
%X1 = | %OMICRON
%TAU T | %UPSILON
%OMEGA Q

%delta o | %epsilon
%théta 0 | %¥varthéta
%mu w | %nu
%varpi w| %rhod
%tau T | %upsilon
%psi Y | %0méga

E
K
O
Y

S

g c T <

Caractéres spéciaux

Certains caractéres spéciaux correspondent aux mémes symboles que les opérateurs mais il n'y
pas de vérification de syntaxe (présence d’éléments a gauche ou a droite).

%pourmille %o
%pasélément ¢
%et A

%identique =

%tend =
%infini o
%0U vV

%tressuppérieura >

%elément €
%angle <
%différent =

%tresinférieura <K
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Mots réservés par ordre alphabétique

Un mot réservé est une expression dont |’utilisation est particuliére et contrdlée par LibreOffice.
Vous ne pouvez pas l'utiliser comme nom de variable. Pour pouvoir utiliser ces mots sans
modification par Math, il faut les mettre entre ". En voici la liste commentée :

: petite espace. Voir opérateur ‘grave’.

A 1 met en exposant. Voir opérateur ‘hat’ et ‘widehat’.
: met en indice

- ! soustraction

-+ : signe -+ avec le -' au-dessus du '+'

: point ; doit avoir un caractére avant

: parenthése ouvrante

: parenthése fermante

: crochet ouvrant

: crochet fermant

: accolade ouvrante de regroupement de caractéres

: accolade fermante de regroupement de caracteres

* NP A e M N A~ -

: produit de convolution
: division avec écriture linéaire

PN

: quand il est devant un crochet, une parenthése ou
une accolade, permet de traiter I’élément comme un
caractere quelconque. Voir opérateurs ‘bslash’ et
‘setminus’.

& : opérateur logique 'et'

# : séparateur entre les éléments d’une ligne d’un
tableau

## : séparateur entre les lignes d’un tableau

% : avant un caractére pour marguer un caractere spécial
(sera affiché normalement s’il n’est pas reconnuy)

%% : commentaire

+ : addition

+- : signe '+-' avec le '+' au-dessus du "'

< : opérateur inférieur a

<?> : marque I'emplacement d’un (des) élément(s) a

c6té d’un opérateur lors de I'utilisation de modeles.

<?> est visible comme un petit carré dans la formule.

La touche F4 permet de les atteindre.

<< : opérateur tres inférieur &

<= : opérateur inférieur ou égal
<> : opérateur différent

= : opérateur égalité

> : opérateur supérieur a

>= : opérateur supérieur ou égal a
>> : opérateur trés supérieur a

| : opérateur ou logique

~ : espace. Voir opérateur ‘tilde’.
abs : fonction valeur absolue
acute : metun accent aigu sur un caractere

aleph : premiere lettre de I’alphabet hébreux (nombre
cardinal)

alignb : (alignement vertical en bas) 13

13 Ce sont des raccourcis obsolétes pour align-

alignc : alignement horizontal centré
alignl : alignement a gauche

alignm : (alignement centré verticalement)
alignr : alignement a droite

alignt : (alignement vertical en haut) **

and : opérateur et

approx : signe environ, deux ~ I’'un sur I'autre
arccos : fonction arc cosinus

arccot : fonction arc cotangente

arcosh : fonction argument cosinus hyperbolique
arcoth : fonction argument cotangente hyperbolique
arcsin : fonction arc sinus

arctan : fonction arc tangente

arsinh : fonction argument sinus hyperbolique
artanh : fonction argument tangente hyperbolique

backepsilon : epsilon renversé
bar : met une barre sur le caractére suivant

binom : metles 2 éléments suivants I’un sur I'autre
black : couleur noir, attribut de ‘color’
blue : couleur bleu, attribut de 'color’

bold

boper : affiche le caractére suivant considéré comme un
opérateur binaire ; sa taille est inchangée

breve : metun demi cercle tourné vers le haut

: style de la police de caractére gras

bslash : opérateur\, comme différence
cdot : opérateur .’ de la multiplication

check : metun accent circonflexe a I’envers

circ : 'rond' opérateur de composition de fonctions
circle : metunrond sur le caractére

color sélection de la couleur : black, blue, cyan,

green, magenta, red, white, yellow
coprod : coproduit (M inversé) ou somme directe
cos : fonction cosinus
cosh : cosinus hyperbolique

cot : cotangente

coth : cotangente hyperbolique

csub : met un indice centré en dessous

csup : metun indice centré au dessus

cyan : couleur attribut de 'color'

dddot met trois points au dessus, notation de la

dérivée triple en physique
: met deux points au dessus, notation de la dérivée
double en physique

ddot

bottom, align-mid et align-top, pour les
alignements verticaux. L’analyseur de Math les
reconnait mais rien n'est modifié.
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def : signe égal avec DEF écrit en petits caractéres
dessus.

div : signe diviser "' avec un '-' au milieu

divides opérateur | (barre de Sheffer), donne le
symbole logique « ou ».

dlarrow : double fleche vers la gauche

les deux sens

dlrarrow double fleche dans

(équivalent)
dot : met un point au dessus, notation de la dérivée en
physique
dotsaxis : aligne ... a mi-hauteur de ligne
dotsdiag : aligne trois points sur une pente a 45°
dotsdown : aligne trois points sur une pente a -45°
dotslow : aligne trois points en bas de ligne
dotsup : aligne trois points sur une pente a 45°

dotsvert : aligne 3 points verticalement

downarrow : fleche vers le bas
drarrow : double fleche vers la droite (implique)
emptyset : ensemble vide

equiv : congru a (signe égal a trois traits)
: il existe (E a I'envers)
exp : fonction exponentielle

exists

fact : fonction factorielle (met un '!" aprés)
fixed : attribut de police

font
forall : quel que soit (A la téte en bas)

: sélectionne une police

'de’, va avec 'to' pour faire 'de &' (avec des
intégrales, des sommes...)

: transforme un texte en fonction

from

func
ge : supérieur ou égal signe « = » horizontal
geslant : supérieur ou égal signe '='le long de >
gg : beaucoup plus grand que >>'

grave : metun accent grave
green : couleur vert, attribut de ‘color’
gt : opérateur plus grand que

hat : met un accent circonflexe

hbar : écrit un h barré (k), constante de Planck réduite

(divisée par )
iiint : intégrale triple, trois fois le signe intégrale
iint : intégrale double, deux fois le signe intégrale
im : fonction partie imaginaire de
in : signe appartient &, élément de
infinity : symbole de I'infini
infty : symbole de I'infini
int : intégrale simple
intersection : opérateur intersection
ital : écrit en italique I’élément suivant
italic : écrit en italique I’élément suivant
lambdabar

langle : < pour ouvrir un '<...>' (crochets d’opérateur
angulaire (langle ... mline ... rangle)

: affiche un lambda barré

lbrace : accolade gauche '{' qui s’affichera
lceil : crochet [ sans le trait du bas
ldbracket
1ldline : double ligne (norme) '||' ouvrante
le : plus petit ou égal avec le « = » horizontal
left

: double crochet ouvrant

: indique que I’objet suivant est traité comme une
parenthése/crochet/accolade ouvrante.
leftarrow : fleche vers la gauche
: plus petit que avec '=' le long du signe '<'
: crochet [ sans le trait du haut

leslant
1floor
1lim : opérateur limite

liminf : opérateur limite inférieure
limsup
lint : intégrale avec un rond dessus, curviligne
11 : opérateur trés inférieur a

1line : barre ouvrante de valeur absolue '|'

: opérateur limite supérieure

11lint : double intégrale avec un rond dessus
111lint : triple intégrale avec un rond dessus
1n : fonction logarithme népérien

log : fonction logarithme décimal

1sub : meten indice a gauche

1sup : meten exposant en bas

1t : opérateur inférieur a '<'

magenta : couleur, attribut de ‘color’

matrix : définit une matrice

minusplus : signe '—+' plus avec le - dessus

mline : ligne verticale '|' (crochets d’opérateur angulaire
(langle ... mline ... rangle)

nabla : opérateur nabla, un delta la téte en bas.

nbold : ne pas écrire en gras.
ndivides opérateur ne divise pas, [/ barré
verticalement

neg : opérateur non
neq : opérateur différent
newline : sautde ligne
ni : signe appartient inversé
nitalic : ne pas écrire en italique

none : attribut de 'left' ou de 'right' pour signaler que la

parenthése de gauche ou de droite est non visible.
notin : opérateur n’appartient pas.
nroot : racine n®m
nsubset : opérateur n’est pas strictement inclus dans
nsubseteq : opérateur n’est pas inclus ou égal dans

nsupset : opérateur n’est pas strictement inclus dans
inversé (de droite a gauche)

nsupseteq : opérateur n’est pas inclus ou égal dans
inversé (de droite a gauche)

odivide : opérateur/ dans un rond
odot
ominus : opérateur '— dans un rond

: opérateur "' dans un rond
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affiche le caractére suivant avec la taille d’un
opérateur (comme sigma majuscule)

oplus : opérateur somme directe, + dans un rond

oper

or : opérateur ou, " la téte en bas
ortho : opérateur orthogonal symbole perpendiculaire
otimes : opérateur produit tensoriel, x dans un rond

over : opérateur division, sert a écrire les divisions avec

les traits de fractions horizontaux.

overbrace met le caractére suivant au dessus des
caracteres précédents avec une accolade
horizontale

overline : met une barre horizontale juste en dessus
de tous les caractéres suivants

overstrike : barre tous les caractéeres

owns : appartient a I’envers (de droite a gauche)

parallel : opérateur paralléle ||

partial : drond de la dérivée partielle

phantom : n’écrit pas les caracteres sélectionnés, laisse
la place vide.

plusminus : opérateur '+-' avec le '+' dessus

prod : opérateur produit,

prop : opérateur proportionnel

rangle : '>' pour fermer un '<...>' (crochets d’opérateur

angulaire (langle ... mline ... rangle)
rbrace : accolade fermante
rceil : crochet fermant sans le trait du bas
rdbracket
rdline : double ligne'||' fermante, norme

: double crochet fermant

re : fonction partie réelle de

red : couleur rouge, attribut de 'color'

rfloor : crochet fermant sans le trait du haut

right : indique que I'objet suivant est traité comme une
parentheése/crochet/accolade fermante.

rightarrow : fleche vers la droite

rline : ligne fermante '|', valeur absolue

rsub : le caractere suivant est formaté en tant qu’indice

rsup le caractere suivant est formaté en tant

gu’exposant
sans : option de police de caractéres
serif : option de police de caracteres

setC : ensemble des complexes.

setminus opérateur \, soustraction dans les
ensembles

setN : ensemble des entiers naturels

setQ : ensemble des rationnels

setR : ensemble des réels

setZ : ensemble des entiers relatifs

sim : opérateur équivalent, écrit un simple ~
simeq : opérateur sensiblement égal, écrit un double ~
sin : fonction sinus

sinh : fonction sinus hyperbolique

size : maodifie les tailles des caracteres

slash : opérateur slash'/'

sqrt : opérateur racine carrée

stack : défini une pile d’éléments séparés avec des #
sub : transforme le caractére suivant en indice

subset : opérateur strictement inclus

subseteq : opérateur inclus ou égal
sum : somme, X

sup : transforme le caractére suivant en exposant

supset : opérateur strictement inclus inversé (de droite
a gauche)

supseteq : opérateur inclus ou égal inversé (de droite a
gauche)

tan : fonction tangente

tanh : fonction tangente hyperbolique
tilde
times

: met un tilde '~' sur le caractére suivant
: opérateur multiplication, 'X'

to : '@, vaavec from pour faire 'de &'

toward : dessine une fleche vers la droite

transl : dessine 2 petits ronds joints par un segment,
celui de gauche est noirci (sighe de correspondance
Image de)

transr : dessine 2 petits ronds joints par un segment,
celui de droite est noirci (signe de correspondance
Origine de)

underbrace : met sous les caractéres précédents une
accolade horizontale avec le caractére suivant
dessous en indice

underline : souligne les caracteres suivants.

union

uoper : le caractére suivant est considéré comme un
opérateur unaire ; sa taille est inchangée

uparrow : fleche vers le haut

: opérateur union, U

vec : met une petite fleche au dessus

white : couleur blanc, attribut de 'color’
widebslash : opérateur qui met un grand ‘\'
widehat : metun chapeau sur les caractéres suivants
wideslash : opérateur division qui met un grand '/
widetilde : metun tilde sur les caractéres suivants

widevec : met une fleche de vecteur sur les caracteres
suivants
wp : fonction de Weierstrass

yellow : couleur jaune, attribut de ‘color’
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