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Windows/Linux Équivalent Mac Effet

Sélection de menu 
Outils > Options

LibreOffice > Préférences Accès aux options de paramétrage

Clic droit z+clic Ouvre un menu contextuel

Ctrl (Contrôle) z (Commande) Utilisé avec d'autres touches

F5 Maj+z+F5 Ouvre le Navigateur

F11 z+T Ouvre la fenêtre Styles & Formatage
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Qu’est-ce que Math ?

Math est le module de LibreOffice pour écrire des équations mathématiques et chimiques. Il est en 
général utilisé comme éditeur d’équation pour les documents texte, mais il peut être utilisé avec 
d’autres types de documents ou comme module en soi. Lorsqu’il est utilisé dans Writer, l’équation 
est considérée comme un objet à l’intérieur du document texte.

Note
L’éditeur d’équation est utilisé pour écrire des équations sous forme symbolique 
comme dans l’équation 1. Si vous cherchez à évaluer une valeur numérique, 
consultez le Guide Calc.

df (x )
dx

=ln( x)+ tan−1(x 2) (1)

ou

NH3+ H2 O⇌ NH 4
+
+ OH−

Pour commencer

Vous pouvez créer une équation (formule) comme un document séparé ou vous pouvez l’insérer 
dans un document Writer ou dans un autre module LibreOffice.

Créer une équation comme un document séparé
Pour créer une équation en tant que document séparé, ouvrez le module Math de LibreOffice avec 
une de ces méthodes :

• Dans la barre de menu, sélectionnez Fichier > Nouveau > Formule.

• Dans la barre d’outils standard, cliquez sur le triangle à gauche de l’icône  Nouveau et 
sélectionnez Formule.

• À partir du centre de démarrage, cliquez sur Formule.

Un document formule vide s’ouvre comme sur la Figure 1.

Figure 1 : Un document formule vide
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La zone supérieure est la fenêtre de visualisation, où l’équation va apparaître pendant et après 
l’écriture. La zone inférieure est l’éditeur d’équation, où le code de l’équation est tapé. La fenêtre 
flottante Éléments va aussi apparaître. 

Insérer une formule dans un document Writer
Pour insérer une formule dans un document Writer, ouvrez le document et sélectionnez dans la 
barre de menu Insertion > Objet > Formule.

Par défaut, l’éditeur d’équation apparaît en bas de la fenêtre Writer, ainsi que la fenêtre flottante 
Éléments.  Une boite avec une bordure grise va également apparaître dans votre document,  à 
l’endroit où la formule sera affichée, comme le montre la Figure 2.

Figure 2: Éditeur d’équation, fenêtre Éléments et placement de l’équation dans Writer

Astuce Si la fenêtre Éléments est absente, faîtes-la apparaître avec Affichage > Éléments.

Quand vous avez fini de taper la formule, vous pouvez fermer l’éditeur en appuyant sur la touche 
Échap. ou en cliquant hors de la formule dans le document principal. Un double-clic sur l’équation 
ouvrira à nouveau l’éditeur, pour pouvoir modifier la formule.

Les formules sont insérées en tant qu’objets OLE. Dans un document Writer, la formule est ancrée 
par défaut comme caractère. Elle est ainsi incluse dans la continuité du texte. Comme pour tout 
objet OLE, vous pouvez modifier l’ancrage et rendre la formule flottante. Dans les documents Calc, 
Impress et Draw, les formules sont insérées comme objets OLE flottants.

Si  vous avez régulièrement  besoin  d’insérer  des  formules,  il  est  conseillé  d’ajouter  le  bouton 
Formule à la barre d’outils Standard ou de créer un raccourci clavier (voir Ajouter un bouton à une
barre d’outils ou Ajouter un raccourci clavier page 31).

Écrire une formule

L’éditeur d’équation utilise un langage de balisage pour afficher les formules. Par exemple, %bêta 
créer le caractère grec bêta ( β ). Ce balisage est conçu pour être lu comme de l’anglais (ou du 
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français pour les caractères grecs et spéciaux) autant que possible. Par exemple,  a over b 

donne une fraction : 
a
b

 (over signifiant au-dessus en anglais).

Vous pouvez écrire une formule de trois manières :

• Sélectionnez un symbole de la fenêtre Éléments.

• Cliquez-droit  dans  l’éditeur  d’équation  et  sélectionnez  le  symbole  à  partir  du  menu 
contextuel.

• Tapez le balisage dans l’éditeur d’équation.

Le menu contextuel et la fenêtre Éléments insèrent le balisage correspondant à un symbole. Cela 
permet d’apprendre simplement le balisage de LibreOffice Math.

Note
Cliquez sur le corps du document pour quitter l’éditeur de formule.

Double-cliquez sur une formule pour retourner dans une formule.

La fenêtre Éléments
La méthode la plus simple pour écrire une formule est la fenêtre Éléments.

Figure 3 : Les symboles sont répartis en catégories

La fenêtre Éléments est divisée en deux parties principales :

• Le haut présente les catégories de symboles. Cliquez sur celles-ci pour changer de liste 
de symboles.

• Le bas présente les symboles disponibles dans la catégorie courante.

Astuce Vous pouvez masquer ou afficher la fenêtre Éléments avec Affichage > Éléments.

Exemple 1 : 5×4
Dans cet exemple, nous allons entrer une formule simple : 5×4 . Dans la fenêtre Éléments :

1) Sélectionnez le bouton en haut à gauche de la section des catégories (haut).

2) Cliquez sur le symbole multiplication.
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Figure 4 : Sélection du symbole multiplication 

Quand le symbole multiplication est sélectionné dans la fenêtre Éléments, deux actions ont lieu :

• L’éditeur d’équation affiche le balisage : <?> times <?>

• Le corps du document affiche une boîte grise comme ceci : ×

Figure 5 : Résultat de la sélection du symbole multiplication 

Les symboles  <?> affichés  Figure  5 sont  les  emplacements  que  vous pouvez remplacer  par 
d’autres textes, par exemple 5 et 4. L’équation va se mettre à jour automatiquement, et le résultat 
devrait ressembler à la Figure 6.

Astuce
Lors de l’édition d’une formule, les places réservées sont marquées par des carrés 
dans les formules et des <?> dans la fenêtre de commande. Utilisez F4 et Maj+F4 
pour naviguer entre ces emplacements.

Figure 6 : Résultat après avoir tapé 5 et 4 à côté de l’opérateur multiplication

Écrire une formule 9



Astuce
Pour éviter la mise à jour automatique de l’équation, sélectionnez Affichage 
>Rafraîchir automatiquement l’affichage. Pour rafraîchir une formule 
manuellement, appuyez sur F9 ou sélectionnez Affichage > Actualiser.

Menu clic-droit (contextuel)
Une autre façon d’accéder aux symboles mathématiques est de faire un clic-droit dans l’éditeur 
d’équation. Un menu contextuel s’affiche alors comme sur la  Figure 7. Les entrées de ce menu 
correspondent à ceux de la fenêtre Éléments, avec quelques commandes supplémentaires.

Figure 7 : Menu contextuel par clic-droit

Note
Ni la fenêtre Éléments, ni le menu contextuel ne contiennent la liste complète des 
commandes. Quelques commandes non usuelles nécessitent de taper leurs balises. 
L’annexe page 43 de ce manuel propose une liste complète des commandes. 

Balisage
Vous pouvez taper directement le  balisage dans l’éditeur d’équation. Par exemple, vous pouvez 
taper  5 times 4 pour obtenir  5×4 . Si vous connaissez le balisage, c’est la méthode la plus 
rapide pour entrer une formule.

Astuce Le balisage correspond à l’écriture en anglais des formules.

Le  tableau  ci-dessous  présente  une  liste  rapide  des  équations  communes  et  leur  balisage 
respectif. 

Affichage Commande Affichage Commande

a=b a = b a sqrt {a}

a2 a^2 a n a_n
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Affichage Commande Affichage Commande

∫ f x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Caractères grecs

Les caractères grecs (  , , , ,  etc.)  sont courants dans les formules mathématiques.  Ces 
caractères  ne  sont  pas  disponibles  dans  la  fenêtre  Éléments  ou  par  le  menu  contextuel. 
Heureusement, le balisage des caractères grecs est simple : tapez un symbole % suivi par le nom 
du caractère en français.

• Pour écrire un caractère en minuscule, tapez le nom du caractère en minuscule.

• Pour écrire un caractère en majuscule, tapez le nom du caractère en majuscule.

• Pour écrire le caractère en italique, insérez un i entre le % et le nom du caractère.

Un tableau complet  des caractères  grecs est  fourni  page  53.  Le tableau ci-dessous présente 
quelques exemples.

Minuscule Majuscule Minuscule italique Majuscule italique

%alpha → α %ALPHA → Α %ialpha → α %iALPHA → Α

%bêta → β %BÊTA → Β %ibêta → β %iBÊTA → Β

%gamma → γ %GAMMA → Γ %igamma → γ %iGAMMA → Γ

%psi  → ψ %PSI  → Ψ %ipsi  → ψ %iPSI  → Ψ

%phi  → ϕ %PHI  → Φ %iphi  → ϕ %iPHI  → Φ

%thêta → θ %THÊTA → Θ %ithêta → θ %iTHÊTA → Θ

Une autre façon d’entrer des caractères grecs est d’utiliser la fenêtre du catalogue de symboles. 
Sélectionnez Outils > Catalogue. Cette fenêtre est présentée Figure 8. Sous Jeu de symboles, 
sélectionnez Grec et double-cliquez sur la lettre grecque de la liste. La balise du nom du caractère 
est indiquée sous la fenêtre de liste.

Figure 8 : Catalogue des symboles utilisés pour entrer les caractères grecs 
et quelques symboles spéciaux
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Exemple 2 : π ≃ 3,14159
Pour cet exemple nous supposerons que :

• Vous voulez entrer la formule ci-dessus (la valeur de pi arrondie à 5 décimales).

• Vous connaissez le nom du caractère grec (pi).

• Mais vous ne connaissez pas la balise associée avec le symbole ≃ .

Étape 1 : Tapez % suivi du texte pi. Le caractère grec π s’affiche.

Étape 2 : Ouvrez la fenêtre Éléments (Affichage > Éléments).

Étape 3 : Le symbole ≃  est une relation, donc cliquez sur la catégorie Relations. En maintenant 
la souris sur ce bouton, vous voyez l’info-bulle Relations (Figure 9).

La Figure 10 montre la fenêtre Éléments après avoir cliqué sur le bouton Relations. Le symbole 
recherché est entouré.

Figure 9 : L’info-bulle indique le 
bouton Relations

Figure 10 : Après sélection de Relations

Étape  4 :  Cliquez  sur  le  symbole  a≃ b.  L’éditeur  d’équation  montre  maintenant  le  balisage 
%pi<?> simeq <?>.

Étape 5 : Effacez le texte <?>, appuyez sur F4, puis tapez 3,14159. Le balisage complet est %pi 
simeq 3,14159. La Figure 11 présente le résultat.

Figure 11 : Résultat final
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Modifier une formule

Vous pouvez modifier une formule à tout moment. Pour basculer en mode édition, double-cliquez 
sur une formule.

Choisir la région à modifier
Pour atteindre la section appropriée du balisage, vous pouvez :

• Dans l’éditeur d’équation, cliquer sur la position.

• Sélectionner une zone du balisage que vous souhaitez modifier.

• Cliquer sur un élément de la zone d’aperçu ; le curseur va automatiquement se positionner 
au point correspondant de l’éditeur d’équations.

• Double-cliquer sur un élément de la zone de l’aperçu ;  la section correspondante dans 
l’éditeur d’équations sera sélectionnée.

Dans la fenêtre du module Math indépendant (Figure 1), pour pouvoir travailler dans la zone du 
dessus (aperçu), le curseur de formule doit être activé. Utilisez le bouton Curseur de formule dans 
la barre d’outils Outils.

Effectuer des changements
Vous pouvez modifier une équation en écrasant le texte sélectionné ou en insérant des nouveaux 
codes de balisage à la position du curseur.

Astuce

LibreOffice fournit également une nouvelle manière de modifier une formule en 
apportant les modifications directement dans la zone d’aperçu. Cette fonctionnalité 
est encore en développement et est donc considérée « expérimentale ». Pour 
l’utiliser, vous devez tout d’abord effectuer ce changement de configuration : 
sélectionnez le menu Outils > Options > LibreOffice > Général et cochez Activer 
les fonctions expérimentales (non stabilisées).

L’activation de cette option rend impossible, par clic sur un élément de formule, 
d’atteindre le code de balisage correspondant.

Attention L’utilisation des fonctionnalités expérimentales peut conduire à des arrêts brutaux du 
programme ou des pertes de données. Ne faîtes les modifications ci-dessus que si 
vous en acceptez le risque. 
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Positionnement dans les formules

La partie la plus difficile lors de l’utilisation de LibreOffice Math provient de l’écriture de formules 
complexes. Cette section donne quelques conseils.

Les accolades sont vos amies
LibreOffice Math n’a aucune connaissance de la priorité des opérateurs. Vous devez utiliser des 
accolades ou des parenthèses pour fixer l’ordre des opérations explicitement. Voyez les exemples 
suivants :

Balisage Résultat Balisage Résultat

2 over x + 1
2
x
1 2 over {x + 1}

2
x1

– 1 over 2   
−1
2

– {1 over 2}   −
1
2

Dans le premier exemple, Math a reconnu que le 2 avant et le x après le over appartiennent à la 
fraction et les a représentés ainsi. Si vous voulez x+1 plutôt que x au dénominateur, vous devez 
les encadrer d’accolades de façon à les placer ensemble.

Dans le second exemple, Math a reconnu le signe moins en tant que préfixe de 1 et l’a ainsi placé 
au numérateur de la fraction. Si vous voulez montrer que la fraction entière est négative, avec le 
signe moins devant la fraction, vous devez encadrer la fraction d’accolades pour signifier à Math 
que la fraction est un ensemble.

Les accolades appartiennent uniquement au balisage du code et ne sont pas visibles. Si vous 
souhaitez utiliser des accolades dans une formule, utilisez les commandes lbrace et rbrace.

Comparez les exemples suivants :

Balisage Résultat Balisage Résultat

x over {–x + 1}
x

−x+1
x over lbrace –x + 1 
rbrace

x
{−x+1}

Faire de grandes parenthèses (pour les matrices)
Commençons par présenter la commande pour les matrices : matrix.

Balisage Résultat

matrix { a # b ## c # d } a b
c d

Note Les lignes sont séparées par deux # et chaque élément d’une ligne par un #.

Le premier problème rencontré avec les matrices est que les parenthèses ne s’adaptent pas à la 
taille de la matrice :
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Balisage Résultat

(  matrix { a # b ## c # d }  ) 
a b
c d



LibreOffice  Math  dispose  de  parenthèses  ajustables :  les  parenthèses  s’agrandissent  pour 
s’adapter  à  la  taille  de  leur  contenu.  Utilisez  les  commandes  left( et  right) pour  obtenir  les 
parenthèses ajustables.

Balisage Résultat

left(  matrix { a # b ## c # d }  right) a b
c d 

Astuce
Utilisez left[ et right] pour obtenir des crochets. La liste des parenthèses utilisables 
est donnée page 49.

Astuce
Si vous préférez avoir toutes les parenthèses ajustables, sélectionnez le menu 
Format > Espacement. Puis dans le dialogue, sélectionnez la catégorie 
Parenthèses et cochez l’option Ajuster toutes les parenthèses.

Ces parenthèses ajustables sont bien sûr utilisables avec n’importe quel élément autre que les 
matrices : fraction, racine, etc.

Parenthèses isolées ou dépareillées
Math s’attend que pour chaque parenthèse ouvrante, il y aura une parenthèse fermante. Si vous 
oubliez une parenthèse, Math insère un point d’interrogation rouge à l’envers ¿ pour la parenthèse 
manquante.  Celui-ci  disparaît  dès  que  les  parenthèses  sont  appariées.  Parfois  l’oubli  d’une 
parenthèse  détruit  toute  la  structure  de  la  formule.  Cependant,  une  parenthèse  dépariée  est 
parfois nécessaire. Deux options sont alors possibles :

Avec des parenthèses non ajustables, faîtes précéder par une barre oblique inversée (backslash) 
\ pour indiquer que le caractère suivant ne doit pas être considéré comme une parenthèse mais 
un caractère littéral.  Ainsi l’intervalle semi-ouvert  [a;b[ est représenté par  \[a;b\[  — vous 
pouvez comparer avec le balisage  [a;b[. Vous pouvez aussi mettre entre guillemets droits les 
parenthèses pour qu’elles soient considérées comme du texte : "["a;b"[".

Les parenthèses ajustables  peuvent  aussi  être dépariées.  Le même intervalle  semi-ouvert  est 
représenté par :

left [ a; b right [
Pour les parenthèses ajustables, vous pouvez également utiliser la balise none pour remplacer la 
seconde parenthèse non existante :

∣x∣={ x pour x≥0
−x pour x<0

peut être représenté par : 

abs x = left lbrace stack {x "pour" x >= 0 # -x "pour" x < 0} right 
none
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Reconnaissance des fonctions dans Math
Dans l’installation par défaut, Math affiche les variables en italique. Si vous tapez une fonction, 
Math habituellement la reconnaît et l’affiche normalement. Si Math ne reconnaît pas une fonction 
(une liste des fonctions reconnues démarre page 46), vous pouvez forcer Math à la reconnaître. 
Tapez la balise func avant la fonction, et le texte qui suit sera connu comme une fonction.

Certaines fonctions reconnues par Math nécessitent d’être suivies de nombres ou de variables. S’il 
n’y en a pas, Math affiche un point d’interrogation rouge à l’envers ¿ à leur place, que vous pouvez 
supprimer en corrigeant la formule : tapez une variable ou un nombre, ou une paire d’accolades 
vide { }.

Astuce Pour naviguer entre les différentes erreurs, utilisez F3 et Maj+F3.

Équations sur plusieurs lignes

Supposez que vous voulez écrire une équation sur plusieurs lignes, par exemple : x=3
y=1

Votre  première  réaction  serait  de  simplement  appuyez  sur  la  touche  Entrée.  Cependant  en 
appuyant sur la touche Entrée, bien que le balisage passe à la ligne suivante, l’équation résultante 
ne  le  fait  pas.  Vous  devez  taper  la  balise  newline explicitement,  comme l’illustre  le  tableau 
suivant :

Balisage Résultat

x = 3

y = 1
x=3 y=1

x = 3 newline

y = 1
x=3
y=1

Si vous souhaitez poursuivre le calcul sur une nouvelle ligne sans écrire une nouvelle équation 
complète, cela n’est pas possible directement, car Math attend un terme de part et d’autre du signe 
égal. Vous pouvez les remplacer par :

• des guillemets vides "". Cela va automatiquement aligner la ligne à gauche ;

• des accolades vides { }. La ligne suivante sera centrée.

L’alignement des signes égal les uns au-dessus des autres est décrit page 18.

De même l’espacement entre les éléments d’une formule n’est pas géré par les espaces tapés 
dans le  code.  Il  faut  pour cela utiliser  les balises d’espace :  ` (accent  grave) pour une petite 
espace, ~ pour une grande espace. Une autre solution est d’ajouter les espaces entre guillemets 
droits pour être comme du texte. Les balises d’espace en fin de formule sont par défaut ignorées 
(voir Espace à la fin d’une formule page 34)

Ajouter des limites aux signes somme ou intégrale
Les balises de type  sum et  int (voir la liste complète page  47) peuvent (de façon optionnelle) 
utiliser les paramètres from et to. Ces derniers sont utilisés pour les limites inférieure et supérieure 
respectivement. Ces paramètres peuvent être utilisés séparément ou ensemble. 
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Balisage Résultat

sum from k = 1 to n a_k ∑
k=1

n

a k

int from 0 to x f(t) dt

ou 

int_0^x f(t) dt
∫
0

x

f t dt  ou ∫0

x
f  t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Note Pour plus de détails sur les intégrales et les sommes, voir page 47.

Écrire une dérivée
Écrire des dérivées se résume principalement à : dîtes à LibreOffice que c’est une fraction.

Autrement dit, vous devez utiliser la commande  over. Combinez ceci avec la lettre  d (pour une 
dérivée  totale)  ou  la  commande  partial (pour  une  dérivée  partielle)  pour  obtenir  l’effet  d’une 
dérivée.

Note Notez l’utilisation des accolades pour écrire les dérivées partielles.

Balisage Résultat

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial t^2} ∂2 f
∂ t2

Pour écrire les noms de fonction avec les primes, comme habituellement en notation scolaire, vous 
devez d’abord ajouter ces signes au catalogue.  L’utilisation de l’apostrophe ou des guillemets 
droits est inesthétique. Voir la section Personnaliser le catalogue page 32.

Caractères du balisage en tant que caractères normaux
Les caractères utilisés comme balise ne peuvent pas être tapé directement comme caractères 
normaux. Les caractères concernés sont : %, {, }, &, |, _, ^ et ". Par exemple vous ne pouvez pas 
taper 2% = 0,02 ou 1" = 2,56cm. Deux méthodes sont disponibles pour dépasser cette limitation :

• Utiliser les guillemets droits pour marquer le caractère comme texte, par exemple 2"%"= 
0,02. Cela n’est bien sûr pas utilisable pour les guillemets droits eux-mêmes.

• Ajouter le caractère au catalogue comme indiqué à la section Personnaliser le catalogue 
page 32. 
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Dans quelques cas, vous pouvez utiliser des commandes :

• lbrace et rbrace donnent des accolades {}.

• mline donne une ligne verticale, par exemple (2 mline 3) pour (2∣3)

La conversion avec une référence de caractère comme dans le langage html ou l’utilisation d’un 
caractère d’échappement n’est pas possible avec Math.

Texte dans une formule
Pour inclure un texte dans une formule, il suffit de l’entourer de guillemets droits :

abs x = left lbrace matrix {x # "pour " x >= 0 ## -x # "pour " x < 0} 
right none

∣x∣={ x pour x≥0
−x pour x<0

Tous  les  caractères,  à  l’exception  des  guillemets  droits,  sont  autorisés  dans  un  texte. 
Malheureusement la boite de dialogue d’insertion des caractères spéciaux n’est pas disponible 
dans Math. En cas de nécessité, il est possible d’écrire le texte dans Writer et de le copier dans 
l’éditeur d’équation par le presse-papier. De cette manière, des guillemets français peuvent être 
insérés comme ci-dessous :

Figure 12 : Guillemets français insérés par copier-coller depuis Writer.

Le texte s’affiche dans la police sélectionnée par la liste Texte dans le dialogue Polices (voir infra 
la section Modifier la police page 20). Pour utiliser une police du bas de la fenêtre de la Figure 16, 
utilisez un balisage font serif, font sans ou font fixed avant le texte.

Par défaut le texte est aligné à gauche. Vous pouvez changer l’alignement avec alignc ou alignr. 
(voir Modifier l’alignement page 23)

Les balises ne sont pas interprétées à l’intérieur d’un texte. Utilisez les guillemets pour interrompre 
le texte et pour utiliser du balisage de formatage.

"Dans les triangles " color blue bold "isocèles" ", les angles de la 
base sont égaux" 

Dans les triangles isocèles , les angles de la base sont égaux

Alignement des équations sur leur signe égal
LibreOffice Math ne dispose pas d’une commande pour aligner les équations sur un caractère 
particulier, mais vous pouvez utiliser une matrice pour le faire, comme dans cet exemple :
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Balisage Résultat

matrix{

   alignr x+y # {}={} # alignl 2 ##

   alignr x   # {}={} # alignl 2-y

}

x+ y = 2
x = 2− y

Les accolades vides autour des = sont nécessaires car = est un opérateur binaire et nécessite une 
expression de chaque côté.

Vous pouvez réduire l’espace autour  des = si  vous changez l’espacement inter-colonne de la 
matrice :

1) Dans l’éditeur d’équation, sélectionnez Format > Espacement dans la barre de menu.

2) Dans  le  dialogue  d’espacement  (Figure  13),  cliquez  sur  le  bouton  Catégorie et 
sélectionnez Matrices dans menu déroulant.

3) Entrez 0% pour l’espacement entre les colonnes et cliquez sur OK.

Figure 13 : Modification de l’espacement dans une matrice

Modification de l’apparence des formules

Modifier la taille de police
C’est une des questions les plus courantes au sujet de LibreOffice Math. La réponse est simple,  
mais peut-être pas si intuitive :

1) Dans l’éditeur de formule, sélectionnez le menu Format > Taille de police.

2) Sélectionnez une taille de police plus grande avec Taille de base (entrée tout en haut).

Figure 14 : Modifier la taille de base (en haut) pour agrandir la formule
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Le résultat de ce changement est illustré sur la Figure 15.

Figure 15 : Résultat du changement de la taille de base de la police

Note

Le changement de taille de police ne s’applique que pour la formule courante. Pour 
changer la taille de façon permanente, cliquez sur le bouton Par défaut puis OK. Un 
changement de la taille par défaut pourra, par exemple, rendre votre travail bien plus 
facile lorsque vous préparez une présentation longue et que vous voulez toutes les 
formules en taille de base 28pt. Cependant, n’oubliez pas de ramener la taille de 
base à sa valeur originale à la fin de votre travail.

Attention : cela n’affecte que la formule courante et les prochaines formules que 
vous créerez. Pour modifier toutes les formules déjà créées dans un document, il 
faut utiliser une macro (voir annexe page 41).1

La taille d’un sous ensemble de caractères dans une formule peut se changer avec la commande 

size. Exemple : b size 5{a} : b a . Avec la fenêtre Éléments, l’avant dernière icône  de 
l’onglet  Attributs permet d’obtenir la commande  size.  La valeur après  size peut être absolue 
(une valeur numérique) ou relative par rapport au contexte (par défaut la taille de base) : +6, -3, 
/2,  ou  *2 par  exemple.  L’emploi  de  valeur  numérique  décimale  nécessite  d’utiliser  un  point 
comme séparateur décimal.

Modifier la police
Les polices utilisées dans Math peuvent être modifiées à l’aide du menu Format > Polices.  La 
section Polices des formules (Figure 16) fait référence aux quatre éléments de formule spécifiés. 
La police pour les opérateurs, les relations et les parenthèses n’est pas affectée, car ces éléments 
viennent  normalement  de  la  police  OpenSymbol.  De  la  même façon,  les  éléments  issus  du 
catalogue  (cf.  Personnaliser  le  catalogue page  32)  continuent  d’être  affichés  dans  la  police 
spécifiée.

Figure 16 : Dialogue des polices

1 http://wiki.documentfoundation.org/FR/FAQ/Math/102 
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La section Polices personnalisées sélectionne la police qui sera utilisée lorsque le balisage font 
serif, font sans ou font fixed est spécifié.

Pour modifier une police, cliquez d’abord sur le bouton Modifier :

Figure 17 : Bouton Modifier

Sélectionnez le type de police à modifier. Le dialogue Polices s’ouvre, montrant toutes les polices 
disponibles dans le système.

Figure 18 : Dialogue des polices

Si vous tapez un premier caractère dans la boite d’entrée du haut, la liste va sauter directement 
jusqu’à cette lettre. Avec quelques caractères supplémentaires, vous pouvez spécifier la police 
exacte recherchée. Si vous ne connaissez pas son nom, utilisez l’ascenseur pour balayer la liste. 
Cliquez sur un nom pour avoir un aperçu dans la zone du bas.

Comme les variables devraient être en italique, assurez-vous que la case Italique est bien cochée. 
Pour les autres éléments,  il  convient  de laisser  la forme basique (Roman).  Le style peut  être 
facilement modifié dans la formule elle-même à l’aide des balises italic ou bold (gras) pour activer 
ces caractéristiques et nitalic ou nbold pour les annuler.

Quand une nouvelle police est sélectionnée pour une formule, l’ancienne police reste disponible 
dans la liste avec la nouvelle, et peut être à nouveau sélectionnée. Ceci ne dure que le temps de 
la session ; l’ancienne police n’est pas stockée de façon permanente.

Vous pouvez choisir n’importe quelle police, mais si vous échangez des documents, vous devriez 
choisir des polices également présentes sur l’ordinateur de votre collègue.
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Ajuster l’espace dans les formules
Pour augmenter ou diminuer l’espace dans les formules, suivez cette procédure :

1) Sélectionnez le menu Format > Espacement.

2) Dans le dialogue Espacement, cliquez sur le triangle à côté de Catégorie, et sélectionnez 
une entrée dans la liste.

3) Sélectionnez les valeurs d’espacement appropriées (les types d’espacement dépendent de 
la catégorie) et cliquez sur OK.

Figure 19 : Dialogue pour l’espacement

Note
Les changements de l’espacement ne s’appliquent que pour la formule courante. 
Pour changer l’espacement des futures formules également, cliquez sur le bouton 
Par défaut puis OK.

Les changements d’espacement sont possibles pour les catégories présentées dans le tableau 
suivant.

Catégorie Ajustement possible

Espacement

Entre les caractères Interligne Espacement de la 
racine

Index

Exposant Indice

Fractions

Numérateur Dénominateur

Barre de 
fraction

Longueur en excès Épaisseur de ligne
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Catégorie Ajustement possible

Limites

Espacement en haut Espacement en bas

Parenthèses

Dépassement vertical Écartement horizontal

Matrices

Interligne Espacement entre les 
colonnes

Symboles

Hauteur primaire Espacement minimum

Opérateurs

Dépassement Écartement

Bordures

À gauche À droite En haut En bas

Modifier l’alignement
Le réglage de l’alignement  détermine comment les éléments de la  formule situés les uns au-
dessus des autres sont alignés horizontalement relativement les uns aux autres. Utilisez le menu 
Format > Alignement pour choisir entre À gauche, Centré ou À droite.

Figure 20 : Dialogue d’alignement 
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Ici à nouveau vous pouvez utiliser le bouton Par défaut pour appliquer le changement à toutes les 
futures formules, et non plus seulement à la formule courante. Le tableau suivant montre l’effet 
dans différentes situations :

Alignement Exemples

À gauche
x2
−9

x (1007 )
c2
=a2

+ b2
−2abcos γ

cos γ=
c2
−a2

−b2

−2ab

Centré (par défaut)
x2
−9
x (1007 )

c2
=a2

+ b2
−2abcos γ

cos γ=
c2
−a2

−b2

−2ab

À droite
x2
−9

x (1007)
c2
=a2

+ b2
−2abcos γ

cos γ=
c2
−a2

−b2

−2ab

Il n’est pas possible d’aligner les formules sur un caractère particulier.

Les réglages par défaut d’alignement ne s’appliquent pas aux éléments de texte ; ils sont toujours 
alignés à gauche. Dans les exemples suivants, l’alignement par défaut est À droite mais le premier 
exemple commence la seconde ligne avec un texte (bien que ce soit un texte vide) et est de ce fait 
aligné à gauche.

Balisage Résultat

{1+2+3+4} over 5 + 2 over {60+70+80+90}

newline

""=2+1 over 150

1+2+3+4
5
+

2
60+70+80+90

=2+
1

150

{1+2+3+4} over 5 + 2 over {60+70+80+90}

newline

{}=2+1 over 150

1+ 2+ 3+ 4
5
+

2
60+ 70+ 80+ 90

=2+
1

150

Indépendamment de l’alignement par défaut, il est possible d’aligner explicitement les formules en 
utilisant les balises alignl, (à gauche), alignc (centré) et alignr (à droite). Ce balisage fonctionne 
aussi pour les éléments de texte.

Modifier la couleur
La commande color permet de changer la couleur d’une sous formule : color red ABC donne 
ABC . Il y a 8 couleurs différentes à choisir parmi : white, black, cyan, magenta, red, blue, 

green, yellow (pour blanc, noir, bleu clair, violet, rouge, bleu, vert, jaune).

Vous pouvez attribuer une couleur à une sous-formule entière si vous la regroupez avec { } ou 
autres parenthèses. Par exemple : A B color green {C D} E pour avoir A BC D E .

Quand plusieurs couleurs sont appliquées, celles qui sont le plus à l’intérieur prennent le dessus 
comme dans cet exemple : color blue {A B color yellow C D} pour avoir A BC D .

Vous ne pouvez pas sélectionner la couleur du fond, il est toujours transparent dans une formule 
Math. La couleur de fond de la formule complète est donc la couleur de fond du document ou du 
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cadre (par exemple un document texte). Dans  Writer,  les propriétés d’objet (clic droit >  Objet) 
permettent de choisir une couleur d’arrière-plan pour l’ensemble de la formule (voir  Arrière-plan,
bordures et taille page 27).

Les formules dans Writer

Numérotation des équations
La numérotation des équations est une des meilleures fonctionnalités cachées de LibreOffice. Les 
étapes sont simples mais peuvent paraître obscures :

1) Dans Writer, démarrez une nouvelle ligne, ou laissez une espace à la fin de votre texte.

2) Tapez nf et appuyez sur F3.

Les caractères nf sont remplacés par une équation numérotée :

E=mc2 (2)

Vous pouvez maintenant double cliquer sur la formule pour l’éditer. Par exemple, voici la fonction 
zêta de Riemann :

ζ( z)=∑
n=1

∞ 1

n z (3)

Vous pouvez faire référence à cette équation (« comme le montre l’équation (2) ») en suivant ces 
étapes dans Writer :

1) Sélectionnez le menu Insertion > Renvoi.

2) Dans l’onglet Renvois (Figure 21), sous Type de champ, sélectionnez Texte.

3) Sous Sélection, sélectionnez le numéro d’équation. 

4) Sous Insérer une référence à, sélectionnez Référence.

5) Cliquez sur Insérer.

C’est  fait !  Si  par  la  suite,  vous  insérez  de  nouvelles  équations  dans  votre  document  avant 
l’équation référencée, toutes les équations vont être automatiquement renumérotées et les renvois 
seront mis à jour.

Astuce
Pour insérer le numéro d’équation sans les parenthèses, sélectionnez Numérotation 
à la place de Référence sous Insérer une référence à.

L’AutoTexte inséré à la suite de la procédure décrite ci-dessus consiste en un tableau 1x2. La 
cellule de gauche contient la formule et celle de droite le numéro. Le numéro est un compteur 
auto-incrémenté nommé  Texte. Vous pouvez éditer cet AutoTexte si par exemple vous préférez 
des crochets plutôt que des parenthèses ou si vous préférez que la formule et le numéro soient 
séparés par une tabulation plutôt que dans un tableau. Reportez-vous à la section Utilisation des 
AutoTextes au chapitre 3 du Guide Writer (Travail avec du texte).
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Figure 21 : Insertion d’un renvoi d’un numéro d’équation

Position
Par défaut une formule est ancrée Comme caractère dans un document Writer. Mais comme pour 
tout autre objet OLE, vous pouvez modifier le mode d’ancrage pour positionner la formule où vous 
voulez. Pour plus de détails, voir le chapitre 11 du guide Débuter avec LibreOffice (Les graphiques, 
la Gallery et l’outil Fontwork).

Par  défaut,  les  objets  formules  ancrés  Comme  caractère,  sont  automatiquement  alignés 
verticalement sur la ligne de base du texte les entourant. Pour aligner manuellement la formule, 
sélectionnez le menu Outils > Options > LibreOffice Writer > Aide au formatage et décochez 
l’option Alignement sur la ligne de base Math. Ce paramétrage est enregistré dans le document 
courant et s’applique à toutes les formules de ce document. Les nouveaux documents utilisent le 
réglage courant de ce dialogue.

Espacement
Un objet Math inséré a des marges à gauche et à droite pour le séparer du texte l’entourant. Si 
vous n’en voulez pas, il est préférable de modifier le style de cadre pour les formules, car cela 
s’appliquera simultanément sur toutes les formules existantes du document, ainsi que celles qui 
seront insérées. Suivez ces étapes :

1) Affichez le styliste par la touche F11. Le dialogue Styles et formatage s’ouvre.

2) Cliquez sur le bouton Styles de cadre.

3) Cliquez-droit sur le style de cadre Formule.

4) Sélectionnez Modifier dans le menu contextuel. Le dialogue Style de cadre s’ouvre.
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5) Cliquez sur l’onglet Adaptation du texte. Modifiez à 0 les valeurs pour À gauche et À droite 
dans la section Espacement.

6) Cliquez sur OK pour fermer le dialogue.

Ceci permet de changer l’espacement pour toutes les formules qui n’ont pas leur espacement 
modifié manuellement. Pour plus de détails sur comment utiliser les styles, voir la section Mise en
forme par défaut avec style page 35.

Mode Texte
Les grandes formules doivent toujours être dans leur propre paragraphe, séparées du reste du 
texte. Lors de l’emploi d’éléments de formule dans le cœur du texte, ils risquent souvent d’être plus 
grand que la hauteur du texte. 

Cependant, s’il est nécessaire de placer une formule dans le cœur du texte, entrez dans l’éditeur 
d’équation et sélectionnez le mode Format > Mode Texte. Math essaiera de réduire la taille de la 
formule pour correspondre à la hauteur du texte. Les numérateurs et dénominateurs de fractions 
sont  réduits  et  les  limites  des  intégrales  et  des  sommes  sont  placées  à  côté  du  signe 
intégrale/somme.

Exemple :
Une formule dans un paragraphe séparé :

∑
i=2

5

i2

et la même formule insérée en mode texte : ∑i=2
5 i2

Arrière-plan, bordures et taille
À propos du formatage, les formules sont traitées comme des objets de type cadre utilisant le style 
de cadre Formule. La couleur d’arrière-plan et les bordures peuvent être choisies à l’aide du style 
ou modifiées manuellement pour chaque formule par le menu Format > Cadre/Objet, ou par clic-
droit sur la formule et sélection de Objet dans le menu contextuel. Par défaut les formules ont un 
arrière-plan  transparent  et  pas  de  bordure.  La  taille  des  formules  ne  peut  pas  être  modifiée 
directement : dans Writer cela dépend directement de la façon dont la formule a été construite (voir 
Modifier la taille de police page 19).

Créer une bibliothèque de formules
Si vous utilisez le module Math de LibreOffice directement avec Fichier > Nouveau > Formule, 
vous créez des documents avec le suffixe .odf (OpenDocument Formula), chacun contenant une 
seule formule. Vous pouvez les utiliser pour vous constituer une bibliothèque des formules les plus 
utilisées. Les formules insérées dans un document peuvent également être enregistrées comme 
des documents Math séparés en cliquant-droit sur la formule et en sélectionnant dans le menu 
contextuel Enregistrer la copie sous. Pour insérer un document Math dans un document Writer, 
sélectionnez le menu  Insertion > Objet > Objet OLE. Sélectionnez l’option  Créer à partir d’un 
fichier  et entrez le chemin du fichier ou cliquez sur le bouton  Rechercher pour parcourir votre 
système de fichiers.

Note
Vous ne pouvez pas insérer le document par glisser-déposer avec la souris, ni à 
l’aide du menu Insertion > Fichier.
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Les formules ne peuvent pas être stockées dans la Gallery car elles ne sont pas dans un format 
graphique.  Vous  pouvez  cependant  enregistrer  une  formule  en  tant  qu’AutoTexte.  Écrivez  la 
formule  dans  un  paragraphe  séparé,  sélectionnez-la,  et  sélectionnez  le  menu  Édition  > 
AutoTexte.  Pour  plus  d’information,  reportez-vous  à  la  section  Utilisation  des  AutoTextes du 
chapitre 3 du Guide Writer (Travail avec du texte).

Insertion rapide de formule
Si vous connaissez le balisage de votre formule, une méthode rapide pour l’insérer consiste à :

• écrire le code de la formule dans Writer,

• sélectionner ce code,

• appeler l’insertion de formule aussi bien par le bouton que par le menu ou le raccourci 
clavier (voir Ajouter un raccourci clavier page 31). 

Ceci évite l’ouverture des fenêtres d’insertion de formule et permet un gain de temps correct.

Les formules dans Calc, Impress, et Draw

Propriétés graphiques
Les objets formule ont  des propriétés similaires dans Calc,  Impress et  Draw.  Ils sont  toujours 
insérés avec un arrière-plan transparent et sans bordure. Dans Draw et Impress, le style graphique 
Standard leur est assigné ; il n’y a pas de style assigné dans Calc et les propriétés doivent être 
spécifiées manuellement. Les propriétés accessibles par le styliste, le menu contextuel ou le menu 
Format > Image sont limitées si ce n’est indisponibles.

Ligne, Remplissage, Ombre
Vous pouvez fixer des valeurs, mais elles sont complètement ignorées.

Attributs de texte
Tous les attributs de texte, tels que la police ou l’alignement, ne font pas référence au texte de la 
formule, mais à l’élément texte présent dans tout objet graphique. Pour un objet sélectionné, ce 
texte est accessible avec la touche F2. Pour plus d’information, référez-vous à la section Travailler  
avec du texte dans Draw au chapitre 10 (Techniques avancées de Draw) du Guide Draw.

Position
Une formule peut être positionnée à l’endroit de votre choix. Utilisez la souris, les touches flèches 
ou le dialogue Position et taille du menu Format > Position et taille.

Taille
Dans les  documents,  une formule  n’est  pas  représentée directement,  mais  remplacée par  un 
graphique.  La  taille  de  ce graphique  est  protégée.  Pour  changer  la  taille,  ouvrez  le  dialogue 
Position et taille et dans le premier onglet Position et taille, dans la section Protéger, décochez la 
case  Taille.  Ceci  rend active  la  section  Taille juste  au-dessus.  Entrez  vos  modifications.  À la 
fermeture du dialogue, la taille va être immédiatement protégée à nouveau.

Modifier la taille n’affecte pas la formule elle-même mais seulement sa représentation graphique. 
En particulier la taille de base de police (cf. Modifier la taille de police page 19) n’est pas modifiée. 
Pour  revenir  à  la  taille  définie par  la  formule elle-même,  utilisez  la  commande  Taille  d’origine 
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accessible par le menu contextuel. Ceci permet de corriger les erreurs de taille parfois introduites 
par l’insertion d’une formule d’un module différent. 

Rotation, cisaillement, réflexion
Les effets de rotation, cisaillement et réflexion (création d’image miroir) ne sont pas possibles ; les 
options correspondant dans les dialogues ne sont pas activées. Si vous avez besoin de ces effets, 
vous devez d’abord convertir la formule en graphique Métafichier GDI. Une fois cette conversion 
effectuée, ce ne sera plus une formule mais une image. Pour cela,  copiez la formule dans le 
presse-papier.  Sélectionnez  le  menu  Édition  >  Collage  spécial ou,  dans  la  barre  d’outils 
Standard, utilisez le menu Coller (disponible à l’aide du petit triangle à droite de l’icône Coller) et 
sélectionnez l’option Métafichier GDI.

Combiner des formules avec du texte
Comme une formule est un objet OLE, vous ne pouvez pas l’insérer dans le contenu d’une cellule 
d’une feuille de calcul, un graphique ou un objet de présentation. Ainsi, contrairement à Writer, 
vous ne pouvez pas intégrer une formule à l’intérieur d’un texte. Voici quelques alternatives :

Mettre les éléments de texte à l’intérieur de la formule
Vous pouvez écrire le texte directement à l’intérieur de la formule. Par exemple :

L'illustration d'un parallélogramme suggère la
relation A⃗B=C⃗D⇔ A⃗C=B⃗C .
Mais cela ne constitue pas une démonstration.

Le balisage correspondant est :

"L'illustration d'un parallélogramme suggère la" newline
"relation " widevec AB = widevec CD dlrarrow widevec AC = widevec BC "." newline
"Mais cela ne constitue pas une démonstration."

Les lignes n’ont pas de renvoi automatique ; vous devez utiliser la balise newline.

Vous pouvez utiliser le menu Format > Polices pour faire correspondre le formatage avec celui du 
texte environnant. Voir la section Modifier la police page 20.

Grouper les formules avec les objets graphiques
Les formules peuvent facilement être combinées avec d’autres objets en groupe, ce qui n’est pas 
possible dans les documents Writer. Dans l’exemple suivant, les boites de texte sont combinées 
avec des formules et des rectangles sont utilisés pour mettre en évidence des éléments de la 
formule.

Figure 22 : Exemple de regroupement d'objets 
rectangles, formules et textes
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Maintenant, le complément quadratique est inséré

= x2
−6x+32

−32
−7

et ensuite les éléments sont rassemblés

= x2
−6x+32

−32
−7

=( x−3)
2
−16



Insérer des objets OLE Writer contenant les formules
Pour disposer des mêmes fonctionnalités que dans les documents Writer, vous pouvez créer les 
formules et leurs textes dans Writer. Choisissez une taille de page qui corresponde approximative-
ment à ce que vous voulez obtenir. N’écrivez pas plus d’une page car la sélection de page posera 
des problèmes lors de l’insertion. Enregistrez votre document dans Writer.

Dans  Impress  (ou  Draw ou  Calc),  sélectionnez  le  menu  Insertion  >  Objet  >  Objet  OLE et 
choisissez  l’option  Créer  à  partir  d’un  fichier. La  formule  est  insérée  en  tant  qu’objet  OLE à 
l’intérieur d’un document qui est lui-même un objet OLE. La conséquence est que la formule n’est 
pas modifiable dans Impress. C’est pour cette raison que vous devriez toujours cocher l’option Lier  
au fichier. Par la suite, si vous avez besoin de faire une modification, ouvrez le document texte 
avec Writer, modifiez la formule et enregistrez le document. Dans Impress, sélectionnez le menu 
Édition > Liens puis le bouton Actualiser. N’essayez pas de modifier la formule dans Impress, 
vous rendriez la représentation défectueuse.

Formules dans les diagrammes
Un diagramme est lui-même un objet OLE. Il n’est donc pas possible d’appeler l’éditeur d’équation 
à l’intérieur du diagramme. Il  n’y a pas de module indépendant de LibreOffice pour créer des 
diagrammes.  Il  n’est  donc  pas  possible  d’utiliser  la  méthode  décrite  ci-dessus  avec  Writer. 
Cependant vous pouvez créer une formule à l’extérieur de l’éditeur de diagramme, la copier dans 
le presse-papier,  entrer dans le diagramme et coller la formule à partir  du presse-papier.  Ceci 
convertira automatiquement la formule en un graphique Métafichier. Si vous souhaitez modifier par 
la suite la formule, vous devez la supprimer et recommencer la procédure.

Personnalisations

L’éditeur de formules comme fenêtre flottante
L’éditeur  de  formules  peut  occuper  une  grande  partie  de  la  fenêtre  Writer.  Pour  transformer 
l’éditeur de formules en fenêtre flottante :

1) Déplacez le souris sur le cadre de l’éditeur, comme sur la Figure 23.

2) Maintenez enfoncé la touche Ctrl et double-cliquez.

Figure 23 : Transformer l’éditeur de formules en fenêtre flottante

La Figure 24 montre le résultat. Vous pouvez ancrer la fenêtre flottante à nouveau en utilisant les 
mêmes étapes : maintenez enfoncé la touche Ctrl et double-cliquez sur le cadre de la fenêtre.
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Figure 24 : L’éditeur de formules en tant que fenêtre flottante

Ajouter un bouton à une barre d’outils
Par défaut, le bouton est présent dans la barre d’outils  Insérer  des modules  Writer et  Impress. 
Vous pouvez cependant ajouter cette icône à d’autres barres d’outils :

• Affichage>Barre d'outils>Personnaliser ou clic-droit sur le début d’une barre de menu > 
Personnaliser  la  barre  d’outils.  Choisir  l’onglet  Barres  d'outils et  la  barre  d’outils 
souhaitée. 

• Sélectionner la position où insérer le bouton.

• Cliquer sur Ajouter.

• Choisir la catégorie Insérer, puis la commande Formule, celle correspondant à l’icône  
(la commande  correspond à l’équivalent d’une formule du tableur).

Figure 25 : Ajout d’un bouton pour l’insertion de Formule

• Cliquer sur Ajouter puis continuer à ajouter des boutons ou cliquer sur Fermer.

• Utiliser les boutons flèches vers le haut et vers le bas pour déplacer éventuellement des 
boutons, avant de valider par OK.

Ajouter un raccourci clavier
Vous pouvez affecter un raccourci clavier de votre choix pour l’insertion de formule :

• Menu Outils>Personnaliser, onglet Clavier.

• Sélectionner le niveau du raccourci :  LibreOffice pour en disposer dans tous les modules 
(si le raccourci n’est pas déjà affecté dans ce module) ou uniquement dans le module en 
cours.

Personnalisations 31



• Choisir  la  catégorie  Insérer,  puis  la  commande  Formule ne  correspondant  pas  au 
raccourci F2 (cette commande correspond à l’équivalent d’une formule du tableur).

• Sélectionner le raccourci à affecter, puis cliquer sur Modifier.

• Procéder de la même façon pour d’autres raccourcis du même niveau, puis valider par OK.

Si votre raccourci déclenche l’apparition d’une barre de formule du type Calc, c’est que vous avez 
choisi la mauvaise fonction Formule.

Figure 26 : Ajout d'un raccourci clavier

Personnaliser le catalogue
Si vous avez besoin d’un symbole qui n’est pas disponible dans Math, vous pouvez l’ajouter vous-
même au catalogue. L’exemple suivant montre la procédure :

1) Sélectionnez le menu Outils > Catalogue ou cliquez sur le bouton du catalogue  pour 
ouvrir le catalogue de symboles (Figure 8).

2) Cliquez sur le bouton Éditer. La fenêtre d’Édition des symboles (Figure 27) s’ouvre.

3) Les symboles sont organisés en jeux de symboles. Dans la partie basse de la fenêtre, 
sélectionnez un jeu  disponible pour  votre nouveau symbole  dans la  liste des  Jeux de 
symboles,  par  exemple  le  jeu  Spécial.  Ou  vous  pouvez  taper  directement  le  nom du 
nouveau jeu de symboles dans la boite.

4) Dans la liste des Polices, sélectionnez la police contenant le symbole souhaité.

Lorsque vous avez sélectionné une police, ses caractères apparaissent dans la fenêtre 
d’aperçu de la police.  Vous pouvez la parcourir  à l’aide de l’ascenseur sur le côté, ou 
utiliser la liste Plage pour aller directement à l’endroit recherché. 

Pour  suivre  cet  exemple,  sélectionnez  la  police  DejaVu Sans et  la  plage  Ponctuation 
générale.

5) Cliquez sur le symbole souhaité (ici Ux2032). Il apparaît agrandi dans la boite d’aperçu à 
l’extrême droite (Figure 28). Assurez-vous que le jeu de symboles est Spécial.

6) Dans le champ Symbole, entrez un nom pour le symbole, par exemple prime.

32 Guide Math LibreOffice 3.5



7) Si le nom n’est pas utilisé actuellement, le bouton Ajouter devient actif. Cliquez dessus.

8) Vous  pouvez  immédiatement  ajouter  d’autres  symboles.  Pour  l’exemple,  les  symboles 
U+2033, nommé dblprime, et U+2034, nommé triprime, sont ajoutés (Figure 29).

9) Cliquez sur OK pour fermer le dialogue.

Figure 27 : Dialogue d’édition des symboles

Figure 28 : Dialogue d’édition des symboles : nommage du nouveau symbole

Maintenant la zone d’aperçu du jeu de symboles montre les nouveaux symboles. Ils peuvent être 
sélectionnés comme les autres symboles, soit à partir de ce dialogue, soit en écrivant directement 
leur nom dans l’éditeur d’équation sous la forme %prime.

Il y a de nombreuses polices gratuites contenant un grand nombre de symboles mathématiques. 
La police STIX2 mérite une attention particulière ici.  Elle  a été développée spécialement pour 
écrire  des  textes  mathématiques  et  techniques.  Les  polices  DejaVu3 et  Lucida4 disposent 
également d’une large gamme de symboles.

2 Les fichiers pour la police STIX sont disponibles sur http://www.stixfonts.org 
3 Les fichiers de la police DejaVu Sans sont disponibles sur http://www.dejavu-fonts.org 
4 Lucida Sans est inclus dans le paquet JRE, qui est probablement déjà sur l’ordinateur.
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Attention
Contrairement aux commandes, les symboles (grecs ou spéciaux) doivent respecter 
la casse (majuscule/minuscule) pour être reconnus.

Figure 29 : Catalogue Spécial avec les nouveaux symboles

Note
Beaucoup de symboles sont disponibles dans plus d’une police. Si vous échangez 
des documents, faîtes attention d’utiliser une police installée sur les machines de 
vos partenaires. 

Dans la configuration par défaut de LibreOffice, seuls les symboles définis par l’utilisateur qui sont 
effectivement utilisés dans le document, sont stockés avec lui. Parfois il peut être utile d’inclure 
tous les symboles définis par l’utilisateur, par exemple quand le document va être édité par la suite 
par une autre personne. Sélectionnez Outils > Options > LibreOffice Math > Paramétrages, et 
décochez l’option  Incorporer uniquement les symboles utilisés (taille de fichier inférieure). 
Ce  paramétrage  est  uniquement  accessible  lors  de  l’utilisation  de  Math  comme  module 
indépendant.

Personnaliser un opérateur
Pour qu’un nom soit reconnu comme un nom de fonction, c’est-à-dire qu’il soit écrit en fonte droite 
et non italique, il faut faire précéder le nom du mot clé func.

Pour qu’un opérateur soit agrandi et accepte des bornes, comme les sommes ou intégrales, il faut 
le faire précéder du mot clé  oper.  Il  est  possible d’utiliser  une lettre,  un nom ou un symbole 
personnel (voir Personnaliser le catalogue page 32). Ainsi F

i∈I
Ai  s’écrit oper F from {i in 

I} A_i.

Vous pouvez modifier le comportement d’un opérateur, ou attribuer un comportement d’opérateur à 
un de vos symboles personnels, à l’aide des mots boper pour faire un opérateur binaire, et uoper 
pour faire un opérateur unaire.

Espace à la fin d’une formule
L’accent grave ` (et non l’apostrophe) insère un petit espace supplémentaire dans la formule ; le 
tilde ~ insère un espace plus grand.  Dans l’installation par défaut,  ces symboles sont  ignorés 
lorsqu’ils sont inclus à la fin d’une formule. Cependant, pour des formules incluses dans le cœur 
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du texte, il peut être nécessaire de prendre en compte l’espace également à la fin des formules. 
Ce paramétrage est seulement accessible avec le module Math indépendant et pas avec un objet 
Math inclus dans un document. 

Créez un nouveau document Math avec Fichier > Nouveau > Formule. Ouvrez le dialogue des 
options avec Outils > Options > LibreOffice Math > Paramétrages. Décochez l’option Ignorer ~ 
et ` en fin de ligne.

Mise en forme par défaut avec style
Dans Writer, les formules sont mises en forme en suivant le 
style  de  cadre  Formule.  Dans  la  fenêtre  du  styliste 
(affichage  par  F11),  cliquez  sur  le  3e bouton  Styles  de 
cadre. Cliquez droit sur Formule et sélectionnez Modifier. 
Vous pouvez modifier ainsi directement toutes les formules 
du document en ce qui concerne l’espacement (page  26) 
ou l’arrière-plan (page  27),  sauf  si  vous avez modifié  le 
format manuellement.

Pour que cette mise en forme soit appliquée à tous les nouveaux documents Writer, vous devez 
intégrer le style  Formule dans le modèle par défaut. Pour cela, créez un nouveau document et 
modifiez le style  Formule comme souhaité. Enregistrez le document par  Fichier > Modèles > 
Enregistrer. Pour le définir comme modèle par défaut, sélectionnez Fichier > Modèles > Gérer ; 
double-cliquez sur  Mes modèles : votre modèle doit apparaître juste en dessous. Cliquez droit 
dessus et sélectionnez  Définir comme modèle par défaut. La commande  Rétablir le modèle 
par défaut, permet de revenir au modèle par défaut fourni lors de l’installation de LibO.

Les nouveaux documents texte suivront ce modèle.

Application aux formules chimiques
Math a été conçu pour écrire des formules mathématiques, mais il peut aussi servir à écrire des 
formules chimiques. En chimie, les formules ressemblent à H2O : les noms des éléments sont 
habituellement en majuscule droite. Pour écrire les formules chimiques avec  Math vous pouvez 
commencer en sélectionnant le style droit pour les variables (voir Modifier la police page 20).

Voici quelques exemples de formules chimiques :

Construction Exemple Entrée

Molécules H2SO4 H_2 SO_4 (notez l’espace !)

Isotopes U92
238 U lsub 92 lsup 238

Ions SO4
2− SO_4^{2-{}} ou SO_4^{2"-"}

Notes :  lsub ou  lsup sont les abréviations de  left subscript et left superscript. Les accolades 
vides après 2- sont nécessaires pour éviter une erreur car il n’y a pas de membre après le moins.

Pour les réactions chimiques réversibles, il n’y a pas de double flèches satisfaisantes dans Math. 
Si  vous disposez d’une police  de caractère comportant  un symbole  satisfaisant,  vous pouvez 
utiliser la méthode décrite à la section Personnaliser le catalogue page 32. Par exemple la police 
Wingdings 3 fournie par certaines applications de Microsoft comporte la double flèche .⇆

Sinon, il faut récupérer le caractère spécial d’un document et le copier, par exemple à partir de 
cette  formule :  C+O⇌CO  "⇌".  Vous  trouverez  d’autres  double  flèches  sur 
http://dev.w3.org/html5/html-author/charref à partir du caractère x021C4.
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Exporter et importer

Exporter au format MathML
En plus de l’export au format PDF, comme présenté au chapitre 10 Imprimer, exporter, envoyer par 
courrier électronique du Guide de mise en route, Math offre la possibilité d’exporter les formules au 
format MathML. Malheureusement les navigateurs ne suivent pas le standard parfaitement. En cas 
d’erreur d’affichage, la faute repose sur votre navigateur !

Prenons comme exemple cette formule :

Balisage Résultat

%zêta (z) = sum from {n = 1} to infinity {1 over 
{n^z}} newline left(matrix {a # b ## c # d}right) 
newline "Texte" newline int_0^x f(t) dt newline x = 
3 y = 1

ζ (z)=∑
n=1

∞ 1

nz

(a b
c d)

Texte

∫0

x
f ( t)dt

x=3 y=1

Cette formule combine plusieurs possibilités offertes par Math, ce qui la rend utile pour les tests.

Si vous travaillez avec Math en tant que module indépendant,  sélectionnez le menu  Fichier > 
Enregistrer sous. Sélectionnez MathML dans la liste des formats de fichier disponibles.

Figure 31 : Export MathML

Pour une formule incluse dans un document, sélectionnez Enregistrer la copie sous à partir du 
menu contextuel.

Résultats
Cette formule a été successivement testée dans divers navigateurs.

Firefox 14 Opera 12.00
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Internet Explorer 9

Chromium 13 et Google Chrome 20.0

Safari 5.1 ne fait qu’ouvrir le gestionnaire de fichiers pour enregistrer le fichier.

Formats de fichier Microsoft
Les options dans le menu Outils > Options > Chargement/enregistrement > Microsoft Office 
contrôlent comment l’import et l’export des formats de fichier de Microsoft Office est effectué par 
rapport aux formules.

Chargement
Si  [C] est coché, LibreOffice convertit les formules Microsoft au format natif lorsqu’un document 
est chargé. Ceci est possible si les formules ont été créées avec MathType5 (jusqu’à la version 
3.1) ou l’éditeur d’équation de Microsoft. Ce dernier est une ancienne version de MathType aux 
fonctionnalités réduites sous licence Microsoft et inclus dans le pack Microsoft Office.

Les  formules  créées  par  des  versions  plus  récentes  de  MathType  ou  par  le  nouvel  éditeur 
d’équations de Microsoft OMML6 (Microsoft Office Suite 2010 et en partie 2007) ne peuvent pas 
être converties.

Si un document créé dans Microsoft Office 2010 et contenant une formule OMML est enregistré au 
format  .doc,  Microsoft  Office  convertit  la  formule  en  graphique.  Seul  ce  graphique  est  alors 
accessible à LibreOffice.

Si vous ouvrez un document .docx qui contient des formules OMML, LibreOffice échoue dans la 
conversion, que [C] soit coché ou non.

Dans Microsoft  Office, les formules créées avec MathType ou l’éditeur d’équation de Microsoft 
sont  traitées  comme des  objets  OLE.  Si  [C] n’est  pas  coché,  LibreOffice  maintient  cet  état. 
Double-cliquer sur l’objet lance alors MathType et de nouvelles formules peuvent être insérées via 
le menu  Insertion > Objet > Objet OLE. Ce réglage est à recommander si vous avez installé 
MathType et souhaitez l’utiliser pour créer et éditer des formules.

5 http://www.dessci.com/en/ 
6 Office Math Markup Language
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Enregistrement
Si [E] est coché, LibreOffice convertit la formule dans une forme lisible et modifiable par l’éditeur 
d’équation de Microsoft et MathType. Si [E] n’est pas coché, la formule est considérée comme un 
objet OLE au moment de la conversion au format .doc, et reste reliée à LibreOffice. Un double-clic  
sur un objet formule dans Word tentera alors de lancer LibreOffice Math.

Si vous enregistrez au format .docx, les formules ne sont pas converties, que vous ayez cocher [E] 
ou non.

Ouverture de texte OpenDocument dans Microsoft Word 2010
Dans Microsoft Office 2010, il est possible d’ouvrir des fichiers texte au format OpenDocument 
.odt. Microsoft Office 2010 indique une erreur à l’ouverture mais affiche néanmoins un document 
« réparé ». Dans ce document toutes les formules originales sont converties au format OMML. Si 
vous  enregistrez  à  nouveau  au  format  .odt,  Microsoft  Office  2010  convertit  les  formules  en 
MathML,  et  ces  formules  peuvent  être  éditées  dans  LibreOffice.  Prenez  soin  d’entourer  les 
symboles qui doivent être ensemble avec des accolades, même si elles ne sont pas nécessaires 
pour l’affichage dans LibreOffice. Cela permet à LibreOffice de traduire correctement la formule en 
MathML. Par exemple, écrivez sum from {i=1} to n {i^2} plutôt que sum from i=1 to 
n i^2.

Avec cette procédure,  l’élément  d’annotation  utilisé par  LibreOffice pour  conserver  le  balisage 
original de la formule est perdu. La conséquence c’est que LibreOffice n’affiche plus le balisage de 
Math original dans l’éditeur d’équation, mais génère à la place un nouveau balisage à partir de la 
notation interne MathML.

XHTML
Dans les modules autres que Math, le format de fichier XHTML n’est disponible que pour l’export. 
C’est la raison pour laquelle l’option se trouve dans le menu Fichier > Exporter plutôt que Fichier 
> Enregistrer sous. Si cette option est absente de votre configuration, vous pouvez installer le 
filtre  nécessaire  (exécutez  l’utilitaire  d’installation  de  LibreOffice,  sélectionnez  Modifier,  puis 
Composants optionnels > Filtres pour exemple XSLT). Le graphique de remplacement de la 
formule est inclus dans le fichier,  mais le balisage original de Math, inclus comme un élément 
d’annotation dans MathML, est absent dans ce cas (comparez avec la section Exporter au format
MathML page 36).

Le rendu correct du document dépend du navigateur. Firefox affiche correctement le document, y 
compris les formules. Opera et Internet Explorer ont des soucis avec les graphiques inclus.

L’ancien filtre Document HTML (OpenOffice.org Writer)(.html) n’enregistre pas les formules, mais 
les remplace par des fichiers au format .gif de faible résolution.

Flat XML
Ce format peut à la fois être lu et enregistré par LibreOffice. Si l’option n’est pas présente sous 
Fichier  >  Enregistrer  sous,  vous pouvez  installer  le  filtre  nécessaire  comme au paragraphe 
précédent. Dans ce format, la totalité du contenu du document, y compris le modèle, est enregistré 
dans un document XML. En d’autres mots, ce n’est pas un répertoire compressé, comme c’est le 
cas normalement pour les fichiers OpenDocument. Chaque formule est incluse en tant qu’élément 
MathML, similaire au résultat de l’export au format MathML. Cependant les formules ne sont pas 
enregistrées individuellement,  mais  la  totalité  du document  y  compris  les formules.  Ce format 
convient comme entrée directe dans un système de contrôle de version externe.
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Extensions pour Math

Si vous utilisez régulièrement le module Math, il peut être intéressant d’installer une de ces deux 
extensions facilitant l’édition de formules. Les deux développeurs ne se concurrencent pas mais 
s’aident mutuellement quand c'est possible. Cependant,  Dmaths et  CmathOOo ne peuvent pas 
être installées simultanément. Ces deux extensions étant complémentaires, il est donc proposé 
de les installer dans deux comptes utilisateurs différents, pour les tester avant de choisir.

Dmaths – une extension pour taper plus rapidement les formules mais 
pas seulement
Dmaths  est  une  extension  pour  LibreOffice  Writer  de  macros  mathématiques.  Elle  est 
téléchargeable sur le site des extensions : http://extensions.libreoffice.org.

Après  installation  de  Dmaths,  fermez  et  relancez  LibreOffice.  Writer  comporte  maintenant  un 
nouveau menu (Figure 32), une nouvelle barre d’outils (paramétrable) avec 36 boutons (Figure
33), une nouvelle barre d’outils avec 26 boutons pour Gdmath (Figure 34), une nouvelle barre 
d’outils  avec  10  boutons  pour  AHmath3D  (Figure  35),  et  deux  petites  barres  d’outils  pour 
activer/désactiver les barres précédentes et accéder à quelques fonctions supplémentaires (Figure
36).

Figure 32 : Menu Dmaths

Figure 33: Barre d’outils Dmaths paramétrable

Figure 34: Barre d’outils Gdmath
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Figure 35: Barre d’outils AHmath3D

Figure 36: Barre d’outils pour activer/désactiver d’autres fonctions

Dmaths fournit de nombreux outils pour créer des documents mathématiques :

• Créer en 1 clic des formules Math à partir d’entrée texte (boutons orange)

• Créer des formules Math à l’aide d’une boîte de dialogue (boutons violets)

• Étiqueter le texte (boutons bleus)

• Modifier les propriétés des formules existantes (boutons verts)

• Dessiner  des  graphiques,  des  grilles,  des  diagrammes  statistiques  et  des  figures 
géométriques (boutons cyan)

• Dessiner  et  modifier  des  objets  géométriques  (barre  d’outils  grise  Gdmath,  également 
disponible dans LibreOffice Draw)

• Dessiner des objets 3D (barre d’outils AHmath 3D avec les modèles en fil de fer)

Le menu permet d’accéder à des add-ons supplémentaires, à la configuration et au guide détaillé 
d’Aide sur Dmaths.

L’extension Dmaths a été créée initialement par le mathématicien français Didier Dorange, mais 
est  maintenant  disponible en allemand, anglais  et  espagnol,  en plus du français.  Le site  web 
original est www.dmaths.org. 

CmathOOo et CmathOOoCAS pour le calcul formel
CmathOOo est un programme qui permet, via un traitement de texte, de taper des expressions 
mathématiques en utilisant à peu près la même syntaxe que sur une calculatrice de type lycée. 
Avec  l'extension  CmathOOoCAS,  il  est  possible  d’effectuer  des  calculs  formels  comme dans 
Xcas7 directement depuis le traitement de texte et la mise en forme du résultat est assuré par 
CmathOOo. Cette extension peut être téléchargée sur le site officiel des extensions :  
http://extensions.services.openoffice.org/fr/project/ CmathOOo et  
http://extensions.services.openoffice.org/fr/project/CmathOOoCAS ou  sur  le  site  de  Christophe 
Devalland http://cdeval.free.fr à la page http://cdeval.free.fr/spip.php?article85.

7 http://www-fourier.ujf-grenoble.fr/~parisse/giac_fr.html 
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Renseignements techniques

Format OASIS Open Document pour la bureautique
La spécification ODF ne propose pas un standard complètement nouveau pour les formules Math 
mais reprend le Standard Mathematical Markup Language (MathML) développé par le World Wide 
Web  Consortium  (W3C)  pour  représenter  les  formules  sur  les  sites  web  (voir 
http://www.w3.org/TR/2003/REC-MathML2-20031021).  Des  deux  types  fournis,  le  balisage  de 
présentation et le balisage de contenu, ODF utilise le premier. De ce fait, il décrit la représentation 
de la formule, plutôt que son sens mathématique.

Le langage de balises MathML se différencie de celui utilisé dans l’éditeur d’équations. Ainsi par 
exemple,  dans la  formule  int from {i=1} to 3 {f(t) {nitalic d}t},  les éléments 
from... to… ne sont pas traduits mais convertis en langage MathML équivalent  int_{i=1}^3. 
La formulation originale de l’éditeur d’équation est le codage de StarMath8 5.0. Pour éviter qu’il ne 
soit perdu, il est enregistré comme élément d’annotation. D’autres applications n’ont pas besoin 
d’évaluer ni d’enregistrer cet élément, et ne le créent pas.

Dans LibreOffice une formule est toujours associée avec un graphique de remplacement. Dans les 
formats de contenu – .odf, .odt etc. – ces graphiques sont enregistrés dans un répertoire séparé et 
sont liés en interne à leur document. Cependant, si vous utilisez le format “Open Document (Flat 
XML)” ou exportez en XHTML, ces graphiques doivent être inclus. Pour cela, ils sont encodés en 
BASE64.

Manipulation de formules en Basic
Cette section n’est pas une introduction au Basic, mais décrit simplement des aspects spécifiques 
des formules. Vous trouverez davantage d’informations au sujet des types et services à l’adresse : 
http://api.libreoffice.org/common/ref/com/sun/star/module-ix.html. Si vous recherchez les notations 
employées ici, l’index vous donnera les descriptions pertinentes.

Formules dans un document Writer
Dans  un  document  Writer,  tous  les  objets  OLE,  y  compris  les  formules,  appartiennent  à  la 
collection de type SwXTextEmbeddedObjects :

oCurrentController = ThisComponent.getCurrentController()
oTextDocument = oCurrentController.Model
oEmbeddedObjects = oTextDocument.EmbeddedObjects

Cette collection est numérotée en continu depuis 0. Vous pouvez trouver un objet donné avec :
nEndIndex = oEmbeddedObjects.Count-1
for nIndex=0 to nEndIndex
  oMathObject = oEmbeddedObjects.getByIndex(nIndex)

Pour  déterminer  si  un  objet  est  effectivement  une  formule,  testez  s’il  supporte  un  service 
spécifique aux formules :

oModel = oMathObject.Model
if oModel.supportsService("com.sun.star.formula.FormulaProperties") then

Une autre solution est de tester si le CLSID, que chaque objet OLE possède, appartient à un objet 
Math :

if oMathObject.CLSID = "078B7ABA-54FC-457F-8551-6147e776a997" then

En utilisant le modèle, vous pouvez modifier les propriétés de la formule, par exemple la taille de 
police de base :

oModel.BaseFontHeight = 12

8 LibreOffice est basé sur la suite StarOffice, développée par StarDivision.
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Pour  rendre  ce  changement  visible,  vous  devez  redessiner  la  formule.  La  propriété 
ExtendedControlOverEmbeddedObject fournit  des  méthodes  qui  s’appliquent  aux  objets 
OLE :

oXCOEO = oMathObject.ExtendedControlOverEmbeddedObject
oXCOEO.update()

À titre d’illustration, voici une macro permettant de modifier le formatage de toutes les formules 
déjà écrites d’un document.

Sub ChangeFormatFormule
oCurrentController = ThisComponent.getCurrentController()
oTextDocument = oCurrentController.Model
oEmbeddedObjects = oTextDocument.EmbeddedObjects
nEndIndex = oEmbeddedObjects.Count-1
for nIndex=0 to nEndIndex

oMathObject = oEmbeddedObjects.getByIndex(nIndex)
oModel = oMathObject.Model
if (not isNull(oModel)) then

if(not isEmpty(oModel)) then
if oModel.supportsService("com.sun.star.formula.FormulaProperties") then
' ou if oMathObject.CLSID = "078B7ABA-54FC-457F-8551-6147e776a997" then

oModel.BaseFontHeight = 11
policeCommune= "Liberation Serif"

' Variables
oModel.FontNameVariables= policeCommune
oModel.FontVariablesIsItalic=true
oModel.FontVariablesIsBold=false

' Fonctions
oModel.FontNameFunctions = policeCommune 
oModel.FontFunctionsIsItalic=false
oModel.FontFunctionsIsBold=false

' Nombres
oModel.FontNameNumbers= policeCommune
oModel.FontNumbersIsItalic=false
oModel.FontNumbersIsBold=false

' Texte
oModel.FontNameText= policeCommune
oModel.FontTextIsItalic=false
oModel.FontTextIsBold=false

' Mise à jour
oXCOEO = oMathObject.ExtendedControlOverEmbeddedObject
oXCOEO.update()

endif ' fin si formule
endif ' fin si pas vide

endif ' fin si pas null
next nIndex
ThisComponent.reformat() ' Met à jour tous les éléments du document

End Sub

Consultez la page d’aide9 sur FormulaProperties pour connaître les autres propriétés modifiables. 

Formules dans un document Draw/Impress/Calc
Dans un document Draw, Impress ou Calc, les objets OLE sont traités de la même manière que 
les graphiques. Après avoir accédé à un objet particulier, testez si c’est un objet OLE, puis si c’est 
une formule. Le cœur de votre macro doit ressembler à :

if oShape.supportsService("com.sun.star.drawing.OLE2Shape") then
if oShape.CLSID = "078B7ABA-54FC-457F-8551-6147e776a997" then

oModelFormula = oShape.Model
oModelFormula.BaseFontHeight = 12

Dans ce cas, une mise à jour explicite n’est pas nécessaire.

9 http://api.libreoffice.org/common/ref/com/sun/star/formula/FormulaProperties.html 
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Commandes Math - Référence

Opérateurs unaires / binaires

Opération Commande Affichage

Signe + +1 1

Signe – –1 −1

Signe +/– +–1 ou plusminus 1 ±1 ou ±1

Signe –/+ –+1 ou minusplus 1 ∓1 ou ∓1

Addition + a + b ab

Soustraction (–) a – b a−b

Multiplication point a cdot b a⋅b

Multiplication (X) a times b a×b

Multiplication (étoile) a * b a∗b

Division (en fraction) a over b
a
b

Division (avec opérateur) a div b a÷b

Division (avec petite barre) a / b a /b

Concaténation a circ b a°b

Division (avec grande barre) a wideslash b
a
b

Barre inversée a widebslash b
a
b

Non booléen neg a ¬a

Et booléen a and b ou a & b a∧b ou a∧b

Ou booléen a or b ou a | b a∨b ou a∨b

Barre inversée a bslash b a∖b

Somme directe a oplus b a⊕b

a ominus b a⊖b

Produit tensoriel a otimes b a⊗b

a odot b a⊙b

a odivide b a⊘b

Opérateur unaire personnalisé uoper monOp b monOpb

Opérateur binaire personnalisé a boper monOp b a monOp b
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Relations

Opération Commande Affichage

Est égal a = b a=b

N’est pas égal a <> b ou a neq b a≠b ou a≠b

Plus petit a < b ou a lt b a<b ou a<b

Plus petit ou égal
a <= b

a leslant b

a≤b

a⩽b

Très petit a ll b ou a << b a≪b ou a≪b

Plus grand a > b ou a gt b a>b ou a>b

Plus grand ou égal
a >= b

a geslant b

a≥b

a⩾b

Très grand a gg b ou a >> b a≫b ou a≫b

Approximativement a approx b a≈b

Similaire a sim b a~b

Similaire ou égal a simeq b a≃b

Congruent a equiv b a≡b

Proportionnel a prop b a∝b

Parallèle a parallel b a∥b

Orthogonal a ortho b a⊥b

Divise a divides b a∣b

Ne divise pas a ndivides b a∤b

Flèche droite a toward b a b

Double flèche gauche a dlarrow b a⇐b

Double flèche gauche et droite a dlrarrow b a⇔b

Double flèche droite a drarrow b a⇒b

Précède a prec b a≺b

Succède a succ b a≻b

Précède ou équivaut a preccurlyeq b a≼b

Succède ou équivaut a succcurlyeq b a≽b

Précède ou équivaut a precsim b a≾b

Succède ou équivaut a succsim b a≿b

Ne précède pas a nprec b a⊀b

Ne succède pas a nsucc b a⊁b

Définition a def b a≝b
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Opération Commande Affichage

Correspondance image de a transl b a⊷b

Correspondance origine de a transr b a⊶b

Opérateurs d’ensemble

Opération Commande Affichage

Appartient a in B a∈B

N’appartient pas a notin B a∉B

Comprend A owns b ou A ni b A∋b ou A∋b

Intersection A intersection B A∩B

Union A union B A∪B

Différence A setminus B A ∖B

Quotient A slash B A /B

Sous-ensemble A subset B A⊂B

Sous-ensemble ou égal A subseteq B A⊆B

Sur-ensemble A supset B A⊃B

Sur-ensemble ou égal A supseteq B A⊇B

N’est pas sous-ensemble A nsubset B A⊄B

N’est pas sous-ensemble ou égal A nsubseteq B A⊈B

N’est pas sur-ensemble A nsupset B A⊅B

N’est pas sur-ensemble ou égal A nsupseteq B A⊉B

Ensemble vide emptyset ∅

Aleph aleph ℵ

Ensemble des entiers naturels setN ℕ

Ensemble des entiers setZ ℤ

Ensemble des rationnels setQ ℚ

Ensemble des réels setR ℝ

Ensemble des complexes setC ℂ
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Fonctions

Opération Commande Affichage

Valeur absolue abs{a} ∣a∣

Factoriel fact{a} a!

Racine carrée sqrt{a} a

Racine nième nroot{n}{a} n√a

Puissance a^{b} ab

Exponentiel func e^{a} ea

Logarithme naturel ln(a) ln a

Exponentiel exp(a) exp a

Logarithme log(a) log(a)

Sinus sin(a) sina

Cosinus cos(a) cos a

Tangente tan(a) tan a 

Cotangente cot(a) cot a

Sinus hyperbolique sinh(a) sinh a

Cosinus hyperbolique cosh(a) cosh a 

Tangente hyperbolique tanh(a) tanh a 

Cotangente hyperbolique coth(a) coth a

Arc sinus arcsin(a) arcsin a 

Arc cosinus arccos(a) arccosa 

Arc tangente arctan(a) arctan a

Arc cotangente arccot(a) arccot a

Argument sinus hyperbolique arsinh(a) arsinh a 

Argument cosinus hyperbolique arcosh(a) arcosh(a)

Argument tangente hyperbolique artanh(a) artanh(a)

Argument cotangente hyperbolique arcoth(a) arcoth(a)
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Opérateurs
Tous ces opérateurs peuvent être utilisés avec les bornes from (depuis) et to (jusqu’à).

Opération Commande Affichage

Limite lim{a} lim a

Limite inférieure liminf{a} lim inf a

Limite supérieure limsup{a} lim sup a

Somme sum{a} ∑ a

Produit prod{a} ∏ a

Coproduit coprod{a} ∐ a

Intégrale int{a} ∫ a

Intégrale double iint{a} ∬a

Intégrale triple iiint{a} ∭a

Intégrale ronde lint a ∮a

Double intégrale ronde llint a ∯a

Triple intégrale ronde lllint a ∰a

Borne inférieure avec opérateur 
somme

sum from {3} b ∑
3

b

Borne supérieure avec opérateur 
produit

prod to {3} r ∏
3

r

Bornes supérieure et inférieure avec 
intégrale

int from {r_0} to {r_t} 
a ∫

r0

rt

a

Opérateur personnalisé oper Op from 0 to 1 a Op
0

1

a

Attributs

Opération Commande Affichage

Accent aigu acute a á

Accent grave grave a à

Circonflexe inversé check a ǎ

Arrondi breve a ă

Cercle circle a å

Point au-dessus dot a ȧ

Double point ddot a ä

Commandes Math - Référence 47



Opération Commande Affichage

Triple point dddot a a

Ligne au-dessus bar a ā

Petite flèche vecteur vec a a⃗

Tilde tilde a ã

Accent circonflexe hat a â

Longue flèche widevec abc abc

Long tilde widetilde abc abc

Long circonflexe widehat abc abc

Longue ligne au-dessus overline abc abc

Longue ligne en dessous underline abc abc

Longue ligne au travers overstrike abc acb

Transparent (utile pour disposer de 
l’emplacement d’une taille donnée)

phantom a

Police gras bold a a

Police non gras nbold a a

Police italique10 ital "a" ou italic "a" a ou a

Police non italique nitalic a a

Taille police size 16 qv qv

Taille police size +12 qv qv
Taille police size *1.5 qv qv
Police sans serif11 font sans qv qv

Police serif font serif qv qv

Police fixe font fixed qv qv

Couleur cyan12 color cyan qv qv

Couleur jaune color yellow qv qv

Couleur blanc color white qv qv

Couleur vert color green qv qv

10 Tout texte non compris entre guillemets droits qui n’est pas une commande, est considéré comme étant 
une variable. Par défaut, les variables sont en italique.

11 Il y a trois polices personnalisées : sans serif (sans empattement), serif (avec empattement) et fixed (non 
proportionnel). Pour changer les polices actuellement utilisées (polices personnalisées et polices pour les 
variables, nombres et fonctions), utilisez le menu Format > Police (voir page 20).

12 Pour toutes les couleurs, la couleur ne s’applique qu’au texte qui suit immédiatement la balise jusqu’à la 
prochaine espace. Pour appliquer la couleur à plusieurs éléments, placez le texte entre accolades.
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Opération Commande Affichage

Couleur bleu color blue qv qv

Couleur rouge color red qv qv

Couleur noir color black qv qv

Couleur magenta color magenta qv qv

Retour à la couleur par défaut color green X qv X qv

Accolades pour changer la couleur de 
plusieurs éléments

color green {X qv} X qv

Parenthèses

Opération Commande Affichage

Parenthèses de regroupement 
invisibles (utilisées pour le balisage)

{a} a

Parenthèses rondes (a) a

Crochets [b] [b]

Crochets doubles ldbracket c rdbracket 〚c〛

Accolades lbrace w rbrace {w}

Parenthèses d’angle langle d rangle 〈d 〉

Parenthèses opérateurs langle a mline b rangle 〈a∣b〉

Semi-crochets hauts lceil a rceil ⌈a⌉

Semi-crochets bas lfloor a rfloor ⌊a⌋

Barres simples lline a rline ∣a∣

Doubles barres ldline a rdline ∥a∥

Parenthèses ajustables
(ajouter left avant la parenthèse 
gauche et right avant la 
parenthèse droite)

left ( stack{a # b # z} 
right ) 

a
b
z

Crochets ajustables
(comme ci-dessus)

left [ a over b right ] [ ab ]
Doubles crochets ajustables

left ldbracket a over b 
right rdbracket ⟦ ab⟧

Accolades ajustables
left lbrace a over b 
right rbrace {ab }

Parenthèses d’angle ajustables
left langle a over b 
right rangle 〈 ab 〉
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Opération Commande Affichage

Parenthèses opérateurs ajustables
left langle a over b 
mline c right rangle 〈 ab∣c〉

Semi-crochets hauts ajustables
left lceil a over b 
right rceil ⌈ ab ⌉

Semi-crochets bas ajustables
left lfloor a over b 
right rfloor ⌊ ab ⌋

Lignes ajustables
left lline a over b 
right rline ∣ab∣

Doubles lignes ajustables
left ldline a over b 
right rdline ∥ab∥

Parenthèses dépareillées 
(ajouter left avant la parenthèse 
gauche et right avant la 
parenthèse droite)

left langle a over b 
right rfloor 〈 ab ⌋

Parenthèse isolée
left lbrace stack 
{a=2#b=3} right none {a=2

b=3

Accolade supérieure ajustable
{accolade au dessus} 
overbrace a accoladeau dessus⏞

a

Accolade inférieure ajustable
{accolade en dessous} 
underbrace {f}

accolade en dessous⏟
f
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Formats

Opération Commande Affichage

Exposant droite a^{b} ab

Indice droite a_{b} ab

Exposant gauche a lsup{b} ab

Indice gauche a lsub{b} ab

Exposant centre a csup{b} a
b

Indice centre a csub{b} a
b

Retour à la ligne abcdefghij newline sadkfj abcdefghij
sadkfj

Petit espace (grave) objet `objet objet objet

Grand espace (tilde) objet~objet objet objet

Pas de vide nospace { x + y } x+ y

Normal x+y x+ y

Pile verticale de 2 binom{a}{b}
a
b

Pile verticale, plus que 2 stack{a # b # z}
a
b
z

Matrice

matrix{
a # b ## 
c # d
}

a b
c d

Aligné à gauche (le texte est aligné 
par défaut au centre) 

stack{Bonjour # alignl(a)}
Bonjour
(a )

Aligné au centre stack{Bonjour # alignc(a)} Bonjour
(a)

Aligné à droite stack{Bonjour # alignr(a)}
Bonjour

(a )

Aligné sur le '=' (avec matrice)

matrix{
a # "=" # alignl{b} ##
{} # "=" # alignl{c+1}
}

a =b
=c+ 1

Aligné sur le '=' (avec vide)

stack{
alignl{a} = b #
alignl{phantom{a} = c+1}
}

a =b
=c+ 1
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Autres

Opération Commande Affichage

Infini infinity ou infty ∞ ou ∞

Dérivée partielle partial ∂

Nabla nabla ∇

Il existe exists ∃

Il n’existe pas notexists ∄

Pour tous forall ∀

H bar (constante de Planck sur π) hbar ℏ

Lambda bar lambdabar ƛ

Partie réelle d’un complexe re ℜ

Partie imaginaire d’un complexe im ℑ

Fonction elliptique de Weierstrass wp ℘

Epsilon inversé backepsilon ∍

Flèche gauche leftarrow 

Flèche droite rightarrow 

Flèche haut uparrow 

Flèche bas downarrow 

Points en bas dotslow 

Points au milieu dotsaxis ⋯

Points verticaux dotsvert ⋮

Points en diagonale croissant dotsup ou dotsdiag ⋰ ou ⋰

Points en diagonale décroissant dotsdown ⋱
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Attention

Le nom des balises des caractères grecs et spéciaux sont localisés dans la langue 
de l’interface. Le tableau ci-dessous les donne pour le français. Pour l’anglais, vous 
pouvez vous référer au guide officiel anglais. Vous pouvez toujours utiliser le 
catalogue de symboles (Figure 8, page 11) pour sélectionner le caractère souhaité à 
partir de sa forme. Le nom localisé du caractère sera alors affiché.

Une fois entré, les caractères s’afficheront correctement quelle que soit la langue.

Contrairement aux mots réservés, les caractères spéciaux sont sensibles à la casse.

Caractères grecs
Les caractères italiques sont obtenus en ajoutant un i juste après le pour cent. Par exemple %iPI
Π  à place de %PI Π .

%ALPHA Α %BÊTA Β %GAMMA Γ %DELTA Δ %EPSILON Ε

%ZÊTA Ζ %ÊTA Η %THÊTA Θ %IOTA Ι %KAPPA Κ

%LAMBDA Λ %MU Μ %NU Ν %XI Ξ %OMICRON Ο

%PI Π %RHÔ Ρ %SIGMA Σ %TAU Τ %UPSILON Υ

%PHI Φ %KHI Χ %PSI Ψ %OMÉGA Ω

%alpha α %bêta β %gamma γ %delta δ %epsilon ϵ

%varepsilo
n

ε %zêta ζ %êta η %thêta θ %varthêta ϑ

%iota ι %kappa κ %lambda λ %mu μ %nu ν

%xi ξ %omicron ο %pi π %varpi ϖ %rhô ρ

%varrhô ϱ %sigma σ %varsigma ς %tau τ %upsilon υ

%phi ϕ %varphi φ %khi χ %psi ψ %oméga ω

Caractères spéciaux
Certains caractères spéciaux correspondent aux mêmes symboles que les opérateurs mais il n’y 
pas de vérification de syntaxe (présence d’éléments à gauche ou à droite).

%pourmille ‰ %tend → %élément ∈

%pasélément ∉ %infini ∞ %angle ∢

%et ∧ %ou ∨ %différent ≠

%identique ≡ %trèssuppérieurà ≫ %trèsinférieurà ≪
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Mots réservés par ordre alphabétique
Un mot réservé est une expression dont l’utilisation est particulière et contrôlée par  LibreOffice. 
Vous  ne  pouvez  pas  l’utiliser  comme  nom  de  variable.  Pour  pouvoir  utiliser  ces  mots  sans 
modification par Math, il faut les mettre entre ". En voici la liste commentée :

` : petite espace. Voir opérateur ‘grave’.

^ : met en exposant. Voir opérateur ‘hat’ et ‘widehat’.

_ : met en indice

- : soustraction

-+ : signe '-+' avec le '-' au-dessus du '+'

. : point ; doit avoir un caractère avant

( : parenthèse ouvrante

) : parenthèse fermante

[ : crochet ouvrant

] : crochet fermant

{ : accolade ouvrante de regroupement de caractères

} : accolade fermante de regroupement de caractères

* : produit de convolution

/ : division avec écriture linéaire

\ : quand il  est devant un crochet,  une parenthèse ou 
une accolade, permet de traiter l’élément comme un 
caractère  quelconque.  Voir  opérateurs  ‘bslash’  et 
‘setminus’.

& : opérateur logique 'et'

# : séparateur  entre  les  éléments  d’une  ligne  d’un 
tableau

## : séparateur entre les lignes d’un tableau

% : avant un caractère pour marquer un caractère spécial 
(sera affiché normalement s’il n’est pas reconnu)

%% : commentaire

+ : addition

+- : signe '+-' avec le '+' au-dessus du '-'

< : opérateur inférieur à

<?> : marque  l’emplacement  d’un  (des)  élément(s)  à 
côté d’un opérateur lors de l’utilisation de modèles. 
<?> est visible comme un petit carré dans la formule. 
La touche F4 permet de les atteindre.

<< : opérateur très inférieur à

<= : opérateur inférieur ou égal

<> : opérateur différent

= : opérateur égalité

> : opérateur supérieur à

>= : opérateur supérieur ou égal à

>> : opérateur très supérieur à

| : opérateur ou logique

~ : espace. Voir opérateur ‘tilde’.

abs : fonction valeur absolue

acute : met un accent aigu sur un caractère

aleph : première lettre de l’alphabet hébreux (nombre 
cardinal)

alignb : (alignement vertical en bas) 13

13  Ce sont des raccourcis obsolètes pour align-

alignc : alignement horizontal centré

alignl : alignement à gauche

alignm : (alignement centré verticalement) 13

alignr : alignement à droite

alignt : (alignement vertical en haut) 13

and : opérateur et

approx : signe environ, deux ~ l’un sur l’autre

arccos : fonction arc cosinus

arccot : fonction arc cotangente

arcosh : fonction argument cosinus hyperbolique

arcoth : fonction argument cotangente hyperbolique

arcsin : fonction arc sinus

arctan : fonction arc tangente

arsinh : fonction argument sinus hyperbolique

artanh : fonction argument tangente hyperbolique

backepsilon : epsilon renversé

bar : met une barre sur le caractère suivant

binom : met les 2 éléments suivants l’un sur l’autre

black : couleur noir, attribut de 'color'

blue : couleur bleu, attribut de 'color'

bold : style de la police de caractère gras

boper : affiche le caractère suivant considéré comme un 
opérateur binaire ; sa taille est inchangée

breve : met un demi cercle tourné vers le haut

bslash : opérateur \, comme différence

cdot : opérateur '.' de la multiplication

check : met un accent circonflexe à l’envers

circ : 'rond' opérateur de composition de fonctions

circle : met un rond sur le caractère

color : sélection  de  la  couleur :  black,  blue,  cyan, 
green, magenta, red, white, yellow

coprod : coproduit (Π inversé) ou somme directe

cos : fonction cosinus

cosh : cosinus hyperbolique

cot : cotangente

coth : cotangente hyperbolique

csub : met un indice centré en dessous

csup : met un indice centré au dessus

cyan : couleur attribut de 'color'

dddot : met  trois  points  au  dessus,  notation  de  la 
dérivée triple en physique

ddot : met deux points au dessus, notation de la dérivée 
double en physique

bottom, align-mid et align-top, pour les 
alignements verticaux. L’analyseur de Math les 
reconnaît mais rien n’est modifié.
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def : signe  égal  avec  DEF écrit  en  petits  caractères 
dessus.

div : signe diviser ':' avec un '-' au milieu

divides : opérateur  |  (barre  de  Sheffer),  donne  le 
symbole logique « ou ».

dlarrow : double flèche vers la gauche

dlrarrow : double  flèche  dans  les  deux  sens 
(équivalent)

dot : met un point au dessus, notation de la dérivée en 
physique

dotsaxis : aligne ... à mi-hauteur de ligne

dotsdiag : aligne trois points sur une pente à +45°

dotsdown : aligne trois points sur une pente à -45°

dotslow : aligne trois points en bas de ligne

dotsup : aligne trois points sur une pente à +45°

dotsvert : aligne 3 points verticalement

downarrow : flèche vers le bas

drarrow : double flèche vers la droite (implique)

emptyset : ensemble vide

equiv : congru à (signe égal à trois traits)

exists : il existe (E à l’envers)

exp : fonction exponentielle

fact : fonction factorielle (met un '!' après)

fixed : attribut de police

font : sélectionne une police

forall : quel que soit (A la tête en bas)

from : 'de',  va  avec  'to'  pour  faire  'de  à'  (avec  des 
intégrales, des sommes...)

func : transforme un texte en fonction

ge : supérieur ou égal signe '=' horizontal

geslant : supérieur ou égal signe '=' le long de >

gg : beaucoup plus grand que '>>'

grave : met un accent grave

green : couleur vert, attribut de 'color'

gt : opérateur plus grand que

hat : met un accent circonflexe

hbar : écrit un h barré (h), constante de Planck réduite 
(divisée par π)

iiint : intégrale triple, trois fois le signe intégrale

iint : intégrale double, deux fois le signe intégrale

im : fonction partie imaginaire de

in : signe appartient à, élément de

infinity : symbole de l’infini

infty : symbole de l’infini

int : intégrale simple

intersection : opérateur intersection

ital : écrit en italique l’élément suivant

italic : écrit en italique l’élément suivant

lambdabar : affiche un lambda barré

langle : < pour ouvrir  un '<...>' (crochets d’opérateur 
angulaire : langle ... mline ... rangle)

lbrace : accolade gauche '{' qui s’affichera

lceil : crochet [ sans le trait du bas

ldbracket : double crochet ouvrant

ldline : double ligne (norme) '||' ouvrante

le : plus petit ou égal avec le « = » horizontal

left : indique que l’objet suivant est traité comme une 

parenthèse/crochet/accolade ouvrante.

leftarrow : flèche vers la gauche

leslant : plus petit que avec '=' le long du signe '<'

lfloor : crochet [ sans le trait du haut

lim : opérateur limite

liminf : opérateur limite inférieure

limsup : opérateur limite supérieure

lint : intégrale avec un rond dessus, curviligne

ll : opérateur très inférieur à

lline : barre ouvrante de valeur absolue '|'

llint : double intégrale avec un rond dessus

lllint : triple intégrale avec un rond dessus

ln : fonction logarithme népérien

log : fonction logarithme décimal

lsub : met en indice à gauche

lsup : met en exposant en bas

lt : opérateur inférieur à '<'

magenta : couleur, attribut de 'color'

matrix : définit une matrice

minusplus : signe '–+' plus avec le - dessus

mline : ligne  verticale  '|'  (crochets  d’opérateur 
angulaire : langle ... mline ... rangle)

nabla : opérateur nabla, un Δ la tête en bas.

nbold : ne pas écrire en gras.

ndivides : opérateur  ne  divise  pas,  /  barré 
verticalement

neg : opérateur non

neq : opérateur différent

newline : saut de ligne

ni : signe appartient inversé

nitalic : ne pas écrire en italique

none : attribut de 'left' ou de 'right' pour signaler que la 
parenthèse de gauche ou de droite est non visible

notin : opérateur n’appartient pas

nroot : racine nième

nsubset : opérateur n’est pas strictement inclus dans

nsubseteq : opérateur n’est pas inclus ou égal dans

nsupset : opérateur n’est pas strictement inclus dans 
inversé (de droite à gauche)

nsupseteq : opérateur  n’est  pas  inclus ou égal  dans 
inversé (de droite à gauche)

odivide : opérateur / dans un rond

odot : opérateur '.' dans un rond

ominus : opérateur '–' dans un rond
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oper : affiche  le  caractère  suivant  avec  la  taille  d’un 
opérateur (comme Σ)

oplus : opérateur somme directe, + dans un rond

or : opérateur logique ou, ^ la tête en bas

ortho : opérateur orthogonal, symbole perpendiculaire

otimes : opérateur produit tensoriel, x dans un rond

over : opérateur division, sert à écrire les divisions avec 
les traits de fractions horizontaux.

overbrace : met  le  caractère  suivant  au dessus  des 
caractères  précédents  avec  une  accolade 
horizontale

overline : met une barre horizontale juste en dessus 
de tous les caractères suivants

overstrike : barre tous les caractères

owns : appartient à l’envers (de droite à gauche)

parallel : opérateur parallèle '||'

partial : d rond de la dérivée partielle

phantom : n’écrit pas les caractères sélectionnés, laisse 
la place vide

plusminus : opérateur '+-' avec le '+' dessus

prod : opérateur produit, Π

prop : opérateur proportionnel

rangle : '>' pour fermer un '<...>' (crochets d’opérateur 
angulaire : langle ... mline ... rangle)

rbrace : accolade fermante

rceil : crochet fermant sans le trait du bas

rdbracket : double crochet fermant

rdline : double ligne '||' fermante, norme

re : fonction partie réelle de

red : couleur rouge, attribut de 'color'

rfloor : crochet fermant sans le trait du haut

right : indique que l’objet suivant est traité comme une 

parenthèse/crochet/accolade fermante

rightarrow : flèche vers la droite

rline : ligne fermante '|', valeur absolue

rsub : le caractère suivant est formaté en tant qu’indice

rsup : le  caractère  suivant  est  formaté  en  tant 
qu’exposant

sans : option de police de caractères

serif : option de police de caractères

setC : ensemble des complexes

setminus : opérateur  \,  soustraction  dans  les 
ensembles

setN : ensemble des entiers naturels

setQ : ensemble des rationnels

setR : ensemble des réels

setZ : ensemble des entiers relatifs

sim : opérateur équivalent, écrit un simple ~ 

simeq : opérateur sensiblement égal, écrit un double ~

sin : fonction sinus

sinh : fonction sinus hyperbolique

size : modifie les tailles des caractères

slash : opérateur slash '/'

sqrt : opérateur racine carrée

stack : défini une pile d’éléments séparés avec des '#'

sub : transforme le caractère suivant en indice

subset : opérateur strictement inclus

subseteq : opérateur inclus ou égal

sum : somme, Σ

sup : transforme le caractère suivant en exposant

supset : opérateur strictement inclus inversé (de droite 
à gauche)

supseteq : opérateur inclus ou égal inversé (de droite à 
gauche)

tan : fonction tangente

tanh : fonction tangente hyperbolique

tilde : met un tilde '~' sur le caractère suivant

times : opérateur multiplication, 'X'

to : 'à', va avec from pour faire 'de à'

toward : dessine une flèche vers la droite

transl : dessine 2 petits ronds joints par un segment, 
celui de gauche est noirci (signe de correspondance 
Image de)

transr : dessine 2 petits ronds joints par un segment, 
celui de droite est noirci  (signe de correspondance 
Origine de)

underbrace : met sous les caractères précédents une 
accolade  horizontale  avec  le  caractère  suivant 
dessous en indice

underline : souligne les caractères suivants

union : opérateur union, U

uoper : le  caractère  suivant  est  considéré comme un 
opérateur unaire ; sa taille est inchangée

uparrow : flèche vers le haut

vec : met une petite flèche au dessus

white : couleur blanc, attribut de 'color'

widebslash : opérateur qui met un grand '\'

widehat : met un chapeau sur les caractères suivants

wideslash : opérateur division qui met un grand '/'

widetilde : met un tilde sur les caractères suivants

widevec : met une flèche de vecteur sur les caractères 
suivants

wp : fonction de Weierstrass

yellow : couleur jaune, attribut de 'color'
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