Preface
Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To this edition
Skip Masonsmith Kees Kriek

To previous edition
Jean Hollis Weber Kieran Peckett Peter Schofield
Dave Barton Olivier Hallot Steve Fanning
Leo Moons Kees Kriek Gordon Bates
Felipe Viggiano Zbyszek Zak

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s forum at https://community.documentfoundation.org/c/documentation/loguides/ (registration is required) or send an email to: loguides@community.documentfoundation.org.

Note

Everything you post to a forum, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted. E-mails sent to the forum are moderated.

Publication date and software version

Published August 2022. Based on LibreOffice 7.4 Community.
Other versions of LibreOffice may differ in appearance and functionality.
Contents
Copyright.......................................................................................................................... 2
Contributors................................................................................................................... 2
Feedback......................................................................................................................... 2
Publication date and software version.......................................................................... 2
Who is this book for?..................................................................................................... 4
What’s in this book?....................................................................................................... 4
Where to get more help................................................................................................ 4
Help system.................................................................................................................. 4
Other free online support............................................................................................. 6
Paid support and training............................................................................................. 6
What you see may be different.................................................................................... 6
Illustrations.................................................................................................................... 6
Icons............................................................................................................................... 7
Using LibreOffice on macOS...................................................................................... 7
What are all these things called?................................................................................ 7
Frequently asked questions........................................................................................... 8
What’s new in LibreOffice Calc 7.4 Community?....................................................... 9
Who is this book for?

This book is for beginner to advanced users of Calc, the spreadsheet component of LibreOffice. You may be new to spreadsheet software, or you may be familiar with another program. If you have never used LibreOffice before, or you want an introduction to all of its components, you might like to read the Getting Started Guide first. If you have never used spreadsheets before, you might also like to read a book or find some tutorials about the use of spreadsheets.

What’s in this book?

This book introduces the features and functions of LibreOffice Calc. It is not a tutorial on using spreadsheets. Some chapters assume familiarity with basic spreadsheet usage when describing how to use Calc.

You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results. Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of the data and observing the results without having to retype all of the data. Functions can be used to create formulas to perform complex calculations on data.

Some of the other features provided by Calc include:

- Database functions, to arrange, store, and filter data.
- Data statistics tools, to perform complex data analysis.
- Dynamic charts: a wide range of 2D and 3D charts.
- Ability to open, edit, and save Microsoft Excel and other spreadsheets.
- Import and export of spreadsheets from multiple formats, including HTML, CSV, and Data Interchange Format.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive online Help system. This is the first line of support for using LibreOffice. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select Help > LibreOffice Help from the Menu bar (Figure 1). If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities.

Note

The following options indicated by a ‡ symbol are only accessible if your computer is connected to the Internet.
Figure 1: The Help menu

- **What's This?** – For quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation, select **Help > What's This?** and hold the pointer over the icon. In addition, you can choose whether to activate extended tips using **Tools > Options > LibreOffice > General > Extended tips.**


- **Show Tip of the Day** – Opens a dialog showing a useful bit of information to help expand your knowledge of LibreOffice.

- **Search Commands** – Opens a dialog where you can search for commands that are present in the main menu and then run a selected command. More information about this facility can be found in Chapter 1, Introduction.


- **Send Feedback**‡ – Opens your default browser at the Feedback page of the LibreOffice website [https://community.documentfoundation.org/c/documentation/loguides/](https://community.documentfoundation.org/c/documentation/loguides/). From there you can report bugs, suggest new features, and communicate with others in the LibreOffice community.

- **Restart in Safe Mode** – Opens a dialog where you can restart LibreOffice and reset the software to its default settings.

- **Get Involved**‡ – Opens your default browser at the Get Involved page of the LibreOffice website [https://www.libreoffice.org/community/get-involved/](https://www.libreoffice.org/community/get-involved/). There you can choose a topic of interest to help improve the program.

- **Donate to LibreOffice**‡ – Opens your default browser at the Donation page of the LibreOffice website [https://donate.libreoffice.org/](https://donate.libreoffice.org/).
• **License Information** – Outlines the licenses under which LibreOffice is made available.

• **Check for Updates** – Opens a dialog and checks the LibreOffice website for updates to your version of the software.

• **About LibreOffice** – Opens a dialog, which displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software. A button is provided to enable you to copy this information to the clipboard so that you can subsequently paste it into a forum post, an email, or a bug report.

---

**Other free online support**

The LibreOffice community not only develops software, but provides free, volunteer-based support. In addition to the Help menu links above, there are other online community support options available, see Table 1.

**Table 1: Free LibreOffice support**

<table>
<thead>
<tr>
<th>Service Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FAQs</td>
<td>Answers to frequently asked questions</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Faq">https://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td>Mailing lists</td>
<td>Free community support is provided by a network of experienced users</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/get-help/mailing-lists/">https://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
<tr>
<td>Forum</td>
<td>As in the mailing lists above, but through forum</td>
</tr>
<tr>
<td></td>
<td><a href="https://community.documentfoundation.org/">https://community.documentfoundation.org/</a></td>
</tr>
<tr>
<td>Questions &amp; Answers and Knowledge Base</td>
<td>Free community assistance is provided in a question and answer formatted web service. Search similar topics or open a new one in <a href="https://ask.libreoffice.org/en/questions">https://ask.libreoffice.org/en/questions</a>.</td>
</tr>
<tr>
<td></td>
<td>The service is available in several other languages; just replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above.</td>
</tr>
<tr>
<td>Native language support</td>
<td>The LibreOffice website in various languages</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/community/nlc/">https://www.libreoffice.org/community/nlc/</a></td>
</tr>
<tr>
<td></td>
<td>Mailing lists for native languages</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Local_Mailing_Lists">https://wiki.documentfoundation.org/Local_Mailing_Lists</a></td>
</tr>
<tr>
<td></td>
<td>Information about social networking</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Website/Web_Sites_services">https://wiki.documentfoundation.org/Website/Web_Sites_services</a></td>
</tr>
<tr>
<td>Accessibility options</td>
<td>Information about available accessibility options</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/get-help/accessibility/">https://www.libreoffice.org/get-help/accessibility/</a></td>
</tr>
</tbody>
</table>

---

**Paid support and training**

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/.

---

**What you see may be different**

**Illustrations**

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.
Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can either use dialogs from your computer’s operating system or from LibreOffice. The differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to Tools > Options > LibreOffice > General and select or deselect the option Use LibreOffice dialogs.

**Icons**

The LibreOffice community has created icons for several icon sets: Colibre, Breeze, Breeze Dark, Elementary, Karasa Jaga, Sifr, Sifr Dark, and Sukapura. Each user can select a preferred set. The icons in this guide have been taken from a variety of LibreOffice installations that use different sets of icons. The icons for some of the many tools available in LibreOffice may then differ from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. Choose from the drop-down list under Icon Style.

**Note**

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the standard installation package. They can be added back by downloading and installing the following extensions:
- [https://extensions.libreoffice.org/extensions/galaxy-icon-theme](https://extensions.libreoffice.org/extensions/galaxy-icon-theme)
- [https://extensions.libreoffice.org/extensions/oxygen-icon-theme](https://extensions.libreoffice.org/extensions/oxygen-icon-theme)

Some of the previously included gallery backgrounds are now only available as an extension from:
- [https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds](https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds)

---

**Using LibreOffice on macOS**

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. Table 2 gives some common substitutions for the instructions in this document. For a more detailed list, see the application Help and Appendix A, Keyboard Shortcuts, to this guide.

**Table 2: Example keystrokes for different environments**

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>
What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls to use to specify how to carry out an action. The technical names for common controls are shown in Figure 2. In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find and Replace dialog.

Figure 2: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).
4) Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.
Frequently asked questions

How is LibreOffice Licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See https://www.libreoffice.org/about-us/licenses/.

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under GNU Lesser General Public License (LGPL) 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.

How many computers may I install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 100 languages, so your language is probably supported. Additionally, there are over 100 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available by selecting the Dictionary tag filter from the LibreOffice Extension Center https://extensions.libreoffice.org/.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is mostly written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JRE (Java Runtime Environment) is only required for some features. The most notable one is the HSQLDB relational database engine used by the Base component of LibreOffice. For Calc, Java is needed to run some of the solver engines described in Chapter 9, Data Analysis.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp.

Note
If you want to use LibreOffice features that require Java it is important that the correct 32 bit or 64 bit edition matches the installed version of LibreOffice.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: https://whatcanidoforlibreoffice.org.

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/.
What’s new in LibreOffice Calc 7.4 Community?

Information about the LibreOffice 7.4 Community release can be found in this announcement: https://blog.documentfoundation.org/blog/2022/08/18/libreoffice-7-4-community/.

This user guide has been updated from Calc Guide 7.2. Significant changes include:

- Calc now supports and uses 16,384 columns.
- Sort options and sort items are easier to access with the most frequently used sort options on the first tab (see Chapter 2).
- Easier to access a sheet in a spreadsheet with a large number of sheets. (Sheet > Navigate > Go to Sheet) opens a dialog to select or search for sheets by name (see Chapter 7).
- Hidden columns/rows can be highlighted with an indicator using (View > Hidden Row/Column Indicator) (see Chapter 1).
- Added COUNTA, PRODUCT, STDEV, STDEVVP, VAR, VARP functions to drop-down AutoSum widget on Formula bar (see Chapter 1).
- AutoInput has extended options for handling multiple suggestion matches (see Chapter 2).

Other speed improvements or performance enhancements to this version include:

- Opening XLSM, XLSX files, import / export of CSV files, and export of Excel files.
- Handling of files with many columns, many formulas or large charts.
- Lookup functions, COUNTIF, and SUMIFS, especially with unsorted data.

Full Release Notes for versions 7.3 and 7.4 can be found at:

7.3: https://wiki.documentfoundation.org/ReleaseNotes/7.3
7.4: https://wiki.documentfoundation.org/ReleaseNotes/7.4