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General notes on database linkage

Base allows you to use documents in LibreOffice Writer and Calc in various ways as data sources. 
This means that the use of Base is not necessarily tied to the registration of databases in the 
configuration of LibreOffice. External forms can also interact directly with Base, provided that the 
path to the data sources is supplied.

Registration of databases

Many functions, such as printing labels or using data for form letters, require the registration of a 
database in the configuration of LibreOffice.

Using Tools > Options > LibreOffice Base > Databases > New, a database can be registered for 
subsequent use by other LibreOffice components.

The database is found using the file browser and connected to LibreOffice in a similar way as for a 
simple form. The database itself must be given a suitably informative name, for which you can 
simply use the name of the database file. The name serves as an alias, which can also be used in 
queries to the database.

Data source browser

The data source browser allows you access to tables and queries of all registered databases under 
their registered names. The browser can be opened using View > Data sources, or by pressing 
the F4 key, or by using the corresponding symbol in the standard toolbar.

4 Linking to Databases



Registered data sources are shown on the left side of the data source browser. The Bibliography 
data source is included in LibreOffice by default. The other data sources are listed by their 
registered names.

A click on the expansion sign in front of the database name opens the database and shows a sub-
folder for queries and another for tables. Other sub-folders of the database are not made available 
here. Internal forms and reports can only be accessed by opening the database itself.

Only when you click on the Tables folder is the database actually accessed. For databases 
protected by a password, the password must be entered at this point.

To the right of the name tree, you can see the table you have selected. It can be edited just as in 
Base. However direct entry into tables should be carried out with caution in very complex relational 
databases, as the tables are linked together with foreign keys. For example, the database shown 
below has separate tables for street names, postcodes and towns.

For a proper view of the data (but without the ability to edit), queries or views are more suitable.

Of the icons in the toolbar, many will be familiar from data entry into tables. The main new ones are 
those in the last section: Data to Text, Data to Fields, Mail Merge, Data Source of Current 
Document, Explorer on/off.
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Figure 1: Data source browser toolbar

Data to Text
The Data to Text function is available as soon as a record is selected.

Figure 2: Selecting a data record

If you now choose Data to Text, a Wizard appears to carry out the necessary formatting.
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Figure 3: Data entry as table

There are several possibilities for entering data as text: as a table, as single fields, or as ordinary 
text.

The figure above shows the option Insert Data as Table. In the case of numeric and date fields, 
the database format can be changed to a chosen format. Otherwise, formatting is carried out 
automatically when the table fields are selected. The sequence of fields is adjusted by using the 
arrow keys.

As soon as table columns have been selected, the Properties button for the table is activated. This 
allows you to set the usual table properties for Writer (table width, column width, and so on).

The checkbox determines if a table header is required. If it is not checked, no separate row will be 
reserved for headings.

The row chosen for the table headings can be taken from the column names, or the record may be 
written out with space left for the headings to be edited in later.

The  AutoFormat button provides several pre-formatted table views. Apart from the suggested 
Default format, all the formats can be renamed.

To add an autoformat, a table in this format must first be created. This is then selected and can be 
added to the list by using the Add button.

The table is finally created with the selected columns.
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Figure 4: AutoFormat provides a choice of table formats

Insert data as Fields provides the possibility of using a mini-editor to position the various table 
fields successively in the text. The text created in this way can also be provided with a paragraph 
style. In this case too, the formatting of dates and numbers can be specified separately, or can be 
read directly from the table settings in the database.

Figure 5: Insert data as Fields – corresponds also to the dialog for Insert data as Text

The fields inserted into the text in this way can subsequently be deleted singly or used for a mail 
merge.

If you choose Insert data as Text, the only difference from using fields is that fields remain linked 
to the database. When you insert as text, only the content of the specified fields is transferred and 
not the link to the actual database. That explains why the dialog for this option is the same as for 
the previous one.
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The results of the two procedures are compared below.

Figure 6: Comparison of Data as Fields and Data as Text

The fields have a gray background. If the mouse is hovered over the fields, it shows that the fields 
are linked to the Media database, to the table Reader and, within this table, to the field ID.

So, for example, a double-click on the field ID opens the following overview. This makes it clear 
which field was created through the Insert Data as Fields procedure. It is the same field type that is 
shown by Insert > Fields > Other > Database.

Figure 7: Double-click on an inserted field to show the properties of the Mail Merge fields

It is simpler to create such a field by selecting the column header of the table in the data source 
browser and dragging it into the document with the mouse. You can create a form letter directly in 
this way.

Data to Fields
Data as Fields, as described in the previous section, is used to create mail merge fields in a  Writer 
document. If now you select a different record in the data source browser and then choose Data as 
Fields, the previously inserted data are replaced by the new data.
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Here another record has been selected. While the Insert data as Fields option leads to the 
previous values being changed to the values for the new record, in the case of Insert data as Text, 
the existing text remains unchanged.

Mail merge

The Mail Merge button launches the Mail Merge Wizard. As the form letter in the above example 
assembles its data from different tables, you need first to launch the database. In the database, 
you then create a new query to make the required data available.

The database is launched through a right-click on the database itself or on one of its tables or 
queries, which immediately refreshes the display in the data source browser. After that the Mail 
Merge Wizard can be called up by using the corresponding button.

Data source of current document
A click on the Data Source of Current Document button opens a direct view on the table which 
forms the basis for the data inserted into the document. In the above example, the Person table 
from the Addresses database appears.

Explorer on/off
Toggling the Explorer On/Off button shows or hides the directory tree to the left of the table view. 
This allows more space, if necessary, for a display of the data. To access another table, you will 
need to switch the Explorer back on.

Creating mail merge documents

The Mail Merge Wizard is also accessible from the database browser. This Wizard allows the 
address field and the salutation to be constructed from a data source in small steps. In principle 
you can create these fields without using the Wizard. Here we will work through the steps of the 
Wizard as an example.
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The Starting document for the form letter is the document to which the database fields are 
linked.

The Merged document is the one containing the data for the various people who are to receive 
the form letters. In the merged document there is no linkage to the data source. It is similar to the 
output of Insert Data as Text.

The Mail Merge Wizard can produce either letters or emails using records from the database.
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The entry of the address block allows the most extensive configuration. The suggested address list 
comes from the currently selected query or table in the currently selected database.

Step 2 determines the overall look of the address block. This address block can be customized 
further using the More button. See the following figure.

Step 3 serves to link the named fields in the address block to the correct fields in the database. 
The Wizard initially recognizes only those database fields which have exactly the same names as 
those the Wizard uses.

In Step 4, the addresses are displayed. You can choose which addresses to take from the 
database by using the arrow keys. In the displayed addresses two elements require further editing:

• There is no salutation.

• Apart from the first name, all the other fields are < not yet allocated > , because the field 
names in the database are different from the names that the Wizard initially uses.

To correct these errors, the address block from Step 2 must be made editable.
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You can see in the background that, when you choose to edit, you are first presented with an 
enlarged list of address blocks. Here you can select the most suitable address block to start with, 
and then edit it.

The address block cannot be edited directly. Instead, the arrangement of the fields is carried out by 
using the arrow buttons visible to the right to move fields into or out of the address block

For the salutation the Salutation field is inserted. All the other fields except FirstName must now be 
entered appropriately.
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Here the address elements are associated with the corresponding elements from the query of the 
database successfully transferred by the Mail Merge Wizard. Again the first record in the query is 
used for the preview.

The database settings are essentially ended with Step 4. Here, it is just a matter of choosing which 
field the gender of the recipient should be taken from. This field has already been named, so that 
only the field content for a female recipient still needs to be specified.

Three different salutations are to be produced. All records with a 'w' start with Dear Ms…, all those 
with 'm' with Dear Mr… If there is no gender given, Dear Sir/Madam is selected.

14 Linking to Databases



Creating mail merge documents 15



Normally the document is initially a rough sketch which can be further edited in Writer. This can be 
done in Step 6.

Up to now all the documents have been identical except for the different content of the fields read 
from the database. This can be changed in Step 7.
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The Starting document is the document in which the field properties and the linkage to the 
database are stored. In the background meanwhile, you can see the original document with the 
contents of the first record that is to be converted into the form letter. This is called the Mail Merge 
document.

Only when one of the options is actually carried out (in the above example to save the starting 
document) does the Mail Merge Wizard terminate.

Label printing

Files > New > Labels launches the Label Printing Wizard. It opens a dialog, which includes all 
questions of formating and content for labels, before the labels themselves are produced. The 
settings in this dialog are saved in the personal settings for the user.
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The basic settings for the content are in the Labels tab. If for Label text you check the Address box, 
all the labels will have the same content, taken from the LibreOffice settings for the user of the 
program.

As an example we will again use the Addresses database. Although the next selection field is 
headed Tables, Tables and Queries are both listed here, just as in the data source browser.

The arrow buttons are used to insert individual database fields into the editor. The name for the 
database field Surname is set here to <Addresses.MailMergeQuery.1.Surname>. The sequence is 
thus <database.Table.1.database field>.

You can work with the keyboard in the editor. So for example, it is possible to insert a line break at 
the beginning, so that the labels will not be printed directly on the top edge but the content can be 
printed as completely and clearly visible.

The format can be selected in the tab Labels. Here many label brands are incorporated so that 
most other settings in the tab Format are not necessary.

Note

In versions 3.4.x to 3.5.2, due to a change in the basic settings in the label wizard, 
display errors occurred when the labels were the same width as the page width. 
Under these conditions, the last label simply slides down one line.

In version 3.5.3 page settings were added in the Format tab.

The Format tab allows you to set the label size accurately. The settings are only significant when 
the make and type of the labels is not known. It is noteworthy that, to print labels 7.00 cm wide, you 
need a page width a little bigger than  3*7.00 cm = 21.00 cm. Only then will three labels be printed 
in a row on the page.
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Under the Options tab you can specify whether only a single label or a whole page of labels will be 
produced. The page will then be filled with data from successive records of the database, 
beginning with the first record. If there are more records than will fit on the page, the next page will 
automatically be filled with the next set of records.

The Synchronize contents checkbox links all the labels together so that subsequent changes in 
layout of any label will be applied to all the others. To transfer the edited content, just use the 
included button labelled Synchronize, which appears during label production if you have selected 
this checkbox.

Finally the New Document button is used to create a document containing the selected fields.

When you initiate the printing process, the following question appears:

Choose Yes to fill the address database fields with the corresponding content.
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The source of the data for the label printing is not found automatically; only the database is pre-
selected. The actual query must be specified by the user, because in this case we are not dealing 
with a table.

When the query is selected and the corresponding records chosen (in this case All), the printing 
can begin. It is advisable, especially for the first tests, to choose Output to a File, which will save 
the labels as a document. The option to save in several documents is not appropriate for label 
printing but rather for letters to different recipients which can then be worked on subsequently. 

Direct creation of mail merge and label documents

Instead of using the Wizard, you can of course produce mail merge and label documents directly.

Mail merge using the mouse
Mail merge fields can be taken from the database browser using the mouse:
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Select the table header with the left mouse button. Hold the button down and drag the cursor 
through the text document. The cursor changes its shape to an insert symbol. The MailMerge field 
is inserted into the text document, here shown in the complete description which is made visible 
using View > Field names.

Creating form letters by selecting fields
Mail merge fields can be inserted using Insert > Fields > Other > Database.

Here all tables and queries in the selected database are available. Using the 'Insert' button,  the 
various fields can be inserted one after another directly into the text at the current cursor position.

If you want to create a salutation, which is usual in form letters, you can use a hidden paragraph or 
hidden text: Insert > Fields > Other > Functions > Hidden paragraph. For both variants take 
care that the condition you formulate will not be fulfilled, since you want the paragraph to be 
visible.

For the formula Dear Mrs <Surname>, to appear only when the person is female, a sufficient 
condition is:

[Addresses.Mailmergequery.Gender] != "f"

Now the only remaining problem is that there may be no surname. Under these circumstances, 
"Dear Sir/Madam," should appear so this is the condition you must insert. The overall condition is:

[Addresses.MailMergeQuery.Gender] != "w" OR NOT 
[Addresses.MailMergeQuery.Surname]

That excludes the possibility of this paragraph appearing when the person is not female or there is 
no entered surname.

In the same way you can create entries for the masculine gender and for missing entries for the 
two remaining types of salutation.
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Naturally you can create a salutation in the address field in exactly the same way, wherever the 
gender is specified.

Further information is given in the LibreOffice Help under Hidden Text and Conditional Text.

Of course it would be still simpler if someone who understands databases were to put the whole 
salutation right into the query. This can be done using a correlated subquery (see the chapter on 
Queries in this Handbook).

Particularly interesting for labels is the field type Next record. If this field type is chosen at the end 
of a label, the next label will be filled with data from the following record. Typical labels for 
sequential label printing look like the following figure when you use View > Field names to make 
the corresponding field designations visible:

Figure 8: Field selection for labels with sequential content

External forms

If simple form properties available in LibreOffice are to be used in other program modules such as 
Writer and Calc, you only need to display the form design toolbar, using View > Toolbars > Form 
design, then open the Form navigator. You can build a form or, as described in the Forms chapter, 
create a form field. The Data tab of the Form Properties dialog looks a little different from the one 
you see when forms are built directly in an ODB database file:

Figure 9: Form with an external data source

Figure 10: Form with an internal data source.

The Data source must be selected separately when using an external form. Use the button to the 
right of the data source listbox to open the file browser. Any ODB file can be selected. In addition, 
the field for the data source contains a link, beginning with file:///.

If instead you look in the listbox contents, you will see databases already registered in LibreOffice 
under their registered names.

The forms are created in exactly the same way as in Base itself.
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Advantages of external forms
Base need not be opened first in order to work with the database. Therefore you do not need 
an extra open window in the background.

In a database that is already complete, existing database users can subsequently be sent the 
improved form without problems. They can continue to use the database during the 
development of further forms, and do not need to copy complicated external forms from one 
database into another.

Forms for a database can be varied to suit the user. Users who do not have the authority to 
correct data or make new entries can be sent a current data set by other users, and simply 
replace their *.odb file to have an up-to-date view. This could, for example, be useful for a 
database for an association where all committee members get the database but only one 
person can edit the data; the others can still view the addresses for their respective 
departments.

Disadvantages of external forms
Users must always install forms and Base with the same directory structure. That is the only 
way that access to the database can be free from errors. As the links are stored relative to the 
form, it is sufficient to store the database and its forms in a common directory.

Only forms can be created externally, not queries or reports. A simple glance at a query 
therefore must go through a form. A report on the other hand requires the opening of the 
database. Alternatively it might be possible to create it, at least partially, using mail merge.

Database use in Calc

Data can be used in Calc for calculation purposes. For this purpose it is first necessary to make the 
data accessible in a Calc worksheet.

Entering data into Calc
There are various ways of inserting data into Calc.

Select a table with the left mouse button and drag it into a Calc worksheet. The cursor sets the left 
upper corner of the table. The table is created complete with field names. The data source browser 
in this case does not offer the options of Data into Text or Data into Fields.

Data dragged into Calc in this way shows the following properties:
Not only the data are imported, but the field properties too are read and acted on during the import. 
Fields such as house numbers, which were declared as text fields, are formatted as text after 
insertion into Calc.

The import becomes a Calc range, which by default is assigned the name Import1. The data can 
later be accessed using this range. Data > Refresh range allows the range, where appropriate, to 
be supplied with new data from the database.
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The imported data is not formatted except as the properties of the database fields require.

You can also use the context menu of a table to make a copy of the data. In this case, however, 
there is no import but merely a copy. The properties of the data fields are not read with them but 
are determined by Calc. In addition the field names are formatted as table headers.
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You see the difference especially in database fields that are formatted as text. On import, Calc 
turns these into text fields and precedes numbers, which would otherwise be interpreted as such, 
with a single quote ('137). These numbers can then no longer be used in calculations.

If you export them again, the single quote is removed, so that the data remain as they were.

Exporting data from Calc into a database
Select the data in the Calc worksheet. Hold the left mouse button down and drag the data that you 
want to turn into a database into the table area of the database browser.
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The cursor changes its appearance, showing that something can be inserted.

The Copy Table dialog appears. In the above case a new table is created. The table name is 
"Names". Definition and Data are to be transferred. The first line contains the column headers.

At this point you can create a new additional field for a primary key. The name of this database 
field must not be one that already exists as a column header in the Calc sheet. Otherwise you get 
the error message:

The following fields are already set as primary key: ID

Unfortunately this message does not describe the problem quite correctly.

If you want an existing field to be used as the key, do not check the Create primary key box. In 
such cases the primary key is set using the third dialog in the Wizard.

26 Linking to Databases



The appropriate fields are selected.

The formatting of the columns needs to be checked, especially for numeric fields. Other fields 
should also be checked for size. It just so happens that the test table contains only first names with 
a maximum length of 10 characters, so that it can become a field of type Varchar with a length of 
10 characters.

Here the ID field, which is to be the primary key, is formatted. The primary key must be set by 
using the context menu of its field name, in cases where it has not been created by the Wizard in 
the Copy Table dialog as an additional field. After you click the Finish button, the table is created.

The new primary key is not an Auto-Value key. To create such a key, you must open the database 
for editing. There you can carry out further formatting of the table.
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Converting data from one database to another

In the explorer of the data source browser, tables can be copied from one database to another by 
selecting the source table with the left mouse button, holding the button down, and dragging it into 
the target database in the table container. This causes the dialog for copying tables to be 
displayed.

In this way, for example, read-only databases (data sources such as address books from an email 
program or a spreadsheet table) can be used as a basis for a database in which the data become 
editable. Also data can be directly copied when changing to another database program (for 
example changing from PostgreSQL to MySQL).

If you wish the new database to have different relationships from the original one, you can arrange 
this by using appropriate queries. Those who are not sufficiently expert can instead use Calc. Just 
drag the data into a spreadsheet and prepare them for import into the target database using the 
facilities that Calc provides.

For the cleanest possible import into a new database, the tables should be prepared in advance. 
This allows problems of formatting and those involving the creation of primary keys to be 
recognized well in advance.
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