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What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word 
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic 
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:

• Templates and styles (see Chapter 3)

• Page layout methods, including frames, columns, and tables

• Automated tables of contents and indexes

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents—to group a collection of documents into a single document

• Change tracking during revisions

• Database integration, including a bibliography database

• Mail merge

• Export to PDF, including bookmarks (see Chapter 10)

• Document digital signature

• Form design and filling

• And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are described in 
Chapter 1, Introducing LibreOffice. Some other features of the Writer interface are covered in this 
chapter.

Figure 1: The main Writer workspace
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Status Bar
The Writer Status Bar provides information about the document and convenient ways to change 
some document features quickly.

Figure 2: Status bar components

Page number
Shows the current page number, the sequence number of the current page (if different), and 
the total number of pages in the document. For example, if you restarted page numbering at 
1 on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list 
of bookmarks; click on one to go to that location.

To jump to a specific page in the document, double-click on this field. The Navigator opens. 
Click in the Page Number field and type the sequence number of the required page and 
press Enter.

Word and character count 
The word and character count of the document is shown in the Status Bar, and is kept up to 
date as you edit. When text is selected, the word and character counts for the selection will 
appear here.

To display extended statistics such as character counts that exclude spaces, double-click the
word count in the Status Bar, or choose Tools > Word Count.

You can also see the number of words and characters (and other information including the 
number of pages, tables, and graphics) in the entire document in File > Properties > 
Statistics.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language at the cursor position, or for the selected text, that is used for checking 
spelling and grammar as well as for hyphenation and thesaurus dictionaries.

Click to open a menu where you can choose another language for the selected text or for the
paragraph where the cursor is located. You can also choose None (Do not check spelling) 
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to exclude the text from a spelling check or choose More to open the Character dialog. Any 
directly formatted language settings can be reset to the default language from this menu.

Insert mode
This area is blank when in Insert mode. Click to change to Overwrite mode; click again to 
return to Insert mode. In Insert mode, any text after the cursor position moves forward to 
make room for the text you type; in Overwrite mode, text after the cursor position is replaced 
by the text you type. This feature is disabled when in Record Changes mode.

Selection mode
Click to choose different selection modes. A context menu displays the available options. 
Howevering the mouse pointer over this field, also displays a tooltip that shows which mode 
is active. Note that the icon does not change. 

Mode Effect

Standard selection Click in the text where you want to position the cursor; click in a cell 
to make it the active cell. Any other selection is deselected.

Extending selection (F8) Clicking in the text extends or crops the current selection.

Adding selection (Shift+F8) A new, separate selection is added to an existing selection. The 
result is a multiple selection.

Block selection 
(Ctrl+Shift+F8)

A block of text can be selected.

On Windows systems, you can hold down the Alt key while dragging to select a block of text. 
You do not need to enter the block selection mode.

Document changes status
The icon that is displayed here changes from this one ( ) if the document has no unsaved 
changes, to this one ( ) if it has been edited and the changes have not been saved. Click 
on the unsaved changes icon to save the document.

Digital signature
If the document has been digitally signed, this icon ( ) is displayed here; otherwise, it is 
blank. To sign the document, or to view the certificate, click the icon.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this 
area opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the 
document in any view. See Figure 3.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or 
right-click on the zoom level percent to pop up a list of magnification values from which to 
choose. Zoom interacts with the selected view layout to determine how many pages are 
visible in the document window.
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Figure 3: View layouts: single, side-by-side, book.

Sidebar
The Sidebar (Figure 4) is normally open by default on the right side of the Writer window. If 
necessary, select View > Sidebar from the Menu bar to display it. The Sidebar also has a 
Hide/Show button.

Figure 4: Default Properties panel of Sidebar in Writer
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The Writer Sidebar contains five decks by default: Properties, Page, Styles, Gallery, and Navigator.
If you have selected Enable experimental features in Tools > Options > LibreOffice > Advanced,
a sixth deck (Manage Changes) will appear, and a seventh (Design) can be selected in Sidebar 
Settings > Customization. Each deck has a corresponding icon on the Tab bar on the right of the 
sidebar, allowing you to switch between them.

Each deck consists of a title bar and one or more content panels. Toolbars and sidebar panels 
share many functions. For example, the buttons for making text bold or italic exist in both the 
Formatting toolbar and the Character panel of the Properties deck.

Some panels contain a small More Options button ( ), which opens a dialog to give greater 

choice of editing controls. When a dialog is open, the document is locked for editing until the dialog
is closed.

The decks are described below.

Properties Deck
Contains tools for direct formatting within the document. 

 For text editing, the default view shows tools organized into three panels:

– Styles: Apply a paragraph style at the cursor position. Create or update a style.

– Character: Modify text by the font type, size, color, weight, style and spacing.

– Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent, 
and spacing. 

Additional panels appear when specific types of items are selected:

If a graphic is selected, then the following panels open:

– Area: Modify the graphic background area fill mode and transparency. Further colors, 
gradients, hatching, patterns, and bitmap selection and importing are available in More 
Options.

– Image: Modify the graphic’s brightness, contrast, color mode and transparency.

– Wrap: Modify wrap and spacing where these are available.

– Position and Size: Modify width and height.

If a drawing object is selected, then the following panels are available:

– Area: Modify fill and transparency.

– Wrap:  Modify wrap and spacing.

– Position and Size: Edit width, height, rotation, and flip attributes.

If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is not 
available.

If a video or audio clip is inserted by selecting Insert > Media > Audio or Visual, the following 
panel opens when the clip is selected:

– Media Playback: Control for play, pause, stop, seek, loop, and volume

– Position and Size:  Modify width and height.

Page Deck 
Modifies the page style to change the most commonly used page properties. It is organized in four 
panels: 

• Format modifies the size, width, height, orientation, and page margins; 
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• Styles modifies the numbering scheme, background, page layout (specifies whether the 
page style should apply to odd or even pages or to both), and columns; 

• Header and Footer modify the respective margins, spacing, and content across pages.

Caution

Be aware that by changing the options on the Page deck, you will change the page style 
in use, modifying not only the current page but all pages in the document using the same 
page style.

Styles Deck
Manages the styles used in the document. This includes applying existing styles, modifying them, 
or creating new ones. You can preview the changes by checking Show Previews at the bottom.

Gallery Deck
Contains images and diagrams included in the Gallery themes. The Gallery has two sections. The 
first lists the themes by name (Arrows, Background, Diagrams, etc.) and the second displays the 
images in the selected category. Select the New Theme button to create new categories. To insert 
an image into a file, or add a new image to the new category, drag and drop the selected image.

Navigator Deck
Makes it easy to navigate to specific types of content and to reorganize contents based on  
categories, such as headings, tables, frames, graphics, etc. This deck is similar to the floating 
toolbar that can be opened from View > Navigator on the Menu bar or the Navigator button on 
the Standard Toolbar, or by pressing F5. However, the Sidebar Navigator does not contain a List 
Box On/Off button that reduces the size of the window.

Manage Changes Deck
Lists all changes made to the document since the Track Changes mode was activated. This deck 
is an alternative view of the Manage Changes dialog that can be opened from Edit > Track 
Changes > Manage Changes on the Menu bar. This tab is available only when Enable 
experimental features has been selected in Tools > Options > LibreOffice > Advanced.

Design Deck
Provides quick access to themes (fonts and colors) and style presets. This deck is available only 
when Experimental Features is enabled in Tools > Options > LibreOffice > Advanced and when 
the deck is selected in Sidebar Settings > Customization. 

Changing document views

Writer has three ways to view a document: Normal, Web, and Full Screen. To change the view, go 
to the View menu and click on the desired view. 

Normal view
Previously called Print Layout, Normal is the default view in Writer. In this view, you can use 
the View Layout icons and the Zoom slider on the Status bar to change the magnification. 
You can set these same options by choosing View > Zoom > Zoom from the menu bar to 
display the Zoom & View Layout dialog.

Normal view also allows you to hide or show the headers and footers and the gap between 
pages. To do this, choose View > Hide Whitespace from the Menu bar. When activated, a 
check mark appears next to the option. This also hides headers, footers, and white space in 
Full Screen view. Note that this only works when single-page view is activated in the Status 
Bar. 
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Web Layout view
In Web Layout view, you can use only the Zoom slider; the View Layout buttons on the 
Status bar are disabled, and most of the choices on the Zoom & View Layout dialog are not 
available. In Web layout there is no visual indication of page boundaries.

Full Screen view
In Full Screen view, the document is displayed using the zoom and layout settings previously
selected in the other views. To exit Full Screen view and return to Normal view, press the Esc
key or toggle the Full Screen button on the floating toolbar in the top left-hand corner. You 
can also use Ctrl+Shift+J to toggle between Full Screen and Normal views.

Moving quickly through a document

Using the Navigator
In addition to the navigation features of the Status Bar (described above), you can use the 
Navigator window and the Navigation toolbar, from either the Standard toolbar or from the Sidebar, 
as described in Chapter 1, Introducing LibreOffice.

The Navigation toolbar (Figure 5), created from the down arrow of the Navigator window, shows 
buttons for all the object types shown in the Navigator.

Figure 5: Navigation toolbar

When the button is selected for a specific object type, clicking the Previous and Next buttons will 
jump to the previous or next occurrence of the object. This is particularly helpful for finding items 
like index entries, which can be difficult to see in the text. The names of the buttons (shown in the 
tooltips) change to match the selected category, such as Next Graphic, Next Bookmark, or 
Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.

Using Go to Page Option
To move to a page in the document use the menu: Edit > Go to Page or the keyboard shortcut 
CTRL + G to open the Go To Page dialog (Figure 6). It initially shows the number of the current 
page and the number of pages in the document. Then type the number of the required destination 
page into the text box and click the OK button.

Figure 6: Go to Page dialog
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Working with documents

Chapter 1, Introducing LibreOffice, includes instructions on creating new documents, opening 
existing documents, saving documents, accessing remote servers, and password-protecting 
documents. Chapter 3, Using Styles and Templates, covers how to create a document from a 
template.

By default, LibreOffice creates and saves files in the OpenDocument file format (ODF), a 
standardized file format (ISO-IEC 26300) used by many software applications. Writer documents 
have the extension .ODT.

Tip

Whenever possible to choose the document file format, choose the default ODF 
format. This reduces the possibility of errors.

Saving as a Microsoft Word file
If you need to exchange documents with users of Microsoft Word who are unwilling or unable to 
receive .ODT files, you can open, edit, and save documents in Microsoft Word formats.

You can also create and edit .ODT files and then save them as .DOC or .DOCX files. To do this:

 1) Important—First save your document in the file format used by LibreOffice Writer (.ODT). If
you do not, any changes you made since the last time you saved will appear only in the 
Microsoft Word version of the document. Also, saving in ODF format enables you to re-save
or modify the document if the recipient of your document experiences trouble with the 
Microsoft format.

 2) Then choose File > Save As. 

 3) On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type 
of Word format you need. You may also choose to change the file name.

 4) Click Save.

This creates a separate document with a different file extension (such as .DOCX). From this point 
on, all changes you make to the document will occur only in the new document.  If you want to go 
back to working with the ODT version of your document, you must open it again.

Tip

To have Writer save documents by default in a Microsoft Word file format, go to Tools 
> Options > Load/Save > General. In the section named Default file format and ODF 
settings, under Document type, select Text document, then under Always save as, 
select your preferred file format.

Using built-in language tools

Writer provides some tools that make work easier if you use more than one language in the same 
document or if you write documents in various languages. Changing the language for specific text 
enables you to use the correct dictionaries and rules to check spelling, grammar, and hyphenation. 
It also applies the localized versions of Autocorrect replacement options and uses the appropriate 
thesaurus.
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Options for applying languages

Tip

The language used at the location of the cursor is shown in the Status Bar, next to the 
page style in use.

Using styles
Languages can be set on the Font tab of the Paragraph Styles dialog or of the Character Styles 
dialog.

See the Writer Guide for information on how to manage the language settings of a style.

Note

Be careful when changing a language in character or paragraph styles, as this will 
change the language for all characters or paragraphs using that style. It may be useful 
to include the language in the name of the style.

Also, note that languages set with direct formatting will override languages set using 
styles.

Using direct formatting
The language of a whole document can be set by using Tools > Options > Language Settings > 
Languages. In the Default languages for documents section, you can choose the language for all 
the text that is not explicitly marked as a different language.

Set the language for the whole document, for individual paragraphs, or even for individual words 
and characters, from Tools > Language on the Menu bar. 

Alternatively, you can set the language for individual paragraphs and characters by selecting text 
or putting the cursor in a paragraph and changing the language on the Status Bar. 

Note

Although these methods are a type of direct formatting, they cannot be cleared by 
using “Clear Direct Formatting”  on the Format menu or by using Ctrl+M.

Preventing text from being checked for spelling
You can set the language for a paragraph or a group of characters as None (Do not check 
spelling) using any of the methods described above. This option is especially useful for text such 
as web addresses or programming language snippets that you do not want to check for spelling.

Obtaining resources for additional languages
The spelling checker works only for those languages in the Spelling dialog list (described on Page

20) that have the symbol ( ) next to them. If you do not see the symbol next to your preferred 
language, you can install the additional dictionary using Tools > Language > More Dictionaries 
Online.

Working with text

Selecting, copying, pasting, or moving text in Writer is similar to working with text in other 
programs. LibreOffice also has some convenient ways to select items that are not next to each 
other, select a vertical block of text, and paste unformatted text.
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Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 7) using the mouse:

 1) Select the first piece of text.

 2) Hold down the Ctrl key and use the mouse to select the next piece of text.

 3) Repeat as often as needed.

To select nonconsecutive items using the keyboard:

 1) Select the first piece of text. 

 2) Press Shift+F8. This puts Writer in “Adding selection” mode.

 3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down 
the Shift key and select the next piece of text.

 4) Repeat as often as required.

Now you can work with the selected text (copy it, delete it, change the style, and so on).

Press Esc to exit from this mode.

Figure 7: Selecting items that are not next to each other

For more information about keyboard selection of text, see the topic “Navigating and selecting with 
the keyboard” in LibreOffice Help (F1).

Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block 
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or 
press Ctrl+F8, or click on the Selection icon in the Status Bar and select Block selection from the
list.

Figure 8: Selection icon

Now highlight the selection, using mouse or keyboard, as shown below.

Selecting a vertical block of text | 15



Figure 9: Selecting a vertical block of text

Cutting, copying, and moving text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You 
can use the mouse or the keyboard for these operations. You can copy or move text within a 
document, or between documents, by dragging or by using menu selections, toolbar buttons, or 
keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it 
into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it. 
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had 
before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in 
point and use Ctrl+V to paste. Alternatively, use the buttons on the Standard toolbar.

Pasting text
When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste button on the Standard toolbar or Ctrl+V, any formatting the text has (such as bold or 
italics) is retained. Text pasted from Web sites and other sources may also be placed into frames 
or tables. If you do not like the results, click the Undo button or press Ctrl+Z.

To make the pasted text inherit the paragraph style at the insertion point:

• Choose Edit > Paste Special, or

• Click the arrow button of the combination Paste button, or

• Click the Paste button without releasing the left mouse button.

Then select Unformatted text from the resulting menu. Unformatted text can also be pasted with 
Shift+Ctrl+Alt+V.

The range of choices on the Paste Special menu or Ctrl+Shift+V varies depending on the origin 
and formatting of the text (or other object) to be pasted. See Figure 10 for an example when text is 
on the clipboard.

Figure 10: Paste Special menu

Finding and replacing text and formatting
Writer has two ways to find text and formatting within a document: the Find toolbar for fast 
searching and the Find & Replace dialog. In the dialog, you can:

• Find and replace words and phrases

• Use wildcards and regular expressions to fine-tune a search

• Find and replace specific attributes or formatting
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• Find and replace paragraph styles

Using the Find toolbar
By default, the Find toolbar is shown docked at the bottom of the LibreOffice window (just above 
the Status Bar) as shown in Figure 11, but you can float it or dock it in another location. If the Find 
toolbar is not visible, you can display it by choosing View > Toolbars > Find from the Menu bar or 
by pressing Ctrl+F. For more information on floating and docking toolbars, see Chapter 1, 
Introducing LibreOffice.

Figure 11: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next 
occurrence of that term. Click the Find Next or Find Previous buttons as needed.

Click the Find All button to select all instances of the search term within the document. Select 
Match Case to find only the instances that also match the case. To open the Find & Replace 

dialog, select the button ( )  to the right of Match Case.

To search in only specific types of content, click the Page option in the Find toolbar and choose 
from the pop-up menu. For example, to search for something inside the document headings, select
the Headings entry in the menu.

Figure 12: Selective Search List.

To close the Find toolbar, click the X button on the left, or press Esc on the keyboard when the 
cursor is in the search box. Ctrl+F toggles the Find toolbar off and on.

Tip

‘Regular expressions’ offer powerful ways to search and replace text. For example, 
they can find all instances where any number is followed by specific letters. However, 
they can be challenging to understand. Refer to the Help files for guidance.
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Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find & 

Replace from the Menu bar. If the Find toolbar is open, click the Find & Replace button ( ) to 

the right of it. When the dialog is open, optionally click Other Options to expand it. Click the button
again to reduce the dialog options.

Figure 13: Expanded Find & Replace dialog

To use the Find & Replace dialog:

 1) Type the text you want to find in the Find box.

 2) To replace the text with different text, type the new text in the Replace box.

 3) You can select various options such as matching the case, matching whole words only, or 
doing a search for similar words.

The other options include searching only in selected text, searching from the current cursor 
position backwards toward the beginning of the file, searching for similar words, and 
searching in comments.

 4) When you have set up your search, click Find Next. To replace the found text, click 
Replace.

If you click Find All, LibreOffice selects all instances of the search text in the document. Similarly, if
you click Replace All, LibreOffice replaces all matches, without stopping for you to accept each 
instance.

For more information on using Find & Replace, see the Writer Guide.

Caution

Use Replace All with caution; otherwise, you may end up with some highly 
embarrassing (and often hilarious) mistakes. A mistake with Replace All might require 
a manual, word-by-word, search to fix.
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Inserting special characters
A special character is one not found on a standard user’s keyboard. For example, © ¾ æ ç ñ ö ø ¢ 
are all special characters not available on an English keyboard. To insert a special character:

 1) Place the cursor where you want the character to appear.

 2) Choose Insert > Special Character or click on the Special Character icon in the main 
toolbar to open the Special Characters dialog.

 3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then 
click OK. Characters previously selected for insertion are shown in the lower left of the 
dialog. As you select a character, it is shown on the right, along with its numerical code.

The Special Characters dialog ( Figure 14) includes areas to select Recent and Favorite 
Characters. To add a new character to the Favorite Characters, click on a character and click the 
Add to Favorites button.

Tip

Different fonts have their own distinct special characters. If you do not find a particular 
special character, try changing the Font selection.

Figure 14: The Special Characters insert dialog

Inserting dashes and non-breaking spaces and hyphens

Inserting non-breaking spaces
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the 
space between the two words. This inserts a non-breaking space.

Inserting non-breaking hyphens
In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.
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Inserting en and em dashes
To enter en and em dashes, you can use the Replace dashes option on the Options tab under 
Tools > AutoCorrect >AutoCorrect Options. This option replaces two hyphens, under certain 
conditions, with the corresponding dash.

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at least 
one character, a space, one or two hyphens, another space, and at least one more letter. The 
one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at least 
one character, two hyphens, and at least one more character. The two hyphens will be 
replaced by an em-dash. Exception: if the characters are numbers, as in a date or time range, 
the two hyphens are replaced by an en-dash.

See the Help for more details. For other methods of inserting dashes, see the Writer Guide.

Checking spelling and grammar
By default, four dictionaries are installed for each language: a spelling checker, a grammar 
checker, a hyphenation dictionary, and a thesaurus (assuming it is available for that language).  
The spelling checker determines if each word in the document is in the installed dictionary. The 
grammar checker in combination with the spelling checker.

Checking spelling automatically
When highlighted, the Automatic Spell Checking option on the Tools menu checks each word 
as it is typed and displays a wavy red line under any unrecognized words. Right-click on an 
unrecognized word to open a context menu. You can click on one of the suggested words to 
replace the underlined word with the one selected. If the list does not contain the word you want, 
click Spelling to open a dialog. When the word is corrected, the line disappears.

Checking spelling and grammar
To perform a combined spelling and grammar check on the document (or a text selection), click the
Check Spelling button on the Standard toolbar, or choose Tools > Spelling. This checks the 
document or selection and opens the Spelling dialog if any unrecognized words are found. To also 
identify potential grammar problems, check the Check grammar box. .

Here are some more features of the spelling checker:

Change dictionary language
Change the dictionary language (for example, Spanish, French or German) in the Spelling 
dialog by selecting the appropriate language in the Text language drop-down list.

Add a word to the dictionary
Add a word to the dictionary by clicking Add to Dictionary in the Spelling dialog or in the 
context menu. The word will be added to the Standard dictionary, unless you have created 
another dictionary in the same language. If you have created a new dictionary, you will be 
given a choice of dictionaries to add the word to. 

Choose text for spell checking
Choose whether to check uppercase words or words that contain numbers, by clicking the 
Options button on the Spelling and Grammar dialog to open a Writing Aids  dialog similar to 
the one in Tools > Options > Language Settings > Writing Aids, described in Chapter 2.  

Manage custom dictionaries
Create, edit, or delete dictionaries and edit words in the dictionary in the same Writing Aids 
dialog.
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Specify language for specific paragraphs
Set paragraphs to be checked in a language (different from the rest of the document) using 
several methods—for example, by clicking on the Text Language field on the Status Bar or by
creating paragraph styles for specific languages. See “Using built-in language tools” on Page
13 or refer to the Writer Guide for more information.

Set additional grammar checking rules
Select additional grammar checking rules through Tools > Options > Language Settings > 
English sentence checking, or through Tools > Extension Manager > English spelling 
dictionaries > Options.

“Grammar by” spell checking
A new feature in LibreOffice 6.0 is “Grammar by” spelling checking. It enables the dictionary 
to recognize different forms of the same word. It is particularly helpful for new words or 
specialized  words that are unlikely to have all variations in the dictionary. As an example, 
variations of the word “motorcycle”—motorcycles, motorcycled, motorcycling, motorcyclist, 
etc.— would all be accepted, without having to enter each of them individually.  

To use the Grammar by feature, first create a new dictionary in the Options window of the 
Spelling dialog.  Select the dictionary and click Edit. Then enter the base word in the Word 
field and enter a word in the Grammar by field that that has the same variations as the base 
word. In the motorcycle example, the word could be cyclist. 

See the Writer Guide for more information about the spelling and grammar checking options.

Using synonyms and the thesaurus
To access a short list of synonyms, right-click on a word and point to Synonyms on the context 
menu.  A submenu of alternative words and phrases is displayed. Click on a word or phrase in the 
submenu to have it replace the highlighted word or phrase in the document.

The thesaurus gives a more extensive list of alternative words and phrases. To use the thesaurus, 
click on Thesaurus from the Synonyms submenu. If the current language does not have a 
thesaurus installed, this feature is disabled.

Note

The thesaurus and synonyms are writing aids provided by language communities. If 
these aids are not available for your language, consider joining the LibreOffice project 
to help your language community develop them.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it 
corrects automatically. For example, “hte” will be changed to “the”. It also includes codes for 
inserting special characters, emoji, and other symbols.

AutoCorrect is turned on by default. You may wish to disable some of its features, modify others, or
turn it off completely.

You can add your own corrections or special characters or change those supplied with LibreOffice. 
Choose Tools > AutoCorrect > AutoCorrect Options to open the AutoCorrect dialog. On the 
Replace tab, you can define which strings of text are corrected and how. In most cases, the 
defaults are fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click
Delete. To add a new spelling to the list, type it into the Replace and With boxes on the Replace 
tab, and click New.
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See the different tabs of the dialog for the wide variety of other options available to fine-tune 
AutoCorrect.

To turn AutoCorrect off, uncheck Tools > AutoCorrect > While Typing.

Tip

LibreOffice has an extensive list of special characters accessible with AutoCorrect. For
example, type :smiling: and AutoCorrect will replace it with ☺. Or, (c) will be changed 
to ©. You can add your own special characters.

Using Word Completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect > AutoCorrect Options > Word 
Completion and deselect Enable word completion.

Figure 15: Word completion tab in AutoCorrect dialog

Options for customizing word completion from the Word Completion page of the AutoCorrect dialog
include:

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the text 
as you type.

• As you add words when working on documents, you can either save them for later use in 
other documents or select the option to remove them from the list when closing documents.

• Change the maximum number of words remembered for word completion and the length of 
the smallest words to be remembered.
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• Delete specific entries from the word completion list.

• Change the key that accepts a suggested entry—the options are right arrow, End key, 
Return (Enter), Space bar, and Tab.

Note

Automatic word completion only occurs after you type a word for the second time in a 
document.

Using AutoText
Use AutoText to store text, tables, fields, and other items for reuse and assign them to a key 
combination for easy retrieval. For example, rather than typing “Senior Management” every time 
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” 
and press F3.

To store some text as AutoText:

 1) Type the text into your document.

 2) Select the text.

 3) Choose Tools > AutoText (or press Ctrl+F3).

 4) In the AutoText dialog, type a name for the AutoText in the Name box. Writer will suggest a 
one-letter shortcut, which you can change.

 5) Choose the category for the AutoText entry, for example My AutoText.

 6) Click the AutoText button at the bottom of the dialog and select from the menu either New, 
to have the AutoText retain specific formatting, no matter where it is inserted, or New (text 
only), to have the AutoText take on the existing formatting around the insertion point.

 7) Click Close to return to your document.

 8) To insert AutoText, type the shortcut and press F3.

Tip

If the only option under the AutoText button is Import, either you have not entered a 
name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See the Writer Guide for more information.

Formatting text

There are two basic ways to format text. Understanding these two alternatives is essential for 
unlocking the power of LibreOffice:

Direct (or Manual) formatting

Applies formatting directly to specific paragraphs, characters, pages, frames, lists, or tables. 
For example, you can select a word, then click on a button on the Formatting toolbar to 
format the text as bold or italics.

Styles 

Bundles formatting options under one name. For example, a paragraph style defines 
numerous settings for options such as font type and size, whether paragraphs should be 
indented, the space between lines, how paragraphs should be aligned on the page, and 
many others.  
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Using styles is highly recommended
Writer is designed to be a style-based program. This means that it may work somewhat differently 
from other word processing programs you are familiar with. It requires some planning but the time 
spent in planning can save time and frustration over the longer term.

Because styles apply whole groups of formats at the same time, they enable you to easily format a 
document consistently and to change the formatting of an entire document with minimal effort. In 
addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For
example, Writer relies on heading styles (or other styles you specify) when it compiles a table of 
contents.

Writer defines six types of styles:  paragraph, character, page, frame, list, and table. See Chapter 
3, Using Styles and Templates, in this book and also refer to the Writer Guide.

Formatting paragraphs using styles
Styles can be applied to paragraphs using the Styles drop-down selection list at the left end of the 
Format toolbar, by using the Styles deck of the Sidebar and by using the Styles menu in the Menu 
Bar.

Tip

You can use keyboard shortcuts Ctrl+1 to Ctrl+5 to apply paragraph styles Heading 1 
to Heading 5.

There is also an option to open a styles toolbar under the View Menu > Toolbars > Formatting 
(Styles)  (Figure 16).

Figure 16: Formatting (Styles) toolbar

Tip

For important information about using paragraph styles to format documents, see 
Chapter 3 of this book and the Writer Guide.

Formatting paragraphs directly
You can manually apply many direct formats to paragraphs using the buttons on the Formatting 
toolbar and by using the Paragraph panel of the Sidebar’s Properties deck. Not all buttons are 
visible in a standard installation, but you can customize the toolbar to include those you use 
regularly. These buttons and formats include:

• Set Paragraph Style

• Bullets On/Off (with a palette of bullet styles)

• Numbering On/Off (with a palette of numbering styles)

• Align Left, Center Horizontally, Align Right, or Justified

• Align Top, Center Vertically, Align Bottom

• Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing

• Increase Paragraph Spacing, Decrease Paragraph Spacing

• Increase Indent, Decrease Indent

• Paragraph (to open the Paragraph dialog)
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Note

Direct formatting (also called manual formatting) overrides styles. This means that 
when a new style is applied, direct formatting is not removed and still determines the 
displayed format. 

Removing direct formatting
To remove direct formatting, select the text and choose Format > Clear Direct Formatting from 
the Menu bar, or right-click and choose Styles > Clear Direct Formatting from the context menu, 
or click the Clear Direct Formatting button on the Formatting toolbar, or press Ctrl+M on the 
keyboard.

Note

When clearing direct formatting, the text formatting will return to the applied paragraph 
and character style and not the Default paragraph style or Default character style 
(unless these styles are actually applied to the text).

Formatting characters using styles
To apply a character style, highlight the characters or words and apply the selected character style 
from the Styles menu on the Main Menu bar, from the Character Styles tab of the Sidebar Styles  
deck, or from the right-click context menu.

Formatting characters directly
It is recommended that you use styles to format characters as much as possible rather than 
formatting characters directly, as described in this section. 

You can directly apply many formats to characters using the buttons on the Formatting toolbar and 
by using the Character panel of the Sidebar’s Properties deck. Not all buttons are visible in a 
standard installation, but you can customize the toolbar to include those you use regularly. These 
buttons and formats include:

• Font Name, Font Size

• Bold, Italic, Underline, Overline, Double Underline, Strikethrough, Outline

• Superscript, Subscript

• Uppercase, Lowercase

• Increase Font Size, Decrease Font Size

• Font Color (with a palette of colors)

• Background Color (with a palette of colors)

• Highlighting (with a palette of colors)

Note

Just as direct paragraph formatting overrides the current paragraph style, applying 
direct character formatting to characters overrides the current character style 
formatting.

Formatting tables
Tables in a Writer document share the same sets of formatting elements as the spreadsheets in 
LibreOffice Calc.
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To apply table styles, place your cursor in the table to be formatted and choose Table > 
Autoformat Styles in the main menu and select a style from the dialog that appears.  Or, 
alternatively, place your cursor in the table to be formatted and double click on a style listed in the 
Table Styles tab of the sidebar Styles deck.  For more information refer to the LibreOffice Writer 
Guide.

AutoCorrection
You can set Writer to format or correct parts of a document automatically as you type, according to 
the choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect > 
AutoCorrect Options).

 Some common unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs 
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide 
as the column in the page. Note that the line is actually the lower border of the preceding 
paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), 
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list
is created when you type a number followed by a period (.), followed by a space or tab at 
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted
with the Default, Text body or Text body indent paragraph styles.

Tip

If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause. In most cases Undo (Ctrl+Z) fixes the issue.

To turn AutoCorrect on or off, choose Format > AutoCorrect and select or deselect the items on 
the list. The Help describes each of these choices.

Creating lists with styles

Creating bulleted and numbered lists
Whenever possible, use paragraph styles for creating bulleted and numbered lists.  Writer comes 
with two sets of paragraph styles for this purpose. However, these styles do not include options for 
settings such as the type of bullet or position of numbers. Those settings come from list styles, 
which are a different type of style than paragraph styles.  It is recommended to use them together 
in these ways:

• Use paragraph styles List 1, List  2, List 3, etc. for creating bulleted lists. These styles use 
list styles List 1, List 2, List 3, etc. 

• Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating numbered 
lists. These styles use the list styles called Numbering 1, Numbering 2, etc. 

To associate one of these paragraph styles to a list style, go to Styles < Manage Styles or click 
F11 to open the list of styles. Right click on the paragraph style you want to use, then Modify < 
Outline & Numbering. In the Numbering drop-down list, choose the appropriate list style.

Paragraph styles such as List 1 Start and List 1 End enable you to adjust specific properties (such 
as the space between paragraphs) for items at the beginning or end of the list.

Note

List styles are not meant to be used on their own. Rather, they are designed to be  
attached to paragraph styles.
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Creating nested lists
With paragraph styles, you can easily create nested lists, in which where list items have subpoints 
under them, as in an outline.  This requires specifying the settings for the additional levels.  To do 
this,  right click on the list style (not the paragraph style) and specify how each layer will be labeled,
using the Numbering Style page. Also specify the position and spacing for each level on the 
Position page. Refer to the Writer Guide for details.

Once you have set up nested lists, you can readily change the hierarchy of an item. To demote an 
item one level, position the cursor at the beginning of the line (after the bullet or number) and press
Tab. To promote an item one level, press Shift + Tab.

Creating lists with direct formatting

Creating bulleted and numbered lists
Bullets and numbers can be manually applied in three basic ways:

• Use AutoCorrect to autoformat text, as described above. 

• Use the Bullets and Numbering buttons on the Formatting bar 

• Use the Paragraph panel of the Sidebar’s Properties deck

Bullets and numbering can be applied to already selected text or they can be applied as you type. 

Tip

Bullets and numbering applied in these ways cannot be removed with the command 
“clear direct formatting” on the Format menu or by using Ctrl + M.  Rather, they are 
turned off or removed from selected text by toggling the Bullets and Numbering 
buttons on the Formatting bar or on the Sidebar’s Properties deck.  

Creating nested lists
Use the buttons on the Bullets and Numbering toolbar (Figure 17) to move items up or down the 
list, create sub-points, change the style of bullets, and access the Bullets and Numbering dialog, 
which contains more detailed controls. Use View > Toolbars > Bullets and Numbering to see the
toolbar.

Note

If numbering or bullets are being applied automatically in a way that you find 
inappropriate, you can switch them off temporarily by unchecking Format > 
AutoCorrect > While Typing.

1 Promote One Level 5 Insert Unnumbered 
Entry

8 Move Up with Subpoints

2 Demote One Level 9 Move Down with Subpoints

3 Promote One Level with
Subpoints

6 Move Up 10 Restart Numbering

4 Demote One Level with 
Subpoints

7 Move Down 11 Bullets and Numbering dialog

Figure 17: Bullets and Numbering toolbar
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The Bullets and Numbering buttons on the Sidebar’s Properties deck can also be used to create 
nested lists.  Click the down arrow next to the Bulleted List or Numbered List button, then More 
Bullets/Numbering to access the Bullets and Numbering dialog. However, the Sidebar does not 
include tools for promoting and demoting items in the list, as found on the Bullets and Numbering 
toolbar.

Setting tab stops and indents
The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the 
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and 
Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph 
(by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other 
people. If you use the default tab spacing and then send the document to someone else who has 
chosen a different default tab spacing, tabbed material will change to use the other person’s 
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of 
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of 
the Paragraph dialog. You can also double-click anywhere between the left and right indent icons 
on the ruler to open the Tabs page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. This is done on the Tab page of the 
Paragraph Style dialog. Press F11, then right click on the style to open the dialog. See the Writer 
Guide for more information.

Tip

Using tabs to space out material on a page is not recommended. Depending on what 
you are trying to accomplish, a table or frame might be a better choice.

Changing the default tab stop interval

Caution

Any changes to the default tab setting will affect the existing default tab stops in any 
document you open afterward, as well as tab stops you insert after making the 
change.

To set the spacing of default tab stop intervals, go to Tools > Options > LibreOffice Writer > 
General.

Figure 18: Selecting a default tab stop interval

Changing measurement units for tab stops and rulers
Change the measurement unit for rulers in the current document by right-clicking on the ruler to 
open a list of units. Click on one of them to change the ruler to that unit. The selected setting 
applies only to that ruler.
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Figure 19: Changing the measurement 
unit for a ruler

Hyphenating words
Hyphenate words at the end of a line in two ways: let Writer do it automatically (using its 
hyphenation dictionaries), or insert conditional hyphens manually for specific words.

Automatic hyphenation using styles
To turn automatic hyphenation of words on or off:

 1) Click on the Styles tab in the Sidebar to open the Styles deck.

 2) On the Paragraph Styles page (Figure 20), right-click on Default Style (or another style you
want to use) and select Modify.

 3) On the Paragraph Style dialog (Figure 21), go to the Text Flow page.

 4) Under Hyphenation, select or deselect the Automatically option. When automatic 
hyphenation is on, you can also set the criteria for when it should occur. Click OK to save.

Figure 20: Modifying a style

Note

Turning on hyphenation for the paragraph Default Style affects all other paragraph 
styles that are based on Default Style. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be hyphenated.

Any styles not based on Default Style are not affected. See Chapter 3, Using Styles 
and Templates, for more about styles based on styles other than Default Style.
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Figure 21: Turning on automatic hyphenation

Setting Hyphenation with Writing Aids
You can also set hyphenation choices through Tools > Options > Language Settings > Writing 
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Figure 22: Setting hyphenation options

To change the minimum number of characters for hyphenation, or the minimum number of 
characters before or after a line break, select the item, and then click the Edit button in the Options
section.

Note

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is 
turned on through paragraph styles.

Manual hyphenation
Manually hyphenate words when you want only a specific word hyphenated at the end of a line.  
Do not use a normal hyphen, which will remain visible even if the word is no longer at the end of a 
line (when you add or delete text or change margins or font size). Instead, use a conditional 
hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear (when 
needed) and press Ctrl+hyphen or use Insert > Formatting Mark > Soft hyphen. When the word 
is at the end of the line it will be hyphenated at this position, even if automatic hyphenation for this 
paragraph is switched off.

Formatting pages

Every page in Writer is based on a page style. Pages styles define basic layout, including page 
size, margins, headers and footers, borders, backgrounds, etc.  Changes to these settings 
automatically change the page style. This means that, in contrast to paragraph styles, these 
settings cannot be used to directly format individual pages. 

As with other styles, Writer comes with a number of page styles. You can modify these styles  or 
create new ones. The Default page style is used when no other page style has been specified. 
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In addition to  page styles, several features enable you to further control page layouts, including 
columns, frames, tables, and sections. For more information, see the Writer Guide.

Tip

Page layout is usually easier if you show text, object, table, and section boundaries in 
Tools > Options > LibreOffice > Application Colors, and paragraph ends, tabs, 
breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Creating headers and footers
A header is an area that appears at the top of a page above the margin. A footer appears at the 
bottom of the page below the margin. Information such as page number is inserted into the header 
or footer of a page style. That information is then displayed on every page with the same page 
style (unless the page style enables separate settings for the first page or for left and right pages).

Inserting a header or footer 
You can insert a header in several ways.  Here is the easiest:

• Click above the top margin (or below the bottom margin) to make the Header or Footer 
marker appear (Figure 23), and then click on the +. 

Figure 23: Header marker at top of text area

After a header/footer has been created, a down-arrow appears on the marker. Click on this arrow 
to drop down a menu of choices for working with the header (Figure 24).

Figure 24: Header menu

Alternatively, you can choose Insert > Header and Footer > Header > Default Style (or some 
other page style, if not Default Style).

Determining header and footer appearance
To format a header (use similar settings for a footer), you can either click on Format Header in the 
menu shown in Figure 24 or go to Format > Page > Header. Both methods take you to the same 
tab on the Page Style dialog.

Here you can specify if headings on the left and right pages should be the same or different. You 
can also specify whether the first page will have no header or a different header than other pages. 
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In this dialog, you can also turn the header on or off, set the margins, and set the spacing between 
the header and document text.

Figure 25: Page header dialog

Inserting document title in headers and footers
Information such as a document title is often put into the header or footer. These items are best 
added as fields. That way, if something (such as the name) changes, the headers and footers are 
updated automatically. Here is one common way to use fields to insert the document title into the 
header:

 1) Choose File > Properties > Description and type a title for your document.

 2) Add a header with Insert > Header and Footer > Header > Default Style (or appropriate 
page style).

 3) Place the cursor in the header area at the top of the page. If needed, click on the + to be 
able to click in the header.

 4) Choose Insert > Fields > Title. The title should appear on a gray background. The 
background does not show when printed and can be turned off in Tools > Options > 
LibreOffice > Application Colors.

 5) To change the title for the whole document, go back to File > Properties > Description.

For more about headers, footers, and fields, see the Writer Guide.

Numbering pages

Displaying the page number
To display page numbers automatically:

 1) Insert a header or footer, as described in “Creating headers and footers” above.

 2) Place the cursor in the header or footer where you want the page number to appear and 
choose Insert > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):

 1) Type the word “page” and a space, then insert the page number as above.

 2) Press the space bar once, type the word “of” and a space, then choose Insert > Field > 
Page Count.
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Note

The Page Count field inserts the total number of pages in the document, as shown on 
the Statistics tab of the document’s Properties window (File > Properties). If you 
restart page numbering anywhere in the document, then the total page count may not 
be what you want. See the Writer Guide for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title 
page or a table of contents. In addition, many documents have the “front matter” (such as the table 
of contents) numbered with Roman numerals and the main body of the document numbered in 
Arabic numerals, starting with 1. To restart page numbering:

Place the cursor in the first paragraph of the new page.

 1) Choose Format > Paragraph.

 2) On the Text Flow tab of the Paragraph dialog (Figure 21 on page 30), select Breaks.

 3) Select Insert and then With Page Style and specify the page style to use.

 4) Specify the page number to start from, and then click OK.

Tip

This is also useful for numbering the first page of a document with a page number 
greater than 1. For example, you may be writing a book, with each chapter in a 
separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25
and Chapter 3 with page 51.

Changing page margins
You can change page margins in three ways:

• Using the page rulers—quick and easy, but does not allow fine control

• Using the Page Style dialog—can specify margins to two decimal places

• Using the Page deck of the Sidebar

Caution

When you change the margins, the page style is also changed and the changed 
margins apply to all pages using that style.

To change margins using the rulers:

 1) The gray sections of the rulers are the margins. Put the mouse cursor over the line between
the gray and white sections. The pointer turns into a double-headed arrow and displays the 
current setting in a tool-tip.

 2) Hold down the left mouse button and drag the mouse to move the margin.

Caution

The two small gray triangles on the ruler are used for indenting paragraphs. The 
double-headed arrows shown in Figure 26 are mouse cursors shown in the correct 
position for moving the margin markers. Because the triangles and arrows are often in 
the same place, when changing page margins you need to be careful to move the 
arrows, not the gray triangles. 
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Figure 26: Moving the margins

To change margins using the Page Style dialog:

 1) Right-click anywhere in the text area on the page and select Page from the context menu.

 2) On the Page tab of the dialog, type the required distances in the Margins boxes.

To change margins using the Page deck of the Sidebar:

 1) On the Sidebar (View > Sidebar) open the Page tab.

 2) In the Format panel, use the Margins drop-down list to select the desired margins. Click the
More Options button to open the Page Style dialog where you can enter exact margin 
distances. 

Adding a custom watermark to the page background
To add a watermark to a page background:

 1) Choose Format > Watermark.

 2) In the Watermark dialog, type the text and select the font, angle, transparency and color of 
the watermark. Then click the OK button.

Figure 27: The Watermark dialog

Note

The watermark will automatically become part of the page style where it is inserted 
and all other pages of the same style will have the watermark. Pages with different or 
no watermarks need different Page Styles for those pages.
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Adding comments to a document

Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark items 
needing attention.

You can connect a comment to multiple paragraphs or a single point. To insert a comment, select 
the text, or place the cursor in the place the comment refers to, and choose Insert > Comment or 
press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted line to a box on the 
right-hand side of the page where you can type the text of the comment. A Comments button is 
also added to the right of the horizontal ruler at the top of the page; you can click this button to 
toggle the display of the comments.

Formatting comments
At the bottom of the comment, Writer automatically adds the author’s name and a time stamp 
indicating when the comment was created. If more than one person edits the document, each 
author is automatically allocated a different background color. Figure 28 shows an example of text 
with comments from two different authors.

Figure 28: Example of comments

Choose Tools > Options > LibreOffice > User Data to configure the name you want to appear in 
the Author field of the comment, or to change it.

Right-click on a comment to open a context menu where you can delete the current comment, all 
the comments from the same author, or all the comments in the document. From this menu, you 
can also reply to a comment and open a dialog to apply some basic formatting to the text.

Navigating through comments
To navigate from one comment to another, open the Navigator (F5), expand the Comments 
section, and click on the comment text to move the cursor to the anchor point of the comment in 
the document. Click the comment directly to edit it and right-click on the comment to delete it.

You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to 
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Printing comments
When a document contains comments, the print dialog has an option for comments to be printed 
next to the text in the right margin, as they appear on the screen. In that case, the text on each 
page is scaled down to make space for the comments. The Print dialog also has options for placing
comments at the end of the page or at the end of the document, or for printing only the comments.
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Creating a table of contents

Writer can generate a table of contents from the headings in your document. Before you start, 
make sure that the headings are styled consistently. For example, you can use the Heading 1 style
for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are 
all you need. Creating a quick table of contents is simple:

 1) When you create your document, use the following paragraph styles for hierarchical 
heading levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, 
and so on. These headings are what will appear in your table of contents.

 2) Place the cursor where you want the table of contents to appear.

 3) Choose Insert > Table of Contents and Index > Table of Contents, Index or 
Bibliography.

 4) Change nothing in the Insert Index/Table dialog (unless you want to change the number of 
levels shown). Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change 
headings, you need to update the table of contents.

To do this:

 1) Place the cursor within the table of contents.

 2) Right-click and choose Update index from the context menu.

Note

If you cannot place the cursor in the table of contents, choose Tools > Options > 
LibreOffice Writer > Formatting Aids, and then select Enable Cursor in the 
Protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose 
Edit Index from the context menu. The Writer Guide describes in detail all the customizations you 
can choose.

Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. In addition to alphabetical 
indexes, other types of indexes supplied with Writer include those for illustrations, tables, and 
objects, and you can even create a user-defined index. 

For example, you might want an index containing only the scientific names of species mentioned in
the text, and a separate index containing only the common names of species. Before creating 
some types of indexes, you first need to create index entries in your Writer document. The Writer 
Guide describes the process in detail.

Working with graphics

Graphics in Writer are of three basic types:

• Image files, including photos, drawings, scanned images, and others

• Diagrams created using LibreOffice’s drawing tools

• Charts created using LibreOffice’s Chart component

See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and the Writer Guide.

36 | Working with graphics



Printing

See Chapter 10, Printing, Exporting, and Emailing, in this book and the Writer Guide for details on 
previewing pages before printing, selecting print options, printing in black and white on a color 
printer, printing brochures, and other printing features.

Using mail merge

Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)

• Mailing labels

• Envelopes

All these features use data from a Writer table or another registered data source (a spreadsheet or 
database containing name and address records or other information). The Writer Guide describes 
the merge processes.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

 1) Make your changes to a copy of the document (stored in a different folder, or under a 
different name, or both), then use Writer to combine the two files and show the differences. 
Choose Edit > Track Changes > Compare Document.

 2) Save versions that are stored as part of the original file. However, this method can cause 
problems with documents of non-trivial size or complexity, especially if you save a lot of 
versions. Avoid this method if you can.

 3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you 
have added or deleted material, or changed formatting. Choose Edit > Track Changes > 
Record Changes before starting to edit. Later, you or another person can review and 
accept or reject each change. Choose Edit > Track Changes > Show Changes. Right-
click on an individual change and choose Accept Change or Reject Change from the 
context menu, or choose Edit > Track Changes > Manage Changes to view the list of 
changes and accept or reject them. Details are in the Writer Guide.

Tip

Not all changes are recorded. For example, changing a tab stop from align left to align 
right, and changes in formulas (equations) or linked graphics are not recorded.

Caution

A document with track changes activated but with the changes not shown carries an 
invisible history of document editing that the current user may not be aware of. 
Contents deleted or modified can be recovered. While this is a feature, it is also a 
potential privacy risk.
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Using fields

Fields are extremely useful features of Writer. They are used for data that changes (such as the 
current date or the total number of pages) and for inserting document properties such as name, 
author, and date of last update. Fields are the basis of cross-referencing (see below); automatic 
numbering of figures, tables, headings, and other elements; and a wide range of other functions—
far too many to describe here. See the Writer Guide for details.

Linking and cross-referencing within a document

If you manually type in cross-references to other parts of a document, those references can easily 
get out of date if you reorganize the order of topics, add or remove material, or reword a heading. 
Writer provides two ways to ensure that your references are up to date: hyperlinks and cross-
references.

Both methods insert links to other parts of the same document or to an external source, taking you 
directly to the cross-referenced item. However, they have major differences:

• The text in a hyperlink does not automatically update if you change the text of the linked 
item (although you can change it manually), but changed text does automatically update in 
a cross-reference.

• When using a hyperlink, you do not have a choice about the type of content linked to (such 
as text or page number), but when using a cross-reference, you have several choices, 
including bookmarks.

• To hyperlink to an object such as a graphic, and have the hyperlink show useful text such 
as Figure 6, you need to give such an object a useful name (instead of a default name like 
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

• If you save a Writer document to HTML, hyperlinks remain active but cross-references do 
not. Both remain active when the document is exported to PDF.

Using hyperlinks
See Chapter 12, Creating Web Pages, for details on creating hyperlinks within a document and to 
other documents and websites.

Creating and using cross-references
After a cross-reference has been created, use F9 to update all references so that the current 
wording or page numbers are displayed. The Cross-references tab of the Fields dialog lists some 
items, such as headings, bookmarks, figures, tables, or numbered items such as steps in a 
procedure. You can also create your own reference items; see “Setting References” in the Writer 
Guide for instructions.

To insert a cross-reference:

 1) In your document, place the cursor where you want the cross-reference to appear.

 2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references 
tab (Figure 29), in the Type list, select the type of item to be referenced (for example, 
Headings or Figure). You can leave this page open while you insert many cross-references.

 3) Click on the required item in the Selection list, which shows all the items of the selected 
type. You can type some characters in the top box under Selection to filter the list in the 
selection box.
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 4) In the Insert reference to list, select the option needed. The options determine the text 
inserted for the hyperlink and how it is formatted. The list varies according to the Type 
chosen. The most commonly used options are Reference (to insert the full text of a 
heading or caption), Category and Number (to insert a figure number preceded by the 
word Figure or Table, but without the caption text), Numbering (to insert only the figure or 
table number, without the word “Figure” or “Table”), or Page (to insert the number of the 
page the referenced text is on). Click Insert.

Figure 29: The Cross-references tab of the Fields dialog 

Using bookmarks
Use bookmarks to rapidly navigate or link to specific locations in a document. They are listed in the
Navigator and can be accessed directly from there with a single mouse click. You can cross-
reference to bookmarks and create hyperlinks to bookmarks, as described above. To create a 
bookmark:

 1) Select the text you want to bookmark. Click Insert > Bookmark.

 2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type
a name for this new bookmark in the top box, and then click Insert.
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Using master documents

A master document joins separate text documents into one larger document, and unifies the 
formatting, table of contents, bibliography, index, and other tables or lists. Master documents are 
typically used for producing long documents such as a book, thesis, or long report. They are 
especially handy when different people are writing different sections of a document, eliminating the
need to continually share the full document. For details on using master documents, see the Writer
Guide.

You can add master document templates to LibreOffice in the same way as ordinary document 
templates. Creating a new document based on a master document template creates a master 
document with the same initial content as the template it is based upon. See Chapter 3, Styles and
Templates, for more about creating and using templates.

Classifying document contents

Document classification and security are important for businesses and governments. Where 
sensitive information is exchanged between users and organizations, the parties agree how such 
information will be identified and handled. LibreOffice provides standardized means for sensitive 
information to be identified and protected, using a set of standard fields that can be used to hold 
sensitive information.

LibreOffice implemented the open standards produced by TSCP (Transglobal Secure Collaboration
Participation, Inc.). It contains three BAF (Business Authentication Framework) categories: 
Intellectual Property, National Security and Export Control. Each category has four BAILS 
(Business Authorization Identification and Labeling Scheme) levels: Non-Business, General 
Business, Confidential, and Internal Only.

To enable document classification, open the TSCP bar (View > Toolbars > TSCP). This toolbar 
contains list boxes to help in selecting the security of the document. LibreOffice then adds custom 
fields in the document properties (File > Properties, Custom fields tab) to store the classification 
policy as document metadata.

To prevent a breach in security policy, contents with a higher classification level cannot be pasted 
into documents with a lower classification level. 

For more information, refer to the Writer Guide.

Creating fill-in forms

In a standard text document, such as a report, any text can be edited. By contrast, a form has 
sections that are not to be edited, and other sections that are designed for the reader to fill in 
information. For example, a questionnaire has an introduction and questions (which do not change)
and spaces for the reader to enter answers.

Forms are used in three ways:

• To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

• To enter information directly into a database or data source. Someone taking orders might 
enter the information for each order into a database using a form.

• To view information held in a database or data source. A librarian might call up information 
about books.

Writer offers several ways to organize information fields in a form, including check boxes, option 
buttons, text boxes, pull-down lists, and spinners. Options for creating forms are available in the 
Forms menu of the Standard toolbar. See the Writer Guide for more information.
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