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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer setup

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Grouping objects
Grouping of objects is similar to putting objects into a container. You can move the objects as a
group and apply global changes to the objects within the group. A group can always be undone
and the objects that make up the group can always be manipulated separately.

Temporary grouping
A temporary grouping is when several objects are selected. Any changes to object parameters that
you carry out are applied to all of the objects within the temporary group. For example, you can
rotate a temporary group of objects in its entirety.
To cancel a temporary grouping of objects simply click outside of the selection handles displayed
around the objects.

Grouping
To group objects together permanently, first select the objects by clicking on each object in turn
while holding down the Shift key. You can also use the Select icon
on the Drawing toolbar and
draw a selection rectangle around the objects using the mouse cursor. Selection handles will then
appear around all the objects within the group (Figure 1).

Figure 1: Grouping objects
Right-click on the group and select Group from the context menu. You can also select Modify >
Group from the main menu bar or use the keyboard shortcut Control+Shift+G.
When objects are grouped, any editing operations carried out on that group are applied to all
objects within the group. If you click on one object in the group, the whole group is selected.
The objects within a group also retain their own individual properties and can be edited
independently. See “Editing individual objects” on page 4 for more information.

Ungrouping
To undo or ungroup a group of objects, right-click on the group and select Ungroup from the
context menu. You can also select Modify > Ungroup from the main menu bar or use the
keyboard shortcut Control+Alt+Shift+G.

Editing individual objects
You can individually edit an object within a group without ungrouping the group. To do this, rightclick on the group and select Enter group, or press the F3 key, or double-click on the group. When
you enter a group, objects outside the group cannot be selected for editing and appear pale
(Figure 2).
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Figure 2: Entering groups
Once inside the group, click on any object to individually edit it (Figure 3).

Figure 3: Editing inside a group
To leave a group, right-click on the group and select Exit group, or press Ctrl+F3 key, or doubleclick outside the group.

Nesting groups
You can create a group of groups, which is more commonly known as nesting groups. When you
create nested groups, Draw retains the individual group hierarchy and remembers the order in
which groups were selected. That is, the last individual group selected will be on top of all the other
groups within a nested group.
Ungrouping and entering a nested group works in exactly the same way as for individual groups.

Combining objects
Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.

Combining
Select the objects you want to combine, then right-click on the selection and select Combine from
the context menu. You can also select Modify > Combine from the main menu bar or use the
keyboard shortcut Control+Alt+Shift+K. At first glance, the results can seem rather surprising, but
once you understand the rules governing combination in Draw, combining objects will become
clearer.

• The attributes (for example, area fill) of the resulting object are those of the object furthest
back. In Figure 4, it is the circle.

• Where the objects overlap, the overlapping zone is either filled or empty depending on the
number of overlaps. When the number of overlaps is even, you get an empty space; when
the number is odd, you get a filled area. An example of this is shown in Figure 5.

Combining objects
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Figure 4: Combining objects

Figure 5: Area fill on overlapping objects

Tip

You can reorder objects so they are further back or further forward in the
arrangement order. Right-click on the object and select Arrangement from the
context menu. See also “Positioning objects” on page 12.

Splitting a combination
An object which is a combination of several objects can be split into individual entities by selecting
Modify > Split from the main menu bar or using the keyboard shortcut Control+Alt+Shift+K. The
original objects will retain the formatting of the combined object and will not revert back to their
original formatting (Figure 6).

Figure 6: Splitting a combined object
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Breaking a combination
An object which is a combination of several objects can be broken into its constituent parts by
selecting Modify > Break from the main menu bar. The original objects are broken into their
constituent parts; for example, a rectangle will be broken into four separate lines and the area fill
will be lost (Figure 7).

Figure 7: Breaking a combined object

Connecting lines
The constituent parts of an object can be connected together by selecting all the constituent parts
of the object and selecting Modify > Connect on the main menu bar. This connects the parts
together and closes the object resulting in the area becoming filled in the same way as before the
object was broken.

Merging, subtracting, or intersecting objects
After you have selected more than one object, the Merge, Subtract, and Intersect functions
become available, allowing you to create a new object with a new shape. After selecting several
objects, go to Modify > Shapes on the main menu bar or right-click and select Shapes from the
context menu.

Merge
When you merge objects, a new object is created with a shape that follows the shape of the
merged objects. The area fill of the merged object is determined by the area fill of the object that is
at the rear of all the other objects (Figure 8).

Figure 8: Merging objects

Merging, subtracting, or intersecting objects
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Subtract
When you subtract objects, the front object is subtracted from the objects behind. This leaves a
blank space that the subtracted object occupied (Figure 9).

Figure 9: Subtracting objects

Intersect
When you intersect objects, the front objects and the exposed area of the object at the rear are
removed. This creates a new object from the area of the object at the rear that was covered by the
objects at the front (Figure 10).

Figure 10: Intersecting objects

Practical example
The following example in Table 1 shows how you can use the merge, subtract and intersect
functions to create a knife with a wooden handle.
Table 1: Creating a knife
Draw an ellipse and then a rectangle overlapping half
of its width.

Select both shapes, right-click, and select Shapes >
Subtract from the context menu.

Draw another rectangle and put it over the top half of
the ellipse.
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Select both shapes, right-click, and select Shapes >
Subtract from the context menu.
Draw a small ellipse covering just the lower right
corner.
Select both shapes, right-click, and select Shapes >
Subtract from the context menu. The knife blade
shape is now complete.
To make the handle, draw a rectangle and an ellipse.
Merge the shapes together.
Position the handle on the blade. Select the handle
and blade, then group together to create a drawing of
the knife.

Duplication and cross fading
Duplication
Duplication makes copies of an object while applying a set of changes (such as color or rotation) to
the duplicates. The Duplicate dialog (Figure 11) has the following options:

• Number of copies – enter the number of copies you want to make.
Placement – sets the position and rotation of a duplicate object with respect to the selected object.

–

X axis-- enter the horizontal distance between the centers of the selected object and
the duplicate object. Positive values shift the duplicate object to the right and negative
values shift the duplicate object to the left.

Figure 11: Duplicate dialog

Duplication and cross fading
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–

Y axis – enter the vertical distance between the centers of the selected object and the
duplicate object. Positive values shift the duplicate object down and negative values
shift the duplicate object up.

–

Angle – enter the angle (0 to 359 degrees) by which you want to rotate the duplicate
object. Positive values rotate the duplicate object in a clockwise direction and negative
values in a counterclockwise direction.

• Enlargement – sets the size of a duplicate object.
– Width – enter the amount by which you want to enlarge or reduce the width of the
duplicate object.

–

Height – enter the amount by which you want to enlarge or reduce the height of the
duplicate object.

• Colors – sets the colors for the selected object and the duplicate object. If you make more
than one copy, these colors define the start and end points of a color gradient.

–
–

Start – choose a color for the selected object.
End – choose a color for the duplicate object. If you are making more than one copy,
this color is applied to the last copy.

To duplicate an object or group of objects:
1) Select an object or group of objects.
2) Go to Edit > Duplicate or use the keyboard shortcut Shift+F3 to open the Duplicate dialog
(Figure 11).
3) Select the number of copies, placement, enlargement, and the start and end colors for your
duplicate copies.
4) Click OK and your duplicate copies are created. An example of a duplication is shown in
Figure 12. Each duplicate object is a separate object.
5) To group the duplicate objects into one group, see “Grouping objects” on page 4.
6) To combine the duplicate objects into one object, see “Combining objects” on page 5.

Figure 12: Duplication example
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Figure 13: Cross-fading dialog

Figure 14: Cross-fading example

Cross fading
Cross-fading transforms one object shape into another object shape. The result is a new group of
individual objects that includes the start and end objects with the intermediate steps show the
transformation from one object shape to another object shape.
The options available in the Cross-fading dialog (Figure 13) are:

• Increments – enter the number of shapes you want between the two selected objects.
• Cross-fade attributes – applies cross-fading to the line and fill properties of the selected
objects. For example, if the selected objects are filled with different colors, a color transition
between the two colors is applied.

• Same orientation – applies a smooth transition between the selected objects.
To cross-fade two objects:
1) Select two objects and go to Edit > Cross-fading on the main menu bar to open .the
Cross-fading dialog (Figure 13).
2) Select the number of increments for the transformation.
3) If necessary, select Cross-fade attributes and Same orientation.
4) Click OK to perform the cross-fading. An example of cross-fading is shown in Figure 14.
The object created is a group of objects.
5) To ungroup this group of objects so that you can use the individual objects, see
“Ungrouping” on page 4.

Duplication and cross fading
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Arranging objects
When you combine, merge, subtract or intersect objects, the end result varies depending on which
object is at the front and which object is at the back. Each new object that you place on a drawing
automatically becomes the front object and all the other objects move backwards in the positioning
order. Arranging objects allows you to change the order in which objects are positioned.
First select one or more objects, then click on the Arrange icon
open the Position toolbar (Figure 16 and Figure 15).

•
•
•
•
•
•
•

on the Drawing toolbar to

Bring to Front – brings the selected object to the front of the group.
Bring Forward – brings the selected object forward one step.
Send Backward – sends the selected object one step backward.
Send to Back – sends the selected object to the back of the group.
In Front of Object – moves the selected object in front of another selected object.
Behind Object – moves the selected object behind another selected object.
Reverse – reverses the order of the selected objects. This tool is grayed out if only one
object is selected.

Figure 15: Position toolbar

Figure 16: Position tools

Aligning objects
To make your drawing look more professional, you can align objects with each other. Select one or
more objects and click on
Figure 18).

on the Drawing toolbar to open the Align toolbar (Figure 17 and

• Left – aligns the left edges of the selected objects. If only one object is selected, the left
edge of the object is aligned to the left page margin.

• Centered – horizontally centers the selected objects. If only one object is selected, the
center of the object is aligned to the horizontal center of the page.

• Right – aligns the right edges of the selected objects. If only one object is selected, the
right edge of the object is aligned to the right page margin.
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Figure 17: Align toolbar

Figure 18: Align tools

• Top – vertically aligns the top edges of the selected objects. If only one object is selected,
the top edge of the object is aligned to the upper page margin.

• Center – vertically centers the selected objects. If only one object is selected, the center of
the object is aligned to the vertical center of the page.

• Bottom – vertically aligns the bottom edges of the selected objects. If only one object is
selected, the bottom edge of the object is aligned to the lower page margin.

Distributing objects
Distributing objects allows you to space three or more objects evenly along the horizontal axis or
the vertical axis. Objects are distributed using the outermost objects in the selection as base points
for spacing.
Select at least three objects. To open the Distribution dialog (Figure 19), go to Modify >
Distribution on the main menu bar or right-click and select Distribution from the context menu.

Figure 19: Distribution of spacing between objects
Horizontal distribution specifies the horizontal distribution between the selected objects.

• None – does not distribute the objects horizontally.
• Left – distributes the selected objects so that the left edges of the objects are evenly
spaced from one another.

• Center – distributes the selected objects so that the horizontal centers of the objects are
evenly spaced from one another.

Positioning objects
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• Spacing – distributes the selected objects horizontally so that the objects are evenly
spaced from one another.

• Right – distributes the selected objects so that the right edges of the objects are evenly
spaced from one another.
Vertical distribution specifies the vertical distribution between the selected objects.

• None – does not distribute the objects vertically.
• Top – distributes the selected objects so that the top edges of the objects are evenly
spaced from one another.

• Center – distributes the selected objects so that the vertical centers of the objects are
evenly spaced from one another.

• Spacing – distributes the selected objects vertically so that the objects are evenly spaced
from one another.

• Bottom – distributes the selected objects so that the bottom edges of the objects are evenly
spaced from one another.
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