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Introduction to forms
This chapter covers the use of forms within Writer documents. Most of the information here also
applies to forms in other LibreOffice components, but there are some differences.
The chapter presents information on using forms in four main sections: setting up a basic form, an
example of creating a form, linking a form to a data source, and some advanced techniques.
LibreOffice forms cover a lot of features; not everything is included here. Notable omissions are
using forms in HTML documents and writing macros to link to form controls.

When to use forms
A standard text document displays information: a letter, report, or brochure, for example. Typically
the reader may edit everything or nothing in the document. A form has sections that are not to be
edited, and other sections that are designed for the reader to make changes. For example, a
questionnaire has an introduction and questions (which do not change) and spaces for the reader
to enter answers.
Writer provides several ways to enter information into a form, including check boxes, option
buttons, text boxes, pull-down lists, and other items, collectively known as form controls.
Forms are used in three ways:
•

To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

•

To link into a database or data source and allow the user to enter information. Someone in
a sales department might enter purchasers’ information into a database using a form.

•

To view information held in a database or data source. A librarian might call up information
about books.

Using forms to access a database offers a fast and easy way to build up complex graphical front
ends. Your form can include not only the fields that link up to the data source but also text,
graphics, tables, drawings and other elements.
A typical way to use a simple form is:
1)

You design the form, then save it.

2)

You send the form to others (for example, by email).

3)

They fill in the form, save it, and send it back to you.

4)

You open the form and see what their answers are.

Tip
By using a data source, or setting a form to update over the web, you can
automatically gather data. However, both of those methods are more complex and are
not covered in this book.

Alternatives to using forms in Writer
LibreOffice Base provides an alternative way to access a data source. There are a lot of similarities
between forms in Base and Writer, but one may be better for a particular task than the other. Base
is appropriate only if the form accesses a data source; you would not use it for simple forms.
LibreOffice Calc, Impress, and Draw also support forms in much the same way that Writer does.
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Creating a simple form
This section explains how to create a simple form without any links to a data source or database
and without advanced customization.

Create a document
There is nothing special to be done when creating a document to use as a form. Create a new
Writer document with File > New > Text document.

Open the form toolbars
Two toolbars control form creation: Form Controls and Form Design. Select View > Toolbars >
Form Controls and View > Toolbars > Form Design to show them both. The Form Controls
toolbar has an icon for each of the most commonly used types of control.
You can also open the Form Design toolbar from the Form Controls toolbar. Some of the less
commonly used controls are on a third toolbar—More Controls—also opened from the Form
Controls toolbar.
You can dock these toolbars in different places on the Writer window, or leave them floating. Figure
1 shows the three toolbars floating. When they are floating, you can also change them from vertical
to horizontal and change the number of tools on a row; to make these changes, drag a corner of
the toolbar.
See “Form controls reference” on page 7 for descriptions of the tools on these toolbars.

Figure 1: The Form Control, More Controls, and Form Design Toolbars

Activate design mode
Click the Design Mode On/Off icon on the Form Controls toolbar to turn design mode on. (Click it
again to turn it off.) This activates the icons for inserting form controls and selects controls for
editing.
When design mode is off, the form behaves as it would for the end user. Buttons can be pressed,
check boxes selected, list items selected, and so on.

Insert form controls
1)

To insert a form control into the document, click the control’s icon to select it. The mouse
pointer changes to look like this:

2)

Click in the document where you want the control to appear. (You can move it later.)

3)

Hold the left mouse button down and drag the control to size it. Some controls have a fixed
size symbol followed by the name of the control (for example, Check Box or Option Button).
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4)

The control icon remains active, so you can insert several controls of the same type without
needing to go back to the toolbar.

5)

To change to another tool, click its icon on the toolbar.

6)

To stop inserting controls, click the Select icon on the Form Controls toolbar, or click on any
of the controls you have just inserted. The mouse pointer changes back to its normal
appearance.

Tip
To make a form control square, hold down the Shift key when creating it. To keep the
proportions of an existing control the same, hold down Shift when resizing it.

Configure controls
After inserting the controls, you need to configure them to look and behave as you want. Right-click
on a form control within the document and select Control from the context menu to open the
Properties dialog for the selected control. Double-clicking on a form control also opens this dialog.
The Properties dialog has three pages: General, Data, and Events. For simple forms, only the
General page is needed. Use this page to set the look and feel of the control. See “Configure form
controls” on page 11 and “Form control formatting options” on page 20 for more information, and
the descriptions in the Help for details. Configuration for use with a database is discussed in
“Creating a form for data entry” on page 16.

Figure 2: Example of the Properties dialog for a form control
The fields on this dialog vary with the type of control.
To see additional fields, use the scroll bar or enlarge the dialog.

Use the form
To use the form, leave design mode by clicking the Design Mode On/Off icon to deactivate it.
Save the form document.
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Form controls reference
Form Control toolbar
Select

Selects a form control to perform some other action on it.

Design mode on/off

Toggles between design mode on (to edit forms) and design mode off
(to use forms).

Control

Launches form control properties dialog. This dialog can be kept open
as different controls are selected.

Form

Launches form properties dialog, controlling properties for the form as
a whole, such as which data source it connects to.

Check Box

A box that can be selected or deselected on the form. You can label
the box.

Text Box

A control to create a box into which the form’s user can type any text.

Formatted Field

A control allowing numeric formatting options. For example, you can
set maximum and minimum values for the number entered, or the
number type (decimal places, scientific, currency).

Push Button

Creates a button that can be linked to a macro. The label is the name
that appears on the button.

Option Button

Creates an option button (also known as a radio button). When
multiple buttons are grouped together, only one can be selected at a
time. The easiest way to group multiple buttons is to use the Group
Box icon on the More Controls toolbar, with wizards enabled.

List Box

Creates a list of options as a pull-down menu that the user can
choose from. If the form is linked to a data source and wizards are on,
creating a list box launches the List Box Wizard.
If the form is not linked to a data source, turn wizards off and create
an empty list box. Then in the List Entries field on the General tab,
enter the options you want to appear on the list.

Combo Box

As with a List Box, you set up a list of choices. In addition, a panel at
the top either displays the choice made or allows the form user to type
in something else. This works the same as the List Box.

Label Field

A text label. The difference between this and just typing on the page is
that, as a control, you can link a label field to macros so, for example,
something happens when the mouse passes over it or clicks on it.

More Controls

Launches the More Controls toolbar.

Form Design

Launches the Form Design toolbar, which can also be opened with
View > Toolbars > Form Design.

Wizards On/Off

Some form controls (List Box and Combo Box) have optional wizards.
If you do not want the wizard to launch when you create one of these
controls, use the Wizards On/Off icon to switch wizards off.
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More Controls toolbar

Spin Button

Allows form users to choose a number by cycling through the list of
numbers. You can specify maximum, minimum, default, and the step
between numbers.
This control is not commonly used in Writer.

Scrollbar

Creates a scrollbar, with a number of options to define the exact
appearance. This control is not commonly used in Writer.

Image Button

Behaves exactly like a push button, but displays as an image. Choose
the image in the Graphics option on the General tab in the Control
Properties dialog.

Image Control

Only useful when the form is connected to a data source and a field in
the data source exists that can hold images. You can add new images
to the database or retrieve and display images from it.

Date Field

Stores a date. You need to configure the earliest and latest dates the
field will accept, the default date, and the date format. You can add a
spinner.

Time Field

Works like a date field but specifies a time.

File Selection

Allows a user to select a file, either by typing the path and name
directly or by clicking on a Browse button and choosing the file from a
dialog.

Numeric Field

Displays a number. You need to specify formatting, maximum,
minimum and default values. You can add a spinner.

Currency Field

Works like a numeric field; additionally you can add a currency
symbol.

Pattern Field

Useful when the form links into a data source. Specify an Edit Mask to
restrict what a user can enter into the field. Specify a Literal Mask to
restrict which data is displayed from the data source.

Group Box

Group boxes have two different uses.
If wizards are on, creating a group box launches the Group Element
wizard. This creates a group of options buttons (in which only one
may be selected at a time). In most cases, using a group box is the
best way to create a set of option buttons.
If wizards are off, a group box is simply a visual box to group together
different controls. It has no effect on the way the controls operate.

Table Control

Table controls are only useful with a data source. If no data source is
specified, you will be prompted to choose one in the Table Element
Wizard. You then pick the fields to display and, when design mode is
off, the data appears in the table. The table also includes controls to
step through the records.
Records can be added, deleted, and modified in the table.

Navigation Bar

A navigation bar is the same as the Form Navigation toolbar (View >
Toolbars > Form Navigation), but can be placed anywhere in the
document and be resized.
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Form Design toolbar
Select

Selects a form control to perform an action on it.

Design mode on/off

Toggles between design mode on (to edit forms) and design mode off
(to use forms).

Control

Launches form control properties dialog. This dialog can be kept
open whiles different controls are selected.

Form

Launches form properties dialog, which controls properties for the
form as a whole, such as which data source it connects to.

Form Navigator

Displays all the forms and controls in the current document and
allows you to edit and delete them easily.
If you use the Form Navigator, give your controls names (in the
properties dialog) you can tell which is which in the navigator.

Add Field

Useful only if you have specified a data source for the form.
Otherwise, an empty box opens.
If you have specified a data source, Add Field opens a list of all the
fields in the specified table, which you can then drag and drop onto
the page. The fields are placed on the page with the name of the field
before them.
This is a quick and easy way to create a form from a data source.

Activation Order

Allows you to specify the order in which focus shifts between
controls. You can test the order by leaving design mode and using
Tab to switch between the controls.

Open in Design Mode

Opens the current form in design mode (to edit the form rather than
entering data into it).

Automatic Control
Focus

If activated, focus is set to the first form control.

Position and Size

Launches the Position and Size dialog, where you can type precise
values, rather than dragging the control. You can also lock the size or
position, so they do not get changed accidentally. For some controls,
you can rotate and set the slant and corner radius.

Change Anchor

Just as with a frame, any form control can be anchored to page,
paragraph, or character and also anchored as a character (meaning
that it behaves like any other character on the page).

Alignment

Disabled unless the control is anchored as a character. You can align
a control in different ways, for example so the top of the control lines
up with the top of the text or the bottom lines up with the bottom of
the text.

Display Grid

Displays a grid of dots on the page, to help you line up controls.

Snap to Grid

When a control is brought close to a grid point or line, it will snap to
the grid. This makes it is easier to line up controls.

Guides when Moving

When a control is being moved, lines extend from the control
horizontally and vertically to help you position it accurately.
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Example: a simple form
Create the document
Open a new document (File > New > Text Document). It is a good idea to write down the outline
of the document, without form controls, though of course it can easily be changed later.

Figure 3: Initial document without form controls

Add form controls
The next step is to add the form controls to the document. We will have four controls:
•

Name is a text box.

•

Gender is three option buttons: male, female, or other; user can select one.

•

Favourite shape is a list of options.

•

All shapes you like is a series of check boxes.

To add these controls:
1)

Select View > Toolbars > Form Controls to open the Form Control toolbar.

2)

If the tools are not active, click the Design Mode On/Off icon to activate them.

3)

Click the Text Box icon, then click in the document and drag the shape of the Name text
box to approximately the size you want. Drag it to line up with the Name: label.

4)

Make sure Wizards On/Off is off. Click the Option Button icon. Click and drag to create
three option buttons near the Gender: label in the document. We will configure these in the
next section.

5)

Click the List Box icon and draw a list box by Favourite Shape: in the document. This will
just be an empty pane for now.

6)

Click the Check Box icon and create four check boxes by All shapes you like, side by side
across the page.

Your document should now look something like Figure 4.
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Figure 4: Document with form controls

Configure form  oonrros왇
No further configuration is required for the Name field.
For the option buttons, do this:
1)

Be sure design mode is on. Right-click on the first option button and click Control on the
context menu. In the Properties dialog (Figure 5), on the General tab, type Male in the
Label field and Gender in the Group name field.

2)

Repeat for the other two options, using Female and Other, respectively, for the Label and
Gender for the Group name. (Grouping options allows only one to be selected at a time.)

Figure 5: Specifying label and group names for an option button
To add the list of choices to the the list box, do this:
1)

Be sure Design Mode is on and Wizards are off. Double-click on the List Box control to
open the control’s Properties dialog (Figure 6). Select the General tab.
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2)

Scroll down to find the List Entries text input box. Type the names of the shapes (Circle,
Triangle, Square, Pentagon) one at a time. After each, press Shift+Enter. You should end
up with a line saying "Circle";"Triangle";"Square";"Pentagon".

Figure 6: Properties dialog for a list box
To give the check boxes names (instead of Check Box, Check Box 2, and so forth):
1)

Double-click on the first Check Box. The Properties dialog stays open but changes to show
the properties for the check box.

2)

Change the text in the Label field to Circle and press Enter. The cursor moves to the next
line, and the label on the check box in the document changes immediately.

Figure 7: Top part of Properties dialog for a check box
3)

Click on each of the other three check boxes in turn. Change the text in the Label text input
box in the Properties dialog to Triangle, Square, and Pentagon in turn.

4)

Close the Properties dialog.

5)

Turn design mode off and close the two Controls toolbars.
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You have now completed the form, which should look something like Figure 8.

Figure 8: Completed form

Fini왇hing rouohe왇
The form is complete, but you are free to make further changes to the document. If you were
sending this out to other people to complete, you would probably want to make the document readonly. The effect would be that users would be able to fill in the form but not to make any other
changes to the document.
To make the document read-only, select File > Properties, select the Security tab and enable
Open file read-only.

Note
If the document is read-only, anyone filling in the form will need to use File > Save as
to save the document.

Accessing data sources
The most common use for a form is as the front end of a database. You can provide a form that
allows users to enter information into a contacts database and, because it is part of a Writer
document, the form can contain graphics, formatting, tables, and other elements to make it look
just the way you want. Modifying the form is as simple as editing a document.
LibreOffice can access numerous data sources. These include ODBC, MySQL, Oracle JDBC,
spreadsheets and text files. As a general rule, databases can be accessed for read and write; other
data sources (such as spreadsheets) are read-only.

Tip
To see the list of supported data source types for your operating system, choose File >
New > Database. On the first page of the Database Wizard (Figure 12), select
Connect to an existing database and then open the drop-down list.
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Creating a database
Chapter 8, Getting Started with Base, in the Getting Started Guide covers in more detail how to
create a database. Below is a short guide to creating a very simple database.
1)

Select File > New > Database to start the Database Wizard.

Figure 9: Database Wizard
2)

Select Create a new database and click Next >>.

3)

On the next page, select Yes, register the database for me and Open the database for
editing. Registering the database means that it can be accessed from other LibreOffice
components such as Writer and Calc. You need to do this if you want to link forms into it.

4)

Click Finish and save your new database, giving it a name. Unlike creating other
documents in LibreOffice, databases must be saved when you first create them.

After saving the database, you should see the main Base window (Figure 10), which contains three
panels. The left-hand panel is Database, with icons for Tables, Queries, Forms and Reports.
The next step is to create a table:
1)

Choose Tables in the left-hand column, then choose Create Table in Design View under
Tasks.

2)

Use the Table Design window to tell Base which fields to create. We will have three input
data fields: Name, Address, and Telephone.

3)

On the first line, enter under Field Name, ID, and set the Field Type to Integer [INTEGER].
In the box at the left of the line, right-click and select Primary Key, bringing up a key icon in
the box. In the Field Properties at the bottom of the window is an Auto Value option; change
this to Yes. Optionally, type Primary key in the Description column. See Figure 11.
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Figure 10: Main Base window

Caution
Setting up the Primary Key field with Auto Value set to Yes is an important step. If this
is not done, the form you create later will be much trickier to use and may generate
errors for the user. It could even prevent the user from saving the records in the form.
Make sure you get this step right!

Figure 11: Setting a primary key
4)

On the next three lines, enter under Field Name Name, Address and Telephone. Accept the
default Field Type of Text [VARCHAR] and leave Description blank.

5)

Save the table (File > Save). You will be prompted to name it. The name can be anything
you like. Click OK.

6)

Finally, close the table design window to return to the main Base window. If File > Save is
available, select it to save the whole database.
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Figure 12: Database table design

Aooe왇왇ing an exi왇ring dara 왇ouroe
If you have an existing data source, such as a spreadsheet or database, you need to register it
with LibreOffice. An example of registering a spreadsheet as a data source is given in Chapter 14,
Mail Merge. To summarize:
1)

Select File > New > Database to launch the Database Wizard.

2)

Select Connect to an existing database and choose the type from the drop-down list.

3)

Click Next >> and follow the instructions to select the database to register (the exact
process varies between different types of data source).

4)

In Step 3: Save and proceed, check that Yes, register the database for me is selected.
Deselect Open the database for editing; you just need to register it, not edit it through Base.

Creating a form for data entry
Once a database is registered with LibreOffice, follow these steps to link a form to the data source:
1)

Create a new document in Writer (File > New > Text Document).

2)

Design your form, without putting in the actual fields (you can always change it later).

3)

Show the Form Controls toolbar (View > Toolbars > Form Controls).

4)

Click the Design Mode On/Off icon to put the document into design mode, if necessary.
With design mode off, most of the toolbar buttons are grayed out. If the Design Mode icon
is also grayed out, click on the Select icon to activate it.

5)

Click the Text Box icon. Click in the document and drag to create a text box for the first
form field (for example, Name, if you are linking to the database created above).

6)

Click the Text Box icon again and drag the mouse to draw another field. Additional fields, of
any type, can be added in the same way (click and drag).
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So far you have followed the same steps used before when creating your first form. Now you will
link the form with the data source you registered.
1)

Click the Form icon in the Form Controls toolbar, or right-click on any of the fields you
inserted and select Form, to open the Form Properties dialog (Figure 13).

2)

In the Form Properties dialog, choose the Data tab.
–

Set Data Source to be the data source you registered.

–

Set Content Type to be Table.

–

Set Content to be the name of the table you want to access.

–

Close the dialog.

Figure 13: Form properties, connecting to a data source
3)

For each form control in turn, click on the control to select it (so small green boxes appear
around it), then launch the Properties dialog: either right-click and select Control or click on
the Control icon on the Form Controls toolbar.

4)

In the Properties dialog, click on the Data tab (Figure 14). If you set up the form correctly,
the Data Field option will contain a list of the different fields in the data source (for example,
Name, Address and Telephone). Select the field you want.

Figure 14: Form control properties, Data tab
5)

Repeat for each control in turn until every control that should be assigned to a field has
been assigned.
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Caution
If you created a database in LibreOffice Base and your Primary Key field had Auto
Value set to Yes, that field does not need to be part of the form. If Auto Value was set
to No, you will have to include it and have your users enter a unique value into that
field whenever they make a new entry—not something that is recommended.

Entering data into a form
Once you have created a form and tied it to a database, you want to use it to enter data into the
database, or modify data already there.
1)

Make sure that the form is not in design mode. (In the Form Controls toolbar, click the
Design Mode On/Off icon. If design mode is off, most of the buttons on the toolbar will be
grayed out.)

2)

Make sure that the Form Navigation toolbar is on (View > Toolbars > Form Navigation).
This toolbar normally appears at the bottom of the workspace.

Figure 15: Form Navigation toolbar
3)

If there is existing data in the data source, use the control buttons on the Form Navigation
toolbar to look at different records. You can amend data in a record by editing the values in
the form. To submit the changes, press Enter with the cursor in the last field. The record is
saved and the next record is displayed.

4)

If there is no data in the form, you can start entering information by typing into the fields of
the form. To submit the new record, press Enter with the cursor in the last field.

5)

Other functions can be performed from the Form Navigation toolbar, including deleting a
record and adding a new record.

Note
If a user tries to fill in the form and receives the error “Attempt to insert null into a nonnullable column”, then the form designer should go back to the database and confirm
that the Primary Key field has the Auto Value set to Yes. This error will prevent the
form user from saving the records.

Advanced form customization
Linking a macro to a form control
You can set any form control (for example, text box or button) to perform an action when triggered
by some event.
To assign a macro to an event:
1)

Create the macro. See Chapter 13, Getting Started with Macros, in the Getting Started
Guide.

2)

Be sure the form is in design mode. Right-click on the form control, select Control and click
on the Events tab (Figure 16).
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Figure 16: Control properties, Events tab
3)

Click the browse icon by any event to open the Assign action dialog (Figure 17).

4)

Click the Macro button and select the macro from the list in the Macro Selector dialog (not
shown). You return to the Assign action dialog. Repeat as needed, then click OK to close
the dialog.

Figure 17: Assign action dialog
Macros can also be assigned to events relating to the form as a whole. To do this, right-click on a
form control in the document, select Form and click on the Events tab.
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Read-only documents
Having created your form, you want whoever is using it to be able to access the information stored
in the database, or complete the form, without changing the layout. To do this, make the document
read-only by choosing File > Properties > Security and selecting Open file read-only.

Fine-tuning database access permissions
By default, when a database is accessed from a form, any changes can be made to it: records can
be added, deleted, and amended. You may not want that behavior. For example, you may want
users to be able only to add new records or to be prohibited from deleting existing records.
In design mode, right-click on a form control and select Form from the context menu. On the Data
tab of the Form Properties dialog are a number of options: Allow additions, Allow deletions, Allow
modifications and Add data only. Set each of these to Yes or No to control the access users have
to the data source.
Individual fields can also be protected. This might be useful if you wanted a user to be able to
modify some parts of a record but only view others, such as a stock list where item descriptions are
fixed and quantities can be modified.
To make an individual field read-only, in design mode, right-click on the form control within the
document and select Control from the context menu. Select the General tab and set Read-only to
Yes.

Figure 18: Data Properties of a form

Form  oonrros form arring oprion왇
You can customize the way form controls look and behave in a number of ways. These are all
accessed in design mode. Right-click on the form control, select Control from the context menu
and select the General tab in the Properties dialog.
•

Set a label for the control in the Label box (not to be confused with the box called Label
Field). Some form controls, such as push buttons and option buttons, have visible labels
that can be set. Others, such as text boxes, do not.
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•

Set whether the form control will print out if the document is printed with the Print option.

•

Use the Font setting to set the font, typeface, and size for a field’s label or for text typed into
a field. This setting does not affect the size of check boxes or option buttons.

•

For a text box, you can set the maximum text length. This is very useful when adding
records into a database. Every database text field has a maximum length and, if the data
entered is too long, LibreOffice displays an error message. By setting the maximum text
length of the form control to be the same as that of the database field, this error can be
avoided.

•

You can set the default option for a form control. By default, a control is blank, or has every
option unselected. You can set the control to start with a particular option or list item
selected.

•

For controls where a password is being entered, setting the Password character (for
example to *) displays only that character, but saves what the user really types.

•

You can add additional information and help text for a form control.

•

Other formatting controls such as background color, 3-D look, text formatting, scroll bars,
and borders allow you to further define how the control appears.
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