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Introduction
Pictures are often used in presentations as they can convey a large amount of information more
quickly than the written word. You can also give a more professional look to your presentation by
adding a company logo. Also, you may want to use Impress to create a presentation consisting
only of pictures, such as a slideshow of holiday snapshots to share with friends.
This chapter describes how to insert and format pictures.

Inserting pictures
This section describes several ways to insert a picture from an external source into the
presentation. Once the picture has been inserted, it can be formatted extensively.

Inserting a picture from a file
Inserting a picture from a file is quick and easy. First choose a slide layout, as described in
Chapter 1 Introducing Impress. Most layouts include a set of icons for inserting objects, but you
can insert a picture into any slide.
Whether you are using an AutoLayout for the placement of the picture, or you are just inserting a
picture, follow these steps:
1) Go to Insert > Picture > From file on the menu bar or click on the Insert Picture icon
(Figure 1) if you have inserted a slide and the Insert Picture dialog opens (Figure 2).
2) Navigate to the directory containing the desired picture and select the file. LibreOffice
recognizes a large number of image types. If the Preview option is selected, a thumbnail of
the selected file will be displayed in the preview pane on the right.
3) Click Open to place the picture on the current slide. The picture is now displayed on the
slide with selection handles displayed around the picture border.

Figure 1: Slide showing the placeholder for inserting objects
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Figure 2: Insert Picture dialog

Note

The Insert Picture dialog has two options: Link and Preview. The position of these
options is determined by the operating system, but they are normally in the bottomleft part of the dialog.

Select the Link option to insert the picture as a link to a file rather than embedding the file itself. In
general it is preferable to embed images so that the presentation can be copied for use on other
computers. On some occasions, however, it makes sense to link the image rather than embed it.
These include:

• When the image file is quite large and linking rather than embedding will dramatically
reduce the size of the presentation file.

• When the same image file is used in many presentations. For example, when using the
same background image for all the presentations created.

• When the linked file will be available when loading the presentation. For example, if the
presentation is a slide show of holiday pictures.

Inserting pictures
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Inserting a picture from a scanner
Inserting an image from a scanner is normally a simple process if one or more than one of the
following are valid.

• The scanner software driver has been installed on the computer.
• The scanner is supported by the SANE system if the computer operating system is Linux or
other UNIX-like operating system

• The scanner is TWAIN compatible and the computer is operating Windows or Mac OS.
• The scanner is configured on the computer with LibreOffice software installed.
The following scanning procedure is only an example to demonstrate how to insert a picture from a
scanner. The actual procedure you use on your computer will depend on the operating system, the
type of scanner being used and the scanner driver software installed.
1) Prepare the image for the scanner and make sure that the scanner is switched on.
2) Go to Insert > Picture > Scan > Select Source on the main menu bar to open the
Scanner dialog (Figure 3). If you have previously used your scanner, then go to Insert >
Picture > Scan > Request on the main menu bar to open the Scanner dialog.
3) If you have more than one scanner connected, select the scanner from the Select Source
or Device Used drop-down list.
4) If available, click Create Preview or Preview to carry out a preview scan of the picture and
place it in the preview area.
5) If necessary crop the scanned image to what you require and make any necessary
scanning adjustments.
6) Click Scan and, when the image has been scanned, Impress places it into the selected
slide. At this point it can be edited as any other image using the available Impress tools.

Figure 3: Example of a Scanner dialog
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Inserting a picture from the Gallery
The Gallery contains a collection of images that you can use in a presentation. You can also add
your own images to the Gallery, making it an essential tool for creating presentations quickly and
with a consistent look. The Gallery is available in all components of LibreOffice. For an introduction
to the Gallery, see the Getting Started Guide Chapter 11 Graphics, the Gallery, and Fontwork.
1) Go to Tools > Gallery on the main menu bar or click the Gallery icon
on the Drawing
toolbar to open the Gallery dialog (Figure 4). The Gallery displays the available themes with
images that are available for each theme.
2) Select a theme from the left pane and then scroll through the right pane to find a suitable
image.
3) Click on the image and drag it onto the workspace.
4) Release the mouse button and the image will be placed into your slide. If necessary, resize
the image as described in “Resizing pictures” on page 10.

Figure 4. Inserting an image from the Gallery

Positioning the Gallery
To expand the Gallery, position the cursor over the line that divides it from the top of the
workspace. When the cursor changes shape, click and drag downward. The workspace will resize
in response.
By default, the Gallery is docked above the Impress workspace. To undock it, hold down the Ctrl
key and double-click on the upper part of the Gallery next to the View icons. Double-click in the
same area again to dock it in its default position at the top of the workspace.
When the Gallery is docked, to hide it and view the full Impress workspace, click the Hide/Show
button in the middle of the thin bar separating the Gallery from the workspace (highlighted in Figure
4). The Hide/Show button lets you keep the Gallery open for quick access while you create your
slide show, yet out of the way when you are no longer using the Gallery.

Managing Gallery themes
Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. The left
pane of the gallery window lists the available themes. Click on a theme to see its images displayed
in the right pane of the Gallery dialog.
Managing Gallery themes
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The default themes are read only; no images or graphics can be added to or deleted from these
themes. The default themes are easily recognizable by right-clicking on each category and the only
available option in the pop-up menu is Properties.
In a default installation of LibreOffice, My Theme is the only category that is customizable and
allows you add or delete your own images. You can also create new theme categories where you
can add or delete your own images, as explained in “Creating new themes” on page 9.

Adding images to My Themes
You can only add images to My Theme or themes that you have created.
1) Right-click on My Theme or the theme name that you created in the list of themes and
select Properties from the context menu to open the Properties of My Theme dialog
(Figure 5).
2) Click on the Files tab.
3) Click Find Files to open the Select Path dialog.
4) Browse to the folder that contains the images you want to use.
5) Click OK to select the files contained in the folder and the Select Path dialog closes. The
list of files contained in the folder now appear in the Properties of My Theme dialog.
6) Select the files you want to use in My Theme and click Add. The added files will disappear
from the file list and the images will appear in the Gallery.
7) If you want to add all the files in the list, then click Add All. All the files will disappear from
the list and the images will appear in the Gallery.
8) Click OK when finished and the Properties of My Theme dialog will close.

Figure 5. Properties of My Theme dialog – Files page
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Deleting images from the Gallery
You can only delete images from My Theme or themes that you have created.
1) Open the Gallery and select My Theme or a theme that you created.
2) Right-click on the image in the Gallery window.
3) Select Delete from the context menu.
4) A confirmation message appears, asking if you want to delete this object. Click Yes.

Note

An images are linked files and are deleted from the Gallery only. The original image
files are not deleted.

Updating themes
All the images in the Gallery are linked files. You may wish to update a theme occasionally, to
make sure that all the files are still there.
1) Open the Gallery.
2) Right-click on the theme where you added at least one file.
3) Select Update from the context menu.

Creating new themes
To add a new theme to the list of themes in the Gallery:
1) Open the Gallery.
2) Click New Theme above the list of themes and the Properties of New Theme dialog opens
(Figure 6).
3) Click the General tab and type a name for the new theme in the text box.
4) Click the Files tab and follow the procedure in “Adding images to My Themes” on page 8.
5) The new theme will now be displayed in the list of themes in the Gallery.

Figure 6. Creating a new theme

Note

If you wish, you can rename a new theme by right-clicking on the theme name and
selecting Rename from the context menu.

Managing Gallery themes
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Moving pictures
1) Click on a picture to select it. Selection handles are displayed.
2) Move the cursor over the picture until it changes shape. The cursor shape depends on the
computer operating system, for example a four headed arrow or a hand.
3) Click and drag the picture to the desired position.
4) Release the mouse button.
For a more accurate placement of a picture, use the Position and Size dialog described in Chapter
6 Formatting Graphic Objects.

Resizing pictures
1) Click on a picture to show the selection handles.
2) Position the cursor over one of the selection handles. The cursor changes shape giving a
graphical representation of the direction of the resizing.
3) Click and drag to resize the picture.
4) Release the mouse button when satisfied with the new size.
For more accurate resizing of a picture, use the Position and Size dialog described in Chapter 6
Formatting Graphic Objects.

Note

Tip

Caution

The corner selection handles resize both the width and the height of the graphic
object simultaneously, while the other four selection handles only resize one
dimension at a time.

To retain the original proportions of the graphic, Shift+click one of the corner selection
handles and then drag. Make sure to release the mouse button before releasing the
Shift key.

Be aware that re-sizing a bit-mapped (raster) image will adversely affect the resolution
causing some degree of blurring. It is better to use a specialized graphics program to
correctly scale the picture to the desired size before inserting it into your presentation.
LibreOffice recommend you use a tool such as Gimp (http://www.gimp.org/).

Rotating pictures
As with the position of the image on the page, rotation of a picture can be done manually or using a
dedicated dialog. The Rotation dialog is described in Chapter 6 Formatting Graphic Objects.
Rotate a picture manually as follows:
1) Select the picture to display the selection handles.
2) Click the Rotate icon
on the Line and Filling toolbar or click again on the selected
picture and the selection handles change color (Figure 7). The color change will depend on
the computer operating system and how the computer has been setup.
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Figure 7: Rotating pictures

Note

The icons representing the functions in the toolbars depend on the computer
operating system used and how the computer has been setup, or whether LibreOffice
has been customized or not. When in doubt, hover the mouse over the icons and
wait for the tooltip to appear showing the name of the button.

3) A circle or circle with crosshairs (depending on computer system) appears in the center of
the picture indicating the rotation point. The center of the picture is the normal rotation
point, but this rotation point can be moved to change the rotation center to a corner or to a
point outside the picture. To do this, click on the rotation point and drag it to the desired
position before applying the rotation.
4) The selection handles in each corner are the rotation handles and the cursor shape will
change when moved over one of them. Click the mouse and move in the direction in which
you want to rotate the picture.
5) When satisfied, release the mouse button.

Tip

To restrict the rotation angles to multiples of 15 degrees, press the Shift key while
rotating the graphic. This is very handy to rotate pictures of right angles, for example
from portrait to landscape or from landscape to portrait.

Formatting using the Picture toolbar
When a picture is selected, the Picture toolbar becomes available. This toolbar provides a number
of formatting options which are described in this section. If the picture toolbar does not appear
when an image is selected, display it by selecting View > Toolbars > Picture from the menu bar
(Figure 8).

Figure 8: Picture toolbar

Formatting pictures
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Table 1: Graphic filters and their effects
Icon

Name

Effect

Invert

Inverts the color values of a color image, or the brightness values
of a grayscale image. Apply the filter again to revert the effect.

Smooth

Softens or blurs the image by applying a low pass filter.

Sharpen

Sharpens the image by applying a high pass filter.

Remove noise

Removes noise by applying a median filter.
Opens a dialog for defining solarization. Solarization refers to an
effect that looks like what can happen when there is too much light
during photo development. The colors become partly inverted.

Solarization

Parameters – specifies the degree and type of solarization.
Threshold Value – specifies the degree of brightness, in percent,
above which the pixels are to be solarized.
Invert – specifies to also invert all pixels.

Aging

Posterize

All pixels are set to their gray values, and then the green and blue
color channels are reduced by the amount you specify. The red
color channel is not changed.
Aging Degree – defines the intensity of aging, in percent. At 0%
you see the gray values of all pixels. At 100% only the red color
channel remains.
Opens a dialog to determine the number of poster colors. This
effect is based on the reduction of the number of colors. It makes
photos look like paintings.
Poster Colors – specifies the number of colors to which the image
is to be reduced.

Pop Art

Converts an image to a pop-art format.

Charcoal sketch

Displays the image as a charcoal sketch. The contours of the
image are drawn in black, and the original colors are suppressed.

Relief

Displays a dialog for creating reliefs. You can choose the position
of the imaginary light source that determines the type of shadow
created, and how the graphic image looks in relief.
Light Source – specifies the light source position. A dot represents
the light source.
Joins small groups of pixels into rectangular areas of the same
color. The larger the individual rectangles are, the fewer details the
graphic image has.

Mosaic

Width – defines the width of the individual tiles.
Height – defines the height of the individual tiles.
Enhance edges – enhances, or sharpens, the edges of the object.
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Applying filters
The graphic filters available on the Picture toolbar apply various filters to the selected picture. The
best way to judge if a filter works for your picture is to try it. Table 1 describes briefly each of the
available graphic filters and their effects. See the Draw Guide for more information and examples
of the effects.
1) Select the pictures so that the selection handles are displayed and the Picture toolbar
becomes available.
2) Click on the Filter icon
to show the different graphic filters that are available.
3) Select the filter you wish to apply. To show the name of the filter, hover the cursor over the
icon and wait for the tooltip to appear.
4) If you are not satisfied with the effect obtained or you want to try a different filter and before
doing anything else, click the Undo icon
on the Standard toolbar or select Edit >
Undo: Bitmap Graphic Filter on the main menu bar or use the keyboard combination
Ctrl+Z.

Changing graphics mode
Click on Graphics mode on the Picture toolbar (Figure 8) to open a drop-down list and change the
graphic mode using one of the following options.

• Default – the view of the graphic object is not changed.
• Grayscale – the graphic object is shown in grayscale. A color graphic object can become
monochrome in grayscale. You can also use the color sliders to apply a uniform color to a
monochrome graphic object.

• Black/White – the graphic object is shown in black and white. All brightness values below
50% will appear black, all brightness values over 50% will appear white.

• Watermark – the graphic object is raised in brightness and reduced in contrast so that it
can be used in the background as a watermark.

Adjusting color
Clicking on the Color icon
in the Picture toolbar (Figure 8) opens the Color dialog (Figure 9).
Use this dialog to modify the individual color components of the image (red, green, blue) as well as
the brightness, contrast, and gamma of the image. Increasing the gamma value of a picture makes
it more suitable to be used as a background or watermark as it will interfere less with a dark text.

Figure 9: Color dialog
To adjust colors more accurately, delete, edit or add colors. go to Format > Area on the main
menu bar to open the Area dialog, then click on the Colors tab (Figure 10). This dialog page
provides the following options when working with color.

• Name – specifies the name of a selected color. You can also type a name in this field when
defining a new color.

• Color – contains a list of available colors. To select a color, choose one from the list.

Formatting pictures
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Figure 10. Colors page in Area dialog

• Color table – to modify colors, select the color model: Red-Green-Blue (RGB) or CyanMagenta-Yellow-BlacK (CMYK). LibreOffice uses only the RGB color model for printing in
color. The CMYK controls are provided only to ease the input of color values using CMYK
notation.
If you select RGB, the initials of the three colors will appear and you can set the color from
0 to 255 with the spin button.
If you select CMYK, the initials of the four colors will appear and you can set the color from
0 to 255 with the spin button.

• Add – adds a new color.
• Modify – changes the current color. Note that the color is overwritten without a
confirmation.

• Edit – define your own colors using the two-dimensional graphic and numerical gradient
chart.

• Delete – deletes the selected element or elements after confirmation.
• Load Color List – this icon

opens a file dialog, which allows you to select a color

palette.

• Save Color List – this icon

opens the Save As dialog, which enables you to save the
current color table under a specified name. If you do not choose this command, the current
color table will be automatically saved as default and re-loaded the next time you start
LibreOffice.

• The preview boxes display the selected color and the new color you are creating.
Setting object transparency
Click on the Transparency icon
on the Picture toolbar (Figure 8) to modify the percentage
value and make the image more transparent. As with the gamma value, increasing the
transparency of a picture makes the picture blend more smoothly in the background making the
overlay text easier to read.
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Figure 11. Transparency page in Area dialog
To adjust the transparency settings applied to a picture, go to Format > Area on the main menu
bar to open the Area dialog, then click on the Transparency tab (Figure 11).

• No transparency – turns off color transparency. This is the default setting.
• Transparency – turns on color transparency. Select this option and then enter a
percentage in the box where 0% is fully opaque and 100% is fully transparent.

• Gradient – applies a transparency gradient to the current fill color. Select this option, and
then set the gradient properties.

• Type – select the type of transparency gradient that you want to apply from Linear, Axial,
Radial, Ellipsoid. Quadratic, or Square.

•
•
•
•

Center X – enter the horizontal offset for the gradient.
Center Y – enter the vertical offset for the gradient.
Angle – enter a rotation angle for the gradient.
Border – enter the amount by which you want to adjust the transparent area of the
gradient. The default value is 0%.

• Start value – enter a transparency value for the beginning point of the gradient, where 0%
is fully opaque and 100% is fully transparent.

• End value – enter a transparency value for the endpoint of the gradient, where 0% is fully
opaque and 100% is fully transparent.

• Use the preview box to view your changes before you apply the transparency effect to the
color fill of the selected object.

Adjusting shadow settings
Click on the Shadow icon on the Picture toolbar (Figure 8) to apply a shadow to the image. If a
shadow is already applied to the picture, clicking on the Shadow icon will remove the shadow.
To adjust the shadow settings applied to a picture, go to Format > Area on the main menu bar to
open the Area dialog, then click on the Shadow tab (Figure 12).

Formatting pictures
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Figure 12. Shadow page in Area dialog

• Position – click where you want to cast the shadow.
• Distance – enter the distance that you want the shadow to be offset from the selected
object.

• Color – select a color for the shadow.
• Transparency – enter a percentage from 0% (opaque) to 100% (transparent) to specify the
transparency of the shadow.

• Use the preview box to view your changes before you apply the shadow effect to the
selected object.

Cropping pictures
Impress provides two ways to crop a picture: using a mouse or using a dialog. Using the mouse is
easier to use, but the dialog provides more precise control.
To crop a selected picture using the mouse:
1) Select the picture.
2) Click the Crop icon
on the Picture toolbar (Figure 8). A set of crop marks appears
around the picture (Figure 13).
3) Place the cursor over any of the crop marks, the cursor changes shape. Drag the mark to
crop the picture.
4) Click outside the picture to deactivate cropping mode.
5) Press and hold the Shift key while working on the crop marks to produce the following
effects:
a) For a corner mark, the two sides of the picture forming the corner are cropped
proportionally with the picture anchored to the opposite corner mark.
b) For a side mark, both dimensions are changed proportionally with the image anchored
to the opposite side mark.

Figure 13: Cropping pictures using the cursor
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Figure 14: Crop dialog and options available when cropping a picture
To crop a picture using a dialog:
1) Select the picture.
2) Right-click on the picture and select Crop Picture from the context menu or go to Format
> Crop Picture on the main menu bar to open the Crop dialog (Figure 14).
Crop the picture using the options given in the Crop dialog.
3) Click OK when finished to close the dialog.
4) To revert back to the original size of the picture, click Original Size.
The Crop dialog has the following options:

• Keep scale – maintains the original scale of the graphic when you crop, so that only the
size of the graphic changes.

• Keep image size – maintains the original size of the graphic when you crop, so that only
the scale of the graphic changes. To reduce the scale of the graphic, select this option and
enter negative values in the cropping boxes. To increase the scale of the graphic, enter
positive values in the cropping boxes.

• Left – if the Keep scale option is selected, enter a positive amount to trim the left edge of
the graphic, or a negative amount to add white space to the left of the graphic. If the Keep
image size option is selected, enter a positive amount to increase the horizontal scale of
the graphic, or a negative amount to decrease the horizontal scale of the graphic.

• Right – if the Keep scale option is selected, enter a positive amount to trim the right edge
of the graphic, or a negative amount to add white space to the right of the graphic. If the
Keep image size option is selected, enter a positive amount to increase the horizontal
scale of the graphic, or a negative amount to decrease the horizontal scale of the graphic.

• Top – if the Keep scale option is selected, enter a positive amount to trim the top of the
graphic, or a negative amount to add white space above the graphic. If the Keep image
size option is selected, enter a positive amount to increase the vertical scale of the graphic,
or a negative amount to decrease the vertical scale of the graphic.

• Bottom – if the Keep scale option is selected, enter a positive amount to trim the bottom of
the graphic, or a negative amount to add white space below the graphic. If the Keep image
size option is selected, enter a positive amount to increase the vertical scale of the graphic,
or a negative amount to decrease the vertical scale of the graphic.

Formatting pictures
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• Scale – changes the scale of the selected graphic.
– Width – enter the width for the selected graphic as a percentage.
– Height – enter the height of the selected graphic as a percentage.
• Image size – changes the size of the selected graphic.
– Width – enter a width for the selected graphic.
– Height – enter a height for the selected graphic.
• Original Size – returns the selected graphic to its original size.

Deleting a picture
1) Click on the picture and the selection handles are displayed.
2) Press Delete key.

Creating an image map
An image map defines areas of the image (called hotspots) associated with a URL (a web address
or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. Clicking on a
hotspot causes Impress to open the linked page in the appropriate program (for example, default
browser for HTML pages; LibreOffice Writer for .ODT files; PDF viewer for PDF files).
You can create hotspots of various shapes, such as rectangles, ellipses, and polygons. You can
also include several hotspots in the same image. When you click on a hotspot, the URL opens in a
browser window or frame that you have specified. You can also specify the text that appears when
your mouse cursor hovers over the hotspot.

Figure 15: Image Map Editor dialog for creating hotspots
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To use the image map tool to create or edit a hotspot:
1) Select the picture on a slide where hotspots are going to be defined.
2) Go to Edit > ImageMap on the main menu bar and the ImageMap Editor dialog opens
(Figure 15). The main part of the dialog shows the image on which the hotspots will be
defined.
3) Active hotspots are indicated by a colored border, while inactive hotspots are indicated by a
black or grayed out border.
4) Use the tools at the top of the dialog and the fields to define hotspots and their links.
5) Click the Apply icon

to apply the settings.

6) When done, click the Save icon

to save the image map to a file, then close the dialog.

The top part of the dialog, from left to right, contains the following tools:

• Apply icon – click this icon to apply any changes made.
• Open, Save, and Select icons.
• Rectangle, Ellipse, Polygon and FreeForm Polygon icons – drawing tools hotspot
shapes. These tools work in exactly the same way as the corresponding tools in the
Drawing toolbar (see Chapter 5 Managing Graphic Objects).

• Edit, Move, Insert, Delete Points icons – advanced editing tools to manipulate the shape
of a polygon hotspot. Select Edit Points tool to activate the other tools.

• Active icon – toggles the status of the hotspot activating a selected hotspot or deactivating
it if active.

• Undo and Redo icons.
• Macro icon – associates a macro with the hotspot instead of a hyperlink.
• Properties icon – sets the hyperlink properties and adds the Name attribute to the
hyperlink.
Below the toolbar are fields which specify the properties of a hotspot:

• Address – the URL address that points to a hyperlink. You can also point to an anchor in a
document such as a specific slide number; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

• Text – enter the text that will be displayed when the mouse is moved over the hotspot.
• Frame – where the target of the hyperlink will open: _blank (opens in a new browser
window), _self (default selection and opens in an active browser window), _top or _parent.

Tip

The value _self for the target frame will work on the vast majority of the occasions. It
is not recommended to use the other values unless absolutely necessary.

Creating an image map
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