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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer system

Open context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Multi-page documents
Draw documents, like Impress presentation documents, can consist of multiple pages. This allows
you to create a drawing that has several sections, but is stored as one file on a computer.
When pages are inserted into a drawing, they are automatically named as Slide 1, Slide 2, and so
on. As you change page order, the pages are automatically renumbered. However, if you want to
identify each page easily, you are recommended to give each page a memorable name.

Using the page pane
By default the Page Pane (Figure 1) appears docked on the left of the workspace when you open
Draw. It shows every page in a drawing as a thumbnail. If the Page Pane is not displayed, go to
View > Page Pane on the main menu bar.

Note

The Page Pane is called Pages when it is in its docked position on the left of the
workspace.

• Select a thumbnail in the Page Pane and the corresponding page is loaded in the
workspace. Click on the page in the workspace to activate it for editing. Alternatively, click
on the Navigator icon
or press the F5 key or go to View > Navigator on the main
menu bar to open the Navigator dialog (Figure 2) and select pages using this dialog.

Figure 1: Page pane and workspace

Figure 2: Navigator dialog
Multi-page documents
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• Select a thumbnail In the Page pane, then drag and drop the thumbnail to change the order
of pages in the document.

• Click and drag on the separator line between the Page pane and the workspace to change
the width of the Page pane.

• Click on the middle of this line to show or hide the Page pane (highlighted in Figure 1).
• Press and hold the Ctrl key, then double-click in the title bar of the Page pane to undock it
and turn it into a floating window.

• Press and hold the Ctrl key, then double-click in the title bar of the undocked Page pane to
dock it back into its default position on the left of the workspace.

• Right-click in the page pane and use the options in the context menu to insert, delete or
rename pages and to cut, copy and paste pages.

• Go to Insert > Slide on the main menu bar to insert a new page or Insert > Duplicate
Slide to insert a duplicate page.

Master pages
A master page is a page that is used as the starting point for other pages in your drawing. It is
similar to a page style in Writer: it controls the basic formatting of all pages based on it. A drawing
can have more than one master page so that you can assign a different to look to other pages in
your drawing.
A master page has a defined set of characteristics, including the background color, graphic, or
gradient; objects (such as logos, decorative lines, and other graphics) in the background, the
formatting of text, blocks of standard text, and inserted fields such as page numbering, date and
filename.

Note

LibreOffice uses interchangeable terms for one concept: slide master, master slide,
and master page. All refer to a page which is used to create other pages. When
searching for information in Draw Help, it may be necessary to use alternative
search terms.

Master page view
To add objects and fields to a master page, go to View > Master to open the master page view.
The Master View toolbar (Figure 3) also opens when you switch to master view. If this toolbar
does not appear, go to View > Toolbars > Master View.
To return to normal page mode, click on Close Master View in the Master View toolbar or go to
View > Normal on the main menu bar.

Figure 3: Master View toolbar

Creating master pages
Each drawing you create already has a default master page, but you can create extra master
pages to change the look of some of the pages in your multi-page drawing.
Switch to Master View and then click on the New Master icon
in the Master View toolbar to
create a new master page. The new master page is automatically selected allowing you to add a
new set of items to create a new look for your pages.
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Renaming master pages
Each new master page created has the default name of Default 1, Default 2, and so on. It is
recommended to rename your new master page with a more meaningful name. The default master
page that was created when you first created your drawing can also be renamed.
Switch to Master View and then right-click on a master page in the Page pane and select Rename
Page from the context menu or click on the Rename Master icon
on the Master View toolbar.
This opens a dialog where you can type a new name. Click on the OK button to save the new
name.

Deleting master pages
Switch to Master View and then select the master page you want to delete. Right-click on a master
page that you created in the Page pane and select Delete Page from the context menu or click on
the Delete Master icon

on the Master View toolbar.

The delete option and delete icon are only available when there is more than one master page in
your drawing. You cannot delete the default master page that was created when you first created
your drawing.

Inserting fields
You can insert fields on each master page by going to Insert > Fields on the main menu bar and
selecting a field from the context menu. The following fields can be inserted into a master page.

• Date (fixed) – inserts the current date into your master page as a fixed field. The date is
not automatically updated.

• Date (variable) – inserts the current date into your master page as a variable field. The
date is automatically updated when you reload the file.

• Time (fixed) – inserts the current time into your master page as a fixed field. The time is
not automatically updated.

• Time (variable) – inserts the current time into your master page as a variable field. The
time is automatically updated when you reload the file.

• Author – inserts the first and last names listed in the LibreOffice user data into the active
page.

• Page Number – inserts the page number into every page of your drawing. To change the
number format, go to Format > Page on the main menu bar and select a format from the
drop down list in Layout Settings.

• File name – inserts the name of the active file. The name only appears after you save the
file.

Assigning master pages
When your drawing has more than one master page, you can assign different master pages to
different pages.
1) Make sure you are in normal page view by going to View > Normal on the main menu bar
and select the page to which you want to assign a new master page.
2) Right-click on the page in the workspace area and select Page > Slide Design from the
context menu to open the Slide Design dialog (Figure 4).
3) Click the Load button to open the Load Slide Design dialog and use any predefined
master pages. All Draw and Impress templates can be used for this purpose.

Multi-page documents
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Figure 4: Slide design dialog
4) Select the Exchange background page option and the selected master page will be used
on all pages of the drawing.
5) Select the Delete unused backgrounds option to delete any master pages shown in the
Slide Design dialog that have not been assigned to a page.
6) Click on the OK button to assign the selected master page to your page.

Multiple layers
Layers in LibreOffice Draw allow you to assemble elements on a drawing page that are related.
Think of layers as individual workspaces that you can hide from view, hide from printing, or lock.
Any layers that do not contain any objects are transparent.

Note

You can lock a layer to protect its contents, or hide a layer and its contents from
view or from printing. When you add a new layer, the layer is added to all of the
pages in your drawing. However, when you add an object to a layer, it is only
added to the current drawing page.
If you want the object to appear on all of the pages (for example, a company logo),
add the object to the master page by going to View > Master. To return to your
drawing, go to View > Normal.

Layers do not determine the stacking order of objects on your drawing page, except for the
Controls layer which is always in front of all other layers. The stacking order of objects on your
drawing page is determined by the sequence in which you add the objects. You can rearrange the
stacking order by going to Modify > Arrange on the main menu bar.

Default layers
LibreOffice Draw provides three default layers, which cannot be deleted or renamed.

• Layout – is the default workspace and determines the location of title, text and object
placeholders on your drawing page.
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• Controls – used for buttons that have been assigned an action, but should not be printed
and the layer properties are set to not printable. Objects on this layer are always in front of
objects on other layers.

• Dimension Lines – is where the dimension lines are drawn. By switching the layer to show
or hide, you can easily switch dimension lines on and off.

Inserting layers
1) Right-click the layer tab area at the bottom and select Insert Layer from the context menu,
or go to Insert > Layer on the main menu bar to open the Insert Layer dialog (Figure 5).
2) Type a meaningful name for the layer in the Name text box.
3) Type a meaningful title for the layer in the Title text box.
4) If necessary, type a description for the layer in the Description text box.
5) Select Visible if you want the layer to be visible in your drawing. When Visible is not
selected, a layer is hidden and the title in the layer tab changes color to blue.
6) Select Printable if you want the layer to print when you print your drawing. Not printing is
useful if you want use a draft layer for guides or annotations that you use in making the
drawing, but do not want to appear in the final output.
7) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No
additional objects can be added to a locked layer. Locking a layer is useful, for example,
when a base plan is to be protected while adding a new layer with other details.
8) Click OK and the new layer automatically becomes active.

Figure 5: Insert Layer dialog

Modifying layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the name tab to open the Modify Layer dialog. This dialog is similar to the
Insert Layer dialog in Figure 5.
2) Make your changes to the layer, then click OK to save the changes and close the dialog.

Multiple layers
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Working with layers
Selecting a layer
To select a layer, click on the name tab of the layer at the bottom of the drawing workspace.

Hiding layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from
the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Clear the Visible check box and click OK. The text for the name tab changes color to blue.
Any objects placed on a hidden layer will no longer be visible on the other layers in your
drawing. Alternatively, hold down the Shift key and click on the name tab.

Showing hidden layers
1) Select a hidden layer, and right-click on the name tab of the layer and select Modify Layer
from the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Check the Visible check box and click OK. The text for the name tab changes to the default
color for text for your computer setup. Any objects placed on a hidden layer will now
become visible on the other layers in your drawing. Alternatively, hold down the Shift key
and click on the name tab.

Locking layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from
the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Check the Locked check box and click OK to prevent any modification of the layer.

Unlocking layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from
the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Uncheck the Locked check box and click OK to allow modification of the layer.

Renaming layers
To rename a layer that you have added to your drawing:
1) Right-click on the name tab of the layer and select Rename Layer from the context menu.
2) Type a new name for your layer and click outside the tab area to save the change.

Note

You can also rename a layer using “Modifying layers” on page 9.

Deleting layers
To delete a layer that you have added to your drawing:
1) Right-click on the name tab of the layer and select Delete Layer from the context menu.
2) Confirm the deletion and the layer and all its objects are deleted.
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Dimensioning
Draw allows you to dimension objects and display these dimensions to make your drawing look
more like an engineering drawing. When you create dimensions, they are automatically placed on
the Dimension Lines layer (see “Default layers” on page 8 for more information).

Configuring dimensioning
Two ways are available to access the options to configure dimensioning. Both methods use a
similar dialog to set the dimensioning options where you can change length, measurement and
guide properties of a dimension line.

Configuring using graphic styles
1) Go to Format >Styles and Formatting or press the F11 key on your keyboard to open the
Styles and Formatting dialog.
2) Select Dimension Line in the Styles and Formatting dialog.
3) Right-click on Dimension Line and select Modify from the context menu to open the
Graphics Styles dialog (Figure 6). See the Impress Guide for more information about
graphic styles.
4) Click on the Dimensioning tab to open the Dimensioning options page.
5) To reset the dimensioning options to the default properties of the template, click Standard.

Figure 6: Graphic Styles Dimensioning dialog

Configuring using context menu
1) Draw a dimension line. See “Dimensioning objects” on page 13 for more information.
2) Right-click on the dimension line and select Dimensions from the context menu to open
the Dimensioning dialog (Figure 7).

Dimensioning
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Figure 7: Context menu Dimensioning dialog

Dimensioning options
With reference to Figure 6 and Figure 7, the dimensioning options are as follows.

• Line – sets the distance properties of the dimension line and the guides with respect to
each other and to the baseline.

–

Line distance – specifies the distance between the dimension line and the baseline (line
distance = 0).

–

Guide overhang – specifies the length of the left and right guides starting at the
baseline (line distance = 0). Positive values extend the guides above the baseline and
negative values extend the guides below the baseline.

–

Guide distance – specifies the length of the right and left guides starting at the
dimension line. Positive values extend the guides above the dimension line and
negative values extend the guides below the dimension line.

–

Left guide – specifies the length of the left guide starting at the dimension line. Positive
values extend the guide below the dimension line and negative values extend the guide
above the dimension line.

–

Right guide – specifies the length of the right guide starting at the dimension line.
Positive values extend the guide below the dimension line and negative values extend
the guide above the dimension line.

–
–

Measure below object – reverses the properties set in the Line options.
Decimal places – specifies the number of decimal places used for the display of line
properties.

• Legend – sets the properties of the dimension text.
– Text position – determines the position of the dimension text with respect to the
dimension line and the guides. The AutoVertical and AutoHorizontal checkboxes must
be cleared before you can assign a text position.

–
–
–
–
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AutoVertical – determines the optimal vertical position for the dimension text.
AutoHorizontal – determines the optimal horizontal position for the dimension text.
Parallel to line – displays the text parallel to or at 90 degrees to the dimension line.
Show meas. units – shows or hides the dimension measurement units. You can also
select a measurement unit you want to display from the list.
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Note

The dimensioning style Dimension Line is always linked and stored with the
current work page. All the changes that you make apply only to this page. New
drawings are started with the standard properties of Draw. If you want to use the
amended style for future drawings, save your drawing as a template.

Tip

When dimensioning objects, it is recommended to use the zoom function, guide
lines and snap functions so that you can accurately place dimension lines on an
object. See Chapter 3 Working with Objects and Object Points for more
information.

Dimensioning objects

Figure 8: Dimensioning objects
1) Click on the small triangle next to the Lines and Arrows icon
on the Drawing toolbar to
open the Arrows pop-up toolbar. Note that this icon changes depending on the last Lines
and Arrows tool used. Also, this toolbar can become a floating toolbar by clicking on the
bottom of the pop-up toolbar and dragging it into your workspace.
2) Click on the Dimension Line icon
on the Arrows toolbar and the cursor normally
changes to a cross.
3) Position the cursor at one corner of your object, then click and drag the cursor to the other
corner of your object to draw the dimension line. To restrict your dimension line to the
horizontal or vertical direction, press and hold the Shift key while dragging the cursor.
4) Release the mouse button when you reach the other corner of your object and the
dimension line is drawn with the dimension automatically added. The dimension line is also
placed automatically on the Dimension Lines layer; see “Default layers” on page 8 for
more information.
5) If you want to edit the text of the dimension, double-click on an unselected dimension line
to enter text edit mode and make your changes. Click outside the dimension line to save
the changes.
6) If you want to configure your dimension line, see “Configuring dimensioning” on page 11.

Drawing to scale
In Draw a drawing is made on a predefined drawing area. This is normally Letter or A4 page size
depending on your locale, computer setup and the default printer connected to your computer.
However, depending on the actual size of the drawn objects, it is often convenient to reduce or
enlarge the drawing by scaling (for example 1:10 or 2:1).

Drawing to scale
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You can specify a scale value by going to Tools > Options > LibreOffice Draw > General and
selecting a value from the Drawing scale drop-down list. The default setting for this option is 1:1.
When you make a change to the drawing scale, it is reflected in the rulers at the top and left side of
your drawing.
Changes in the drawing scale have no effect on the basic drawing operations. Draw automatically
calculates the necessary values (for example, dimension lines). The spacing of the grid points is
independent of drawing scale, as the grid is an optical drawing aid and not a drawing element.
An increase in scale (for example 1:4) allows you to draw objects that would not fit into the paper
size for your drawing. A decrease in drawing scale (for example 4:1) allows you to draw small
objects accurately at an increased size to make them easier to understand.

• An example of drawing to scale is shown in Figure 9. All three rectangles are the same
size.

• The left rectangle was drawn at the default 1:1 scale and dimensioned.
• The drawing scale was then changed to 1:4 and the dimensions were automatically
increased by Draw to reflect the decrease in scale for the center rectangle.

• The drawing scale was then changed to 4:1 and the dimensions were automatically
decreased by Draw to reflect the increase in scale for the right rectangle.

Figure 9: Examples of drawing to scale

Gallery images
Draw includes several images in a Gallery which are grouped in themes: Bullets; Rulers;
Homepage; Rulers; Sounds. The left pane of the gallery window lists the available themes. Click
on a theme to see its images displayed in the right pane of the Gallery dialog (Figure 10).
The default themes are read only; no images can be added to or deleted from these themes. The
default themes are easily recognizable by right-clicking on each category and the only available
option in the pop-up menu is Properties.
In a default installation of LibreOffice, the My themes is the only category that is customizable and
allows you add or delete your own graphics. You can also create new theme categories where you
can add or delete your own images and this is explained in “Adding a new theme” on page 16.

Using the Gallery
1) Click on the Gallery icon
on the Drawing toolbar or go to Tools > Gallery on the main
menu bar to open the Gallery dialog.
2) Choose a theme in the left pane of the Gallery dialog.
3) Click on an image in the right pane of the Gallery dialog and drag the image into your
drawing.
14
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Figure 10. Gallery dialog
4) Alternatively, right-click on a gallery image and select Insert > Copy from the context
menu.
5) Move to your drawing and paste the gallery image into your drawing.

Adding images to My themes
You can add images only to My themes or themes that you have created.
1) Right-click on My themes or a theme name that you created in the list of theme categories
and choose Properties from the pop-up menu to open the Properties of My Theme dialog
(Figure 11).

Figure 11. Properties of My Theme dialog

Gallery images
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Figure 12. Selecting path for new images in themes
2)
3)
4)
5)

Click on the Files tab.
Click on Find Files to open the Select Path dialog (Figure 12).
Browse to the folder that contains the images you want to use.
Click OK to select the files contained in the folder and the Select Path dialog closes. The
list of files contained in the folder now appear in the Theme Properties dialog.
6) Select the files you want to use in My themes and click on Add. The added files will
disappear from the file list and the images will appear in the Gallery.
7) If you want to add all the files in the list, then click on Add All. All the files will disappear
from the list and the images will appear in the Gallery.
8) Click OK when finished and the Properties of My Theme dialog will close.

Deleting graphics
You can delete images only from My themes or themes that you have created.
1) Right-click on the image in the Gallery window.
2) Choose Delete from the pop-up menu.
3) A confirmation message appears, asking if you want to delete this object. Click Yes.

Note

The image is a linked file and is deleted from the Gallery only. The original image file
is not deleted.

All the images in a gallery are linked files. From time to time it is beneficial to update the gallery
theme to make sure that all the files are still there. To do so, right-click on the theme where you
added at least one file and then select Update from the pop-up menu.

Adding a new theme
You can add a new theme to the list of theme categories in the gallery as follows:
1) Click the New Theme button above the list of theme categories and the Properties dialog
opens.
2) Click the General tab and type a name for the new theme in the text box (Figure 13).
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Figure 13. Adding new theme to the Gallery
3) Click the Files tab and follow Steps 3 through to 8 in “Adding images to My themes” on
page 15.
4) The new theme will now be displayed in the list of theme categories in the Gallery.

Note

If you wish, you can rename this new theme by manually by right-clicking the theme
name and selecting Rename.

Colors and color palettes
Draw (like all LibreOffice components) uses color palettes for the representation of colors. Also,
you can customize the color palette to suit your own needs by modifying colors in a palette, adding
other colors, or creating new color palettes.

Note

LibreOffice uses the RGB color model internally for printing in all of its software
modules. The CMYK controls are provided only to ease the input of color values
using CMYK notation.

Using colors
Two color dialogs are available where you can select, add, modify, edit or delete colors. Go to
Tools > Options > LibreOffice > Colors (Figure 14) or Format > Area > Colors (Figure 15) on
the main menu bar to open these color dialogs. Also, if you right-click on a selected object and go
to Area in the context menu, then click on the Colors tab, you will open the Area dialog in Figure
15.
Color values are numeric and can be input directly as numbers. The color values for the RGB color
model (Red, Green and Blue) can be any integer value between 0 and 255. The color values for
the CMYK color model (Cyan, Magenta, Yellow and Black (K)) are percentages. When selecting
between the RGB and CMYK color models, the value boxes automatically change in both dialogs
to show RGB or CMYK.

Colors and color palettes
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When using CMYK values, the conversion to RGB values used in LibreOffice is made
automatically. Any modifications made to colors apply only to the active palette in your drawing
unless you save the modified color palette for future use.

Tip

For more information about color models, go to
http://en.wikipedia.org/wiki/Color_model

Figure 14: Options LibreOffice Colors dialog

Figure 15: Format Area Colors dialog
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Selecting colors
1) Go to Tools > Options > LibreOffice > Colors (Figure 14) or Format > Area > Colors
(Figure 15) on the main menu bar to open a color dialog.
2) Alternatively, right-click on a selected object and select Area from the context menu, then
click on the Colors tab to open the color dialog (Figure 15).
3) Select a color from the Color drop down list, or select a color from the color table, or enter
the RGB or CMYK values if you know these values for the color you want to use.
4) Click OK to use the selected color and close the dialog.

Color palettes
The Format > Area Colors dialog (Figure 15) allows you to load color palettes, and to create and
save color palettes for future use.

• Click on the Load Color List icon

to open a dialog where you can select a color palette

to use in Draw.

• If you have made any changes to the color palette, click on the Save Color List icon

to
open a dialog where you can save your color palette for future use in Draw. The file format
used in LibreOffice for color palettes is .soc.

Note

The Load Color List and Save Color List icons are only available if you select the
color dialog using the Format > Area > Colors command or right-clicking on a
selected object and selecting Area from the context menu.

Creating colors
Using color values
1) Select either RGB or CMYK from the drop down options on the color dialog.
2) Enter integer values or percentage values in each of the RGB or CMYK boxes or use the
spinners at the right of each box.
3) The original color is shown in the top color sample and the new color is shown in the lower
color sample.
4) Click Modify to apply and store the new setting in the color palette without changing the
color name. Alternatively click Add and you will be prompted to give the color a new name.
Entering a name and clicking OK will add the new color to the end of the color list and store
it in the currently active palette.,
5) Click OK to use the modified or new color and close the dialog.

Note

To store your new color in a color palette for future use in Draw, see “Color palettes”
on page 19.

Using the color picker
You can define colors using the Color Picker dialog (Figure 16).
1) Go to Format > Area > Colors on the main menu bar or right-click on a selected object
and go to Area in the context menu to open the Area dialog and then click on the Colors
tab to open the colors dialog (Figure 15).

Colors and color palettes
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Figure 16: Color Picker dialog
2) Click Edit to open the Color Picker dialog, where you have three ways of selecting a color
to create and use.

•
•

Click on the colored bar to the right of the color sample area to select a color. The values
in the RGB, HSB (Hue, Saturation and Brightness) and CMYK boxes will change.
Or enter values in either the RGB, HSB or CMYK boxes to create the color. Entering
values in one set of value boxes will change the values in the other two sets of boxes.

•

Or click on the small circle in the color sample area and drag it to a new position to create
a new color.
3) The color bar below the sample color area will show the new color on the left half of this bar
so that you can compare it with the original color on the right half of this bar.
4) If you are satisfied with the color created, click OK to use the color.
5) See “Using color values” on page 19 to save the color.

Deleting colors
1)
2)
3)
4)

To delete a color from a color palette, open the color dialog (Figure 14 or Figure 15).
Select the color from the Color drop down list or the color table and click Delete.
Click Yes to confirm the deletion of the color.
Click OK to close the color dialog.

Bézier curves
In LibreOffice you can use Bézier curves in your drawing. A curve is defined by means of a start
point P0, an end point P3, and two control points P1 and P2 (Figure 17). For points on the curve, the
terms nodes or anchors are often used. For the mathematical background of Bézier curves, see
http://en.wikipedia.org/wiki/Bezier_curve.
Bézier curves are very useful for experimenting with the shape and form of curves. In point mode
you can change the curve alignment by dragging the points with the mouse. The curve leaves the
start point P0 in the direction of the control point P1 and arrives at the end point P3 from the
direction of the control point P2. The more distant a control is from its start or end point the smaller
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the curvature at that point. If a control point lies directly on one of these points, it has no influence
on the curve.

Figure 17: Points in Bézier curves

Drawing a Bézier curve
1) Click on the small triangle to the right of the Curve icon
on the Drawing toolbar to
open the Lines toolbar (Figure 18). The Curve icon will show the last tool selected from the
Lines toolbar. To make this toolbar a floating toolbar, click at the bottom of the pop-up
toolbar and drag it onto your workspace.

Figure 18: Lines toolbar
2) Click on the Curve icon
on the Lines toolbar. Note that this may be a different icon to
the Curve icon on the Drawing toolbar.
3) Click at the start point where you want to draw the curve and, keeping the mouse button
pressed, drag the cursor to the approximate position of the end point for the curve.
4) Double-click when you have reached the end position of your curve and a curve is drawn.
The arc of the curve is determined by the distance you have dragged to create the end
point.

Note

If you single-click when you have reached the end point of your curve, you will
continue drawing straight lines until you double-click to end the drawing of a curve.

5) Click on the Points icon
on the Drawing toolbar or press the F8 key to open the Edit
Points toolbar (Figure 19).
6) Click once on your curve to display the start and end points. The colored square marking
the start point of the curve is larger than the one at the end point.
7) Move the cursor over the start or end point and drag it to the position where you want the
control point to be. The control point appears at the end of a dashed line connected to the
point you have selected (Figure 21).
8) When you have the correct position, release the cursor and the control point remains
active.
9) Click on the control point and drag it to change the shape of the curve.
10) When you have finished editing your curve, click anywhere on your workspace to deselect
the curve and stop editing points.
Bézier curves
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Figure 19: Edit Points toolbar

Figure 20: Edit Points tools

Figure 21: Control points on a curve

Edit Points tools
The tools available on the Edit Points toolbar (Figure 19 and Figure 20), allow you to edit and change
the shape of a Bézier curve:

• Points – allows you to activate or deactivate the edit mode for Bézier objects. In the edit
mode, individual points of the drawing object can be selected.

• Move Points – activates a mode in which you can move points. The mouse pointer
displays a small empty square when resting on a point. Drag that point to another location.
The curve on both sides of the point follows the movement; the section of the curve
between points changes shape. Point at the curve between two points or within a closed
curve and drag the mouse to shift the entire curve without distorting the form.

• Insert Points – activates the insert mode and allows you to insert points. You can also
move points, just as in the move mode. If, however, you click at the curve between two
points and move the mouse a little while holding down the mouse button you insert a new
point. The point is a smooth point, and the lines to the control points are parallel and remain
so when moved. If you wish to create a corner point you must first insert either a smooth or
a symmetrical point which is then converted to a corner point by using Corner Point.
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• Delete Points – used to delete one or several selected points. If you wish to select several
points, click the appropriate points while holding down the Shift key. First select the points
to be deleted, and then click this icon or press Delete key.

• Split Curve – this tool splits a curve. Select the point or points where you want to split the
curve, then click.

• Convert To Curve – converts a curve into a straight line or a straight line into a curve. If
you select a single point, the portion of the curve before the point will be converted. If two
points are selected, the curve between both points will be converted. If you select more
than two points, each time you click this icon, a different portion of the curve will be
converted. If necessary, round points are converted into corner points and corner points are
converted into round points. If a section of the curve is straight, the end points of the line
have a maximum of one control point each. They cannot be modified to control points
unless the straight line is converted back to a curve.

• Corner Point – converts the selected point or points into corner points (Figure 22). Corner
points have two movable control points, which are independent of each other. A curved line
does not go straight through a corner point, but forms a corner.

Figure 22: Corner point

• Smooth Transition – converts a corner point or symmetrical point into a smooth point
(Figure 23). Both control points of the corner point are aligned in parallel and always move
simultaneously. The control points may be different in length, allowing you to vary the
degree of curvature.

Figure 23: Smooth transition point

• Symmetric Transition – converts a corner point or a smooth point into a symmetrical point
(Figure 24). Both control points of the corner point are aligned in parallel and have the
same length. They can only be moved simultaneously and the degree of curvature is the
same in both directions.

Figure 24: Symmetric transition point

• Close Bézier – closes a line or a curve. A line is closed by connecting the last point with
the first point, indicated by an enlarged square.

• Eliminate Points – marks the current point or the selected points for deletion. This
happens in the event that the point is located on a straight line. If you convert a curve or a
Bézier curves
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polygon with the Convert to Curve tool into a straight line or you change a curve with the
mouse so that a point lies on the straight line, it is removed. The angle from which the point
reduction is to take place can be set by going to Tools > Options > LibreOffice Draw >
Grid.

Adding comments to a drawing
Draw supports comments similar to those in Writer and Calc.
1) Go to Insert > Comment in the main menu bar. A comment box appears with a small
marker box containing your initials in the upper left-hand corner of your drawing. Draw
automatically adds your name and the date at the bottom of the comment (Figure 25).
2) Type or paste your comment into the text box.
3) To apply basic formatting to the text, right-click and select the formatting option from the
context menu.
4) To delete a comment, right-click on the comment or marker box and select an option from
the context menu or click on the small triangle in the bottom right of the comment and
select an option from the context menu.
5) To move a comment, click on the small marker box and drag it to a new position on your
drawing.
6) To show or hide the comments, go to View > Comments.

Figure 25: Comment in a drawing

Note

For your initials and name to appear in a comment, you have to enter your user data.
Go to Tools > Options > LibreOffice > User Data and enter all the necessary data.
If more than one person edits the document, each author is automatically allocated a
different background color.

Connecting and breaking lines
It is possible in Draw to connect separate line elements together making one line, or break a line
that has been created from separate elements.
Select a number of lines and go to Modify > Connect. The lines are converted to curves and
adjacent end points are joined together. The resulting shape is a polyline, not a closed shape.
Select a line that is composed of separate elements and go to Modify > Break. Each separate
element is now indicated with start and end points. Click on an element and drag it to a new
position.
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