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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Putting together a slide show
LibreOffice Impress gives you the tools to organize and display a slide show, including:

•
•
•
•
•

Which slides to show and in what sequence
Whether to run the show automatically or manually
Transitions between slides
Animations on individual slides
Interactions: what happens when you click a button or link

Most tasks associated with putting together a slide show are best done in Slide Sorter view.
Choose View > Slide Sorter from the main menu or click the Slide Sorter tab at the top of the
Workspace pane. All of your slides appear in the workspace; you may need to scroll to see them
all.

Basic settings for a slide show
Basic settings for a slide show include which slide to start from, the way you advance the slides,
the type of presentation, and pointer options.
Select Slide Show > Slide Show Settings. From the main menu to open the Slide Show dialog
(Figure 1).

Figure 1: Selecting slide show settings
In the Range section, select which slides to include in the slide show:

• All slides: includes all of the slides except for those marked Hidden (see “Hiding slides” on
page 6). Slides are shown in the sequence they occur in the file. To change the sequence,
either rearrange the slides in the slide sorter or choose a custom slide show (see below).

• From: starts the show at a slide other than the first. For example, you might have several
slides at the beginning that describe you and your company, but when you present this
show to your work colleagues, you want to skip that introduction.
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• Custom Slide Show: shows the slides in a different sequence that you have previously set
up. This setting is not available until you have set up a custom slide show (see “Showing
slides in a different order” on page 6). You can set up as many different custom shows as
you wish from one set of slides; they will appear in the drop-down list under this choice.
In the Type section, select how the slides will be displayed:

• Default: shows the slides full screen, without the LibreOffice program controls visible, and
exits the show after the last slide.

• Window: runs the slide show in the LibreOffice program window and exits the show after
the last slide.

• Auto: restarts the slide show after the last slide. A pause slide is displayed between the
last slide and the start slide. Press the Esc key to stop the show. In the box, specify the
length of time before the show restarts. If you enter zero, the show restarts immediately
without showing a pause slide. The Show Logo option shows the LibreOffice logo on the
pause slide.
In the Options section:

• Change slides manually: prevents slides from changing automatically even if an
automatic transition has been set up.

• Mouse pointer visible: shows the mouse pointer during a slide show. If you do not have a
laser pointer or other device to highlight items of interest during the show, this can be
useful.

• Mouse pointer as pen: enables you to write or draw on slides during the presentation.
Anything you write with the pen is not saved when you exit the slide show. The color of the
pen cannot be changed.

• Navigator visible: displays the Navigator during the slide show. For more information on
the Navigator, see Chapter 1 Introducing Impress of this guide.

• Animations allowed: displays all frames of animated GIF files during the slide show. If this
option is not selected, only the first frame of an animated GIF file is displayed. This has
nothing to do with the slide animations described in “Using slide animation effects” on page
10.)

• Change slides by clicking on background: advances to the next slide when you click on
the background of a slide. You can also press the spacebar on the keyboard to advance to
the next slide.

• Presentation always on top: prevents any other program window from appearing on top
of the presentation.
In the Multiple displays section:

• You can select which display to use for full screen slide show mode. Only available if the
current desktop is displayed on more than one monitor.

• If the current desktop is displayed on only one monitor, or if the multiple-display feature is
not supported on the current system, you cannot select another display.

• By default the primary display is used for slide show mode.
Note

This multiple displays setting is not a property saved in the document, but is instead
saved as a local setting in the user configuration. This means that if you open the
presentation on a different computer the local settings are applied.

Putting together a slide show

5

Hiding slides
You may not want to show all of the slides in a particular slide show. You can either hide some of
the slides or set up a custom slide show; whichever method suits your requirements. For example,
you may have draft slides that you do not want to show until they are finished, or you may have
some slides that contain information for yourself, but not your audience.
To hide a slide:
1) In the Slides pane, or in Slide Sorter view, select the slides that you want to hide.
2) Click the Hide Slide icon
on the Slide View toolbar (Figure 2), right-click and select
Hide Slide from the context menu, or select Slide Show > Hide Slide on the main menu.
The slide is now displayed greyed out to indicate that it is hidden (Figure 3). The slide is not
deleted and remains in the file.

Figure 2: Slide View toolbar

Figure 3: Slide 2 is hidden
To show a hidden slide:
1) In the Slides pane, or in Slide Sorter view, select the hidden slides that you want to show.
2) Click the Show Slide icon
on the Slide View toolbar (Figure 2), right-click and select
Show Slide from the context menu, or select Slide Show > Show Slide on the main
menu.

Showing slides in a different order
To show the slides in a different order, you can either rearrange them in the slide sorter, or set up a
custom slide show. You can define as many custom slide shows as you require from one set of
slides.
In a custom slide show, you can select which slides to include as well as the order in which they
are shown. Any slides marked Hidden will not appear in a custom show.

Setting up a custom slide show
To set up a new custom slide show:
1) Choose Slide Show > Custom Slide Show from the main menu to open the Custom Slide
Shows dialog (Figure 4).
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Figure 4: Custom Slide Shows dialog

Figure 5: Defining a custom slide show
2) Click on New and the the Define Custom Slide Show dialog opens (Figure 5).
3) Type a name for the new custom show in the Name text box.
4) In the Existing slides list, select the slides to include in the show. Click the >> button to
include the slides in the Selected slides list. In Figure 5, the first three slides have been
selected.
5) You can select and include several slides at the same time. Hold down the Shift key and
click the first and last slide in a group to select that group, or hold down the Control key and
click on individual slides to select them.

Note

If you include several slides at the same time, they are added to the Selected slides
list in the order they appear in your presentation regardless of the order in which you
selected them. To put the selected slides in a different order, either select and include
each slide individually or select a slide and drag it up or down in the selected slide
list. You can also use the Slide Sorter view to rearrange the order of slides before
making your selection.

Putting together a slide show
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Tip

Slides are added to the Selected slides list after whichever slide is currently
highlighted in the list. By default, the last slide added is highlighted unless you have
selected a different one. For example, in Figure 5, to add the slide Final Slide
Example after the Default Example and before Shapes, make sure that Default
Example is highlighted before moving Final Slide Example into Selected slides.

6) When you have finished arranging the order of the slides, click OK to save this custom
show and return to the Custom Slide Shows dialog box.
7) To activate a custom show, select it in the list in the Custom Slide Shows dialog box and
then select the Use Custom Slide Show option at the bottom.

Editing, deleting, or copying a custom slide show
To edit a custom slide show (add, remove, or change the order of slides, or change the name of
the show), select it in the Custom Slide Shows dialog (Figure 4) and click Edit.
To delete a custom slide show, select it in the Custom Slide Shows dialog and click Delete.
Deletion is immediate; no confirmation message appears.
To create a copy of a slide show, select it in the Custom Slide Shows dialog and click Copy. You
can now edit the copy by renaming and adding, removing, or changing the order of slides in it.
You can run or test your custom slide show from the Custom Slide Shows dialog, if the Use
Custom Slide Show checkbox is selected. Select the slide show from the list and click on Start.
When you have finished working with custom slide shows, click Close to save all changes and
close the Custom Slide Shows dialog.

Using slide transitions
Slide transitions are the effects that take place between slides when slides change in a
presentation. Transitions add dynamic flair to a slide show, smoothing the change over between
slides.
1) In the Tasks pane, choose Slide Transition (Error: Reference source not found).
2) In the Slides pane or Slide Sorter view, select the slides to which you want to apply the
transition. If you want the transition to apply to all slides, do not select any slides.
3) In the Apply to selected slides list, select a transition.
4) Modify the selected transition by changing the speed or adding a sound, in the Modify
transition section. If you decide to play a sound during transitions, select a sound from the
Sound list. The Loop until next sound option now becomes active. Select this option to
play the sound repeatedly until another sound starts. If there are no subsequent sounds in
your slide show, the selected sound will play continuously for the remainder of the show.
5) Select how to advance to the next slide: manually (on mouse click) or automatically. If you
choose automatically, you can specify how long the slide remains visible before it
automatically advances to the next slide.
6) If you want the transition to apply to all slides, click the Apply to All Slides button.
7) To start the slide show from the current slide so you can check your transitions, click the
Slide Show button.
8) If the Automatic preview checkbox is marked, the effect of a selected transition is
immediately displayed in the work area. You can replay the effect at any time by pressing
the Play button.
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Figure 6: Slide transitions

Tip

You can apply a single type of transition to all slides in the presentation or apply a
different transition to any single slide, even having a different transition for every slide
in the show. While using many different transitions may be fun to do, it may not give
your slide show a professional appearance.

Tip

If you want most of the slides to have the same transition with a few different
transitions, you may find it easier to apply one transition to all slides and then change
only the ones you want to be different.

Setting the timing of automatic slide changes
You can set up a slide show to run automatically, either unattended or while you speak.
To set the default time for slides to be displayed before changing to the next slide:
1) Go to Slide Transition in the Tasks pane (Figure 6).
2) Leave the transition effect set to No Transition.
Using slide transitions
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3) Select Automatically after in the Advance slide section.
4) Set a time and click the Apply to All Slides button.
To vary the timing for some of the slides in your slide show:
1) Select Slide Show > Rehearse Timings from the main menu, or click the Rehearse
Timings icon
on the Slide Show toolbar. The slide show begins in full-screen mode,
and a timer appears in the lower left-hand corner of the screen.
2) When you want to advance to the next slide, click the timer. To keep the default setting for
this slide, click the slide, not the timer.
3) Continue until you have set the timing for all slides in your presentation. Impress records
the display time for each slide. When you next look at the time set under Automatically
after, you will see that the times have changed to match what you set when rehearsing.
4) To exit from the rehearsal, press the Escape key or right click on the slide and select End
Show.
If you want the whole presentation to auto-repeat, open the Slide Show dialog (Figure 1) by going
to Slide Show > Slide Show Settings on the main menu. Click on Auto and then OK.

Playing a sound throughout a presentation
You can use the Slide Transition pane so that a sound or a song is played throughout the
presentation.
1) Select the slide where you want the sound to start and go to the Slide Transition pane.
2) In the Modify transition section, select Other sound from the Sound drop-down list.
3) Select Loop until next sound checkbox if you want the sound to restart once it is finished.

Caution

Note

Do not click the Apply to all button; otherwise your selected sound will restart at
every slide.

The sound file is linked to a presentation rather than embedded; therefore if you plan
to display the presentation on a different computer, remember that you also have to
make the sound file available on the computer where the presentation will be played,
and re-establish the link to the local sound file before starting the slideshow.

Removing a transition effect
1) Select the desired slides.
2) Choose No Transition in the list on the Slide Transition page of the Tasks pane.

Using slide animation effects
Slide animations are similar to transitions, but they are applied to individual elements on a single
slide: title, chart, shape, or individual bullet point. Animations can make a presentation more lively
and memorable. Just as with transitions, heavy use of animations can be fun, but distracting and
even annoying for an audience expecting a professional presentation.
Animation effects need to be applied from Normal view so that you can select individual objects on
a single slide.
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Note

At present it is not possible to apply animation effects to the slide master elements.
This means that if you want to display the items in a text box one by one, and use the
same animation on more than one slide, you need to apply the effects to each slide,
or alternatively copy the text box from one slide to another.

Applying an animation effect
In Normal view, display the desired slide and then select the text or object you want to animate. An
object such as a graphic or an entire text box will have selection handles around it when selected.
If you choose only a portion of the text in a text box, you may not see any selection handles.

Figure 7: Custom Animation on Task pane
1) In the Tasks pane, select Custom Animation (Figure 7).
2) Click Add to open the Custom Animation dialog (Figure 8).
3) Select an effect from one of the tabbed pages of this dialog, and choose the speed or
duration of that effect.
4) Select an animation to be applied from the Entrance page when an object is placed on the
screen.

Using slide animation effects
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Figure 8: Custom Animation dialog
5) Use the Emphasis page to apply a basic effect to an object, for example changing font
color, or adding special effects such as blinking text.
6) Use the Exit page to apply an effect when an object leaves the screen.
7) If you want the object to move along a line or curve, select an animation from the Motion
Paths page. An example of this type of animation is provided in “Example: Setting up a
motion path” on page 14.
8) If required, change the speed of an effect from the Speed drop-down list before moving to
another tabbed page.
9) Select Automatic preview if you want to see how the effect works with having to run the
whole slide show.
10) Click OK to save the animation effects and return to the Custom Animation page on the
Task pane. Here you can choose how to start the animation, change the overall speed, and
apply some additional properties to the selected effect.

Starting an animation effect
You have three options from the Start drop-down list for starting an animation effect:
On click − the animation does not start until you click the mouse.
With previous − the animation runs at the same time as the previous animation.
After previous − the animation runs as soon as the previous animation ends.
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Choosing additional properties of an animation effect
Many animations have a set of properties that you can set or change. For example, for the Change
Font Color effect on the Emphasis page, you can specify the font color. If you select Fly In on the
Entrance page, you can specify the direction from which the object flies in.
The label on the Effect properties section changes depending on the effect selected. Also, the
options available in this section change depending on the selected effect. For example, a Fly In
effect has an option labelled Direction and a Change Font Color effect has an option labelled Font
color.
Clicking on the … button opens the Effect Options dialog giving you additional options to customize
the animation effect you have selected. An example of this dialog is shown in Figure 9.

Figure 9: Example of the Effect Options dialog

Example: Using multiple animation effects
To illustrate how you can set up multiple effects, we shall use a common animation: list items fly in
one at a time from the bottom of the slide, and as each new item appears, the previous items
change to a different color. Here is an example on how to create these effects:
Step 1. Apply the Fly in effect to all the items.
1) Display the Custom Animation page of the Task pane.
2) Create a slide with several items in a bullet list.
3) Select all items. Click Add on the Custom Animation in the Tasks pane.

Figure 10: Example of animated points

Using slide animation effects
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4) On the Entrance page of the Custom Animation dialog select Fly In, change the Speed to
Medium, and click OK.
5) The four animation effects set up are listed in the Custom Animation page (Figure 10).
Step 2. Apply the Change Font Color effect to some items.
Now the first three list items are going to change color when the following item appears on the
slide. To do this:
1) Select the first three items on the slide (not in the animations list) and click Add in the
Custom Animation pane.
2) Go to the Emphasis page of the Custom Animation dialog and select Change Font Color.
Click OK to save this effect.
3) Notice that three new animations are listed at the bottom of the animations list, and the icon
for type of effect is now is different from the icon for the first four effects (Figure 11).
4) You could, if you wish, select any of the last three items and choose a different color from
the Font color list on the Custom Animation pane.
5) Use the Change order: up-arrow button to move each of the last three items up the list so
that they are under the other item with the same name.

Figure 11: Second animation added
Step 3. Change timing of some list items from With previous to On click.
All of the items on the animations list (except for the two “Point one” items) are set to start at the
same time as the previous item. However, it is best that when you click to make the next point
appear the previous point is dimmed. Therefore to set the color change of the previous point and
the entrance of the new point to run on mouse click simultaneously.
1) Select the color change animations and choose On click from the Start list, then select the
entrance animations (except the first) and choose With Previous from the Start list.
2) Test this set of animations by clicking the Slide Show button.

Example: Setting up a motion path
The Motion path effect moves an object along a path consisting of a combination of straight and
curved lines. Several pre-packaged paths are provided in LibreOffice, but it is not difficult to create
your own custom path. Start by selecting the object you want to animate and selecting a prepackaged motion path animation that is similar to the effect you want to obtain. Alternatively use
the Polygon or Curve animation to create a new path.
Select the object to show the animation path, which will be displayed as a thin gray line with a
triangle showing the starting point and another indicating the end point. Click on any point on the
14
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line so that selection handles are displayed around it. When the selection handles are shown, you
can move or resize the path the same way you would perform these operations on a graphic
object.

Note

When moving a path, remember to also move the object on that path; otherwise the
animation will start with a jump. Currently it is not possible to rotate a path.

If instead you want to modify the individual points on the line, select the Points icon
from the
Drawing toolbar while the path is selected. The Edit Points toolbar (Figure 12) is displayed; if not,
select it from View > Toolbars > Edit Points. The number of icons available in the Edit Points
toolbar will depend on the type of motion path and object selected.

Figure 12: Edit Points toolbar and icons
Once a point is selected, you can add an additional point, delete it, move it and so on. For a
detailed explanation on how to manipulate the points on a curve, see the Draw Guide. Once you
are satisfied with the shape of the curve and its speed, click anywhere on the screen to deselect
the object and continue normal editing.
You can combine a motion path with other effects such as spinning or changing of size or colors to
create dramatic effects.

Advanced animation effects
Click the Effect Options button [...] next to the Properties drop-down list to display the Effect
Options dialog (Figure 9 on page 13).
What you see in the Effect Options dialog depends on the type of object selected. When a text
object is selected, the dialog has three pages: Effect, timing, and Text Animation. When a graphical
object is selected, the dialog has two pages: Effect and Timing.
The options available on the Effect page also vary depending on the type of object selected and
the type of animation selected, such as Direction effect or a Font Color effect. For graphical
objects, the Text animation box on the Effect page is unavailable.

Using slide animation effects
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On the Effect page, you can select a sound to play, whether to dim or hide the object after
animation, and (in the case of text objects) whether to animate the text all at once or word by word
or letter by letter.
On the Text Animation page of the Effect Options dialog (Figure 13), you can group text as one
object, all paragraphs at once, or by first-level paragraphs (that is, one list item together with its
sub-items, if any).

Figure 13: Text Animation page of Effect Options dialog
On the Timing page of the Effect Options dialog (Figure 14) you to change the speed, delay, and
other aspects of the timing of the effect.

Figure 14: Timing page of Effect Options dialog

Removing animation effects
1) On the Custom Animation page of the Task pane, select the desired object.
2) Click the Remove button.

Using interactions
Interactions are things that happen when you click on an object in a slide. They are typically used
with buttons or images, but text objects can also have interactions.
To apply an interaction to an object (or change an interaction applied to an object), right-click on
the object and choose Interaction from the pop-up menu to open the Interaction dialog (Figure
15). Select an interaction from the Action at mouse click drop-down list. With some interactions
the Interaction dialog changes to offer more options.

16

Slide Shows

Figure 15: Dialog box before choosing an interaction

Tip

A sound interaction can be also applied using the Effect Options dialog (Figure 9
on page 13).

Running a slide show
To run the slide show, do one of the following:

• Press F5.
• Click Slide Show > Slide Show on the main menu.
• Click the Slide Show icon on the Presentation toolbar or the Slide Sorter toolbar.
If the slide transition is Automatically after x seconds, let the slide show run by itself.
If the slide transition is On mouse click, do one of the following to advance from one slide to the
next.

• Press the down arrow key, the right arrow key, or the Page Down key on the keyboard.
• Click the left mouse button.
• Press the Spacebar.
To go backwards through the show one slide at a time, press the up arrow key, the left arrow key,
or the Page Up key. For more complex navigation, use the right-click menu (see “Navigating using
the right-click menu”).
Custom animations on a slide are run in the specified order when performing one of the above
actions.
When you advance past the last slide, the message Click to exit presentation... appears. Click
the left mouse button or press any key to exit the presentation.
To exit the slide show and return to the Impress workspace at any time, including at the end, press
the Esc key.

Navigating using the right-click menu
If your presentation consists of more than one slide, right-clicking anywhere on the screen brings
up a menu. The choices are:

• Next: moves to the next slide in the defined sequence.
• Previous: moves to the previous slide in the defined sequence.
• Go to Slide: displays a submenu allowing to quickly navigate through the presentation.
Options on the submenu include First slide, Last Slide, or any slide in the show. This
illustrates why giving the slides meaningful names, rather than leaving them at the default
Slide 1, Slide 2, and so on, can be very helpful.
Running a slide show
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• Screen: displays a submenu with two options. Each option blanks the screen, showing it
as either all black or all white. This can be useful if you want to pause the show for awhile,
perhaps during a break or to demonstrate something on another computer.

• End Show: ends the presentation and returns you to the Impress workspace. This is the
same effect as pressing the Esc key.

Controlling a slide show using the Presenter Console
Most installations of LibreOffice Impress come with the Presenter Console extension built in. If it is
not included, you can also get the extension and install it as described in Chapter 11, Setting up
and Customizing Impress.
The Presenter Console provides extra control over slide shows (presentations) through different
views on the computer screen the presenter is using and on the projection that the audience sees.
The presenter’s view includes the current slide, the upcoming slide, the slide notes, and a
presentation timer.

Note

The Presenter Console works only on operating systems that support two displays,
and only when two displays are connected (one may be the laptop display).

The Presenter Console provides three easily changeable views:

• First view displays the current slide, including the effects, and the upcoming slide.
• Second view shows the notes for the speaker in large, scalable type, plus the current and
upcoming slide.

• Third view is a slide sorter view with the slide thumbnails where you can select a thumbnail
to jump to a slide out of sequence.

• Lastly, the presenter can display a set of help notes with navigational and other information.
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