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Introduction

LibreOffice Impress provides the tools to organize and display a slide show, including:

• Which slides to show and in what sequence.

• Whether to run the show automatically or manually.

• Transitions between slides.

• Animations on individual slides.

• Interactions: what happens when clicking on a button or link.

• A presenter console.

Creating slide shows

Basic settings
Most tasks associated with putting together a slide show are best done in Slide Sorter view 
where all of the slides in the presentation appear in the Workspace.

1) Open the Slide Sorter view (Figure 1) using one of the following methods:

– Go to View > Slide Sorter on the Menu bar.

– Click on the Slide Sorter tab at the top of the Workspace.

2) Go to Slide Show > Slide Show Settings on the Menu bar to open the Slide Show 
Settings dialog (Figure 2).

3) Select the options required for the slide show.

4) Click OK to save the changes and close the Slide Show Settings dialog.

Figure 1: Slide Sorter view
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Figure 2: Slide Show Settings dialog

Slide Show options

• Range – select which slides to include in the slide show.

– All slides – includes all slides except for those slides marked Hidden (see “Hiding 
slides” on page 6). Slides are shown in the sequence they occur in the file. To change 
the sequence, either rearrange the slides in Slide Sorter view or select the custom 
slide show option.

– From – starts the show at the slide selected from the drop-down list. For example, 
there maybe several slides at the beginning that describe the company, but when 
presenting this slide show to work colleagues, this introduction could be skipped.

– Custom slide show – shows the slides in a different sequence from the sequence 
previously setup. This setting is not available until a custom slide show has been 
setup (see “Custom slide show” on page 7). Many different custom shows can be 
setup as required from one set of slides and they appear in the drop-down list for this 
option.

• Presentation Mode – select how the slides are displayed.

– Full screen – shows the slides full screen without the LibreOffice program controls 
visible and exits the show after the last slide.

– In a window – runs the slide show in the Impress window and exits the show after the 
last slide.

– Loop and repeat after – restarts the slide show after the last slide has displayed and 
after the specified time delay. Setting of this option allows the slide show to 
automatically run continuously. A pause slide is displayed between the last slide and 
the start slide. Press the Esc key at any time to stop the show. If zero is entered as 
time delay, the show restarts immediately without showing a pause slide.
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– Show logo – shows the LibreOffice logo on the pause slide when Loop and repeat 
after option is selected.

Note

Before selecting the option Loop and repeat after, make sure that the option After is 
selected and that an interval time setting has been entered. The option After is in 
Advance slide options located in the Slide Transitions deck on the Sidebar (Figure 7
on page 10). If there is no interval time setting for After, then the option Loop and 
repeat after will not function.

• Options – determine how the slide show runs as a presentation.

– Change slides manually – prevents slides from changing automatically even if an 
automatic transition has been set up.

– Mouse pointer visible – shows the mouse pointer during a slide show. If a laser pointer
or other device is being used to highlight items of interest during the show, this can be
useful.

– Mouse pointer as pen – enables writing or drawing on slides during the presentation. 
Anything written with the pen is not saved when exiting the slide show. The color of 
the pen cannot be changed.

– Animations allowed – displays all frames of animated GIF files during the slide show. 
If this option is not selected, only the first frame of an animated GIF file is displayed. 
This has nothing to do with the slide animations described in “Animations” on page 12.

– Change slides by clicking on background – advances to the next slide when the slide 
background is clicked. Also, pressing the spacebar advances to the next slide.

– Presentation always on top – prevents any other program window from appearing on 
top of the presentation.

• Multiple Displays – determines how the slide show is displayed.

– Presentation display – select from the drop-down list which display to use for full 
screen slide show mode. Only available if the computer being used for the slide show 
is connected to more than one display monitor.

Note

The multiple displays setting is not an option saved with the presentation file, but is 
instead saved as a local setting in the user configuration for the computer. This 
means that if the presentation is opened on a different computer, the local settings 
for that computer are applied.

Hiding slides
Some slides may not be required in a particular slide show. Either hide some of the slides or set 
up a custom slide show to suit the requirements. For example, there maybe draft slides that are 
not shown until they are finished, or there maybe some slides that contain information that is not 
to be shown to an audience.

Hiding slides
1) In the Slides pane, or Slide Sorter view in the Workspace, select the slides that are to be

hidden.
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Figure 3: Slide 2 hidden

Figure 4: Slide View toolbar

2) Hidden slides are displayed greyed out indicating that it is hidden as shown in Figure 3. 
The slide is not deleted and remains in the presentation file. Hide selected slides using 
one of the following methods:

– Click on Hide Slide in the Slide View toolbar (Figure 4).

– Right-click on the selected slide and select Hide Slide from the context menu.

– Go to Slide > Hide Slide on the Menu bar.

Showing hidden slides
1) In the Slides pane, or Slide Sorter view, select the hidden slides.

2) Show the selected slides using one of the following methods. Show Slide is only active 
when there hidden slides are selected in a presentation.

– Click on Show Slide in the Slide View toolbar.

– Right-click on the selected slide and select Show Slide from the context menu.

– Go to Slide > Show Slide on the Menu bar.

Custom slide show
To show the slides in a different order, rearrange the slides in the Slides pane or Slide Sorter 
view in the Workspace, or create a custom slide show. In a custom slide show, select which 
slides to include as well as the order in which they are shown.

Creating custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 

Shows dialog (Figure 5).

2) Click on New to open the Define Custom Slide Show dialog (Figure 6).

3) Type a name for the new custom slide show in the Name text box.
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Figure 5: Custom Slide Shows dialog

Figure 6: Define Custom Slide Shows dialog

4) In the Existing slides box, select the slides using one of the following methods:

– Click on an individual slide to select it.

– Hold down the Shift key and click the first and last slide to create a consecutive group 
of slides.

– Hold down the Ctrl key (macOS ) and click on individual slides to create a group of ⌘
slides.

5) Click on >> to include the slides in the Selected slides box.

6) If required, rearrange the slide order in the Selected slides box by clicking on a slide 
name and dragging it to a new position in the list.

7) Click OK to close the Define Custom Slide Shows dialog.

8) Click on Start to test the custom slide show as a presentation.

9) Click OK to save the custom slide show and close the Custom Slide Shows dialog.
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Using custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 

Shows dialog.

2) Select the required custom slide show and click on Start to run the selected custom slide 
show.

3) When the presentation is over, click OK to close the Custom Slide Shows dialog.

Editing custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 

Shows dialog.

2) Select the name of the custom slide show for editing.

3) Click on Edit and the Define Custom Slide Show dialog opens.

4) Add slides, remove slides, change the slide order, or change the name of the custom 
slide show in the Define Custom Slide Show dialog.

5) Click OK to save the custom slide show and close the Custom Slide Shows dialog.

6) Click OK to close the Custom Slide Shows dialog.

Copying custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 

Shows dialog.

2) Select the name of the custom slide show for copying and click on Copy. The name of 
the selected custom slide show is repeated with (Copy 1) added to the name.

3) Select the name of the copied custom slide show and click on Edit and the Define 
Custom Slide Show dialog opens.

4) Change the name of the copied custom slide show in the Define Custom Slide Show 
dialog.

5) Click OK to save the copied custom slide show and close the Define Custom Show 
dialog.

6) Click OK to close the Custom Slide Shows dialog.

Deleting custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide 

Shows dialog.

2) Select the name of the custom slide show for deletion and click on Delete. Deletion is 
immediate and no confirmation message appears.

3) Click OK to close the Custom Slide Shows dialog.

Slide transitions

Slide transitions are effects and/or sounds that take place between slides when slides are 
changed in a slide show. Transitions add a professional look to a slide show, smoothing the 
change over between slides.

Adding transitions
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 7).

2) Open the presentation file to add slide transitions.

3) In the Slides pane or Slide Sorter view, select the slide to apply a slide transition.
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Figure 7: Slide Transition deck on Sidebar

4) Click on the required transition from the displayed list to apply it to the selected slide.

5) In Modify Transition, select from the available options as follows:

– Variant – select an option from the drop-down list. The available options change 
according to the transition that has been selected.

– Duration – enter a time for how long the transition lasts.

– Sound – select a sound from the drop-down list that is played when the transition 
activates. If a sound is selected, the Loop until next sound option becomes active. 
Select this option to play the sound repeatedly until another sound starts. If there are 
no subsequent sounds in a slide show, the selected sound plays continuously for the 
remainder of the show. Sounds can be played when None is selected for the transition
effect.

6) In Advance Slide, select one of the two following options on how the slides change in a 
presentation. Only one option can be selected as follows:

– On mouse click – each time the mouse is clicked, the presentation advances to the 
next slide.

– After – enter a time in the box to elapse before the next slide in the presentation 
advances automatically into view.

Note

A time must be entered in After to automatically open the next slide and allow the 
option Loop and repeat after in Presentation Mode to function when it is required for
a slide show to automatically run continuously.
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7) If required and to apply the same transition to all slides in the presentation, click on Apply
Transition to All Slides option in Advance Slide.

8) To check how the transition looks, click on Play option in Advance Slide.

9) Alternatively, to automatically preview how the transition looks when it is applied to a 
slide, select Automatic Preview option in Advance Slide.

Tip

A single type of transition can be applied to all the slides in the slide show or a 
different transition to individual slides in the slide show. While using many different 
transitions may look good, it may make the slide show look unprofessional.

Removing transitions
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck.

2) In the Slides pane or Slide Sorter view, select the slide or slides to remove the slide 
transition.

3) Select None at the top of the available transitions in the Slide Transition deck.

Note

Slides with transitions are indicated by a star in the bottom left corner of the slide 
when viewed in the Slides pane or the Slide Sorter view.

Playing music
Music can be played during a slide show instead of a sound as a transition effect. When using 
music in a slide show, make sure any musical copyright or licensing for the music is not being 
infringed.

1) Click on Slide Transition in the Sidebar to open the Slide Transition deck.

2) Open the presentation file to add slide transitions.

3) In the Slides pane or Slide Sorter view, select the slide where music is going to be 
added as part of the slide transition.

4) In Modify Transition, select Other sound from the Sound drop-down list.

5) In the file browser window that opens, navigate to where the music file is located and 
select the music file required.

6) Click on Play to check if the music file is suitable.

7) If the music is suitable, click Open to add the music to the selected slide and close the file
browser window.

8) To play a music file continuously in the slide show, select Loop until next sound in Modify 
Transition. The music file restarts once it is finished until the next music file that is 
inserted in the slide show.

Note

Do not select the Apply Transition to All Slides option to prevent the selected music 
file restarting as each slide opens in the presentation.
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Note

The music file is linked to a slide show rather than embedded. If the slide show is 
going to be displayed on a different computer, the music file must be available on the
computer where the slide show is going to be displayed and the link to the music file 
must be established before starting the slide show.

Animations

Slide animations are similar to transitions, but are applied to individual elements in a single slide, 
such as title, chart, shape, or individual bullet point. Animations can make a presentation more 
lively and memorable. However, as with transitions, heavy use of animations can be fun, but 
distracting and even annoying for an audience expecting a professional presentation.

Animations are best applied using Normal view to make it easier to select individual objects on a 
single slide.

Note

At present it is not possible to apply animations to elements in master slides. This 
means that to display the items in a text box one by one and use the same animation
on more than one slide, the effects have to be applied to each slide. Alternatively, 
copy the animated element from one slide to another.

Figure 8: Animation deck on Sidebar
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Applying animation
On a slide, an element such as a graphic or an entire text box has selection handles around it 
when selected. If a portion of the text in a text box is selected, selection handles may not be 
displayed.

The following procedure is an example of applying an animation to an object. The options 
available for an animation depend on the Category, Effect and slide element that have been 
selected to create an animation.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) Select a slide in the Slides pane so that it appears in Normal view.

3) On the Sidebar, select Animation to open the Animation deck (Figure 8).

4) Select a slide element that is going to be animated on the slide that is displayed in 
Normal view.

5) Click on Add Effect (+ plus sign) to open the animation options and add the slide 
element into the Animation box.

6) In Category, select a category from the options in the drop-down list.

7) In Effect, select an animation effect from the available options in the Effect list.

8) In Start, select how the animation starts from the options in the drop-down list.

9) In Direction, select the direction of the animation from the drop-down list.

10) In Duration, enter a time for the duration of the animation in the box.

11) In Delay, enter a time for the delay before the animation starts in the box.

12) If more animation options are required, see “Additional animation options” on page 14 for 
more information.

13) If required, select Automatic Preview so to automatically check how the animation looks 
when it is applied to a slide element.

14) Click on Play to check how the animation looks when applied to a slide element.

Changing animation
1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) On the Sidebar, select Animation to open the Animation deck.

3) Select a slide in the Slides pane so that it appears in Normal view.

4) Select the slide element in the Animation box that has the animation effect that is going 
to be changed.

5) Use the procedure in “Applying animation” on page 13 to select a new animation effect for
the selected element.

6) Click on Play to check how the animation looks when applied to a slide element. 

Removing animation
1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) On the Sidebar, select Animation to open the Animation deck.

3) Select the slide and the animated element being removed.

4) Click on Remove Effect to remove the animation from the selected element.

Chapter 9, Slide Shows and Photo Albums | 13



Figure 9: Effect Options dialog - Effect page

Additional animation options
Some animations have additional options that can be set or changed. Available options are 
dependent on the animation selected.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) On the Sidebar, select Animation to open the Animation deck.

3) Select the slide and element to apply additional animation options.

4) Click on Options to the right of the Direction drop-down list and open the Effect Options 
dialog (Figure 9).

5) Select the options required for the animation effect. For more information on effect 
options, see “Effect options”, “Timing options” and “Text animation options” below.

6) Click OK to save the changes and close the Effect Options dialog.

Effect options
Specifies the settings and enhancements for the selected animation using the following options 
on the Effect page in the Effect options dialog (Figure 9).

• Direction – specifies the direction for the effect.

• Sound – select a sound from the drop-down list or select one of the special entries as 
follows:

– (No sound) – no sound is played during animation of the effect.

– (Stop previous sound) – the sound of the previous effect is stopped as soon as the 
current effect runs.

– Other sound – displays a file open dialog to select a sound or music file.

• After animation – select what happens after animation.

– Don't dim – no after-effect runs.
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– Dim with color – after the animation a dim color fills the shape.

– Hide after animation – hides the shape after the animation ends.

– Hide on next animation – hides the shape on the next animation.

• Dim color – select the dim color. Only available if Dim with color has been selected.

• Text animation – select the animation mode for the text of the current shape:

– All at once – animates the text all at once.

– Word by word – animates the text word by word.

– Letter by letter – animates the text letter by letter.

• Delay between characters – specifies the percentage of delay between animations if 
Word by word or Letter by letter has been selected for Text animation.

Timing options
Specifies the timing for the selected animation using the following options on the Timing page of 
the Effects Options dialog (Figure 10).

• Start – displays the start property of the selected animation effect.

– On click – the animation stops at this effect until the next mouse click.

– With previous – the animation runs immediately.

– After previous – the animation runs as soon as the previous animation ends.

• Delay – specifies an additional delay in seconds until the effect starts.

• Speed – specifies the duration of the effect in seconds.

Figure 10: Effect Options dialog - Timing page
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• Repeat – specifies when and how to repeat the current effect. Enter the number of 
repeats, or select from the list:

– none – the effect is not repeated.

– Until next click – the animation is repeated until the next mouse click.

– Until end of slide – the animation repeats as long as the slide is displayed.

• Rewind when done playing – the animated shape returns to its starting state after the 
animation ends.

• Animate as part of click sequence – allows the animation start in a normal click 
sequence.

• Start effect on click of – allows the animation start when a specified shape is clicked. 
Select the shape by its name from the drop-down list.

Text animation options
Specifies the text animation settings for the selected animation using the following options on the 
Text Animation page of the Effects Options dialog (Figure 11).

• Group text – specifies how multiple paragraphs are animated:

– As one object – all paragraphs are animated as one object.

– All paragraphs at once – all paragraphs are animated at once, but paragraphs can 
have different effects.

– By 1st level paragraphs – the first level paragraphs, including sub-level paragraphs, 
are animated one after another.

• Automatically after – if By 1st level paragraphs is selected for Group text, the 
paragraphs are animated one after the other. Enter an additional delay in seconds to 
animate subsequent paragraphs.

• Animate attached shape – deselect this box to animate only the text, not the shape.

• In reverse order – animates the paragraphs in reverse order.

Figure 11: Effect Options dialog - Text Animation 
page

Animation example
Creating animations on a slide takes practice to achieve the animation effect required. The 
following steps explains how to setup the simple example animation shown in Figure 12 using 
multiple animations. The example slide is taken from a LibreOffice presentation. It would be very 
easy to create a similar slide and recreate this example.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
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Figure 12: Animation example

2) Select a slide for animation.

3) On the Sidebar, select Animation to open the Animation deck.

4) Select the elements on the slide, then click on Add Effect (+ plus sign) to open the 
animation options on the Animation deck. The selected elements appear in the box on the
Animation deck.

5) Select the first element (Shape 11) and select Entrance from the Category drop-down list
and select the following options for the animation:

– Effect – Venetian Blinds

– Start – On click

– Direction – Vertical

– Duration – 0.50 sec

6) Select the second element (Shape 3) and select Motion Paths from the Category 
drop-down list and select the following options for the animation:

– Effect – 5 Point Star

– Start – After previous

– Duration – 10.00 sec

7) Go to Slide Show > Rehearse Timings on the Menu bar and check the animation of 
these two objects.

Using interactions

Interactions are where objects on a slide are used to create an event when clicked on with the 
mouse cursor. These objects with interactions can be buttons, images, or text objects.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.

2) Select a slide to add an interaction to an object on the slide.
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Figure 13: Interaction dialog

3) Select the object, then right-click on the object and select Interaction from the context 
menu, or go to Format > Interaction on the Menu bar. to open the Interaction dialog 
(Figure 13).

4) Select an interaction from the Action at mouse click drop-down list. The options available 
for further selection and to setup the interaction depend on the type of interaction that has
been selected.

5) Click OK to save the changes and close the Interaction dialog.

Slide shows

Running a slide show
1) Open a presentation and start the slide show using one of the following methods:

– Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the 
current slide.

– Go to Slide Show > Start from First Slide or Start from Current Slide on the Menu 
bar.

– Click on Start from First Slide on the Slide Sorter toolbar.

2) If slide transition is set to Automatically after x sec, the slide show starts and runs after 
the set time has elapsed.

3) If slide transition is set to On mouse click, use one of the following methods to advance 
the slides:

– Click the left mouse button.

– Press the down arrow key.

– Press the right arrow key.

18| Chapter 9, Slide Shows and Photo Albums



– Press the page down key.

– Press the spacebar.

4) To navigate backwards through a slide show one slide at a time, use one of the following 
methods:

– Press the up arrow key.

– Press the left arrow key.

– Press the page up key.

5) Right-click on a slide during a slide show to open a context menu with more navigation 
options. For more information on these navigation options, see”Context menu navigation 
and options” below.

6) When the last slide has displayed, the message Click to exit presentation is displayed on 
screen. Press the Esc key or click the mouse button to exit the slide show.

7) To exit the slide show and return to the Impress workspace at any time, press the Esc key
during the slide show.

Note

During the slide show, any animations on a slide are run in the configured order as 
the slide is displayed.

Context menu navigation and options
If the slide show consists of more than one slide, right-clicking on the screen opens a context 
menu displaying navigation options as follows:

• Next – moves to the next slide in the slide show.

• Previous – moves to the previous slide in the slide show.

• Go to Slide – displays a sub-context menu allowing selection and navigation to any slide
in the slide show. The list of slides shows the need to name slides in a slide show rather 
than using the default slide names of Slide 1, Slide 2, and so on. Naming slides makes it 
easier to identify the required slide.

• Mouse Pointer as Pen – allows the cursor to be used as a pen and draw on a slide to 
emphasize or explain a point.

• Pen Width – opens a sub-context menu providing options to set the width of any lines 
drawn on a slide when using the cursor as a pen.

• Change Pen Color – opens a dialog allowing changes to the line color when using the 
cursor as a pen.

• Erase all ink on Slide – deletes all lines drawn after using the cursor as a pen.

• Screen – opens a sub-context menu with a black or white color choice. This is useful if 
the slide show is going to be paused for a break or to demonstrate something else.

• End Show – ends the presentation and returns to the Impress workspace. This is the 
same effect as pressing the Esc key.

Automatic slide show repeat
1) Select a slide in Normal and open the Slide Transition deck in the Sidebar.

2) In the Advance Slide panel, make sure the option After is selected and a time setting is 
entered in the box before the next slide is advanced. For more information on transitions, 
see “Slide transitions” on page 9.
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3) Go to Slide Show > Slide Show Settings on the Menu bar to open the Slide Show 
Settings dialog.

4) In Presentation Mode, select the option Loop and repeat after and insert a time delay in 
the box before the slide show is displayed again.

5) If necessary, select Show logo if a company logo is to be displayed during the pause 
between slide shows.

6) Click OK to save the settings and close the Slide Show Settings dialog.

Slide show timing

Default timing
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck.

2) Select None in Slide Transition as the transition effect.

3) Select the option After in Advance Slide and set a time in the box.

4) Click on Apply Transition to All Slides in Advance Slide to set the default timing for the 
slide show.

5) Go to Slide Show > Start from First Slide on the Menu bar to check how the 
presentation runs.

6) If necessary, adjust the default timing until the slide show runs as required.

Variable timing
1) Select Slide Show > Rehearse Timings on the Menu bar. The slide show starts in 

fullscreen mode and a timer appears in the lower left corner of the display.

2) When advancing to the next slide, click on the timer to set the time duration for the 
displayed slide and advance to the next slide. To keep the default time duration for a 
slide, click the slide and not the timer.

3) Continue until the time duration is set for all slides in the slide show. Impress records the 
time duration set for each slide.

4) To exit from rehearsal timing of the slide show, press the Esc key, or click on the slide.

Presenter Console
LibreOffice Impress normally includes the Presenter Console as part of the LibreOffice 
installation. If the Presenter Console is not included, the extension can be downloaded from the 
LibreOffice website and installed on a computer. For more information, see Chapter 11, Setting 
up and Customizing Impress.

The Presenter Console (Figures 14, 15, and 16) provides extra control over slide shows when 
using dual displays, such as a laptop for control and a large display or projector for an audience. 
The view on the laptop display includes the current slide that can be seen by the audience, the 
next slide in the presentation, any slide notes, and a presentation timer.

Note

The Presenter Console only works with operating systems that support two displays. 
When two displays are being used, one display can be a laptop.

The Presenter Console provides the following views when making a presentation:

• Default view – displays the current slide, including any effects and the next slide in the 
presentation (Figure 14). Click on the Previous and Next arrows to navigate a 
presentation.
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• Notes view – click on Notes to switch to display any notes that accompany each slide in 
the presentation (Figure 15). Click on Notes again to return to the default view.

• Slides view – click on Slides to switch to display the slide thumbnails that are being 
used for the presentation (Figure 16). Click on Slides again to return to the default view.

• Exchange – click on this icon to switch the Presentation Console between displays.

Figure 14: Presenter Console - default view

Figure 15: Presenter Console - Notes view
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Figure 16: Presenter Console - Slides view

Photo albums

Impress can create a photo album from a set of images, usually with one photo per slide. This 
photo album can be a slide show or multimedia show with graphics, images, or photographs.

Creating photo album
1) Create a new presentation or open an existing presentation.

2) Select the slide that is going to precede the photo album. In a new presentation, this is 
the first slide.

3) Go to Insert > Media > Photo Album on the Menu bar to open the Create Photo Album 
dialog (Figure 17).

4) Click on Add to open a file browser.

5) Navigate to the folder where the photographs are located.

6) Select the photographs and click on Open. This closes the file browser and the selected 
files appear in the Create Photo Album dialog.

7) Select the number of images per slide in the Slide layout: drop-down list.

8) If required, select Add caption to each slide inserting a text box on each slide allowing a 
caption to be added to the photographs.

9) If required and there is only one image per slide, select Fill Screen for each photograph to
fill the entire slide.

10) Create the required sequence of photographs by moving the files up or down in the list of 
selected files.

11) When the sequence is ready, click Insert Slides to create the number of slides required 
for the photo album. Impress creates a presentation with as many slides that are required
to contain the photographs. The sequence of slides can be changed if necessary.
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Figure 17: Create Photo Album dialog

12) If required, move photographs between slides and create frames for photographs. For 
more information see “Editing photo albums” below.

13) If required, run the photo album as a slide show. See “Creating slide shows” on page 4 
and “Slide shows” on page 18.

Editing photo albums
When a photo album is created, the full images of photographs are placed within the boundaries 
of the slides created for the photo album. Each of the photographs in the photo album can be 
edited just like any other object that can be placed on a slide. For more information on formatting 
photographs, see the following chapters of the Impress Guide:

Chapter 4, Adding and Formatting Images

Chapter 5, Managing Graphic Objects

Chapter 6, Formatting Graphic Objects

However, to make the photo album look more attractive, frames can be added to each 
photograph in the photo album and the photographs enhanced using options available on the 
Sidebar.

Experiment with different levels for each of the following options to create the right effect for each
photograph in the photo album.

1) Select a photograph in the photo album to open the Image, Line and Effect panels in the
Properties deck on the Sidebar (Figure 18).

2) In the Image panel, adjust the following options to enhance the photograph:

– Color –– select the color mode from the drop-down list.

– Brightness –– select the brightness level as a percentage.

– Contrast –– select the contrast level as a percentage.

– Transparency –– select the transparency level as a percentage.

Chapter 9, Slide Shows and Photo Albums | 23



Figure 18: Image, Line and Effect panels in 
Properties deck on Sidebar
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Figure 19: Example photo using a line frame

Figure 20: Example photo using a soft frame

3) In the Line panel, select the following options to create a frame around the photograph. 
Figure 19 shows an example of a photo where a line frame has been added.

– Line –– select the line style from the drop-down list.

– Width –– select the line width from the drop-down list or enter a line width in the 
Custom Line Width box.

– Color –– select a color from the available color palettes, or create a custom color for 
the line frame.

– Transparency –– select the transparency level as a percentage for the line frame.

4) In the Effect panel, select the following options to create a soft frame around the 
photograph. Figure 20 shows an example of a photo where a soft frame has been added.

– Glow Radius –– adjust the radius value to apply a soft frame around the outside of 
the photograph.

– Glow Color –– select a color for the soft frame from the available color palettes.

– Glow Transparency –– enter a transparency value to adjust the transparency of the 
soft frame.

– Soft Edge Radius –– adjust the radius value to reduce the internal width of the soft 
frame and make the photograph look smaller.
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