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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer system

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open Styles & Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
This chapter describes some common customizations that you may wish to do.
You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first
save them in a document and then save the document as a template as described in
Chapter 10, Working with Templates.

Customizing menu content
In addition to changing the menu font (described in Chapter 2, Setting up Writer), you can add to
and rearrange categories on the menu bar, add commands to menus, and make other changes.
To customize menus:
1) Choose Tools > Customize.
2) On the Customize dialog, go to the Menus page.

Figure 1: The Menus page of the Customize dialog
3) In the Save In drop-down list, choose whether to save this changed menu for the
application (Writer) or for a selected document.
4) In the section LibreOffice Writer Menus, select from the Menu drop-down list the menu
that you want to customize. The list includes all the main menus as well as submenus, that
is menus that are contained under another menu. For example, in addition to File, Edit,
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View, and so on, there is File | Send and File |Templates. The commands contained in the
selected menu are shown in the central part of the dialog.
5) To customize the selected menu, click on the Menu or Modify buttons. You can also add
commands to a menu by clicking on the Add button. These actions are described in the
following sections. Use the up and down arrows next to the Entries list to move the
selected menu item to a different position.
6) When you have finished making all your changes, click OK to save them.

Creating a new menu
In the Menus page of the Customize dialog, click New to display the Move Menu dialog, shown in
Figure 2.
1) Type a name for your new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into the required position on
the menu bar.
3) Click OK to save.
The new menu now appears on the list of menus in the Customize dialog.
After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 6.

Figure 2: Adding a new menu

Modifying existing menus
To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these
modifications can be applied to all the entries in the Menu list. For example, Rename and Delete
are not available for the supplied menus, and Move is not available for submenus.
To move a menu (such as File), choose Menu > Move. The dialog shown in Figure 3 opens. Use
the up and down arrow buttons to move the menu into the required position.

Customizing menu content
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Figure 3: Moving a menu
To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.
To rename a custom menu, selecting it in the Menu list, click the Menu button in the upper section
of the page, and select Rename.
To rename supplied menu items, supplied submenus, and custom submenus, select the item in the
Entries list, click the Modify button in the Menu Content section of the dialog, and select Rename.

Note

Changes to the menus are not immediately displayed. Changes saved to LibreOffice
Writer's menu are displayed the next time Writer is opened. Changes saved to a
document's menu are displayed the next time the document is opened.

In addition to renaming, you can allocate a letter in a custom menu's name, which will become
underlined, to be used as a keyboard shortcut, that allows you to select that menu when you press
Alt + that letter. Existing submenus can be edited to change the letter which is used to select them
from the keyboard once the menu is open.
1) Select a custom menu or a submenu in the Menu drop-down list.
2) Click the Menu button and select Rename.
3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to
select the Send submenu command by pressing S (after opening the File menu using
Alt+F), enter ~Send. This changes it from the default d.

Note

It is possible to use a letter already in use in the menu list (for example, in the Insert
menu, the letter v is used in Envelope and in Movie and sound as an accelerator).
However, you should use an unused letter if possible, to make it simpler for the user
to navigate.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of
the dialog. The Add Commands dialog is displayed.
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Figure 4: Adding a command to a menu
On the Add Commands dialog, select a category and then the command, and click Add. The dialog
remains open, so you can select several commands. When you have finished adding commands,
click Close. Back on the Customize dialog, you can use the up and down arrow buttons to arrange
the commands in your preferred sequence.

Tip

You can also add a command to a menu by clicking on it and dragging to the Menu
list on the Customize dialog. Choose the menu you want to modify before dragging
the command. Thus, you can also place the command in your preferred location.
This procedure works too when you add a command to a toolbar (see “Adding a
command to a toolbar” on page 9).

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.
To begin, select the menu or submenu to be modified, from the Menu list near the top of the
Customize page, then select the entry in the Entries list under Menu Content. Click the Modify
button and choose the required action from the drop-down list of actions.
Add Submenu does just that. After adding a submenu, it can be selected in the Menu list in the
top section of the page and another submenu can be nested within it.
Add Separator adds a separator line after the highlighted entry.
Rename allows you to rename the entries and to modify the accelerator letter used in the menu
entry for items other than submenus (see “Modifying existing menus“ on page 5).
Delete removes the selected entry from the Entries list.

Customizing menu content
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Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. This section describes how to create new toolbars and add or delete icons on existing
ones.

Figure 5: The Toolbars page of the Customize dialog
To get to the toolbar customization dialog, do any of the following:

• On the toolbar, right-click in the toolbar and choose Customize Toolbar.
• Choose View > Toolbars > Customize from the menu bar.
• Choose Tools > Customize from the menu bar and go to the Toolbars page.

Modifying existing toolbars
To modify an existing toolbar:
1) In the Save In drop-down list, choose whether to save this changed toolbar for the
application (Writer) or for a selected document.
2) In the section LibreOffice Writer Toolbars, select from the Toolbar drop-down list the
toolbar that you want to modify.
3) Click on the Toolbar or Modify buttons to edit or remove items on the toolbar, and add
commands to a toolbar by clicking on the Add button. You can also create a new toolbar by
clicking on the New button. These actions are described in the following sections.
4) When you have finished making all your changes, click OK to save them.
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Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.
1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and
click the Add button in the Toolbar Content section of the dialog.
2) The Add Commands dialog (Figure 4) is the same as for adding commands to menus.
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.
3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.
4) When you are done making changes, click OK to save.

Tip

You can also add a command to a menu by clicking on it and dragging to the toolbar
on the Customize dialog. Choose the toolbar you want to modify before dragging the
command. Thus you can also place the command in your preferred location.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
To choose an icon for a command, select the command in the Toolbar Content – Commands list in
the Customize dialog, and click Modify > Change icon. On the Change Icon dialog, you can scroll
through the available icons, select one, and click OK to assign it to the command.
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons must be 16×16 in size and cannot contain
more than 256 colors.

Figure 6: Change Icon dialog

Customizing toolbars
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Example: Adding a Fax icon to a toolbar
You can customize LibreOffice so that a single click on an icon automatically sends the current
document as a fax.
1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more
information.
2) Choose Tools > Options > LibreOffice Writer > Print. The dialog shown in Figure 7
opens.

Figure 7: Setting up LibreOffice for sending faxes
3) Select the fax driver from the Fax list and click OK.
4) Right-click in the Standard toolbar. In the drop-down menu, choose Customize Toolbar.
The Toolbars page of the Customize dialog appears (Figure 5). Click Add.
5) On the Add Commands dialog (Figure 8), select Documents in the Category list, then
select Send Default Fax in the Commands list. Click Add, and then click Close. Now you
can see the new icon in the Commands list of the Toolbars page.
6) In the Commands list, click the up or down arrow button to position the new icon where you
want it. Click OK and then click Close. Your toolbar now has a new icon to send the current
document as a fax.
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Figure 8: Adding a Send Fax command to a toolbar

Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize > Toolbars from the menu bar.
2) Click New. On the Name dialog, Figure 9, type the new toolbar’s name and choose from
the Save In drop-down list where to save this changed menu: for the application (Writer) or
for a selected document.

Figure 9: Create a new toolbar
The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described above.

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite.

Assigning shortcut keys
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Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined
shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, especially if other users share your
computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Choose Tools > Customize > Keyboard. The Customize dialog opens.
2) To have the shortcut key assignment available in all components of LibreOffice, select the
LibreOffice button; to have it available only in Writer, select the Writer button.
3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut key in the Shortcut keys list at the top of the page and click
the Modify button on the right. The selection now appears in the Keys list on the lower
right.
5) Click OK to accept the change. Now the chosen shortcut key will execute the function
chosen in step 3 above whenever it is pressed.
Repeat as required.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that no key combination has been
chosen for the selected function. If it is not empty, and you click Modify, the shortcut
key combination is added to the shortcut key(s) already assigned to the currently
selected function.
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style and
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.
1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog
(Figure 10) opens.
2) To have the shortcut key assignment available only for Writer, select Writer in the upper
right corner of the page; otherwise select LibreOffice to make it available to every
component.
3) Choose the shortcut key you want to assign a style to. In this example, we have chosen
Ctrl+9. This enables the Modify button.
4) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the ► (or + sign, depending on your operating system) to expand the list of
styles.
5) Choose the category of style. (This example uses a paragraph style, but you can also
choose character styles and others.) The Function list will display the names of the
available styles for the selected category. The example shows some of LibreOffice’s
predefined styles.
6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.
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7) Make any other required changes, and then click OK to save these settings and
close the dialog.

Figure 10. Defining keyboard shortcuts for applying styles

Example: Assigning macros to shortcut keys
A common use for assigning macros to shortcut keys is to enable quick and easy insertion of
special characters. This example shows how to set up keyboard shortcuts for inserting en-dashes
and em-dashes.

Note

To enable macro recording, go to Tools > Options > LibreOffice > Advanced and
select the Enable macro recording option. By default, this feature is turned off when
LibreOffice was installed on your computer.

First, you need to record a macro for inserting each type of dash. Then, you need to assign those
macros to shortcut key combinations.
1) Choose Tools > Macros > Record Macro to start recording a macro.
2) A small window is displayed, Figure 11, so you know that LibreOffice is recording. (This
window may look slightly different on different operating systems.)

Figure 11: Record macro

Assigning shortcut keys
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3) Choose Insert > Special Characters to open the Special Characters dialog. Scroll down
until you find the en-dash (U+2013), Figure 12, and em-dash (U+2014) characters. Select
one of them and click OK.

Figure 12: Find and choose the en-dash
4) Click the Stop Recording button to stop recording, save the macro, and display the
LibreOffice Basic Macros dialog (see Figure 13). Type a descriptive name for the new
macro in the Macro name box on the upper left.
5) Be sure to open the library container named My Macros. Find the library named Standard
under My Macros. Select Module1 and click Save.
6) Repeat steps 1–4 to create other macros, for example to insert an em-dash.
7) Choose Tools > Customize > Keyboard tab (Figure 14). In the Shortcut keys list, pick an
unused combination (for example, Ctrl+Shift+N for an en-dash). In the Category list, scroll
down to LibreOffice Macros, click the ► (or + sign, depending on your operating system),
click the ► (or +) next to user, then click the ► (or +) next to Standard and choose
Module1. In the Function list, choose en_dash and click the Modify button on the upper
right. The selected key combination now appears in the Keys list on the lower right, and
en_dash appears next to Ctrl+Shift+N in the Shortcut keys list.
8) Repeat for the em-dash macro, selecting perhaps Ctrl+Shift+M for the shortcut key and
then click OK.

Tip
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For inserting en- and em-dashes, and other special characters, you may find
extensions such as Compose Special Characters useful. See “Adding functionality
with extensions” on page 17.

Customizing Writer

Figure 13: Naming the new macro and storing it

Figure 14: Defining keyboard shortcuts for running macros
Assigning shortcut keys
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Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button on the Customize
dialog (Figure 10).
2) In the Save Keyboard Configuration dialog, Figure 15, select All files from the Save as Type
list.
3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.
4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Figure 15: Save Keyboard Configuration

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load
button on the Customize dialog, and then select the configuration file from the Load Keyboard
Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.
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Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. For example, a common use is to assign the “open
document” event to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros, in the Getting Started guide.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Several extensions are shipped bundled with LibreOffice and are installed with the program.
Others can be downloaded from various websites. The official extension repository is located at
http://extensions.libreoffice.org/. These extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
Extensions can be installed in any of three ways.
1) Directly from the *.oxt file in your system's file browser.
2) From your web browser if it can be configured to open this file type from a web page
hyperlink.
3) Directly from Tools > Extension Manager by clicking Add.
To install directly from a saved *.oxt file on your system, double-click the file.
To install from a suitably enabled web browser, select the hyperlink, and then select to Open the
file.
To install directly from Extension Manager:
1) In LibreOffice, select Tools > Extension Manager from the menu bar. You can deselect the
Installation option (which covers extensions bundled with LibreOffice) to easier view those
extensions that have been added by a user.
2) In the Extension Manager dialog (Figure 17), click Add.
3) A file browser window opens. Find and select the extension you want to install and click
Open.
4) Users with administrator or root privileges will see a dialog where they can choose to install
extensions "for all users" (shared) or "only for me" (user). Normal users without those
privileges can install, remove, or modify extensions only for their own use (user).

Figure 16: Dialog showing the installation choices
5) The extension begins installing.
Adding functionality with extensions
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6) In all three cases, during the process you may be asked to accept a license agreement.
When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip

To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online link. You do not need to
download them separately.

Figure 17: Using the Extension Manager
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