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Introduction
Although Draw does not match the functionality of leading drawing or picture editing programs, it is
capable of producing and editing 3D drawings and pictures. 3D objects can be created using one
of the following methods:

•
•
•
•

Extrusion – creates a 3D shape.
Rotation – creates a 3D scene.
Conversion – creates a 3D scene.
Ready-made 3D objects which are 3D scenes.

3D object types
3D shapes
A 3D shape is created when a 2D object or text from the Fontwork Gallery is turned into 3D using
extrusion with the Extrusion On/Off icon
on the Drawing or 3D-Settings toolbars. The Status
bar displays Shape selected when this type of 3D object is selected.
A 3D shape can be viewed and edited in 2D mode by clicking on the Extrusion On/Off icon. To
switch back to 3D mode, click the Extrusion On/Off icon again.
Any changes you want to make to the 3D effects used for a 3D shape are carried out using the 3DSettings toolbar.

Note

The Extrusion On/Off icon only becomes available for use when you select a 2D
object, or a 3D object that has been extruded from a 2D object.

3D scenes
3D scenes are built from objects which have dimensions using x, y, and z coordinates. The Status
bar displays 3D scene selected when a 3D object is selected that has been created from a 2D
object using body rotation or conversion, or it is a ready-made 3D object that has been inserted
into your drawing.
When you create a 3D scene from a selection of more than one 2D object, a group is automatically
created. You can enter this 3D scene group so that you change the 3D effects and rotate the
individual 3D objects within the group.
To enter the group, go to Modify > Enter Group on the main menu bar, or press the F3 key, or
right-click on the group and select Enter Group from the context menu.
To exit the group after you have finished your changes, go to Modify > Exit Group on the main
menu bar, or use the Ctrl+F3 key combination, or right-click on the group and select Exit Group
from the context menu.

Note

3D object types

You cannot ungroup into individual objects a 3D scene group that has been
created from a selection of 2D objects.
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Creating
Drawing toolbar
Before you begin creating 3D objects in your drawing, it is recommended that you add the
LibreOffice 3D tools to the Drawing toolbar as follows:
1) Right-click in an empty area on the Drawing toolbar and select Visible Buttons from the
context menu.
2) Select To 3D
and To 3D Rotation Object
from the available list of icons to place
them on the Drawing toolbar as shown in Figure 1.

Figure 1: Drawing toolbar

Note

The To 3D, To 3D Rotation Object, and Extrusion On/Off icons only become
active when a 2D object is selected in your drawing.

Extrusion
Extrusion is a procedure that creates a 3D shape from a 2D object. The 3D geometry is formed by
extruding a polygon perpendicular to the plane of the given polygon using depth to create front,
back, and side faces. The side faces are formed by connecting all corresponding single edges of
the front and back faces.
Draw uses a default value for extrusion (depth) based on the size of a 2D object. This value can be
changed after carrying out extrusion; see “3D-Settings toolbar” on page 11 for more information.
1) Draw an object using one of the shape tools on the Drawing toolbar.
2) Select the 2D object you want to convert to 3D.

Note

Extrusion only works on basic shapes, symbol shapes, block arrows, flowcharts,
callouts, and stars that are included as a part of the default set of tools on the
Drawing toolbar. Extrusion can also be used on any text created using the
Fontwork Gallery.

Figure 2: Extruding a 3D object from a 2D object

Creating
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3) Click the Extrusion On/Off icon
on the Drawing toolbar and the selected 2D object is
converted into a 3D shape (Figure 2). The Extrusion On/Off icon used to create 3D
shapes from 2D objects is included in the default set of tools for the Drawing toolbar.
4) Alternatively, click on the Extrusion On/Off icon
on the 3D-Settings toolbar and the
selected 2D object is converted into a 3D shape. If the 3D-Settings toolbar is not visible, go
to View > Toolbars > 3D-Settings on the main menu bar.

Rotation
To 3D rotation
To 3D rotation converts a 2D object into a 3D scene by rotating the object using the left edge of the
bounding box around the object as the axis of rotation. Examples of rotation are shown in Figure 3,
where a thick line has been used as an example object. The actual 3D shape created also
depends on the angle and shape of the object being rotated.
1) Draw a line and make sure it is selected.
2) To convert the line into a 3D scene, click on the To 3D Rotation Object icon
on the
Drawing toolbar, or go to Modify > Convert > To 3D Rotation Object on the main menu
bar, or right-click on and select Convert > To 3D Rotation Object from the context menu.

Figure 3: Examples of using To 3D body rotation

In 3D rotation
In 3D rotation converts a 2D object into a 3D scene by rotating the object using a movable axis of
rotation. A 2D object is rotated and slightly tilted with the central projection turned on so that the
converted object is better recognized as a 3D scene (Figure 4).

Figure 4: Examples of rotating 2D objects to create a 3D objects
The default location of this rotation axis is the left edge of the bounding box around the object.
However, this location and angle of rotation can be adjusted, allowing you to create 3D scenes that
have different shapes. Examples of adjusting the rotation location and angle are shown in Figure 5
where a thick line has been used as an example object. The actual 3D scene created also
depends on the angle and shape of the object being rotated.
1) Draw a line and make sure it is selected.
2) Click on the small triangle next to the Effects icon on the Line and Filling toolbar and select
the In 3D Rotation Object icon
Creating

in the popup toolbar.
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Figure 5: In 3D body rotation
3) Alternatively, go to View > Toolbars > Mode on the main menu bar to open the Mode
toolbar and select the In 3D Rotation Object icon
.
4) If necessary, adjust the position and angle of the rotation axis. This is shown as a dashed
line with rotation points at each end.
5) Click anywhere outside the object and it is converted into a 3D scene.

Note

The shape of the Effects icon on the Line and Filling toolbar changes depending
on the last Effects tool that was used on the Line and Filling or Mode toolbars.
If the Effects icon is not visible on the Line and Filling toolbar, then right-click in an
empty area on the toolbar and click on Visible Buttons, then select Effects.

Conversion
When a 2D object is converted to a 3D scene, it is slightly tilted and central projection turned on so
that the converted object is better recognized as a 3D scene.
1) Select a 2D object in your drawing.
2) Go to Modify > Convert > To 3D or To 3D Rotation object on the main menu bar and the
object is converted into a 3D scene.
3) Alternatively, right-click on the object and select Convert > To 3D or To 3D Rotation
object from the context menu and the object is converted into a 3D scene.
Examples of conversion using To 3D are shown in Figure 4 on page 6 and for To 3D Rotation
object conversion; see “To 3D rotation” on page 6 for more information.

Creating
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Text and Fontwork
Text
Draw treats text like an object which can be converted to 3D as easily as any other object in your
drawing.
1) Click on the Text icon
on the Drawing toolbar.
2) Move the cursor onto your drawing and click once to create a text box, then type your text.
3) Click again on the text box to select it. Selection handles will show on the text box.
4) Click the To 3D
icon on the Drawing toolbar, or go to Modify > Convert > To 3D or To
3D Rotation object, or right-click on the object and select Convert > To 3D or To 3D
Rotation object from the context menu and the selected text is converted into a 3D scene.
5) See “Editing 3D objects” on page 9 on how to change the 3D effects for 3D text.

Fontwork
The Fontwork Gallery in Draw contains a set of templates allowing you to create artistic text for
your drawings. Click on the Fontwork icon
on the Drawing toolbar to open the Fontwork
Gallery (Figure 6). See the Impress Guide Chapter 5 Managing Graphic Objects for more
information on the Fontwork Gallery and its tools.
After creating your text using the Fontwork Gallery, it can be converted to a 3D shape using the
information in “Extrusion” on page 5, and into a 3D scene using “Rotation” on page 6, “Conversion”
on page 7, or “Text” above.

Figure 6: Fontwork Gallery

Creating
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Ready-made 3D objects
LibreOffice has a collection of ready-made 3D objects available for immediate use. To access
these ready-made 3D objects, go to View > Toolbars > 3D Objects on the main menu bar to open
the 3D-Objects toolbar or click on the 3D Objects icon
up menu (Figure 7).

on the Drawing toolbar to open a pop-

Creating 3D scenes using this toolbar is exactly the same as drawing basic shapes. See Chapter 2
Drawing Basic Shapes for more information.

Figure 7: 3D Objects toolbar

Note

The shape of the 3D Objects icon on the Drawing toolbar changes depending on
the last tool that was used.
If the 3D Objects icon is not visible on the Drawing toolbar, then right-click in an
empty area on the toolbar and click on Visible Buttons and select 3D Objects.

Editing 3D objects

Note

Where 3D scenes have been created from more than one 2D object, a 3D scene
group is automatically created. You cannot ungroup this 3D scene group and any
editing carried out will affect all 3D objects within the group. To edit an individual
3D object within this 3D scene group, you must enter the group. See “3D scenes”
on page 4 for more information.

Rotation
Rotating 3D scenes and shapes is similar to rotation for 2D objects (see Chapter 3 Working with
Objects and Object Points for more information).

Using the mouse
Note

For 3D shapes that have been created using extrusion, see “3D-Settings toolbar”
on page 11 for information on how to rotate 3D shapes about the horizontal or
vertical axes.

1) Select a 3D object (3D scene or 3D shape), then click on the small triangle next to the
Effects icon on the Line and Filling toolbar and select the Rotate icon
in the pop-up
toolbar, or go to View > Toolbars > Mode on the main menu bar to open the Mode toolbar
and select the Rotate icon
or go to Modify > Rotate on the main menu bar.
2) Click on a corner selection handle and hold the mouse button down until the cursor
changes to a double-headed circular arrow.
3) Drag the cursor to rotate the 3D object around the rotation point
in exactly the same
way as rotating a 2D object.
4) Release the mouse button when you are satisfied with the rotation effect.
Editing 3D objects
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5) Click on a center selection handle and hold the mouse button down until the cursor
changes to parallel arrows. These center selection handles are not available for 3D shapes
created using the extrusion method.
6) Drag the cursor to rotate the 3D object around the horizontal axis or the vertical axis. The
left and right center selection handles are used for the horizontal axis. The top and bottom
center selection handles are used for the vertical axis.
7) Release the mouse button when you are satisfied with the rotation effect.

Note

By default, the rotation point
is in the center of a selected 3D object. This
rotation point can be moved to change the center of rotation and create a different
effect when you carry out rotation. Move your cursor over the rotation point until it
changes (normally a pointed fist), then click and drag the rotation point to a new
position. Alternatively, click and drag on the 3D object to a new position when it is
in rotation mode to move the object away from the default position for the center of
rotation.

Using the Rotation dialog
1) Select the 3D object (3D scene or 3D shape).
2) Go to Format > Position and Size on the main menu bar, or right-click on the selected
object and select Position and Size from the context menu, or press the F4 key to open
the Position and Size dialog (Figure 8).
3) Click on the Rotation tab to open the Rotation page.
4) In the Rotation angle section, enter the number of degrees for rotation in the Angle box.
5) Alternatively, click and drag the Rotation Angle indicator in Default settings until you reach
the rotation angle you require. As you drag the indicator, the rotation angle is displayed in
the Angle box.
6) In the Pivot point section, enter the X and Y coordinates in the Position X and Position Y
boxes to adjust the location of rotation point.
7) Alternatively, select one of the position points in Default settings to adjust the location of the
rotation point. The default location is in the center.
8) Click OK to save your changes and close the dialog.

Figure 8: Rotation dialog
Editing 3D objects
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3D-Settings toolbar
The 3D-Settings toolbar (Figure 9) is only used to edit a 3D shape that has been created from a 2D
object using extrusion ( see “Extrusion” on page 5 for more information). To open the 3D-Settings
toolbar, go to View > Toolbars > 3D-Settings on the main menu bar. The 3D-Settings toolbar only
becomes active when a 3D shape has been selected.

Figure 9: 3D-Settings toolbar
The tools available for editing 3D shapes are as follows. The result of any changes made using
these editing tools is applied to the selected 3D shape immediately and the 3D effect is displayed.

• Extrusion On/Off – used to create a 3D shape from a 2D object. If necessary, can also be
used to switch off the 3D effects created by extrusion allowing you to edit the underlying 2D
object.

• Tilt Down – tilts the selected object downward (horizontal axis rotation) by 5 degrees each
time the icon is used.

• Tilt Up – tilts the selected object upward (horizontal axis rotation) by 5 degrees each time
the icon is used.

• Tilt Left – tilts the selected object left (vertical axis rotation) by 5 degrees each time the
icon is used.

• Tilt Right – tilts the selected object right (vertical axis rotation) by 5 degrees each time the
icon is used.

• Depth – opens a pop-up menu where you can set the extrusion depth from an object by a
fixed or custom amount.

• Direction – opens a pop-up menu where you can set the view direction to create an
extrusion in either a perspective or parallel projection.

• Lighting – opens a pop-up menu where you can set the direction and intensity of the
lighting when creating an extrusion.

• Surface – opens a pop-up menu where you can set the surface of the extrusion as matt,
plastic, metal, or wireframe display.

• 3D Color – opens a pop-up menu where you can set the color used for the extrusion. This
color does not have to be the same as the color used for the original 2D object.

Editing 3D objects

11

3D effects
The 3D Effects dialog (Figure 10) offers a wide range of possible settings for 3D objects created
using the following methods. This dialog can also be used to convert a 2D object to 3D using the
tools in the bottom left corner of the dialog.
To open the 3D Effects dialog, select the 3D object and right-click on the object then select 3D
Effects from the context menu to open the 3D Effects dialog.
Any 3D effects that you apply to a 3D scene are not carried out until you click on the Assign icon
. This allows you to make all the 3D effect changes before applying them to your 3D scene.

Figure 10: 3D Effects dialog - Geometry

Note

You can add a 3D Effects icon
to the Drawing toolbar, or any other toolbar, by
going to View > Toolbars > Customize or right-clicking in an empty area on the
toolbar and selecting Customize Toolbar. When the Customize dialog opens, go
to Toolbars, select the toolbar you want to use and click on the Add button to
display the Add Commands dialog. The 3D Effects icon is located in the Options
category.

3D conversion
In the bottom left corner of all the pages in the Effects dialog are tools allowing you to convert a 2D
object to a 3D object and to change the projection used in a 3D object.

• Convert to 3D

– converts the selected object into a 3D scene. This tool works in the
same way as “Conversion” on page 7.

• Convert to Lathe Object

– converts a 2D object into a 3D scene using body rotation.
This tool works in the same way as “To 3D rotation” on page 6.

Editing 3D objects
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• Perspective On/Off

– switches perspective projection on or off for a 3D object.
Perspective projection is where projecting lines from the center of projection pass through
an imaginary plane until they meet at a point some distance from an object.

3D Effects – Geometry
On the Geometry page of the Effects dialog (Figure 10) you can make changes to the geometry of
a 3D object.

• Geometry – defines the properties for a 3D scene or shape created from a 2D object.
– Rounded edges – enter the amount by which you want to round the corners of a 3D

shape as shown by the example in Figure 11. The default setting for rounded edges is
10%

Figure 11: Rounded edges example

–

Scaled depth – enter the amount by which to increase or decrease the frontal area of
the selected 3D object. Figure 12 shows an example where the scaled depth has been
increased to 150% and then decreased to 50%. The default setting for scaled depth is
100%.

Figure 12: Scaled depth example

–

Rotation angle – enter the angle in degrees to rotate a 2D object that has been
converted to 3D using the To 3D Rotation Object tool. Figure 13 shows an example of
a 2D circle converted to 3D and the rotation angle changed to 150 degrees.

Editing 3D objects
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Figure 13: Rotation angle example

–

Depth – enter the extrusion depth for the selected 3D object. This option is not available
for 2D rotation objects converted to 3D using the To 3D Rotation Object tool. Figure 14
shows an example of a 2D circle converted to a 3D cylinder with the extrusion depth
increased to 3 cm.

Figure 14: Depth example

• Segments – changes the number of segments that Draw uses to draw a 3D rotation

object. The higher the number of segments, the smoother the object surface will be.
However, a high segment number may increase the time it takes to generate the 3D object
on your display. Figure 15 shows the difference on a 3D sphere when the segments have
been increased from 10 to 30 segments horizontally and vertically.

–

Horizontal – enter the number of horizontal segments to use in the selected 3D rotation
object.

–

Vertical – enter the number of vertical segments to use in the selected 3D rotation
object.

Figure 15: Segment example

Editing 3D objects

14

Figure 16: Object-Specific, Flat, and Spherical examples

Figure 17: Invert Normals and Double-Sided Illumination examples

• Normals – modifies the rendering style of the 3D surface (Figure 16 and Figure 17).
–

Object-Specific
– renders the 3D surface according to the shape of the object. For
example, a circular shape is rendered with a spherical surface.

–

Flat

–

Spherical

–

Invert Normals
– inverts or reverses which side of the selected object is considered
to be the outside face and which side is considered the inside face.

–

Double-Sided Illumination
– lights an object from the outside and the inside of the
object. To use as an ambient light source, click this button, and then click Invert
Normals. This is a setting for the whole of the 3D scene and not fopr a single object
within the scene.

–

Double-Sided
– a 3D object has a front and back face. With Double-Sided
switched off, only the front face of the object is rendered. The effect, when looking from
outside, is that the object solid, but, when looking from inside, the front face is

Editing 3D objects

– renders the 3D surface as polygons.
– renders a smooth 3D surface regardless of the shape of the object.
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transparent. If there is no view to the inside face, normally for an extruded 3D object
with solid texture, the Double-Sided should be switched off to improve performance
during rendering. Any 3D object created using rotation often allow an inside view and it
is recommended that Double-Sided is switched on. Which side of an object face is
considered to be back or front is determined by the Invert Normals setting, that is the
front side of a plane is the one the normal points away from.

3D Effects – Shading
On the Shading page of the Effects dialog (Figure 18) you can set the shading and shadow options
for the selected 3D object.

• Shading – specifies the type of shading applied to a 3D object (Figure 19).
– Flat Mode – assigns a single color of shading to a single segment on the surface of the
object.

–
–

Gouraud Mode – blends shading colors across the segments.
Phong Mode – averages the shading color of each pixel in a segment based on the
pixels that surround it, and requires the most processing power.

Figure 18: 3D Effects dialog - Shading

Figure 19: Shading mode examples

Editing 3D objects
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Figure 20: Example of using Shadow

• Shadow – adds or removes a shadow from a selected 3D object (Figure 20).
– 3D Shadowing On/Off
– switches the shadowing on or off.
– Surface angle – enter an angle from 0 to 90 degrees for casting a shadow.
• Camera – sets the camera options for a selected 3D scene as if you are actually using a
camera to take a photograph (Figure 21).

–

Distance – enter the distance to leave between the camera and the center of the
selected 3D scene. The default setting for distance is 2.6cm.

–

Focal length – enter the focal length of the camera lens, where a small value
corresponds to a fish-eye lens and a large value to a telephoto lens. The default setting
for focal length is 10cm.

Figure 21: Distance and Focal Length examples

3D Effects – Illumination
On the Illumination page of the Effects dialog (Figure 22) you define how a 3D scene is lit and the
settings apply to all 3D objects in a scene. You can specify the direction of the light source for the
3D scene, as well as the color of the light source and of the ambient light.
By default one light source is already selected when you open the Illumination page. However, you
can select another light source or use more than one light source for illumination. A maximum of
eight sources can be used and each light source can use a different color. Figure 22 shows three
light sources selected with each color having a different color. At least one light source must be
active; otherwise, the rendering and shading functions on 3D Effects will not function correctly.
1) Select a Light source icon
to turn the required light source on. The icon changes to an
illuminated bulb.
2) Press the space bar or click again on the selected light source so you can adjust the color
and ambient light for the light source.

Editing 3D objects
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Figure 22: 3D Effects dialog - Illumination
3) Select a color for the light from the drop-down list for Light source. A different color can be
used for each light source selected.
4) If necessary, select a color from the drop-down list for Ambient light to set the color of the
surrounding light.
5) To deselect a light source, select the light source and click on it again.
The light source location and color are shown in the lower right corner of the Illumination page. The
vertical slider bar adjusts the lighting angle and the horizontal slider bar rotates the light about the
object. Alternatively you can click on the light point and drag the light source to where you want it.
To change the preview from a sphere to a cube, click on the small square to the right of the
horizontal slider bar and below the vertical slider bar.
Each light source selected is shown as a small colored sphere in the color specified for it. The
larger colored sphere indicates the active light source.

3D Effects – Textures
On the Textures page of the Effects dialog (Figure 23) you can set the properties of the surface
texture for a selected 3D object. The Textures page is only available after you have set the Area
Fill of a 3D object to Gradient, Hatching or Bitmap. For more information, see Chapter 4 Changing
Object Attributes.

• Type – sets the color properties of the texture.
–

Black & White

–

Color

– converts the texture to black and white.

– converts the texture to color.

• Mode – shows or hides shading.
–

Only Texture

–

Texture and Shading
– applies the texture with shading. To define the shading
options for the texture, use the Shading page of this dialog.

Editing 3D objects

– applies the texture without shading.
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Figure 23: 3D Effects - Textures

• Projection X – sets the options for displaying the texture along the X axis. Only one of the
three following options can be selected.

–

Object-Specific
– automatically adjusts the texture for best fit based on the shape
and size of the object. This is the default setting.

–

Parallel
– applies the texture parallel to the horizontal axis and is mirrored on the
rear side of the object.

–

Circular

– wraps the horizontal axis of the texture pattern around an object.

• Projection Y – sets the options for displaying the texture along the Y axis. Only one of the
three following options can be selected.

–

Object-Specific
– automatically adjusts the texture for best fit based on the shape
and size of the object. This is the default setting.

• Parallel

– applies the texture parallel to the vertical axis and is mirrored on the rear side
of the object.

–

Circular

– wraps the vertical axis of the texture pattern around an object.

• Filter – filters out noise that can occur when you apply a texture to a 3D object.
–

Filtering On/Off

– blurs the texture slightly to remove unwanted speckles.

Before Textures can be used, you must change the area fill of the 3D object as follows:
1) Select the 3D object.
2) Right-click on the 3D object and select Area from the context menu or go to Format > Area
on the main menu bar to open the Area dialog.
3) From the Fill drop-down list, select Gradient, Hatching or Bitmap.
4) Select the fill from the list that appears and then click OK. The texture is then applied to the
selected 3D object.

Editing 3D objects
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Figure 24: 3D Effects - Material

3D Effects - Material
On the Materials page of the Effects dialog (Figure 24) you can change the appearance of a 3D
object to represent different materials. Materials and textures can be combined with each other and
it is a matter of trial and error to achieve the desired result.

• Material – assigns a predefined color scheme or lets you create your own color scheme.
– Favorites – select a predefined color scheme, or select a custom color scheme that has
been user defined.

–
–

Object color – select the color that you want to apply to a 3D object.
Illumination color – select the color to illuminate the object and brightening parts of the
object which lie in shadow making the object seem more illuminated.

• Specular – sets the light reflection properties for the selected object simulating the

reflecting capacity of the surface. The position of the illuminated point is determined by the
setting of the first light source.

–
–

Color – select the color that you want the object to reflect.
Intensity – enter the intensity of the specular effect.

• The Color icon

opens the Color dialog allowing you to define your own colors using
the two-dimensional graphic and numerical gradient chart.

Tip

Do not use a very high brightness values for individual colors. These are all
additive and it is easy to end up with a colored area that is white.

When you use individual color parameters additional effects can be produced, which are similar to
the color parameters in “3D Effects – Illumination” on page 17.

Note

Editing 3D objects

Metallic and glass surfaces do not simulate well because the appearance of these
materials is produced using reflection.
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3D-Settings toolbar editing
When 3D shapes have been created from 2D objects using the extrusion method, they are handled
differently from 3D scenes. You have to use the tools on the 3D-Settings toolbar to make any
changes to a 3D shape. These tools are highlighted in Figure 25.

• Depth

– sets the extrusion depth and direction from the pop-up options.

• Direction

– sets a view direction and a perspective or parallel projection from the pop-

up options.

• Lighting

– sets the lighting direction and lighting intensity from the pop-up options.

• Surface

– sets the surface material or use a wireframe display from the pop-up

options.

• 3D Color

– sets the extrusion color from the pop-up options.

Figure 25: 3D-Settings toolbar - editing
The result of any changes made using these editing tools is applied to the selected 3D shape
immediately and the effect is displayed.

Note

The 3D Effects dialog described in “3D effects” on page 12 cannot be used on 3D
shapes created using the Extrusion On/Off tool because the correct formatting
results will not be achieved. If you have used the 3D Effects dialog in error, you
can remove any incorrect formatting by going to Format > Default Formatting on
the main menu bar.

Combining 3D objects
Multiple 3D objects can be grouped or combined together in the same way as 2D objects. See
Chapter 5 Combining Multiple Objects for more information.

Note

When copying and pasting a 3D scene into another 3D scene, it is not pasted in as
a scene, but the objects within the copied scene are pasted in.

Combining 3D objects
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