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Quick printing

If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire 
document using the current default print settings. If the icon is not visible, you can make it visible 
by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

Specifying the default printer
To specify the default printer, choose File > Printer Settings on the Menu bar. The Printer Setup 
dialog (Figure 1) opens. To access other printing options, click the Options button on the Printer 
Setup dialog. The same default options are available through Tools > Options > LibreOffice 
Writer > Print, and more general print options through Tools > Options > LibreOffice > Print. 
See Chapter 20, Customizing Writer, for more information.

Figure 1: Printer Setup dialog

Controlling printing using the Print dialog

For more control over printing, use the Print dialog (File > Print, Ctrl+P ( +P ⌘ for macOS), or the 
Print icon on the Standard toolbar). The appearance of the Print dialog is different on Windows 
and Linux than it is on macOS, so they are described separately in this chapter.

Print dialog on Windows and Linux
On Windows and Linux, the Print dialog (Figure 2) has two tabs, on which you can choose a 
range of options, as described in the following sections. The appearance of this dialog may vary 
slightly depending on the operating system in use.

Selecting general printing options
On the General tab of the Print dialog, you can choose:

• The printer, from the list of available printers.

• Which pages to print, the number of copies to print, and whether to collate multiple 
copies (Range and copies section).

• Paper size and print orientation (Page Layout section).

• How many pages to print on one sheet of paper and whether to draw a border around 
each page (Page Layout section).

• Whether to print a brochure (see page 7).

• Whether to print in reverse page order (useful on some printers to make the pages come 
out in page order).
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Figure 2: The Print dialog on Windows and Linux

Selecting printer and print job options
In the Printer section of the General tab, click the Properties button to display the selected 
printer’s properties dialog where you can choose portrait or landscape orientation, which paper 
tray to use, and the paper size to print on.

Click the More button at the bottom of the Range and Copies section of the General tab to 
choose whether to create separate print jobs for collated output, instead of one print job 
containing all the collated pages (not relevant if only one copy of a document is printed).

Selecting what to print
In addition to printing a full document, you can choose to print individual pages, a ranges of 
pages, or a selection from a document.

Individual page
1) In the Print dialog, in the Range and Copies section, select the Pages option. The text 

box shows the current page number.

2) Enter the page number of the page you want to print. The preview box on the left 
changes to show the selected page.
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Range of pages
1) In the Print dialog, in the Range and Copies section, select the Pages option.

2) Enter the page numbers of the pages to print (for example, 1–4 or 1,3,7,11 or a 
combination).

Selection of text or graphics
1) In the document, select the material to print, then open the Print dialog.

2) In the Range and Copies section of the Print dialog, the Selection option is now active 
and selected and the preview box shows the selected material (Figure 3).

Figure 3: Printing a selection of text

Choices on the LibreOffice Writer tab
On the LibreOffice Writer tab (Figure 4) you can choose to print a subset of contents (for 
example, images or hidden text), print text in black (even if a color is defined for the text), 
whether to print automatically inserted blank pages, and whether and where to print any 
comments that are in the document.

Some selections may not be available all the time. For example, if the document contains no 
comments, the Comments drop-down list is disabled.

Figure 4: LibreOffice Writer tab of Print dialog
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Print dialog on macOS
The LibreOffice Print dialog in macOS has several pages, described in the following sections. 
These pages are listed in a drop-down menu below the upper part of the dialog (Figure 5). Its 
appearance and layout on macOS 13 (Ventura) vary a bit from macOS 12 (Monterey) and earlier.
The examples here are from macOS 12.

Figure 5: Pages of the Print dialog on macOS

Selecting general printing options
In the upper part of the Print dialog on macOS (Figure 5), you can choose:

• The printer, from the list of available printers

• The number of copies to print

• Which pages to print: all, or a continuous range of pages; for a discontinuous range of 
pages, see the Pages section under LibreOffice Writer in the lower part of the dialog.

Choices on the LibreOffice Writer page
On the LibreOffice Writer page of the Print dialog on macOS (Figure 6), you can choose:

• What contents to print: page background, images and other graphic objects, hidden text, 
text placeholders, and form controls.

• Whether to print text in black, instead of any colors defined in the document.

• Whether to print automatically inserted blank pages, a selection of pages, or a selection 
of contents.

• Whether and where to print comments.

• Whether to print a brochure (see page 11).

Some selections may not be available all the time. For example, if the document contains no 
comments, the Comments drop-down list is disabled.
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Figure 6: The LibreOffice Writer page of the Print dialog

Selecting what to print
In addition to printing a full document, you can choose to print individual pages, a range of pages,
or a selection from a document.

Individual page
To print an individual page, you can use either of the top or bottom Pages sections of the 
Print dialog (Figure 3). In the top section, enter the required page number in both the 
From: and To: boxes. The preview box on the left changes to show the selected page.

Consecutive range of pages
To print a consecutive range of pages, you can use either of the Pages sections of the 
Print dialog (Figure 3). In the top section, enter the first and last page numbers in the 
From: and To: boxes. Or, use the method described below for a non-consecutive range of 
pages.

Non-consecutive range of pages
To print a non-consecutive range of pages (for example, 1,3,7,11 or a combination like 1–
4; 7, 11, 22), you need to use the bottom Pages section (in the LibreOffice Writer area). 
Select the Pages: option. The box below Selection becomes active. Type the required 
page numbers in this box.

Selection of text or graphics
To print a selection of text or graphics: in the document, select the material to print, then 
open the Print dialog. In the bottom Pages section of the Print dialog, the Selection 
option is now active and selected and the preview box shows the selected material 
(Figure 7).
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Figure 7: Printing a selection of text

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

• [Windows or Linux] On the Page Layout section of the General tab of the Print dialog 
(Figure 8), click More and select from the Pages per sheet drop-down list the number of 
pages to print per sheet of paper.

• [macOS] Go to the Layout page (Figure 9) of the Print dialog and select from the Pages 
per Sheet drop-down list the number of pages to print per sheet of paper.

When printing more than two pages per sheet, you can choose the order in which they are 
printed across and down the paper.

The preview panel on the left of the Print dialog changes to show how the printed document will 
look.

Figure 8: Print order choices on Windows and Linux
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Figure 9: The Layout page of the Print dialog on macOS

Printing a brochure
In Writer, you can print a document with two pages on each side of a sheet of paper, arranged so
that when the printed pages are folded in half, the pages are in the correct order to form a
booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate 
margins, font sizes, and so on. You may need to experiment.

The process for printing a brochure is the same for all operating systems, but the settings are 
found in different places.

To print a brochure on a single-sided printer:

1) [Windows and Linux] In the Page Layout section of the General tab of the Print dialog, 
click more and select Brochure near the bottom.

[macOS] On the LibreOffice page of the Print dialog, select Brochure near the bottom.

2) The preview on the left changes to show the sequence in which the pages will be printed. 
(Figure 10.)

3) If you have Asian or CTL selected in your language settings1, the Print dialog will include 
a drop-down menu adjacent to the Brochure button (not shown in Figure 10). This list 
provides Left-to-right script and Right-to-left script options. Select the required setting.

4) [Windows and Linux] In the Range and Copies section of the General tab of the Print 
dialog, select Even pages.

[macOS] On the Paper Handling page of the Print dialog (Figure 11), in the Pages to Print
drop-down list, select Even pages.

5) Click Print. Take the printed pages out of the printer and put them back into the printer in 
the correct orientation to print on the blank side. You may need to experiment to find the 
correct arrangement for your printer.

6) [Windows and Linux] In the Range and Copies section of the General tab of the Print 
dialog, select Odd pages.

[macOS] On the Paper Handling page of the Print dialog (Figure 11), in the Pages to Print
drop-down list, select Odd pages.

7) Click Print.

1 Tools > Options > Language Settings > Languages on Windows or Linux; LibreOffice > 
Preferences > Language Settings > Languages on macOS.
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Tip

If your printer can print double-sided (duplex) automatically, choose All pages in 
step 3 and skip steps 4 and 5.

Figure 10: Settings for printing a brochure using Windows or Linux

Figure 11: Settings for printing a brochure using macOS

Printing in black and white on a color printer

You may wish to print documents in black and white on a color printer. Several choices are 
available.

Note

Some color printers may print in color regardless of the settings you choose.
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[Windows and Linux] For one document, change the printer settings to print in black and white or 
grayscale:

1) On the Print dialog, click Properties to open the Properties dialog for the printer. The 
available choices vary from one printer to another, but you should find options for the 
color settings. See your printer’s help or user manual for more information.

2) The choices for color might include black and white or grayscale. Choose grayscale.

3) Click OK to confirm your choice and return to the Print dialog.

4) Click Print to print the document.

[macOS] For one document, change the Color setting on the LibreOffice Writer page of the Print 
dialog (Figure 6):

1) In the Color section, select Print text in black.

2) Click Print to print the document.

[All] To print all color text and images as grayscale, change the LibreOffice settings:

1) Choose Tools > Options > LibreOffice > Print [macOS: LibreOffice > Preferences > 
LibreOffice > Print].

2) Select the Convert colors to grayscale option. Click OK to save the change.

[All] To print all color text as black, and all images as grayscale, change the LibreOffice Writer 
settings: 

1) Choose Tools > Options > LibreOffice Writer > Print [macOS: LibreOffice > 
Preferences > LibreOffice Writer > Print].

2) Under Contents, select the Print text in black option. Click OK to save the change.

Previewing pages before printing

The normal page view in Writer shows what each page will look like when printed; you can edit 
the pages in that view. If you are designing a document to be printed double-sided, you may want
to see what facing pages look like. Writer provides two ways to do this:

• View Layout (editable view): use the Book View button on the status bar and (usually) 
zoom out.

Figure 12: Book view icon on Status bar

• Print Preview (read-only view).

To use Print Preview:

1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview icon on 
the Standard toolbar, or press Ctrl+Shift+O. Writer now displays the Print Preview 
toolbar instead of the Formatting toolbar.

Figure 13: Print Preview toolbar

2) Select the required preview icon: Single Page Preview, Two Pages Preview,  Book 
Preview, or Multiple Pages Preview.

3) To print the document from this view, click the Print icon to open the Print dialog. Choose 
the print options and click Print.
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Printing envelopes

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with a document:

1) Click Insert > Envelope on the Menu bar.

2) In the Envelope dialog, start with the Envelope tab (Figure 14). Verify, add, or edit the 
information in the Addressee and Sender (the “from” on the envelope) boxes. The sender 
information is picked up from the User Data page in Tools > Options > LibreOffice 
(macOS: LibreOffice > Preferences > LibreOffice).

You can type information directly into the Addressee and Sender boxes, or use the right-
hand drop-down lists to select the database or table from which you can draw the 
envelope information. See Chapter 14, Mail Merge, for details on how to print envelopes 
from a database.

Figure 14: Choosing addressee and sender information for an envelope

3) On the Format tab (Figure 15), verify or edit the positioning of the addressee and the 
sender information. The preview area on the lower right illustrates your choices.

4) To format the text of these blocks, click the Edit button to the right. In the drop-down list 
you have two choices: Character and Paragraph.

– Select Character to open a dialog similar to the standard Character dialog, where you
can set the formatting of the text.

– Select Paragraph to open a dialog similar to the standard Paragraph dialog, where 
you can set the paragraph's attributes.
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Figure 15: Choosing positioning and size of elements for an envelope

5) In the lower left of this tab is the Size section. Choose the envelope format in the drop-
down list. The width and height of the selected envelope are shown in the boxes below 
the selected format. If you chose a pre-existing format, just verify these sizes. If you 
chose User Defined in the Format list, then you can edit the sizes.

6) After formatting, go to the Printer tab (Figure 16) to choose which printer to use, setup 
(for example, specification of the tray holding envelopes), and other printer options such 
as envelope orientation and shifting. You may need to experiment to see what options 
work best for your printer and how the envelopes need to be positioned in the printer.

Figure 16: Choosing printer options for an envelope
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7) When you have finished formatting and are ready to print, click either the New Document
button or the Insert button to finish. New Document makes only an envelope or starts a 
new document with the envelope. Insert puts the envelope into your existing document as
page 1.

8) Save this file before you do anything else.

To print the envelope:

1) Choose File > Print on the Menu bar.

2) [Windows and Linux] On the Print dialog (Figure 2 on page 6), under Range and Copies, 
choose Pages and type 1 in the box. Choose the required printer (which may be different 
from the usual printer).

[macOS] On the Print dialog (Figure 5 on page 8), in the upper section of the dialog, 
choose Pages – From: and type 1 in both boxes.

3) Click Print.

Printing labels

Labels are commonly used for printing address lists (where each label shows a different 
address), but they can also be used to make multiple copies of one label, for example return-
address stickers, labels for CDs/DVDs, or other items.

Printing labels, like printing envelopes, has two steps: setup and printing. This topic is covered in 
detail in Chapter 14, Mail Merge.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This standard file format 
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Warning

A document in PDF format is not protected against contents tampering or editing by 
default. The PDF document contents can be edited by specialized software tools, 
including LibreOffice Draw.

Tip

Unlike Save As, the Export command writes a copy of the current document in a new
file with the chosen format, but keeps the current document and format open in your 
session.

Quick export to PDF
Click the Export Directly as PDF icon on the Standard toolbar, or File > Export As > Export 
Directly as PDF, to export the entire document using the PDF settings you most recently 
selected in the PDF Options dialog. You are asked to enter the file name and location for the 
PDF, but you do not get a chance to choose a page range, the image compression, or other 
options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as > 
Export as PDF. The PDF Options dialog opens. This dialog has six tabs (General, Initial View, 
User Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then 
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click Export. Then you are asked to enter the location and file name of the PDF to be created, 
and click Save (Windows and Linux) or Export (macOS) to export the file.

Note

You can also export to PDF with File > Export. On the Export dialog, select the PDF 
file format, the file name and location, and click Save or Export. The PDF Options 
dialog then opens. Select the appropriate settings and then click Export. The only 
difference between the two export methods is the sequence in which steps occur.

General tab of PDF Options dialog
On the General tab (Figure 19), you can choose which pages to include in the PDF, the type of 
compression to use for images (which affects the quality of images in the PDF), and other 
options.

Range section
• All: Exports the entire document to PDF.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of 
page ranges and single pages, by using a format like 3-6;8;10;12.

• Selection: Exports whatever material is selected.

• View PDF after export: Your default PDF viewer will open and display the newly 
exported PDF.

Figure 17: General tab of PDF Options dialog

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make 

large files when used with photographs. Recommended for other kinds of images or 
graphics.
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• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well 
with photographs (smaller file size, little perceptible loss of quality).

• Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Lower 
resolutions (100 dpi or less) may be sufficient for viewing on a computer screen, but 
many modern devices have much higher resolutions; and for printing it is generally 
preferable to use at least 300 or 600 dpi, depending on the capability of the printer. 
Higher DPI settings increase the size of the exported file.

Note

EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.

Watermark section
• Sign with Watermark: When this option is selected, a transparent overlay of the text you

enter into the watermark text box will appear on each page of the PDF.

General section
• Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF 

containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF 
file, and it remains fully editable in LibreOffice.

• Archive (PDF/A, ISO 19005): PDF/A is an ISO standard for long-term preservation of 
documents, by embedding all the information necessary for faithful reproduction (such as
fonts) while forbidding other elements (including forms, security, and encryption). PDF 
tags are written. PDF/A-1b refers to the minimum compliance level with PDF/A-1. 
PDF/A-2b is recommended for most users, because it allows layers and transparency 
with shapes and images. It also compresses better, usually producing smaller files. 
PDF/A-3b is identical to PDF/A-2b, but also accepts embedding of other file formats.

• Universal Accessibility (PDF/UA): Creates a universal accessibility-complaint PDF file 
that follows the requirements of PDF/UA (ISO 14289) specifications. See the Help for 
more information.

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form – Submit format: Choose the format of submitting forms from within 
the PDF file. This setting overrides the control’s URL property that you set in the 
document. There is only one common setting valid for the whole PDF document: PDF 
(sends the whole document), FDF (sends the control contents), HTML, and XML. Most 
often you will choose the PDF format.

• Allow duplicate field names: If enabled, the same field name can be used for multiple 
fields in the generated PDF file. You can enter data in the first occurrence of the named 
field in the PDF document and all fields with the same name will carry your entry. If 
disabled, field names will be exported using generated unique names.

Structure section
• Export outlines: Exports headings as an outline (table of contents list) displayed by 

most PDF viewers, including Adobe Reader. In Writer 7.0 and earlier, these were called 
bookmarks.

• Export placeholders: The PDF will include any defined placeholder fields, which can be 
filled in by users.

18 | Chapter 7, Printing, Exporting, Emailing, Signing



• Comments as PDF annotations: If selected, comments are included in the PDF as 
annotations.

• Export automatically inserted blank pages: If selected, automatically inserted blank 
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For 
example, books usually have chapters set to always start on an odd-numbered (right-
hand) page. When the previous chapter ends on an odd page, Writer inserts a blank 
page between the two odd pages. This option controls whether to export that blank page.

• Use reference XObjects: Reference XObjects enable one PDF file to import content 
from another. More information can be found in section 8.10.4 of the PDF specification, 
ISO 32000-2:2017 (https://www.iso.org/standard/63534.html). If you are not familiar with 
referenceXObjects, leave this box unchecked.

Initial View tab of PDF Options dialog
On the Initial View tab (Figure 18), you can choose how the PDF opens by default in a PDF 
viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings > 
Languages), an additional selection is available under the Continuous facing option: First 
page is left (normally, the first page is on the right when using the Continuous facing option).

Figure 18: Initial View tab of PDF Options dialog

User Interface tab of PDF Options dialog
On the User Interface tab (Figure 19), you can choose more settings to control how a PDF viewer
displays the file. Some of these choices are particularly useful when you are creating a PDF to be
used as a presentation or a kiosk-type display.
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Figure 19: User Interface tab of PDF Options dialog

Window options section
• Resize window to initial page. The PDF viewer window will resize to fit the first page of 

the PDF.

• Center window on screen. The PDF viewer window will be centered on the computer 
screen.

• Open in full screen mode. The PDF viewer will open full-screen.

• Display document title. The PDF viewer will display the document’s title (as recorded in 
File > Properties) in the title bar.

User interface options section
• Hide menubar. The PDF viewer will hide the Menu bar.

• Hide toolbar. The PDF viewer will hide the toolbar.

• Hide window controls. The PDF viewer will hide other window controls.

Transitions
Not available in Writer.

Collapse Outlines
Select how many heading levels are displayed in the outline, if Export Outlines is selected
on the General tab.

Links tab of PDF Options dialog
On the Links tab (Figure 20), you can choose how links in documents are exported to PDF.

Figure 20: Links tab of PDF Options dialog
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Export outlines as named destinations
Paragraphs defined in Writer’s outline levels are exported as “named destinations” to 
which Web pages and PDF documents can link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such 
as .odt, .ods, and .odp), the file extensions are converted to .pdf in the exported PDF 
document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one of the alternatives:

– Default mode: The PDF links will be handled as specified in your operating system.

– Open with PDF reader application: Use the same application used to display the PDF 
document to open linked PDF documents.

– Open with Internet browser: Use the default Internet browser to display linked PDF 
documents.

Security tab of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.

• With an open password set, the PDF can only be opened with the password. Once 
opened, there are no restrictions on what the user can do with the document (for 
example, print, copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted (Figure 21). After you set a password for permissions, the other choices
on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Figure 21: Security tab of PDF Options dialog with passwords set
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Note

Permissions settings are effective only if the user’s PDF viewer respects the settings.

Digital Signatures tab of PDF Options dialog
The Digital Signatures tab (Figure 22) contains the options for exporting a digitally signed PDF.

Figure 22: Digital Signatures tab of PDF Options dialog

Digital signatures are used to ensure that the PDF was really created by the original author (that 
is, you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key 
store location or on a smartcard. The key store to be used can be selected under Tools > 
Options > LibreOffice > Security > Certificate Path (Linux) or LibreOffice > Preferences > 
Security > Certificate Path (macOS). [On Windows, LibreOffice uses the default Windows 
location for storing and retrieving certificates.]

When using a smartcard, it must already be configured for use by your key store. This is usually 
done during installation of the smartcard software. Details about using these features is outside 
the scope of this chapter.

• Use this certificate to digitally sign PDF documents: Click Select to open the Select 
Certificate dialog, where all certificates found in your selected key store are displayed. If 
the key store is protected by a password, you are prompted for it. When using a 
smartcard that is protected by a PIN, you are also prompted for that.

• Select the certificate to use for digitally signing the exported PDF, then click Sign.

• All other fields on the Digital Signatures tab are accessible only after a certificate has 
been selected.

• Certificate password: Enter the password used for protecting the private key associated 
with the selected certificate. Usually this is the key store password. If the key store 
password has already been entered in the Select Certificate dialog, the key store may 
already be unlocked and not require the password again.

• When using a smartcard, enter the PIN here. Some smartcard software will prompt you 
for the PIN again before signing.

• Location, Contact information, Reason: Optionally enter additional information about the 
digital signature that will be applied to the PDF. This information will be embedded in the 
appropriate PDF fields and will be visible to anyone viewing the PDF. Any or all of the 
three fields may be left blank.
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• Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During 
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that 
is then embedded in the signature. Anyone viewing the PDF can use this timestamp to 
verify when the document was signed.

• The list of TSA URLs that can be selected is maintained under Tools > Options > 
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature 
will not be timestamped, but will use the current time from your local computer.

Exporting to EPUB format

EPUB format has become popular since mobile devices such as smartphones, tablets, and 
e-readers appeared on the market. The EPUB format is implemented as an archive file 
consisting of HTML files carrying the content, along with images and other supporting files.

Writer can export a file to EPUB. A text-only document generally exports well, but some contents 
(such as illustrations, tables, and cross-references) may not export correctly.

Quick export to EPUB
Choose File > Export As > Export Directly as EPUB to export the entire document using the 
EPUB settings you most recently selected on the EPUB Export dialog (Figure 23). Enter the file 
name and location for the EPUB file; you do not get a chance to select other options.

Controlling export to EPUB
For more control over the content and quality of the resulting EPUB file, use File > Export As > 
Export as EPUB. The EPUB Export dialog opens (Figure 23).

Figure 23: EPUB Export dialog
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The EPUB Export dialog has the following fields:

Version
Choose the EPUB version for the exported file. Values are EPUB 2.0 and EPUB 3.0. Most
new e-readers can read EPUB 3.0.

Split method
Select the method to start a new section. Choose Heading to start the section on a 
heading, according to the document’s chapter numbering. Choose Page break to start 
the section on a page break.

Layout method
Choose Reflowable to have the ebook display change to fit the screen size and the 
user’s preference (so page size and header/footer content is not exported). Choose Fixed
to have the ebook layout remain the same under all conditions.

Customize - Cover image
The path to the image file for the cover page. If no image is specified, the EPUB file will 
automatically use any image with a name like cover.gif, cover.jpg, cover.png, or cover.svg.
A custom cover image is embedded in the EPUB file.

Customize - Media directory
The path to the optional directory for the cover image, metadata, and multimedia files. If 
you do not specify a directory, the exporter looks for custom media and metadata in the 
current document directory inside a folder with the same name as the document file 
name.

Metadata
The basic information for the file that provides tags to help searches. These fields provide
another chance to edit metadata that is picked up by default from File > Properties in 
Writer.

Tip

Other ways to export to EPUB from Writer (.odt) files include Calibre, an open-source
e-book manager that runs on Windows, macOS, and Linux. Calibre provides many 
e-book conversion facilities and allows editing of the result.
https://calibre-ebook.com/ 

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you 
cannot find what you want under File > Save As, look under File > Export as well. Writer can 
export files to XHTML, EPUB and other formats, as shown in Figure 24.

Choose File > Export. On the Export dialog, specify a file name for the exported document, then 
select the required file format and click Export.

Figure 24: Export file formats
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Emailing Writer documents

LibreOffice provides several ways to quickly and easily send a Writer document as an email
attachment in one of three formats: .odt (OpenDocument Text, Writer’s default format), .docx 
(Microsoft Word format), or .pdf.

To send the current document in .odt format, choose:

1) File > Send > Email Document, or File > Send > Email as OpenDocument Text. 
Writer opens your default email program (if installed). The document is attached to a new 
email.

2) In your email program, enter the recipient, subject, and any text you want to add, then 
send the email.

If you choose Email as Microsoft Word, Writer first creates a file in Word format (.docx) and then 
opens your email program with the Word file attached to a new email. Similarly, if you choose 
Email as PDF, Writer opens the PDF Options dialog where you can select the settings you want, 
then creates a PDF, and then opens your email program with the PDF attached to a new email.

Emailing a document to several recipients
To email a document to several recipients, you can use the features in your email program or you
can use Writer’s mail merge facilities to extract email addresses from an address book.

You can use Writer’s mail merge to send email in two ways:

• Use the Mail Merge Wizard to create the document and send it.

• Create the document in Writer without using the Wizard, then use the Wizard to send it.

See Chapter 14, Mail Merge, for details.

Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from 
a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s
content plus your personal key. The checksum and your public key are stored with the document.

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. 

In addition, the program can show you the public key information from the certificate. You can 
compare the public key with the public key that is published on the web site of the certificate 
authority. Whenever someone changes something in the document, this change breaks the 
digital signature.

For a more detailed description of how to get and manage a certificate, and signature validation, 
see the LibreOffice Help.

A signed document shows an icon in the Status bar. You can double-click the icon to view the 
certificate. More than one signature can be added to a document.

Changing an existing description invalidates the signature. However, multiple signatures from the
same author are allowed, because each signature can have a different description.
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Applying a digital signature
The following procedure is an example of how to digitally sign a document. The actual procedure 
depends on how your computer is set up and its operating system.

1) Choose File > Digital Signatures > Digital Signatures.

– If you have set LibreOffice to warn you when the document contains comments or 
recorded changes (see “Removing personal data” on page 28), you may see a 
message box asking whether you want to continue signing the document.

– If you have not saved the document since the last change, a message box appears. 
Click Yes twice: once to continue and again to save the file.

2) The Digital Signatures dialog (Figure 25) opens. It lists existing signatures together with 
their description (if they have any). Click the Sign Document button to add a new 
signature to the document.

Figure 25: Signatures of the document

3) In the Select Certificate dialog (Figure 26), select your certificate, add an optional 
description, and click Sign to return to the Digital Signatures dialog. The certificate used 
is displayed in the dialog with an icon next to its name. This icon indicates the status of 
the digital signature.

4) Click Close in the Digital Signatures dialog to apply the digital signature.
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Figure 26: Signatures can have a description

Including a signature line
You can generate a graphic box representing a signature line using Insert > Signature Line (see
Figure 27), and you can optionally sign the signature line using a digital certificate.

Figure 27: Creating a signature line for a document
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Figure 28: Signature line example

Removing personal data

You may wish to ensure that personal data, versions, comments, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security, click the Options button to display a dialog 
(Figure 29) where you can set LibreOffice to warn you when files contain certain information 
and/or automatically remove personal information on saving.

Figure 29: Set security warnings and options

To remove personal and some other data from a file, go to File > Properties. On the General 
tab, uncheck Apply user data and click the Reset Properties button. This removes any names 
in the created and modified fields, deletes the modification and printing dates, and resets the 
editing time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list 
and click Delete, or (b) use Save As and save the file with a different name.

Redaction

You can redact documents to remove or hide sensitive information, to allow the selective 
disclosure of information in a document while keeping other parts of the document secret. For 
example, when a document is subpoenaed in a court case, information not specifically relevant to
the case at hand is often redacted.

To redact a document:

1) Open the document in Writer.

2) Click Tools > Redact on the Menu bar, and wait for the document to be prepared for 
redaction and transferred to Draw. The Redaction toolbar (Figure 30) opens.
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Figure 30: Redaction toolbar

3) Do the redaction by using the Rectangle Redaction and Freeform Redaction tools on 
the Redaction toolbar. The shapes will be transparent and in gray so you can see what 
you are redacting.

4) Optionally use the Export Directly as PDF tool to make an in-redaction copy of the 
document in PDF to use as a verbatim copy for review. The redacted items will be in 
transparent gray.

5) To finalize the redaction, select the desired option (black or white) on the Redacted 
Export tool. The transparent grey shapes are converted to opaque black or white shapes 
and the document is exported as a pixellized PDF. There will be no selectable text in it, 
and the redacted content will be non-existent.

Auto-redaction
To partially automate the redaction process, you can define certain words (such as names) to be 
redacted wherever they are found in the document. To do this, choose Tools > Auto-Redact on 
the Menu bar to open the Automatic Redaction dialog (Figure 31). Here you can load a list of 
terms (targets), add targets, delete targets, edit targets, and save a list of targets.

Figure 31: Automatic Redaction dialog
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