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Formatting objects

This chapter describes how to format the graphic objects created with the available drawing tools.

The format of each graphic object, in addition to its size, rotation and position on the slide, is 
determined by a number of attributes that define the line, text and area fill of each object. These 
attributes (among others) also contribute to a graphics style. Although this chapter discusses 
mainly the manual formatting of objects, it concludes by showing how to create, apply, modify and 
delete graphics styles.

Formatting lines
In LibreOffice the term line indicates both a freestanding segment and the outer edge of a shape. 
In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so 
on), its width and its color. All these options can be applied with a few clicks of the mouse. Select 
the line you need to format and then use the controls on the Line and Filling toolbar to select your 
desired options.

Figure 1: Common line options (style, width, color) highlighted

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or 
right-click on the line and select Line from the pop-up menu, or select the Line icon from the Line 
and Filling toolbar. All of these methods open the Line dialog shown in Figure 2, where you can set 
line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 2: Line properties dialog
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Line page
The Line page is where you can set the basic parameters of the line and is divided into four 
sections as follows.

Line properties section
The Line Properties section on the left side allows you to set the following parameters:

• Line style: several line styles are available from the drop-down list, but more line styles 
can be defined if necessary.

• Color: choose from the predefined colors in the drop down list or refer to “Creating custom
colors” on page 13 to create a new color.

• Width: specifies the thickness of the line.

• Transparency: sets the transparency of a line. Figure 3 illustrates the effects of different 
percentages of transparency to lines when placed over an object.

Figure 3: Line transparency effect (0%, 25%, 50%, 75% left to right)

Arrow styles section
The Arrow styles section of the Line dialog is only applicable to individual lines and is not used for 
lines that form the borders of a shape or polygon. To create a new arrow style, use Arrow styles on 
page 8.

• Style: sets the style of the two ends of a line. The left drop down menu is for where you 
start the line and the right drop down menu is for where you end the line.

• Width:  specifies the thickness of the arrow endings

• Center: moves the center of the arrow endings to the end point of the line. Figure 4 shows 
the effects of selecting this option.

• Synchronize ends: makes the two line ends identical.

Figure 4: Default arrowheads (left) and centered arrowheads (right)
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Arrowheads

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon  in 
the Line and Filling toolbar (Figure 1). This opens the Arrowheads menu (Figure 5), where you can 
choose one of the many predefined arrowhead styles for the start and ending of the selected line.

Figure 5: Arrowheads menu

Corner style section
Corner styles determines how the connection between two segments looks. There are four 
available options in the drop down menu. To appreciate the difference between corner styles, 
choose a thick line style and observe how the preview changes.

Preview section
The bottom part of the Line page previews the applied style for a line and two different corners so 
that the corner style selection can be evaluated.

Shadow page
Use the Shadow page of the Line dialog to add and format the line shadow. The settings on this 
page are the same as those for shadows applied to other objects and are described in Formatting
shadows on page 20.

A quicker way to apply a shadow to a line is using the Shadow icon  on the Line and Filling 
toolbar (Figure 1). The main disadvantage of using the Shadow icon is that the shadow 
appearance will be constrained by the shadow settings of the default graphics style.
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Line styles page
Use the Line Styles page (Figure 6) of the Line dialog to create new line styles as well as to load 
previously saved line styles. It is normally better to create new styles when necessary than to 
modify the predefined styles.

Figure 6: Creating line styles

To create a new line style:

1) Choose Format > Line from the menu bar, or right-click on the line and select Line from 
the pop-up menu, or select the Line icon from the Line and Filling toolbar.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add. On the pop-up dialog, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line 
selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the 

line style in other presentations, click the Save Line Styles icon  and type a unique 
filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon  and select a style 
from the list of saved styles. Click Open to load the style into your presentation.

11) If necessary, click on the Modify button to change the name of the style.
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Arrow styles page
Use the Arrow Styles page (Figure 7) of the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Figure 7: Creating arrow Styles

1) First draw a curve in the shape you want to use for the arrowhead or create a shape and 
convert to a curve. The top of the shape must face upward, as shown in Figure 8 because 
this becomes the point of the arrow.

Note
The arrowhead created must be convertible to a curve. A curve is something you can 

draw without lifting a pencil. For example,  can be converted to a  curve but   
cannot.

Figure 8: Using shapes for arrow styles

2) Select the shape and, if necessary, right click and choose Convert > To Curve to convert 
the shape to a curve. If the shape is already a curve, To Curve will not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click 
and choose Line from the pop-up menu.

4) Go to the Arrow styles page (Figure 7), click the Add button, type a name for the new 
arrow style, and click OK. The new arrowhead style will be shown in the preview.

5) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog.
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6) The new arrowhead style created is available only in the current document. If you want to 

use this arrowhead style in other presentations, click the Save Line Styles icon  and 
type a unique filename in the Save as dialog that opens. Saved styles have the file 
extension of .sod.

7) To use previously saved arrowhead styles, click the Load Line Styles icon  and select 
the style from the saved list of styles. Click Open to load the style into your presentation.

8) If necessary. click on the Modify button to change the name of the style.

Formatting the fill area

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching 
pattern, or bitmap (Figure 9). An area fill can be made partly or wholly transparent and can throw a 
shadow.

Figure 9: Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If 
this toolbar is not showing, choose View > Toolbars > Line and Filling from the menu bar. You 
can also use the Area dialog, described on page 11.

To format the area of an object, select it so that the selection handles show. A wide number of 
default fillings are readily available from the Line and Filling toolbar (Figure 10). Select from the 
Color pull-down menu the type of fill required (Figure 11). If you want no fill at all, select Invisible.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow 
or transparency.

Figure 10: Common fill options highlighted

Figure 11: Area fill types
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Color area fill
To change the area fill of an object to a color (Figure 12):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Color from the drop down list.

3) Select a color from the drop-down list.

Figure 12: Color area fill

Gradient area fill
A gradient fill provides a smooth transition from one color to another. The transition pattern may 
vary from a simple linear transition to a more complex radial transition. To change the area fill of an 
object to a gradient (Figure 13):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Gradient from the drop down list.

3) Select a gradient from the drop-down list.

Figure 13: Gradient area fill

Hatching or line pattern area fill
When a hatching fill is applied it fills the complete area of the selected object.. To change the area 
fill of an object to a hatching (Figure 14):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Hatching from the drop down list.

3) Select a hatching fill from the drop-down list.
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Figure 14: Hatching area fill

Bitmap image area fill
You can fill an object only with a bitmap image but not a vector graphic image. To change the area 
fill of an object to a bitmap image (Figure 15):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Bitmap from the drop down list.

3) Select a bitmap fill from the drop-down list.

Figure 15: Bitmap image area fill

Using the Area dialog
In addition to using the Line and Filling toolbar, you can use the Area dialog to apply existing area 
fills or create your own area fill. To open it, choose Format > Area from the menu bar, or click on 

the Area icon  on the Line and Filling toolbar, or right-click on the object and select Area.

Use the Area tab to apply predefined fills, both those supplied with LibreOffice and those you 
create yourself.

Use the Colors, Gradients, Hatching, and Bitmaps tabs to define new fills, as described in 
“Creating new area fills” on page 13. The Transparency tab is discussed on page 21. To make the 
object cast a shadow, see page 20.

To apply an area fill, first select the required fill type in the top left drop-down list. The page 
changes to show, in the middle section, the list of predefined styles for that fill type.
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Note In the Area dialog, the choice for no fill is None rather than Invisible.

When using the Area tab of the Area dialog, some additional options may become available once 
you have selected the fill type and one of the available fill styles.

• For color fills, select Color from the drop down list and then select your required color from 
the list of available colors. Click on the OK button and the fill color will appear in the 
selected shape (Figure 16).

Figure 16: Area color dialog

• For gradient fills, select Gradient from the drop down list and then select your required 
gradient from the list of available gradients. Click on the OK button and the fill gradient will 
appear in the selected shape (Figure 17). You can override the number of steps 
(increments) that should be applied to the gradient transition. To do so, deselect the 
Automatic option under Increments and then enter the number of steps required in the box 
to the right.

Figure 17: Area gradient dialog

• For hatching fills, select Hatching from the drop down list and then select your required 
hatching from the list of available hatchings. Click on the OK button and the fill hatching will 
appear in the selected shape (Figure 18). You can apply a different background color by 
selecting the Background color option and choosing a color from the drop down list.

Figure 18: Area hatching dialog
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• For bitmap fills, select Bitmaps from the drop down list and then select your required 
bitmap from the list of available bitmaps. Click on the OK button and the fill bitmap will 
appear in the selected shape (Figure 19). You can customize a large number of 
parameters. Refer to “Working with bitmap fills” on page 17 for additional information.

Figure 19: Area bitmap dialog

Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is 
recommended that you create new fills or modify custom fills rather than  the predefined ones, as 
these may be reset when updating LibreOffice.

Creating custom colors
On the Colors page (Figure 20), you can modify existing colors or create your own. You can also 
specify a new color either as a combination of the three primary colors Red, Green, and Blue, 
(RGB notation) or by percentages of Cyan, Magenta, Yellow, and Black (CMYK notation).

To create a new color:

1) Enter the name for the color in the Name box.

2) Select whether to define the color in RGB or CMYK. For RGB Specify the red (R), green 
(G) and blue (B) component on a 0 to 255 scale. For CMYK specify the cyan (C), magenta 
(M), yellow (Y) and black (K) components from 0% to 100%.

3) Click the Add button. The color is now added to the Color drop down list.
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Figure 20: Creating a new color

To modify a color:

1) Select the color to modify from the list.

2) Enter the new values that define the color in RGB or CMYK.

3) Modify the name as required.

4) Click the Modify button.

Alternatively, you can edit a color:

1) Click on the Edit button to open the Color Picker dialog (Figure 21).

Figure 21: Editing a color
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2) Modify the color components as required using RGB, CMYK or HSB (Hue, Saturation, 
Brightness).

3) Click OK to exit the Color Picker dialog.

4) Click the Modify button on the Color dialog then click the OK button.

The new color created is available only in the current document. If you want to use this color in 

other presentations, click the Save Color List icon  and type a unique filename in the Save as 
dialog that opens. The saved colors list has the file extension of .soc.

To use a previously saved color list , click the Load Color List icon  and select from the file 
open dialog. Click Open to load the saved color list into Impress.

Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This 
method makes the color available to all components of LibreOffice, whereas colors 
created using Format > Area > Colors are only available for Impress.

Creating custom gradients
To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog 
(Figure 23). Several types of gradients are predefined and in most cases changing the From and 
To colors will be sufficient to obtain the desired result.

It is highly recommended that you create a new gradient even if you just want to change the two 
colors, rather than modifying the predefined ones, which should be used only as starting points.

To create a new gradient:

1) First choose the From and To colors.

2) Then choose a type of gradient from the drop down list: Linear, Axial, Radial, Ellipsoid, 
Square or Rectangular.

Figure 22: Creating a new gradient
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3) A preview of the gradient type is shown under the available gradients list in the middle of 
the dialog.

4) Depending on the chosen type, some options will be grayed out. Set all the properties as 
desired (very often the default values will work well). The properties to set to create a 
gradient are summarized in Table 1.

5) Click the Add button to add the newly created gradient to the list.

The new gradient created is available only in the current document. If you want to use this gradient 

in other presentations, click the Save Gradients List icon  and type a unique filename in the 
Save as dialog that opens. The saved gradients list has the file extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon  and select from 
the file open dialog. Click Open to load the saved gradients list into Impress

Table 1: Gradient properties

Property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
shape.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

Creating custom hatching patterns
To create new hatching patterns or modify existing ones, select the Hatching tab of the Area dialog 
(Figure 23). As with gradients and colors, it is better to create a new hatching pattern rather than 
modify a predefined one. The properties that can be set for a hatching pattern are shown in Table
2.

To create a new hatching pattern:

1) Select as a starting point a pattern similar to the one that will be created.

2) Modify the properties of the lines forming the pattern. A preview is displayed in the window 
below the available patterns.

3) Click the Add button and choose a name for the newly created hatching.

The new hatching pattern created is available only in the current document. If you want to use this 

hatching pattern in other presentations, click the Save Hatches List icon  and type a unique 
filename in the Save as dialog that opens. The saved hatches list has the file extension of .soh.

To use a previously saved hatches list, click the Load Hatches List icon  and select from the 
file open dialog. Click Open to load the saved hatches list into Impress.
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Figure 23: Creating a new hatching pattern

Table 2: Properties of hatching patterns

Property Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.

Working with bitmap fills
On the Area tab, chose Bitmap from the drop-down list. Select from the list of bitmaps the one to 
be used to fill the area. Note that any imported bitmaps will become available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the page, and 
then click OK to close the dialog.

As Figure 24 shows, there are quite a number of parameters to be configured when using a bitmap 
fill. These are described in Table 3.

Table 3: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the bitmap.

Size – Relative To rescale the object, deselect Original and select Relative. The Width 
and Height edit boxes are enabled.
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Property Meaning

Size – Width When Relative is selected 100% means that the bitmap original width will  
be resized to occupy the whole fill area width, 50% means that the width 
of the bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the bitmap original height 
will be resized to occupy the whole fill area height, 50% means that the 
height of the bitmap will be half that of the fill area.

Position – Anchor Map Select from the map the place within the area to which the bitmap should 
be anchored.

Position – Tile When this option is selected, the bitmap will be tiled to fill the area. The 
size of the bitmap used for the tiling is determined by the Size settings.

Position – X offset When Tile is enabled, enter in this box the offset for the width of the 
bitmap in percentage values. 50% offset means that Impress will place 
the middle part of the bitmap at the anchor point and start tiling from 
there.

Position – Y offset This will have a similar effect to the X offset, but will work on the height of 
the bitmap.

Position – Autofit Stretches the bitmap to fill the whole area. Selecting this option disables 
all the size settings.

Offset – Row If Tile is enabled, offsets the rows of tiled bitmaps by the percentage 
entered in the box so that two subsequent rows are not aligned.

Offset – Column If Tile is enabled, offsets the columns of tiled bitmaps by the percentage 
entered in the box so that two subsequent columns of bitmaps are not 
aligned.

Figure 24: Advanced formatting for bitmap fill
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The best way to acquire understanding of these parameters is to use them. Figure 25 shows some 
examples of bitmap fills and the parameters used.

Figure 25: Examples of bitmap fill

Creating and importing bitmaps
You can add (import) new bitmap fills or create your own pattern on a 8x8 grid using the Bitmaps 
tab of the Area dialog (Figure 26).

To create a bitmap fill:

1) Start with the Blank bitmap type on top of the list to activate the Pattern Editor.

2) Select the Foreground and Background colors.

3) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you 
want in the foreground color. Use the right mouse button to apply the background color. 
Check the preview window to see if the desired effect is achieved.

4) When done, click Add to save the pattern.

To import a bitmap created in Draw or another program:

1) Click the Import button.

2) A file picker dialog is displayed and shows a list of compatible file types. Browse to the 
directory containing the bitmap file and select it, then click Open.

3) Type a name for the imported bitmap and click OK.

Note
Bitmaps generally have an extension .bmp or .png. To create a bitmap image with 
Draw, select File > Export, choose PNG from the pull-down list of file formats, give 
the file a name, and save it.
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The new bitmap created is available only in the current document. If you want to use this bitmap in 

other presentations, click the Save Bitmap List icon  and type a unique filename in the Save 
as dialog that opens. The saved bitmap list has the file extension of .sob.

Figure 26: Creating a new bitmap

To use a previously saved bitmap list, click the Load Bitmap List icon  and select from the file 
open dialog. Click Open to load the saved bitmap list into Impress.

Formatting shadows
Shadowing can be applied to lines, shapes and text.

To quickly apply a shadow to a line or shape only, first select the line or shape and then click on the 

Shadow icon  in the Line and Filling toolbar. The shadow applied using this method cannot be 
customized and is set to default settings.

For a more flexible way to apply a shadow to a line, shape or text, first select the object and then 
select Format > Area to open the Area dialog. Click on the Shadow tab to open the Shadow page 
(Figure 27). This will allow you to set the following properties for the shadow.

• Position: selects the point that determines the direction in which the shadow is cast.

• Distance: determines the distance between the object and the shadow.

• Color: sets the color of the shadow.

• Transparency: determines the amount of transparency for the shadow.

An alternative method for using shadows is to apply a style that uses a shadow See “Working with
graphics styles” on page 26 for additional information on using styles.
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Figure 27: Customizing a shadow

Transparency formatting
Transparency is applicable to objects as well as shadows. To apply transparency to lines, refer to 
“Formatting lines” on page 4; for shadows, refer to “Formatting shadows” on page 20.

To apply transparency to objects, select the object and then select Format > Area to open the Area 
dialog. Click on the Transparency tab to open the Transparency page shown (Figure 28).

Figure 28: Setting object transparency

Two types of transparency are available: uniform transparency and gradient transparency.

To create a uniform transparency, select Transparency and then select the percentage of 
transparency required.

To create a gradient transparency (so that the area becomes gradually transparent) select 
Gradient and then set the parameters of the gradient. Refer to Table 4 for a description of the 
properties.

More information on gradient transparency, including an example of combining color gradient with 
gradient transparency, can be found in “Advanced gradient controls” on page 22.
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Table 4: Gradient transparency properties

Property Meaning

Center X
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the vertical offset of the gradient center.

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradient, specifies the angle of 
the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% means 
fully transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% means fully 
transparent.

Advanced gradient controls
As discussed in “Creating custom gradients” on page 15, gradient properties can be configured 
using the properties given in the dialogs shown in Figure 23 and Table 1. Impress also provides a 
graphical interface for modifying the gradient parameters using only the mouse.

To use this tool, select an object with a gradient, then click on the Gradient icon  in the Mode 
toolbar (Figure 29). This displays a dashed line connecting to squares. The colors show the From 
and To colors that are used for the selected gradient (Figure 30).

Figure 29: Mode toolbar

Figure 30: From Red 4 to Yellow 1 gradient
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• For linear gradients: move the square corresponding to the From color to change where 
the gradient starts (border value). Move the square corresponding to the To color to change 
the orientation (angle value).

• For axial gradients: you can move only the To color to change both the angle and border 
properties of the gradient.

• For radial gradients: move the From color to modify the border property to set the width of 
the gradient circle. Move the To color to change the point where the gradient ends (Center 
X and Center Y values).

• For ellipsoid gradients: move the From color to modify the border property to set the size 
of the gradient ellipsoid. Move the To color to change the angle of the ellipsoid axis and the 
axis itself.

• For square and rectangular gradients: move the From color to modify the border to set 
the size of the gradient square or rectangle and the angle of the gradient shape. Move the 
To color to change the center of the gradient.

Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Formatting text

Impress provides two dialogs related to text formatting: Format > Character for individual 
characters and Format > Text for whole words, sentences or paragraphs.

To modify formatting such as font and font effects, select the text in the shape and then go to 
Format > Character or Format > Text. This section covers the formatting of the overall shape of 
text which is added to an object. For more information on formatting text, see Chapter 3, Adding 
and Formatting Text.

Figure 31: Text dialog
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To add text to an object:

1) Select the object to which text will be added so that the selection handles are showing.

2) Double-click on the object and the cursor becomes an I-beam to indicate text mode.

3) Type your text.

4) When finished, click outside of the object or press Esc.

To format the text in an object:

1) Select the object to which text was added.

2) Select Format > Text or right-click on the shape and select Text from the pop-up menu. 
The Text dialog is displayed (Figure 31).

The Text section of the dialog offers several options in the form of checkboxes. Some of the 
options will be grayed out, depending on the object to which the text has been attached.

• Fit width to text: expands the width of the object if the text is too long for it.

• Word wrap text in shape: starts a new line automatically when the edge of the object is 
reached.

• Fit height to text: expands the object height whenever it is smaller than the text (set by 
default for lines).

• Resize shape to fit text expands a custom object when the text inserted in the object is 
too large.

• Fit to frame: expands the text so that it fills all the available space.

• Adjust to contour: makes the text follow a curved line.

In the Spacing to borders section, specify the amount of space to be left between the borders of 
the object and the text. This is similar to setting indentation and spacing for paragraphs.

The Text anchor section is used to anchor the text to a particular point within the object. The Full 
width option for anchoring centers the text within the object and will use the full width of the object 
before wrapping text.

Figure 32: Text animation dialog

24 Formatting Graphic Objects



Text animation
The Text Animation dialog (Figure 32) adds animation effects to the text. Select one of four options 
from the drop down list. The animation direction of the effect, where applicable, is selected using 
one of the four arrow buttons to the right. The available effects are:

• No animation: default setting.

• Blink: the text will blink on the screen.

• Scroll through: the text will move into the object and then out following the selected 
direction.

• Scroll back and forth: the text will move first in the selected direction, but will bounce back 
at the object border.

• Scroll in: the text will scroll in towards the given direction starting from the edge of the 
object and stop in the center.

The other properties that can be set are:

• Start inside: when selected, the animation will start from inside the object.

• Text visible when editing: select this option to see the text while editing.

• Animation cycles: select either Continuous or a specific number of cycles for the 
animation.

• Increment: sets the amount the animation moves in either Pixels or a specific distance. 
Units of measurement depend on the settings in Tools > Options > LibreOffice Impress > 
General.

• Delay: sets the delay time either Automatically or a specific length of time before the 
animation starts.

To see some of the animations in action, it is necessary to start the presentation. Press F9 or 
select Slide Show > Slide Show from the main menu. To return to the edit mode, press Esc.

Formatting connectors

Connectors are lines that join two shapes and always start from or finish at a glue point on an 
object. Refer to Chapter 5, Managing Graphic Objects for a description of the use of connectors.

Figure 33: Connector properties dialog
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Connector properties can be accessed and modified in two ways:

• Right-click on the connector line and select Connector from the pop up menu.

• Select Format > Styles and Formatting or press the F11 key, then select Connector > 
Modify.

Both methods open the Connector dialog (Figure 33) where you can set the properties of the 
connectors.

• Type: sets the type of connector - Standard (default), Line, Straight, and Curved.

• Line skew: used where multiple connectors overlap to set the distance between the lines. 
You can customize the distance between four different lines.

• Line spacing: used to set the horizontal and vertical space between the connector and the 
object at each end of the connector.

Working with graphics styles

To achieve consistency in the style across the slides of a presentation, or a presentation portfolio, 
or to apply the same formatting to a large number of objects, the best approach is to use a 
graphics style.

Graphics styles are similar to paragraph styles for text. A graphics style groups all the formatting 
properties applicable to a graphical object and then associates this group of properties with a 
name. This makes a graphics style reusable for other graphical objects. If a graphics style is 
modified (for example, changing an area transparency), the changes are automatically applied to 
all objects using the same graphics style.

Figure 34: Graphics Styles and Formatting
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If you use Impress frequently, a library of well-defined graphics styles is an invaluable tool for 
speeding up the process of formatting your work according to your taste or any style guidelines you 
may need to follow (company colors, fonts and so on).

Click on the Graphics Styles icon  on the Styles and Formatting dialog (Figure 34) to access 
graphic styles. If the dialog is not open, press the F11 key, or click on the Styles and Formatting 

icon  on the formatting toolbar, or select Format > Styles and Formatting from the menu bar.

Linked graphics styles
Graphics styles support inheritance; that is, a style can be linked to another (parent) style so that it 
inherits all the formatting settings of the parent. You can use this property to create “families” of 
styles.

For example, if you need multiple boxes that differ in color but are otherwise identically formatted, 
the best way to proceed is to define a generic style for the box including borders, area fill, font, and 
so on and a number of hierarchically dependent styles which differ only in the fill color attribute. If 
later you need to change the font size or the thickness of the border, it is sufficient to change the 
parent style and all the other styles will change accordingly.

Creating graphics styles
You can create a new graphics style in two ways:

• Using the Style and Formatting dialog

• From a selection

Creating new graphics style using the Style and Formatting dialog

Click on the Graphics Styles icon  at the top of the Styles and Formatting window.

To link a new style with an existing style:

1) Select the style you want to use in the Styles and Formatting dialog (Figure 34).

2) Right click and select New to open the Graphics Styles dialog (Figure 35).

3) Give your new graphics style a memorable file name.

4) Use the various tabs and text boxes in the Graphics Styles dialog to format and categorize 
your new style.

5) Click on the OK button when finished to save your new graphics style.

Figure 35: Graphics Styles dialog
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The Graphics Styles dialog consists of several pages that may be grouped as follows:

• Organizer page contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography pages set the 
properties of the text inserted in a text box or in a graphic object.

• Dimensioning page is used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency pages 
determine the formatting of a graphic object and are discussed elsewhere in this chapter.

Note
When styles are linked, changing the font for example will change the font in all linked 
styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all linked styles. It pays to plan ahead.

Creating new graphics style from a selected object
You can create a new style from an object that has already been formatted. This can be text or 
graphics:

1) Select the object you want to use to create your new style.

2) Open the Styles and Formatting dialog and click the New Style from Selection icon 
(Figure 36).

3) In the Create Style dialog (Figure 37) type a name for the new style. The list shows existing 
custom styles of that are available.

4) Click OK to save the new style.

Figure 36: New style from selection

Figure 37: Naming a new style created from a selection

Modifying a graphics style
To modify an existing style, right-click on it in the Styles and Formatting dialog and choose Modify 
from the pop-up menu. The dialog for the modification of a graphics style is the same as the dialog 
for creating a new graphics style (Figure 35). Make the required changes to the style and then click 
OK to save them.
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Updating a graphics style from a selection
To update a style from a select object:

1) Select an object that uses the format you want to adopt as a style.

2) In the Styles and Formatting dialog, select the style you want to update, and then click the 
Update Style icon (Figure 38).

Figure 38. Updating a style from a selection

Tip

Any changes you make to a style are effective only in the document on which you are 
working and do not go into change the associated template. If you want the changes 
to apply to more than one document, you need to change the template (see Chapter  
2 Using Slide Masters, Styles, and Templates).

Applying graphics styles
You can apply a graphics style in two ways using the Styles and Formatting dialog. First make sure 
that the graphics styles are shown (Figure 34), then do one of the following:

• Select the object to which you want to apply a graphics style and double-click on the name 
of the style you want to apply.

• Click the Fill Format mode icon  and the mouse pointer changes to this icon. Position 
the icon on the graphic object to be styled and click the mouse button. This mode remains 
active until you turn it off, so you can apply the same style to several objects. To quit Fill 
Format mode, click the Fill Format mode icon again or press the Esc key.

• When Fill Format mode is active, a right-click anywhere in the document cancels the last 
Fill Format action. Be careful not to accidentally right-click and thus undo actions you want 
to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or groups of styles such as applied styles or (in the case of  
graphics styles) custom styles.

Deleting graphics styles
You cannot delete any of the predefined styles in Impress, even if you are not using them. You can 
only delete user-defined (custom) styles. However, before you delete a custom style, make sure 
the style is not in use. If an unwanted style is in use, replace it with a substitute style.
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To delete custom styles, right-click on them (one at a time) in the Styles and Formatting window 
and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Assigning styles to shortcut keys
LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while working with a document. You can redefine these shortcuts or define your own, as described 
in Appendix A, Keyboard Shortcuts.
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