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Toolbars and menus

To change object attributes, such as color or border width, and so on, use the Line and Filling 
toolbar, the Text Formatting toolbar, or the context menu.

Line and Filling toolbar
If the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling to open 
the toolbar (Figure 1). The most common object attributes can be edited using this toolbar. You can 

also open the Line dialog by clicking on the Line icon  and the Area dialog by clicking on the Area 

icon  for access to more formatting options.

Figure 1: Line and Filling toolbar

The tools available on the Line and Filling toolbar from left to right are shown in Figure 2.

Figure 2: Tools available on 
Line and Filling toolbar

Text Formatting toolbar
When you select text, the Line and Filling toolbar automatically changes to show the Text 
Formatting toolbar (Figure 3). You can also open the Text Formatting toolbar by selecting View > 
Toolbars > Text Formatting. The tools on this toolbar will not become active until text has been 
selected.

Figure 3: Text Formatting toolbar

The tools available on the Text Formatting toolbar from left to right are shown in Figure 4.
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Figure 4: Tools available on Text Formatting toolbar

Context menu
When an object is selected and you right-click on the object, a context menu (Figure 5) opens that 
applies to the selected object. This context menu provides access to the options available and 
allows you to change object attributes without having to open a dialog. Menu entries with a small 
arrow on the right-hand side contain a submenu.

Figure 5: Context menu
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Formatting lines

In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape 
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid, 
dashed, invisible, and so on), its width and its color.

Select the line you need to format and then use the controls on the Line and Filling toolbar to 
change the most common options highlighted in Figure 6.

Figure 6: Common line properties (style, color, width)

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or 

right-click on the line and select Line from the context menu, or select the Line icon  from the 
Line and Filling toolbar. All of these methods open the Line dialog (Figure 7), where you can set 
line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 7: Line properties dialog

Line properties
The Line page is where you can set the basic parameters of the line and is divided into four 
sections as follows.

Line properties section
The Line Properties section on the left side allows you to set the following parameters:

• Line style: several line styles are available from the drop-down list, but more line styles 
can be defined if necessary.

• Color: choose from the predefined colors in the drop down list or create a new color.
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• Width: specifies the thickness of the line.

• Transparency: sets the transparency of a line. Figure 8 shows the effects of different 
percentages in transparency levels to lines when placed over an object.

Figure 8: Line transparency effect (0%, 25%, 50%, 75% left to right)

Arrow styles section
The Arrow styles section of the Line dialog is only applicable to individual lines and is not used for 
lines that form the borders of a shape.

• Style: sets the style of the two ends of a line. The left drop down menu is for where you 
start the line and the right drop down menu is for where you end the line.

• Width:  specifies the thickness of the arrow endings

• Center: moves the center of the arrow endings to the end point of the line. Figure 14 shows 
the effects of selecting this option.

• Synchronize ends: makes the two line ends identical.

Figure 9: Default arrowheads (left) and centered arrowheads (right)

Arrowheads

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon  in the 
Line and Filling toolbar. This opens the Arrowheads menu (Figure 10), where you can select one of 
the many predefined arrowhead styles for the start and ending of the selected line.

Note
Arrowheads are only applicable to lines. They have no effect on the border of an 
object.
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Figure 10: Arrowheads menu

Corner style section
Corner styles determines how the connection between two segments looks. There are four 
available options in the drop down menu. To appreciate the difference between corner styles, 
choose a thick line style and observe how the preview changes.

Preview section

The bottom part of the Line page previews the applied style for a line and its corners so that the 
corner style selection can also be evaluated.

Line shadows
Use the Shadow page (Figure 11) of the Line dialog to add and format the line shadow. The 
settings on this page are the same as those for shadows applied to other objects and are 
described in “Formatting shadows” on page 23.

Figure 11: Shadow page of Line properties dialog

A quicker way to apply a shadow to a line is using the Shadow icon  on the Line and Filling 
toolbar. The main disadvantage of using the Shadow icon is that the shadow appearance will be 
constrained by the shadow settings of the default graphics style.
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Line styles
Use the Line Styles page (Figure 12) of the Line dialog to create new line styles as well as to load 
previously saved line styles. It is normally better to create new styles when necessary than modify 
predefined styles.

Figure 12: Creating line styles

Creating line styles
To create a new line style:

1) Choose Format > Line from the menu bar, or right-click on the line and select Line from 
the pop-up menu, or select the Line icon from the Line and Filling toolbar.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add. On the pop-up dialog, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line 
selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the 

line style in other documents, click the Save Line Styles icon  and type a unique 
filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon  and select a style 
from the list of saved styles. Click Open to load the style into your document.

11) If necessary, click on the Modify button to change the name of the style.Arrow styles
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Use the Arrow Styles page (Figure 13) of the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Figure 13: Creating arrow styles

Creating arrow styles
To create a new arrow style:

1) First draw a curve in the shape you want to use for the arrowhead, or create a shape and 
convert to a curve. The top of the shape must face upward, as shown in Figure 14, 
because this becomes the point of the arrow.

Figure 14: Using shapes for arrow styles

Note
The arrowhead must be a curve, which is something you can draw without lifting a 
pencil from the paper. For example, a star ¶ can be a curve but a smiley face J 
cannot be a curve.

2) Select the shape and, if necessary, right click and choose Convert > To Curve to convert 
the shape to a curve. If the shape is already a curve, To Curve will not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click 
and choose Line from the pop-up menu.

4) Go to the Arrow styles page, click the Add button, type a name for the new arrow style, and 
click OK. The new arrowhead style will be shown in the preview.
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5) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog.

6) The new arrowhead style created is available only in the current document. If you want to 

use this arrowhead style in other documents, click the Save Line Styles icon  and type 
a unique filename in the Save as dialog that opens. Saved styles have the file extension 
of .sod.

7) To use previously saved arrowhead styles, click the Load Line Styles icon  and select 
the style from the saved list of styles. Click Open to load the style into your document.

8) If necessary. click on the Modify button to change the name of the style.

Formatting fill area

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching 
pattern, or bitmap (Figure 15). An area fill can be made partly or wholly transparent and can throw 
a shadow.

Figure 15: Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If 
this toolbar is not showing, choose View > Toolbars > Line and Filling from the menu bar. You 
can also use the Area dialog, described in “Using the Area dialog” on page 14.

To format the area of an object, select it so that the selection handles show. A wide number of 
default fillings are readily available from the Line and Filling toolbar (Figure 16). Select from the 
Color pull-down menu the type of fill required (Figure 17). If you want no fill at all, select Invisible.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow 
or transparency.

Figure 16: Common fill options highlighted

Figure 17: Area fill types
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Color area fill
To change the area fill of an object to a color (Figure 18):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Color from the drop down list.

3) Select a color from the drop-down list.

Figure 18: Color area fill

Gradient area fill
A gradient fill provides a smooth transition from one color to another. The transition pattern may 
vary from a simple linear transition to a more complex radial one. To change the area fill of an 
object to a gradient (Figure 19):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Gradient from the drop down list.

3) Select a gradient from the drop-down list.

Figure 19: Gradient area fill

Hatching or line pattern area fill
When a hatching fill is applied it fills the complete area of the selected object. To change the area 
fill of an object to a hatching (Figure 20):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Hatching from the drop down list.

3) Select a hatching fill from the drop-down list.
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Figure 20: Hatching area fill

Figure 21: Bitmap image area fill

Bitmap image area fill
You can fill an object only with a bitmap image but not a vector graphic image. To change the area 
fill of an object to a bitmap image (Figure 21):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Bitmap from the drop down list.

3) Select a bitmap fill from the drop-down list.

Using the Area dialog
In addition to using the Line and Filling toolbar, you can use the Area dialog to apply existing area 
fills or create your own area fill. To open it, choose Format > Area from the menu bar, or click on 

the Area icon  on the Line and Filling toolbar, or right-click on the object and select Area.

Use the Area tab to apply predefined fills, both those supplied with LibreOffice and those you 
create yourself.

Use the Colors, Gradients, Hatching, and Bitmaps tabs to define new fills, as described in 
“Creating new area fills” on page 16. The Transparency tab is discussed in “Transparency
formatting” on page 24. To make the object cast a shadow, see “Formatting shadows” on page 23.

To apply an area fill, first select the required fill type in the top left drop-down list. The page 
changes to show, in the middle section, the list of predefined styles for that fill type.
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Note In the Area dialog, the choice for no fill is None rather than Invisible.

When using the Area tab of the Area dialog, some additional options may become available once 
you have selected the fill type and one of the available fill styles.

• For color fills, select Color from the drop down list and then select your required color from 
the list of available colors (Figure 22). Click on the OK button and the fill color will appear in 
the selected shape.

Figure 22: Area color dialog

• For gradient fills, select Gradient from the drop down list and then select your required 
gradient from the list of available gradients (Figure 23). Click on the OK button and the fill 
gradient will appear in the selected shape. You can override the number of steps 
(increments) that should be applied to the gradient transition. To do so, deselect the 
Automatic option under Increments and then enter the number of steps required in the box 
to the right.

Figure 23: Area gradient dialog

• For hatching fills, select Hatching from the drop down list and then select your required 
hatching from the list of available hatchings (Figure 24). Click on the OK button and the fill 
hatching will appear in the selected shape. You can apply a different background color by 
selecting the Background color option and choosing a color from the drop down list.

Figure 24: Area hatching dialog
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• For bitmap fills, select Bitmaps from the drop down list and then select your required 
bitmap from the list of available bitmaps (Figure 25). Click on the OK button and the fill 
bitmap will appear in the selected shape. You can customize a large number of parameters. 
Refer to “Working with bitmap fills” on page 20 for additional information.

Figure 25: Area bitmap dialog

Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is 
recommended that you create new fills, or modify custom fills rather than the predefined ones, as 
these may be reset when updating LibreOffice.

Creating custom colors
On the Colors page (Figure 26), you can modify existing colors or create your own. You can also 
specify a new color either as a combination of the three primary colors Red, Green, and Blue, 
(RGB notation) or by percentages of Cyan, Magenta, Yellow, and Black (CMYK notation).

To create a new color:

1) Enter the name for the color in the Name box.

2) Select whether to define the color in RGB or CMYK. For RGB Specify the red (R), green 
(G) and blue (B) component on a 0 to 255 scale. For CMYK specify the cyan (C), magenta 
(M), yellow (Y) and black (K) components from 0% to 100%.

3) Click the Add button. The color is now added to the Color drop down list.
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Figure 26: Creating a new color

To modify a color:

1) Select the color to modify from the list.

2) Enter the new values that define the color in RGB or CMYK.

3) Modify the name as required.

4) Click the Modify button.

Alternatively, you can edit a color:

1) Click on the Edit button to open the Color Picker dialog (Figure 27).

Figure 27: Editing a color
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2) Modify the color components as required using RGB, CMYK or HSB (Hue, Saturation, 
Brightness).

3) Click OK to exit the Color Picker dialog.

4) Click the Modify button on the Color dialog then click the OK button.

The new color created is available only in the current document. If you want to use this color in 

other documents, click the Save Color List icon  and type a unique filename in the Save as 
dialog that opens. The saved colors list has the file extension of .soc.

To use a previously saved color list, click the Load Color List icon  and select from the file 
open dialog. Click Open to load the saved color list into Draw.

Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This 
method makes the color available to all components of LibreOffice.

Creating custom gradients
To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog 
(Figure 28). Several types of gradients are predefined and in most cases changing the From and 
To colors will be sufficient to obtain the desired result.

It is highly recommended that you create a new gradient even if you just want to change the two 
colors, rather than modifying the predefined ones, which should be used only as starting points.

Figure 28: Creating a new gradient

To create a new gradient:

1) First choose the From and To colors.

2) Then choose a type of gradient from the drop down list: Linear, Axial, Radial, Ellipsoid, 
Square or Rectangular.
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3) A preview of the gradient type is shown under the available gradients list in the middle of 
the dialog.

4) Depending on the chosen type, some options will be grayed out. Set all the properties as 
desired (very often the default values will work well). The properties to set to create a 
gradient are summarized in Table 1.

5) Click the Add button to add the newly created gradient to the list.

The new gradient created is available only in the current document. If you want to use this gradient 

in other documents, click the Save Gradients List icon  and type a unique filename in the 
Save as dialog that opens. The saved gradients list has the file extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon  and select from 
the file open dialog. Click Open to load the saved gradients list into Draw.

Table 1: Gradient properties

Property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
shape.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

Creating custom hatching patterns
To create new hatching patterns or modify existing ones, select the Hatching tab of the Area dialog 
(Figure 28). As with gradients and colors, it is better to create a new hatching pattern rather than 
modify a predefined one. The properties that can be set for a hatching pattern are shown in Table
2.

To create a new hatching pattern:

1) Select as a starting point a pattern similar to the one that will be created.

2) Modify the properties of the lines forming the pattern. A preview is displayed in the window 
below the available patterns.

3) Click the Add button and choose a name for the newly created hatching.

The new hatching pattern created is available only in the current document. If you want to use this 

hatching pattern in other documents, click the Save Hatches List icon  and type a unique 
filename in the Save as dialog that opens. The saved hatches list has the file extension of .soh.

To use a previously saved hatches list, click the Load Hatches List icon  and select from the 
file open dialog. Click Open to load the saved hatches list into Draw.
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Figure 29: Creating a new hatching pattern

Table 2: Properties of hatching patterns

Property Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.

Working with bitmap fills
On the Area tab, chose Bitmap from the drop-down list. Select from the list of bitmaps the one to 
be used to fill the area. Note that any imported bitmaps will become available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the page, and 
then click OK to close the dialog.

As Figure 30 shows, there are quite a number of parameters to be configured when using a bitmap 
fill. These are described in Table 3.
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Figure 30: Advanced formatting for bitmap fill

Table 3: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the bitmap.

Size – Relative To rescale the object, deselect Original and select Relative. The Width and 
Height edit boxes are enabled.

Size – Width When Relative is selected 100% means that the bitmap original width will be 
resized to occupy the whole fill area width, 50% means that the width of the 
bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the bitmap original height will be 
resized to occupy the whole fill area height, 50% means that the height of the 
bitmap will be half that of the fill area.

Position – Anchor 
Map

Select from the map the place within the area to which the bitmap should be 
anchored.

Position – Tile When this option is selected, the bitmap will be tiled to fill the area. The size 
of the bitmap used for the tiling is determined by the Size settings.

Position – X offset When Tile is enabled, enter in this box the offset for the width of the bitmap in 
percentage values. 50% offset means that Draw will place the middle part of  
the bitmap at the anchor point and start tiling from there.

Position – Y offset This will have a similar effect to the X offset, but will work on the height of the 
bitmap.

Position – Autofit Stretches the bitmap to fill the whole area. Selecting this option disables all  
the size settings.

Offset – Row If Tile is enabled, offsets the rows of tiled bitmaps by the percentage entered 
in the box so that two subsequent rows are not aligned.

Offset – Column If Tile is enabled, offsets the columns of tiled bitmaps by the percentage 
entered in the box so that two subsequent columns of bitmaps are not aligned.
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The best way to acquire understanding of these parameters is to use them. Figure 31 shows some 
examples of bitmap fills and the parameters used.

Figure 31: Examples of bitmap fill

Creating and importing bitmaps
You can add (import) new bitmap fills or create your own pattern on a 8x8 grid using the Bitmaps 
tab of the Area dialog (Figure 32).

Figure 32: Creating a new bitmap
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To create a bitmap fill:

1) Start with the Blank bitmap type on top of the list to activate the Pattern Editor.

2) Select the Foreground and Background colors.

3) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you 
want in the foreground color. Use the right mouse button to apply the background color. 
Check the preview window to see if the desired effect is achieved.

4) When done, click Add to save the pattern.

To import a bitmap created in another program:

1) Click the Import button.

2) A file picker dialog is displayed and shows a list of compatible file types. Browse to the 
directory containing the bitmap file and select it, then click Open.

3) Type a name for the imported bitmap and click OK.

The new bitmap created is available only in the current document. If you want to use this bitmap in 

other documents, click the Save Bitmap List icon  and type a unique filename in the Save as 
dialog that opens. The saved bitmap list has the file extension of .sob.

To use a previously saved bitmap list, click the Load Bitmap List icon  and select from the file 
open dialog. Click Open to load the saved bitmap list into Draw.

Formatting shadows
Shadowing can be applied to lines, shapes and text.

To quickly apply a shadow to a line or shape only, first select the line or shape and then click on the 

Shadow icon  in the Line and Filling toolbar. The shadow applied using this method cannot be 
customized and is set to default settings.

Figure 33: Customizing a shadow

For a more flexible way to apply a shadow to a line, shape or text, first select the object and then 
select Format > Area to open the Area dialog. Click on the Shadow tab to open the Shadow page 
(Figure 33). This will allow you to set the following properties for the shadow.

• Position: selects the point that determines the direction in which the shadow is cast.

• Distance: determines the distance between the object and the shadow.

• Color: sets the color of the shadow.

• Transparency: determines the amount of transparency for the shadow.
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Transparency formatting
Transparency is applicable to objects as well as shadows. To apply transparency to lines, refer to 
“Formatting lines” on page 7; for shadows, refer to “Formatting shadows” on page 23.

To apply transparency to objects, select the object and then select Format > Area to open the Area 
dialog. Click on the Transparency tab to open the Transparency page (Figure 34).

Two types of transparency are available: uniform transparency and gradient transparency.

To create a uniform transparency, select Transparency and then select the percentage of 
transparency required.

To create a gradient transparency (so that the area becomes gradually transparent) select 
Gradient and then set the parameters of the gradient. Refer to Table 4 for a description of the 
properties.

More information on gradient transparency, including an example of combining color gradient with 
gradient transparency, can be found in “Advanced gradient controls” on page 25.

Figure 34: Setting object transparency

Table 4: Gradient transparency properties

Property Meaning

Center X
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the vertical offset of the gradient center.

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradient, specifies the angle of  
the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% means 
fully transparent.
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Property Meaning

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% means fully 
transparent.

Advanced gradient controls
As discussed in “Creating custom gradients” on page 18, gradient properties can be configured 
using the properties given in the dialogs shown in Figure 28 and Table 1.

To use this tool, select an object with a gradient, then click on the Gradient icon  in the Mode 
toolbar (Figure 35). This displays a dashed line connecting two colored squares. The colors show 
the From and To colors that are used for the selected gradient (Figure 36).

• For linear gradients: move the square corresponding to the From color to change where 
the gradient starts (border value). Move the square corresponding to the To color to change 
the orientation (angle value).

• For axial gradients: you can move only the To color to change both the angle and border 
properties of the gradient.

Figure 35: Mode toolbar

Figure 36: From Red 4 to Yellow 1 gradient

• For radial gradients: move the From color to modify the border property to set the width of 
the gradient circle. Move the To color to change the point where the gradient ends (Center 
X and Center Y values).

• For ellipsoid gradients: move the From color to modify the border property to set the size 
of the gradient ellipsoid. Move the To color to change the angle of the ellipsoid axis and the 
axis itself.

• For square and rectangular gradients: move the From color to modify the border to set 
the size of the gradient square or rectangle and the angle of the gradient shape. Move the 
To color to change the center of the gradient.
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Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. 
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a 
formatting template (a style) and then to apply that style to multiple objects. For more information 
on styles, see Chapter 6 Introduction to Styles in the Writer Guide.

Click on the Styles and Formatting  icon on the Line and Filling toolbar or press the F11 key 

to open the Styles and Formatting dialog, then click on the Graphics Styles icon  in the top left 
corner of the dialog (Figure 37). This will open a list of styles available for use with graphics.

Figure 37: Styles and Formatting dialog

Linked graphics styles
Graphics styles support inheritance; that is, a style can be linked to another (parent) style so that it 
inherits all the formatting settings of the parent. You can use this property to create families of 
styles.
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For example, if you need multiple boxes that differ in color but are otherwise identically formatted, 
the best way to proceed is to define a generic style for the box including borders, area fill, font, and 
so on. Then create a number of hierarchically dependent styles which differ only in the fill color 
attribute. If you then need to change the font size or the thickness of the border, it is sufficient to 
change the parent style and all the other linked styles will change accordingly.

Creating graphics styles
You can create a new graphics style in two ways:

• Using the Style and Formatting dialog

• From a selection

Using Style and Formatting dialog

Click on the Graphics Styles icon  in the top left corner of the Styles and Formatting dialog.

To link a new style with an existing style:

1) Select the style you want to use in the Styles and Formatting dialog (Figure 37).

Figure 38: Graphics Styles dialog

2) Right click and select New to open the Graphics Styles dialog (Figure 38).

3) Give your new graphics style a memorable file name.

4) Use the various tabs and text boxes in the Graphics Styles dialog to format and categorize 
your new style.

5) Click on the OK button when finished to save your new graphics style.

The Graphics Styles dialog consists of several pages that may be grouped as follows:

• Organizer page contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography pages set the 
properties of the text inserted in a text box or in a graphic object.

• Dimensioning page is used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency pages 
determine the formatting of a graphic object.

Note
When styles are linked, changing a color for example will change the color in all linked 
styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all linked styles. It pays to plan ahead.
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Figure 39: New style from selection

Figure 40: Naming a new style created from a selection

Using a selected object
You can create a new style from an object that has already been formatted. This can be text or 
graphics:

1) Select the object you want to use to create your new style.

2) Open the Styles and Formatting dialog and click the New Style from Selection icon 
(highlighted in Figure 39).

3) In the Create Style dialog (Figure 40) type a name for the new style. The list shows existing 
custom styles of that are available.

4) Click OK to save the new style.

Modifying a graphics style
To modify an existing style, right-click on it in the Styles and Formatting dialog and choose Modify 
from the pop-up menu. The dialog for the modification of a graphics style is the same as the dialog 
for creating a new graphics style (Figure 38). Make the required changes to the style and then click 
OK to save them.

Updating from a selection
To update a style from a select object:

1) Select an object that uses the format you want to adopt as a style.

2) In the Styles and Formatting dialog, select the style you want to update, and then click the 
Update Style icon (highlighted in Figure 41).
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Figure 41. Updating a style from a selection

Applying graphics styles
You can apply a graphics style in two ways using the Styles and Formatting dialog. First make sure 
that the graphics styles are shown (Figure 37), then do one of the following:

• Select the object to which you want to apply a graphics style and double-click on the name 
of the style you want to apply.

• Click the Fill Format mode icon  and the mouse pointer changes to this icon. Position 
the icon on the graphic object to be styled and click the mouse button. This mode remains 
active until you turn it off, so you can apply the same style to several objects. To quit Fill 
Format mode, click the Fill Format mode icon again or press the Esc key.

• When Fill Format mode is active, a right-click anywhere in the document cancels the last 
Fill Format action. Be careful not to accidentally right-click and thus undo actions you want 
to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or groups of styles such as applied styles or (in the case of  
graphics styles) custom styles.

Deleting graphics styles
You cannot delete any of the predefined styles in Draw, even if you are not using them. You can 
only delete user-defined (custom) styles. However, before you delete a custom style, make sure 
the style is not in use. If an unwanted style is in use, replace it with a substitute style.

To delete custom styles, right-click on them (one at a time) in the Styles and Formatting window 
and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also 
be applied to objects in Draw. Several of these effects are readily available in the Mode toolbar 
(Figure 42). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.

This section describes how to rotate, flip, or distort an object, and two ways of setting an object in a 
circle.
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Figure 42: Mode toolbar and available options

The tools are described in the following sections with the exception of the 3D rotation tool, which is 
described in Chapter 7 Working with 3D Objects.

Rotating graphic objects
Rotation of an object can be carried out manually or using a dedicated dialog, just like changing 
object position and size.

To rotate an object manually:

1) Click on an object and the selection handles will show.

2) Click the Rotate icon  in the Drawing or Mode toolbar.

3) The selection handles change shape and also change color (Figure 43).

4) Move the mouse over one of the corner handles and the mouse cursor shape will change. 
Click the mouse and move in the direction in which you want to rotate the object. Only the 
corner selection handles are active for rotation.

5) When satisfied release the mouse button.

Figure 43: Object selected for rotation
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Note

The icons representing the functions in the toolbars may be different depending on 
the operating system used and on whether LibreOffice has been customized. When 
in doubt, hover the mouse over an icon and wait for the tooltip to appear showing the 
name of the icon.

When the Rotate icon is clicked, a circle appears in the middle of the selected object to indicate the 
pivot point for rotation. Normally the center of an object will be just fine, but on some occasions you 
may wish to rotate around a corner or even around a point outside the picture. To move the rotation 
point, click on the circle and drag it to the desired position.

To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating 
the graphic. This is very handy for rotating pictures through a right angle, for example from portrait 
to landscape.

Instead of rotating a graphic object manually, you can use the Rotation dialog (Figure 44). To 
display this dialog, select the graphic object so that the selection handles are shown, then press 
F4 or select Format > Position and Size and select the Rotation page.

In the upper part of the dialog, select the position of the pivot point relative to the top left corner of 
the page. The default position of the pivot point is the center of the figure.

In the lower part of the dialog select the angle by which to rotate the graphic object. To the right of 
the Angle text box, eight default rotation values can be selected.

Figure 44: Rotation page of Position and Size dialog

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the selection handles will show.

2) Right click and select Flip > Horizontally or Flip > Vertically and the selected object will 
be flipped to face the other direction.
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Figure 45: Using the Flip tool

The Flip tool on the Drawing or Mode toolbar can also be used. Using this tool also allows you to 
change the position and angle that the object flips over (Figure 45).

1) Click on a graphic object and the colored selection handles will show.

2) Click on the Flip icon  and the axis of symmetry appears as a dashed line through the 
middle of the object. The object will be flipped about this axis of symmetry.

3) Move one or both ends of the axis of symmetry with your mouse cursor to set the 
orientation of the axis.

4) Place the mouse cursor over one of the object selection handles until it changes shape.

5) Click and hold, then move your cursor across to the other side of the axis of symmetry. The 
new position of the figure is shown faintly until the mouse is released.

6) Release the mouse button and the object will appear flipped over. The angle and position of 
the flip will depend on the angle and position of the axis of symmetry.

Note
If you press the Shift key while moving the line, the line will rotate in 45-degree 
increments.
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Mirror copies
At the moment there is no mirror command existing in Draw. However, mirroring an object can be 
emulated by using the Flip tool as follows:

Figure 46: Making a mirror copy of an object

1) Select the object you want to make a mirror copy of (Figure 46).

2) Copy the object to the clipboard.

3) Select the Flip tool on the Drawing or Mode toolbar.

4) Move the axis of symmetry to the desired location of the mirror axis.

5) Flip the object.

6) Click on an empty area of the page to deselect the object.

7) Paste from the clipboard to put a copy of the object in its original location and now you 
have a mirror copy.

Distorting an image
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the 
image.

• Distort tool  distorts an object in perspective.

• Set to Circle (slant)  creates a pseudo three-dimensional effect.

• Set in Circle (perspective)  creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. The results of using these tools are shown in the following figures.

Distort tool

Select an object and click on the Distort icon  on the Mode toolbar. After converting to a curve 
as requested, move the handles to stretch the object. The corner handles distort the corners, the 
vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically 
(Figure 47).
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Figure 47: Distorting an image

Figure 48: Setting an image to a circle with perspective

Set in circle (perspective)

Select an object and click on the Set in Circle (perspective) icon  in the Mode toolbar. After 
converting to a curve , move the object handles to give a pseudo three-dimensional perspective) 
(Figure 48).

Set to circle (slant) tool

Select an object and click on the Set to Circle (slant) icon  in the mode toolbar. After 
converting to a curve, move the object handles to give a pseudo three-dimensional slant 
perspective (Figure 49).
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Figure 49: Setting an image to a circle with slant

Note
Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.

Dynamic gradients
You can control transparency gradients in the same manner as color gradients. Both types of 
gradient can be used together. With a transparency gradient, the direction and degree of object fill 
color changes from opaque to transparent. In a color gradient, the fill changes from one color to 
another, but the degree of transparency remains the same.

Two icons are present on the Mode toolbar to dynamically control transparency and color 
gradients. Even if you have not assigned transparency to an object with a color fill, you can control 

the transparency by clicking on the Transparency icon . This defines a transparency gradient 
and a dashed line connecting two squares appears on the object. Move the two squares to modify 
the gradient. You can define the direction of the gradient (vertical, horizontal, or at any angle) and 
the spot at which the transparency begins.

A regular color gradient is defined in the same manner. Select an object, choose a gradient fill from 

the Line and Filling toolbar. The Gradient icon  is now active on the Mode toolbar. When you 
click on the gradient icon, a dashed line connecting two squares appears on the object, just as it 
does for a transparency gradient.

In both transparency gradient and gradient fill, click outside the object to set the gradient.

Note
Moving the squares will have different effects, depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.
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Example 1
A single color object and a transparency gradient, covering part of the underlying object. The 
gradient can be dynamically adjusted; the direction of transparency by moving the white square or 
the distance over which it is applied by moving the black square (Figure 50).

Figure 50: Example 1 of a dynamic gradient

Example 2
An object with a color gradient, completely covering another object. The gradient is adjusted 
dynamically by moving the squares – the color of the square relating to the increase or decrease in 
that color (Figure 51).

Figure 51: Example 2 of a dynamic gradient

Example 3
An object with both color and transparency gradients, partly covering the underlying object (Figure
52).

Figure 52: Example 3 of a dynamic gradient
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