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Introduction

LibreOffice Draw can create 2D and 3D objects. This chapter shows how to draw simple 2D 
objects. The following chapters describe how to work with and edit such objects. For more 
information on 3D objects, see Chapter 7, Working with 3D Objects.

All shapes, such as lines, rectangles, or more complicated shapes, are called objects. This is 
common notation in vector drawing software.

The most commonly used drawing tools are found on the Drawing toolbar (Figure 1) and this 
toolbar is normally docked on the left side of the main Draw window. If the toolbar is not visible, 
go to View > Toolbars on the Menu bar and select Drawing from the available options.

As with all the components of LibreOffice, the Drawing toolbar can be unlocked and placed the 
Draw workspace as a floating toolbar. Toolbars can be configured by adding, moving, hiding, or 
deleting tools. See Chapter 1, Introducing Draw for more information.

When a shape is drawn, an object selected for editing, or text added to the drawing, the 
information field in the Status Bar (Figure 2) changes to reflect the action taken or in progress. 
See Chapter 1, Introducing Draw for more information on the Status Bar.

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The default set of tools available for 
drawing basic shapes on the Drawing toolbar are shown in Figure 1. To add more tools to the 
Drawing toolbar, see Appendix B, Toolbars and the Getting Started Guide for more information.

Figure 1: Drawing toolbar

Figure 2: Status Bar
1) Slide (drawing) number
2) Information area
3) Master drawing
4) Cursor position

5) Selected object size
6) Scaling factor of the 

document
7) Unsaved changes

8) Digital signature
9) Fit drawing

10) Zoom slider
11) Zoom percentage
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Some tool icons on the Drawing toolbar change shape according to the last tool used from the 
selection of available tools. Each tool that has a triangle ▼ next to the tool icon indicates that 
more tools are available. See “Drawing geometric shapes” on page 16 for information on the 
available shapes.

Note

When a basic shape is drawn, or one selected for editing, the information area at 
the left side in the Status Bar changes to reflect the present action. For example 
Line created, Text frame xxyy selected, and so on.

Straight lines

Creating straight lines
A straight line is the simplest element or object in Draw to create.

1) Use one of the following options to draw a straight line:

– Click Insert Line on the Drawing toolbar.

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar and select 
Insert Line from the options available.

– Click Insert Line in the Line and Arrows panel of the Shapes deck on the Sidebar 
(Figure 3).

Figure 3: Lines and Arrows panel in Shapes deck on Sidebar

Figure 4: Line starting point
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2) Place the cursor at the starting point on the drawing, then click and drag the cursor to 
draw a straight line.

3) Release when the end point is reached and a straight line is created.

Notes

A selection handle appears at each end of the line, showing that this object is the 
currently selected object. The selection handle at the starting point of a line is 
slightly larger than the selection handle at the end point (highlighted in Figure 4).

To snap the end of a straight line to the nearest grid point, keep the Ctrl 
(macOS ) key pressed while drawing the straight line. This is the default ⌘
behavior of the Ctrl (macOS ) key. If the option ⌘ View > Snap Guides > Snap 
to Grid on the Menu bar has been selected, pressing the Ctrl (macOS ) key ⌘
while drawing a straight line temporarily deactivates the Snap to Grid option.

To restrict the drawing angle of a straight line to a multiple of 45 degrees (0, 45, 
90, 135, and so on), keep the Shift key pressed while drawing a straight line. If 
the option When creating or moving objects in the Constrain Objects section of
Tools > Options > LibreOffice Draw > Grid (macOS LibreOffice > Preferences
> LibreOffice Draw > Grid) has been selected, pressing the Shift key 
temporarily deactivates this restriction.

To draw a straight line symmetrically outwards in both directions from the start 
point, keep the Alt (macOS ) key pressed while drawing the straight line. This ⌥
draws straight lines from the middle of the straight line.

Figure 5: Line dialog - Line page
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Figure 6: Line panel in Properties deck on Sidebar

Figure 7: Line and Filling toolbar

Formatting straight lines
When a straight line is drawn, it uses default attributes. To change any of these attributes to the 
drawing requirements, select the straight line by clicking on it to display the selection handles and
use one of the following methods to format the selected straight line:

• Go to Format > Line on the Menu bar to open the Line dialog (Figure 5).

• Right-click on the line and select Line from the submenu to open the Line dialog.

• Open the Line panel in the Properties deck on the Sidebar (Figure 6).

• Use the tools Line Style, Line Width, and Line Color on the Line and Filling toolbar 
(Figure 7).

Lines and arrows
Draw classifies both lines and arrows as lines and are drawn like straight lines (for more 
information, see “Straight lines” on page 5). Hovering the cursor over each tool in the Lines and 
Arrows sub-toolbar, or the Line and Arrows panel in the Shapes deck on the Sidebar, indicates 
what type of line or arrow each tool draws. The information field on the Status Bar shows them 
only as lines.
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Figure 8: Lines and Arrows sub-toolbar
1) Insert Line
2) Line Ends with Arrow
3) Line with Circle/Arrow
4) Line with Square/Arrow

5) Line with Arrows
6) Line Starts with Arrow
7) Line with Arrow/Circle
8) Line with Arrow/Square

9) Dimension Line
10) Line (45º)

Creating lines or arrows

Note

The tool icon for the last tool used on a sub-toolbar is already selected on the 
Drawing toolbar. This makes it easier to use the same tool again.

1) Use one of the following methods to draw a line or arrow:

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar and select 
the type of line or arrow required on the Lines and Arrows sub-toolbar (Figure 8).

– Select the type of line or arrow required in the Lines and Arrows panel of the Shapes
deck on the Sidebar (Figure 3 on page 5).

2) Place the cursor at the starting point for the line or arrow, then click and drag the cursor. 
The arrowhead(s) is drawn at the end(s) of the line when the line is completed.

3) For more information on how to draw lines and arrows, see “Straight lines” on page 5.

Formatting line or arrow
After drawing a line or arrow, make sure it is selected and format the line or arrow to the drawing 
requirements using one of the following methods:

1) To format the line used for an arrow, see “Straight lines” on page 5 for more information.

2) To format an arrow using the same arrowhead style for both ends of the arrow:

a) Select the arrow so that the selection handles are displayed.

b) Go to Format > Line on the Menu bar or right-click on the arrow to open the Line 
dialog.

c) Click on Arrow Styles to open the Arrow Styles page (Figure 9).

d) Select an arrow style from the options available in the Arrow style drop-down list.

e) Click OK to apply the arrow style and close the Line dialog.

f) Click in an empty space on the drawing to deselect the arrow.

3) To format an arrow using different arrowhead styles for each end of the arrow:

a) Select the arrow so that the selection handles are displayed.

b) Open the Line panel on the Properties deck of the Sidebar (Figure 10).

c) In Line, click on Arrow Style to open the drop-down list for arrowhead styles.

d) Select an arrowhead style from the left-hand list of arrowhead styles for the start point 
of the arrow.
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e) Select an arrowhead style from the right-hand list of arrowhead styles for the end point 
of the arrow.

f) Click in an empty space on the drawing to deselect the arrow.

Figure 9: Line dialog - Arrow Styles page

Figure 10: Arrowhead styles in Line panel in Properties deck on Sidebar
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Figure 11: Shapes deck on Sidebar

Figure 12: Legacy Rectangles toolbar

Rectangles or squares
1) Use one of the following methods to start drawing a rectangle or square:

– Click on Rectangle on the Drawing toolbar.

– Select the type of rectangle or square in the Basic Shapes panel in the Shapes deck 
on the Sidebar (Figure 11).

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar and select the 
type of rectangle or square required from the drop-down list.

– Select the type of rectangle or square on the Legacy Rectangles toolbar (Figure 12). 
To display the Legacy Rectangles toolbar, go to View > Toolbars on the Menu bar 
and select it.

2) Place the cursor at the starting point for the rectangle or square, then click and drag the 
cursor until the required size is drawn. The rectangle or square is drawn from the starting 
point using the bottom right corner as the anchor point for the cursor.
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3) If necessary, use one of the following options to draw a rectangle or square:

– If a rectangle option is selected, hold down the Shift key while dragging the cursor 
to draw a square.

– If a rectangle option is selected, hold down the Alt key while dragging the cursor to 
draw a rectangle from its center.

– If a rectangle option is selected, hold down the Shift and Alt keys while dragging 
the cursor to draw a square from its center.

– If a square option is selected, hold down the Shift key while dragging the cursor to 
draw a rectangle.

– If a square option is selected, hold down the Alt key while dragging the cursor to 
draw a square from its center.

Note

If the option When creating or moving objects has been selected in the Constrain
Object section of Tools > Options > LibreOffice Draw > Grid (macOS 
LibreOffice> Preferences > LibreOffice Draw > Grid), the action of the Shift 
key reversed. A square is drawn instead of a rectangle. To draw a rectangle, hold 
down the Shift key. This reversal of the Shift key action also applies when 
drawing ellipses, circles, arcs, and segments.

Ellipses or circles
1) Use one of the following methods to start drawing an ellipse or circle:

– Click on Ellipse on the Drawing toolbar.

– Select the type of ellipse or circle in the Basic Shapes panel in the Shapes deck on 
the Sidebar.

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar and select the 
type of ellipse or circle required from the drop-down list.

– Select the type of ellipse or circle on the Legacy Circles and Ovals toolbar 
(Figure 13). To display the Legacy Circles and Ovals toolbar, go to View > Toolbars 
on the Menu bar and select it.

2) Place the cursor at the starting point for the ellipse or circle, then click and drag the cursor
until the required size is drawn. The ellipse or circle is drawn from the starting point using 
the bottom right corner as the anchor point for the cursor.

3) If necessary, use one of the following options while drawing an ellipse or circle:

– If an ellipse option is selected, hold down the Shift key while dragging the cursor to 
draw a circle.

– If an ellipse option is selected, hold down the Alt key while dragging the cursor to 
draw an ellipse from its center.

Figure 13: Legacy Circles and Ovals toolbar
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– If an ellipse option is selected, hold down the Shift and Alt keys while dragging the
cursor to draw a circle from its center.

– If a circle option is selected, hold down the Shift key while dragging the cursor to 
draw an ellipse.

– If a circle option is selected, hold down the Alt key while dragging the cursor to draw 
a circle from its center.

Tip

To quickly insert a line, rectangle, ellipse, or text, press and hold down the Ctrl 
(macOS ) key and then click on ⌘ Line, Rectangle, Ellipse, or Text and a 
standard sized object is drawn automatically in the Workspace. The size, shape, 
and color are all standard values. These attributes can be changed later, if 
desired. See Chapter 4, Changing Object Attributes for more information.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 14). A dimension line 
does not belong to the object itself, but is positioned close to it. An object can have as many 
dimension lines as necessary to indicate the size of its sides, edges, and distances.

To format the display of a dimension line and its components, right-click on the dimension line 
and selecting Dimensions from the context menu to open the Dimension line dialog (Figure 15).

Inserting dimension lines
1) Use one of the following options to start drawing a dimension line:

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar and select 
Dimension Line from the drop-down list.

– Click on Dimension Line in the Lines and Arrows panel of the Shapes deck on the 
Sidebar.

2) Place the cursor at the point close to the object to position the start of the dimension line.

3) Click and drag to draw the dimension line. As the dimension line is drawn, the dimension 
is displayed and automatically calculated.

4) Select the dimension line, then right-click on the dimension line and select Dimensions 
from the context menu to open the Dimension Line dialog.

Figure 14: Example of dimension lines on an object
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Figure 15: Dimension Line dialog

5) Format the dimension line using the options available the. For more information 
dimension line options, see Chapter 11, Advanced Draw Techniques.

6) Click OK to save the changes and close the Dimension Line dialog.

7) Click in an empty space on the drawing to deselect the dimension line.

Note

The measurement units used for dimension lines can be changed by going to 
Tools > Options > LibreOffice Draw > Grid on the Menu bar and select a 
measurement unit from the available options in the Units of measurement 
drop-down list.

Arcs and segments
1) Use one of the following methods to start drawing an arc or segment (partial circles or 

ellipses):

– Select the type of arc or segment in the Basic Shapes panel in the Shapes deck on 
the Sidebar.

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar and select the 
type of arc or segment required from the drop-down list.

– Select the type of arc or segment from the Legacy Circles and Ovals toolbar. To 
display the Legacy Circles and Ovals toolbar, go to View > Toolbars on the Menu bar
and select it.

2) Click, hold and drag the cursor to start creating an arc or segment. Release when the 
required object size is reached.

3) Move the cursor to the position where the arc or segment starts and click to start drawing 
the arc or segment. The Status Bar indicates the angle in degrees.
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4) Move the cursor to the end position of where the arc or segment finishes. The Status Bar
shows the angle in degrees.

5) Click again to complete the arc or segment.

Curves, polygons or freeform lines
Select the required tool for drawing curves, polygons, or freeform lines using one of the following 
methods:

• Click on the triangle ▼ next to Curves and Polygons on the Drawing toolbar and select 
the type of curve, polygon or freeform line from the drop-down list.

• Select the type of curve, polygon or freeform line in the Curve and Polygons panel of 
the Shapes deck on the Sidebar.

Curves
1) Click, hold and drag the cursor from the starting point to draw a line.

2) Release and continue to drag the cursor to bend the line into the required curve shape.

3) Click to set the end point of the curve and position the curve on the drawing.

4) Continue dragging the cursor to draw straight lines at the end of the curve. Each click sets
a corner point and allows drawing of another straight line from each corner point.

5) Double-click to end the drawing of a curve and straight lines.

Note

A filled curve automatically joins the last point to the first point to close off the 
object and fills it with the selected fill. A curve without filling is not closed at the 
end of the drawing.

Polygons
1) Click, hold and drag the cursor to draw a line between the first and second corner points.

2) Click again to end the drawing between the first and second corner points of the polygon.

3) Move the cursor to draw the next line and click to finish drawing to the next corner point. 
Each click sets a corner point and draws another line.

4) Double-click to end the drawing of a polygon.

Note

A filled polygon automatically joins the last corner point to the first corner point to 
close off the figure and fills it with the selected fill. A polygon without filling is not 
closed at the end of the drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted 
to 45 or 90 degrees. If required, hold down the Shift key as the line is drawn so that the line is 
drawn at an angle other than 45 or 90 degrees.

Freeform lines
Using freeform line tools is similar to drawing with a pencil on paper.

1) Click, hold and drag the cursor to the line shape required, then release to complete the 
drawing of the freeform line.
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2) If Freeform Line Filled is selected, the end point is joined automatically to the start point 
and the object is filled with the selected fill.

Note

The points in curves, polygons and freeform lines can be moved and edited. See 
Chapter 3, Working with Objects and Chapter 11, Advanced Draw Techniques for 
more information.

Gluepoints and connectors

Gluepoints
All Draw objects have , which are not normally displayed, become visible when Connectors is 
selected on the Drawing toolbar or a connector tool is selected in the Connectors panel on the 
Shapes deck in the Sidebar.

Most objects have four gluepoints, as shown in the example in Figure 16. More gluepoints can be
added and customized using the Gluepoints toolbar (Figure 17). Go to View > Toolbars > 
Gluepoints on the Menu bar to open the toolbar.

Gluepoints are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Gluepoints are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object. For a more detailed
description on the use of gluepoints, see Chapter 3, Working with Objects and Object Points and 
Chapter 8, Connections, Flowcharts, and Organization Charts.

Figure 16: Example of gluepoints on an object 

Figure 17: Gluepoints toolbar
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Figure 18: Example of connector between two objects

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are not the same as lines and arrows. When objects are moved or reordered, the 
connectors remain attached to a gluepoint. Figure 18 shows an example of two objects and a 
connector.

Draw offers a range of different connectors and connector functions. On the Drawing toolbar, 
click on the triangle ▼ next to Connectors and select a connector type from the drop-down list, or
select a connector from the Connectors panel in the Shapes deck on the Sidebar. For a more 
detailed description of the use of connectors, see Chapter 8, Connections, Flowcharts, and 
Organization Charts.

Drawing geometric shapes

The tools for drawing geometric shapes are located on the Drawing toolbar and the Shapes deck 
in the Sidebar. The use of these tools for geometric shapes is similar to the tools used for 
drawing rectangles and squares, or ellipses and circles. For more information, see “Drawing 
basic shapes” on page 4.

Clicking on the triangle ▼ to the right of a tool icon on the Drawing toolbar opens a drop-down list
giving access to the toolset for that shape. If necessary, this drop-down list can be “torn off” to 
create a floating sub-toolbar.

• Click and hold on the dotted line at the top of the toolset (highlighted in Figure 19), then 
drag it across the screen to the Workspace and release to create a floating toolbar

• To close a floating toolbar, click on the X on the right of the toolbar title.

Figure 19: Example of creating a floating toolbar

16 | Chapter 2, Drawing Basic Shapes



Notes

The tool icons on the Drawing toolbar always indicate the last geometric shape 
drawn and may not be the same as the tool icons shown on the Drawing toolbar 
in this chapter. The last tool used remains on the Drawing toolbar making it easier
to use the same tool again.

Text can be added to all of these geometric shapes. For more information, see 
Chapter 11, Advanced Draw Techniques.

Basic shapes
Clicking on the triangle ▼ to the right of Basic Shapes on the Drawing toolbar opens the Basic 
Shapes sub-toolbar (Figure 20). This sub-toolbar also includes rectangle and ellipse tools that 
are identical to the ones already displayed on the Drawing toolbar. Alternatively, select the 
required tool from the Basic Shapes panel in the Shapes deck on the Sidebar.

Figure 20: Basic Shapes sub-toolbar

Symbol shapes
Clicking on the triangle ▼ to the right of Symbol Shapes on the Drawing toolbar opens the 
Symbol Shapes sub-toolbar (Figure 21). Alternatively, select the required tool from the Symbol 
Shapes panel in the Shapes deck on the Sidebar.

Figure 21: Symbol Shapes sub-toolbar

Block arrows
Clicking on the triangle ▼ to the right of Block Arrows on the Drawing toolbar opens the Block 
Arrows sub-toolbar (Figure 22). Alternatively, select the required tool from the Block Arrows 
panel in the Shapes deck on the Sidebar.

Figure 22: Block Arrows sub-toolbar
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Flowcharts
Clicking on the triangle ▼ to the right of Flowchart on the Drawing toolbar opens the Flowchart 
sub-toolbar (Figure 23) for symbols. Alternatively, select the required tool from the Flowchart 
panel in the Shapes deck on the Sidebar. The creation of flowcharts, organization charts, and 
similar planning tools are further described in Chapter 8 Connections, Flowcharts and 
Organization Charts.

Figure 23: Flowchart sub-toolbar

Callouts
Clicking on the triangle ▼ to the right of Callout on the Drawing toolbar opens the Callouts 
sub-toolbar (Figure 24). Alternatively, select the required tool from the Callouts panel in the 
Shapes deck on the Sidebar.

Figure 24: Callouts sub-toolbar

Stars and banners
Clicking on the triangle ▼ to the right of Stars and Banners on the Drawing toolbar opens the 
Stars and Banners sub-toolbar (Figure 25). Alternatively, select the required tool from the Stars 
and Banners panel in the Shapes deck on the Sidebar.

Figure 25: Stars and Banners sub-toolbar

3D Objects
Clicking on the triangle ▼ to the right of 3D Objects on the Drawing toolbar opens the 
3D-Objects sub-toolbar (Figure 26). Alternatively, select the required tool from the 3D-Objects 
panel in the Shapes deck on the Sidebar.

Figure 26: 3D-Objects sub-toolbar
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Adding, inserting and formatting text

In Draw text can be added, inserted, and formatted to in text boxes, objects, and shapes. For 
more information on how to add, insert, and format text in a drawing, see Chapter 9, Adding and 
Formatting Text.
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