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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click
depending on computer setup

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/
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Introduction
This chapter describes some common customizations that you may wish to do, in addition to the
options described in Chapter 20, Setting up Writer.
You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Note
Customizations to menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in
Chapter 10, Working with Templates.

Customizing menu content
You can add to and rearrange menus on the Menu bar, add commands to menus, and make other
changes. You can also modify context (right-click) menus in a similar way.
To customize menus:
1)

Choose Tools > Customize.

2)

On the Customize dialog, go to the Menus page (Figure 1) or the Context Menus page.

Figure 1: The Menus page of the Customize dialog
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3)

In the LibreOffice Writer Menus section, select from the Menu drop-down list the menu that
you want to customize. The list includes all the main menus as well as submenus, that is
menus that are contained under another menu. For example, in addition to File, Edit, View,
and so on, there are File | Send, File | Templates, and others. The commands contained in
the selected menu are shown in the central part of the dialog (Menu Content).

4)

In the Save In drop-down list below the Menu Content box, choose whether to save this
changed menu for the application (Writer) or for a selected document.

5)

To customize the selected menu, click one of the buttons on the right of the Entries list.
These actions are described in the following sections. Use the up and down arrows next to
the Entries list to move the selected command to a different position.

6)

When you have finished making all your changes, click OK to save them.

Creating a new menu
On the Menus page of the Customize dialog, click New to display the New Menu dialog (Figure 2).
(Not available for context menus.)
1)

Type a name for the new menu in the Menu name box.

2)

Use the up and down arrow buttons to move the new menu into the required position on the
Menu bar.

3)

Click OK to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
Menu bar itself after you save your customizations.)
After creating a new menu, you need to add some commands to it, as described in “Adding a
command, a separator, or a submenu to a menu” on page 6.

Figure 2: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button to drop down a list
of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the
entries in the Menu list. For example, Rename and Delete are not available for the supplied
menus, and Move is not available for submenus.
To move a menu (such as File), click the Menu button and select Move. A dialog similar to the one
shown in Figure 2 (but without the Menu name box) opens. Use the up and down arrow buttons to
move the menu into the required position.
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To move commands (such as Close) and submenus (such as File | Send), select the main menu
item (File) in the Menu list and then, in the Menu Content section of the Customize dialog, select
the command or submenu (Send) in the Entries list and use the arrow icons to move it up or down
in the sequence. Submenus are easily identified in the Entries list by a small black triangle on the
right hand side of the name.
To move the commands on a submenu, select the submenu in the Menu list and then, in the Menu
Content section of the Customize dialog, select the command and use the arrow icons to move it
up or down in the sequence.
To rename a custom menu, select it in the Menu list, click the Menu button, and select Rename.
To rename a menu item or a submenu, select the item in the Entries list, click the Modify button
and select Rename.

Note
Changes to the menus are not immediately displayed. Changes saved to LibreOffice
Writer's menu are displayed the next time Writer is opened. Changes saved to a
document's menu are displayed the next time the document is opened.

Adding a command, a separator, or a submenu to a menu
You can add commands to both the supplied menus and menus you have created. On the
Customize dialog, select the menu in the Menu list and click the Add Command button in the
Menu Content section of the dialog. The Add Commands dialog (Figure 3) is displayed.

Figure 3: Adding a command to a menu
On the Add Commands dialog, select a category and then the command, and click Add. The
dialog remains open, so you can select several commands. When you have finished adding
commands, click Close. Back on the Customize dialog, you can use the up and down arrow
buttons to arrange the commands in your preferred sequence.
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In addition to adding commands, you can add submenus and group separators by clicking the
appropriate button on the Customize dialog.
After adding a submenu, you can select it in the Menu list in the top section of the page and add
commands to it. A separator line is added after the highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. The controls on the Toolbars page of the Customize dialog (Figure 4) are similar to those
on the Menus page.

Figure 4: The Toolbars page of the Customize dialog

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
To choose an icon for a command, select the command in the Toolbar Content – Commands list in
the Customize dialog, and click Modify > Change icon. On the Change Icon dialog, scroll through
the available icons, select one, and click OK to assign it to the command.
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons must be 16×16 in size and cannot contain
more than 256 colors.
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Assigning shortcut keys
In addition to using the built-in keyboard shortcuts, you can define others. You can assign shortcuts
to standard LibreOffice functions or your own macros and save them for use with Writer or with the
entire LibreOffice suite.
To adapt shortcut keys to your needs, use the Keyboard page of the Customize dialog (Figure 5):
1)

Choose whether to have the shortcut key assignment available in all components of
LibreOffice or only in Writer.

2)

Select the desired shortcut key in the Shortcut keys list at the top of the page.

3)

Select the required function from the Category and Function lists.

4)

Click the Modify button. The selection now appears in the Keys list on the lower right.

5)

Click OK to accept the change.

Repeat as required.

Note
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Figure 5: Defining keyboard shortcuts for applying styles

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.
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Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, so you can create and apply different configurations as needed. To save keyboard
shortcuts to a file:
1)

After making keyboard shortcut assignments, click the Save button on the Customize
dialog (Figure 5).

2)

In the Save Keyboard Configuration dialog, type a name for the keyboard configuration file
in the File name box, or select an existing file from the list. Browse to the location where
you want to save the file.

3)

Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load
button on the Customize dialog, and then select the configuration file from the Load Keyboard
Configuration dialog.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. For example, a common use is to assign the “open
document” event to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Several extensions are shipped bundled with LibreOffice and are installed with the program.
Others can be downloaded from various websites. The official extension repository is located at
http://extensions.libreoffice.org/. These extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
Extensions can be installed in these ways:
•

Directly from the *.oxt file in your system's file browser. Double-click the file.

•

Directly from Tools > Extension Manager, as follows:
1)

In LibreOffice, select Tools > Extension Manager from the Menu bar.

2)

In the Extension Manager dialog (Figure 6), click Add.

3)

A file browser window opens. Find and select the extension you want to install and click
Open.

4)

Users with administrator or root privileges will see a dialog where they can choose to
install extensions "for all users" (shared) or "only for me" (user). Users without those
privileges can install, remove, or modify extensions only for their own use.

5)

The extension begins installing.
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In each case, during the process you may be asked to accept a license agreement. When the
installation is complete, the extension is listed in the Extension Manager dialog.

Tip
To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online link. You do not need to
download them separately.

Figure 6: Using the Extension Manager
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