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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens context menu

Ctrl Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Designing a presentation
In addition to careful planning of the content (as discussed in Chapter 1 Introducing Impress), you
need to plan the appearance of the presentation. It is best to do this after you have developed an
outline, because the outline will determine some of the requirements for the appearance of the
slides. For example:

• What color combinations (background and text) will look good and also be easy for your
audience to read?

• Would a picture help your audience understand the contents better?
• Do you want particular text and a picture to appear on all the slides? (for example a
company name and logo.)

• Would the audience benefit from having the slides numbered so that they can quickly refer
to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that does
not interfere or clash with content such as the colors used in charts.

• Will you need one slide master or more than one? Will one slide design suit all of the
content?
You can change the appearance of slides as you develop the presentation, but planning ahead will
save you time in the long run.

What are slide masters?
A slide master is a slide that is used as the starting point for other slides. It is similar to a page style
in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than
one slide master.

Note

LibreOffice uses three terms for one concept: slide master, master slide, and master
page. All refer to a slide which is used to create other slides. This book uses the term
slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers
and footers; placement and size of text frames; and the formatting of text.
All of the characteristics of slide masters are controlled by styles. The styles of any new slide you
create are inherited from the slide master from which it was created. In other words, the styles of
the slide master are available and applied to all slides created from that slide master. Changing a
style in a slide master results in changes to all the slides based on that slide master. It is, however,
possible to modify each individual slide without affecting the slide master.

Note

Although it is highly recommended to use the slide masters whenever possible, there
are occasions where manual changes are needed for a particular slide, for example
to enlarge the chart area when the text and chart layout is used.

Slide masters have two types of styles associated with them: presentation styles and graphic
styles. Both these style types can be modified. New graphic styles can be created but new
presentation styles cannot..
Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphic
styles is covered in Chapter 6, Formatting Graphic Objects. See also “Working with styles in
Impress” on page 15.
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Working with slide masters
Impress comes with a collection of slide masters. These slide masters are shown in the Master
Pages section of the Tasks pane (Figure 1). This section has three subsections: Used in This
Presentation, Recently Used, and Available for Use. Click the expand marker (usually a downwardpointing triangle or + sign) next to the name of a subsection to expand it and show thumbnails of
the slides, or click the collapse marker (usually an upward-pointing triangle or a – sign) to collapse
the subsection to hide the thumbnails.

Figure 1: Available master pages (slide masters)
Each of the slide masters shown in the Available for Use list is from a template of the same name.
If you have created your own templates, or added templates from other sources, slide masters
from those templates will also appear in this list. See “Working with templates” on page 15 for more
about templates.

Creating slide masters
You can create a new slide master in a similar way to modifying the default slide master.
To start, enable editing of slide masters by selecting View > Master > Slide Master and the
Master View toolbar opens. You can also right-click on the slide master in the Master Pages
section of the tasks pane and select Edit Master to open the Master View toolbar. On the Master
View toolbar, click the New Master icon (highlighted in Figure 2).

Figure 2: Master View toolbar
A second slide master appears in the Slides pane. Modify this slide master to suit your
requirements. It is recommended that you rename this new slide master. To do that, right-click on
the slide in the Slides pane and select Rename master from the pop-up menu. When you are
done, close the Master View toolbar to return to normal slide editing mode.
Working with slide masters
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Applying a slide master
In the Tasks Pane, be sure the Master Pages section is showing (Figure 1).
To apply one of the slide masters to all slides in your presentation, click on it in the list.
To apply a different slide master to one or more selected slides:
1) In the Slides Pane, select the slides you want to change.
2) In the Master Pages section of the Tasks Pane, right-click on the slide master you want to
apply to the selected slides and click Apply to Selected Slides on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong
to different templates (the use of templates is explained later in “Working with templates” on page
15). For example, you may need a completely different layout for the first slide of the presentation,
or you may want to add a slide from a different presentation to your current presentation (based on
a template available on the hard disk).
The Slide Design dialog (Figure 3) makes this possible. Access this dialog either from the menu
bar (Format > Slide design) or from the pop-up menu that appears when right-clicking on a slide
in the Slides pane.

Figure 3: Slide Design
The main area in the dialog shows the slide masters already available for use. To add more:
1) Click the Load button.
2) Select in the Load Slide Design dialog (Figure 4) the template from which to load the slide
master and click OK.
3) Click OK again to close the slide design dialog.
The slide masters in the template you selected are now shown in the Available for use subsection
in the Master Pages section of the Tasks pane.
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Figure 4: Load Slide Design dialog for selecting templates

Note

Tip

The slide masters you have loaded will also be available the next time you load the
presentation. If you want to delete the unused slide masters, click the corresponding
checkbox in the Slide Design dialog.
To limit the size of the presentation file, you may want to minimize the number of
slide masters used.

Modifying a slide master
The following items can be changed on a slide master:

•
•
•
•
•

Background (color, gradient, hatching, or bitmap)
Background objects (for example, adding a logo or decorative graphics)
Text attributes for the main text area and notes
Size, placement, and contents of header and footer elements to appear on every slide
Size and placement of default frames for slide titles and content

Figure 5: Example of a slide with several modifications

Modifying a slide master
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To select the slide master for modification:
1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of the
slide master so you can edit it.
2) Click Master Pages in the Tasks pane. This gives you access to the slide masters.
3) Click on the slide master you want to modify (Figure 1).
4) Make changes as described in this chapter, then click the Close Master View icon on the
Master View toolbar. Save the file before continuing.

Caution

Any changes made to one slide when in Master View mode will appear on all slides
using this slide master. Always make sure you close Master View and return to
Normal view before working on any of the presentation slides. Select View > Normal
from the menu bar, or clicking Close Master View in the Master View toolbar to
return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point
style, the color of the title area, and so on) will not be overridden by subsequent changes to the
slide master. There are cases, however, where it is desirable to revert a manually modified element
of the slide to the style defined in the slide master: to do that, select that element and choose
Format > Default Formatting from the menu bar.
It is also possible to modify the default layout of the slide master, for example by moving the title to
the side; however, you are restricted to modifications to the “Title, Text” layout (that is, the layout
containing a title box and a text box).
Sometimes, depending on the contents of the slide, you may want to apply a different layout. The
title and text boxes will inherit the properties of the slide master, but if you have changed the
position of these text boxes in the slide master, the layout may appear corrupted and you may
need to re-position some of the layout elements manually.

Choosing and applying the background
Backgrounds can be applied to a number of elements in Impress: the page, a default text area, a
graphic object and so on. The procedures to apply a background are always the same.
The following procedure is used to apply a background to the page.
1) To begin, do one of the following:

• Select Format > Page from the menu bar. On the Page Setup dialog, choose the
Background tab (Figure 7).
OR

• Select Format > Styles and Formatting from the menu bar (or press F11) and make
sure the Presentation Styles icon is selected (Figure 6), then right-click Background
and select Modify from the pop-up menu. This opens the Background dialog, which has
one tab (Area) that is the same as the Background tab in the Page Setup dialog.
2) Select the type of fill you want for your background from the five choices in the drop-down
menu (Figure 7): None, Color, Gradient, Hatching, or Bitmap.
3) A list of choices for the selected fill type then appears. Figure 8 shows an example of
background colors.
4) Select one of the items on the Fill list and click OK. The fill you have chosen is added to the
slide master, replacing any previously selected fill.
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Figure 6: Presentation Styles

Figure 7: Background choices on Page Setup dialog

Figure 8: Selecting a background color in the Page Setup dialog

Modifying a slide master

9

Tip

You can make custom additions to each type of background, with the obvious
exception of None. After you create new fills, they are listed in the Background dialog
along with the fills provided with LibreOffice (see Chapter 6 for more information).

Adding background objects
This section describes how to add background objects and graphic elements (such as a logo,
decorative lines, and so on). LibreOffice supports a large number of graphic formats.
When you want the same graphic to appear on every slide of your presentation, the easiest and
quickest solution is to use the slide master. It saves time while creating the presentation and when
you want to modify or reposition the graphic on the slide. If the graphic is added to each slide
manually, these operations have to be performed on each individual slide in the presentation.
One of the most common actions in preparing a presentation is to add a picture to the slide master.
To insert a picture already available on the computer, follow these steps:
1) Choose View > Master > Slide Master from the menu bar.
2) Select from the menu bar Insert > Picture > From File.
3) Navigate to the directory where your picture is located and select it. If you want to see a
preview, select the corresponding checkbox in the file browser dialog.

Caution

LibreOffice offers the option to insert a picture as a link to the file rather than
embedding it in the document. This can be useful when a presentation is not intended
for distribution onto other computers, but where it will remain in the same computer
and directory structure. For example, it could be created on a notebook computer,
which is to be used to give the presentation to a group of clients.
However, if the presentation file is to be distributed onto other computers, the picture
must be embedded to avoid the “missing picture” syndrome when the presentation is
given on a different computer.

Once the picture is inserted, you need to move it to the background. To do that, while the picture is
still selected, right click on the picture and select Arrange > Send to Back from the context menu.
You may also need to reposition it and modify its size. To do that see Chapter 4, Adding and
Formatting Pictures.

Tip

If you want the image to blend with the background, you can set the background color
of the picture as transparent. Select the picture, then chose Tools > Color Replacer
from the menu bar. Select the first checkbox and then move the mouse cursor onto
the picture and click on the color you want to make transparent. This color appears
next to the checkbox. Make sure that Replace with... is set to Transparent and click
Replace.

Tip

An easy way to make the picture lighter so that the text stands out better against its
background, is to increase the transparency of the picture or change the gamma. Both
these adjustments can be quickly made from the Picture toolbar.

In addition to pictures you can add a number of other background objects, for example decorative
lines, text and shapes. Figure 5 is an example of a slide master with a custom background
gradient, a background picture, another picture in the top right corner, some decorative lines and
some customized presentation styles.

10

Using Slide Masters, Styles, and Templates

Slide master styles
Within the slide master you can define a complete set of styles for the default appearance of text
and graphic objects inserted in slides based on that background. If for example your slide master
has a dark background, you may want to set the font color of the title and text areas to be light.
Rather than manually changing the font color for every new slide you create, a time-consuming
operation prone to errors and omissions, simply modify the style in the slide master. Changes
made to styles in the slide master only apply to the slides based on that particular slide master.
Styles in Impress are sub-divided into two main categories: Presentation styles and Graphics
styles.

Presentation styles
Presentation styles (Figure 6) affect three elements of a slide master: the background, background
objects (such as icons, decorative lines, and text frames), and the text placed on the slide. Text
styles are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline
styles are used for the different levels of the outline to which they belong. For example, Outline 2 is
used for the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.
The presentation styles can be modified, but new presentation styles cannot be created.

Graphics styles
Graphics styles (Figure 9) apply to lines, shapes and text boxes created using the Impress drawing
tools and define the formatting of such objects. You can create additional styles or modify the
included styles.
To work on the slide master styles, start by opening the Styles and Formatting window shown in
Figure 6 for Presentation styles and Figure 9 for Graphic styles. Either press F11 or select Format
> Styles and Formatting from the main menu.

Figure 9: Graphic Styles and Formatting

Modifying a slide master
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Note

Tip

The presence of text and title styles both in the Presentation and Graphics styles may
seem confusing. This apparent duplication is because Impress uses special text
boxes when adding structured text to slides where Presentation styles apply
(AutoLayout boxes). The title and other text styles in Graphics styles continue to apply
to other text boxes you may want to add, or to text associated with shapes or lines.

At the bottom of the Styles and Formatting window is a drop-down list. You can
choose to show all styles or other groups of styles, for example applied styles or (for
Graphics styles only) custom styles.

You can dock or undock the Styles and Formatting dialog by holding down the Control key while
double-clicking on the icon toolbar. Press F11 to close the Styles and Formatting window when you
do not need it. LibreOffice will remember its position the next time you re-open the Styles and
Formatting dialog.

Modifying default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 10.

•
•
•
•
•

Title area for AutoLayouts
Object area for AutoLayouts
Date area
Footer area
Slide number area

Figure 10: Slide master showing five editable areas
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Click with the left mouse button on any of these areas to display eight colored selection handles
around the rectangle. Use these handles to modify the size and position of the area.
1) To change the position, move the mouse towards one of the edges, away from the
handles, until the cursor changes shape1, then click the left mouse button and drag the
area to the desired position.
2) To modify the shape and size of one of the rectangular areas, use one of the eight handles.
The corner handles modify the height and width of the rectangle simultaneously while the
side handles modify only one dimension at a time. The shape of the mouse cursor usually
changes shape when over a handle, giving a clear visual indication of how it will affect the
shape of the rectangular area.

Tip

To keep the shape of the rectangular area constant, move the mouse to one of the
four corner handles and keep the Shift key pressed while dragging the handle with
the mouse.

To accurately control the shape and size as well as the position of the default text area, it is better
to use the Position and Size dialog than the mouse. First select the rectangular area by clicking on
any point inside it, then press F4 or choose Format > Position and Size. The dialog shown in
Figure 11 is displayed.
The functions of this dialog are explained in the Draw Guide, so only a short description of the
most important fields is provided in this chapter.
Use the Position section to specify the X (horizontal) and Y (vertical) position of the rectangular
area. The values represent the distance of the selected base point and the default position is the
top left corner of the slide.

Figure 11: Position and Size dialog

1

The shape of the cursor to move and resize objects is operating system specific.

Modifying a slide master
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Use the Size section to specify the width and height of the rectangular area. In the Base point
section, select the part of the rectangular area that you do not want to move while resizing. The
default setting of top left corner means that the position of the top left corner of the area will not
change after resizing.
You can also use the Rotation tab of the dialog to rotate the default text area. For example, you
can place the footer area on the side by rotating each text area by 90 degrees and obtain a more
modern-looking layout. In general it is preferable to use only right angles for ease of editing,
although the program does not impose restrictions on the values that can be used.

Further modifications to the default text areas
Besides the shape, size and position, it is also possible to modify other aspects of the editable
areas on the slide master, such as the background, border, alignment relative to the slide, and
position relative to other objects.
While the background style and line style of an area can be accessed from the Format menu, to
access the Alignment and Arrange menus you need either to open the Drawing toolbar or to use
the context menu. To display the Drawing toolbar (Figure 12), select View > Toolbars > Drawing.
To open the context menu, right-mouse click on the edge of the selected rectangular area. On the
Drawing toolbar, click the arrow next to the Alignment or Arrange icon (highlighted in Figure 12) to
display choices. See the Draw Guide for details.

Figure 12: Alignment and Arrange icons on the Drawing toolbar
The date area and slide number area do not automatically appear on every slide, even though you
have defined them. To show them, you need to close the Master View and select the desired field
from the main menu: Insert > Page number or Insert > Date and time. This procedure is
explained in detail in Chapter 8, Adding and Formatting Slides, Notes, and Handouts.

Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects
to the master page for your slides to act as a header or a footer.
1) Choose View > Master > Slide Master from the main menu.
2) On the Drawing toolbar (Figure 12), select the Text icon
or press F2.
3) Click once and drag in the master page to draw a text object, and then type or paste your
text into the object or add fields as described below.
4) Choose View > Normal when you are finished.
To add a field, such as the date or page number (slide number), to a text object in the header or
footer, select Insert > Fields. and select the required field from the submenu. If you want to edit a
field in your slide, see Chapter 3, Adding and Formatting Text for more information.
The fields you can use in Impress are:

•
•
•
•
•
•
•
14

Date (fixed)
Date (variable): updates automatically when you reload the file
Time (fixed)
Time (variable): updates automatically when you reload the file
Author: first and last names listed in the LibreOffice user data
Page number (slide number)
File name
Using Slide Masters, Styles, and Templates

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field,
choose Format > Page and then select a format from the list in the Layout Settings
area.
To change the author information, go to Tools > Options > LibreOffice > User Data.

Working with styles in Impress
If you are familiar with styles in Writer, you will find both similarities and differences in Impress. The
presentation styles are comparable to paragraph styles in Writer and are used in a similar fashion.
You cannot create new presentation styles but you can fully configure the existing ones. Note that,
as with the Heading styles in Writer, the Outline styles are hierarchically linked, so that a change in
the Outline 1 will cascade through all the other Outline levels.
In Impress you will also find the graphics styles very useful. They define the characteristics of a
graphic object (including a text object). If, for example, if you need to create an organization chart
diagram in one of the slides of your presentation, you will probably want all of the objects to have a
consistent appearance, meaning the same line style, same font type, maybe the same shadow,
and so on. The easiest way to achieve this result with the minimum effort is to create a graphics
style for the objects and apply it to each object. The major benefit is that if you decide to change,
say, the background color of objects, all you need to do is modify the style rather than each
individual object.
Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphics
styles is covered in Chapter 6, Formatting Graphic Objects.

Working with templates
All documents in LibreOffice are based on templates. However, Impress is a little different from
other LibreOffice components, in that it starts with the Presentation Wizard unless you have
elected to turn off this wizard.
When you choose File > New > Presentation from the menu bar and if the wizard is active, it
opens offering several choices for a new presentation, one of which is From template.
If you have turned off the Presentation Wizard, when you start a new presentation by choosing File
> New > Presentation from the menu bar, LibreOffice uses the default presentation template. If
you have not defined your own default template, LibreOffice uses the blank template supplied with
Impress.

Using templates supplied with LibreOffice
Impress comes with a set of predefined templates. Two are in the Presentations folder and the
others are in the Presentation backgrounds folder. The difference between them is that
Presentation templates include a series of slides with sample titles and topics, while Presentation
background templates have only backgrounds and background objects. Both types have
predefined presentation and graphics styles.
You can create a new presentation from a previously saved presentation template by choosing File
> New > Templates and Documents from the menu bar. This opens the Templates and
Documents – Templates dialog. To open a new presentation based on a template, double-click the
name of the template in the list.

Working with templates
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Using templates from other sources
You can download templates for LibreOffice from many sources, including the official template
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites
you may find collections of templates that have been packaged into extension (.OXT) files. These
are installed a bit differently (using the Extension Manager), as described below.
Some of these templates are free of charge; others are available for a fee. Check the descriptions
to see what licenses and fees apply to the ones that interest you.
If you have created your own templates (see page 16), or installed templates from another source,
they are probably stored in the My Templates folder. Templates installed using the Extension
Manager may be installed in their own folders. Go to File > New > Templates and Documents to
open the dialog where these folders are located.

Installing individual templates
To install individual templates:
1) Download the template and save it anywhere on your computer.
2) Import the template into a template folder by following the instructions in “Importing a
template“ on page 20.

Tip

(For advanced users) If you know the location of LibreOffice template folders, you
can manually copy new templates into them. The location varies with the operating
system of your computer. To learn where the template folders are stored on your
computer, go to Tools > Options > LibreOffice > Paths.

Installing template collections
The Extension Manager provides an easy way to install collections of templates that have been
packaged into extension (.OXT) files. Follow these steps:
1) Download the extension and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager from the main menu. In the Extension
Manager dialog, click Add to open a file browser window.
3) Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, the templates are available for use through File
> New > Templates and Documents and the extension is listed in the Extension Manager.
The slide masters created by the newly installed templates will now appear in the list of Available
Master Pages in the Tasks Pane (Figure 1).

Tip

To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions here link. You do not need to download
them separately as in step 1 above. It is advised that you use the Extension Manager
to check for any new Impress updates.

Creating your own templates
To create a template from a presentation:
1) Open the presentation that you want to use for a template.
2) From the main menu, choose File > Templates > Save. The Templates dialog opens
(Figure 13).
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Figure 13. Saving a new template
3) In the New template field, type a name for the new template.
4) In the Categories list, click the folder in which you want to store the template. This is
usually the My Templates folder, unless you have created other folders. To learn more
about template folders, see “Organizing templates” on page 19.
5) Click OK. LibreOffice saves the new template and the Templates dialog closes.

Note

All the slide masters used in the template become available for use in other
presentations.

Setting a default template
If you create a document by choosing File > New > Presentation from the main menu, LibreOffice
creates the document from the default Impress template. However, you can set any presentation
template to be the default template, even a custom template that you have created, so long as it is
in one of the folders displayed in the Template Management dialog. You can reset back to the
default Impress template later if you choose.

Figure 14. Template Management dialog

Working with templates
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Setting a custom template as default
To set a custom template as default instead of using the Impress default template:
1) From the main menu, choose File > Templates > Organize. The Template Management
dialog opens (Figure 14).
2) In the box on the left, double-click the folder containing the template that you want to set as
the default, then select the template.
3) Click the Commands button.
4) From the drop-down menu, choose Set As Default Template. The next time that you
create a new presentation by choosing File > New, the new presentation will be created
from this template.

Resetting default Impress template
To reset the default template for a new presentation to use the Impress default:
1) In the Template Management dialog, click any folder in the box on the left.
2) Click the Commands button and choose Reset Default Template from the drop-down
menu. This command does not appear unless a custom template has previously been set
as the default, as described above.
The next time that you create a new presentation by choosing File > New, the presentation will be
created from the default Impress template.

Modifying a template
You can edit the styles and content of a template and then, if you wish, you can reapply the
template styles to presentations that were created from that template.

Note

You can only reapply styles. You cannot reapply content.

To edit a template:
1) From the main menu, choose File > Templates > Edit. A standard file browser window
opens.
2) Find and select the template that you want to edit and then click Open. The selected
template opens in Impress.
3) Edit the template just as you would any other presentation. To save your changes, choose
File > Save from the main menu.

Updating a document from a changed template
The next time that you open a presentation that was created from the changed template, the
following message appears (Figure 15).

Figure 15. Update styles message
Click Update Styles to update any styles in the template that have been changed in the document.
Click Keep Old Styles if you do not want to update any styles in the template that have been
changed in the document. Whichever option you choose, the message box closes and the
presentation opens in Impress.
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Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new
LibreOffice template folders and use them to organize your templates. For example, you might
have separate template folders for different purposes or projects. You can also import and export
templates.
To begin, choose File > Templates > Organize from the main menu. The Template Management
dialog (Figure 14) opens.

Note

Tip

All the actions available from the Commands button in the Template Management
dialog can also be carried out by right-clicking on the templates or the folders.

The location of LibreOffice template folders varies with your computer’s operating
system. To learn where the template folders are stored on your computer, go to
Tools > Options > LibreOffice > Paths.

Creating a template folder
To create a template folder:
1) In the Template Management dialog (Figure 14), click any folder.
2) Click the Commands button and choose New from the drop-down menu. A new folder
called Untitled appears.
3) Type a name for the new folder, and then press Enter. LibreOffice saves the folder with the
name that you entered.

Deleting a template folder
You cannot delete the template folders supplied with LibreOffice or installed using the Extension
Manager. You can only delete folders that you have created.
To delete a template folder that you have created:
1) In the Template Management dialog (Figure 14), select the folder that you want to delete.
2) Click the Commands button and choose Delete from the drop-down menu. A message box
appears and asks you to confirm the deletion. Click Yes.

Moving a template
To move a template from one template folder to another template folder:
1) In the Template Management dialog (Figure 14), double-click the folder that contains the
template you want to move. A list of all the templates contained in that folder appears
underneath the folder name.
2) Click the template that you want to move and drag it to the desired folder. If you do not
have the authority to delete templates from the source folder, this action copies the
template instead of moving it.

Deleting a template
You cannot delete the templates supplied with LibreOffice or installed using the Extension
Manager. You can only delete templates that you have created or imported.
To delete a template:
1) In the Template Management dialog (Figure 14), open the folder that contains the template
you want to delete by double-clicking on it. Then click the template that you want to delete.
Working with templates

19

2) Click the Commands button and choose Delete from the drop-down menu. A dialog
appears and asks you to confirm the deletion. Click Yes.

Importing a template
Before you can use a template, you must import it into a LibreOffice template folder. To import a
template into a template folder from another location on your computer:
1) In the Template Management dialog (Figure 14), click the folder into which you want to
import the template.
2) Click the Commands button and choose Import Template from the drop-down menu. A
standard file browser window opens.
3) Find and select the template that you want to import and click Open. The file browser
window closes and the template appears in the selected template folder.
4) If you want, type a new name for the template, and then press Enter.

Exporting a template
To export a template from a template folder to another location:
1) In the Template Management dialog (Figure 14), double-click the folder that contains the
template you want to export.
2) Click the template that you want to export.
3) Click the Commands button and choose Export Template. from the drop-down menu. The
Save As window opens.
4) Find the folder into which you want to export the template and click Save.

Printing a list of styles defined in a template
To print a list of the styles defined in a template:
1) In the Template Management dialog (Figure 14), double-click the folder that contains the
template.
2) Double-click the required template and Styles appears below the template name. Click
Styles to select it.
3) Click the Commands button and choose Print from the drop-down menu and the Print
dialog opens. From here you can print to a file or to a printer as usual.
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