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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens context menu

Ctrl Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
A template is a document model that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will all have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.
All documents in LibreOffice are based on templates. If you do not specify a template when you
start a new Writer document, then the document is based on the default template for text
documents. If you have not specified a default template, Writer uses the blank template for text
documents that is installed with LibreOffice. See “Setting a default template” on page 9 for more
information.
LibreOffice 4.0 supplies one user-selectable text template, MediaWiki, as an alternative to the
default in documents (Writer). Note that German is the default document language in the
MediaWiki template. This can be changed on the Languages page in Tools > Options >
Language Settings.
Ten colored backgrounds are supplied for presentations (Impress). No alternative templates are
supplied for drawings (Draw) or spreadsheets (Calc).

Using a template to create a document
To use a template to create a document:
1) From the Menu bar, choose File > New > Templates to open the Template Manager
dialog.

Figure 1. Template Manager
2) From the tabs at the top of the dialog, select the Documents category (type) of template.
Folders containing templates are listed in the category page of the dialog. If no other
folders than MediaWiki are visible, there are no templates available.
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3) Double-click the folder that contains the template that you want to use, typically this will be
My Templates. All the templates contained in that folder are then listed on the page, as
shown in Figure 1.
4) Select the template that you want to use. If you wish to view the template’s properties, click
the Properties button above the list of templates. The template’s properties appear in a
pop-up window. Click Close to close this pop-up window.
5) Double-click on the required template. A new document based on the selected template
opens in Writer. You can then edit and save the new document just as you would any other
document.

Creating a template
You can create your own templates in two ways: from a document or using a wizard.

Creating a template from a document
To create a template from a document and save it to My Templates:
1) Open a new or existing document that you want to make into a template.
2) Add or modify the content and styles that you want.
3) From the Menu bar, choose File > Save as Template. The Template Manager dialog
opens displaying the four default folders (and any user created folders).

Figure 2: Saving a template
4) Select the My Templates folder.
5) Click the Save icon.
6) Enter a name for the template in the text input box that opens, and click Accept (see
Figure 2).
7) Close the Template Manager dialog.
Creating a template
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Any settings that can be added to or modified in a document can be saved in a template. For
example, below are some of the settings (although not a full list) that can be included in a Writer
document and then saved as a template for later use:

• Printer settings: which printer, single-sided or double-sided printing, paper size, and so on
• Styles to be used, including character, page, frame, numbering, and paragraph styles
• Format and settings regarding indexes, tables, bibliographies, table of contents
Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 16, Customizing
Writer, for more information.

Creating a template using a wizard
You can use wizards to create Writer templates for letters, faxes, and agendas.
For example, the Fax Wizard guides you through the following choices:

• Type of fax (business or personal)
• Document elements like the date, subject line (business fax), salutation, and
complimentary close

• Options for sender and recipient information (business fax)
• Text to include in the footer (business fax)
To create a template using a wizard:
1) From the menu bar, choose File > Wizards > [type of template required].

Figure 3: Creating a template using a wizard
2) Follow the instructions on the pages of the wizard. This process is slightly different for each
type of template, but the format is similar for all of them.
3) In the last section of the wizard, you can specify the template name which will show in the
Template Manager, and also the name and location for saving the template. The two
names can be different but may cause you confusion if you choose two different names.
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The default location is your user templates folder, but you can choose a different location if
you prefer.
4) Selecting the Path button to set the file name, and perhaps change the directory, causes
the Save As dialog to open. Setting the file name and clicking Save closes the dialog.
5) Finally, you have the option of creating a new document from your template immediately, or
manually changing the template, by clicking Finish. For future documents, you can re-use
the template created by the wizard, just as you would use any other template.
You may have to open the Template Manager and click Refresh on the Action menu to have any
new templates appear in the listings.

Note

In this release of LibreOffice, clicking Finish reopens the Save As dialog in which
you set the file name at Step 4. Clicking Save now, in the reopened dialog, causes
the file to be saved to the hard drive, and the template to open.
Clicking Save in Step 4 only saved the dialog in memory and not to the hard drive.

Editing a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s
styles to documents that were created from that template. Note that you can only reapply styles.
You cannot reapply content.
To edit a template:
1) From the Menu bar, choose File > New > Templates. The Template Manager dialog
opens.
2) Navigate to the template that you want to edit. Click once on it to activate the file handling
controls (see Figure 1). Click Edit. The template opens in LibreOffice.
3) Edit the template just as you would any other document. To save your changes, choose
File > Save from the Menu bar.

Updating a document from a changed template
The next time you open a document that was created from the changed template, the following
message appears.

Figure 4. Update styles message
Click Update Styles to apply the template’s changed styles to the document. Click Keep Old
Styles if you do not want to apply the template’s changed styles to the document (but see the
Caution notice below).

Editing a template
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Caution

If you choose Keep Old Styles in the message box shown in Figure 4, that message
will not appear again the next time you open the document after changing the
template it is based on. You will not get another chance to update the styles from the
template, although you can use the macro given in the Note below to re-enable this
feature.

To re-enable updating from a template:
1) Use Tools > Macros > Organize Macros > LibreOffice Basic. Select the
document from the list, click the expansion symbol (+ or triangle), and select
Standard. If Standard has an expansion symbol beside it, click that and select a
module.
2) If the Edit button is active, click it. If the Edit button is not active, click New.
3) In the Basic window, enter the following:

Note

Sub FixDocV3
' set UpdateFromTemplate
oDocSettings = ThisComponent.createInstance( _
"com.sun.star.document.Settings" )
oDocSettings.UpdateFromTemplate = True
End Sub 'FixDocV3
4) Click the Run BASIC icon, then close the Basic window.
5) Save the document.

Next time when you open this document you will have the update from template
feature back.

Adding templates obtained from other sources
You can download templates for LibreOffice from many sources, including the official template
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites
you may find collections of templates that have been packaged into extension (OXT) files. These
are installed a little differently, as described below.

Installing individual templates
To install individual templates:
1) Download the template and save it anywhere on your computer.
2) Import the template into a template folder by following the instructions in “Importing a
template” on page 13.

Tip

You can manually copy new templates into the template folders. The location
varies with your computer’s operating system. To learn where the template folders
are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been
packaged as extensions. Follow these steps:
1) Download the extension package (OXT file) and save it anywhere on your computer.
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2) In Writer, select Tools > Extension Manager from the Menu bar. In the Extension Manager
dialog (Figure 5), click Add to open a file browser window.
3) Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, the templates are available for use through File
> New > Templates and the extension is listed in the Extension Manager.

Figure 5: Newly-added package of templates
Extension packages may also be installed by double-clicking the file, and then accepting the
installation and any license agreement which is requested.
See Chapter 16, Customizing Writer, for more about the Extension Manager.

Setting a default template
If you create a document by choosing File > New > Text Document from the Menu bar, Writer
creates the document from the default template for text documents. You can, however, set a
custom template to be the default. You can reset the default later, if you choose.

Note for
Windows
users

You may know that Microsoft Word employs a normal.dot or normal.dotx file
for its default template and how to regenerate it.
LibreOffice does not have a similar default template file; the “factory defaults” are
embedded within the software.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the
Template Manager dialog. If necessary, you can add the template to a folder as described in
“Importing a template” on page 13.
To set a custom template as the default:
1) From the Menu bar, choose File > New > Templates to open the Template Manager
dialog.
2) In the Template Manager dialog, open the folder containing the template that you want to
set as the default, then select the template.
3) Click the Set As Default icon above the list of templates (see Figure 6).

Setting a default template
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The next time that you create a document by choosing File > New > Text Document, the
document will be created from this template.
Although many important settings can be changed in the Tools > Options dialog (see Chapter 2,
Setting up Writer), for example default fonts and page size, more advanced settings (such as page
margins) can only be changed by replacing the default template with a new one.

Figure 6: Setting a default template using the Template Manager dialog

Resetting Writer’s default template as the default
To re-enable Writer’s default template as the default:
1) In the Template Manager dialog (Figure 7), click the Action Menu icon on the right.
2) Point to Reset Default Template on the drop-down menu, and click Text Document.

Figure 7: Resetting the default template
This choice does not appear unless a custom template had been set as the default, as described in
the previous section.
The next time that you create a document by choosing File > New > Text Document, the
document will be created from Writer’s default template.
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Associating a document with a different template
At times you might want to associate a document with a different template, or perhaps you’re
working with a document that did not start from a template.
One of the major advantages of using templates is the ease of updating styles in more than one
document, as described in Chapter 7, Working with Styles. If you update styles in a document by
loading a new set of styles from a different template (as described in Chapter 7), the document has
no association with the template from which the styles were loaded—so you cannot use this
method. What you need to do is associate the document with the different template.

Note

In LibreOffice 3.x, you could use the Template Changer extension to simplify this
process. Unfortunately, this extension does not work in LibreOffice 4.0.

For best results, the names of styles should be the same in the existing document and the new
template. If they are not, you will need to use Edit > Find & Replace to replace old styles with new
ones. See Chapter 3 of the Writer Guide, Working with Text, for more about replacing styles using
Find & Replace.
1) Use File > New > Templates. In the Template Manager dialog, double-click the template
you want to use. A new document opens, containing any text or graphics that were in the
template. Delete any unwanted text or graphics from this new document.
2) Open the document you want to change. (It opens in a new window.) Press Ctrl+A to select
everything in the document. Click in the blank document created in step 1. Press Ctrl+V to
paste the content from the old document into the new one.
3) Update the table of contents, if there is one. Close the old file without saving. Use Save As
to save this new file with the name of the file from which content was taken. Confirm you
wish to overwrite the old file when asked.

Organizing templates
Writer can only use templates that are in LibreOffice template folders. You can, however, create
new LibreOffice template folders and use them to organize your templates. For example, you might
have one template folder for report templates and another for letter templates. You can also import
and export templates.
To begin, choose File > New > Templates from the Menu bar to open the Template Manager
dialog.

Creating a template folder
To create a template folder:
1) In the Template Manager dialog, doube-click any folder, then click any template to activate
the row of icons above the list of templates (see Figure 8).
2) Click the Move to folder button and choose New folder from the drop-down menu.
In the pop-up dialog, type a name for the new folder and click Accept.

Organizing templates

11

Figure 8: Template file handling icons

Deleting a template folder
You cannot delete template folders supplied with LibreOffice or installed using the Extension
Manager; you can only delete template folders that you have created.
To delete a template folder:
1) In the Template Manager dialog, select the folder that you want to delete.
2) In the row of icons above the list of folders, click the Delete button. A message box
appears, asking you to confirm the deletion. Click Yes.

Caution

Folders which contain no files are hidden. If the folder is visible, ensure that you
want to delete the files that are inside. You may have to put a dummy template into
an empty folder in order to delete it (just select File > Save As Template for any file
you have opened, move it into the folder to be deleted, and then delete the folder;
see Figure 8).

Moving a template
To move a template from one template folder to another template folder:
1) In the Template Manager dialog, double-click the folder that contains the template that you
want to move. A list of all the templates contained in that folder appears underneath the
folder name.
2) Click the template that you want to move and click the Move to folder button above the list
of templates (see Figure 8).

Deleting a template
You cannot delete templates supplied with LibreOffice or installed using the Extension Manager;
you can only delete templates that you have created or imported.
To delete a template:
1) In the Template Manager dialog, double-click the folder that contains the template that you
want to delete. A list of all the templates contained in that folder appears underneath the
folder name.
2) Click the template that you want to delete.
3) Click the Delete button above the list of templates. A message box appears and asks you
to confirm the deletion. Click Yes.
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Importing a template
If the template that you want to use is in a different location, you must import it into a LibreOffice
template folder.
To import a template into a template folder:
1) In the Template Manager dialog, select the folder into which you want to import the
template.
2) Click the Import button above the list of template folders. A standard file browser window
opens.
3) Find and select the template that you want to import, and then click Open. The file browser
window closes and the template appears in the selected folder.

Exporting a template
To export a template from a template folder to another location:
1) In the Template Manager dialog, double-click the folder that contains the template that you
want to export. A list of all the templates contained in that folder appears underneath the
folder name.
2) Select the template that you want to export.
3) Click the Export button above the list of template folders. The Save As window opens.
4) Find the folder into which you want to export the template and click Save.

Organizing templates
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