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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click
depending on computer setup

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Opens the Navigator

F11

⌘+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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What is a template?
A template is a model that you use to create other documents in a standard format. For example,
you can create a template for invoices that has your company logo and address at the top of the
page. This means that any new spreadsheets (invoices) created from this template will then have
your company logo and address on the first page of the spreadsheet.
Templates can contain anything that regular documents can contain, such as text, graphics, styles,
and user-specific setup information such as measurement units, language, default printer, and
toolbar and menu customization.
All documents in LibreOffice are based on templates. You can create, or download and install, as
many templates as you wish. If you do not specify a template when you start a new spreadsheet,
any new spreadsheet is then based on the default template for spreadsheets that is included with
LibreOffice Calc. This default template consists of a blank spreadsheet which you can customize to
your needs and then, if you wish, use as a basis to create a custom default template. See “Setting
default template” on page 21.

What are styles?
A style is a set or group of formats that you can apply to selected elements in a document to
quickly change their appearance. When you apply a style, you apply a whole group of formats at
the same time.
Many people manually format spreadsheet cells and pages without paying any attention to styles
and are used to formatting documents according to physical attributes. For example, for the
contents of a cell you might specify the font family, font size, and any character formatting such as
bold or italic.
Styles are logical attributes. Using styles means that you stop applying attributes and
characteristics individually (for example, font size 14pt, Times New Roman, bold, centered) and
start using a style, for example Title. Applying attributes and characteristics is time consuming and
prone to errors. In contrast, using a style, which has been defined to include the attributes and
characteristics you want to use, will save you time and give greater consistency in formatting.
Styles also make major formatting changes easy. For example, you may decide to change the
appearance of all subtotals in your spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman
after you have created a 15-page spreadsheet. You can change all of the subtotals in the
document by simply changing the properties for the subtotal style.
Another type of style is a page style. Page styles allow you to define page margins, headers and
footers, and other printing attributes giving you consistency each time you print a spreadsheet.

Styles
Calc style types
While some components of LibreOffice offer many style types, Calc offers only two: cell styles and
page styles. These style types are explained in the following sections.

Cell styles
Cell styles are similar to paragraph styles used in LibreOffice Writer and are the most basic type of
style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number
formats (for example, currency, date, number), and cell protection to format the data contained
within the cells.
Styles
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A basic range of cell styles is supplied with LibreOffice. These styles are shown in Figure 1.
Initially, the basic styles are configured so that if you change the font family of Default, then all of
the other styles will change to match. Creating, modifying, and accessing styles is explained in the
following sections.

Figure 1: Examples of basic cell styles

Page styles
Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one
page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a
different page style can be applied to each sheet. For example, a spreadsheet might contain one
sheet to be printed in landscape orientation and the other sheets in the spreadsheet are printed in
portrait orientation.
Two page styles are supplied with Calc: Default and Report. You can adjust many settings using
page styles and you can also define as many page styles as you require.
Spreadsheets are primarily used onscreen and not printed, therefore Calc does not display the
page style on the screen. If you want a spreadsheet to fit on a certain page size, you have to
carefully control the column width and row height using File > Page Preview and View > Page
breaks preview on the main menu bar to guide you.
Despite this limitation, it is recommended to define page styles for any spreadsheets that you are
likely to print. This will help prevent any lost time or paper wastage due to trial and error.
Page styles allow you to set page size and orientation, page margins, headers and footers, borders
and backgrounds, and the sequence for printing sheets.

Applying cell styles
To apply cell styles in Calc, you can use the Styles and Formatting dialog, Fill Format mode, the
Apply Style list, or assign styles to shortcut keys.

Styles and Formatting dialog
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

Styles

on the Formatting toolbar to open the Styles and
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Figure 2: Styles and Formatting dialog
2) Click on the Cell Styles icon
in the Styles and Formatting dialog to open the list of cell
styles.
3) Highlight the cell or group of cells where you want to apply a cell style.
4) Double-click on the cell style name in the Styles and Formatting dialog and the formatting
attributes for that style are applied to the data contained in the cell or group of cells.

Note

The Styles and Formatting dialog can be docked into the main Calc workspace. To
dock or undock the window, hold down the Ctrl key and double-click on the icon bar
at the top of the dialog, or click anywhere in the dialog and use the keyboard
combination Ctrl+Shift+F10.

Fill Format mode
The Fill Format mode is useful when you want to apply the same style to many scattered cells.
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).
2) Select the style you want to apply.

on the Formatting toolbar to open the Styles and

3) Click on the Fill Format mode icon
in the Styles and Formatting dialog and the cursor
changes to a similar shape as the Fill Format Mode icon.
4) Click in each cell where you want to apply the formatting attributes.
5) When you have finished formatting cells, click the Fill Format Mode icon again or close the
Styles and Formatting dialog.

Note

When this mode is active, a right-click anywhere in the document cancels the last
Fill Format action. Be careful not to accidentally right-click and thus cancel any
formatting actions you want to keep.

Apply Style list
The Apply Style drop-down list used to select a style for selected cells is not normally included on
the Formatting toolbar in Calc and has to be added as follows:
1) Right-click in a blank space on the Formatting toolbar and select Visible Buttons from the
context menu (Figure 3).
2) Click on Apply Style and the context menus close. The Apply Style list now appears at the
left end of the Formatting toolbar.

Styles
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Figure 3: Adding an Apply Style list to the Formatting toolbar
Apply a style using the Apply Styles drop-down list as follows:
1) Select a cell or a group of cells in your spreadsheet.
2) Click the small triangle to open the drop-down list for Apply Styles.
3) Select the style you require and the formatting attributes of the selected style are applied to
the selected cells.
4) Each style in the drop-down menu is displayed with its preview, but only few styles are
available. Click on More to go to the Styles and Formatting dialog where all cell styles are
available.

Assigning shortcut keys
You can create keyboard shortcuts to apply commonly-used cell or page styles, including any
custom styles that you have created. See Chapter 14 Setting up and Customizing Calc for more
information.

Applying page styles
When a page style has been applied to a sheet within a spreadsheet, the page style being used is
indicated on the Status Bar as shown in Figure 4.

Figure 4: Page style indicated on Status Bar
1) Select the sheet to be styled by clicking on its sheet tab at the bottom of the displayed
spreadsheet.
2) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

3) In the Styles and Formatting dialog, click on the Page Styles icon
4) Double-click on the required page style.

Styles

.
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Creating new or custom styles
You can create new or custom styles using the Styles and Formatting dialog or creating a new
style from a selection.

Note

Any new or custom styles apply only to your spreadsheet and are not saved in the
template. To save new styles in a template, see “Templates” on page 20 for more
information.

New style from styles and Formatting dialog
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) To create a new cell style, click on the Cell Styles icon
dialog to open the list of cell styles.

in the Styles and Formatting

3) To create a new page style, click on the Page Styles icon
in the Styles and Formatting
dialog to open the list of page styles.
4) Right-click in the Styles and Formatting dialog and select New from the context menu to
open either the Cell Style dialog (Figure 5) or the Page Style dialog (Figure 6).
5) Use the various tabbed pages in the dialogs to set the attributes for your new style. See
“Cell style attributes” on page 10 and “Page style attributes” on page 14 for more
information.
6) Click OK to close the dialog and save your new style.

Figure 5: Cell Style dialog – Organizer page

Figure 6: Page Style dialog – Organizer page

Styles
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New style from a selection
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) To create a new cell style, click on the Cell Styles icon
dialog to open the list of cell styles.

in the Styles and Formatting

3) To create a new page style, click on the Page Styles icon
in the Styles and Formatting
dialog to open the list of page styles.
4) Select the style you want to use as a base for your new style.
5) Click the New Style from Selection icon
to open the Create Style dialog (Figure 7).
6) Type a name for the new style. The list box displays the names of any existing custom
styles used in the spreadsheet.
7) Click OK to save the new style.
8) Right-click on the new style and select Modify from the context menu to open a dialog
where you can change the style attributes. See “Cell style attributes” on page 10 and “Page
style attributes” on page 14 for more information.

Figure 7: Create Style dialog

Note

Style names are case sensitive. You can define, for example, a style called red
and another style called Red. Make sure all style names are sufficiently different
to prevent any confusion.

Cell style attributes
The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 5).

Organizer
• Name – displays the name of the selected style. If you are creating or modifying a custom
•
•
•

style, enter a name for the style. You cannot change the name of a predefined style.
Linked with – select an existing style that you want to base the new style on, or select
none to define your own style.
Category – displays the category for the current style. If you are creating or modifying a
new style, select Custom Style from the list. You cannot change the category for a
predefined style.
Contains – describes the relevant formatting used in the current style.

Numbers
• Category – select a category from the list and then select a formatting style in the Format
•

Styles

box.
Format – select how you want the contents of the selected cell(s) to be displayed. The
code for the selected option is displayed in the Format Code box.
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•

•

When you select Currency as a category, you have to select a currency from the drop-down
list and then select the format to use from the available options for that currency.
The format code for currencies uses the form [$xxx-nnn], where xxx is the currency symbol,
and nnn the country code. Special banking symbols, such as EUR (for Euro), do not
require the country code. The currency format is not dependent on the language that you
select in the Language box.
The default currency format for a cell is determined by the regional settings of your
operating system.
Language – specifies the language setting for the selected cells. With the language set to
Automatic, LibreOffice automatically applies the number formats associated with the
system default language. Select any language to fix the settings for the selected cells. The
language setting ensures that date and currency formats are preserved even when the
document is opened in an operating system that uses a different default language setting.
Options – specify the options for the selected format.

–
–
–
–
•
•

Decimal places – enter the number of decimal places that you want to display.
Leading zeroes – enter the maximum number of zeroes to display in front of the
decimal point.
Negative numbers in red – changes the font color of negative numbers to red.
Use thousands separator – inserts a separator between thousands. The type of
separator that is used depends on your language settings.

Format code – displays the number format code for the selected format. You can also
enter a custom format. The following options are only available for user-defined number
formats.
Preview Field – displays a preview of the current selection.

Font
The changes are applied to the current selection, to the entire word that contains the cursor, or to
the new text that you type. Depending on your language settings, you can change the formatting
for the following font types:
• Western text font – Latin character sets

•
•

Asian text font – Chinese, Japanese, or Korean character sets
Complex text layout font – right-to-left text direction

Note
•
•
•
•

•

Styles

To enable support for complex text layout and Asian character sets, go to Tools >
Options > Language Settings > Languages and select Enabled.

Font – enter the name of an installed font family that you want to use, or select a font from
the list.
Style – select the formatting you want to apply: Bold or Italic.
Size – enter or select the font size that you want to apply. For scalable fonts, you can also
enter decimal values. If you are creating a style that is based on another style, you can
enter a percentage value or a point value (for example, –2pt or +5pt).
Language – sets the language that the spelling checker uses for the selected text or the
text that you type. The spelling checker for the selected language only functions when you
have installed the corresponding language module. A language entry has a check mark in
front of it if the spelling checker is activated for that language.
Preview – displays a preview of the current selection.
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Font Effects
The changes are applied to the current selection, to the entire word that contains the cursor, or to
the new text that you type.

•
•
•
•
•
•
•

Font Color – sets the color for the selected text. If you select Automatic, the text color is
set to black for light backgrounds and to white for dark backgrounds.
Relief – select a relief effect to apply to the selected text. The Embossed relief makes the
characters appear as if they are raised above the page. The Engraved relief makes the
characters appear as if they are pressed into the page.
Outline – displays the outline of the selected characters. This effect does not work with
every font.
Shadow – adds a shadow that casts below and to the right of the selected characters.
Overlining – select the overlining style that you want to apply. To apply the overlining to
words only, select Individual words.
Overline color – select the color for the overlining.
Strikethrough – select a strikethrough style for the selected text.

Note
•

•
•
•

If you save your document in MS Word format, all of the strikethrough styles are
converted to the single line style.

Underlining – select the underlining style that you want to apply. To apply the underlining
to words only, select Individual words.
If you apply underlining to a superscript text, the underlining is raised to the level of the
superscript. If the superscript is contained in a word with normal text, the underlining is not
raised.
Underline color – select the color for the underlining.
Individual words – applies the selected effect only to words and ignores spaces.
Preview – displays a preview of the current selection.

Alignment
• Text alignment – sets the alignment options for the contents of the current cell, or the
selected cells.
– Horizontal – select the horizontal alignment option that you want to apply to the cell
contents.
– Default – aligns numbers to the right and text to the left.

–
–
–
–
–
–
–
–
–

Styles

Left – aligns the contents of the cell to the left.
Right – aligns the contents of the cell to the right.
Center – horizontally centers the contents of the cell.
Justified – aligns the contents of the cell to the left and to the right cell borders.
Filled – repeats the cell contents (number and text) until the visible area of the cell is
filled. This feature does not work on text that contains line breaks.
Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also
justifies the very last line of text.
Indent – indents from the left edge of the cell by the amount that you enter.
Vertical – select the vertical alignment option that you want to apply to the cell contents.
Default – aligns the cell contents to the bottom of the cell.

12

–
–
–
–
–
•

Bottom – aligns the contents of the cell to the lower edge of the cell.
Middle – vertically centers the contents of the cell.
Justified – aligns the contents of the cell to the top and to the bottom cell borders.
Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also
justifies the very last line of text.

Text orientation – defines the text direction of cell contents.

–
–
–

•

Top – aligns the contents of the cell to the upper edge of the cell.

ABCD wheel – click anywhere in the wheel to define the text orientation. The
characters "ABCD" on the wheel correspond to the new setting.
Vertically stacked – assigns vertical text orientation for cell contents.

Degrees – allows you to manually enter the orientation angle. A positive number rotates
the text to the left and a negative number rotates the text to the right.
– Reference edge – specify the cell edge from which to write the rotated text.
Text Extension From Lower Cell Border – writes the rotated text from the bottom cell
edge outwards.
Text Extension From Upper Cell Border – writes the rotated text from the top cell edge
outwards.
Text Extension Inside Cells – writes the rotated text only within the cell.
Properties – determine the text flow in a cell.

–
–
–

Wrap text automatically – wraps text onto another line at the cell border. The number of
lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in
the cell.
Hyphenation active – enables word hyphenation for text wrapping to the next line.
Shrink to fit cell size – reduces the apparent size of the font so that the contents of the
cell fit into the current cell width. You cannot apply this command to a cell that contains
line breaks.

Borders
Sets the border attributes for the selected cells.

•
•
•

Line arrangement – select a predefined border style to apply. In a spreadsheet, you can
also add or remove predefined borders with the Borders icon on the Table toolbar.
Line – select the border style, width, and color that you want to apply. The style is applied
to the borders selected in the preview.
Spacing to contents – specify the amount of space that you want to leave between the
border and the contents of the selection.
– Left – enter the distance between the left border and the contents of the selection.

–
–
–
–
•

Styles

Right – enter the distance between the right border and the contents of the selection.
Top – enter the distance between the top border and the contents of the selection.
Bottom – enter the distance that between the bottom border and the contents of the
selection.
Synchronize – applies the same spacing to contents setting to all four borders when
you enter a new distance.

Shadow style – applies a shadow effect to borders. For the best results, only apply this
effect when all four borders are visible. Graphics or objects that are anchored to a frame in

13

the document cannot exceed the size of the frame. If you apply a shadow to the borders of
an object that fills an entire frame, the size of the object is reduced to display the shadows.
– Position – select a shadow style for the selected borders.

–
–

Distance – enter the distance the shadow extends from the object.
Color – select a color for the shadow.

Background
Select a color that you want to use as a background for your selected cells. To remove a
background color, select No Fill.

Cell protection
• Hide all – hides formulas and contents of the selected cells.
• Protected – prevents the selected cells from being modified. This cell protection only takes
•
•

effect if you also protect the sheet.
Hide formula – hides formulas in the selected cells.
Hide when printing – prevents the selected cells from being printed.

Page style attributes
The following attributes are available on the various tabbed pages of the Pages Style dialog
(Figure 6).

Organizer
• Name – displays the name of the selected style. If you are creating or modifying a custom
•
•
•

style, enter a name for the style. You cannot change the name of a predefined style.
Linked with – select an existing style that you want to base the new style on, or select
none to define your own style.
Category – displays the category for the current style. If you are creating or modifying a
new style, select Custom Style from the list. You cannot change the category for a
predefined style.
Contains – describes the relevant formatting used in the current style.

Page
You can define page layouts for single and multiple-page documents, as well as page numbering
and paper formats.

•

Styles

Paper format – select from a list of predefined paper sizes, or define a custom paper
format.
– Format – select a predefined paper size, or create a custom format by entering the
dimensions for the paper in the Height and Width boxes.
– Width – displays the width of the selected paper format. To define a custom format,
enter a width here.
– Height – displays the height of the selected paper format. To define a custom format,
enter a height here.
– Orientation: Portrait – displays and prints the current document with the paper oriented
vertically.
– Orientation: Landscape – displays and prints the current document with the paper
oriented horizontally.
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–

Paper tray – select the paper source for your printer. If you want, you can assign
different paper trays to different page styles. For example, you can assign a different
tray for the first page style in your spreadsheet and load the tray with your company
letterhead paper.

•

Margins – specify the amount of space to leave between the edges of the page and the
document text.
– Left/Inner – enter the amount of space to leave between the left edge of the page and
the document text. If you are using Mirrored page layout, enter the amount of space to
leave between the inner text margin and the inner edge of the page.
– Right/Outer – enter the amount of space to leave between the right edge of the page
and the document text. If you are using Mirrored page layout, enter the amount of
space to leave between the outer text margin and the outer edge of the page.
– Top – enter the amount of space to leave between the upper edge of the page and the
document text.
– Bottom – enter the amount of space to leave between the lower edge of the page and
the document text.

•

Layout settings – select the page layout style to use in the current document.

–
–
–
–
–
–
–

Page layout: Right and left – shows both odd and even pages with left and right
margins as specified.
Page layout: Mirrored – shows both odd and even pages with inner and outer margins
as specified. Use this layout if you want to bind the printed pages like a book. Enter the
binding space as the Inner margin.
Page layout: Only right – shows only odd (right) pages. Even pages are shown as
blank pages.
Page layout: Only left – shows only even (left) pages. Odd pages are shown as blank
pages.
Format – select the page numbering format to use for the page style.
Table alignment: Horizontal – centers the cells horizontally on the printed page.
Table alignment: Vertical – centers the cells vertically on the printed page.

Borders and Background
See “Borders” and “Background” in “Cell style attributes” above for information on how to set the
borders and background for page styles.

Header
Adds a header to the page style. A header is an area in the top page margin where you can add
text or graphics.

•
•
•
•
•

Styles

Header on – adds a header to the page style.
Same content left/right – even and odd pages share the same content. To assign a
different header to even and odd pages, deselect this option and then select Edit.
Left margin – enter the amount of space to leave between the left edge of the page and
the left edge of the header.
Right margin – enter the amount of space to leave between the right edge of the page and
the right edge of the header.
Spacing – enter the amount of space to maintain between the bottom edge of the header
and the top edge of the document text.
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•
•
•
•
•

Height – enter the height that you want for the header.
AutoFit height – automatically adjusts the height of the header to fit the content.
Preview – displays a preview of the current selection.
More – defines a border, background color, or background pattern for the header.
Edit – allows you to add or edit header text.

Footer
Adds a footer to the page style. A footer is an area in the bottom page margin where you can add
text or graphics. See “Header” above for information on the available options you can use for a
footer.

Sheet
Specifies the elements to be included in the printout of all sheets with the page style. Additionally,
you can set the print order, the first page number, and the page scale.

•

Page Order – defines the order in which data in a sheet is numbered and printed when it
does not fit on one printed page.
– Top to bottom, then right – prints vertically from the left column to the bottom of the
sheet.
– Left to right, then down – prints horizontally from the top row of the sheet to the right
column.
– First page number – select this option if you want the first page to start with a number
other than 1.

•

Print – defines which elements of the spreadsheet are to be printed.

–
–
–
–
–
–
–
–
•

Drawing objects – includes all drawing objects in the printed document.
Formulas – prints the formulas contained in the cells, instead of the results.
Zero values – specifies that cells with a zero value are printed.

Scale – defines a page scale for the printed spreadsheet.

–
–
–
–

Styles

Column and row headers – specifies whether you want the column and row headers to
be printed.
Grid – prints the borders of the individual cells as a grid. For the view on screen, make
your selection in Tools > Options ->LibreOffice Calc ->View > Grid lines.
Comments – prints the comments defined in your spreadsheet. They will be printed on
a separate page along with the corresponding cell reference.
Objects/graphics – includes all inserted objects (if printable) and graphics with the
printed document.
Charts – prints the charts that have been inserted into your spreadsheet.

Scaling mode – select a scaling mode from the drop-down list. Appropriate controls will
be shown below this option.
Reduce/enlarge printout – specifies a scaling factor to scale all printed pages.
Scaling factor – enter a percentage figure for scaling your spreadsheet for printing. The
default setting is 100%.
Fit print range(s) to width/height – specifies the maximum number of pages horizontally
(width) and vertically (height) on which every sheet with the same page style is to be
printed.
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–
–
–
–

The print ranges are always scaled proportionally, so the resulting number of pages
may be less than specified.
You may deselect one of the options, then the unspecified dimension will use as many
pages as necessary.
If you deselect both options, this will result in a scaling factor of 100%.
Width in pages – enter the maximum number of pages to be printed horizontally
across.
Height in pages – enter the maximum number of pages to be printed vertically stacked.
Fit print range(s) on number of pages – specifies the maximum number of pages on
which every sheet with the same page style is to be printed. The scale will be reduced
as necessary to fit the defined number of pages.
Number of pages – enter the maximum number of pages to be printed.

Modifying and updating styles
Modifying styles
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) To modify a cell style, click on the Cell Styles icon
to open the list of cell styles.

in the Styles and Formatting dialog

3) To modify a page style, click on the Page Styles icon
in the Styles and Formatting
dialog to open the list of page styles.
4) Right-click on the style name you want to modify and select Modify from the context menu
to open either the Cell Style dialog (Figure 5) or the Page Style dialog (Figure 6).
5) Make the necessary changes to the style attributes. For more information on style
attributes, see “Cell style attributes” on page 10 and “Page style attributes” on page 14.
6) Click OK to save the changes and close the dialog.

Note

The Modify command is unavailable if one or more sheets are protected, even if
the style to be modified is being used in an unprotected sheet.

Updating styles
Updating styles can only be carried out on cell styles as follows:
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) Click on the Cell Styles icon
in the Styles and Formatting dialog to open the list of cell
styles.
3) Select a cell on the spreadsheet that is using the cell style you want to update and highlight
the data in the cell. The cell style name will be highlighted in the Styles and Formatting
dialog.
4) Make the necessary format changes to the data.

Styles
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5) Click on the Update Style icon
and the cell style attributes will be updated with your
changes. Any other cells using the same cell style will also be updated to with your
changes.

Hiding, showing and displaying styles
Hiding styles
Hiding styles can only be carried out on cell styles as follows. Only styles that are not being used in
the spreadsheet can be hidden.
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) Click on the Cell Styles icon
in the Styles and Formatting dialog to open the list of cell
styles.
3) Right click on an unused cell style and select Hide from the context menu. The style is then
moved to the Hidden Styles category in the Styles and Formatting dialog.

Showing styles
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
on the Formatting toolbar to open the Styles and
Formatting dialog (Figure 2).
2) Click on the drop-down list at the bottom of the Styles and Formatting dialog and select
Hidden Styles from the list.
3) Right click on the hidden style you want to show and select Show from the context menu.
The style will then be displayed in the Styles and Formatting dialog.

Displaying styles
The Styles and Formatting dialog can display different categories of styles as follows:
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
on the Formatting toolbar to open the Styles and
Formatting dialog (Figure 2).
2) Click on the drop-down list at the bottom of the Styles and Formatting dialog.
3) Select the style category you want displayed in the Styles and Formatting dialog. The
categories are as follows:
– Hierarchical – lists the styles used in an outline and normally only applies to documents
that use a hierarchical outline.
– All Styles – lists all the styles that are available in Calc and in your spreadsheet, except
for Hidden Styles.
– Hidden Styles – lists all the styles that have been hidden in a spreadsheet.

–
–

Styles

Applied Styles – lists only the styles that have been applied to the spreadsheet.
Custom Styles – lists only the styles that you have created for use in a spreadsheet or
a template.
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Copying cell styles
To copy a cell style already in use to another cell in your spreadsheet or into a cell in another
spreadsheet:
1) Click one of the cells that has been assigned the style you want to copy, and then copy the
cell to the clipboard.
2) Select the cells that are to receive the same formatting as the copied cell.
3) Go to Edit > Paste Special on the menu bar to open the Paste Special dialog (Figure 8).
4) Make sure that only Formats is selected and click OK to paste the style formatting
attributes into the cell.

Figure 8: Paste Special dialog

Deleting styles
You can only delete styles that you have created. The styles that are included with LibreOffice as
part of the software installation cannot be deleted.
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or
click the Styles and Formatting icon
Formatting dialog (Figure 2).

on the Formatting toolbar to open the Styles and

2) To delete a cell style, click on the Cell Styles icon
to open the list of cell styles.

in the Styles and Formatting dialog

3) To delete a page style, click on the Page Styles icon
in the Styles and Formatting
dialog to open the list of page styles.
4) Right-click on the style you want to delete and select Delete from the context menu.
5) Select Yes on the warning message that opens to delete the style. Any data in a cell or a
sheet in the spreadsheet that used the deleted style will revert to the Default style included
with Calc.
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Templates
Creating templates
Templates are created from a new or existing spreadsheet as follows:
1) Open a new or existing spreadsheet that you want to use as a base for a template.
2) Add any necessary pre-defined content that you want to appear in a spreadsheet each time
you use the new template. For example, company logo and name, company information,
page numbers, and so on.
3) Create all the cell and page styles that you want to use in your new template.
4) Go to File > Save as Template on the main menu bar, or use the keyboard combination
Shift+F11 to open the Template Manager dialog (Figure 9).
5) Double-click to open the folder where you want to save your template or create a new
folder for spreadsheet templates. It is recommended to use the My Templates folder for all
your LibreOffice templates.
6) Click the Save icon
and type a memorable name for your template.
7) Click OK to save the new template.

Figure 9: Template Manager dialog

Note

When you create and save a spreadsheet template, it will be automatically saved in
the Spreadsheets section in the Template Manager.

Editing templates
1) Go to File > New > Templates on the main menu bar, or click on the Templates button on
the LibreOffice opening dialog to open the Template Manager dialog. By default, the
Template Manager opens in the My Templates folder.
2) Click on the Spreadsheets tab or navigate to the folder where you have saved your
spreadsheet templates.
3) Select the template that you want to edit. When you do this, a row of icons appears above
the templates (see Figure 10).
4) Click the Edit icon
and the spreadsheet template opens in Calc.
5) Make all necessary to the template content, cell styles, and page styles just as you would
with a spreadsheet.
6) Go to File > Save on the menu bar to save your changes, or go to File > Save As
Template on the main menu bar to save the edited template as a new template.
Templates
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Figure 10: Template Manager dialog – Editing templates

Creating spreadsheets from templates
To create a spreadsheet from a template:
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Select the Spreadsheets tab and navigate to the folder where the template is located. The
default folder for templates is My Templates.
3) Select the template you want to use and click on the Open icon
, or double-click on the
template to open it. The Template Manager closes and a new spreadsheet opens in Calc.
4) Go to File > Save As on the main menu bar, or use the keyboard combination Ctrl+Shift+S
and save your new spreadsheet with the filename you want to use.

Updating styles from a changed template
If you make any changes to a template and its styles, the next time you open a spreadsheet that
was created before you changed the template, a confirmation message is displayed.
1) Click Update Styles to apply the changed styles in the template to the spreadsheet.
2) Click Keep Old Styles if you do not want to apply the changed styles in the template to the
spreadsheet.

Note

If you select Keep Old Styles, the confirmation message will not appear again the
next time you open the spreadsheet using the same changed template.

Setting default template
If you create a new spreadsheet using File > New > Spreadsheet on the main menu bar, Calc
creates the document from the default template for spreadsheets. You can, however, set any
template as the default template. You can also reset the default template to the Calc default
template at a later date if you want to.

Templates
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Setting a template as default
You can set any template to be the default, but the template must be located in one of the folders
displayed in the Template Manager dialog.
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Navigate to the folder containing the template that you want to set as the default.
3) Select the template.
4) Click on the Set As Default icon
will be created from this template.

. The next time that you create a new spreadsheet, it

Resetting default template
To set the default spreadsheet template back to the default template supplied with Calc:
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Click on the Action Menu icon.
3) Select Reset Default Template > Spreadsheet from the context menu. The next time that
you create a new spreadsheet, it will be created using the Calc default template.

Note

Resetting the default template back to the Calc default template is only available if the
default has been changed previously.

Associating spreadsheets with a different template
At times you might want to use or associate a spreadsheet with a different template. The main
advantage of associating a spreadsheet with a different template is that it makes it easier to update
the styles if the requirement arises.
For best results when associating spreadsheets with another template is to make sure that the
style names in the spreadsheet and in the template are the same. If the names are not the same,
you will need to use Search and Replace function in Calc to replace the old styles with new ones.
See Chapter 2 Entering, Editing, and Formatting Data for more information about finding and
replacing styles.
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Navigate to the folder containing the template that you want to use.
3) Double click on the template and a new blank spreadsheet is created.
4) Open the spreadsheet you want to associate with the template.
5) Go to Edit > Select All on the main menu bar, or use the keyboard combination Ctrl+A to
select everything in the spreadsheet you want to change.
6) Go to Edit > Copy on the main menu bar, or use the keyboard combination Ctrl+C to copy
the spreadsheet data to the clipboard.
7) Close the old spreadsheet without saving.
8) In the new blank spreadsheet, go to Edit > Paste on the main menu bar, or use the
keyboard combination Ctrl+V to paste the data into the spreadsheet.
9) Go to File > Save As on the main menu bar, or use the keyboard combination Ctrl+Shift+S
to save this new spreadsheet with the filename as the old spreadsheet.
10) When asked, confirm that you want to overwrite the old file.
Templates
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Organizing templates
LibreOffice can only use templates that are in its template folders. You can create new template
folders and use them to organize your templates and import templates into these folders. For
example, you might have one template folder for sales templates and another for invoice
templates. You can also export templates.

Tip

The location of template folders in LibreOffice depends on the operating system of
your computer. If you want to know where the template folders are located, go to
Tools > Options > LibreOffice > Paths.

Creating template folders
1) Go to File > New > Templates on the main menu bar to open the Template Manager
dialog. If necessary, click on All Templates to display the view shown in Figure 9.
2) Click the New Folder icon
.
3) In the pop-up dialog, type a name for the new folder and click OK. The new folder now
appears in the list of folders.

Deleting template folders
You cannot delete template folders supplied with LibreOffice. You can only delete template folders
that you have created.
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Select the folder that you want to delete.
3) Click the Delete icon

.

4) Click Yes to confirm the deletion and the folder and templates inside the folder are deleted.

Moving templates
To move a template from one template folder to another template folder:
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Navigate to the folder containing the template that you want to move to another folder.
3) Select the template you want to move.
4) Click the Move to folder icon
and select the folder you want to use from the context
menu. The selected template is moved to the folder.

Deleting templates
You cannot delete templates supplied with LibreOffice. You can only delete templates that you
have created or imported.
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Select the folder that you want to delete.
3) Click the Delete icon

.

4) Click Yes to confirm the deletion and the folder and templates inside the folder are deleted.
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Importing templates
You can import and add templates to your collection as follows:
1) Open your browser software and locate the web page where the template is located. It is
recommended to use the link http://templates.libreoffice.org/template-center which will take
you to the LibreOffice Template Center where you will find several templates that are fully
compatible with LibreOffice.
2) Download the template you want to use.
3) In Calc, go to File > New > Templates to open the Template Manager dialog (Figure 11).
4) Click on the Import icon
and navigate to the folder where the downloaded template is
located on your computer.
5) Select the template and click Open. After import, the template becomes available in the
Template Manager.

Figure 11: Template Manager dialog – Importing templates

Note

It is recommended to import templates using the above procedure as this places
the templates into the correct location for LibreOffice to locate the templates.

Exporting templates
To export a template from a template folder to another location:
1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 10).
2) Navigate to the folder containing the template that you want to export.
3) Select the template that you want to export.
4) Click the Export icon and the Save As dialog opens.
5) Navigate to the location where you want to export the template and click Save. If
necessary, you can also rename the template.
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