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What is Draw?

Draw is a vector graphics drawing program, although it can also perform some operations on raster 
graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display an image as simple geometric elements such as lines, circles, 
and polygons rather than a collections of pixels (points on the screen). Vector graphics allow for 
easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all 
components of the suite. For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also work with drawings directly 
from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses more functionality than the drawing tools that are 
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw 
features. See the Draw Guide and the application help for more information.

Figure 1: LibreOffice Draw workspace
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Draw workspace

The main components of the Draw workspace are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the 
drawing area with toolbars and information areas. The number and position of the visible tools vary 
with the task in hand and user preferences. Therefore your setup may look different. For example, 
many users put the main Drawing toolbar on the left-hand side of the workspace and not at the 
bottom, as shown in Figure 1.

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw window in Figure 1 gives an overview 
of the pages that you create. If the Pages pane is not visible on your setup, you can enable it from 
the View menu (View > Page Pane). To make changes to the page order, just drag and drop one 
or more pages.

In LibreOffice Draw, the maximum size of a drawing page is 300 cm by 300 cm.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If 
they are not visible, you can enable them by selecting View > Ruler in the main menu bar. The 
rulers show the size of a selected object on the page using double lines (highlighted in Figure 2). 
When no object is selected, they show the location of the mouse pointer, which helps to position 
drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position 
objects.

Figure 2: Rulers showing size of a selected object

Figure 3: Ruler units
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The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

To modify the measurement units of the rulers, which can be defined independently, right-click on 
the desired ruler, as illustrated for the horizontal ruler in Figure 3.

Status bar
The Status bar (Figure 4) is located at the bottom of the screen in all LibreOffice components; it 
includes several Draw-specific fields. For details on the contents and use of these fields, see 
Chapter 1 Introducing LibreOffice in this guide and Chapter 1 Introducing Draw in the Draw Guide.

Figure 4: Draw status bar

Note

The sizes are given in the current measurement unit and are not to be confused with 
the ruler units. This current measurement unit is defined in Tools > Options > 
LibreOffice Draw > General, where you can also change the scale of the page. 
Another way to change the scale is to double-click on the number shown in the 
status bar.

Toolbars
To display or hide the various Draw toolbars. choose View > Toolbars. On the menu that appears, 
select which toolbars you want to display. For more about working with toolbars, see Chapter 1 
Introducing LibreOffice in this guide.

The tools available in the Draw toolbars are explained in the following sections. The appearance of 
the toolbar icons may vary depending on your operating system and the selection of icon size and 
style in Tools > Options > LibreOffice > View.

Standard toolbar
The Standard toolbar (Figure 5) is the same for all LibreOffice components and is not described in 
detail in this chapter. 

Figure 5: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 6) is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes and for organizing them on the page.
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Figure 6: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 7) lets you modify the main properties of a drawing object. The 
icons and pull-down lists vary, according to the type of object selected. For example, to change the 
style of a line, click on the up and down arrows for Line Style and select the required style. See 
“Editing objects” on page 22 for details.

Figure 7: Line and Filling toolbar

Text Formatting toolbar
If the selected object is text, the toolbar changes to the Text Formatting toolbar (Figure 8), which is 
similar to the Formatting toolbar in Writer. For more information, see Chapter 4 Getting Started 
with Writer in this guide.

Figure 8: Text Formatting toolbar

Options toolbar
Use the Options toolbar (Figure 9) to activate or deactivate various drawing aids. The Options 
toolbar is not one of the toolbars displayed by default. To display the Options toolbar, select View > 
Toolbars > Options.

Figure 9: Options toolbar

Choosing and defining colors

To display the Color bar,(Figure 10) use View > Toolbars > Color Bar. The toolbar appears at the 
bottom of the workspace and displays the current color palette. This toolbar lets you rapidly choose 
the color of the various objects (lines, areas, and 3D effects). The first box in the panel 
corresponds to invisible (no color).

Figure 10: Color bar
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Figure 11. Changing the color palette

You can access several specialized color palettes in Draw, as well as change individual colors to 
your own taste. This is done using the Area dialog by selecting Format > Area on the main menu 

bar or the Area icon  on the Line and Filling toolbar (Figure 7), then selecting the Colors tab 
(Figure 11).

To load another palette, click on the Load Color List icon . The file selector dialog asks you to 
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example, 
web.soc is a color palette that is adapted to creating drawings for placing in web pages. These 
colors will display correctly on workstations with screens capable of at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical 
values in the fields provided to the right of the color palette. You can use the color schemes known 
as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).

Click on the Edit button to open the Color dialog, where you can set individual colors. See “Color 
options” in Chapter 2 Setting Up LibreOffice in this guide.

For a more detailed description of color palettes and their options, see Chapter 8 Tips and Tricks in 
the Draw Guide.

Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar 
(Figure 6) and these various tools are described, from left to right on the Drawing toolbar, are given 
in Table 1.This section describes only a few of the basic shapes, which are treated as objects in 
Draw, including text. See the Draw Guide for a complete description of the shapes available.

Please note that some of the icons on the Drawing toolbar will change according to the shape that 
has been selected from the choice available. Available tools are indicated by a small triangle or 
arrow to the right of the icon.
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Table 1: Basic drawing tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Select Line
Line ends 
with arrow

Rectangle

Ellipse Text Vertical text Curve

Connector
Lines and 
arrows

Basic 
shapes

Symbol 
shapes

Block arrows Flowcharts Callouts Stars

Note
When you draw a basic shape or select one for editing, the Info field at the left side 
in the status bar changes to reflect the present action: for example Line created, 
Text frame xxyy selected, and so on.

Drawing a straight line

Click on the Line icon  and place the mouse pointer at the point where you want to start the line 
(Figure 12). Drag the mouse while keeping the mouse button pressed. Release the mouse button 
at the point where you want to end the line. A selection handle appears at each end of the line, 
showing that this object is the currently selected object. The selection handle at the starting point of 
the line is slightly larger than the other selection handle.

Figure 12: Drawing a straight line

Keeping the Shift key pressed while you draw a line restricts the drawing angle of the line to a 
multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution
This is the default behavior of the Shift key. However, if the option When creating 
or moving objects in the Snap position section of Tools > Options > LibreOffice 
Draw > Grid has been selected, the action of the Shift key is the opposite. Lines 
will automatically be drawn at a multiple of 45 degrees unless the Shift key is 
pressed.

Keeping the Ctrl key pressed while drawing a line enables the end of the line to snap to the nearest 
grid point.
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Caution This is the default behavior of the Ctrl key. However, if the Snap to Grid option on 
the View > Grid menu has been selected, the Ctrl key deactivates the snap to grid 
activity.

Holding down the Alt key while drawing a line results in the line extending outwards symmetrically 
in both directions from the start point. This lets you draw lines by starting from the middle of the 
line.

When a line is drawn, it uses default attributes. To change any of these attributes, select the line by 
clicking on it, then right-click and select Line to open the Line dialog (Figure 13). Line style, line 
width and line color can also be changed using the controls in the Line and Filling toolbar at the top 
of the workspace.

Figure 13: Line dialog

Drawing an arrow
Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with 
arrowheads. The information field on the status bar shows them only as lines. Click on the Line 

Ends with Arrow icon  to draw an arrow. The arrow head is drawn at the end point of the arrow 
when you release the mouse button.

Choosing line endings
Several types of line endings (arrows, circles, squares, and others) are available in Draw. Click on 

the small triangle or arrow to the right of the Lines and Arrows  icon on the Drawing toolbar to 
open a pop-up toolbar with ten tools for drawing lines and arrows. Alternatively, go to View > 
Toolbars > Arrows to open the Arrows toolbar as a floating toolbar (Figure 14 and Table 2). The 
icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to use 
the same tool again.

After drawing the line, you can change the arrow style by clicking on the Arrowheads icon  in 
the Line and Filling toolbar and select the arrow start and end options.

Drawing basic shapes 11



Figure 14: Arrows toolbar

Table 2: Tools on the Arrows toolbar

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Line
Line ends 
with arrow

Line with 
arrow/circle

Line with 
arrow/square

Line (45°)
Line starts 
with arrow

Line with 
circle/arrow

Line with 
square/arrow

Dimension 
line

Line with 
arrows

Drawing rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon  in the 
Drawing toolbar. As you draw the rectangle with the mouse cursor, the rectangle appears with the 
bottom right corner of the rectangle attached to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle  
icon  and hold down the Shift key whilst you draw a square.

Note

If the option When creating or moving objects has been selected in Tools > 
Options > LibreOffice Draw > General, the action of the Shift key is reversed. 
When the Rectangle tool is selected, a square is drawn. To draw a rectangle, you 
have to press the Shift key when drawing. This Shift key reversal also applies when 
drawing ellipses and circles.

To draw a rectangle or square from its center rather than the bottom right corner, position your 
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with 
the cursor. The rectangle or square uses the start point (where you first clicked the mouse button) 
as the center.

Drawing circles or ellipses

To draw an ellipse (also called an oval), click on the Ellipse icon  on the Drawing toolbar. A 
circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and 
hold down the Shift key whilst you draw a circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the 
start point (where you first clicked the mouse button) as the center.

Note

If you first press and hold down the Ctrl key and then click on one of the icons for 
Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in 
the work area; the size, shape, and color are all standard values. These attributes 
can be changed later, if desired. See the Draw Guide for more information.
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Drawing curves or polygons

To draw a curve or polygon click the Curve icon  on the Drawing toolbar. Click on the triangle or 
arrow to the right of the icon to open the tools that are available (Figure 15 and Table 3).

Note

Hovering the mouse pointer over this icon gives a tooltip of Curve. If you open the 
floating toolbar, the title is Lines, as shown in Figure 15.

Holding down the Shift key when drawing lines with the Curve or Polygon tools will 
restrict the angles between the lines to 45 or 90 degrees.

Figure 15: Curves (Lines) toolbar

Table 3: Curve and polygon tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Curve filled
Polygon 
filled

Polygon 45° 
filled

Freeform line 
filled

Curve Polygon Polygon 45° Freeform line

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the 
function.

Curves
Click and hold the left mouse button to create the starting point of your curve, then, while holding 
down the left mouse button, drag from the starting point to draw a line. Release the left mouse 
button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the 
curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a 
straight line. Each mouse click sets a corner point and allows you to continue drawing another 
straight line from the corner point. A double click ends the drawing of your line.

A filled curve automatically joins the last point to the first point to close off the figure and fills it with 
the current standard fill color. A curve without filling will not be closed at the end of the drawing.

Polygons
Click and draw the first line from the start point with the left mouse button held down. As soon as 
you release the mouse button, a line between the first and second points is drawn. Move the 
cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another 
line. A double-click ends the drawing.

A filled polygon automatically joins the last point to the first point to close off the figure and fills it 
with the current standard fill color. A polygon without filling will not be closed at the end of the 
drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 
45 or 90 degrees.
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Freeform lines
Using the Freeform Line tools is similar to drawing with a pencil on paper. Press and hold the left 
mouse button and drag the cursor to the line shape you require. It is not necessary to end the 
drawing with a double-click, just  release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the 
object is filled with the appropriate color.

Adding text

To activate the text tool, click on the Text icon  for horizontal text or the Vertical Text icon  for 
vertical script. If the Vertical Text icon is not visible, check that the option Enabled for Asian 
languages has been selected in Tools > Options > Language Settings > Languages. The Text 
Formatting toolbar appears (Figure 8 on page 8) when the Text icon is selected; from this toolbar 
you can select font type, font size, and other text properties before you start typing your text.

After activating the Text command, click at the location where you want to position the text. A small 
text frame appears, containing only the cursor. This frame can be moved like any other object. A 
text frame is also dynamic and grows as you enter text.

Observe the information field in the status bar: it shows that you are editing text and also provides 
details about the current cursor location using paragraph, row, and column numbers (Figure 16).

Figure 16: Text information on the Status Bar

You can insert a line break with the Shift+Enter key combination or start a new paragraph with the 
Enter key. The insertion of line breaks or new paragraphs does not terminate text editing or 
deselect the text frame. When you have finished typing text, click outside the text frame to cancel 
adding text.

If you want to edit text, double-click on the text to open the Text Formatting toolbar and highlight 
the text to start editing.

Text properties can also be changed during text input, with any changes taking effect from the 
cursor position onwards. To change the properties for all of the text in the text frame, you have to 
highlight all text in the text frame.

You can create Graphics styles that you can reuse for other text frames. Select Format > Styles 
and Formatting or press F11 to open the Styles and Formatting dialog. Graphics styles affect all 
of the text within a text frame. To only format parts of the text, use direct formatting with the toolbar.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object. 
You can rotate the frame and write the text at any angle. These options are available by right-
clicking on the text frame itself.

If you double-click on a graphic object, or press F2 or click on the Text icon when an object is 
selected, you can add text to the graphic object. This text then becomes part of the graphic object.
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A graphic object is not dynamic and does not behave like a text frame. To keep text within the 
borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the 
object size, or combine all four methods.

For more information about text, see Chapter 2 Drawing Basic Shapes and Chapter 10 Advanced 
Draw Techniques in the Draw Guide.

Gluepoints and connectors

Gluepoints
All Draw objects have gluepoints, which normally are not displayed. Gluepoints become visible 

when the Connectors icon  on the Drawing toolbar is selected.

Most objects have four gluepoints (Figure 17). You can add more gluepoints and customize 
gluepoints, using the Gluepoints toolbar (Figure 18). Go to View > Toolbars > Gluepoints to 
open the toolbar.

Figure 17: Gluepoints

Figure 18: Gluepoints toolbar

Gluepoints are not the same as the selection handles of an object. The handles are for moving or 
changing the shape of an object. Gluepoints are used to fix or glue a connector to an object so that 
when the object moves, the connector stays fixed to the object. For a more detailed description on 
the use of gluepoints, see Chapter 3 Working with Objects and Object Points and Chapter 9 
Organization Charts, Flow Diagrams, and More in the Draw Guide.

Connectors
Connectors are lines or arrows whose ends automatically snap to a gluepoint of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a gluepoint. Figure 19 
shows an example of two objects and a connector.

Draw offers a range of different connectors and connector functions. Click on the arrow next to the 

Connector icon  to open the Connectors toolbar (Figure 20 and Table 4). For a more 
detailed description of the use of connectors, see Chapter 9 Organization Charts, Flow Diagrams, 
and More in the Draw Guide.
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Figure 19: A connector between two objects

Figure 20: Connectors toolbar

Table 4: Connector tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Connector
Connector 
ends with 
arrow

Connector 
with arrows

Line connector

Line connector 
ends with 
arrow

Line 
connector 
with arrows

Straight 
connector

Straight 
connector ends 
with arrow

Straight 
connector with 
arrows

Curved 
connector

Curved 
connector 
ends with 
arrow

Curved 
connector with 
arrows

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric 
shape is explained in the following sections. Clicking on the triangle or arrow to the right of the icon 
opens a floating toolbar giving access to the tools for that geometric shape.

Tip
The use of these tools for geometric shapes is similar to the tool used for drawing 
rectangles and squares. For more information, see “Drawing rectangles or squares” 
on page 12 and Chapter 2 Drawing Basic Shapes in the Draw Guide.

Note
The icons for geometric shapes displayed on the Drawing toolbar will change shape 
according to the last tool selected and used to draw an object.
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Basic shapes

Click on the triangle or arrow to the right of the Basic Shapes icon  to open the Basic Shapes 
toolbar (Figure 21) for drawing basic shapes. This toolbar also includes a rectangle tool identical to 
the one already displayed on the Drawing toolbar.

Figure 21: Basic Shapes toolbar

Symbol shapes

Click on the triangle or arrow to the right of the Symbol Shapes icon  to open the Symbol 
Shapes toolbar (Figure 22) for drawing symbols.

Figure 22: Symbol Shapes toolbar

Block arrows

Click on the triangle or arrow to the right of the Block Arrows icon  to open the Block Arrows 
toolbar (Figure 23) for drawing block arrows.

Figure 23: Block Arrows toolbar

Flowcharts

Click on the triangle or arrow to the right of the Flowcharts icon  to open the Flowchart toolbar 
(Figure 24) for symbols used in drawing flowcharts. The creation of flowcharts, organization charts, 
and similar planning tools are further described in Chapter 9 Organization Charts, Flow Diagrams, 
and More in the Draw Guide.

Figure 24: Flowcharts toolbar
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Callouts

Click on the triangle or arrow to the right of the Callouts icon  to open the Callouts toolbar 
(Figure 25) for drawing callouts.

Figure 25: Callouts toolbar

Stars and banners

Click on the triangle or arrow to the right of the Stars icon  to open the Stars and Banners 
toolbar (Figure 26) for drawing stars and banners.

Figure 26: Stars and Banners toolbar

Note
You can add text to all these geometric shapes. See Chapter 2 Drawing Basic 
Shapes and Chapter 10 Advanced Draw Techniques in the Draw Guide for details.

Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. One click selects; a second click deselects. To select or deselect 
more than one object, hold the shift button down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. This 
cursor dragging draws a rectangle around the objects and only objects that lie entirely within the 
rectangle will be selected.

To select multiple objects by framing, the Select icon  on the Drawing toolbar must be active.

Note
When dragging the mouse cursor to select multiple objects, the selection rectangle 
being drawn is also known as a marquee.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the 
Alt key and click on the object at the front of where the hidden object is located, then click again to 
select the hidden object. If there are several hidden objects, keep holding down the Alt key and 
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clicking until you reach the object you want. To cycle through the objects in reverse order, hold 
down the Alt+Shift keys and click.

When you click on the selected object, its outline will appear briefly through the objects covering it.

Note
Using the Alt key method works on computers using a Windows or Mac operating 
systems. On a computer using a Linux operating system the Tab key method, 
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle 
through the objects, stopping at the object you want to select. To cycle through the objects in 
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be 
practical if there a large number of objects in a drawing.

Arranging objects
In a complex drawing, several objects may be stacked on top of one another. To rearrange the 
stacking order by moving an object forward or backward, select an object, click Modify > Arrange 
on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the 
object, select Arrange from the context menu, then Bring Forward or Send Backward.

The Arrange options are also available by clicking on the small triangle or arrow to the right of the 

Arrange icon  on the Drawing toolbar. This opens the Position toolbar giving access to the 
various arrangement options.

Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the 
bottom of the Draw window (Figure 27). The area on the left of the Drawing toolbar, from left to 
right, shows what object is selected, its position on the drawing in X/Y coordinates and dimensions 
of the object. The units of measurement are those selected in Tools > Options > LibreOffice 
Draw > General.

For more information on moving and adjusting object size, see Chapter 3 Working with Objects 
and Object Points in the Draw Guide.

Figure 27: Left end of status bar when moving or adjusting an object

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold 
down the left mouse button while dragging the mouse. During movement, the shape of the object 
appears as dotted lines to help with repositioning (Figure 28). To locate the object at its new 
location, release the mouse button.
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Figure 28: Moving an object

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to 
one of the selection handles. The mouse cursor will change shape to indicate the direction of 
movement for that selection handle. As you change the size of the object, a ghosted outline of the 
object appears (Figure 29). When you have reached the desired size of the object, release the 
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side handle. To resize along both axes, use a corner handle.

Figure 29: Adjusting object size

Note

If you press the Shift key while resizing an object, the change in size will be carried 
out symmetrically with respect to the two axes so that the aspect ratio of the object 
remains the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is the aspect ratio will be preserved unless 
the Shift key is pressed.

Rotating and slanting an object

For more information on rotating and slanting an object, see Chapter 3 Working with Objects and 
Object Points in the Draw Guide.

Rotating an object
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of 
the following methods:

• Click on the object again. Do not double click as this will cancel object selection.

• Click on the Rotate icon  on the Drawing toolbar.

• Go to View > Toolbars > Mode and select the Rotate icon .

The selection handles will change shape and color (Figure 30). Also a center of rotation point will 
appear in the center of the object. As you move the mouse cursor over the handles the cursor 
changes shape. The corner handles are for rotating an object and the top, bottom and side handles 
are to shear or slant an object.
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Figure 30: Rotating an object

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an 
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the 
object. A dotted outline of the object being rotated appears and the current angle of rotation is 
shown in the status bar.

Note
Rotation works differently for 3D objects because rotation occurs in global axes and 
not in a single axis. See Chapter 7 Working with 3D Objects for more information.

The rotation point is normally located at the center of an object. To change the position of the 
rotation point, click on the object with the mouse cursor and drag the object until the rotation point 
is at the desired position. This rotation point can even be outside of the object.

Note

If you press the Shift key while rotating an object, rotation will be restricted to 15° of 
movement.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is rotation will be restricted to 15° of 
movement unless the Shift key is pressed.

Slanting an object
To slant an object, use the handles located at the midpoints on the top, bottom and sides of a 
selected object. The mouse cursor changes when it hovers over one of these midpoint handles. 
The axis used for slanting an object is the object edge directly opposite the midpoint handle being 
used to slant the object. This axis stays fixed in location while the other sides of the object move in 
relation to it as you drag the mouse cursor.

Click and hold the mouse button, then start to move the cursor to shear the object. A dotted outline 
of the object being slanted appears (Figure 31) and the current angle of slanting is shown in the 
status bar.

Note

If you press the Shift key while slanting an object, slanting will be restricted to 15° of 
movement.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the 
action of the Shift key is reversed: that is slanting will be restricted to 15° of 
movement unless the Shift key is pressed.
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Figure 31: Shearing an object

Editing objects

To edit an object or change its attributes, such as color or border width, and so on, the Line and 
Filling toolbar, the Text Formatting toolbar, or the context menu can be used. More information on 
editing objects and changing attributes can be found in Chapter 4 Changing Object Attributes in the 
Draw Guide.

Line and Filling toolbar
If the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling to open 
the toolbar (Figure 32). The most common object attributes can be edited using this toolbar. You 

can also open the Line dialog by clicking on the Line icon  and the Area dialog by clicking on the 

Area icon  for access to more formatting options. Available tools on the Line and Filling toolbar 
are shown from left to right in Figure 33.

Figure 32: Line and Filling toolbar

Figure 33: Available tools on 
Line and Filling toolbar
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Text Formatting toolbar
When you select text, the Line and Filling toolbar automatically changes to show the Text 
Formatting toolbar (Figure 34). You can also open the Text Formatting toolbar by selecting View > 
Toolbars > Text Formatting. The tools on this toolbar will not become active until text has been 
selected. Available tools on the Text Formatting toolbar are shown from left to right in Figure 39.

Figure 34: Text Formatting toolbar

Figure 35: Available tools on Text Formatting toolbar

Figure 36: Context menu
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Context menu
When an object is selected and you right-click on the object, a context menu (Figure 36) opens that 
applies to the selected object. This context menu provides access to the options available and 
allows you to change object attributes without having to open a dialog. Menu entries with a small 
arrow on the right-hand side contain a submenu.

Formatting lines and borders
In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape 
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid, 
dashed, invisible, and so on), its width and its color.

Select the line you need to format and then use the controls on the Line and Filling toolbar to 
change the most common options highlighted in Figure 37.

Figure 37: Common line properties (style, color, width)

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or 

right-click on the line and select Line from the context menu, or select the Line icon  from the 
Line and Filling toolbar. All of these methods open the Line dialog (Figure 38), where you can set 
line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 38: Line properties dialog
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Arrows, arrowheads and line endings
Arrows, arrowheads and other line endings are usually referred to as arrows and can be treated 
the same as lines when editing and changing attributes. Select a line and click on the Arrow Style 

icon  from the Line and Filling toolbar to open the Arrowheads menu (Figure 39).

Several types of arrowheads are available. Each end of a line can have a different arrowhead or no 
arrowhead). Arrowheads are only applicable to lines and they have no effect on the border of an 
object.

Figure 39: Arrowheads menu

Formatting area fill

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching 
pattern, or bitmap (Figure 40). An area fill can be made partly or wholly transparent. In most cases, 
you will choose one of the standard fill options, which are all available from the Line and Filling 
toolbar. You can also define your own area fills. For more information on formatting area fill, see 
Chapter 4 Changing Object Attributes in the Draw Guide.

Figure 40: Different types of area fill
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Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. 
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a 
formatting template (a style) and then to apply that style to multiple objects. For more information 
on styles, see Chapter 3 Using Styles and Templates in this guide, Chapter 6 Introduction to Styles 
in the Writer Guide and Chapter 4 Changing Object Attributes in the Draw Guide.

Positioning objects

Snap function
In Draw, objects can be accurately and consistently positioned using the snap function. Grid points, 
snap points and lines, object frames, individual points on objects, or page edges can all be used 
with the snap function.

Snap function is easier to work with at the high zoom values that are practical for your display. Two 
different snap functions can be used at the same time; for example snapping to a guide line and to 
the page edge. It is recommended, however, to activate only the functions that you really need.

For more detailed information about the snap function, see Chapter 8 Tips and Tricks and Chapter 
10 Advanced Draw Techniques in the Draw Guide.

Snap to grid
Snap to grid allows you to position an object to a grid point (Figure 41). Go to View > Grid > Snap 

to Grid or click on the Snap to Grid icon  on the Options toolbar to turn on or off the snap to 
grid function. If the Options toolbar is not displayed, go to View > Toolbars > Options.

Figure 41: Positioning with snap to grid

Displaying the grid
To display the grid in Draw or to switch off the grid, go to View > Grid > Display Grid or click on 

with the Display Grid  icon on the Options toolbar.
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Figure 42: Configuring the grid

Configuring the grid
The resolution, snap and snap position of the grid points can be configured. Go to Tools > 
Options > LibreOffice Draw > Grid to open the options dialog for the grid (Figure 42).

• Vertical and horizontal spacing of the dots in the grid. You can also change the unit of 
measurement used in the general Draw options by going to Tools > Options > LibreOffice 
Draw > General.

• The resolution is the size of the squares or rectangles in the grid. If the resolution is 1 cm 
horizontal and 2 cm vertical, the grid consists of rectangles 2 cm high and 1 cm wide.

• Subdivisions are additional points that appear along the sides of each rectangle or square 
in the grid. Objects snap to subdivisions as well as to the corners of the grid.

• The pixel size of the snap area defines how close you need to bring an object to a snap 
point or line before it will snap to it.

• The default color of the grid is light gray. To change the color of the grid points, go to Tools 
> Options > LibreOffice > Appearance.

Help lines
Draw has help lines to easily allow you to position an object using the rulers at the top and left side 
of the workspace. To turn on or off the help lines, go to Tools > Options > LibreOffice Draw > 
View and select Snap Lines when moving option or go to the Options toolbar and by click on the 

Helplines While Moving icon .

Applying special effects

With Draw, you can apply many special effects to objects and groups of objects and this section is 
an introduction to some of these effects. For more information on special effects can be found in 
Chapter 4 Changing Object Attributes of the Draw Guide.
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To access the tools used for special effects, go to View > Toolbars > Mode (Figure 43 and Figure 
44). Rotate and Flip can also be accessed by going to Modify on the main menu bar or by right 
clicking on the object and using the context menu.

Figure 43: Mode toolbar

Figure 44: Available tools on Mode 
toolbar

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the selection handles will show.

2) Right-click and select Flip > Vertically or Horizontally, or got to Modify > Flip > Vertically 
or Horizontally on the main menu bar and the selected object will be flipped to face the 
other direction.

However, the Flip tool on the Mode or Drawing toolbar can be used to give you greater control 
over the flipping process. Using the Flip tool allows you to change the position and angle that the 
object flips over and this is described in Chapter 4 Changing Object Attributes of the Draw Guide.

Mirror copies
At the moment there is no mirror command existing in Draw. However, mirroring an object can be 
emulated by using the Flip tool and this is described Chapter 4 Changing Object Attributes of the 
Draw Guide.

Distorting an object
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the 
image.

• Distort tool  distorts an object in perspective.

• Set to Circle (slant)  creates a pseudo three-dimensional effect.

• Set in Circle (perspective)  creates a pseudo three-dimensional effect.
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In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. See for Chapter 4 Changing Object Attributes of the Draw Guide for more information on 
how to distort an object.

Dynamic transparency gradients
You can control transparency gradients in the same manner as color gradients. Both types of 
gradient can be used together. With a transparency gradient, the direction and degree of object fill 
color changes from opaque to transparent. In a regular gradient, the fill changes from one color to 
another, but the degree of transparency remains the same.

The Transparency and Gradient tools on the Mode toolbar dynamically control transparency and 
color gradients. See Chapter 4 Changing Object Attributes of the Draw Guide for more information 
on how to create transparencies and gradients in an object.

Duplication
Duplication makes copies of an object while applying a set of changes such as color or rotation to 
the duplicates that are created. Click on an object or group of objects and go to Edit > Duplicate 
on the main menu bar to open the Duplicate dialog (Figure 45). Select the required options 
chosen from the options available. When the options in the dialog are applied to a blue rectangle, 
they produce the result shown in Figure 46.

Figure 45: Duplicate dialog

Figure 46: Result of a duplication
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Cross-fading
Cross-fading transforms one object shape to another object shape and only works when two 
objects are selected.

1) Select two differently shaped objects.

2) Go to Edit > Cross-fading to open the Cross-fading dialog (Figure 47).

3) Select Increments to determine the number of shapes between the two objects.

4) Select Cross-fading to apply a gradual change of line and fill properties between the two 
objects.

5) Select Same orientation to apply a smooth transition between the two objects.

6) Click on OK and the result is a new group of objects with the first object selected as the 
start object and the second object selected as the end object. The intermediate objects 
show the transformation from one shape to another (Figure 48).

Figure 47: Cross-fading dialog

Figure 48: Cross-fading result

Combining multiple objects

Using Draw, you can group or combine objects together allowing you to treat multiple objects as 
one unit, or to merge objects to form a new shape. For more information, see Chapter 5 
Combining Multiple Objects in the Draw Guide.

Grouping of objects is similar to putting objects into a container. You can move the objects as a 
group and apply global changes to the objects withing the group. A group can always be undone 
and the objects that make up the group can always be manipulated separately. The objects within 
a group also retain their own individual properties.
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Combining objects is a permanent merging of objects that creates a new object. The original 
objects are no longer available as individual entities and cannot be edited as individual objects. 
Any editing of a combined object affects all the objects that were used when combination was 
carried out.

Grouping

Temporary grouping

A temporary grouping is when several objects are selected using the Select icon  on the 
Drawing toolbar or using the mouse to drag a rectangle around the objects (also known as a 
marquee). Any changes to object parameters you carry out are applied to all of the objects within 
the temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed 
around the objects.

Permanent grouping
A permanent grouping of objects is created after you have selected your objects and then going to 
Modify > Group on the main menu bar, or right clicking on the selection and select Group from 
the context menu, or using the keyboard shortcut Ctrl+Shift+G. When you deselect your selection 
the objects remain grouped together.

When objects are permanently grouped, any editing operations carried out on that group are 
applied to all members of the group. If you click on one member of the group, the whole group is 
selected.

You can edit an individual member of a group without ungrouping or breaking the group. Select the 
group and go to Modify > Enter Group, or right click and select Enter Group from the context 
menu, or double click on the group.

When you have finished editing an individual member of a group, go to Modify > Exit Group, or 
right click and select Exit Group from the context menu.

Ungrouping
To ungroup or break apart a group of objects, select the group then go to Modify > Ungroup on 
the main menu bar, or right click and select Ungroup from the context menu or use the keyboard 
shortcut Ctrl+Alt+Shift+G.

Combining objects
Combining objects is a permanent merging of objects that creates a new object. The original 
objects are no longer available as individual entities and cannot be edited as individual objects. 
Any editing of a combined object affects all the objects that were used when combination was 
carried out.

Select several objects, then go to Modify > Combine on the main menu bar, or right click on the 
objects and select Combine from the context menu, or use the keyboard shortcut Ctrl+Shift+K.

After you have selected your objects, the Merge, Subtract, and Intersect functions also become 
available so that you can create a new object from your selected objects. See Chapter 5 
Combining Multiple Objects in the Draw Guide for more information on these functions.
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Arranging, aligning and distributing objects

In Draw you can arrange, align and distribute selected objects in relation to each other:

• Arrange the position of an object by moving it either forward or backward in relation to the 
order of objects.

• Align objects with respect to each other using Left, Centered, or Right for horizontal 
alignment and Top, Center or Bottom for vertical alignment.

• Distribute objects so that the space between each of the objects is the same.

See Chapter 5 Combining Multiple Objects in the Draw Guide for more information on arranging 
and aligning objects in relation to each other.

Inserting and editing pictures

Draw contains a number of functions for editing pictures or raster graphics (bitmaps); for example, 
photos and scanned images. This includes the import and export of graphics, and the conversion 
of one graphic format to another graphic format.

Draw includes a large range of graphic filters so that it can read and display several graphic file 
formats. It also includes several tools for working with raster graphics, but does not have the same 
functionality as specialized graphic programs like Gimp or Adobe Photoshop. See Chapter 6 
Editing Pictures in the Draw Guide for more information.

You can add pictures from several sources:

• Directly from a scanner (Insert > Picture > Scan)

• Images created by another program, including photographs from a digital camera (Insert > 
Picture > From File)

• The Draw Gallery; see Chapter 11 Graphics, the Gallery, and Fontwork in this guide for 
more information.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs, 
it is capable of producing and editing very good 3D drawings.

Draw offers two types of 3D objects: 3D bodies and 3D shapes. Depending on which type you 
choose, there are different methods of editing of a 3D object (rotation, illumination, perspective, 
and so on) with 3D shapes being simpler to set up and edit than 3D bodies. However, 3D bodies 
currently allow for more customization.

See Chapter 7 Working with 3D Objects in the Draw Guide for more information.

Exporting graphics

Draw saves graphics and images in the open source format *.odg. To save a graphic or the entire 
file in another format, use File > Export and select a format from the list displayed. The graphic 
formats that Draw can export and save to are listed in Appendix B Open Source, Open Standards, 
OpenDocument in this guide.

You can also export Draw files to HTML, XHTML, PDF, or Flash. PDF export for modules of 
LibreOffice a and is described in Chapter 10 Printing, Exporting, and E-mailing of this guide.
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HTML export uses a conversion wizard that creates as many web pages as there are pages in 
your Draw document. You can optionally choose to display pages in frames with a navigator and 
set an index page. For more information, see Chapter 12 Creating Web Pages in this guide.

Inserting comments in a drawing

You can insert comments into your drawing and this a similar process used in Writer and Calc.

1) Go to Insert > Comment on the menu bar. A small box containing your initials appears in 
the upper left-hand corner of your drawing with a larger text box beside it (Figure 49). Draw 
automatically adds your name and the date at the bottom of this text box.

Figure 49: Inserting comments

2) Type or paste your comment into the text box. You can apply basic formatting to parts of 
the text by selecting it, right-clicking, and choosing from the context menu. From this menu, 
you can also delete the current comment, all the comments from the same author, or all the 
comments in the document.

3) You can move the small comment markers to anywhere you wish on the drawing. Typically 
you might place it on or near an object you refer to in the comment.

4) To show or hide the comment markers, go to View > Comments on the main menu bar.

5) Go to Tools > Options > User Data to enter the name you want to appear in the Author 
field of the comment.

6) If more than one person edits the document, each author is automatically allocated a 
different background color.
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