Chapter 19
Spreadsheets, Charts, Other Objects
Copyright

This document is Copyright © 2017 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis Weber

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgements

This chapter is based on Chapter 7 in the LibreOffice 4.2 Impress Guide. Contributors to that chapter are:

Jean Hollis Weber  Michele Zarri  T. Elliot Turner
Peter Schofield

Publication date and software version

Published 31 December 2017. Based on LibreOffice 5.4.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Window or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/
# Contents

**Copyright**.................................................................................................................................2
**Contributors**.................................................................................................................................2
**Feedback**........................................................................................................................................2
**Acknowledgements**.........................................................................................................................2
**Publication date and software version**...........................................................................................2
**Note for Mac users**...........................................................................................................................2

**Introduction: OLE objects**..................................................................................................................4
**Inserting a new OLE object**..............................................................................................................4
**Inserting an OLE object from a file**..................................................................................................5
**Editing OLE objects**..........................................................................................................................5

**Spreadsheets**.....................................................................................................................................5
**Resizing and moving spreadsheet objects**........................................................................................6
  **Resizing**..........................................................................................................................................6
  **Moving**...........................................................................................................................................6
**Editing a spreadsheet object**............................................................................................................6
  **Spreadsheet organization**..............................................................................................................7
  **Working with sheets**.......................................................................................................................7
  **Cell navigation**................................................................................................................................7
  **Entering data**...................................................................................................................................8
  **Formatting cell data**........................................................................................................................8
  **Formatting spreadsheets**...............................................................................................................8
    **Manual formatting**......................................................................................................................8
    **Using formatting styles**...............................................................................................................9
    **Inserting and deleting rows, columns, or cells**..........................................................................9
    **Merging and splitting cells**.........................................................................................................9

**Charts**................................................................................................................................................10
**Inserting a chart**...............................................................................................................................10
**Selecting chart type**..........................................................................................................................10
  **Chart types**....................................................................................................................................11
**Entering chart data**............................................................................................................................12
**Adding or removing chart elements**................................................................................................12
  **Chart formatting**............................................................................................................................13
  **Resizing and moving charts**..........................................................................................................13
    **Resizing**........................................................................................................................................13
    **Moving**.........................................................................................................................................13
    **Position and Size dialog**.............................................................................................................13
  **Chart elements**..................................................................................................................................13
  **Changing chart area background**...................................................................................................14
  **Changing chart wall background**...................................................................................................14

**Audio and video**................................................................................................................................14
**Using media files**.............................................................................................................................14
**Using the Gallery**................................................................................................................................15
**Media playback**...............................................................................................................................15

**Formulas**.............................................................................................................................................15
Introduction: OLE objects

Object Linking and Embedding (OLE) is a way to use information from one application (say, Calc) in another application (Writer, in this case).

Both linking and embedding insert information from one document into another document, but they store information differently. In addition, they are different from directly copying and pasting information because you can open and edit objects in the applications that created them.

An embedded OLE object is a copy of information from another document. When you embed objects, there is no link to the source document and any changes made to the source document are not reflected in the destination document. Embed objects if you want to be able to use the application that created them for editing, but you do not want the OLE object to be updated when you edit information in the source document.

A linked object is a reference to information in another document. Link objects when you want to use the same information in more than one document. Then, if you change the original information, you need to update only the links in order to update the document containing the OLE objects. You can also set links to be updated automatically. When you link an object, you need to maintain access to the source application and the linked document. If you rename or move either of them, you may need to reestablish the link.

The following types of files or documents can be inserted into a Writer document as an OLE object: spreadsheets, charts, drawings, formulas (equations), presentation.

Inserting a new OLE object

When you insert a new OLE object into a document, it is embedded; that is, the object is available only in that document and can only be edited using Writer.

To insert a new OLE object into a document:

1) Click where you want to insert the object.
2) Choose Insert > Object > OLE Object from the Menu bar.
3) On the Insert OLE Object dialog (Figure 1), select Create new.
4) Select the type of object you want to create and click OK.
5) A new OLE object is inserted in the document in edit mode. The toolbars displayed in Writer will change, providing the necessary tools for you to create the new OLE object.

```
Figure 1: Inserting a new OLE object
```

Note

Computers running Microsoft Windows show an additional option of Further Objects in the Object Type list. This option opens another dialog where you can create an OLE object using other software that is compatible with OLE and LibreOffice. This option is available for new OLE objects and OLE objects from a file.
Inserting an OLE object from a file

When you insert an existing file (for example, a spreadsheet) into a Writer document as an OLE object, you can choose whether to embed or link the file.

1) Click where you want to insert the file and choose Insert > Object > OLE Object from the Menu bar.

2) On the Insert OLE Object dialog, select Create from file. The dialog changes to show a File text box (Figure 2).

3) Click Search and the Open dialog is displayed.

4) Locate the file you want to insert and click Open.

5) Select the Link to file option if you wish to insert the file as a live link so that any changes made are synchronized in both the original file and your document.

6) Select the Display as icon option to show an icon for the application that created the file (for example, Calc), instead of displaying the contents of the file.

7) Click OK to insert the file as an OLE object.

Editing OLE objects

To edit an OLE object after it has been created or inserted from a file:

1) Double-click on the OLE object to open it in edit mode. The toolbars displayed in Writer will change to provide the tools necessary to edit the object.

2) When finished editing the object, click anywhere outside the object to cancel editing.

3) Save the Writer document. Any changes made to the OLE object are also saved.

Spreadsheets

To include a spreadsheet in a Writer document, you can insert either an existing spreadsheet file or a new spreadsheet as an OLE object. See above for more information. You can also copy a portion of a spreadsheet into a Writer document as an OLE object; see below.

Embedding a spreadsheet into Writer includes most of the functionality of a Calc spreadsheet. Writer is capable of performing complex calculations and data analysis. However, if you plan to use complex data or formulas, it is recommended to perform those operations in a separate Calc spreadsheet and use Writer only to display the embedded spreadsheet with the results.

You may be tempted to use spreadsheets in Writer for creating complex tables or presenting data in a tabular format. However, the Table feature in Writer is often more suitable and faster to use, depending on the complexity of your data; see Chapter 13, Tables.
To copy a spreadsheet area to a Writer document:

1) Open both the Writer document and the spreadsheet.
2) Select the sheet area (cells) that you want to copy.
3) Right-click and choose **Copy** from the context menu, or press **Ctrl+C**, or drag the area into the Writer document. The sheet area is inserted as an OLE object.

When an entire spreadsheet is inserted into a document, if it contains more than one sheet and the one you want is not visible, double-click the spreadsheet, and then select a different sheet from the row of sheet tabs at the bottom.

### Resizing and moving spreadsheet objects

When resizing or moving a spreadsheet object in Writer, ignore the first row and first column (easily recognizable because of their light background color) and any horizontal and vertical scroll bars. They are only used for spreadsheet editing purposes and will not be included in the spreadsheet that appears in the document.

#### Resizing

When selected, a spreadsheet object is treated like any other object. However, resizing an embedded spreadsheet also changes the spreadsheet area that is visible in the document.

To resize the area occupied by the spreadsheet:

1) Double-click the object to enter edit mode, if it is not already active. Note the selection handles visible in the border surrounding the spreadsheet object.
2) Move the mouse pointer over one of the handles. The pointer changes shape to give a visual representation of the effects applied to the area.
3) Click and hold the left mouse button and drag the handle. The corner handles move the two adjacent sides simultaneously, while the handles at the midpoint of the sides modify one dimension at a time.

#### Moving

Moving a spreadsheet object to change its position within the document is the same as moving any other object in Writer:

1) Select the object so that the selection handles are displayed.
2) Move the cursor over the object until the cursor changes shape (normally a hand, but this depends on your computer setup). Be careful to not double-click on the spreadsheet object and enter into object editing mode.
3) Click and drag the object to the desired position. Release the mouse button.

### Editing a spreadsheet object

To edit a spreadsheet object, double-click on it, or select it and choose **Edit > Object > Edit** from the Menu bar, or right-click and choose **Edit** from the context menu.

You edit the object in its own frame within the Writer document, but some of the toolbars change in Writer so that you can easily edit the spreadsheet. One of the most important changes is the presence of the Formula toolbar, which contains (from left to right):

- The active cell reference or the name of a selected range of cells.
- The **Formula Wizard** icon.
- The **Sum** and **Function** icons or the **Cancel** and **Accept** icons, depending on the editing actions taken in the spreadsheet.
- A long edit box to enter or review the contents of the active cell.
If you are familiar with Calc, you will immediately recognize the tools and the menu items. See Chapter 5, Getting Started with Calc, in the *Getting Started Guide* for more information.

**Spreadsheet organization**

A spreadsheet consists of pages called sheets. However, in Writer, only one sheet can be shown at any one time when a spreadsheet with multiple sheets is embedded into an Writer document. The default names for sheets are Sheet 1, Sheet 2, Sheet 3 and so on, unless the sheets have been renamed, and the sheet names are shown at the bottom of the spreadsheet area.

Each sheet is organized into cells, which are the elementary units of the spreadsheet. They are identified by a row number (shown on the left hand side) and a column letter (shown in the top row). For example, the top left cell is identified as A1, while the third cell in the second row is C2. All data elements, whether text, numbers, or formulas, are entered into a cell.

**Note**

If you have multiple sheets in your embedded spreadsheet, only the active sheet is shown on the page after exiting edit mode.

**Working with sheets**

You can insert, rename, delete, etc sheets in an embedded spreadsheet. To begin, double-click on the embedded spreadsheet to open it in edit mode. When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

**Inserting sheets**

1) Right-click on the sheet names and select **Insert > Sheet** from the context menu, or click on the plus sign to the right of the sheet names, or go to **Insert > Sheet** on the Menu bar to open the Insert Sheet dialog.

2) Select the sheet position, number of sheets to be inserted, sheet name, or which spreadsheet file to use from the options available in the Insert Sheet dialog.

3) Click **OK** to close the dialog and insert the sheet.

**Renaming sheets**

1) Click on the sheet tab you want to rename.

2) Right-click on the sheet tab and select **Rename Sheet** from the context menu, or go to **Format > Sheet > Rename** on the Menu bar.

**Moving and copying sheets**

1) Right-click on the sheet names and select **Move/Copy Sheet** from the context menu, or go to **Edit > Sheet > Move/Copy** on the Menu bar to open the Move/Copy Sheet dialog.

2) Select whether to move or copy the sheet, the sheet location and position, and a new sheet name. Click **OK** to close the dialog and move or copy the sheet.

3) Alternatively, click on the sheet tab and drag it to a new position in the embedded spreadsheet.

**Deleting sheets**

1) Right-click on the tab of the sheet you want to delete and select **Delete Sheet** from the context menu, or go to **Edit > Sheet > Delete** on the Menu bar.

2) Click **Yes** to confirm.

**Cell navigation**

To move around the spreadsheet to select a cell to make it active, you can:

- Use the keyboard arrow keys.
- Position the cursor in a cell and left-click on the mouse.
• Use the Enter key to move one cell down and Shift+Enter to move one cell up.
• Use the Tab key to move one cell to the right and Shift+Tab to move one cell to the left.
• Use other keyboard shortcuts.

**Entering data**
Data input into a cell can only be done when a cell is active. An active cell is easily identified by a thickened and bolder border. The cell reference (or coordinates) for the active cell is displayed at the left hand end of the Formula toolbar.

1) Select the cell to make it active and start typing. The data input is also displayed in the large text box on the Formula toolbar making the data entry easier to read.

2) Use the Formula Wizard icon, Sum icon and Function icon to enter data, formula or function into a cell. If the input is not a formula (for example, a text or date entry), the Sum and Function icons change to the Cancel icon and Accept icon.

3) To confirm data input into a cell either select a different cell, or press the Enter key, or click on the Accept icon.

**Formatting cell data**
Writer normally recognizes the type of contents (text, number, date, time, and so on) entered into a cell and applies default formatting to it. However, if Writer wrongly recognizes the type of data you have entered into a cell:

1) Select the cell, then right-click on the cell and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1.

2) In the Format Cells dialog, click on the appropriate tab to open the correct page and use the options on that page to format the cell data.

3) Click OK to close the dialog and save your changes.

**Tip**
To force Writer to treat numbers as text (for example, telephone numbers) and to prevent Writer from removing the leading zeros or right-align them in a cell, type a single quotation mark (') before entering the number.

**Formatting spreadsheets**
It may be necessary to change the formatting of a spreadsheet to match the style used in the document.

When working on an embedded spreadsheet, you can also access any cell styles created in Calc and use them. However, if you are going to use styles, it is recommended to create specific cell styles for embedded spreadsheets, as Calc cell styles may be unsuitable when working within Writer.

**Manual formatting**
To manually format an embedded spreadsheet:

1) Select a cell or a range of cells. See Chapter 5, Getting Started with Calc, in the Getting Started Guide for more information on selecting ranges of cells.

   a) To select the whole sheet, click on the blank cell at the top left corner between the row and column indexes, or use the keyboard shortcut Ctrl+A.

   b) To select a column, click on the column header at the top of the spreadsheet.

   c) To select a row, click on the row header on the left hand side of the spreadsheet.
2) Right-click on a cell and select Format Cells from the context menu, or go to **Format > Cells** on the Menu bar, or use the keyboard shortcut `Ctrl+1` to open the Format Cells dialog.

3) Use the various dialog pages to format the embedded spreadsheet so that it matches the style of your document.

4) Click **OK** to close the dialog and save your changes.

5) If necessary, adjust the column width by hovering the mouse over the line separating two columns in the header row until the mouse cursor changes to a double-headed arrow; then click the left button and drag the separating line to the new position.

6) If necessary, adjust the row height by hovering the mouse over the line separating two rows in the row header until the mouse cursor changes to a double-headed arrow; then click the left button and drag the separating line to the new position.

7) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing.

**Using formatting styles**

When an embedded spreadsheet is in edit mode, Writer displays the available styles for a spreadsheet in the Styles and Formatting window.

If style formatting you want to use is not available, then see Chapter 8, Introduction to Styles, on how to create a style. Styles used in an embedded spreadsheet are similar to paragraph styles used in Writer.

To use styles in your embedded spreadsheet:

1) Open Styles and Formatting in the Sidebar.

2) Select data in a cell and double-click on a style in Styles and Formatting to apply that style.

**Inserting and deleting rows, columns, or cells**

To insert rows, columns, or cells in an embedded spreadsheet:

1) Select the same number of rows, columns, or cells in the embedded spreadsheet that you want to insert.

2) Go to **Insert > Rows** or **Insert > Columns** or **Insert > Cells** on the Menu bar or right-click on the selection and select **Insert** from the context menu.

3) When inserting cells, select **Insert** from the Insert Cells dialog that opens and click **OK**.

To delete rows, columns, or cells from an embedded spreadsheet:

1) Highlight the number of rows, columns, or cells on the embedded spreadsheet you want to delete.

2) Go to **Edit > Delete Cells** on the Menu bar or right-click on the row or column headers and select **Delete Selected Rows** or **Delete Selected Columns** or **Delete** from the context menu.

**Merging and splitting cells**

To merge multiple cells into a single cell:

1) Select the cells to be merged.

2) Go to **Format > Merge cells** on the Menu bar and select either **Merge and Center Cells** or **Merge Cells**.

3) Alternatively, right-click on the selected cells and select **Merge Cells** from the context menu.
To split a group of cells that have been merged into a single cell:

1) Select the cell that contains merged cells.
2) Go to Format > Split Cells or right-click on the cell and select Split Cells from the context menu.

**Charts**

A chart is a graphical interpretation of information that is contained in a spreadsheet. More information about charts and the use of charts is described in the *Calc Guide*.

**Inserting a chart**

You can add a chart to your document as an OLE object (see page 4) or using the tools within Writer.

To add a chart using Writer’s tools, choose Insert > Chart on the Menu bar to insert a generic chart (Figure 3) at the cursor location. The chart is selected and the Menu bar and toolbars change to those appropriate for charts.

![Figure 3: Chart with sample data](image)

**Selecting chart type**

Your data can be presented using a variety of different charts. Writer contains several chart types that will help you convey your message to your audience. See “Chart types” below.

![Figure 4: Chart Type dialog showing two-dimensional charts](image)
1) Make sure that the chart is selected. The chart has a border and selection handles when selected.

2) Click the **Chart Type** icon on the Formatting toolbar or go to **Format > Chart Type** on the Menu bar, or right-click on the chart and select **Chart Type** from the context menu to open Chart Type dialog (Figure 4).

3) As you change selections in the left-hand list, the chart examples on the right change. Move the Chart Type dialog to one side to see the effect in the chart.

4) As you change chart types, other selections become available on the right-hand side. For example, some chart types have both 3D and 2D variants. When 3D charts are selected, more options become available for selection of shapes for the columns or bars.

5) Choose the chart characteristics you want and click **OK**. You return to the edit window.

6) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

**Chart types**

The following summary of the chart types available will help you choose a type suitable for your data. Column, bar, pie, and area charts are available as 2D or 3D types.

**Column charts**

Column charts displays data that shows trends over time. This the default type of chart. It is recommended to use column charts where there is a relatively small number of data points. If you have a large time series as your data, it is recommended to use a line chart.

**Bar charts**

Bar charts give an immediate visual impact for data comparison where time is not important, for example comparing the popularity of products in a marketplace.

**Pie charts**

Pie charts give a comparison of proportions, for example, when comparing what different departments spent on different items or what different departments actually spent overall. They work best with a small range of values, for example six or less. Using larger range of values, the visual impact of a pie chart begins to fade.

**Area charts**

Area charts are versions of line or column charts. They are useful when you want to emphasize volume of change. Area charts have a greater visual impact than a line chart, but the type of data you use does make a difference to the visual impact.

**Line charts**

Line charts are time series with progression. Ideal for raw data and useful for charts with data showing trends or changes over time where you want to emphasize continuity. On line charts, the X-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a thicker line gives a better visual impact.

**Scatter or XY charts**

Scatter charts are great for visualizing data that you have not had time to analyze and may be best for data where you have a constant value for comparison: for example weather data, reactions under different acidity levels, conditions at altitude, or any data which matches two numeric series. The X-axis usually plots the independent variable or control parameter (often a time series).

**Bubble charts**

Bubble charts are used to represent three variables. Two variables identify the position of the center of a bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.
Net charts
Net charts are similar to polar or radar graphs and are useful for comparing data not in time series, but show different circumstances, such as variables in a scientific experiment. The poles of the net chart are the Y-axes of other charts. Generally, between three and eight axes are best; any more and this type of chart becomes confusing.

Stock charts
Stock charts are specialized column graphs specifically used for stocks and shares. You can choose traditional lines, candlestick, and two-column charts. The data required for these charts is specialized with a series for opening price, closing price, and high and low prices. The X-axis represents a time series.

Column and line charts
Column and line charts are a combination of two other chart types. It is useful for combining two distinct, but related data series, for example sales over time (column) and the profit margin trends (line).

Entering chart data
1) Make sure that the chart is selected and you have selected the chart type.
2) Click on the Data Table icon, or select View > Data Table, or right-click on the chart and select Data Table from the context menu to open the Data Table dialog (Figure 5).
3) Type or paste information into the cells within the desired rows and columns in the Data Table dialog. You can also use the icons in the top left corner of the Data Table dialog to insert, delete or move data.

Figure 5: Chart Data Table dialog

Adding or removing chart elements
The specimen chart inserted into a document includes two elements: a chart wall and a chart legend (also known as the key). You can add or remove elements to or from a chart as follows:
1) Make sure the chart is selected and in edit mode.
2) Go to Insert on the Menu bar and select from the submenu an element that you want to add to the chart, or right-click on the chart wall or a chart element and select an element you want to add from the context menu. Selecting an element opens a dialog where you can specify options for the element.

Note
Right-clicking on a chart element will give you more options to choose from when adding elements to your chart. The number of available insert options in the context menu depends on the type of element selected.
3) To remove an element from a chart, right-click on the chart element you want to remove and select **Delete** from the context menu. The type of element selected for removal will change the delete options in the context menu.

4) Select a chart element and press the **Del** or **Backspace (←)** key to remove it from the chart.

**Chart formatting**

To change the format of a selected chart:

1) Make sure the chart is selected and in edit mode.

2) Go to **Format** on the Menu bar and select from the submenu an element that you want to format, or right-click on a chart element and select a format option from the context menu. Selecting an element opens a dialog where you can specify format options for the element.

The formatting options available depend on whether the whole chart is selected or which chart element has been selected.

**Resizing and moving charts**

You can resize or move a chart interactively or by using the Position and Size dialog. You can also use a combination of both methods.

**Resizing**

To resize a chart interactively:

1) Click on a chart to select it. Selection handles appear around the chart.

2) To increase or decrease the height of a chart, click and drag on a selection handle at the top or bottom of the chart.

3) To increase or decrease the width of a chart, click and drag on a selection handle at the left or right of the chart.

4) To increase or decrease both the height and width of a chart at the same time, click and drag on a selection handle in one of the corners of the chart. To maintain the correct aspect ratio between height and width, hold the **Shift** key down while you click and drag.

**Moving**

To move a chart interactively:

1) Click on the chart to select it. Selection handles appear around the chart.

2) Move the cursor anywhere on the chart other than on a selection handle.

3) When it changes shape, click and drag the chart to its new location.

4) Release the mouse button when the chart is in the desired position.

**Position and Size dialog**

To resize or move a chart using the Position and Size dialog:

1) Click on the chart to select it.

2) Go to **Format > Position and Size** on the Menu bar, or right-click on the chart and select **Position and Size** from the context menu. For more information on using the Position and Size dialog, see Chapter 13, Images and Graphics.

**Chart elements**

You can move or resize individual elements of a chart element independently of other chart elements. For example, you can move the chart legend to a different position. Pie charts allow individual wedges of the pie to be moved as well as “exploding” the entire pie.
1) Double-click the chart so that it is in edit mode.
2) Click any chart element to select it. Selection handles appear.
3) Move the cursor over the selected element and when the cursor changes shape, click and drag to move the element.
4) Release the mouse button when the element is in the desired position.

**Note**

If the chart is 3D, round selection handles appear; these control the three-dimensional angle of the chart. You cannot resize or reposition the chart while the round selection handles are showing. **Shift+click** to get back to the square resizing handles. You can now resize and reposition the 3D chart.

**Changing chart area background**

The chart area is the area surrounding the chart graphic and includes the (optional) main title and key.

1) Double-click the chart so that it is in edit mode.
2) Go to **Format > Chart Area** on the Menu bar, or right-click in the chart area and select **Format Chart Area**, or double-click in the chart area to open the **Chart Area** dialog.
3) Click on the **Area** tab and select the button corresponding to the type of background fill you want to use. The available options will change depending on the type of fill selected.
4) Make your selections and click **OK** to close the dialog and save the changes.

**Changing chart wall background**

The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is in edit mode.
2) Go to **Format > Format Selection** on the Menu bar, or right-click in the chart wall and select **Format Wall**, or double-click in the chart wall to open the **Chart Wall** dialog.
3) Click on the **Area** tab and proceed as above.
4) Click **OK** to close the dialog and save the changes.

**Audio and video**

Although linked audio and video files are irrelevant when a Writer document is printed, if the document is opened on a computer or exported to PDF or HTML, you can play the files by clicking on the links.

**Using media files**

To insert a media file into your document:

1) Choose **Insert > Media > Audio or Video** on the Menu bar to open the Insert Audio or Video dialog.
2) Select the media file to insert and click **Open** to place the object in the document.

**Tip**

To see a list of audio and video file types supported by Writer, open the drop-down list of file types. This list defaults to **All audio and video files**, so you can also choose unsupported files such as .mov.
Writer only links media files and does not embed a media file into a document. Therefore if a document is moved to a different computer, any links will be broken and the media files will not play. To prevent this from happening:

1) Place any media files which are included in a document in the same folder where the document is stored.
2) Insert the media file in the document.
3) Send both the document and any media files to the computer which is to be used for the document and place both files in the same folder on that computer.

Using the Gallery

To insert media clips directly from the Gallery:

1) Go to the Gallery in the Sidebar.
2) Browse to a theme containing media files (for example, Sounds).
3) Click on the movie or sound to be inserted and drag it into the document area.

Media playback

The Media Playback toolbar is automatically opened when a media file is selected. The default position of the toolbar is at the bottom of the workspace, just above the Drawing toolbar. However, this toolbar can be undocked and placed anywhere. If the toolbar does not open, go to View > Toolbars > Media Playback on the Menu bar.

The Media Playback toolbar contains the following tools:

- Insert Audio or Video – opens the Insert Audio or Video dialog.
- Play, Pause, Stop – controls media playback.
- Repeat – if selected, media will continuously repeat playing until this tool is de-selected.
- Playback slider – selects the position to start playing from within the media file.
- Timer – displays current position of the media clip and length of media file.
- Mute – when selected, the sound will be suppressed.
- Volume slider – adjusts the volume of the media file.
- Media path – the location of the file on the computer.
- Scaling drop-down menu – only available for movies and allows scaling of the movie clip.

Formulas

Go to Insert > Object > Formula on the Menu bar to create a formula (equation). A formula can also be inserted as an OLE object; see page 4 for more information.

When creating or editing a formula, the Math menu becomes available.

When creating formulas, take care about font sizes used to make sure they are similar in size to fonts used in the document. To change font attributes of a Math object, go to Format > Font Size on the Menu bar. To change font type, use Format > Fonts.

For information on how to create formulas, see the Math Guide or Chapter 9, Getting Started with Math, in the Getting Started Guide.