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Quick printing
If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire
document using the current default print settings. If the icon is not visible, you can make it visible
it by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

Note
The Print Directly and other printing options are not available when viewing a Base
table or query.
You can specify the default printer on the Printer Setup dialog; go to File > Printer Settings on
the Menu bar. When further printing options are available, click the Options button on the Printer
Setup dialog to access them. The same options are available through Tools > Options >
[LibreOffice Component] > Print, and more general print options through Tools > Options >
LibreOffice > Print. See Chapter 2, Setting Up LibreOffice, for more information.

Controlling printing
For more control over printing, use the Print dialog (File > Print, Ctrl+P (⌘+P for macOS), or the
Print icon on the Standard toolbar).

Note
The appearance of the Print dialog is different on macOS and may include extra
printer controls not described in this chapter.
The Print dialog (Figure 1) has two tabs, from which you can choose a range of options as
described in the following sections. The first tab is General; it is similar in all LibreOffice
components although some of the options available in Writer are unavailable in other
components. The second tab is component-specific.
The different components of LibreOffice have different print settings available, as summarized in
Table 1.
Table 1: Print options in LibreOffice components
Feature

Writer

Calc

Impress

Draw

Math

Select pages/sheets/slides to print

Yes

Yes

Yes

Yes

Yes

Print multiple pages/sheets/slides on one page

Yes

Yes

Yes

Yes

No

Print a brochure

Yes

No

Yes

Yes

No

Print envelopes

Yes

No

No

No

No

Print labels or business cards

Yes

No

No

No

No

Preview pages/sheets before printing

Yes

Yes

No

No

No

Base forms and reports are printed using the Writer version of the Print dialog and hence provide
the facilities in the Writer column of Table 1.
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Figure 1: The Print dialog in Writer

Selecting general printing options
On the General tab of the Print dialog, you can choose:
•

The printer, from the list of available printers

•

Which pages to print, the number of copies to print, and whether to collate multiple
copies (Range and Copies section; see “Selecting pages/sheets/slides to print” on page
7)

•

Paper size and print orientation (Page Layout section)

•

How many pages to print on one sheet of paper and whether to draw a border around
each page (Page Layout section)

•

Whether to print a brochure (see “Printing a brochure” on page 12)

•

Whether to print in reverse page order (useful on some printers to make the pages come
out in page order)
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Selecting printer and print job options
In the Printer section of the General tab, click the Properties button to display the selected
printer’s properties dialog where you can choose portrait or landscape orientation, which paper
tray to use, and the paper size to print on.
Click the More Options button at the bottom of the Print dialog to choose whether to create
separate print jobs for collated output, instead of one print job containing all the collated pages
(not relevant if only one copy of a document is printed).

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this, in the Page Layout
section of the General tab, click more and select from the Pages per sheet drop-down list the
number of pages to print per sheet of paper. The preview panel on the left of the Print dialog
shows how the printed document will look. This facility is not available in Math.
When printing more than two pages per sheet, you can choose the order in which they are
printed across and down the paper (Figure 2).

Tip
In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from
Print Preview instead. See page 14.

Figure 2: Print order choices

Selecting pages/sheets/slides to print
In addition to printing a full document, in the Range and Copies section of the General tab, you
can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection
of a document. The details vary slightly between Writer, Calc, Draw, Impress, and Math, as
described below.

Writer and Math
Printing an individual page:
1) In the Print dialog, in the Range and Copies section, select the Pages option. The text
box shows the current page number.
2) Enter the page number of the page you want to print. The preview box on the left
changes to show the selected page.
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Printing a range of pages:
1) In the Print dialog, in the Range and Copies section, select the Pages option.
2) Enter the page numbers of the pages to print (for example, 1–4 or 1,3,7,11).
Printing a selection of text or graphics (Writer only):
1) In the document, select the material to print, then open the Print dialog.
2) In the Range and Copies section of the Print dialog, the Selection option is now active
and selected and the preview box shows the selected material (Figure 3).

Figure 3: Printing a selection of text

Calc
You can choose individual sheets, ranges of sheets, or selections of sheets for printing.

Figure 4: Choosing what to print in Calc
Printing an individual sheet:
1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.
2) Open the Print dialog and choose the General tab.
3) In the Range and Copies section, click more and choose Print Selected Sheets in the
From which drop-down.
Printing a range of sheets:
1) In the spreadsheet, select the sheets to print.
a) Select the first sheet.
b) Hold down the Control key and click on the additional sheet tabs.
c) Release the Control key when all required sheets are selected.
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2) Open the Print dialog and choose the General tab.
3) In the Range and Copies section, click more and choose Print Selected Sheets in the
From which drop-down.

Caution
After printing, be sure to deselect the extra sheets. If you keep them selected, the
next time you enter data on one sheet, you enter data on all the selected sheets.
This might not be what you want.
Printing a selection of cells:
1) In the document, select the cells to print.
2) Open the Print dialog and choose the General tab.
3) In the Ranges and Copies section, choose Print Selected Cells in the From which dropdown.

Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.
To print an individual slide or a range of slides, do one of the following:
•

In the Print dialog, select the Slides option in the Range and Copies section (Figure 5)
and then enter the numbers of the slides to print (for example, 1-4 or 1,3,7,11).

•

Select the slides first and then open the Print dialog, which will show the slide numbers in
the box. See Chapter 6, Getting Started with Impress, for information on selecting slides.

Figure 5: Choosing what to print in Impress and Draw
To print a selection from a slide, or a selection from multiple slides:
1) In the document, select the section of the slide to print.
2) Open the Print dialog.
3) Choose the Selection option in the Range and Copies section.
You can also choose to print only even-numbered slides or only odd-numbered slides.

Choices on the component tabs
Choices on the LibreOffice [Component] tab vary with the component.

Writer
On the LibreOffice Writer tab (Figure 6) you can choose to print a subset of contents (for
example, images or hidden text), print text in black (even if a color is defined for the text),
whether to print automatically inserted blank pages, and whether and where to print any
comments that are in the document (Figure 7).
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Figure 6: LibreOffice Writer tab of Print dialog
Some selections may not be available all the time. For example, if the document contains no
comments, the Comments drop-down list is disabled.

Figure 7: Choosing whether and where to print comments

Calc
The only choice on the LibreOffice Calc tab is whether to suppress the printing of blank sheets.

Impress
On the LibreOffice Impress tab (Figure 8), you can choose to print slides, handouts, notes, or an
outline. See Chapter 6, Getting Started with Impress, for more information on these features.
•

Handouts prints the slides in reduced size on the page, from one to nine slides per page.
The slides can be printed horizontally (landscape orientation) or vertically (portrait
orientation) on the page.

•

Notes prints a single slide per page with any notes entered for that slide in Notes View.

•

Outline prints the title and headings of each slide in outline format.
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Figure 8: LibreOffice Impress tab of Print dialog
To print slides, handouts, notes, or outlines:
1) In the Document section, select the required option under Type.
2) For Handouts, you can then choose how many slides to print per page, and the order in
which they are printed (Figure 9).

Figure 9: Handouts
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Draw
On the LibreOffice Draw tab (Figure 10), you can choose print options as shown.

Figure 10: LibreOffice Draw tab of Print dialog

Math
On the LibreOffice Math tab (Figure 11), you can choose print options as shown.

Figure 11 - LibreOffice Math tab of Print dialog

Printing a brochure
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.

Tip
Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.
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To print a brochure:
1) In the Page Layout section of the General tab, click more and select the Brochure
option. The preview on the left changes to show the sequence in which the pages will be
printed (Figure 12).

Figure 12: Settings for printing a brochure on a simplex printer
2) Depending on your language settings (Tools > Options > Language Settings >
Languages), the Writer variant of the Print dialog may include a drop-down menu
adjacent to the Brochure button (not shown in Figure 12). This provides Left-to-right
script and Right-to-left script options. Select the required setting in this menu.
3) If your printer can print double-sided (duplex) pages automatically, choose All pages in
the Range and Copies section, then click OK to print.
4) If your printer can print only single-sided pages automatically, follow these steps:
a) Select Even pages in the Range and Copies section, then click OK to print.
b) Take the printed pages out of the printer and put them back in the correct orientation
to print on the blank side. You may need to experiment to find the correct
arrangement for your printer.
c) On the Print dialog, in the Range and Copies section, select Odd pages. Click OK.
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Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.
For details, see Chapter 14, Using Mail Merge, in the Writer Guide.

Previewing pages/sheets before printing
You can use the previewing options in Writer and Calc to view the document as it will be printed.
Several viewing options are available.

Writer
The normal page view in Writer shows you what each page will look like when printed and you
can edit the pages in that view. If you are designing a document to be printed double-sided, you
may want to see what facing pages look like. Writer provides two ways to do this:
•

View Layout (editable view): use the Book view button on the status bar.

•

Print Preview (read-only view).

To use Print Preview:
1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button
on the Standard toolbar, or press Ctrl+Shift+O (Shift+⌘+O for macOS).
Writer now displays the Print Preview toolbar instead of the Formatting toolbar.
Figure 13: Print Preview toolbar (Writer)
2) Select the required preview icon: Single Page, Two Pages, Multiple Pages, or Book
Preview.
3) To print the document from this view, click the Print icon to open the Print dialog. Choose
the print options and click OK or Print (macOS).

Calc
To preview the sheets in Calc before printing:
1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button
on the Standard toolbar, or press Ctrl+Shift+O (Shift+⌘+O for macOS).
The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 14: Print Preview toolbar (Calc)
2) To print the document from this view, click the Print icon to open the Print dialog.
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Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are
available.

Note
Some color printers may print in color regardless of the settings you choose.
For one document, change the printer settings to print in black and white or grayscale:
1) On the Print dialog, click Properties to open the Properties dialog for the printer. The
available choices vary from one printer to another, but you should find options for the
color settings. See your printer’s help or user manual for more information.
2) The choices for color might include black and white or grayscale. Choose grayscale.
3) Click OK to confirm your choice and return to the Print dialog.
4) Click Print to print the document.
To print all color text and images as grayscale, change the LibreOffice settings:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
To print all color text as black, and all images as grayscale, change the LibreOffice Writer settings
1) Choose Tools > Options > LibreOffice Writer > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.

Exporting to PDF
LibreOffice can export documents to PDF (Portable Document Format). This standard file format
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Warning
A document in PDF format is not protected against contents tampering or editing by
default. The PDF document contents can be edited by specialized software tools,
including LibreOffice Draw.
The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor
differences mentioned in this section.

Tip
Unlike Save As, the Export command writes a copy of the current document in a new
file with the chosen format, but keeps the current document and format open in your
session.

Quick export to PDF
Click the Export Directly as PDF icon on the Standard toolbar to export the entire document
using the PDF settings you most recently selected on the PDF Options dialog (see below). In
Writer, Impress, and Draw, you can also use File > Export As > Export Directly as PDF. You
are asked to enter the file name and location for the PDF file, but you do not get a chance to
choose a page range, the image compression, or other options.
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Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export As >
Export as PDF (Writer, Impress, and Draw) or File > Export as PDF (Calc and Math) on the
Menu bar. The PDF Options dialog opens. This dialog has six tabs (General, Initial View, User
Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then click
Export. Then you are asked to enter the location and file name of the PDF to be created, and
click Save (Windows and Linux) or Export (macOS) to export the file.

Note
You can also export to PDF from File > Export (not Math). On the Export dialog,
select the PDF file format, the file name and location, and click Save or Export
(macOS). The PDF Options dialog then opens. Select the appropriate settings and
then click Export. The only difference between the two export methods is the
sequence in which steps occur.

General tab of PDF Options dialog
On the General tab, you can choose which pages to include in the PDF, the type of compression
to use for images (which affects the quality of images in the PDF), and other options. Figure 15
shows the Writer variant of the General tab – the corresponding tabs for other LibreOffice
components have minor differences from this figure.

Figure 15: General tab of PDF Options dialog (Writer)
Range section
• All: Exports the entire document to PDF.
•

Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;10;12.

•

Selection: Exports all the selected material.
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•

View PDF after export: Your default PDF viewer will open and display the newly
exported PDF.

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.
•

JPEG compression: Allows for varying degrees of quality. A setting of 90% works well
with photographs (small file size, little perceptible loss of quality).

•

Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Lower
resolutions (100 DPI or less) may be sufficient for viewing on a computer screen, but
many modern devices have higher resolutions; and for printing it is generally preferable
to use at least 300 or 600 DPI, depending on the capability of the printer. Higher DPI
settings increase the size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only
as previews. EPS images without embedded previews are exported as empty
placeholders.
Watermark section
• Sign with watermark: When this option is selected, a transparent overlay of the text you
type in the Sign with watermark text box will appear on each page of the PDF.
General section
• Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.
•

Archive (PDF/A, ISO 19005): PDF/A is an ISO standard for long-term preservation of
documents, by embedding all the information necessary for faithful reproduction (such as
fonts) while forbidding other elements (including forms, security, and encryption). PDF
tags are written. PDF/A-1b refers to the minimum compliance level with PDF/A-1.
PDF/A-2b is recommended for most users, because it allows for layers and transparency
with shapes and images. It also compresses better, usually producing smaller files.
PDF/A-3b is identical to PDF/A-2b, but also accepts embedding of other file formats.

•

Universal Accessibility (PDF/UA): Creates a universal accessibility-complaint PDF file
that follows the requirements of PDF/UA (ISO 14289) specifications. See the Help for
more information.

•

Tagged PDF: Tagged PDF contains information about the structure of the document’s
contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

•

Create PDF form – Submit format: Choose the format of submitting forms from within
the PDF file. This setting overrides the control’s URL property that you set in the
document. There is only one common setting valid for the whole PDF document: PDF
(sends the whole document), FDF (sends the control contents), HTML, and XML. Most
often you will choose the PDF format.
Allow duplicate field names: If enabled, the same field name can be used for multiple
fields in the generated PDF file. You can enter data in the first occurrence of the named
field in the PDF document and all fields with the same name will carry your entry. If
disabled, field names will be exported using generated unique names.
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Structure section
• Export outlines: Exports headings in Writer documents, and page or slide names in
Impress and Draw documents, as an outline (table of contents list) displayed by most
PDF viewers, including Adobe Reader. In LibreOffice 7.0 and earlier, these were called
bookmarks.
•

Export placeholders: The PDF will include any defined placeholder fields, which can be
filled in by users. This option is only available in Writer.

•

Comments as PDF annotations: If selected, comments are included in the PDF as
annotations.

•

Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (righthand) page. When the previous chapter ends on an odd page, LibreOffice inserts a blank
page between the two odd pages. This option controls whether to export that blank page.

•

Use reference XObjects: Reference XObjects enable one PDF file to import content
from another. More information can be found in section 8.10.4 of the PDF specification,
ISO 32000-2:2017 (https://www.iso.org/standard/63534.html). If you are not familiar with
referenceXObjects, leave this box unchecked.

Initial View tab of PDF Options dialog
On the Initial View tab (Figure 16), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.
If you have Complex Text Layout enabled (in Tools > Options > Language Settings >
Languages), an additional selection is available under the Continuous facing option: First
page is left (normally, the first page is on the right when using the Continuous facing option).

Figure 16: Initial View tab of PDF Options dialog

User Interface tab of PDF Options dialog
On the User Interface tab (Figure 17), you can choose more settings to control how a PDF viewer
displays the file. Some of these choices are particularly useful when you are creating a PDF to be
used as a presentation or a kiosk-type display.
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Figure 17: User Interface tab of PDF Options dialog
Window Options section
• Resize window to initial page: The PDF viewer window will resize to fit the first page of
the PDF.
•

Center window on screen: The PDF viewer window will be centered on the computer
screen.

•

Open in full screen mode: The PDF viewer will open full-screen instead of in a smaller
window.

•

Display document title: The PDF viewer will display the document’s title in the title bar.

User Interface Options section
• Hide menubar: The PDF viewer will hide the menu bar.
•

Hide toolbar: The PDF viewer will hide the toolbar.

•

Hide window controls: The PDF viewer will hide other window controls.

Transitions
In Impress, displays slide transition effects as their respective PDF effects.
Collapse Outlines
Select how many heading levels are displayed in the outline, if Export outlines is selected
on the General tab.

Links tab of PDF Options dialog
On the Links tab (Figure 18), you can choose how links are exported to PDF.

Figure 18: Links tab of PDF Options dialog
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Export outlines as named destinations
Paragraphs defined in Writer’s outline levels, Impress or Draw slide names, and Calc sheet
names are exported as “named destinations” to which Web pages and PDFs can link.
Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt,
.ods, and .odp), the file extensions are converted to .pdf in the exported PDF document.
Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.
Cross-document Links
Defines the behavior of links clicked in PDF files. Select one among the following
alternatives:
– Default mode: The PDF links will be handled as specified in your operating system.
– Open with PDF reader application: Use the same application used to display the
PDF document to open linked PDF documents.
– Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

Security tab of PDF Options dialog

Figure 19: Security tab of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.
•

With an open password set, the PDF can only be opened with the password. Once
opened, there are no restrictions on what the user can do with the document (for
example, print, copy, or change it).

•

With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. After you set a password for permissions, the other choices on the
Security page (Figure 19) become available.

•

With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.
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Note
Permissions settings are effective only if the user’s PDF viewer respects the settings.

Digital Signatures tab of PDF Options dialog
The Digital Signatures tab (Figure 20) contains the options related to exporting a digitally signed
PDF.

Figure 20: Digital Signatures tab of PDF Options dialog
Digital signatures are used to ensure that the PDF was really created by the original author (that
is, you), and that the document has not been modified since it was signed.
The signed PDF export uses the keys and X.509 certificates already stored in your default key
store location or on a smartcard. The key store to be used can be selected under Tools >
Options > LibreOffice > Security > Certificate (macOS and Linux only). When using a
smartcard, it must already be configured for use by your key store. This is usually done during
installation of the smartcard software. Details about using these features is outside the scope of
this chapter.
•

Use this certificate to digitally sign PDF documents: Click Select to open the Select
Certificate dialog, where all certificates found in your selected key store are displayed. If
the key store is protected by a password, you are prompted for it. When using a
smartcard that is protected by a PIN, you are also prompted for that.
Select the certificate to use for digitally signing the exported PDF, then click Sign.
All other fields on the Digital Signatures tab are accessible only after a certificate has
been selected.

•

Certificate password: Enter the password used for protecting the private key associated
with the selected certificate. Usually this is the key store password. If the key store
password has already been entered in the Select Certificate dialog, the key store may
already be unlocked and not require the password again.
When using a smartcard, enter the PIN here. Some smartcard software will prompt you
for the PIN again before signing.

•

Location, Contact information, Reason: Optionally enter additional information about
the digital signature that will be applied to the PDF. This information will be embedded in
the appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of
the three fields may be left blank.
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•

Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that
is then embedded in the signature. Anyone viewing the PDF can use this timestamp to
verify when the document was signed.
The list of TSA URLs that can be selected is maintained under Tools > Options >
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature
will not be timestamped, but will use the current time from your local computer.

Exporting to EPUB format (Writer only)
EPUB format has become popular since mobile devices such as smartphones, tablets, and
e-readers appeared on the market. The EPUB format is implemented as an archive file
consisting of HTML files carrying the content, along with images and other supporting files.
Writer can export a file to EPUB. A text-only document generally exports well, but some contents
(such as illustrations, tables, and cross-references) may not export correctly.

Tip
Other ways to export to ePub from Writer (.odt) files include Calibre, an open-source
e-book manager that runs on Windows, macOS, and Linux. Calibre provides many
e-book conversion facilities (including PDF to EPUB) and allows editing of the result.
https://calibre-ebook.com/

Quick export to EPUB
Choose File > Export As > Export Directly as EPUB to export the entire document using the
EPUB settings you most recently selected on the EPUB Export dialog (see below). You are
asked to enter the file name and location for the EPUB file, but you do not get a chance to select
other options.

Controlling export to EPUB
For more control over the content and quality of the resulting EPUB file, use File > Export As >
Export as EPUB. The EPUB Export dialog opens (Figure 21).
The EPUB Export dialog has the following fields:
Version
Choose the EPUB version for the exported file. Values are EPUB 2.0 and EPUB 3.0. Most
new e-readers can read EPUB 3.0.
Split method
Select the method to start a new section. Choose Heading to start the section on a
heading, according to the document’s chapter numbering. Choose Page break to start the
section on a page break.
Layout method
Choose Reflowable to have the ebook display change to fit the screen size and the user’s
preference (so page size and header/footer content is not exported). Choose Fixed to have
the ebook layout remain the same under all conditions.
Customize - Cover image
The path to the image file for the cover page. If no image is specified, the EPUB file will
automatically use any image with a name like cover.gif, cover.jpg, cover.png, or cover.svg.
A custom cover image is embedded in the EPUB file.
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Figure 21: EPUB Export dialog
Customize - Media directory
The path to the optional directory for the cover image, metadata, and multimedia files. If
you do not specify a directory, the exporter looks for custom media and custom metadata in
the current document directory inside a folder with the same name as the document file
name.
Metadata
The basic information for the file that provides tags to help searches. These fields provide
another chance to edit metadata that is picked up by default from File > Properties in
Writer.

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export (not available in
Math) as well.
LibreOffice can export files to XHTML. In addition, Draw and Impress can export to a range of
image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file
name for the exported document, then select the required format in the Save as type or File
format (macOS) list and click the Save or Export (macOS) button.
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Emailing documents
LibreOffice provides several ways to send documents quickly and easily as email attachments in
one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or
PDF.
To send the current document in OpenDocument format:
1) Choose File > Send > Email Document. LibreOffice opens your default email program.
The document is attached to a new email.
2) In your email program, enter the recipient, subject, and any text you want to add, then
send the email.
File > Send > Email as OpenDocument [Text, Spreadsheet] has the same effect in Writer or
Calc.
If you choose Email as Microsoft [Word, Excel] in Writer or Calc, LibreOffice first creates a file
in one of those formats and then opens your email program with the file attached to a new email.
Similarly, if you choose Email as PDF, LibreOffice first creates a PDF using your default PDF
settings (as when using the Export Directly as PDF function) and then opens your email
program with the PDF file attached to a new email.

Emailing a document to several recipients
To email a document to several recipients, you can use the features in your email program or you
can use LibreOffice Writer’s mail merge facilities to create the document and send it. See
Chapter 14, Mail Merge, in the Writer Guide for details.

Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from
a certification authority, which may be a private company or a governmental institution.
When you apply a digital signature to a document, a checksum is computed from the document’s
content plus your personal key. The checksum and your public key are stored with the document.
When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.
Whenever someone changes something in the document, this change breaks the digital
signature.
For a more detailed description of how to get and manage a certificate, and signature validation,
see “Applying Digital Signatures” in the LibreOffice Help.
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Applying a digital signature
The following procedure is an example of how to digitally sign a document. The actual procedure
depends on how your computer is set up and its operating system.
1) Choose File > Digital Signatures > Digital Signatures.
– If you have set LibreOffice to warn you when the document contains comments or
recorded changes (see “Removing personal data” on page 27), you may see a
message box asking whether you want to want to continue signing the document.
Click Yes to continue.
– If you have not saved the document since the last change, a message box appears.
Click Yes twice: once to continue and again to save the file.
2) The Digital Signatures dialog (Figure 23) opens. It lists existing signatures together with
their description (if they have any). Click the Sign Document button to add a new
signature to the document.
3) In the Select Certificate dialog (Figure 24), select your certificate, add an optional
description, and click Sign to return to the Digital Signatures dialog.
The certificate used is displayed in the dialog with an icon next to its name. This icon
indicates the status of the digital signature.
4) Click Close in the Digital Signatures dialog to apply the digital signature.
A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.
Changing an existing description invalidates the signature. However, multiple signatures from the
same author are allowed, because each signature can have a different description.

Figure 22: Signatures of the document
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Figure 23: Signatures can have a description

Including a signature line (Writer and Calc)
You can generate a graphic box representing a signature line using Insert > Signature Line
(Figure 24), and you can optionally sign the signature line using a digital certificate.

Figure 24: Creating a signature line for a document
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Figure 25: Signature line example

Removing personal data
You may wish to ensure that personal data, versions, notes, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.
In Tools > Options > LibreOffice > Security, click the Options button to display a dialog where
you can set LibreOffice to warn you when files contain certain information and/or automatically
remove personal information on saving.
To remove personal and some other data from a file, go to File > Properties. On the General
tab, uncheck Apply user data and click the Reset Properties button. This removes any names
in the created and modified fields, deletes the modification and printing dates, and resets the
editing time to zero, the creation date to the current date and time, and the version number to 1.
To remove version information, either go to File > Versions, select the versions from the list and
click Delete; or use File > Save As and save the file with a different name.

Redaction
You can redact documents to remove or hide sensitive information, to allow the selective
disclosure of information in a document while keeping other parts of the document secret. For
example, when a document is subpoenaed in a court case, information not specifically relevant to
the case at hand is often redacted.
To redact a document:
1) Open the document in LibreOffice.
2) Click Tools > Redact on the Menu bar, and wait for the document to be prepared for
redaction and transferred to Draw. The Redaction toolbar (Figure 26) opens.

Figure 26: Redaction toolbar
3) Do the redaction by using the Rectangle Redaction and Freeform Redaction tools on
the Redaction toolbar. The shapes will be transparent and in gray so you can see what
you are redacting.
4) Optionally use the Export Directly as PDF tool to make an in-redaction copy of the
document in PDF to use as a verbatim copy for review. The redacted items will be in
transparent grey.
5) To finalize the redaction, select the desired option (black or white) on the Redacted
Export tool. The transparent grey shapes are converted to opaque black or white shapes
and the document is exported as a pixellized PDF. There will be no selectable text in it,
and the redacted content will be non-existent.
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Auto-redaction
To partially automate the redaction process, you can define certain words (such as names) to be
redacted wherever they are found in the document. To do this, choose Tools > Auto-Redact on
the Menu bar to open the Automatic Redaction dialog (Figure 27). Here you can load a list of
terms (targets), add targets, delete targets, edit targets, and save a list of targets.
This feature is not available in Draw.

Figure 27: Automatic Redaction dialog
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