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Images (graphics) in Writer

You can add graphic and image files, including photos, drawings, and scanned images, to Writer 
documents. Writer can import various vector (line drawing) and raster (bitmap) file formats.

Images in Writer are of these basic types:

• Image files, such as photos, drawings, and scanned images

• Diagrams created using LibreOffice’s drawing tools

• Artwork created using clip art or Fontwork

• Charts created using LibreOffice’s Chart facility

This chapter covers images, diagrams, and artwork. Instructions on how to create charts are given 
in Chapter 19, Spreadsheets, Charts, other Objects. For more detailed descriptions on working 
with drawing tools, see the Draw Guide.

Creating and editing images

You might create images (also called ‘pictures’ in LibreOffice) using a graphics program, scan 
them, or download them from the Internet (make sure you have permission to use them), or use 
photos taken with a digital camera. Writer can import various vector (line drawing) images, and can
rotate and flip such images. Writer also supports raster (bitmap) file formats, the most common of 
which are GIF, JPG, PNG, and BMP. See the Help for a full list.

Writer can also import SmartArt images from Microsoft Office files. For example, Writer can open a 
Microsoft Word file that contains SmartArt, and you can use Writer to edit the images.

Some things to consider when choosing or creating images include image quality and whether the 
image will be printed in color or black-and-white (grayscale).

To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector 
drawing program. You do not need to buy expensive programs. For many graphics, LibreOffice 
Draw is sufficient. Open-source (and usually no-cost) tools such as GIMP (bitmap editor) and 
Inkscape (vector drawing program) are excellent. These and many other programs work on 
Windows, macOS, and Linux.

For best results:

• Create images that have the exact dimensions required for the document, or use an 
appropriate graphics package to scale photographs and large drawings to the required 
dimensions. Do not scale images with Writer, even though Writer has tools for doing this, 
because the results might not be as clear as you would like.

• Do any other required image manipulation (brightness and contrast, color balance, 
cropping, conversion to grayscale, and so on) in a graphics package, not in Writer, even 
though Writer has the tools to do a lot of these things, too.

• If the document is meant for screen use only, there is no need to use high resolution 
images of 300 or more dpi (dots per inch). Most computer monitors work at between 72 and
96 dpi; reducing the resolution (and the file size) has no negative impact on what is 
displayed.

Preparing images for black-and-white printing
If color images are to be printed in grayscale, check that any adjacent colors have good contrast 
and print dark enough. Test by printing on a black-and-white printer using a grayscale setting. 
Better still: change the “mode” of the image to grayscale, either in a photo editor or in Writer itself 
(see “Image mode” on page 10).
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For example, the following diagram looks good in color. The circle is dark red and the square is 
dark blue. In grayscale, the difference between the two is not so clear. A third element in the 
diagram is a yellow arrow, which is almost invisible in grayscale.

Original drawing in color Drawing printed in grayscale

Changing the colors of the circle and the arrow improves the contrast and visibility of the resulting 
grayscale image.

Original drawing in color Drawing printed in grayscale

If the document will be available in black-and-white print only, a better result can often be obtained 
by choosing grayscale fills, not color fills.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file stored on your 
computer, directly from a graphics program or a scanner, by dragging them from the clip art internal
gallery, or by copying and pasting from a source being viewed on your computer.

Inserting an image file
When the image is in a file stored on the computer, you can insert it into a LibreOffice document 
using any of the following methods.

Drag and drop
 1) Open a file browser window and locate the image you want to insert.

 2) Drag the image into the Writer document and drop it where you want it to appear. A faint 
vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the Writer document. To link the file 
instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

Insert Image dialog
 1) Click in the Writer document where you want the image to appear.

 2) Choose Insert > Image from the Menu bar or click the Insert Image icon in the Standard 
toolbar.

 3) On the Insert Image dialog, navigate to the file to be inserted, and select it.

 4) At the bottom of the dialog (Figure 1) is a Link option; see page 7. Select Preview to show 
a thumbnail of the selected image on the right, as in the example.

 5) Click Open.
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Figure 1: Insert Image dialog

Note

If you choose the Link option, a message box appears when you click Open. It asks if 
you want to embed the image instead. Choose Keep Link if you want the link, or 
Embed Graphic if you do not. To prevent this message from appearing again, 
deselect the option Ask when linking a graphic at the bottom of the message.

Copy and paste
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice 
document and from other programs. To do this:

 1) Open both the source document and the target document.

 2) In the source document, select the image to be copied.

 3) Press Ctrl+C (or right-click and select Copy from the context menu) to copy the image to 
the clipboard.

 4) Switch to the target document.

 5) Click to place the cursor where the image is to be inserted.

 6) Press Ctrl+V (or right-click and select Paste from the context menu) to insert the image.

Caution

If the application from which the image was copied is closed before the image is 
pasted into the target, the image stored on the clipboard could be lost.

Linking an image file
If the Link option in the Insert Image dialog is selected, Writer creates a link to the file containing 
the image instead of saving a copy of the image in the document. The result is that the image is 
displayed in the document, but when the document is saved, it contains only a reference to the 
image file, not the image itself. The document and the image remain as two separate files, and 
they are merged together only when you open the document again.
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Linking an image has two advantages and one disadvantage:

• Advantage – You can modify the image file separately without changing the document 
because the link to the file remains valid, and the modified image will appear when you next
open the document. This can be a big advantage if you (or someone else, perhaps a 
graphic artist) are updating images.

• Advantage – Linking can reduce the size of the document when it is saved, because the 
image file itself is not included. File size is usually not a problem on a modern computer 
with a reasonable amount of memory, unless the document includes many large image 
files; LibreOffice can handle quite large files.

• Disadvantage – If you send the document to someone else, or move it to a different 
computer, you must also include the image files, or the recipient will not be able to see the 
linked images. You need to keep track of the location of the images and make sure the 
recipient knows where to put them on another machine, so the document can find them. 
For example, you might keep images in a subfolder named Images (under the folder 
containing the document); the recipient of the file needs to put the images in a subfolder 
with the same name and in the same place relative to the document.

Note

When inserting the same image several times in a document, LibreOffice embeds only 
one copy of the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To 
do so:

 1) Open the document in LibreOffice and choose Edit > Links to External Files.

 2) The Edit Links dialog (Figure 2) shows all the linked files. In the Source file list, select the 
files you want to change from linked to embedded.

 3) Click the Break Link button.

Note

Going the other way, from embedded to linked, is not so easy—you must delete and 
reinsert each image, one at a time, selecting the Link option when you do so.

Figure 2: The Edit Links dialog
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Inserting an image using a scanner
If a scanner is connected to your computer, Writer can call the scanning application and insert the 
scanned item into your document as an image. To start this procedure, click where you want the 
image to be inserted and choose Insert > Media > Scan > Select Source from the Menu bar.

Select the scan source from the list of available devices, then choose Insert > Media > Scan > 
Request to open the imaging software where you can adjust settings for image quality, size, and 
other attributes. This practice is quick and easy, but may not result in a high-quality image of the 
correct size. You may get better results by scanning material into a graphics program and cleaning 
it up there before inserting the resulting image into Writer.

Inserting an image from the Gallery
The Gallery (Figure 3) provides a convenient way to group reusable objects such as images and 
sounds that you can insert into your documents. The Gallery is available in LibreOffice Writer, Calc,
Impress, and Draw. You can copy or link an object from the Gallery into a document.

Figure 3: The Gallery in the Sidebar

To insert an object:

 1) Click the Gallery icon in the Sidebar.

 2) Select a theme from the list provided.

 3) Select an object with a single click.

 4) Drag and drop the image into the document, or right-click the object and choose Insert.

To insert an object as a link, hold down the Ctrl+Shift keys and drag and drop the object into the 
document.

Modifying, handling, and positioning images

When you insert a new image, you may need to modify it to suit the document. The placement of 
the image relative to the text is discussed in “Positioning images within the text” on page 18. This 
section describes the use of the Image toolbar, resizing, cropping, and rotating an image.
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Writer provides many tools for working with images. These tools are sufficient for most people’s 
everyday requirements. However, for professional results it is generally better to use an image 
manipulation program such as GIMP to modify images (for example, to crop, resize, rotate, and 
change color values) and then insert the result into Writer.

Using the Image toolbar
When you insert an image or select one already present in the document, the Image toolbar 
appears. You can set it to always be present (View > Toolbars > Image) and choose whether to 
float or dock it. Two other toolbars can be opened from this one: the Image Filter toolbar, which can
be torn off and placed elsewhere on the window, and the Color toolbar, which opens as a separate 
floating toolbar.

From these three toolbars, you can apply small corrections to the image or obtain special effects: 
transparency, color adjustment, flipping and rotating, and applying special-effects filters.

1 Filter 10 Color 19 Charcoal Sketch
2 Image Mode 11 Invert 20 Relief
3 Crop Image 12 Smooth 21 Mosaic
4 Flip Vertically 13 Sharpen 22 Color
5 Flip Horizontally 14 Remove Noise 23 Green
6 Rotate 90° Left 15 Solarization 24 Blue
7 Rotate 90° Right 16 Aging 25 Brightness
8 Rotate 17 Posterize 26 Contrast
9 Transparency 18 Pop Art 27 Gamma

Figure 4: Image toolbar plus Color toolbar and Image Filter toolbar

Image mode
You can change color images to grayscale, to black-and-white, or to a watermark by selecting the 
image and then selecting the relevant item from the Image Mode list.

Transparency
Increase the percentage value in the Transparency box on the image toolbar to make the image 
more transparent. This is particularly useful when creating a watermark or when placing the image 
in the background.
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Color
Use this toolbar to modify the individual RGB color components of the image (red, green, blue) as 
well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, you can 
press Ctrl+Z to restore the default values.

Flip vertically, horizontally or in 90° rotations 
To flip an image vertically, horizontally, or rotate it by ninety degrees, select the image, and then 
click the relevant button on the image toolbar.

Image filters
Table 1 provides a short description of the available filters. The best way to understand them is to 
see them in action. Experiment with the different filters and filter settings, remembering that you 
can undo all the changes by pressing Ctrl+Z or Alt+Backspace or by selecting Edit > Undo.

Table 1: Image filters and their effects

Name Effect

Invert
Inverts the color values of a color image or the brightness values of a grayscale 
image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization
Mimics the effects of too much light in an image. A further dialog opens to adjust 
the parameters.

Aging
Simulates the effects of time on an image. Can be applied several times. A 
further dialog opens to adjust the aging level.

Posterize Makes an image appear like a painting by reducing the number of colors used.

Pop Art Modifies the image dramatically.

Charcoal Sketch Displays the image as a charcoal sketch.

Relief
A dialog is displayed to adjust the light source that will create the shadow and, 
hence, the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Using the Formatting toolbar and Image dialog
When an image is selected, you can customize some aspects of its appearance using the tools 
available on the Formatting toolbar and in the dialog opened by right-clicking on the image and 
selecting Properties. You can, for example, create a border around the image, selecting style and 
color; or you can (on the Borders page of the Image dialog) add a shadow to the image.

Cropping images
When you are only interested in a section of the image for the purpose of your document, you may 
wish to crop (cut off) parts of it. Writer provides two ways to crop an image: the Crop tool and the 
Crop page of the Image dialog. The Crop tool provides a quick and easy way to crop an image; but
for more control, use the Image dialog.

Note

If you crop an image in Writer, the image itself is not changed. Writer hides, not cuts 
off, part of the image. If you export the document to HTML, the original image is 
exported, not the cropped image. For export, crop images in an external editor.
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Using the Crop tool
To use the Crop tool, right-click the image and select Crop from the context menu. Cropping 
handles appear at the corners and mid-points of the sides of the image (see Figure 5). Drag a 
handle to cut off part of the image. Click outside the image to turn off cropping mode.

Figure 5: Cropping handles on an image

Using the Crop page of the Image dialog
To use the Image dialog, right-click the image and select Properties from the context menu, then 
select the Crop page of the Image dialog.

Figure 6: Result on image size of cropping using Keep scale option

The units of measurement shown on the Crop page are those set in Tools > Options > 
LibreOffice Writer > General.

Two options are available in the crop section for cropping an image: Keep scale and Keep image 
size. Keep scale maintains the proportions of the image; Keep image size may result in distortion 
of the image.

As the values for Left, Right, Top, and Bottom are altered, the boundaries of the image in the 
preview box change to show the crop area on the image, and the Width and Height fields under 
either Scale or Image size. This results in either an image size change (Figure 6), or a scale 
change for a fixed image size (Figure 7).

The original image size is indicated above the Original Size button.
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Figure 7: Result using Keep image scale option

Resizing an image
To perfectly fit the image into your document, you may have to resize it. There are a number of 
options available in Writer to do this.

A quick and easy way to resize is by dragging the image’s sizing handles:

 1) Click the image, if necessary, to show the green sizing handles.

 2) Position the pointer over one of the green sizing handles. The pointer changes shape, 
giving a graphical representation of the direction of the resizing.

 3) Click and drag to resize the image.

 4) Release the mouse button when satisfied with the new size.

Tip

The corner handles resize both the width and the height of the image simultaneously, 
while the other four handles resize only one dimension at a time. To retain the original 
proportions of the image, hold down the Shift key while dragging one of these handles.

For more accurate resizing of images, use either the Crop page (Figure 6) or the Type page of the 
Image dialog.

On the Crop page you can adjust the following settings:

• Scale Width and Height: specify in percentages the scaling of the image. The size of the 
image changes accordingly. For a symmetrical resizing, both values need to be identical.

• Image size: specify the size of the image in your preferred unit of measurement. The image
enlarges or shrinks accordingly.

• Original size button: when clicked, restores the image to its original size. This will be the 
size resulting after any cropping was carried out.

On the Type page of the Image dialog, select the Relative option to toggle between percentage 
and actual dimension. For a symmetrical resizing, select the Keep ratio option. Clicking on the 
Original Size button restores the original image size, but the scale dimensions are altered if the 
image has been cropped.
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Rotating or flipping an image
To quickly rotate an image 90 or 180 degrees, or flip it vertically or horizontally, right-click the 
image and select Rotate or Flip on the context menu, then choose the desired result.

Figure 8: Quickly rotating or flipping an image

You can rotate images at any required angle, using either of these methods:

• Interactively. Select the image and click the Rotate icon on the Image toolbar or right-click 
and select Rotate or Flip > Rotate. Rotation handles appear around the object. Hover the  
cursor over a handle; when the cursor changes shape, click and drag it to the required 
angle. This method is quick and easy, but not precise.

• Using the Image dialog. For precise rotation angles, right-click the image and select 
Properties. On the Image dialog, select the Image tab. In the Rotation Angle field, specify
the rotation required.

Other settings
The Image dialog (Figure 6) consists of ten pages. The Crop page was described on page 12; the 
Type and Wrap pages are explained in “Positioning images within the text” on page 18. The other 
pages serve the following purposes:

• Options: give the image a descriptive name (as you want it to appear in the Navigator), 
display alternative text when the cursor hovers over the image in a web browser, protect 
some of the image settings from accidental changes, and prevent the image from being 
printed.

• Borders: create borders around the image. The Borders dialog is the same as the one 
used for defining table or paragraph borders. You can also add a shadow to the image.

• Area: change the background color of the image. This setting produces the desired results 
only for images with a transparent color.

• Hyperlink: associate a hyperlink to the image, or create an image map (see page 27).

• Image: flip or rotate the image, and display the original location of the file in case the image
is linked rather than embedded.

• Transparency: set the transparency options for the image.

• Macro: associate a macro to the image. You can choose among the predefined macros or 
write your own.

Deleting an image
To delete an image, click it to show the green resizing handles, then press the Delete key.
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Exporting images
To make complex adjustments to the image, or to save it for use in another document, you can 
export it directly from the document. Right-click the image to select it and open the context menu. 
Then choose Save to open the Image Export dialog. Depending on the original format of the 
image, Writer will let you save the image in many different formats. Give a name to the image, 
select the desired image format in the File type list, and click Save.

If the image has been modified, Writer offers the choice of exporting the original version or the 
altered version of the image.

Compressing images
If you insert a large image in your document and resize it to fit into the layout of the page, the 
complete original image is stored in the document file to preserve its content, possibly resulting in a
large document file to store or send by mail.

If you can accept some loss of quality of the image rendering, you can compress or resize the 
image object to reduce its data volume while preserving its display in the page layout. You probably
don’t want to compress something that will be professionally printed.

Right-click to select the image and open the context menu. Then choose Compress to open the 
Compress Image dialog (Figure 9). The Calculate New Size button updates the image information
on the dialog on each parameter set you change. Click OK to apply the compression settings. If 
the resulting image is not acceptable, press Ctrl+Z to undo and choose another compression 
setting. For more information, see the Help.

Figure 9: Compressing an image

Using Writer’s drawing tools

You can use Writer’s drawing tools to create graphics such as simple diagrams using rectangles, 
circles, lines, text, and other predefined shapes. You can also group several drawing objects to 
make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in the document or insert them into a frame.
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You can also use the drawing tools to annotate photographs, screen captures, or other illustrations 
produced by other programs, but this is not recommended because:

• You cannot include images in a group with drawing objects, so they may get out of 
alignment in your document.

• If you convert a Writer document to another format, such as HTML, the drawing objects and
the images will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended you use LibreOffice Draw, 
which includes many more features such as layers and styles.

Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 10) by clicking View > 
Toolbars > Drawing or by clicking on the Show Draw Functions icon on the standard toolbar.

The Drawing toolbar may appear at the bottom or left side of the workspace. You can move it to 
another location and dock it, or float it and move it to a convenient place on the screen.

1 Select 6 Polygon 11 Stars and Banners 15 Insert Text Box
2 Insert Line 7 Quick Shapes 12 Callouts 16 Fontwork
3 Lines & Arrows 8 Basic Shapes 13 Flowchart 17 Points
4 Curve/Freeform Line 9 Symbol Shapes 14 Callouts 18 Toggle Extrusion
5 Curve 10 Block Arrows

Figure 10: The Drawing toolbar

To use a drawing tool:

 1) Click in the document where you want the drawing to be anchored. You can change the 
anchor later, if necessary.

 2) Select the tool from the Drawing toolbar (Figure 10). The cursor changes to a drawing-
functions pointer and the normal Formatting toolbar changes to the Drawing Object 
Properties toolbar (Figure 11).

 3) Move the cross-hair pointer to the place in the document where you want the image to 
appear and then click-and-drag to create the drawing object. Release the mouse button. 
The selected drawing function remains active, so that you can draw another object of the 
same type.

 4) To cancel the selected drawing function, press the Esc key or click the Select icon (the 
arrow) on the Drawing toolbar.

 5) You can now change the properties (fill color, line type and weight, anchoring, and others) 
of the drawing object using either the Drawing Object Properties toolbar (Figure 11) or the 
choices and dialogs reached by right-clicking on the drawing object.

Setting or changing properties for drawing objects
To set the properties for a drawing object before you draw it:

 1) On the Drawing toolbar (Figure 10), click the Select tool.

 2) On the Drawing Object Properties toolbar (Figure 11), click the icon for each property and 
select the value you want for that property.

 3) For more control, or to define new attributes, you can click the Area or Line icons on the 
toolbar to display detailed dialogs.
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The default you set applies to the current document and session. It is not retained when you close 
the document or close Writer, and it does not apply to any other document you open. The defaults 
apply to all the drawing objects except text objects.

To change the properties for an existing drawing object, select the object, then continue as 
described above.

1 Line Color 4 Line Width 7 Anchor 10 Align
2 Arrow Style 5 Area Color 8 Wrap 11 Arrange
3 Line Style 6 Area Style / Filling 9 Rotate 12 Group

13 Insert Caption

Figure 11: Drawing Object Properties toolbar

You can also specify the position and size, rotation, and slant and corner radius properties of the 
drawing object: right-click the drawing object and select Position and Size from the context menu. 
Choose any properties, as required.

Resizing a drawing object
To resize a drawing object, select the object, click one of the eight handles around it and drag it to 
its new size. The object will be scaled up or down.

When you grab an edge or corner handle of an object and drag it, LibreOffice will not keep the 
object’s proportions. If you also press the Shift key, the resizing will keep object proportions. (This 
is opposite to the behaviour for images.)

For more sophisticated control of the size of the object, right-click on the object and choose 
Position and Size from the context menu, or choose Format > Text Box and Shape > Position 
and Size from the Menu bar. Use the Position and Size tab to set the dimensions independently. If 
the Keep ratio option is selected, then the two dimensions change so that the proportion is 
maintained, resulting in a scaled resizing.

Grouping drawing objects

Grouping drawing objects makes it easier to handle several objects as a single entity, while 
preserving their relative sizes and positions. When objects are grouped, any editing operations 
carried out on that group are applied to all members of the group. If you click on one member of 
the group, the whole group is selected.

To group drawing objects:

 1) Select one object, then hold down the Shift key and select the others you want to include in 
the group. The bounding box expands to include all the selected objects.

 2) With the objects selected, hover the cursor over one of the objects and choose Format > 
Group > Group from the Menu bar, or click the Group icon on the Drawing Object 
Properties toolbar, or right-click and choose Group in the context menu.

Note

You cannot include an embedded or linked image in a group with drawing objects.
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You can edit an individual member of a group without ungrouping or breaking the group. Select the
group and go to Format > Group > Enter Group on the Menu bar, or right-click and select Enter 
Group from the context menu, or click the Enter Group icon in the Drawing Object Properties 
toolbar. 

When you have finished editing an individual member of a group, go to Format > Group > Exit 
Group on the Menu bar, or right-click and select Group > Exit Group from the context menu, or 
click the Exit Group icon in the Drawing Object Properties toolbar.

To ungroup or break apart a group of objects, select the group then go to Format > Group > 
Ungroup on the Menu bar, or right-click and select Ungroup in the context menu, or click the 
Ungroup icon in the Drawing Object Properties toolbar.

Rotating drawing objects
You can rotate a drawing object in a similar way to rotating images (page 14). To rotate a drawing 
object to any required angle, use either of these methods:

• Interactively. Select the drawing object and click the Rotate icon on the Drawing Object 
Properties toolbar. Rotation handles appear around the object. Hover the cursor over a 
handle; when the cursor changes shape, click and drag it to the required angle.

• Position and Size dialog. Right-click the object and select Position and Size. On the 
dialog, select the Rotation page. In the Rotation Angle field, specify the rotation required. 
By default, rotation is around the center of the object, but you can choose a different pivot 
point.

Tip

Of particular interest to Writer is the Text Box drawing object. Ordinary text can only be
rotated to 90, 180, or 270 degrees, as described in Chapter 9, but a Text Box object 
can be rotated to any desired angle.

Positioning images within the text

When you add an image to a text document, you need to choose how to position it with respect to 
the text and other images. Positioning is controlled by four settings:

• Arrangement refers to the placement of an image on an imaginary vertical axis. 
Arrangement controls how images are stacked upon each other or relative to the text.

• Alignment refers to the vertical or horizontal placement of an image in relation to the 
chosen anchor point.

• Anchoring refers to the reference point for the images. This point could be the page, or 
frame where the object is, a paragraph, or even a character. An image always has an 
anchor point.

• Wrapping refers to the relation of images to the surrounding text, which may wrap around 
the image on one or both sides, be overprinted behind or in front of the image, or treat the 
image as a separate paragraph or character.

The settings can be accessed in several ways, depending on the nature of the images:

• From the Format menu: Anchor, Wrap, and Arrange (for images and drawing objects).

• From the context menu displayed when you right-click the image; this menu also includes 
an Align submenu.

• For images, from the Type and Wrap tabs of the Image dialog. You cannot control the 
arrangement or alignment using the dialog.
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• For drawing objects, from the Position and Size tab of the Position and Size dialog. To open
the dialog, right-click the drawing object and choose Position and Size on the context 
menu.

• For an embedded object (such as a Calc spreadsheet or Draw document), from the OLE-
Object toolbar.

Note

While all the positioning techniques discussed in this section apply equally to frames, 
contour wrapping is not possible for frames.

Arranging images
Arranging an image means to determine its position relative to other images or text. Arranging is 
only relevant when objects are overlapping. You can choose between four common settings, plus a
fifth special setting for drawing objects:

Bring to Front
Places the image on top of any other images or text.

Forward One
Brings the image one level up in the stack. Depending on the number of overlapping objects, 
you may need to apply this option several times to obtain the desired result.

Back One
Sends the image one level down in the object stack.

Send to Back
Sends the image to the bottom of the stack.

To Background / To Foreground
Only available for drawing objects; moves the drawing object behind or in front of the text 
respectively.

Tip

To select an object that is covered by other objects, press the Tab key to move through
the objects until you reach the object you want.

Anchoring images
You can anchor images as a character or to a page, paragraph, or character. You can also place 
images in a frame and anchor the frame to a page, paragraph, or character. Which method you 
choose depends on what you are trying to achieve.

To Page
The image keeps the same position in relation to the page margins. It does not move as you 
add or delete text or other images. This method is useful when the image does not need to 
be visually associated with a particular piece of text. It is often used when producing 
newsletters or other documents that are very layout intensive, or for placing logos in 
letterheads.

Caution

If you plan to use a document within a master document, do not anchor images To 
Page because the images will disappear from the master document. See Chapter 16, 
Master Documents, for more information.
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To Paragraph
The image is associated with a paragraph and moves with the paragraph. It may be placed in
the margin or another location. This method is useful as an alternative to a table for placing 
icons beside paragraphs.

To Character
The image is associated with a character but is not in the text sequence. It moves with the 
paragraph but may be placed in the margin or another location. This method is similar to 
anchoring to a paragraph.

As Character
The image is placed in the document like any other character and, therefore, affects the 
height of the text line and the line break. The image moves with the paragraph as you add or 
delete text before the paragraph. This method is useful for keeping screenshots in sequence 
in a procedure (by anchoring them as a character in a blank paragraph) or for adding a small 
(inline) icon in sequence in a sentence.

To Frame
If the image has been placed in a frame, you can anchor the image in a fixed position inside 
the frame. The frame can then be anchored to the page, a paragraph, or a character, as 
required.

Aligning images
Once you have established the anchor point of an image, you can decide the position of the image 
relative to its anchor: this is called aligning the image. Choose from six options: three for aligning 
the image horizontally (left, center, right) and three for aligning the image vertically (top, middle, 
bottom). Horizontal alignment is not available for images anchored As Character.

For finer control of the alignment, use the Position options on the Type page of the Image dialog, 
shown in Figure 12.

For both the horizontal and vertical position, start by picking the reference point in the right hand 
side drop-down menu, then select in the first drop-down menu among Left, Right, or Center for 
Horizontal or Top, Bottom, Center for vertical. If you select From left or From top, you can specify 
the distance. In the example in Figure 12, the image was anchored To Page; the upper-left corner 
of the image will be placed at 5 cm from the left edge of the page text area and 10 cm from the top 
edge of the entire page.

Figure 12: Fine tuning the alignment

Wrapping text around images
The Wrap setting determines the relation between the text and the image. Several choices are 
available from the context menu:

No Wrap
With this option the text is placed above and below the image but not to either side of it. This 
is the wrapping type used for most of the figures in this guide. The advantage of No Wrap is 
that it does not need much tweaking.
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Page Wrap or Optimal Page Wrap
The text flows around the image. Moving the image around the page causes the text to be 
rearranged to fill the space to the left and right of it. Optimal Page Wrap prevents text from 
being placed to the side of the image if the spacing between the image and the margin is 
less than 2 cm.

Wrap Through
Superimposes the image on the text. That is, the image is in front of the text. This option 
must be used in conjunction with the image-transparency setting in order to make the text 
under the image is visible.

In Background
Similar to Wrap Through, but the image is placed behind the text so there may be no need to 
change the transparency to make the text visible. Best used only for images without a lot of 
contrast or different colors.

The wrap format is normally selected after anchoring and alignment of the image. To set the 
position of an image to the desired wrap format, right-click the image to display the context menu 
and move the cursor to Wrap to display a submenu of the available wrap formats. Alternatively, 
select Format > Wrap from the Menu bar. Select the desired wrap format.

Note

When anchoring an image as character, you can only adjust the distance between the 
image and the text, but no wrapping option is displayed.

To fine-tune the wrapping options, open the Image dialog and select the Wrap tab (Figure 13).

Figure 13: The advanced wrap format options

This tab is divided into three sections. In the top part you can select from the wrap types mentioned
above, plus two additional wrap formats that prevent the text from filling the area to the left (After) 
or to the right (Before) of the image. Use the Spacing section of the page to adjust the spacing 
between the image and the text. The contents of the Options section of the tab change depending 
on the selected wrap format.

First paragraph
Starts a new paragraph after the image even if it could still wrap around the image.

In background
Moves the image to the background. Available only for Through Wrap.

Contour
Wraps the text around a custom contour rather than around the edge of the image. Available 
for Page or Optimal Page Wrap.
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Outside only
Forces the text to wrap on the outside of the image, even if the contour contains open areas 
within the shape.

Allow overlap
Specifies whether the object is allowed to overlap another object. This option has no effect 
on wrap through objects, which can always overlap.

Editing the contour
If you select wrapping around a drawing object, LibreOffice automatically creates a contour. The 
Edit Contour option is only available for image wrapping. To create a contour, right-click the image 
and select Wrap > Edit Contour from the context menu, or access the Contour Editor from the 
Menu bar by selecting Format > Wrap > Edit Contour.

The dialog shown in Figure 14 opens with the image loaded in the main window. Use the tools to 
draw the region of the image you do not want to be covered by the text; this area will be shaded.

Figure 14: The Contour Editor in action with AutoContour

Four tools are available in the Contour Editor window: Rectangle, Ellipse, Polygon, and 
AutoContour. Some familiarity with drawing tools is required to create complex contours; however, 
in most circumstances there is no need for high accuracy. You can also select the Edit Points 
button and adjust the contour shape point by point. See the Draw Guide for details.

When you are done, click the Apply button to save the contour.

Example 1: Page wrapping
Figure 15 shows an example of page wrapping in action. To achieve this:

 1) Insert the image into the document, then anchor it to the paragraph of your choice. To move
the anchor, select the image or the anchor, and move it until the anchor symbol is at the 
beginning of the chosen paragraph.

 2) Align the image so that the left margin of the image is where you want it to be. This can be 
done with the mouse or using the advanced settings. The Status bar shows the location of 
the upper left corner and the image size.

 3) Change the wrap to Page Wrap. To increase the space between the image and the text, 
access the Wrap page of the Image dialog and set the spacing between the image and text 
in all the boxes.
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Tip

When adjusting white space in a wrap, consider also the white space in the image.

Figure 15: Example of image with Page Wrap formatting

Example 2: Simple contour wrapping in action
In this example we again apply page wrapping as in Example 1, enabling this time the contour 
option. We will work on an image and on a drawing object as the contour option works slightly 
differently in each case.

The example in Figure 16 was created following the steps below.

Figure 16: Image and drawing objects with contour wrapping

 1) Create some text.

 2) Insert an image of your choice and anchor it to the first paragraph. Adjust the alignment as 
desired, then change the wrap type to Page Wrap. Right-click the image and select Wrap >
Edit Contour from the context menu.

 3) Use the technique discussed in “Editing the contour” on page 22 to create a custom contour
and click Apply. If needed, adjust the spacing between the edge of the image and the text 
using the Wrap page of the Image dialog.

 4) Insert an AutoShape of your choice (a triangle in the example) and proceed as in step 2 
above.
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 5) Enable the contour wrap by selecting Format > Wrap > Contour from the Menu bar or 
right-click and choose Wrap > Contour from the context menu. LibreOffice automatically 
generates the contour for a drawing object. You may need to adjust the distance between 
the drawing object and the text using Format > Wrap > Edit.

Example 3: Wrap Through and In Background
This example shows how to use an image as a background by wrapping the text through it and 
adjusting the transparency. 

Selecting the Wrap Through option for an inserted image causes the image to overlap the text, 
which as a result will be hidden. To make the text appear, change the transparency of the image; 
although the words under the image become visible, they may be difficult to read and will appear 
lighter than the rest of the text.

To reproduce the example in Figure 17, create some text, then insert the image of your choice. 
Anchor the image (to the page in the example) and select Format > Wrap > Wrap Through from 
the Menu bar or right-click the image and select Wrap > Wrap Through from the context menu. 
Move the image into the desired position. The Image toolbar should be displayed when the image 
is selected. Change the transparency to a suitable value (40% in the example) so that the text can 
be read.

Figure 17: Transparent image added over the text

Tip

You can obtain a better result if you set the image wrap to In Background. With this 
selection all the text will be clearly readable, with all characters having the same 
intensity, as long as the background is not too dark. You may still need to adjust the 
transparency of the image.

Adding captions to images

You can add captions to images in three ways: automatically, by using the Caption dialog, or 
manually.

Adding captions automatically
You can set up LibreOffice to add captions automatically whenever you insert an image, a table, or 
other objects into a document. You can choose which objects are captioned automatically, what the
sequence name is for each caption (for example, Table or Figure), and the position of the caption.

To set up automatic captions, choose Tools > Options > LibreOffice Writer > AutoCaption. At 
the right of the dialog, choose which objects you want to be automatically captioned and specify 
the characteristics of the captions.
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When you insert an image, if automatic captioning is enabled, the image is placed in a frame along
with a caption containing the default sequence name for images. Position the cursor in the caption 
area and type the text for the caption. You can change the sequence name by selecting one from 
the drop-down Category list or typing in your own.

If you need a sequence name that is not one of the names provided, you can add any custom 
name you wish:

 1) Open the AutoCaption dialog, as described above.

 2) In the Add captions automatically when inserting section, select LibreOffice Writer Image. 
This activates the Caption area in the dialog for images.

 3) Under the Category drop-down list, enter the name that you want added (say, Photo), by 
typing it in the box. (Overwriting a term in the box does not delete it from the list.) You can 
also set some options for the number style and for a separator between the name and the 
number, if desired. Click OK to save the changes.

Adding captions using the Caption dialog
To add captions using the Caption dialog:

 1) Insert the image, then either right-click it and select Insert Caption from the context menu, 
or select it and choose Insert > Caption from the Menu bar.

Figure 18: Defining the caption for an illustration

 2) Under Properties on the Caption dialog (Figure 18), make your selections for the Category, 
Numbering, and Separator fields [Illustration, Arabic (1 2 3), and a colon (:), respectively, for
the example in Figure 18] and type your caption text in the Caption box at the top. The text 
you enter for the caption appears in the box at the bottom, after the sequence name, 
number, and separator.

 3) Click OK. The image and its caption are placed in a frame.

Tip

In the Category box, you can type any name you want (for example, Photo) if the drop-
down list does not include it. Writer will create a numbering sequence using that name,
as it does when using the AutoCaption feature.
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Numbering images by chapter
Additional options for numbering captions are available under the Options button in the Captions 
dialog (Figure 19). Some of these settings, which refer to the outline level, will have an effect only if
you are using outline level paragraph styles on the chapter headings within your document.

Figure 19: Options for numbering figures

When chapter numbering is set up, Writer will restart the caption numbering for each chapter it 
encounters. For example, if the last figure caption you create in chapter 1 is Figure 1.15, and the 
next figure caption you create is in chapter 2, the numbering will start over at Figure 2.1.

Options available to chapter numbering for captions include the following:

• Use Level to specify the outline level that triggers a restart of the numbering as well as how
many levels of outline numbering are shown before the table number. For example, if the 
document uses Heading 1 style for chapters and Heading 2 style for sub-headings, if you 
want all the tables in a chapter (that is, between two Heading 1 paragraphs) to be 
numbered sequentially independently of the sub-heading they are under, select 1 as Level. 
If instead you want to restart the numbering at each sub-heading, select level 2.

• Use the Separator field to establish the separator between the chapter number and figure 
number.

• Use Character style to set a character style for the caption. This is useful if the separator 
of your choice is not a symbol included in the default font type of your document or if you 
want the caption to have a special color, size and so on.

• The Apply border and shadow option does not apply to table captions. LibreOffice 
normally wraps the objects you can add a caption to in a frame, but not for tables.

• Use Caption order to specify whether you want the category or numbering to appear first 
in the caption.

Adding captions manually
If you save as or export to other formats, you may find that captions applied as described above 
(either automatically or using the Caption dialog) are lost during the export.

26 | Chapter 11  Images and Graphics



To avoid export problems, or as another way to put captions above images or below them (the 
usual case), you can add a caption manually, in either of two ways:

• Place the image and its caption in separate paragraphs.

• Use a table.

Place the image and its caption in separate paragraphs
Insert the image and anchor it to its paragraph as a character. Press Enter to create a new 
paragraph for the caption.

 1) In the caption paragraph, type, for example, Figure and add a space.

 2) To insert the figure number automatically, click Insert > Field > More Fields (Ctrl+F2) and 
select the Variables tab.

 3) Select Number range in the Type list. Select Figure in the Select list and choose (for 
example) Arabic (1 2 3) in the Format drop-down list. Click the Insert button.

 4) A number will appear after the word “Figure” in the caption. Now, type the text of the 
caption.

Tip

If you are manually adding captions to a lot of figures using this method, you might 
want to make an AutoText entry containing, for example, Figure and a space, the 
figure-number field, and an optional separator and a space after it.

To ensure the image and its caption stay together on the page, create a new 
paragraph style, for example Figure. If the image is going above the caption, define 
the text flow of the Figure paragraph style as Keep with next paragraph and the next 
style as Caption. Conversely, if the caption is going above, define the Caption 
paragraph style as Keep with next paragraph and the next style as Figure.

Use a table
Create a one-column, two-row table. Place the image in one row and type the caption in the other 
row—or use two or more rows for the caption and other text. This method can be especially useful 
for images with numbered legends, such as Figure 10 on page 16.

Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text 
hyperlinks. Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate 
program (for example, the default browser for an HTML page; LibreOffice Calc for a ODS file; a 
PDF viewer for a PDF file). You can create hotspots of various shapes and include several 
hotspots in the same image.

To use the image map editor (Figure 20):

 1) In the Writer document, select the image in which you want to define the hotspots.

 2) Choose Tools > ImageMap from the Menu bar. The ImageMap Editor (Figure 20) opens.

 3) Use the tools and fields in the dialog (described below) to define the hotspots and links 
necessary.

 4) Click the Apply icon to apply the settings.

 5) When done, click the Save icon to save the image map to a file, then close the dialog.
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Figure 20: The dialog to create or edit an image map

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is 
identified by a line indicating its shape.

The toolbar at the top of the dialog contains the following tools:

• Apply icon: applies the changes.

• Open, Save, Close and Select icons.

• Tools for drawing a hotspot shape: these tools work in exactly the same way as the 
corresponding tools in the Drawing toolbar.

• Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a 
polygon hotspot. Select the Edit Points tool to activate the other tools.

• Active icon: toggles the status of a selected hotspot between active and inactive.

• Macro: associates a macro with the hotspot instead of just associating a hyperlink.

• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

• Address: the address pointed to by the hyperlink. You can also point to an anchor in a 
document; to do this, write the address in this format: 
file:///<path>/document_name#anchor_name

• Text: type the text that you want to be displayed when the cursor is moved over the hotspot.

• Frame: where the target of the hyperlink will open: pick among _blank (opens in a new 
browser window), _self (opens in the active browser window), _top or _parent.

Tip

The value _self for the target frame will work in the vast majority of occasions. It is 
therefore not recommended to use the other choices unless absolutely necessary.
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Managing the LibreOffice Gallery

Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and People. You can 
create other groups or themes and add your own images or find extensions containing more 
graphics. Click a theme to see its contents displayed in the Gallery window.

You can display the Gallery in Icon View (Figure 2) or Detailed View (Figure 21), and you can hide 
or show the Gallery by clicking on the Sidebar’s Hide button.

Note

The default themes supplied with LibreOffice can not be customized, although new 
themes can be added; see “Adding a new theme to the Gallery” on page 30. The 
locked themes are easily recognizable by right-clicking on them; the only available 
option in the context menu is Properties.

By default, the Gallery is opened in the Sidebar. You can float the Gallery as you can other Sidebar
decks; see Chapter 1, Introducing Writer, for more information.

Figure 21: Gallery in Detailed View

Adding objects to the Gallery
You may wish to add any images that you use frequently, for example, a company logo, to a theme
in the Gallery. You can then easily insert these graphics into a document later.

 1) Right-click the name of the theme in the top list and select Properties from the context 
menu.

 2) In the Properties dialog, click the Files tab (Figure 22), then click the Find Files button.

 3) A file browser dialog (not shown) opens. Navigate to the folder containing the required files.

 4) Click Open. You are returned to the Properties dialog, where the image files in that folder 
are now listed.

 5) Select the required files (hold down either the Shift key or the Ctrl key while clicking on the 
files) and click Add to add them to the Gallery. To add all of the files shown in the list, click 
Add All.
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 6) Click OK on the Properties dialog to close it.

Figure 22: Gallery Properties dialog

Adding a new theme to the Gallery
To add a new theme to the Gallery:

 1) Click the New Theme button above the list of themes (Figure 21).

 2) In the Properties of New Theme dialog, click the General tab and type a name for the new 
theme.

 3) Click the Files tab and add images to the theme, as described earlier.

Deleting images and themes from the Gallery
To delete an image from a theme, right-click on the name of the image file or its thumbnail in the 
Gallery, then click Delete in the context menu. A message appears, asking if you want to delete 
this object. Click Yes.

Note

Deleting the name of a file from the list in the Gallery does not delete the file from the 
hard disk or other location.

To delete a theme from the Gallery, select it from the list of themes, right-click, then click Delete in 
the context menu.

Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard
disk, on a network drive, or other removable media. When you add graphics to the Gallery, the files
are not moved or copied; the location of each new object is simply added as a reference.

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents 
unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can 
change this location, and you can copy your gallery files (SDV) to other computers.
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Gallery contents provided with LibreOffice are stored in a different location. You cannot change this
location.

Note

Gallery themes can be packed for distribution through the LibreOffice extensions 
framework. In that case, the location of the files is determined by the extension 
settings. To get more gallery themes, visit the LibreOffice extensions website at 
http://extensions.libreoffice.org.

Using Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There 
are many different settings for text art objects (line, area, position, size, and more), so you have a 
large choice.

Fontwork is available with LibreOffice Writer, Calc, Impress, and Draw, but you will notice small 
differences in the way that each component displays it.

Creating a Fontwork object
 1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View > 

Toolbars > Drawing), click the Fontwork icon, or choose Insert > Fontwork in the Menu 
bar.

 2) In the Fontwork Gallery dialog (Figure 23), select a Fontwork style, then click OK. The 
Fontwork object will appear in your document.

 3) Notice the colored squares around the edge (indicating that the object is selected) and the 
yellow dot; these are discussed in “Moving and resizing Fontwork objects” on page 33.

Resize the object using one of the corner handles (hold down the Shift key to keep the 
sides proportional), or right-click and choose Position and Size from the context menu for 
more precise sizing.

Figure 23: The Fontwork Gallery
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 4) Double-click the object to edit the Fontwork text (see Figure 24). Type your own text in 
place of the black Fontwork text that appears over the object.

Figure 24: Editing Fontwork text

 5) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object
Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use
the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the 
selected Fontwork object is a 3D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar, shown in Figure 25, is visible. If you do not see it, go to View 
> Toolbars > Fontwork. Click the different icons to edit Fontwork objects.

Figure 25: The floating Fontwork toolbar

1 Fontwork Gallery: Opens the Fontwork Gallery (Figure 23).

2 Fontwork Shape: Edits the shape of the selected object. 
You can choose from a palette of shapes.

Figure 26: Fontwork toolbar 
showing palette of shapes

3 Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles 
between normal height (some characters taller than others, for example capital letters, d, h, l
and others) and all letters the same height.

Figure 27: Left: normal letters; right: same letter heights
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4 Fontwork Alignment: Changes the alignment of characters. 
Choices are left align, center, right align, word justify, and stretch 
justify. The effects of the text alignment can only be seen if the 
text spans over two or more lines. In the stretch justify mode, all 
the lines are filled completely.

5 Fontwork Character Spacing: Changes the character spacing 
and kerning in the object. Select from the choices in the drop-
down list.

6 Toggle Extrusion: changes a 2D Fontwork object into a 3D 
object or a 3D object into a 2D object.

Using the Formatting toolbar
You can customize the Fontwork object with several more attributes. Click on the object; the 
Formatting toolbar changes to show the options for customizing the object. These choices are the 
same as the ones for other drawing objects, described earlier in this chapter. See also the Draw 
Guide for details.

Using menu options
You can use some the choices on the Format menu to anchor, align, arrange, and group selected 
Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click a Fontwork object and choose many of the same options from the context 
menu. The context menu also provides quick access to the Line, Area, and Position and Size 
dialogs. For more information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar
If the selected Fontwork object is a 3D object, you can also use the options on the 3D-Settings 
toolbar. You can also change a 2D Fontwork object into a 3D object (or change a 3D object into a 
2D object) by clicking the Toggle Extrusion icon on the Fontwork toolbar. For more information, 
see the Draw Guide.

Moving and resizing Fontwork objects
When you select a Fontwork object, eight colored squares (known as handles) appear around the 
edge of the object, as shown below. You can drag these handles to resize the object.

A yellow dot also appears on the object. This dot may be 
along an edge of the object, or it may be somewhere else; in 
the example on the right. If you hover the pointer over this 
yellow dot, the pointer turns into a hand symbol. You can drag
the dot in different directions to distort the object.

Hovering the pointer over other parts of the object turns the 
pointer into the usual symbol for dragging the object to 
another part of the page.

For precise control of the location and size of the object, use the Position and Size dialog.
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Generating a QR code

A QR code (short for Quick Response code) is a type of barcode. QR codes often contain data that
points to a website or application. Writer, Calc, Impress, and Draw can generate QR codes.

 1) Choose Insert > Object > QR Code on the Menu bar to open the QR Code Generator 
dialog (Figure 28).

Figure 28: QR Code Generator dialog

 2) Fill in the URL/Text field, select a correction factor (the complexity of the graphic 
generated), and the width of the border around it, then click OK. Figure 29 shows the code 
generated by the input in Figure 28.

Figure 29: QR code example
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