Writer Guide

Chapter 16
Customizing Writer

Copyright
This document is Copyright © 2011–2012 by its contributors as listed below. You may distribute it
and/or modify it under the terms of either the GNU General Public License
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.
All trademarks within this guide belong to their legitimate owners.

Contributors
Ron Faile Jr
Barbara Duprey
Jean Hollis Weber
John A Smith

Feedback
Please direct any comments or suggestions about this document to:
documentation@global.libreoffice.org

Acknowledgments
This chapter is based on Chapter 16 of the OpenOffice.org 3.3 Writer Guide. The contributors to
that chapter are:
Peter Hillier-Brook
Jean Hollis Weber

Barbara M. Tobias
Michele Zarri

Publication date and software version
Published 31 December 2012. Based on LibreOffice 3.6.4.

Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Open context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open Styles & Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
This chapter describes some common customizations that you may wish to do.
You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first
save them in a document and then save the document as a template as described in
Chapter 10, Working with Templates.

Customizing menu content
In addition to changing the menu font (described in Chapter 2, Setting up Writer), you can add to
and rearrange categories on the menu bar, add commands to menus, and make other changes.
To customize menus:
1) Choose Tools > Customize.
2) On the Customize dialog, go to the Menus page.

Figure 1. The Menus page of the Customize dialog
3) In the Save In drop-down list, choose whether to save this changed menu for the
application (Writer) or for a selected document.
4) In the section LibreOffice Writer Menus, select from the Menu drop-down list the menu that
you want to customize. The list includes all the main menus as well as submenus, that is
menus that are contained under another menu. For example, in addition to File, Edit, View,
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and so on, there is File | Send and File |Templates. The commands contained in the
selected menu are shown in the central part of the dialog.
5) To customize the selected menu, click on the Menu or Modify buttons. You can also add
commands to a menu by clicking on the Add button. These actions are described in the
following sections. Use the up and down arrows next to the Entries list to move the
selected menu item to a different position.
6) When you have finished making all your changes, click OK to save them.

Creating a new menu
In the Menus page of the Customize dialog, click New to display the New Menu dialog, shown in
Figure 2.
1) Type a name for your new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into the required position on
the menu bar.
3) Click OK to save.
The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
menu bar itself after you save your customizations.)
After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 6.

Figure 2: Adding a new menu

Modifying existing menus
To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these
modifications can be applied to all the entries in the Menu list. For example, Rename and Delete
are not available for the supplied menus, and Move is not available for submenus.
To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure
2 (but without the Menu name box) opens. Use the up and down arrow buttons to move the menu
into the required position.
To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
Customizing menu content
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arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.
Custom menus, and supplied submenus, can be renamed by pressing the Menu button in the
upper section of the page and selecting Rename.
In addition to renaming, you can allocate a letter in a custom menu's name, which will become
underlined, to be used as a keyboard shortcut, that allows you to select that menu when you press
Alt+ that letter. Existing submenus can be edited to change the letter which is used to select them
from the keyboard once the menu is open.
1) Select a custom menu or a submenu in the Menu drop-down list.
2) Click the Menu button and select Rename.
3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to
select the Send submenu command by pressing S (after opening the File menu using
Alt+F), enter ~Send. This changes it from the default d.

Note

It is possible to use a letter already in use in the menu list (for example, in the Insert
menu, the letter v is used in Envelope and in Movie and sound as an accelerator).
However, you should use an unused letter if possible, to make it simpler for the user
to navigate.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of
the dialog. The Add Commands dialog is displayed.

Figure 3: Adding a command to a menu
On the Add Commands dialog, select a category and then the command, and click Add. The
dialog remains open, so you can select several commands. When you have finished adding
commands, click Close. Back on the Customize dialog, you can use the up and down arrow
buttons to arrange the commands in your preferred sequence.
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Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.
To begin, select the menu or submenu to be modified, from the Menu list near the top of the
Customize page, then select the entry in the Entries list under Menu Content. Click the Modify
button and choose the required action from the drop-down list of actions.
Add Submenu does just that. After adding a submenu, it can be selected in the Menu list in the
top section of the page and another submenu can be nested within it.
Begin a group adds a separator line after the highlighted entry.
Rename allows you to rename the entries and to modify the accelerator letter used in the menu
entry for items other than submenus (see “Modifying existing menus“ on page 5).
Delete removes the selected entry from the Entries list.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. This section describes how to create new toolbars and add or delete icons on existing
ones.
To get to the toolbar customization dialog, do any of the following:

• On the toolbar, right-click in the toolbar and choose Customize Toolbar.
• Choose View > Toolbars > Customize from the menu bar.
• Choose Tools > Customize from the menu bar and go to the Toolbars page.

Figure 4. The Toolbars page of the Customize dialog

Customizing toolbars
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Modifying existing toolbars
To modify an existing toolbar:
1) In the Save In drop-down list, choose whether to save this changed toolbar for the
application (Writer) or for a selected document.
2) In the section LibreOffice Writer Toolbars, select from the Toolbar drop-down list the toolbar
that you want to modify.
3) Click on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on the
Add button. You can also create a new toolbar by clicking on the New button. These
actions are described in the following sections.
4) When you have finished making all your changes, click OK to save them.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.
1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and
click the Add button in the Toolbar Content section of the dialog.
2) The Add Commands dialog (Figure 3) is the same as for adding commands to menus.
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.
3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.
4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
To choose an icon for a command, select the command in the Toolbar Content – Commands list in
the Customize dialog, and click Modify > Change icon. On the Change Icon dialog, you can scroll
through the available icons, select one, and click OK to assign it to the command.

Figure 5: Change Icon dialog
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To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons must be 16×16 in size and cannot contain
more than 256 colors.

Example: Adding a Fax icon to a toolbar
You can customize LibreOffice so that a single click on an icon automatically sends the current
document as a fax.
1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more
information.
2) Choose Tools > Options > LibreOffice Writer > Print. The dialog shown in Figure 6
opens.

Figure 6: Setting up LibreOffice for sending faxes
3) Select the fax driver from the Fax list and click OK.
4) Right-click in the Standard toolbar. In the drop-down menu, choose Customize Toolbar.
The Toolbars page of the Customize dialog appears (Figure 4). Click Add.
5) On the Add Commands dialog (Figure 7), select Documents in the Category list, then
select Send Default Fax in the Commands list. Click Add. Now you can see the new icon
in the Commands list of the Toolbars page.
6) In the Commands list, click the up or down arrow button to position the new icon where you
want it. Click OK and then click Close. Your toolbar now has a new icon to send the current
document as a fax.

Customizing toolbars
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Figure 7: Adding a Send Fax command to a toolbar

Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize > Toolbars from the menu bar.
2) Click New. On the Name dialog, type the new toolbar’s name and choose from the Save In
drop-down list where to save this changed menu: for the application (Writer) or for a
selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described above.

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined
shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, especially if other users share your
computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Choose Tools > Customize > Keyboard. The Customize dialog opens.
2) To have the shortcut key assignment available in all components of LibreOffice, select the
LibreOffice button.
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3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut key in the Shortcut keys list at the top of the page and click
the Modify button on the right. The selection now appears in the Keys list on the lower
right.
5) Click OK to accept the change. Now the chosen shortcut key will execute the function
chosen in step 3 above whenever it is pressed.
Repeat as required.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
that is already in use, you must first delete the existing key.
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style and
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.
1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog
(Figure 8) opens.

Figure 8. Defining keyboard shortcuts for applying styles

Assigning shortcut keys

11

2) To have the shortcut key assignment available only for Writer, select Writer in the upper
right corner of the page; otherwise select LibreOffice to make it available to every
component.
3) Choose the shortcut key you want to assign a style to. In this example, we have chosen
Ctrl+9. This enables the Modify button.
4) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the + sign to expand the list of styles.
5) Choose the category of style. (This example uses a paragraph style, but you can also
choose character styles and others.) The Function list will display the names of the
available styles for the selected category. The example shows some of LibreOffice’s
predefined styles.
6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.
7) Make any other required changes, and then click OK to save these settings and close the
dialog.

Example: Assigning macros to shortcut keys
A common use for assigning macros to shortcut keys is to enable quick and easy insertion of
special characters. This example shows how to set up keyboard shortcuts for inserting en-dashes
and em-dashes.
To enable macro recording, go to Tools > Options > LibreOffice > General and
select the Enable macro recording (limited) option.

Note

First, you need to record a macro for inserting each type of dash. Then, you need to assign those
macros to shortcut key combinations.
1) Choose Tools > Macros > Record Macro to start recording a macro.
2) A small window is displayed so you know that LibreOffice is recording. (This window may
look slightly different on different operating systems.)

3) Choose Insert > Special Characters to open the Special Characters dialog. Scroll down
until you find the en-dash (U+2013) and em-dash (U+2014) characters. Select one of them
and click OK.
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Figure 9: Find and choose the en-dash
4) Click the Stop Recording button to stop recording, save the macro, and display the
LibreOffice Basic Macros dialog (see Figure 10). Type a descriptive name for the new
macro in the Macro name box on the upper left.

Figure 10: Naming the new macro and storing it
5) Be sure to open the library container named My Macros. Find the library named Standard
under My Macros. Select Module1 and click Save.
6) Repeat steps 1–4 to create other macros, for example to insert an em-dash.
7) Choose Tools > Customize > Keyboard tab (Figure 11). In the Shortcut keys list, pick an
unused combination (for example, Ctrl+Shift+M for an em-dash). In the Category list, scroll
down to LibreOffice Macros, click the + sign (or small triangle, depending on your
operating system), then click the + (or triangle) next to the Standard library and choose
Module1. In the Function list, choose Emdash and click the Modify button on the upper
right. The selected key combination now appears in the Keys list on the lower right, and
Emdash appears next to Ctrl+Shift+M in the Shortcut keys list.
8) Repeat for the en-dash macro, selecting perhaps Ctrl+Shift+N for the shortcut key and then
click OK.
Assigning shortcut keys
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Tip

For inserting en- and em-dashes, and other special characters, you may find
extensions such as Compose Special Characters useful. See “Adding functionality
with extensions” on page 15.

Figure 11: Defining keyboard shortcuts for running macros

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button on the Customize
dialog (Figure 8).
2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.
3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.
4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.
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Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load
button on the Customize dialog, and then select the configuration file from the Load Keyboard
Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. For example, a common use is to assign the “open
document” event to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros, in the Getting Started guide.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Several extensions are shipped bundled with LibreOffice and are installed with the program.
Others can be downloaded from various websites. The official extension repository is located at
http://extensions.libreoffice.org/. These extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
Extensions can be installed in any of three ways.
1) Directly from the *.oxt file in your system's file browser.
2) From your web browser if it can be configured to open this file type from a web page
hyperlink.
3) Directly from Tools > Extension Manager by clicking Add.
To install directly from a saved *.oxt file on your system, double click the file.
To install from a suitably enabled web browser, select the hyperlink, and then select to Open the
file.
In both cases, after the Extension Manager opens, a warning dialog opens for you to verify the
installation and then continue. The file is installed as a “user only“ file in a multi user system.

Figure 12: Installation warning dialog
Adding functionality with extensions
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To install directly from Extension Manager:
1) In LibreOffice, select Tools > Extension Manager from the menu bar. The option to view
the extensions bundled with LibreOffice can be deselected to easier view those installations
which have been added by a user.
2) In the Extension Manager dialog (Figure 14), click Add.
3) A file browser window opens. Find and select the extension you want to install and click
Open.
4) Users with administrator or root privileges will see a dialog where they can choose to install
extensions "for all users" (shared) or "only for me" (user). Normal users without those
privileges can install, remove, or modify extensions only for their own use (user).

Figure 13: Dialog showing the installation choices
5) The extension begins installing.
6) In all three cases, during the process you may be asked to accept a license agreement.
When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip

To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online link. You do not need to
download them separately.

Figure 14: Using the Extension Manager
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