Difference between revisions of "ReleaseNotes/3.5/fr"

From The Document Foundation Wiki
Jump to: navigation, search
(Writer)
(Writer)
Line 58: Line 58:
 
[[Image:New_Grammar_Checking_dlg.png| 350px]]
 
[[Image:New_Grammar_Checking_dlg.png| 350px]]
  
* Les tables des matières ont désormais des hyperliens par défaut (Cédric Bosdonnat)
+
* Les tables des matières contiennent désormais par défaut les hyperliens vers les pages concernées. (Cédric Bosdonnat)
  
 
== Calc ==
 
== Calc ==

Revision as of 2011-12-08T13:05:49

Nouveautés de LibreOffice 3.5

A propos de cette page

Il s'agit d'un brouillon des travaux en cours, qui servira à construire les notes de version lors de la sortie. Veuillez ne pas lister ici de fonctionnalités déjà incluses dans la version 3.4 !

A quoi doit ressembler une bonne fonctionnalité ici :

  • Elle possède une description, ainsi qu'une manière, pour le lecteur novice, de trouver et de jouer avec cette nouvelle fonctionnalité. Visez une personne à moitié endormie, qui ne connait quasiment rien du produit. Ainsi, s'il s'agit d'un nouvel élément de l'interface utilisateur, soyez très explicite sur sa localisation (par exemple, Menu->Format->Caractères->Position[onglet]->"90 degrés" conduit aux éléments modifiés). Bien entendu, vous jugez votre fonctionnalité importante, et pensez que tout le monde devrait être attentif au "dialogue des propriétés des Formes Automatiques extensibles" - mais souvent les types qui prennent les aperçus d'écran et qui écrivent les notes ne le sont pas.
  • Elle crédite les auteurs principaux - ajoutez-les simplement entre parenthèses à la suite de la fonction, où vous pouvez.
  • Si la fonctionnalité peut être présentée grâce à un fichier exemple / test - particulièrement pour les nouvelles fonctions d'importation, il serait fantastique d'avoir un lien vers ce fichier de test, utilisable pour mettre en valeur au maximum la fonction. C'est une aide appréciable pour faire de bons aperçus d'écran, et permet aux testeurs de bien faire leurs tests.

Merci par avance pour votre participation au remplissage de cette page !

Writer

  • Affichage des caractères non-imprimables en fin de ligne. Maintenant, modifier les espaces en fin de ligne est très simple. (Bartosz Kosiorek)

Affichage des espaces en fin de ligne

  • Nouveaux types de numérotation (Mohammad Elahi)
  1. mots perses : ‫یک، دو، سه ...‬
  2. séquence de lettres abjad Arabe : ‫ا، ب، ج ...‬


  • Affichage de la résolution des images bitmap en pixels par pouce (PPI: pixel/inch) dans Format - Image - onglet Rogner. (László Németh)

Ppi.png

  • Interface de gestion des en-têtes et pieds de page améliorée (Cédric Bosdonnat)
    • Ajout des en-têtes ou pieds de page facilité
    • Visualisation immédiate de ce qui est modifié (nouvelles limites de la zone de texte)
    • Modification / Suppression rapide des en-têtes et pieds de page sans naviguer dans les styles de page.

Copie d'écran du nouvel indicateur En-tête/Pied de page

  • Indicateur de saut de page amélioré (Cédric Bosdonnat)
  • Le dialogue Outils > Statistiques devient non modal et se met à jour au fur et à mesure de la saisie (Matt Pratt).
  • L'AutoTexte "Numérotation de formule" (fn+F3) a été corrigé pour la plupart des environnements linguistiques : l'espace surnuméraire après la formule a disparu, la police de la formule insérée suit la police par défaut (fdo#40499, i#75665). Taper fn+F3 ou nf+F3 en fonction de votre environnement. (Laurent BP, Caolán McNamara)
  • Dialogue Imprimer : la zone de saisie "Pages" affiche désormais par défaut le numéro de page en cours. fdo#34697 (Ta Duc Tung)
  • Corrections de mise en page (Cédric Bosdonnat)
    • Quand un taquet de tabulation est posé après la marge de fin, la tabulation utilise cette valeur et ne crée plus une nouvelle ligne. Une option de compatibilité a été ajoutée, ainsi ce comportement n'affecte que les nouveaux documents.
    • Lors de l'import de fichiers doc, docx and RTF, les numérotations ne sont pas découpées sur de nouvelles lignes si elles ne tiennent pas dans les marges. Ceci uniquement pour la compatibilité de mise en page avec Word.
  • Améliorations de la vérification grammaticale (Cédric Bosdonnat)
    • Dialogue retravaillé pour un meilleur affichage du message d'erreur.
    • Les correcteurs grammaticaux peuvent maintenant ajouter un URL optionnel pour donner plus de détails sur l'erreur dans SingleProofreadingError::aProperties. La propriété doit être nommée FullCommentURL. Ce lien apparaît dans zone détail du dialogue de vérification grammaticale et comme un item "Explications..." dans le menu contextuel.

New Grammar Checking dlg.png

  • Les tables des matières contiennent désormais par défaut les hyperliens vers les pages concernées. (Cédric Bosdonnat)

Calc

  • Prise en charge de 32000 feuilles et performances améliorées pour un grand nombre d'opérations de feuilles (l'insertion de plusieurs feuilles devrait être bien plus rapide maintenant). (Markus Mohrhard)
  • Prise en charge améliorée de l'échec des liens DDE et externes. Au lieu de transformer les formules dont les liens ne sont pas mis à jour en erreur, les valeurs précédentes sont conservées et il s'affiche un message d'erreur indiquant à l'utilisateur que la mise à jour des liens a échoué. (Kohei Yoshida)
  • Le lissage des lignes de diagramme a été mis à jour sur le standard ODF1.2 (Regina Henschel)
Les lignes fermées qui sont lissées en utilisant une "spline cubique" sont maintenant complètement rondes
Les lignes ouvertes et closes qui sont lissées en utilisant une “Spline-B” va maintenant à travers les points donnés, interpolant entre eux.
  • Nouvelle option permettant de spécifier le nombre initial de feuilles dans les nouveaux documents. (Albert Thuswaldner)

Calc's new Defaults options page.

  • Collage d'une cellule dans une plage multiple autorisé. Il subsiste toutefois quelques restrictions. (Kohei Yoshida)
  • Nouvelles fonctions BITAND, BITOR, BITXOR BITRSHIFT and BITLSHIFT, cf. les spécifications ODF 1.2. (Wolfgang Pechlaner)
  • Ajout de nouveaux symboles pour les points de données dans les diagrammes, cf. les 'standard markers' de la spécification ODF1.2. La correspondance des points pour les graphiques des fichiers xls est changée dans le cas où une meilleure correspondance est désormais possible. (Regina Henschel)

List of all available standard markers

  • La palette standard est enrichie de quelques nouvelles extrémités de ligne, pour la plupart non remplies. Certaines sont utiles pour les diagrammes UML. Les nouveaux symboles sont conçus pour s'adapter au mieux aux lignes de 0,02cm et aux points de 0,3cm. Seule l'extrémité "demi-cercle vide" est conçue pour les points de 0,45cm, afin qu'elle puisse entourer un cercle rempli comme le symbole 'interface' le nécessite. La largeur de la ligne de l'extrémité s'adapte avec celle de la ligne ou du point. (Regina Henschel)

Nouvelles extrémités de ligne

  • Protéger une feuille est désormais accessible depuis l'onglet de la feuille (Olivier Hallot)

Protection de feuille accessible depuis l'onglet

  • La boîte combinée de l'AutoFiltre a été reconçue pour une meilleure présentation et autoriser les sélections multiples. Cf. ce billet de ce blog pour plus d'information. (Kohei Yoshida)

Nouvelle boîte combinée de l'AutoFiltre

Performance

  • Amélioration des performances dans l'import de documents Excel contenant un grand nombre de contrôles de formulaire. (Kohei Yoshida)
  • Amélioration des performances dans l'import des formats de cellule de documents Excel. (Kohei Yoshida)
  • Amélioration des performances lors de l'import ODS, particulièrement pour les documents comprenant un grand nombre de zones nommées. (Laurent Godard, Markus Mohrhard, Kohei Yoshida)

Impress / Draw

  • Arcs elliptiques dans les chemins
Jusqu'à maintenant les arcs elliptiques dans les chemins étaient ignorés par LibreOffice et OpenOffice.org. Avec la version 3.5 ces arcs seront correctement importés et rendus.
  • Meilleure gestion des listes d'animation personnalisée
Il était auparavant pénible de travailler sur une liste d'animation personnalisée car le moindre changement provoquait le rafraîchissement au début de la liste. Avec la version 3.5, nous défilons depuis l'animation nouvellement ajoutée, nous restons sur les items quand ils ont été déplacés vers le haut ou le bas dans la liste, et gardons visibles les animations lors de la modification de leurs propriétés. (Luke Symes)
  • Gestion des palettes incorporées et d'autres types de liste de propriétés
Auparavant, nous aurions dû stocker dans le document un lien vers le système de fichiers local pointant sur une de nos listes de propriétés (une palette de couleurs, par exemple). Nous avons ajouté la possibilité (sélective) de les intégrer à l'intérieur du conteneur ODF (Michael Meeks)
copie d'écran
Case à cocher Embed (incorporer)


  • Démarrer par défaut Impress sans l'assistant.
L'assistant peut être lancé manuellement depuis le menu "Fichier -> Assistants -> Présentation" et il peut être réactivé au démarrage via "Outils -> Options -> Impress -> Général -> Démarrer avec l'assistant". (Tim Hardeck)

Math

  • Nouveau symbole "N'existe pas" (Julien Nabet)
  • Nouveaux symboles pour la théorie des jeux (Olivier Hallot)

Math nouveaux symboles théorie des jeux.


Filtres

  • Filtre d'import pour les documents MS Visio
DNetwork.vsd dans Visio
DNetwork.vsd dans LibreOffice Draw
OrgChart.vsd dans Visio
OrgChart.vsd dans LibreOffice Draw
Calendar.vsd dans Visio
Calendar.vsd dans LibreOffice Draw
  • Réécriture de l'import Writer RTF, voir ici pour les détails (Miklos Vajna)
  • Amélioration de plusieurs import DOCX voir ici pour les détails (Miklos Vajna)

Changements du noyau

Interface graphique (GUI)

  • Le sélecteur de couleur, accessible par ex. dans Outils -> Options -> Couleurs, puis clic sur Edition, a été réécrit pour être plus moderne et plus pratique. La vidéo suivante montre comment ça marche : http://www.youtube.com/watch?v=rPu6EmIxkIM&hd=1 [Christian Lippka]
  • Les entrées de barre d'outils non utilisées ont été supprimées des barres d'outils et l'indication qu'il y a des éléments masqués a été actualisée pour être plus jolie, voir une descriptions plus complète et des copies d'écran (Jan Holesovsky)
  • Le paramétrage des couleurs de l'application (Outils -> Options -> LibreOffice -> Apparence) présente un aperçu correct pour les couleurs 'Automatique' dans les listes déroulantes.
  • Tri "Naturel" : Les menus listent leurs entrées dans un ordre naturel. i.e. "Titre 10" apparaît désormais directement après "Titre 9" et non plus immédiatement après "Titre 1". Voir les copies d'écran avant et après. Exemples tirés de Writer > Format > Styles et formatage. (Sébastien Le Ray)
  • Ajout d'un bouton Scan au dialogue Scanner (copie d'écran). (Rob Snelders)
  • Nettoyage substantiel et re-factorisation des backends vcl unix : ajout portage initial pour gtk3, and donc via Broadway d'un prototype web office (Michael Meeks, Lucas Baudin, Caolan McNamara, Cosimo Cecchi)
  • Ajout de nouvelles poignées : la distinction entre "Modern" et "Simple" a été supprimée (Tim Hardeck, Michael Meeks), de nouvelles poignées utilisant les couleurs Tango ont été produites, utilisant la transparence alpha pour améliorer l'ergonomie. (Astron)

35newhandles.png

  • Déplacement des barres d'outils contextuelles en bas d'écran pour éviter qu'elles ne masquent des parties importantes du document. (Tim Hardeck)

Performance

  • De grandes quantités de code "mort" supprimées, réduisant ainsi la taille du code (Caolan McNamara, Joseph Powers)
  • Nettoyage de l'héritage des filtres de formats de fichiers binaires pour supprimer les non-utilisés (Joseph Powers)

Autres

  • Police Liberation désormais dans les builds windows [1]
  • LibreOffice utilisera désormais *la plus récente* Berkeley DB installée sur le système (au moment de la compilation), et non pas la plus ancienne. (Lionel Elie Mamane)
  • LibreOffice acceptera désormais d'utiliser un Java qui serait un lien symbolique (Lionel Elie Mamane, d'après un patch Debian/oo-build)

Scripting

  • Python UNO: Il est désormais possible d'initialiser par nom les membres d'une structure UNO, et non plus seulement par position. Par exemple:
from com.sun.star.util import Date
d1 = Date(Year=2004, Month=11, Day=2)
d2 = Date(Day=2, Year=2007, Month=5)

Comparé à l'initialisation par position:

from com.sun.star.util import Date
d1 = Date(2, 11, 2004)
d2 = Date(2, 5, 2007)
  • Messages d'erreur améliorés en cas d'échec au chargement du bridge Python UNO (Lionel Elie Mamane)

Nettoyage du code

Traduction