Design/Meetings/2021-02-03

From The Document Foundation Wiki
Jump to navigation Jump to search

Link

https://listarchives.libreoffice.org/global/design/2021/msg00013.html

Minutes

Present: Heiko
Comments: Sascha, Mike, Regina, John, Seth, Telesto, Dieter, Eike

Tickets/Topic

 * UI: Footnotes and endnote settings has no reset button
   + https://bugs.documentfoundation.org/show_bug.cgi?id=139712
   + seems to be a global option and effective across sessions
   + could enhance workflow, but
   + first Bug 128469 (terminology of Reset/Standard) has to be solved
     for naming convention (Sascha)
   + don't see the benefit, Reset becomes "Set to Parent" and works only
     with hierarchically organized data; F&E is kind of global option and
     would fit tools > options > writer
   + if we add Reset it will behave as reset to factory settings and
     rather add confusion than making dialogs more consistent
   => comment

 * UI Footnote/endnote settings dialog caption
   + https://bugs.documentfoundation.org/show_bug.cgi?id=139713
   + dialog has other label then menu entry, slash bad practice for
     titles (Sascha)
   + suggest naming dialog and menu entry to "Foot- and Endnotes..." (Sascha)
   + yes to "Footnotes and Endnotes Settings" but no to properties since
     this dialog works similar to tools > options (Heiko)
   => comment

 * "Links to External Files" is not precise
   + https://bugs.documentfoundation.org/show_bug.cgi?id=139735
   + "External Links..." or "Links to External Data..." (Mike)
   + "External Links" bad naming, links itself aren't external (Sascha)
   + suggest "Externally Linked..." or "Linked Data and Files..." (Sascha)
   + +1 to "Links to External Data..." (too much
   + Calc: .uno:InsertExternalDataSource "Link to E~xternal Data..."
+ Draw/Impress: .uno:ManageLinks "Lin~ks to External Files..."
   + Writer: .uno:LinkDialog "Lin~ks to External Files..."
     + cui/uiconfig/ui/baselinksdialog.ui is titled "Edit Links"
   + streams are rather a corner case for Writer and DrawImpress
   + if "data" is read similar to "file" we should harmonize acc. Calc

+ documentation under https://help.libreoffice.org/7.0/en-US/text/shared/01/02180000.html is outdated

   => comment

 * Paragraph/Character Style Dialog: "Reset" and "Standard"
   buttons have confusing labels
   + https://bugs.documentfoundation.org/show_bug.cgi?id=128469
   + suggest "Reset Tab" and "Reset to Parent" but probably to long
     labels (Sascha)
   + Reset -> Revert, Unapply, Undo, Clear, Undo Unsaved Changes, Undo Tab
     + keep Reset since it's used in different context
   + Standard -> Reset, Default, Parent, Original, Inherited,
     Reset Tab to Parent, Reset Tab, Re/Set to Parent
     + "Reset" for "Standard" adds confusion (Regina)
   + remove Reset
     + works nicely with Apply (John)
   + both apply to the current tab only (Apply works on all tabs)
   + ideally we have a true "Reset" button, which works as Undo for Apply, and
     a "Standard" that reverts everything to the default (pretty difficult for
     hierarchical content)
   => simplicity first, short terms, long and informative tooltips

 * The behavior of the border picker is sometimes off
   + https://bugs.documentfoundation.org/show_bug.cgi?id=139838
   + see also https://bugs.documentfoundation.org/show_bug.cgi?id=139094
   + keep makes no sense in many cases, e.g. edit single cell, column, row
   + consistent behavior would be: init off>on>off; init partial>on all>off
     all (Sascha)
   + bike-shedding to me, don't see the benefit of keep either but there is
     likely one (Heiko)
   => comment

 * UI - Find in Calc fails when a formula refers to a cell in
   another sheet's pivot table
   + https://bugs.documentfoundation.org/show_bug.cgi?id=134724
   + expect quick find to search content instead of display values (Eike)
   + default search should be values (for Benjamin), option for formulas given
     (for Eve) (Sascha)
   + maybe rename "Values" into "Values and Results" (Sascha)
   + simply find both, Values/Results, Content and Notes (Heiko)
     + otherwise I vote for an option
   => comment