Domande frequenti - Base

From The Document Foundation Wiki
< Faq‎ | Base
Jump to: navigation, search
This page is a translated version of the page Faq/Base/143 and the translation is 100% complete.

Other languages:
dansk • ‎Deutsch • ‎English • ‎français • ‎italiano


Come collegare (allegare) tabelle di formato di testo in un database HSQL?

Esiste un file di testo (.Txt, .Csv) che si desidera collegare a un database LibreOffice (formato predefinito HSQL). Questo file può essere modificato al di fuori di LibreOffice. Questo può essere ad esempio un file generato da un'applicazione. Vogliamo, non importarlo in un database (che produce un risultato non dinamico), ma collegarlo, collegarlo per poter riflettere le modifiche.

Il principio è creare una tabella in formato testo che definisce la struttura, quindi collegarsi al file sorgente. L'interfaccia non consente di eseguire "graficamente" questo tipo di funzionalità. Dobbiamo usare il menu Tools ▸ SQL. A parte questo, la tabella verrà utilizzata come un'altra tabella. Può essere utilizzato in particolare in join con tabelle standard HSQL.

In questo esempio creiamo una tabella con un valore ID (INTEGER) auto-valore, un campo di testo (VARCHAR), un campo data (DATE) e un campo numerico (NUMERIC).

Il set di dati corrispondente (test.csv) sarà:

1; Prodotto uno; 2008-07-01; 23.10
2; Prodotto due; 2008-07-02; 15.50
3; Prodotto tre; 2008-07-03; 11
4; Prodotto quattro; 2008-07-04; 13.50

Come creare la tabella

  • Aprite la tabella HSQL
  • Eseguite Strumenti ▸ SQL
  • Digitate il seguente codice SQL nella zona Comando da eseguire quindi fate clic su Esegui
-- Solo da Strumenti> SQL
CREATE TEXT TABLE  "NomTableLiaison" ("ID" INTEGER GENERATED BY DEFAULT AS IDENTITY, "NomProduit" VARCHAR(50), "DateDebut" Date, "Nombre" NUMERIC)
SET TABLE "NomTableLiaison" SOURCE "test.csv;fs=\semi"

Note

  • Il file "test.csv" è archiviato nella stessa cartella del database.
  • L'elenco delle tabelle non viene aggiornato automaticamente, eseguite il comando Visualizza ▸ Aggiorna tabelle (abilitato solo quando vengono visualizzati gli oggetti "Tabelle").

Se si desidera modificare qualcosa all'apertura del database, è possibile disconnettere la tabella dal file di origine utilizzando il comando:

-- Only with Tools> SQL
SET TABLE "NomTableLiaison" SOURCE OFF

La riconnessione avverrà con il comando:

-- Only with Tools> SQL
SET TABLE "NomTableLiaison" SOURCE ON