Faq/Calc/139/da

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 139
Jump to: navigation, search

Hvordan indsætter jeg en fast dato eller et fast klokkeslæt?

Problem

Funktionerne IDAG() og NU() beregner aktuel dato og klokkeslæt automatisk, men disse værdier genberegnes pr. definition og er ikke faste.

Indsæt med tastaturet

Den enkleste og hurtigste løsning er at bruge standard tastaturgenveje:

  • Ctrl+; for at indsætte dato
  • ⇧ Shift+Ctrl+; for at indsætte klokkeslættet

I begge tilfælde er værdi i cellen i formatet dd/mm/yyyy hh:mm:ss. Det anvendte standardformat er henholdsvis dd/mm/yy for datoen og hh:mm:ss, når kun den valgte del vises.

Indsæt med musen

Der er to muligheder: opret en rulleliste i cellen er brug en kalender-kontrol.

  • Rulleliste
    1. Markér den relevante celle eller celleområdet og gå til Data ▸ Valider
    2. På fanebladet Kriterier i rullelisten Tillad vælger du Celleområde
    3. I feltet Kilde skriver du TEKST(IDAG();DD/MM/YY)

Formlen IDAG() returnerer det tal, der svarer til antallet af dage siden udgangsdatoen. Formlen TEKST() præsenterer dette tal i det ønskede format. Brugeren kan indsætte datoen med et museklik:

screenshot of Data Validity
Indsæt datoen med et klik på listen
  • Kontrolelementet Kalender

Få vist værktøjslinjen Formularkontrolelementer På denne værktøjslinje klikker du på Flere kontrolelementer og på denne nye værktøjslinje vælger du så værktøjet Datofelt

toolbars screenshot
Menuen Vis > værktøjslinjer til valg af værktøjslinjen Formularkontrolelementer
  1. Tegn kontrolelementet
  2. Højreklik på det og vælg Kontrolegenskab for at se dets egenskaber
  3. På fanebladet Generelt definerer du egenskaben Rulleliste til Ja
  4. På værktøjslinjen Formularkontrolelementer vælger du den anden knap fra venstre Skift designtilstand

Fra nu af ser du en kalender, når du klikker på pilen for at rulle gennem kontrolelementet.

screenshot of Date control
Klik på pilen for at få vist kalenderen

OBS:

  • Kalender-inputtet indsættes ikke i en celle .
  • Der er et kontrolelement ved navn Time, men det ruller ikke som kontrolelementet Dato. Derfor tillader det ikke, at det aktuelle tidspunkt (timen) med et museklik

Indsæt en tidsstemplingssformel

I dette eksempel indskrives formlen i celle A1 og benytter et gentaget henvisning til celle B1.

Formater celle A1 til det ønskede dataformat.

Fra Standardmenuen vælger du Funktioner ▸ Indstillinger ▸ LibreOffice Calc ▸ Beregn

screenshot of Calculate Options
Klik for at aktivere feltet Gentagelser og indstille Trin til 1 (én)

Klik for at aktivere feltet Gentagelser og indstille Trin til 1 (én).

I celle A1 skriver du formlen =HVIS(B1<>"",HVIS(A1="",NU(),A1),"")

Skriv data i celle B1 og celle A1 vil vise tidstemplet

OBS:

  • Redigering eller ændring af indholdet i celle B1 på senere tidspunkt vil automatisk opdatere tidsstemplet i celle A1.