Domande frequenti - Writer

From The Document Foundation Wiki
< Faq‎ | Writer
Jump to: navigation, search
This page is a translated version of the page Faq/Writer/144 and the translation is 100% complete.

Other languages:
dansk • ‎English • ‎français • ‎italiano

Come evitare la stampa di alcuni oggetti

Scegliere il tipo di oggetti da stampare

  • Dal menu Strumenti ▸ Opzioni ▸ LibreOffice Writer ▸ Stampa ▸ Contenuto potete scegliere il tipo di oggetti che desiderate stampare:


screenshot of the writer printing options
Menu Strumenti ▸ Opzioni ▸ LibreOffice Writer ▸ Stampa ▸ Contenuto


  • Le impostazioni di stampa definite in questa pagina sono applicate a tutte le stampe successive fino a che non le cambiate.
  • Se desiderate che le modifiche impostate valgano solo per corrente sessione di stampa, usate l'opzione dal menu File ▸ Stampa ▸ LibreOffice Writer [scheda].

Scegliere gli oggetti da stampare

Le opzioni disponibili a livello globale o durante la stampa consentono di scegliere se includere immagini e oggetti di disegno durante la stampa, ma non di scegliere alcuni oggetti da stampare mentre rifiutarne altri.

Il metodo da utilizzare a questo scopo dipende dal fatto che siano coinvolte immagini o oggetti di disegno.

  • Le immagini hanno una proprietà Stampa: fate clic con il pulsante destro del mouse sull'immagine e quindi scegliete Immagine (o selezionate l'immagine e quindi scegliete Formato ▸ Immagine ▸ Opzioni [scheda] e deselezionate Stampa.
  • Gli oggetti di disegno non hanno questa proprietà. Per risolvere il problema, inserire una sezione nel documento e ancorare il disegno a questa sezione:
    • è possibile inserire una sezione in una cornice
    • le sezioni possono essere nascoste su richiesta tramite Formato ▸ Sezione


screenshot of the Format Section dialog
Nascondere una sezione tramite Formato ▸ Sezione

Automatizzare il passaggio dalla stampa alla non stampa di un oggetto

Come mostra lo screenshot sopra, le sezioni possono essere nascoste condizionatamente. È possibile automatizzare il passaggio tra Mostra e Nascondi inserendo una variabile [1] nel documento.

La creazione e l'inserimento della variabile vengono eseguite tramite Inserisci ▸ Campi ▸ Altri ▸ Variabili [scheda]. Scegliete Imposta variabile, assegnategli un nome (ad esempio Nascondi) e un valore VERO o FALSO e selezionate invisibile, quindi inserirlo nel documento. Un piccolo rettangolo grigio apparirà sulla pagina per contrassegnare il campo.

  • un doppio clic sul campo
  • posizionando il cursore immediatamente prima del campo, quindi Modifica ▸ Campi
  • tramite un campo di input nel documento
    • Nell'esempio seguente, una variabile denominata Nascondi è stata inserita in modo invisibile all'inizio del documento. Per facilitare la lettura, viene inserito in formato testo.
    • Un campo di input per questa variabile è inserito nel paragrafo "fate clic qui" ; è sufficiente inserire VERO' o FALSO
    • La prima tabella viene inserita in una sezione nascosta in modo condizionale; pertanto l'intera sezione è nascosta
    • La seconda tabella include un frame in A2. In questo riquadro viene inserita una sezione nascosta, che verrà nascosta in base alla stessa condizione; quindi questa è solo la cornice nascosta.


screen shot of the dialog for entering the field
Passa da Mostra/Nascondi immettendo una variabile

Note:

  1. Variabili associando un nome (il nome dato alla variabile) con un valore o un oggetto. Questo valore può cambiare, quindi il nome, e i campi variabili consentono di aggiungere contenuto dinamico al documento.