Translations:QA/BugReport/25/ru

From The Document Foundation Wiki
Jump to navigation Jump to search

Раздел Severity можно проигнорировать. Выбор Blocker не сделает решение проблемы более быстрым. Если вам интересно знать значения элементов этого списка, смотрите эту схему и критерии выпуска.

Описание (Description)

В поле Summary:

  • Не включайте информацию из предыдущих полей.
  • Включите в это поле название субкомпонента из Компонентов.
    • Название субкомпонента указывайте в верхнем регистре.
    • Если имя субкомпонента может быть спутано с частью слова (для примера, UI часть слова quit), заключите его в квадратные скобки ([UI]).
    • Не используйте более двух субкомпонентов.
    • Вы можете сочетать компоненты в поле Subject, но используйте названия субкомпонентов точно идентичные написанию(например, "WIKIHELP [UI] not available in all languages").
  • Постарайтесь изложить проблему кратно, но точно.
    • Плохой пример: "File is broken" ("Файл сломан")
    • Хороший пример: "Menu File > Save as not available (greyed out)" ("Меню Файл -> Сохранить как... не доступен (отображается серым цветом")
  • Избегайте коротких форм таких, как "doesn't" или "isn't". Такие формы затрудняют запросы для поиска по Summary. Вместо них используйте полные формы "does not" или "is not".
  • Если отчет об ошибке связан с некорректным завершением приложения LibreOffice или оно перестаёт отвечать(зависает), добавьте слово CRASH в поле Summary - это позволяет проще отследить появление таких ошибок на Bugzilla.

В поле Possible Duplicates: (Возможные дубликаты) автоматически делается выборка похожих ошибок. Проверьте не указана ли ваша ошибка в этим списке. Дополнительно проверьте список в Таблице Дубликатов, чтобы не создавать дублирующий отчет об ошибке. (Если вы нашли отчет об ошибке с вашей проблемой, не создавайте нового. Просто оставьте комментарий с дополнительной информацией, в уже существующем.) В поле "Description" укажите полное описание проблемы.

  • Используйте пронумерованный список для последовательности шагов.
  • Объясните что вы сделали. Например, вместо того, чтобы писать: "Open document" ("Открыть документ"), опишите действия полностью: "In new empty LibO Spreadsheet document, use menu File > Open (LibO dialog) > file type "Text documents" > select attached sample document > double click" ("В новом пустом документе электронных таблиц LibreOffice, использовать меню Файл > Открыть (Диалог LibreOffice) > тип файла Текстовый документ > выберите прилагаемый текстовый документ > двойной щелчок по документу левой кнопкой мыши")
  • Если используете заранее подготовленные пакеты для установки в Linux, не забудьте сказать точную версию пакетов согласно вашему пакетному менеджеру. Для Windows укажите полное имя файла программы установки и откуда он был вами скачан.
  • Укажите информацию об установленной и используемой локализации (язык пользовательского интерфейса, язык документа). Это может оказаться полезным.
  • Если вы используете 32-битную версию LibreOffice на 64-битной операционной системе, пожалуйста, не забудьте это указать.
  • Если это не официальная сборка LibreOffice, укажите источник пакетов.
  • Опишите ожидаемое и текущее поведение.

Вы можете также прикрепить к отчету скриншот, образец документа или лог работы с отладочными символами⁠Wikipedia logo v3.svg.

  • Если вы на скриншоте не пытаетесь показать особенности национальной локализации, создавайте скриншот находясь в английском интерфейсе. Перейти в английский интерфейс можно в Сервис ▸ Параметры... ▸ Настройки языка ▸ Язаки в разделе Язык, Пользовательский интерфейс. После выбора языка потребуется перезагрузка приложения.
  • Скриншоты можно сделать более информативными, добавив комментарии и выделив места, на которые вы хотите обратить внимание.
  • Если вы хотите прикрепить более одного скриншота, соберите их в один документ, например, в формате PDF. Пожалуйста, не забудьте добавить комментарии к каждому скриншоту.
  • Если вы хотите добавить более одного документа (например, скриншот и лог выполнения программы), соберите их в один архив (лучше, если это будет zip-формат) и уже этот архив прикрепляйте к сообщению.
  • Если вам необходимо прикрепить файл большого размера (больше чем 1 MB) на Bugzilla, воспользуйтесь ownCloud.