Rubrique générale - Étape 2

From The Document Foundation Wiki
Jump to: navigation, search
Environnement LibreOffice Module O Étape 2
Étape 2 Objectif opérationnel
Les barres d'outils
Durée : 1h00
Prendre connaissance des barres d'outils et de défilement
Fonctions mises en oeuvre QCM
  • La barre des menus
  • Les barres d'outils
  • La barre d'état
  1. Est-il possible de modifier le zoom et la disposition des pages à partir de la barre d'état ?
  2. Existe-t-il une différence entre infobulle et infoballon ?
  3. La barre Standard représente-t-elle un raccourci vers les menus ?

Après avoir visité notre espace de travail et les éléments qui l'entourent, examinons maintenant les différents outils que nous avons à porté de main pour réaliser nos travaux. Ceux-ci sont répartis sur des barres organisées tout autour de l'espace principal de travail.

Les barres d'outils

Plusieurs barres entourent l'écran

  • La barre des menus

G1S2 1.png

  • La barre Standard

G1S2 2.png

  • La barre Formatage

G1S2 3.png

  • La barre d'état

G1S2 4.png

Nous allons détailler ces barres et leur fonctions car elles nous seront très utiles tout au long de notre travail.

La barre des menus

Sous Writer, cette barre regroupe pratiquement toutes les fonctions du traitement de texte, de même celle sous Calc regroupe pratiquement toutes les fonctions du tableur. Ces menus sont regroupés en catégorie d’actions ou de thèmes (ex : le menu Insérer regroupe tout ce qu’il est possible d’insérer dans un document). Parfois, une entrée de menu cache d’autres entrées de menus, qui peuvent elles aussi cacher d’autres entrées de menus. Elles sont en général notées ainsi : Insérer ▸ Images ▸ Scanner ▸ Sélectionner la source.

G1S2 5.png

Une entrée suivie de points de suspension indique l’ouverture d’une fenêtre de dialogue, exemple : Format ▸ Caractères... ouvrira la boîte de dialogue de formatage de caractères. S’il n’y a pas de points de suspension, l’action est directement effectuée dans le document. Exemple : Éditer ▸ Coller, collera le contenu du presse papier à l’endroit où se trouve le curseur.

La barre Standard

Cette barre regroupe sous forme d’icônes une partie des fonctionnalités que vous retrouvez dans la barre des menus. Ces sont des raccourcis, en quelque sorte, vers les fonctions les plus utilisées. Si vous ne savez pas à quoi correspond une icône, vous pouvez activer les infobulles, une petite étiquette apparaîtra alors pendant quelques secondes lorsque vous laissez le curseur sur l’icône.

G1S2 6.png

Pour activer ces infobulles :

  1. Dans le menu Outils, sélectionnez Options,
  2. Dans la fenêtre qui s'ouvre, cliquez sur la petite croix devant LibreOffice pour déployer son arborescence et sélectionnez sur Général
  3. Dans la partie droite, cliquez sur la case à cocher Infobulles pour activer les étiquettes des icônes. Si vous activez également la case à cocher Infoballons, un texte explicatif de l’icône ou de la fonctionnalité s’affichera quelques instants lorsque vous laissez le pointeur de la souris sur l’icône ou le menu. Enfin, vous pouvez activer ponctuellement les infoballons en utilisant la combinaison de touches Maj+F1

Dans cette barre, les icônes munies d’une petite flèche à droite, comme celle pour ouvrir un nouveau document, indique un menu déroulant ou des icônes complémentaires ou encore une palette de couleurs. Cliquez sur la petite flèche pour les afficher. Bien sûr, vous apprendrez à vous servir de toutes ces icônes (et plus encore !) au fur et à mesure de l’avancement de votre formation.

La barre Formatage

Si la barre des menus et la barre Standard sont des barres que vous retrouverez dans tous les modules de LibreOffice, la barre de formatage, elle, est contextuelle à Writer. Sous Calc, elle s’appelle également barre Formatage, mais comme vous pouvez le voir, certaines icônes sont différentes puisqu’elles ont trait au formatage de cellules. Il en sera de même sous Impress.

G1S2 7.png

Cette barre contient donc des commandes de formatage du texte et reprend la plupart des fonctions du menu Format. Elle comporte en outre trois listes déroulantes permettant d’appliquer un style, de modifier la police ou sa taille. Enfin certaines icônes cachent en fait des palettes de couleurs lorsque vous les déployez.

Lorsque vous activez la numérotation ou les puces, une nouvelle barre apparaît. Il s’agit de la barre Puces et Numérotation qui a un comportement contextuel : elle s’active lorsque la fonction correspondante est activée. Il en sera donc de même pour la barre des tableaux, ou encore de cadres, d’images, de dessin... Si vous souhaitez activer ces barres en dehors de leur contextualité, ou si vous les avez fermées par inadvertance, rendez-vous dans le menu Affichage > Barres d’outils et sélectionnez celle que vous voulez afficher.

La barre d'état

Cette barre, sans en avoir l’air, contient en fait une foule d’informations et de fonctionnalités. Bien cachées, certes !

G1S2 4.png

La première partie à gauche indique le nombre de page et le numéro de page à l’écran, il peut en effet être parfois différent si vous avez modifié la numérotation. Si vous avez inséré des repères de texte, un clic avec le bouton droit sur ce numéro de page affichera la liste des repères et la sélection de l’un d’entre eux positionnera le curseur directement dessus. Un double clic quant à lui affichera le Navigateur.

G1S2 8.png

Le cadre suivant indique le style de page en cours. Un clic avec le bouton droit sur le nom du style en cours affichera un menu listant tous les styles de pages disponibles. Un double clic ouvrira la boîte de dialogue de formatage du style de pages.

G1S2 9.png

À la suite est indiquée la langue actuelle du texte et donc le correcteur orthographique qui sera utilisé (s'il est présent bien sûr). Si vous faites un clic sur la langue, vous pourrez désactiver ce correcteur, ou choisir une autre langue pour activer un autre correcteur.

G1S2 10.png

La petite case INS réagit comme un bouton à bascule à partir du clic. Que fait-elle ? Elle détermine le mode de saisie : INS insère le texte parmi celui qui est déjà présent dans la page en repoussant les caractères, RFP ou mode refrappe, viendra se substituer au texte déjà présent, écrasant les caractères déjà saisis.

La case STD se modifiera en EXT après un clic et en AJT après un autre clic et enfin BLC après encore un autre clic. Il s’agit de la modification de la sélection :

  • STD correspond à standard, un mode de sélection normal
  • EXT correspond à Extended et étend la sélection : tout ce qui est compris entre la première position du curseur et le clic que vous faites après avoir affiché EXT sera sélectionné.
  • AJT qui correspond à Ajouter permet de faire des sélections disjointes : sélectionnez un mot, affichez AJT et cliquez sur les autres mots dans le texte qui doivent appartenir à la sélection.
  • BLC qui correspond à Bloc, permet de réaliser une sélection sans tenir compte des fins de ligne, on peut ainsi sélectionner un bloc de caractères ou réaliser une sélection rectangulaire.

La case suivante affiche un point d'exclamation, ou rien du tout, la présence de ce point d'exclamaton indique que le document a été modifié depuis son dernier enregistrement. Suit à nouveau une petite case, vide la plupart du temps sauf lorsque le document est signé numériquement, l’icône cochée apparaît alors ici.

Enfin, le dernier espace affiche des informations contextuelles sur le document :

  • si le curseur est positionné dans un tableau, la référence de la cellule, le nom du tableau et son état, protégé ou non, apparaîtront,
  • si le curseur est dans une liste à puce ou une numérotation, c’est alors le niveau hiérarchique de la puce ou de la numérotation qui apparaîtra,
  • si le curseur est positionné dans une section, le nom de la section sera indiqué et son état (masqué ou non).

Si le curseur est positionné dans une liste, c'est la fenêtre de formatage des puces et numérotations qui s'ouvrira par un double clic dans cet espace de la barre d'état. Si le curseur est positionné dans un tableau, un double clic dans le même espace ouvrira alors la barre de formatage des tableaux. S'il est positionné dans une section, c'est dont la fenêtre de formatage des sections qui s'ouvrira lors du double clic. Enfin si le curseur est positionné dans un texte normal, c'est la fenêtre de dialogue de champs qui s'ouvrira.

Le cadre qui vient ensuite et qui contient une miniature de disposition de la page permet de modifier la disposition de l'affichage des pages à l'écran. La première miniature indique une disposition classique, les pages les unes au-dessus des autres. La seconde miniature indique des pages côte à côte. La troisième indique également des pages côte à côte, mais avec une disposition telle que dans un livre, à savoir que la première page est toujours à droite.

G1S2 11.png

Suit ensuite le curseur de zoom et la dernière case contient la valeur de ce zoom. Un clic droit vous permet de choisir dans le menu contextuel qui s’affiche parmi différentes valeurs, quand le double clic ouvre, lui, une fenêtre de dialogue qui permet en plus de personnaliser le pourcentage de zoom ou la disposition des pages.

Voilà, vous savez tout sur cette barre d’état ! sauf peut-être que c’est une barre que vous ne pouvez pas paramétrer, à savoir vous ne pouvez pas lui ajouter d'autres fonctions. Vous pouvez cependant la désactiver dans le menu Affichage.

En résumé

Nous avons abordé l’ensemble de l’espace de travail de LibreOffice, ce que l’on appelle également l’interface graphique. Nous avons appris à quoi servent les règles, les barres de défilement, les infobulles et infoballons. Et la barre d'état n'a plus de secrets pour nous !