Rubrique générale - Étape 5

From The Document Foundation Wiki
Jump to: navigation, search


Environnement LibreOffice Module O Étape 5
Étape 5 Objectif opérationnel
Les options
Durée : 2h00
Savoir paramétrer les options générales de LibreOffice et les options générales des modules
Fonctions mises en oeuvre QCM
  • Paramétrages généraux
  • Paramétrages propres à Writer
  • Paramétrages propres à Calc
  • Paramétrages propres à Impress
  1. Si je ne me souviens plus comment accéder à une fonction, puis-la rechercher dans l'aide ?
  2. Si j'ajoute un mot de passe à mon document, les données d'identité seront-elles chiffrées?
  3. La case à cocher Enclencher des options de Impress, permet-elle de dessiner un rectangle ?

Cette étape est un peu longue puisque LibreOffice regroupe un grand nombre d'options. Nous n'allons pas toutes les détailler, mais aborderons celles qui ne sont pas forcément explicites ou nécessitent des connaissances complémentaires. N'hésitez pas cependant à déployer toutes les rubriques pour bien noter l'emplacement de ces options.

Les options LibreOffice

De qui s'agit-il en fait ? Dans le menu Outils > Options > LibreOffice, un certain nombre de paramétrages de la suite sont réalisables. Il est important de les connaître car ces paramètres vont influer sur le comportement de la suite et peuvent parfois vous créer des surprises.

XXXEncart Mac car les options sont ailleursXXX

Lorsque la fenêtre s'ouvre, à droite s'affiche un commentaire ou les options et paramétrages de la rubrique et à gauche un ensemble de rubriques contenant des sous-rubriques à déployer en appuyant sur la petite croix en regard.

G1S5 1.png

Détaillons quelques-unes de ces rubriques pour les rendre plus explicites :

Données d'identité

Ces données peuvent être saisies lors de l'installation de LibreOffice ou peuvent être complétées par la suite ici. Où sont-elles utilisées ? Lorsque vous faites des étiquettes par exemple, ou lorsque vous avez besoin d'un champ Expéditeur, ou encore lorsque vous faites des modifications ou insérez des notes dans un document, enfin, le champ Auteur dans les propriétés du document. À chaque fois, ce sont les informations que vous aurez inscrites ici qui seront réutilisées.

Enfin, LibreOffice est un ensemble de fichiers XML, regroupé dans un fichier unique. Le format permet aux documents d'être accédés par des éditeurs externes, il vous est donc possible de chiffrer les documents avec un mot de passe pour qu'ils soient protégés.

Sachez cependant que les informations contenues dans les propriétés du document ne sont pas chiffrées et apparaîtront en clair. Vous pourrez les supprimer automatiquement à l'enregistrement du document, en cochant l'option correspondante dans la rubrique Sécurité (nous y viendrons plus loin).

Général

G1S5 2.png

L'aide

Les infobulles sont de petites bulles qui apparaissent lorsque vous survolez une icône. Le nom de l'icône s'affiche alors. Très pratique lorsque vous ne connaissez pas encore très bien votre environnement, vous pouvez trouver ces étiquettes un peu gênantes par la suite. Décochez alors l'option infobulles.

Il en est de même pour les infoballons, qui sont des descriptions sur l'action de l'icône. Un paragraphe court vous explique ce qu'elle va produire. Cochez la case si vous souhaitez disposer de cette aide.

L'assistant est une petite ampoule qui s'affiche lorsque LibreOffice active un de ses automatismes. Un exemple, commencez une phrase sans mettre la majuscule au début de la phrase, une petite ampoule apparaîtra en bas à droite de votre écran lorsque LibO ajoute la majuscule au début de la phrase. Si vous cliquez sur l'assistant, la page de l'aide en ligne correspondante s'ouvrira.

G1S5 3.png

Les boîtes de dialogue

Suivant que vous cochez ou décochez cette option, elles seront présentées différemment. À vous de voir la présentation que vous préférez sur les copies d'écran ci-après. La première utilise les boîtes de dialogue LibreOffice, la seconde celle du système.

G1S5 4.png G1S5 5.png

Statut du document

Dans les propriétés de LibreOffice, vous pouvez enregistrer la date de la dernière impression du document si cette option est cochée. Après chaque impression et lorsque vous souhaiterez fermer le document, même si vous n'avez fait que l'imprimer, LibreOffice vous signale donc que le document a été modifié. L'option d'enregistrement ne pose pas de questions.

L'année

Ça n'est pas clair du tout ! LibreOffice considère les années sur quatre chiffres, exemple : 2011 au lieu de 11. Que se passe-t-il alors lorsque vous saisissez 14/02/11 ? Va-t-il s'agir de 2011 ou de 1911 ?

Il s'agira de 2011 puisque '11' fait partie de la plage 2000-2011. Si vous modifiez 1930, et que vous mettez 1920, l'écart dans la fenêtre de dialogue se positionne alors entre 1920 et 2019. Saisissez la date 14/02/25 et Calc affichera donc 1925 puisque '25' ne fait partie de la plage 2000-2019.

Mémoire vive

Annuler

G1S5 6.png

Il s'agit là du nombre d'opérations que vous allez pouvoir annuler lorsque vous sélectionnez le menu Édition > Annuler ou lorsque vous tapez Ctrl+Z.

Cache pour les images

G1S5 7.png

Là encore, qu’est-ce que c’est que le cache pour les images ? C’est une partie de la mémoire vive de votre ordinateur dans laquelle LibO va enregistrer les images (et leurs informations) contenues dans les documents. Cet enregistrement ici va permettre de naviguer dans le document et afficher les images sans que le module dans lequel vous êtes, ait à les recharger à chaque fois. Il les garde à portée de la main en quelque sorte pendant le temps de navigation dans le document. Par défaut LibreOffice utilise 9 Mo et alloue une place pour les objets allant jusqu’à 2,4 Mo. S’ils sont plus grands, ils ne seront pas stockés dans le cache, mais à leur emplacement de stockage normal. La mémoire du cache est régulièrement effacée pour ne pas l’encombrer, spécifiez ici combien de temps l’image doit rester dans cette partie de la mémoire. Il s’agit uniquement de son affichage, pas de son stockage bien sûr. Si vous avez des documents très lourds avec beaucoup d’images, n’hésitez pas à augmenter ces valeurs pour le temps de travail sur le document. Vous aurez ainsi moins de lenteurs et de risques de plantage.

Démarrage rapide Lorsque vous démarrez votre ordinateur, LibO va charger une partie de son programme en mémoire pour que lorsque vous l’appellerez à partir de la barre des tâches, vous y ayez accès rapidement, en faisant un clic droit ou un double clic sur son icône.

Afficher

Encore une fois, une foule d'options très explicites !

Interface utilisateur

L'interface est ce qui s'affiche tout autour de votre écran lorsque vous ouvrez LibreOffice : les barres d'outils, les menus, les règles, l'espace de travail, etc.

G1S5 8.png

Si vous modifiez l’échelle, l’ensemble des polices, icônes etc. va se modifier. Vous pouvez régler la taille des icônes qui s’affichent suivant vos besoins. Enfin, si la police du système ne doit pas être utilisée, LibreOffice en choisira une de remplacement. Vous pouvez également modifier le thème utilisé ainsi que la taille des icônes dans les menus.

La souris

Le positionnement automatique fera que le curseur se positionnera directement sur le bouton actif dans une boîte de dialogue.

Vous pouvez régler le bouton du milieu sur plusieurs positions. Toutefois le contenu du presse-papier (appelé ici presse-papier de sélection) que vous collerez ne sera pas identique à l’entrée Édition>Copier/Coller ou Ctrl+c et Ctrl+v. L'aide vous expliquera la différence entre ces deux presse-papiers, sachez seulement qu'ils peuvent avoir des contenus différents au même moment.

Impression

Nous ne nous attarderons pas sur cette rubrique qui est assez claire et propose différentes options pour la qualité de l'impression.

Chemins

G1S5 9.png

Ce qui est indiqué ici, ce sont les chemins vers des répertoires de LibreOffice que vous utilisez fréquemment et que vous préféreriez peut-être modifier.

Un répertoire surtout nécessite sans doute d’être modifié si vous souhaitez y accéder directement lors de la sauvegarde des documents sur lesquels vous travaillez, il s’agit de Mes documents. Dans la fenêtre d’enregistrement ou d’ouverture de fichier, une icône vous permet d’accéder directement à ce fichier, ou encore, c’est vers ce fichier que la fenêtre d’enregistrement s’ouvrira par défaut.

Couleurs

Cette rubrique permet de modifier les palettes de couleur de LibreOffice. Rien de très compliqué et nous y reviendrons dans le cours sur Impress.

Polices

Ici, vous avez la possibilité de faire remplacer par LibreOffice des polices qu’il ne saurait interpréter ou que vous ne possédez pas sur votre système. LibO choisira alors la police indiquée pour afficher le document.

G1S5 10.png

  1. Cochez la case Utiliser la police de remplacement pour activer la fenêtre
  2. Sous Police, indiquez à l’aide du menu déroulant la police non reconnue
  3. Dans le cadre Remplacer par, sélectionnez la police de substitution que LibreOffice doit utiliser
  4. Appuyez sur la coche verte pour valider votre choix
  5. La police s’affiche maintenant dans la liste en dessous
  6. Cochez Toujours ou/et Écran, pour que la police soit utilisée pour l’impression ou/et pour l’affichage à l’écran.

Options et avertissement de sécurité

C’est un point important que de savoir ce que va réellement contenir au final votre document, s’il a été modifié, ou encore s’il contient des macros, si elles doivent être activées ou non.

Options

Dans la partie supérieure de cette boîte de dialogue, vous trouvez un bouton Options qui concerne les informations qui peuvent être masquées dans votre document. Lorsque vous appuyez sur ce bouton, une nouvelle boîte de dialogue s'ouvre. Les options qu'elle contient ne sont pas difficiles à comprendre. Notez bien cependant que c'est ici que vous réglez le comportement de l'édition des hyperliens.

G1S5 11.png

Il est possible d’enregistrer des versions ou des modifications réalisées dans le document. Si parfois elles ont été enregistrées dans le but de les transmettre, ce n’est pas toujours le cas et il est alors souhaitable de nettoyer le document de toutes ces indications et même des données d’identité qui peuvent y figurer. Les différentes options proposées ici vous le permettent.

Rappelez-vous toutefois que la protection par mot de passe d’un document, ne chiffre pas vos données d’identité.

Sécurité des macros

Lorsque vous appuyez sur le bouton Sécurité des macros, vous obtenez l’écran suivant dans lequel vous pouvez régler le niveau de sécurité des macros contenu dans vos documents.

G1S5 12.png

Choisissez l’option qui vous convient en fonction du type de documents que vous manipulez. Certains documents peuvent être signés et la signature placée parmi les sources de confiance sous l’onglet correspondant de la boîte de dialogue.

Apparence

Un onglet sympathique où vous allez pouvoir jouer de la couleur dans votre environnement. En effet, la couleur des marges, du fond de l’espace de travail, des champs, etc. peut être personnalisée. A vous de voir celles qui vous correspondent le mieux.


Pour modifier une couleur : Sélectionnez-la dans la liste déroulante correspondant à ce que vous voulez changer dans l’interface. Dans notre exemple, ce sont les délimitations du texte.

G1S5 13.png

Une fois la sélection effectuée, la case juste à côté affiche la couleur. Lorsque vous cliquerez sur Ok pour fermer la boîte de dialogue, la modification sera prise en compte et s’appliquera à toute la suite.

G1S5 14.png

Accessibilité

Ces options permettent à des personnes souffrant de handicaps d’avoir accès, à travers LibreOffice, à des logiciels qui permettent d’y pallier. Notez si vous vous trouvez dans cette situation, pour que LibreOffice prenne en charge correctement les logiciels, il faut que leur version ait été mises à jour et qu’elles soient dans les plus récentes possible.

Java

Java est un langage et vous avez besoin qu’un environnement Java (ce qui va permettre de lire le langage) soit installé sur votre machine pour avoir accès à toutes les fonctionnalités de LibreOffice. En effet, certaines parties sont écrites dans ce langage. C’est le cas des Assistants que vous trouvez dans le menu Fichier>Assistants. C’est également le cas pour la base de données Base de LibreOffice.

Si vous n’avez pas Java installé, cela ne vous empêchera pas, bien sûr, d’utiliser LibreOffice. Pour l’installer, téléchargez-le sur le site Java, par exemple ici : http://www.java.com/fr/download/manual.jsp

Suivez la procédure d’installation. Une fois terminé, le nouvel environnement apparaîtra dans la fenêtre Java. Sélectionnez-le, il sera maintenant utilisé par LibreOffice.

G1S5 15.png

Les options de Writer

Chaque module de la suite possède ses propres paramétrages. Là encore nous ne détaillerons que ceux qui manquent de clarté.

Général

Les documents Writer peuvent contenir des champs, ou des tableaux ou encore des images liés. Vous pouvez figer ces liens, et donc l’image ou le tableau s’ils ont été modifiés ne s’actualiseront pas ou au contraire demander leur actualisation automatiquement ou manuellement. Appuyez sur le bouton radio correspondant à votre choix.

G1S5 16.png

Affichage

Les repères sont des aides lors de la manipulation d’objets. Par exemple si vous cochez la case Repère lors du déplacement, des lignes pointillées seront projetées pour vous aider à positionner l’objet que vous déplacez. Les poignées sont les petits carrés verts ou bleus qui entourent un objet sélectionné. S'il s'agit d'un objet 3D, ce sont alors de petites boules rouges qui permettent de modifier l'orientation de l'objet. Poignées simples signifie qu’elles seront plates, Grandes poignées signifie que les carrés seront deux fois plus gros.

Aide au formatage

Vous allez paramétrer ici toutes les aides visuelles qui peuvent s’afficher lors de la réalisation de vos documents. Vous retrouvez la plupart de ces options de façon ponctuelle dans les menus de la suite. Quant au curseur direct, nous ne nous en occupons pas pour le moment, nous l’étudierons plus tard avec toutes ses fonctions.

Activer le curseur dans les zones protégées va permettre à un lecteur d'écran d'accéder à ces zones (comme l'aide par exemple). Si vous utilisez des outils d'accessibilité pour lire vos documents, il est donc important de laisser cette case cochée.

Grille

Il est possible de poser une grille sur le document qui vous aidera lors du positionnement des objets, la grille peut-être ‘magnétisée’ pour que les objets collent uniquement sur les points de la grille. Si ponctuellement vous ne le souhaitez pas, appuyez sur la touche Ctrl en même temps que vous déplacez l’objet, cela désactivera l’option.

Polices standards

Les polices du modèle de document par défaut sont définies ici, vous pouvez les modifier et appliquer celles que vous souhaitez. Le bouton Par défaut ramènera tous les paramétrages que vous avez effectués à leur valeur initiale.

Impression

Rien de compliqué avec cet onglet. Notez juste que si un fax est installé sur votre système, c’est ici que vous l’indiquez à LibreOffice.

Tableau

Les options qui sont préréglées ici peuvent être désactivées ponctuellement lorsque vous insérez un tableau dans un texte. C’est donc le comportement général des tableaux que vous paramétrerez ici.

Compatibilité

Les options de compatibilité qui sont définies ici s’activent automatiquement à l’ouverture d’un document. Vous n’aurez donc normalement pas à y toucher sauf cas très spécifique d’import ou d’export d’un document.

Les options de Calc

La plupart des options de Calc sont similaires à celles de Writer en ce qui concerne l’affichage (mais jetez-y un œil quand même, beaucoup d'options qui rendent le travail plus agréable sont paramétrables ici), la grille, etc. Nous allons donc examiner trois rubriques spécifiques :

Calcul

Qu’est-ce donc qu’une référence circulaire ? C’est une formule dont le calcul est répété continuellement jusqu’à la résolution du problème. Cette répétition s’appelle l’itération. Vous pouvez donc déterminez un pas qui réglera le nombre maximum d’itérations voulu.

Listes de tri

Des listes préenregistrées peuvent être insérées dans Calc. Il suffit de saisir le premier mot de la liste et le reste de la liste s’inscrira au fur et à mesure que le curseur glissera sur la page. Mais nous expliquerons ceci en détail plus loin dans les cours.

Raccourcis claviers

Vous pouvez ici revenir aux raccourcis claviers que vous utilisiez sous OpenOffice.org. À savoir, la touche Suppr qui ouvre une boîte de dialogue vous permettant de choisir le contenu à supprimer. Ou alors la touche Retour arrière qui supprime directement le contenu de la cellule, quel qu'il soit.

Les options de Impress

Là encore, les options de Impress sont très similaires à celles des autres modules. Juste une précision en ce qui concerne la Grille car cela peut être bloquant.

Si vous cochez Enclencher lors de la création ou du déplacement, lorsque vous insérerez un rectangle ou une ellipse, vous obtiendrez obligatoirement un carré ou un cercle. Cette option limite en effet la longueur et la largeur des côtés. Pour la désactiver ponctuellement dans la page de dessin, appuyez sur la touche Maj en même temps que vous faites le tracé.

En résumé

Voilà, il n’y a plus aucun obstacle maintenant pour maîtriser l’ensemble des options et des paramétrages de LibreOffice, vous allez pouvoir entrer dans chacun des modules et en apprendre les fonctionnalités en toute tranquillité !

N’oubliez pas, lorsque vous recherchez une fonction, ou lorsque vous ne vous souvenez plus de son action, n’hésitez pas à afficher l’aide. Tous les accès aux fonctions sont clairement indiqués et nombre d’exemples vous aident à comprendre comment elles s’appliquent.