Writer, tout savoir sur les filigranes

From The Document Foundation Wiki
Jump to: navigation, search

FR.WRITER Tavaux.gif Page en cours de rédaction

Préambule

Les filigranes sont des objets graphiques transparents placés à l'arrière-plan d'un document. Ils font généralement partie de l'ensemble des éléments qui définissent l'identité visuelle (charte graphique) propre à chaque institution, entreprise ou association. Ils sont également utilisés par les particuliers selon leurs besoins propres et leur goût pour la création de correspondances et de cartes de vœux, par exemple. Il peut s’agir de dessins, de photographies, de logos ou d’images sous forme de texte. LibreOffice permet d’insérer de manière professionnelle ces objets au sein de la page d’un document ou de son en-tête, mais également à l’arrière-plan d’un paragraphe ou encore d’un tableau.


Objectif

Dans ce tutoriel, nous examinerons les différentes techniques d'insertion de filigrane, et exploiterons divers outils et modules qui nous permettront de faciliter ces tâches voire de les automatiser. Cette page wiki se veut didactique avec une méthode d'approche "étape par étape" et constituée d'exemples pratiques et détaillés. Nous débuterons par la création de filigranes "texte", la modification de la transparence d'objets et leur export à l'aide du module Draw. Nous poursuivrons avec l'insertion dans un document Writer d'un filigrane sur une ou plusieurs pages ainsi que la création de pages de style et de modèles. Nous traiterons également de l'usage de la Gallery pour l'insertion d'images à l’arrière-plan en deux clics de souris, et ce, dans de nombreux contextes. Enfin, nous terminerons avec l'export d'un document en PDF et sa signature avec un filigrane.

Création et export d'objets Texte avec le module Draw

Pour l'exercice, nous allons travailler avec un certain nombre d'objets, aussi est-il préférable de créer dès maintenant un dossier bien distinct sur notre poste de travail ; nommons-le « FiligranesDraw », par exemple.

FR-doc-Note.png

Nous verrons plus bas que Writer permet d'insérer sans préparation particulière une image et de l'adapter sur une page comme filigrane. Dans les versions antérieures à LibreOffice 4.4 l’image devait impérativement être retouchée en amont pour présenter un certain degré de transparence. Depuis, avec les améliorations apportées, cette phase est devenue obsolète et ne sera donc pas abordée ici.

Création et export de textes sous forme d'images avec l'outil Fontwork

Création de l'objet Fontwork


FR-doc-Note.png

Pour de plus amples informations, sur la création et la modification d'objets Fontwork, nous pouvons nous référer utilement à la section L'outil Fontwork.


Ouvrons le module Draw et vérifions si la barre d'outils de dessins est bien présente ; dans le cas contraire, sélectionnons Affichage ▸ Barre d'outils ▸ Dessin.

  • Depuis cette barre d'outils, cliquons sur l'icône Galerie Fontwork FR.FAQ Draw IcôneGallerieFontwork.jpg. La boîte de dialogue Galerie Fontwork s'ouvre et affiche de nombreux styles
  • Double-cliquons sur le premier élément (intitulé « favori1 » par l’infobulle lors du survol de ce dernier avec le pointeur de la souris)
  • Double-cliquons sur l'objet, et remplaçons le texte « Fontwork » par « Confidentiel », puis cliquons en dehors de l'objet ou appuyons sur la touche Échap ; les modifications apportées sont enregistrées, et l’objet est sélectionné (poignées bleues apparentes). Dans ce contexte la barre d'outils Texte et formatage apparaît automatiquement.
  • Cliquons sur la liste déroulante Style de ligne et sélectionnons Aucune, puis sur la liste déroulante Style de remplissage et cliquons sur la couleur Rouge, par exemple (Figure 1).
  • Apportons dès à présent un degré de transparence à l'objet Fontwork en cliquant sur l'outil Remplissage FR.HT Writer-IcôneTransparence.png de la barre d'outils Ligne et remplissage. La boîte de dialogue Remplissages'ouvre ; cliquons sur l'onglet Transparence puis sur le Bouton radio Transparence, modifions les paramètres à 70 %, et validons au moyen du bouton OK (Figure 2).
  • Redimensionnons sommairement la hauteur des lettres composant l'objet en faisant appel à la boîte de dialogue Position et taille en appuyant sur la touche F4 ou via le menu Format ▸ Position et taille puis réglons la hauteur (des lettres) à 3 cm (Figure 3).
  • Cliquons maintenant sur l'onglet Rotation de cette même boîte de dialogue et réglons l'angle de rotation sur 300 ° ; nous pouvons valider les modifications apportées à l'objet avec le bouton OK (Figure 4).



FR-doc-Note.png

Nous avons modifié la hauteur de l'objet, et lui avons fixé une valeur de 3 cm. Lorsque nous avons pivoté le texte, Draw a automatiquement appliqué des modifications à la taille de l'objet pour prendre en compte le nouvel axe de rotation, mais cela n'aura aucune incidence sur les proportions initiales.

Export de la sélection au format PNG

Nous allons exporter le filigrane «Confidentiel» au format PNG (Portable Network Graphics), de manière à pouvoir l'insérer rapidement dans une page standard du module Writer (avec des marges de 2 cm, par exemple). L'objectif étant de disposer d'un objet qui remplisse une grande partie diagonale de cette page (à l'intérieur des marges).

  • Assurons-nous que l'objet est bien sélectionné, puis cliquons sur le menu Fichier ▸ Exporter FR.HT Witer-Filigranes MenuExporter.png, la boîte de dialogue Exporter s'ouvre. Parcourons nos dossiers et sélectionnons le répertoire «Filigranes» fraîchement créé. Nous constatons que l'option Extension automatique de nom de fichier est cochée par défaut ; déroulons la liste Type et Choisissons l'entrée PNG - Portable Network Graphic (.png). Dans la zone Nom du Fichier inscrivons Confidentiel sans saisir l'extension (.png), activons la case à cocher Sélection, et cliquons sur le bouton Enregistrer (Figure 5)
  • À l'issue de cette phase d'enregistrement, une boîte de dialogue spécifique PNG Options, s'affiche à l'écran et nous offre la possibilité de modifier la taille, la résolution, le taux de compression, le mode d'entrelacement ainsi que l'enregistrement de la transparence de l'objet. Laissons toutes ces options par défaut, hormis la largeur de l'objet que nous déterminerons à 17 cm. Le module Draw ajustera alors en conséquence les nouvelles valeurs pour la taille (Figure 6).


N'oublions pas d'enregistrer notre document de travail Draw (Confidentiel.odg, par exemple) dans notre dossier Filigranes; nous pouvons également nous assurer dès maintenant de la présence de notre premier filigrane (Confidentiel.png)!

Création et export de textes sous forme d'images avec l'outil Texte

Nous allons créer rapidement un filigrane sous forme de texte grâce à l'outil Texte de Draw. Ce filigrane que nous appellerons DiffusionRestreinte pour l'exemple, sera plus modeste en taille que le précédent. Il sera destiné a être inséré dans une page standard de Writer et reproduit automatiquement un certain nombre de fois sur la page ; il s'agira d'un filigrane dit "en mosaïque". Pour la création et la mise en forme de ce nouvel objet, servons-nous du volet latéral de LibreOffice (disponible à partir des versions 4.1). Procédons dès maintenant à son affichage et son activation en cliquant sur Outils ▸ Options ▸ Avancé ▸ Activer les fonctions expérimentales, et en vérifiant que l'option Affichage ▸ Volet latéral est bien cochée.

Création de l'objet Texte

  • Créons un nouveau document Draw. Le volet latéral contextuel, par défaut, est ancré à droite de notre espace de travail et affiche un panneau de contenu intitulé Insérer des formes ; nous pouvons le placer sur le côté gauche en glissant sa barre de titre (voir figures 7 et 8).
  • Panneau de contenu Insérer des formes: cliquons sur l'outil Texte FR.HT Writer-Filigrane OutilTexte.png ou en appuyons ou sur la touche F2, dessinons un rectangle, et tapons le texte Diffusion restreinte, en veillant à effectuer « un retour chariot » à l'aide de la touche ↵ Entrée après le mot Diffusion. Cliquons sur un espace libre de l'éditeur ou sur la touche Échap pour valider ; l'objet est affiché encadré en bleu avec ses poignées de redimensionnement . Nous remarquons alors, dans ce contexte, que le volet latéral affiche six panneaux de contenu, dont l'arborescence de chacun peut être développée ou repliée selon nos besoins à l'aide des boutons + ou - (figure 8).


FR-doc-Astuce.png

Astuce :
Lorsque l'objet est sélectionné, le volet latéral nous permet d'appliquer les différentes mises en forme sans que nous soyons obligés de mettre en surbrillance le texte.


  • Panneau de contenu Caractère : cliquons sur la liste déroulante des polices de caractères, sélectionnons Arial Black, laissons la taille de la police par défaut sur la valeur 18, puis cliquons sur l'outil Couleur de police et sélectionnons Gris 1 (Figure 9)
  • Panneau de contenu Paragraphe : cliquons sur le bouton Aligner au centre (Figure 10)
  • Panneau de contenu Position et taille : déterminons une valeur de 45 ° pour la rotation de l'objet (Figure 11)



Export de la sélection au format PNG

En cela, procédons de la même manière que pour le filigrane "Confidentiel.png" ; ainsi, nommons l'export "DiffusionRestreinte", sans oublier de cocher la case Sélection. Dans la boîte de dialogue Export PNG saisissons une valeur de 5,50 cm dans la zone Largeur, la hauteur de l'objet sera modifiée en conséquence par le module Draw. Pensons à enregistrer notre document de travail : "DiffusionRestreinte.odg".

Insérer un filigrane sur une page

  • Pour le tutoriel, cliquons sur le lien Image LibreOffice, puis clic droit avec la souris et Enregistrer l'image sous... avec notre navigateur Internet. Nous pouvons maintenant enregistrer cette image dans notre dossier "FiligranesDraw".

Insertion de l'image

  • Depuis le module Writer, créons un nouveau document texte à l'aide des touches Ctrl+N, cliquons sur l'icône FR.HT Writer-IcôneImage.png de la barre d'outils Dessin, ou depuis le menu Insertion ▸ Image.... Le navigateur de notre système d’exploitation s’ouvre et affiche la boîte de dialogue Insérer une image (Figure 12). Parcourons les dossiers et sélectionnons l’image voulue. Sous notre sélection figure une case à cocher Lier. Si nous l'activons, l'image sera insérée comme un simple lien, si nous la désactivons , une copie de l'image sera directement incorporée dans le document.


PhC Attention.png

L'option Lier réduit (sensiblement) la taille d'un fichier Writer, car celui-ci contient une référence sur l'emplacement physique de l'image mais pas l'image elle-même. Si nous partageons ce type de document avec une personne (sur un autre poste de travail), cette dernière sera pas en mesure de visualiser les images liées.


  • Laissons donc cette case décochée par défaut et cliquons sur le bouton Ouvrir (figure 12) :
  • L’image, entourée de huit poignées vertes, est alors insérée dans notre document et ancrée par défaut au paragraphe. Nous remarquons qu’une barre d’outils flottante (Image) est apparue (figure13).
  • Cette barre d'outils va nous permettre de "convertir" l'image en filigrane. Pour ce faire, il nous suffit de cliquer sur la liste déroulante Mode graphique puis de sélectionner l'item Filigrane (figure 14).


  • La transparence de l’objet est alors accentuée et le contraste réduit en conséquence par Writer.Toutefois, si le résultat ne nous satisfait pas (image jugée trop pâle et contraste trop élevé par exemple), nous annulerons la modification apportée à l'image par la combinaison des touches Ctrl+Z, et ajusterons la transparence selon nos préférences à l'aide de l'outil éponyme FR.HT Writer-OutilTransparence.png de la barre d'outils Image (Figure 15 ci-dessus).

La boîte de dialogue Image

Mais en l’état nous ne pouvons toujours pas "écrire" du texte sur cette image car elle n’est pas considérée par Writer comme un fond de page. Nous devons procéder à quelques ajustements au moyen de la boîte de dialogue Image, qui peut être appelée par un double clic sur l’image, un clic avec le bouton droit de la souris, puis Image..., ou via le menu Format ▸ Image... Celle-ci comporte neuf onglets (Illustration 15), chacun comprenant plusieurs sections ; seuls les trois premiers (Type, Options et Adaptation du texte) nous seront utiles afin d'appliquer nos différents réglages.

copie d'écran de la boîte de dialogue Image
Figure 15 : boîte de dialogue Image

L'onglet Type

Pour l’onglet Type, section Ancrer, cliquons sur le bouton radio À la page, et dans la section Position, optons pour un centrage horizontal et vertical de l’image à l’aide des listes déroulantes (Figure 16). La section Taille pourrait nous permettre, par exemple, d'adapter la taille de l’objet afin de l'ancrer à l'arrière-plan d'un paragraphe ou d'un tableau (pour l’instant ignorons cette option).

copie d'écran boîte de dialogue onglet Type Image
Figure 16 : L'onglet Type


L'onglet Options

Cliquons sur l’onglet Options (Illustration 17),nommons explicitement l’image, LibO_Filigrane, par exemple, ce qui peut être très utile si l’on veut rappeler le filigrane disposé en fond de page à l’aide de l’Explorateur (touche F5). La section Protéger (facultatif) peut nous prémunir de toute suppression ou modification accidentelle de l’objet. Enfin, la case à cocher Imprimer (activée par défaut) permet ou non d’imprimer l’image placée à l’arrière plan du document.

copie d'écran boîte de dialogue onglet Options Image
Figure 17 : L'onglet Options

L'onglet Adapter

Cliquons sur l’onglet Adapter (Illustration 18), dans la section Paramètres définissons le réglage sur Continu, et à l’Arrière-plan dans la section Options. Ce sont ces deux options, qui permettent véritablement de placer l'objet derrière le texte. Cliquons sur le bouton OK de la boîte de dialogue nous pouvons désormais taper du texte sur notre filigrane (figure 19):

copie d'écran boîte de dialogue onglet Adapter Image
Figure 18 : L'onglet Adapter


Réalisons un test en insérant un texte Lorem ipsum, par exemple, au-dessus du filigrane : Aperçu du texte en premier plan

PhC Attention.png

L'attention du lecteur ne doit pas être détournée par une image trop criarde ; il est nécessaire d’en ajuster judicieusement la transparence. Gardons à l'esprit que le texte exige une parfaite lisibilité.


Le menu contextuel

Tous les réglages que nous venons d'effectuer avec la boîte de dialogue Image sont reproductibles avec le menu contextuel (clic droit directement sur l'image), hormis le nommage de l’image (figures ci-dessous) :

  • l’ancrage à la page
  • l'alignement
  • l’adaptation du texte


Pour aller (beaucoup) plus vite !

  • Pour une nécessaire compréhension du mécanisme mis en œuvre afin d’obtenir un filigrane, nous avons vu, plus haut, les phases requises :
  1. insertion de l’image (avec un certain degré de transparence),
  2. succession d’adaptations (fastidieuses) à apporter à la boîte de dialogue Image.


FR-doc-Astuce.png

Dans la suite LibreOffice, une image est, par défaut, intégrée dans un conteneur appelé « Cadre ». Or, Writer recèle, nativement, un style de cadre nommé… « Filigrane » qui contient toutes les options d’ancrage, d’alignement et d’adaptation du texte prédéfinies. Pourquoi nous en priverions-nous ?


  • Créons un nouveau document Texte, insérons une image et réglons sa transparence, cliquons sur l'icône FR.HT Writer-BoutonStylesEtFormatage.png Style et formatage du panneau latéral (ou appuyons sur la touche F11), cliquons sur le bouton FR.HT Writer-BoutonStylesDeCadre.png Style de cadre, puis double-cliquons sur le style Filigrane... c'est tout !
copie d'écran Appliquer le style de cadre Filigrane
Figure 23 : Appliquer le style de cadre Filigrane

Insérer un filigrane sur plusieurs pages

  • Avec le module Writer, chaque page d'un document est fondée sur un style. Dans le cas où nous n'attribuons aucun style de page (natif ou personnalisé), Writer utilisera le style de page par défaut. Si nous modifions ce style de page et lui apportons une image en arrière-plan, toutes les pages du document auront les mêmes caractéristiques.

Présentation du Style de page : Style par défaut

  • Créons un nouveau document Texte Writer pour procéder à quelques essais, et regardons de plus près le format par défaut d’une page, à l'aide :
    • du menu Format ▸ Page (A),
    • d'un clic avec le bouton droit de la souris dans un endroit quelconque de l'éditeur, puis Page... (B),
    • d'un clic sur le Style par défaut affiché dans la barre d’état (C).
  • La boîte de dialogue Style de page : Style par défaut s’ouvre (D) Style par défaut .

Les différents onglets utilisés pour l’insertion d’un filigrane

  1. L’onglet Gestionnaire dans lequel figure une section Style comportant le nom du style (Style par défaut) et le Style de suite (style de la page suivante), ainsi qu’un descriptif détaillé du contenu de la page.
  2. L’onglet Arrière-plan qui permet le remplissage de la page avec une couleur, un dégradé de couleurs, des hachures ou bien, dans notre cas d’espèce, une image.
  3. L’onglet Transparence, qui, comme son nom l’indique, nous permettra de rendre l’image plus ou moins translucide selon notre choix.
copie d'écran les 3 onglets dialogue syle par défaut
Illustration Les 3 onglets utilisés pour l’insertion d’un filigrane


Présentation de l'onglet Arrière-plan

Ouvrons, si ce n'est déjà fait, la boîte de dialogue du style par défaut au moyen de l’une des trois méthodes évoquées plus haut. Cliquons sur l’onglet Arrière-plan, puis sur la liste déroulante de la section Remplir et sélectionnons l’entrée Image. Le dialogue change et nous propose toute une série d’options listée ci-après :

copie d'écran boîte de dialogue onglet Arrière-plan
Illustration : L'onglet Arrière-plan


  • Section Taille :
    • Original : cochée par défaut, conserve la taille d’origine de l’image.
    • Relatif : permet, lorsque l’option Original est désactivée, de définir manuellement une taille de l’image différente de celle d'origine à l’aide des zones Largeur et Hauteur ;
  • Section Position : il s’agit d’une vignette représentant la position de l’image au sein de la page.
    • Décalage X : Déplace l’image vers la droite de la page ;
    • Décalage Y : Déplace l’image vers le bas de la feuille.
  • Section Mosaïque : permet de remplir la page avec l’objet (l’image) autant de fois que possible, à l’instar d’un pavage en mosaïque. Cette option est appelée également Carrelage.
    • Adaptation auto: lorsque l'option Mosaïque est désactivée, permet d'étirer l'image de manière à ce qu'elle occupe la totalité de l'espace disponible de la page (à l'intérieur des marges).
    • Ligne : décale l’objet dans le sens horizontal par rapport à sa disposition en mosaïque et selon la valeur que nous définissons en pourcentage dans la zone en regard.
    • Colonne décale l’objet dans le sens vertical par rapport à sa disposition en mosaïque et selon la valeur que nous définissons en pourcentage dans la zone en regard.
    • Bouton Importer une image: ouvre l'explorateur de notre système d'eploitation pour naviguer dans les dossiers et ouvrir l'image souhaitée.

Configuration de l'onglet arrière-plan

  • Nous verrons dans ce qui suit comment apposer l'estampille "Confidentiel" qui occupera la totalité de la page, puis nous ferons de même avec l'objet "Diffusion restreinte", mais cette fois-ci sous forme de mosaïque.

Insertion du filigrane Confidentiel

À partir de l'onglet Arrière-plan, désactivons les options Mosaïque (1) et Adaptation Auto (2); seule la case à cocher Original reste sélectionnée. Cliquons alors sur le bouton Importer une image... (3), à l'aide de l'explorateur, parcourons les dossiers et sélectionnons l'image "Confidentiel.png", puis cliquons sur le bouton Ouvrir. La boîte de dialogue reste active ; cliquons sur le bouton Appliquer (4), le filigrane apparaît sur notre page. Validons par OK (5) (Figure ci-dessous). À ce stade nour pourrions régler plus finement encore l'opacité du filigrane en rappelant la boîte de dialogue Style par défaut, et en cliquant sur l'onglet Transparence pour en augmenter ou en diminuer le degré à l'aide du bouton radio ad oc.

copie d'écran insertion du filigrane Confidentiel à la page
Illustration : Insertion du filigrane Confidentiel à la page


Si nous ajoutons des pages à l'aide de la combinaison des touches Ctrl + ↵ Entrée (ou du texte au kilomètre), nous constatons que le filigrane est bien reproduit sur l'ensemble des pages composant notre document de test.

Insertion du filigrane DiffusionRestreinte

Nous allons maintenant insérer un filigrane qui sera reproduit autant de fois que possible sur les pages d'un document en utilisant l'option dite "en mosaïque". Créons un document Texte Writer appelons la boîte de dialogue Style par défaut et cliquons sur l'onglet Arrière-plan. Laissons en l'état toutes les options défnies par défaut dans l'onglet Arrière-plan. Cliquons sur le bouton Importer une image..., à l'aide de l'explorateur, parcourons les dossiers et sélectionnons l'image "DiffusionRestreinte.png", puis cliquons sur le bouton Ouvrir. La boîte de dialogue reste active ; cliquons sur le bouton Appliquer, le filigrane en mosaïque apparaît sur notre page. Validons par OK (Figure ci-dessous).

copie d'écran insertion du filigrane DiffusionRestreinte à la page
Illustration : Insertion du filigrane Diffusion restreinte à la page


Modification de l'objet "Confidentiel"

  • Nous voudrons peut-être modifier la taille de l'image "Confidentiel.png" que nous avions définie dans le module Draw à 3 entimètres pour la hauteur des lettres, et, lors de l'export en .png à 17 cemtimètres de largeur. Il est possible de modifier directement l'objet depuis la page de style, afin, par exemple, de le disposer en mosaïque. Il suffit de rappeler la boîte de dialogue, de décocher l'option Original. Dans les zones Largeur et Longueur saisissons respectivement 5,00 cm et 8,50 cm, laissons par défaut les options Mosaïque et Adaptation Auto activées, ainsi que le bouton radio Ligne (Figure ci-dessous).
copie d'écran Modification du filigrane Confidentiel
Illustration : Modification du filigrane Confidentiel


  • Il est également possible de modifier les décalages horizontaux et verticaux des images en carrelage à l'aide des boutons radio Ligne et Colonne en déterminant une valeur de pourcentage dans la case en regard.

Modification de l'objet "Diffusion restreinte

À l'inverse, nous pouvons vouloir agrandir le filigrane "DifusionRestreinte.png" afin qu'il occupe le centre (ou d'autres endroits) de la page en un seul exemplaire. Rappelons la boîte de dialogue, désactivons les options Original et Mosaïque mais conservons la case à cocher Adaptation Auto active qui se chargera d'étirer l'objet en conséquence. Cliquons sur le bouton Importer une image... et rapatrions l'image. N'oublions pas de valider au moyen des boutons Appliquer et OK du dialogue (Figure ci-dessous).

copie d'écran Modification du filigrane Diffusion restreinte
Illustration : Modification du filigrane Diffusion restreinte


Si nous ne voulions pas que l'objet subisse de disgracieuses distorsions, il aurait simplement fallu décocher toutes les cases du dialogue Arrière-plan, et attribuer une valeur de 20 cm, par exemple, dans les zones Largeur et Hauteur de la section Taille.

copie d'écran Modification de la taille d'un filigrane sans distorsions
Illustration :Modification de la taille d'un filigrane sans distorsions


Création de styles de page personnalisés et de modèles

  • L’évaluation du temps épargné quotidiennement à celui dévolu à la seule création d’un modèle comportant des styles de page est sans appel. Le mariage des styles et des modèles nous offrira :
    • le respect de l’identité visuelle ;
    • la cohésion, l’uniformité des documents produits ;
    • la modification instantanée à toutes les pages ayant le même style au sein d’un document ou d’un modèle ;
    • le chargement de styles de page dans un autre document.
  • L'objectif étant de créer un exemple de modèle comprenant :
  1. une première page (page de garde) avec un style de suite page gauche et comprenant un style de titre principal modifié ;
  2. un style de page gauche (page paire) nue avec un style de suite de page Filigrane page droite.
  3. un style de page droite (page impaire) pourvu d'un filigrane avec un style de suite page gauche ;

Création du style de page Filigrane page droite

Cliquons sur le bouton Style et formatage du volet latéral (ou appuyons sur la touche F11), puis cliquons sur 'icône Style de page. Dans la liste des styles de page qui s'affichent, sélectionons le style Page droite. Ainsi, nous allons utiliser les caractéristiques de ce style et ajouter une image en arrière-plan. Cliquons sur l'outil "Nouveau style à partir de la sélection" FR.HT Writer-BoutonNouveauStyle.png, puis cliquons sur l'entrée Nouveau style à partir de la sélection. La boîte de dialogue Créer un style s'ouvre ; dans le champ Nom du Style inscrivons "Filigrane page droite" et validons à l'aide du bouton OK (Figure ci-dessous).

copie d'écran Nommage boîte de dialogue Créer un style
Illustration : Nommage boîte de dialogue Créer un style


Dans le volet latéral, sous la liste des styles de page affichés, cliquons sur la liste déroulante et sélectionnons l'entrée Styles personnalisés. Le style Filigrane page droite apparaît. Effectuons un clic droit sur ce style et cliquons sur Modifier.

copie d'écran Liste styles de page personnalisée
Illustration : Liste styles de page personnalisée


La boîte de dialogue du style Filigrane page droite s'affiche à l'écran sur l'onglet Gestionnaire. Déroulons la liste Style de suite et séléctionnons Page gauche.

copie d'écran Dialogue Gestionnaire Style de suite
Illustration : Boîte de dialogue Filigrane page droite, Onglet Gestionnaire Style de suite


Cliquons sur l'onglet Arrière-plan, puis sur la liste déroulante de la section Remplir et sélectionnons l’entrée Image, désactivons les options Mosaïque et Adaptation Auto; seule la case à cocher Original reste sélectionnée. Cliquons sur le bouton Importer une image..., à l'aide de l'explorateur, parcourons les dossiers et sélectionnons l'image "LibreOffice MotifScatter RGB.png", puis cliquons sur le bouton Ouvrir. Réglons l'opacité du filigrane en cliquant sur l'onglet Transparence, activons le bouton radio Transparence et paramétrons la case à 75 %. La boîte de dialogue reste active ; cliquons sur le bouton Appliquer, puis Validons par OK.

Modification du style de page gauche

Dans le volet latéral, sous la liste des styles de page affichés, n'oublions pas de cliquer sur la liste déroulante et sélectionnons Tous les styles. Effectuons un clic droit sur le style Page gauche, puis Modifier, puis, dans l'onglet Gestionnaire sélectionnons Filigrane page droite depuis de la liste déroulante Style de suite.

Modification du style de page Première page

  • Nous allons modifier la première page afin qu'elle ait pour style de suite une Page gauche. Dans cette page de garde, nous insérerons un champ "Titre" auquel nous affecterons un style de titre principal.
    • Utilisons le menu Fichier ▸ Propriétés…, une boîte de dialogue s'affiche à l'écran ; cliquons sur l'onglet Description et incrivons "Titre du document" dans le champ Titre et validons avec le bouton OK. Cliquons sur le menu Insersion ▸ Champs ▸ Titre, le champ est alors créé et s'affiche sur notre feuille de travail.
    • Cliquons maintenant sur le bouton Style et formatage du volet latéral (ou appuyons sur la touche F11), cliquons sur la première icône en partant de la gauche FR.HT Writer-IcôneStylesDeParagraphe.png Styles de paragraphe, puis, à l'aide de la liste déroulante sélectionnons Titre principal (tout en bas de la liste), effectuons un clic droit, puis cliquons sur Modifier. Dans la boîte de dialogue qui s'affiche, cliquons sur l'onglet Effets de caractère, déroulons la liste Couleur de police et choisissons l'entrée Vert 5. Sélectionnons l'onglet Retraits et espacement, dans la section Espacement, apportons une valeur de 6,00 cm à la case Au-dessus du paragraphe, et validons avec les boutons Appliquer et OK de la boîte de dialogue. Dès lors, nous pouvons cliquer sur le champ Titre du document de notre espace de travail, puis double-cliquer sur le style Titre principal du volet latéral.
    • Depuis le volet latéral, cliquons sur l'icône Style de page, dans la liste des style effectuons un clic droit sur Première page, puis cliquons sur Modifier. Dans l'onglet Gestionnaire, activons Page gauche dans le style de suite.
  • Toutes les modifications ont été apportées au style de la première page. Dans la liste des styles de pages, double cliquons sur Première page.

Enregistrement du modèle

  • Nous pouvons dès maintenant terminer notre travail en cliquant sur le menu Fichier ▸ Modèles ▸ Enregistrer comme modèle…, la boîte de dialogue Gestionnaire de modèles s'ouvre ; cliquons sur le bouton Tous les modèles. Dans notre cas, nous aurons une préférence pour le dossier Style sur lequel nous pouvons double cliquer. Les documents Défaut et Modern y sont présents. Ajoutons notre modèle en cliquant sur le bouton Enregistrer. Un dialogue est affiché pour permettre la saisie du nom du modèle, inscrivons FiligranePageDroite et validons à l'aide du bouton OK.
  • Le modèle que nous venons de créer est diponible au téléchargement : Modèle de styles de page

Quand les filigranes amusent la Gallery !