Perguntas Frequentes sobre o LibreOffice Calc

From The Document Foundation Wiki
< Faq‎ | Calc
Jump to: navigation, search


Contents

Como eu abro um arquivo delimitado por tabulações no Calc? E se eu tiver um delimitador diferente?

Proceda conforme os passos abaixo:

  1. selecione Arquivo > Abrir;
  2. selecione o arquivo desejado;
  3. selecione o tipo de arquivo Texto CSV;
  4. clique em Abrir;
  5. no diálogo que aparecer, selecione o delimitador apropriado. Após selecionar, uma pré-visualização dos dados será mostrada. Se houver uma quantidade variável de espaços entre cada valor mas os dados aparecerem visualmente em colunas, selecione Largura Fixa.


Eu vejo '###' numa célula que contém dados. O que posso fazer para ver meus dados normalmente?

A apresentação de '###' no conteúdo da célula significa que a célula possui um conteúdo numérico cujo tamanho é maior do que a largura da célula corrente. Para melhorar a visualização, vá até o cabeçalho da coluna e mova uma das bordas até que ela fique larga o suficiente para apresentar todos os dados.


Como escrevo duas linhas de texto numa única célula?

  1. Vá ao menu Formatar > Células.
  2. Escolha a aba Alinhamento e marque a opção Fluxo de texto > Quebra automática de texto.

Para forçar a quebra de linha num determinado local do texto, posicione o cursor na posição desejada e pressione CTRL + ENTER. Para adicionar uma quebra de linha onde o texto já foi informado, dê um duplo-clique na célula para editá-la e pressione CTRL + ENTER para forçar a quebra de linha.


Como selecionar uma ou mais linhas da planilha para repeti-la(s) como cabeçalho em todas as páginas da planilha a serem impressas?

Siga esses passos:

  1. abra a planilha;
  2. selecione a linha (ou linhas) a ser(em) repetida(s);
  3. vá ao menu Inserir > Nomes > Definir (ou pressione CTRL+F3);
  4. no diálogo que aparecer, dê um nome à seleção (acentos não são permitidos);
  5. clique em Mais >>;
  6. marque a opção Repetir linha;
  7. clique em Adicionar;
  8. clique em OK;
  9. selecione o menu Formatar > Intervalo de Impressão > Editar;
  10. no campo Linhas a serem repetidas, selecione o cabeçalho criado;
  11. clique em OK.

Quando você imprimir, as linhas de cabeçalho serão repetidas em cada página. Nenhuma alteração visual será feita na planilha. Use o menu Arquivo > Visualizar Página para visualizar as páginas antes de imprimir.

Note que não é obrigatório criar um cabeçalho nomeado (da forma como fizemos acima), o campo Linhas a serem repetidas permite a inserção da sintaxe $1:$3 (da linha 1 até a linha 3, por exemplo).


Eu não quero letras maiúsculas no início de cada conteúdo que eu digitar numa célula. O que devo fazer para desativar esse comportamento?

Vá até a opção de menu Ferramentas > Opções da autocorreção automática > Opções e desmarque a opção Primeira letra de cada frase em maiúsculas.


Como eu congelo/divido as primeiras linhas e colunas para elas permanecerem visíveis quando eu rolo minha planilha?

Congelar células

Se você tiver linhas e colunas de títulos, você pode congelá-las selecionando uma célula de referência. Todas as células que estiverem à esquerda e acima da célula de referência serão congeladas. Por exemplo, se você escolher a célula B2 como célula de referência, a linha 1 e a coluna A serão congeladas. Os passos são detalhados abaixo:

  1. selecione a célula de referência;
  2. vá até o menu Janela > Congelar;
  3. após a seleção do menu, as células à esquerda e acima da célula de referência estarão congeladas.

Dividir células

A divisão é uma função parecida com o congelamento. A diferença é que, na divisão, a área da planilha pode ser dividida em até quatro áreas. Para fazer a divisão:

  1. escolha uma célula de referência - a divisão será feita a partir da do canto superior esquerdo desta célula;
  2. vá até o menu Janela > Dividir;
  3. após a seleção do menu, será possível identificar as áreas da planilha divididas por uma linha preta que, caso desejado, também pode ser movida.

Também é possível dividir uma planilha de outra maneira. No topo da barra de rolagem da direita, e à direita da barra de rolagem inferior, você pode ver uma pequena linha preta. Quando o mouse está sobre ela, o ponteiro muda para um ícone de redimensionamento. Clicando e segurando o botão esquerdo do mouse aparecerá uma linha cinza clara na janela da planilha. Arraste o mouse até a linha ou coluna para divisão e solte o botão do mouse. A planilha será dividida.


Como posso imprimir corretamente uma planilha?

Geralmente, a melhor maneira de imprimir planilhas grandes é, primeiro, visualizar a saída. Depois, então, ajustar as configurações de impressão para obter o efeito desejado. Os seguintes procedimentos abaixo explicam as principais opções de impressão.

Visualizando a planilha

  1. Com a planilha aberta, selecione Arquivo > Visualizar página;
  2. na janela que aparecerá, use os botões de navegação para observar a planilha. Se a planilha ocupar mais de uma página, as colunas e/ou linhas faltantes aparecerão nas próximas páginas;
  3. feche a janela de visualização clicando no botão Visualizar página, à direita dos botões da barra de navegação;
  4. faça ajustes nas configurações de impressão, e então visualize novamente.

Obs.: Este comando permitirá visualizar qual o número da página associado aos dados que você imprimirá. Isto é útil quando apenas uma parte da planilha será impressa.

Definindo a orientação da página: Retrato ou Paisagem

  1. Com a planilha aberta, selecione Formatar > Página;
  2. no diálogo que aparecer, selecione a guia Página;
  3. na área Formato do papel, clique sobre a opção Retrato ou Paisagem (conforme o desejado);
  4. clique em OK.

Ajustando visualmente o conteúdo das páginas

  1. Com a planilha aberta, selecione Exibir > Visualizar quebra de página;
  2. colocando o cursor exatamente no topo da linha de corte azul e ajuste com o mouse os limites como você desejadar;
  3. para alterar a visualização e retornar ao modo Normal, vá até o menu Exibir > Normal.

Obs.: Este comando permitirá verificar qual o número da página associado aos dados que você imprimirá. Além disso, você pode utilizar intervalos de impressão. Se tudo aparecer em cinza, significa que nada foi definido para imprimir. Se um intervalo de impressão for definido, a área será mostrada com fundo branco e delimitada por linhas azuis. Uma Página N cinza (onde N é o número sequencial da página para a planilha) aparecerá no meio da área de impressão. Se nenhuma faixa for definida para impressão, siga as instruções abaixo.

Definindo um intervalo de impressão

O seguinte procedimento definirá a área de impressão:

  1. vá para a planilha desejada;
  2. acesse o menu Formatar > Intervalo de impressão > Definir;
  3. repita o procedimento para todas as áreas e planilhas desejadas.

Ajustando a escala da planilha para que ela caiba em uma página

  1. Com a planilha aberta, selecione Formatar > Página;
  2. .na janela que aparecer, selecione a guia Planilha;
  3. no canto inferior direito do diálogo, há uma seção chamada Escala;
  4. marque a opção Reduzir/aumentar impressão;
  5. informe um valor que você acha que fará com que os dados caibam na página (normalmente um percentual menor);
  6. clique em OK;
  7. visualize a impressão como já demonstrado anteriormente.

Imprimindo apenas uma área da planilha

  1. marque a área desejada;
  2. acesse o menu Arquivo > Imprimir;
  3. na janela que aparecer, clique sobre a opção Seleção (no canto inferior esquerdo);
  4. clique em OK.

Obs.: Imprimir uma área da planilha obedece às informações de escala.


Imprimindo uma planilha no meio do papel

  1. Com a planilha aberta, selecione Formatar > Página;
  2. na janela que aparecer, selecione a guia Página;
  3. na seção Alinhamento da tabela, marque ou desmarque as opções Vertical e Horizontal, conforme desejado. A área de visualização prévia, no canto superior direito, mostrará o posicionamento da planilha na página;
  4. clique em OK.


Como faço para mesclar células?

Siga os passos abaixo:

  1. selecione as células que deverão ser mescladas;
  2. vá até o menu Formatar > Mesclar células.

Caso você queira que o título seja centralizado:

  1. selecione a célula mesclada;
  2. vá até o menu Formatar > Células;
  3. selecione a guia Alinhamento;
  4. abra a lista do campo Horizontal e escolha a opção Centralizado;
  5. clique OK para finalizar.

Caso você queira desmesclar uma célula mesclada anteriormente, basta selecioná-la e clicar no menu Formatar > Mesclar células para desmarcá-lo.


Como rotacionar o título de uma coluna para ele se ajustar a uma coluna muito estreita?

Siga este procedimento:

  1. selecione a célula;
  2. vá até o menu Formatar > Células;
  3. selecione a guia Alinhamento;
  4. na seção Orientação do texto, clique e arraste o pequeno ponto azul no círculo onde está escrito ABCD até o topo (ou até um valor, em graus, que você considere agradável para a leitura do seu conteúdo);
  5. clique em OK para ver o resultado.

De forma alternativa, você também poderá experimentar a opção Empilhado verticalmente, onde as letras aparecerão empilhadas uma sobre a outra, fazendo com que a leitura do texto seja feita na vertical.


Como eu faço para proteger células da minha planilha?

Por padrão, todas as células vem com a opção Protegida marcada, porém, essa opção só é ativada quando o usuário aciona o menu Ferramentas > Proteger > Planilha. Para utilizar corretamente a proteção, siga os passos abaixo:

  1. selecione as células que você deseja manter editáveis;
  2. com as células selecionadas, vá até o menu Formatar > Células;
  3. escolha a guia Proteção de célula e desmarque a opção Protegida;
  4. clique OK.

Você acaba de definir que um intervalo de células da planilha permanecerá editável, mesmo depois que a proteção de células estiver ativada. As demais células serão protegidas, pois a opção Protegida de cada uma delas continua marcada.

Para, então, ativar a proteção de células, vá até o menu Ferramentas > Proteger documento > Planilha.

Você pode inserir uma senha se desejar. Após a inclusão e a confirmação da senha, clique OK. A partir de agora, as células protegidas não podem mais ser editadas.

Para desproteger as células da planilha, clique novamente no menu Ferramentas > Proteger documento > Planilha. Se necessário, insira a senha de proteção.


Como exportar os dados da planilha para um arquivo texto com delimitadores?

Siga esses passos:

  1. vá até o menu Arquivo > Salvar como;
  2. na janela que aparecer, selecione o tipo de arquivo Texto CSV;
  3. marque a opção Editar as configurações do filtro;
  4. clique em Salvar;
  5. você será consultado se desejar manter o formato escolhido (Texto CSV) ou se deseja salvar em formato OpenDocument (ODT);
  6. clique em Manter o formato atual;
  7. na janela que aparecer, escolha a configuração do conjunto de caracteres desejada (em geral, você poderá manter a opção padrão);
  8. escolha, ainda, as opções e os delimitadores de sua preferência:
    1. o Delimitador de campo é o caractere que separa um campo de outro no arquivo texto, o padrão é a vírgula, mas você pode escolher outros caracteres;
    2. o Delimitador de texto é o caractere utilizado para diferenciar valores de texto de valores numéricos nos campos de dados;
    3. caso desejado, opte pela opção de exportar com uma Largura de coluna fixa;
    4. é sugerido manter a opção Salvar o conteúdo da célula como mostrado marcada pois, assim, os valores serão exportados com a sua formatação aplicada;
  9. clique em OK para salvar o arquivo.


Algumas linhas da minha planilha estão ocultas. Como posso ver essas linhas?

  1. Selecione as linhas adjacentes às linhas ocultas, ou seja, arraste o mouse sobre os identificadores de linha (números) no lado esquerdo da área de trabalho, fazendo com que todas as linhas sejam selecionadas, mesmo as ocultas;
  2. vá até o menu Formatar > Linha > Mostrar ou clique com o botão direito do mouse sobre um dos identificadores de linha e clique no item Mostrar;

As células ocultas passarão a ser visíveis.


Como fazer para que as linhas sejam numeradas automaticamente?

Um dos métodos (assumindo que você queira colocar os números das linhas na coluna A) é:

  1. digite a fórmula abaixom na célula A1:
    =linha(A1)
  2. arraste o conteúdo da célula pelo ponto preto no canto inferior direito, chamado alça de preenchimento.

As suas células serão numeradas. Se você adicionar novas linhas, terá de copiar a fórmula para as novas linhas.


Como posso criar vínculos entre células de diferentes arquivos?

  1. Abra o arquivo de destino e o arquivo de origem;
  2. no arquivo de destino, selecione a célula que deverá receber o vínculo;
  3. clique no sinal de = (como se você fosse inserir uma fórmula);
  4. vá até o arquivo de origem;
  5. clique sobre a célula que fornecerá o conteúdo a ser vinculado;
  6. volte para o arquivo destino e confirme a criação do vínculo teclando Enter.

Para atualizar um vínculo, vá até o menu Editar > Vínculos, selecione o arquivo de origem e clique no botão Atualizar. Também é possível atualizar os vínculos na abertura do arquivo, para fazer isso siga os passos abaixo:

  1. vá até o menu Ferramentas > Opções;
  2. selecione a seção LibreOffice Calc e a subseção Geral;
  3. defina o modo de atualização na seção Atualização;
  4. clique OK para confirmar e finalizar.

Como posso mudar a ordem das planilhas no meu arquivo?

Siga esses passos:

  1. selecione a planilha que você quer mover;
  2. com a planilha selecionada, clique com o botão direito do mouse sobre ela e e escolha a opção Mover/Copiar planilha...;
  3. na lista Inserir antes, selecione a posição para onde a planilha será movida;
  4. clique em OK.


Como posso renomear uma planilha?

  1. selecione a planilha a ser renomeada;
  2. com a planilha selecionada, clique com o botão direito do mouse e escolha a opção Renomear;
  3. digite o novo nome;
  4. clique em OK.


Como inserir numa célula uma função que mostre sempre a data atualizada?

  1. selecione a célula desejada;
  2. vá até o menu Inserir > Função (ou pressione CTRL + F2);
  3. na guia Funções, selecione a categoria Data e Hora;
  4. selecione a função Hoje se você quiser somente a data, ou Agora se você quiser a data e a hora;
  5. clique em Próximo;
  6. clique em OK.

A sua célula deverá ficar com o seguinte conteúdo:

=HOJE()

Ou

=AGORA()


Como crio bordas nas células?

Siga esses passos:

  1. selecione a área onde a borda será aplicada;
  2. acesse o menu Formatar > Células e selecione a guia Bordas;
  3. no lado esquerdo, na parte superior, clique no ícone que representa o tipo de borda que você deseja aplicar;
  4. no diagrama abaixo dos ícones, customize as bordas, clicando sobre as linhas individuais e formatando-as através do Estilo, do Espaçamento e do Estilo da sombra;
  5. clique OK para aplicar.


Como inserir um número de página no formato “Página 1 de N” em cada página da planilha?

Números de páginas podem ser inseridos no cabeçalho ou no rodapé da planilha. Eles serão visíveis na impressão ou visualização de impressão, no entanto, não podem ser vistos no modo de edição da planilha. Para inserir os números das páginas, siga os passos abaixo:

  1. vá até o menu Editar > Cabeçalhos e rodapés;
  2. selecione a guia Cabeçalho ou na guia Rodapé;
  3. clique na área onde deseja que o número da página seja inserido (esquerda, central ou direita da página);
  4. digite o texto Página;
  5. clique no ícone que possui uma cerquilha (#) para inserir o número da página (note que os campos disponíveis são representados por ícones. Esses são os únicos campos e formatos disponíveis nas planilhas);
  6. digite o texto de;
  7. clique no ícone que contém duas cerquilhas (##) para inserir o número total de páginas;
  8. clique em OK.


Como inserir texto sobrescrito ou subscrito em uma célula?

O controle de formatação de caracteres é encontrado no menu de contexto (acessado pelo botão direito do mouse). Siga os passos:

  1. clique duas vezes sobre a célula para entrar no modo de edição;
  2. selecione os caracteres a serem sobrescritos ou subscritos;
  3. clique com botão direito do mouse para acessar o menu de contexto;
  4. selecione o menu Estilo e escolha Sobrescrito ou Subscrito;
  5. você pode, também, usar as teclas de atalho: CTRL + SHIFT + P (sobrescrito) ou CTRL + SHIFT + B (subscrito);

Outra maneira é marcar o texto, ir até o menu de contexto Caractere e, então, na guia Posição, escolher a posição desejada.

Obs: A altura da célula pode se ajustar para acomodar o novo texto.


Como posso criar minhas próprias listas ordenadas?

O Calc tem um recurso muito útil. Quando, por exemplo, você insere um dia da semana e arrasta o quadrado preto do canto inferior direito da célula (chamado alça de preenchimento), os outros dias da semana serão automaticamente preenchidos nas células seguintes. Você pode criar suas próprias listas ordenadas dessa maneira:

  1. acesse o menu Ferramentas > Opções;
  2. na janela que aparecer, selecione LibreOffice Calc > Listas de ordenação;
  3. clique no botão Novo (localizado no canto superior direito da Janela);
  4. o cursor aparecerá na área chamada Entradas;
  5. digite os componentes da lista, pressionando ENTER após cada um deles;
  6. quando digitar todos os dados, clique em Adicionar;
  7. clique em OK para finalizar.


Quero fazer a verificação ortográfica da planilha em português, no entanto, algumas células estão configuradas para inglês. Como faço para configurar o idioma dessas células para português?

  1. Selecione todas as células da planilha clicando no quadrado vazio ao lado da letra A (coluna) e acima do número 1 (linha);
  2. clique com o botão direito do mouse em Formatar células;
  3. vá até a guia Fonte;
  4. escolha Português (Brasil) no campo Idioma;
  5. clique OK.


Gostaria de visualizar as planilhas de um mesmo arquivo com diferentes fatores de "zoom". É possível fazer isso no Calc?

Sim, para fazer isso siga os passos abaixo:

  1. vá até o menu Ferramentas > Opções;
  2. selecione a seção LibreOffice Calc e a subseção Exibir;
  3. desmarque o campo Sincronizar planilhas da seção Zoom;
  4. clique OK para confirmar e finalizar.