Faq/Draw/109/fr

From The Document Foundation Wiki
< Faq‎ | Draw
Jump to: navigation, search

Comment réutiliser un dessin à l'aide de la Gallery ?

La Gallery est un moyen très simple de mettre à disposition de l'ensemble des modules (Draw, Impress, Writer, etc.) des objets et en particulier des dessins réalisés dans Draw, comme par exemple des logos. Après avoir créé votre dessin, vous allez l'insérer dans un thème de la Gallery et il sera disponible dans tous les modules pour pouvoir être intégré par un simple cliquer-glisser.

Finaliser le dessin

Une fois le dessin terminé :

  • sélectionnez tous les objets appartenant au dessin, à l'aide d'un cliquer-glisser entourant tous ces objets, ou faites Ctrl+A s'il n'y a pas d'autres objets sur la page ;
  • groupez les objets par un clic droit sur un objet  ▸ Grouper ou le menu Modifier ▸ Grouper ou le raccourci Ctrl+⇧ Maj+G.

Cette étape n'est pas indispensable, mais permettra de conserver le dessin comme un ensemble lorsqu'il sera inséré de nouveau.

Insérer le dessin dans la Gallery

Afficher la Gallery

  • sélectionnez le menu Outils ▸ Gallery
  • si le volet de la Gallery est replié, cliquez sur la poignée cerclée de rouge sur la figure 1 :
Figure 1 : Poignée d'ouverture de la Gallery
Note : si la Gallery est ouverte, vous pouvez cliquez sur cette même poignée pour la faire disparaitre temporairement.

À partir de LibreOffice 4.1, il est possible d'utiliser le volet latéral pour afficher la Gallery :

  • activez le volet latéral :
    • sélectionnez le menu Outils ▸ Options ▸ LibreOffice ▸ Avancé,
    • cochez l'option Activer le volet latéral expérimental (au redémarrage),
    • validez par OK et acceptez le redémarrage de LibreOffice,
    • dans Draw, sélectionnez le menu Affichage ▸ Volet latéral ;
  • affichez la Gallery dans le volet latéral en cliquant sur le 3e bouton à partir du haut.

Choisir le thème où insérer le dessin

La Gallery est organisée en différents thèmes dont la liste apparait sur la partie gauche, comme sur la figure 2 :

Figure 2 : Exemple de Gallery

Vous pouvez :

  • soit cliquer sur le nom du thème où vous voulez enregistrer votre dessin, Mon thème par exemple ;
  • soit créer un nouveau thème en cliquant sur le bouton Nouveau thème : renseignez son nom et validez par OK.

Faire glisser le dessin dans la Gallery

C'est assurément l'étape la plus délicate. Pour faire comprendre à LibreOffice que vous ne voulez pas déplacer votre dessin sur votre page mais le copier dans la Gallery, un simple cliquer-glisser ne fonctionne pas. Procédez comme suit :

  • cliquez une fois sur le dessin pour le sélectionner ;
  • maintenez le clic gauche enfoncé sur votre dessin sans bouger pendant 1 à 2 s ;
  • le pointeur de la souris se modifie, vous pouvez alors faire glisser l'objet vers la Gallery et le relâcher dans la partie droite de la Gallery où apparaissent les objets déjà enregistrés.
Nota
  • Si le dessin se déplace sur la page et ne veut pas se déposer dans la Gallery, c'est que vous n'avez probablement pas assez attendu avant de bouger la souris.
  • Si vous ne pouvez pas relâcher le dessin dans la Gallery, c'est sans doute que vous n'avez pas le droit de modifier le thème choisi. Choisissez alors Mon thème ou un autre de vos thèmes personnalisés (l'icône du thème doit être vert, ou orange si vous utilisez un compte administrateur).

Insérer un dessin à partir de la Gallery

À partir du document où vous voulez insérer votre dessin :

  • ouvrez la Gallery comme précédemment ;
  • sélectionnez le thème où se trouve votre dessin ;
  • cliquez-glissez sur le dessin souhaité et déposez-le dans votre document.

Pour aller plus loin

Si vous voulez partager votre thème de Gallery, un moyen simple est de créer une extension facilement installable. Veuillez consulter le tutoriel Comment créer une extension - Application à la création d'un thème pour la Gallery pour plus d'informations.