Jump to content

Tools Customize menu

From The Document Foundation Wiki
This page contains changes which are not marked for translation.

This page is in work!

Foreword

This video shows how under LibreOffice the menu Tools ▸ Customize menu can be applied. Customizing means that you can add or remove an "Available Command". The menu Tools ▸ Customize menu can be found in all components of LibreOffice. This description uses the Writer component as an example and provides further information and details. Once you have selected the menu, six tabs are displayed in the "Customize" dialog. There you can make adjustments for:
Menus | Toolbars | Notebookbar | Context Menus | Keyboard shortcuts | Events

Link to the Video

Link to the Video (in German [DE]): Menü Extras Anpassen This video is in work!

"Tools > Customize" menu

For example, open Writer. Choose the Tools ▸ Customize menu. Depending on what you want to customize, select one of the following tabs:
| Menus | Toolbars | Notebookbar | Context Menus | Keyboard | Events |
Customize means that you can add or remove an "Available Command" from one of these options. See also in the online help:
Configuring LibreOffice
Customize

Customize Menus

Choose Tools ▸ Customize from the menu. The "Customize" dialog will open.

Figure 1: "Customize-Menus" Dialog

Click on the "Menu" tab in Figure 1.

Left side of the dialog

The "Customize" dialog tab "Menus" is divided on the left side so that you can select an available command and add it on the right side to an existing menu. You can select a command using Search _1_, for this you enter a string in the text field to narrow down the search for commands. Or you can select a thematic group of commands at Category _2_. If "All Commands" _3_ is selected at Category, you can scroll all commands at Available Commands _4_ and select one. When you have selected your desired command, you can add it to the displayed menu.

Add / remove entries

In the middle of the dialog there are two arrows _5_ Add entry / Remove entry. With the arrow you can return Assigned commands _6_ to Available commands. With the arrow you can assign Available Commands to Assigned Commands. So when you have selected your desired command, click on the arrow so that it is inserted into the right side of the dialog.

Right side of the dialog

On the right side you can select the Scope _7_, Writer or only the document, for which the adjustment should be valid. Below that you can select the Target _8_, which is the menu or submenu where the customization should be made. If you click on the arrow next to the Target _9_ entry, you will get a list of menus and submenus to choose from. To the right of this arrow ˅ is a hamburger menu _10_ with choices that vary by situation. And in the next field below, you will find the existing Assigned Commands of the selected menu. To the right of it there are two arrows _11_ / . For example, if you mark the new command inside the Assigned Commands, you can use the arrows / to move the command. When you are done click OK. The new command should now be visible for use in the previously selected menu.
See also in the online help: Menus

Customize Toolbars

Choose Tools ▸ Customize from the menu. The "Customize" dialog will open.

Figure 2: "Customize-Toolbars" dialog

Click on the "Toolbars" tab (Figure 2).

Left side of the dialog

The dialog "Customize" tab "Toolbars" is divided on the left side so that you can select an Available command and add it to a toolbar. You can select a command using Search _1_, for this you enter a string in the text field to narrow the search for commands. Or you can select a thematic group of commands at Category _2_. If "All Commands" _3_ is selected at Category, you can scroll all commands at Available Commands _4_ and select one. When you have selected your desired command, you can add it to the displayed toolbar at Target.

Add / remove entries

In the middle of the dialog there are two arrows _5_ / . With the arrow you can return Assigned Commands _6_ to Available Commands. With the arrow you can assign Available Commands to Assigned Commands. So when you have selected your desired command, click on the arrow so that it is inserted into the right side of the dialog.

Right side of the dialog

On the right side you can select the Scope _7_, for Writer or a document, for which the adjustment should be valid. Below that you can select the Target _8_, that is the toolbar, where the customization should be made. If you click on the arrow _9_, next to the displayed toolbar, you will get a list of toolbars to choose from. To the right of this arrow _10_ is a hamburger menu with the choices varying by situation. And in the next field below you will find the existing Assigned commands of the selected toolbar. To the right of it there are two arrows _11_ / . For example, if you select the new command inside the Assigned Commands, you can use the arrows / to move the command. When you are finished click OK. The new command should now be visible in the previously selected toolbar for use. See also in the online help: Adding Buttons to Toolbars

Customize Notebookbar

See also in the online help: User interface.
You can reach the relationship to the Notebookbars by selecting View ▸ User Interface from the menu. In the "Select Your preferred User Interface" dialog that then opens, select one of the options below the Toolbars selection 1
| "Tabbed" 2 | "Tabbed Compact"3 | "Groupedbar Compact"4 | (Figure 3).

Figure 3: "Select Your Preferred User Interface" dialog

See also: User interface in Writer
The menu Tools ▸ Customize "Notebookbar" tab refers to one of these user interface settings. If none of the above user settings have been made, there will be no selection in the "Customize" dialog.

Note:
Example: In the "Tabbed" user interface, select Customize on the upper right side in the Selection menu.

In the Target area _1_, you can select either "All Commands" or sub-functions. In the Assigned Commands _2_ area, you can deselect or select commands by selecting or deselecting a checkbox (check/uncheck). (Figure 4)

Figure 4: "Customize Notebookbar" dialog

The selected command should now be visible or hidden in the previously selected Notebookbar. See also: Using Notebookbar

Customize Context Menus

Choose Tools ▸ Customize from the menu. The "Customize" dialog opens.

Figure 5: "Customize-Context Menus" dialog

Click on the "Context Menus" tab. (Figure 5)

Left side of the dialog

The dialog "Customize" in the tab "Context menus" is divided on the left side so that you can select an Available command and add it to a Context Menu. You can select a command using Search _1_. To do this, enter a string in the text field to narrow the search for commands. Or you can select a thematic command group at Category _2_. If "All Commands" _3_ is selected at Category, you can scroll all commands at Available Commands _4_ and select one. When you have selected your desired command, you can add it to the displayed context menu.

Add / remove entries

In the middle of the dialog there are two arrows _5_ / . With the arrow you can return Assigned Commands to Available Commands. With the arrow you can assign Available Commands to Assigned Commands. So, when you have selected your desired command, click on the arrow so the command will be inserted in the right side of the dialog.

Right side of the dialog

On the right side you can select the Scope _7_, for Writer or a document, for which the adjustment should be valid. Below that you can select the Target _8_, that is the Context Menu, where the customization should be made. If you click on the arrow _9_, next to the displayed Context Menu, you will get a list of Context Menus to choose from. And in the next field below, you will find the existing Assigned Commands _6_ of the selected context menu. To the right of it _11_ there are two arrows / . For example, if you highlight the new command inside the Assigned Commands, you can use the arrows to move the command. When you are done click OK. The new command should now be visible for use in the previously selected Context Menu.
See also in the online help: Context Menus

Customize Keyboard - (Keyboard Shortcuts)

Choose Tools ▸ Customize from the menu. The "Customize" dialog opens.

Figure 6: "Customize Keyboard" dialog

Click on the "Keyboard" tab. (Figure 6) In the upper part of the "Customize" dialog are the keys and key combinations _1_. Some keys and key combinations are already assigned, but can be changed under certain circumstances. Some keys and key combinations are displayed in light gray and cannot be used. In the middle of the dialog you can search for Functions _2_. Below that is the area _3_ and the functions _4_ for the commands. On the far right, the keys that you have marked for customization above are displayed _5_. In the upper right area of the dialog, you have the choice of whether you want to customize for LibreOffice or Writer _6_. Below that are the buttons _7_ for Modify, Delete, Load, Save and Reset. The new command should now be assigned to the selected button or button combination in the upper part at button combinations and can be used.
See also in the online help: Keyboard

Customize Events

Choose Tools ▸ Customize from the menu. The "Customize" dialog will open.

Figure 7: "Customize-Events" dialog

Click on the "Events" tab (Figure 7). Here you can make assignments to actions (macros) to certain events.
See also in the online help: Events

Further Informations

Topic book as a document for this wiki page

(In German [DE]): Common - Tools>Customize - Theme book

Customize Context menu

Customize Context menu

Documentation / Manuals

Here you will find the Documentation / Manuals: Documentation / Manuals

Any questions?

For questions on this topic go to: Ask.LibreOffice

Get Involved

Join us today and help us to make it even better! : Get Involved

LibreOffice is Free Software and is made available free of charge. Your donation, which is purely optional, supports our worldwide community. If you like the software, please consider a Donation.