Daten Desaster vermeiden

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page Videos/Preventing data disaster and the translation is 100% complete.
Other languages:
Deutsch • ‎English

Diese Seite ist noch in Arbeit - hilf uns, es zu verbessern!

Vorwort

Dieser Beitrag soll helfen, Datenverlust zu vermeiden, und gibt dazu einige Hinweise.

Datensicherheit bei der Verwendung von LibreOffice

Daten Desaster vermeiden

Jeden Morgen steht jemand auf, geht an den Computer und stellt fest:

″Meine Daten sind verschwunden, gestern (oder gerade eben) waren sie noch da″, siehe auch Links zu AskLibreOffice.

So oder so ähnlich passiert es jeden Tag. Wir wissen nicht, wie viele Menschen davon betroffen sind.

Ist es Gedankenverlorenheit, Leichtsinnigkeit, Gleichgültigkeit oder die Hoffnung "Oh, es wird schon nichts passieren".

"Ist doch bisher alles gut gegangen".

Aber, das Daten Desaster hat soeben zugeschlagen!

Dann ist die Panik groß.

Ob es sich um eine Arbeit für die Schule, die Uni, den Arbeitgeber oder für sich selber handelt, meist sind es gerade wichtige und eilige Informationen, die man niedergeschrieben oder eingegeben hat, denn es muss noch heute oder sofort fertig sein.

- Zum Seitenanfang -

Warum können Daten verloren gehen?

Hier ein paar Beispiele:

  • Das Speichermedium (Festplatte, SSD, CD, DVD oder Stick) hat Schaden genommen, dadurch können Daten nicht mehr gelesen werden.
  • Die bearbeitete Datei wurde nicht gespeichert, oder der Speichervorgang wurde unterbrochen.
  • Die bearbeitete Datei wurde in einem falschen Dateiformat gespeichert.
  • Die App Ihres Cloudanbieters funktioniert nicht wie gedacht.
  • Eine Systemwiederherstellung hat die Dateien auf Ihrem Desktop entfernt.
  • Das Programm, mit dem gearbeitet wurde, ist unerwartet abgestürzt.
  • Ein wesentliches Computerbauteil fällt plötzlich aus.
  • Es gibt einen Spannungseinbruch bzw. Stromausfall.
  • Der Benutzer überschreibt eine erstellte Datei mit einer leeren Datei.
  • Der Benutzer löscht (aus Versehen) die erstellte Datei.

Die Gegebenheiten, warum Daten verloren gehen, ließen sich noch weiter fortsetzen.

Die meisten Fehler werden aber nicht durch Hardware oder Software verursacht, sondern durch den Benutzer (user).

Wie können wir weitgehend verhindern, dass Daten verloren gehen?

Um zu verhindern, dass Daten verloren gehen, wendet man die sogenannte Datensicherung an.

Und da gibt es vielerlei Möglichkeiten.

Es fängt schon bei der Bearbeitung eines Dokumentes an.

Je wichtiger ein Dokument für Sie ist, desto häufiger sollten Sie es speichern.

LibreOffice intern

Dialog box: Options - Load/Save – General
Verzeichnis Backup
Dialog "Optionen - LibreOffice Erweitert"
Dialog "Experteneinstellungen"

Dokument automatisch speichern aus der aktuellen Hilfe.

Autowiederherstellung

LibreOffice bietet über das Menü Extras ▸ Optionen ▸ Laden/Speichern ▸ Allgemein unter ″Speichern″ die Möglichkeit an, die Autowiederherstellungsinfos alle "X Minuten" zu speichern ("X" steht für die Anzahl Minuten).

LibreOffice verwendet die Autowiederherstellungsinfos zur Wiederherstellung einer Datei nach einem Absturz.

Wofür gibt es die Option Sicherungskopie und wie kann ich ein Dokument wiederherstellen?

Datei Backup

Außerdem kann dort ein Häkchen gesetzt werden bei ″Sicherungskopie immer erstellen″.

Dadurch wird beim Speichern eines Dokuments der bisher gespeicherte Stand des Dokuments in einer Kopie mit der Endung .bak gespeichert.

Beim nächsten Speichern wird diese durch den nächsten Stand überschrieben.

Dies ist eine Maßnahme, die vor allem dazu dient, dass Sie auf einen früheren Stand zurückgreifen können, wenn Sie bei der Bearbeitung eines Dokuments Fehler gemacht haben.

Sicherungskopien werden in dem Verzeichnis abgelegt, das unter Extras ▸ Optionen ▸ LibreOffice ▸ Pfade dort bei Sicherungskopien eingestellt ist.

Unter Windows 10 sind die Sicherungskopien standardmäßig im Verzeichnis C:\Users\USERNAME\AppData\Roaming\LibreOffice\4\user\backup hinterlegt.

Wenn Sie auf Ihrer Festplatte im PC eine Partion angelegt haben oder eine zweite Festplatte dort haben, können Sie überlegen, das Backup-Verzeichnis dort zu ändern.

Falls Sie eine *.BAK Datei nicht in LibreOffice öffnen können, können Sie diese umbenennen in .ODT oder machen Sie eine Dateizuordnung im Betriebssystem für .BAK.

Siehe: Ändern der Standardprogramme

Wenn Sie noch andere Programme verwenden, die ebenfalls eine .BAK Datei speichern, sollten Sie eventuell auf eine dauerhafte Zuordnung verzichten.

Siehe auch: Erweiterung (Extension)

Wofür gibt es die Option Sicherungskopie und wie kann ich ein Dokument wiederherstellen?

Sperrdatei

Format-Darstellung einer Sperrdatei: .~lock.FILENAME.FILEext#

Die Sperrdatei befindet sich in demselben Verzeichnis wie das geöffnete Dokument bzw. sie wird beim Öffnen dort angelegt 1).

Voraussetzung dafür ist, dass das Verzeichnis, in dem gearbeitet wird, Schreibberechtigung hat.

Die Sperrdatei wird erstellt, wenn ein Dokument geöffnet wird, und normalerweise gelöscht, wenn das Dokument geschlossen wird.

Sie dient dazu, in einer Mehrbenutzerumgebung zu verhindern, dass mehr als ein Benutzer ein Dokument bearbeitet, was ein Problem darstellen würde.

Der erste Benutzer, der die Datei öffnet, kann das Dokument bearbeiten, aber alle nachfolgenden Benutzer, die das Dokument öffnen, können es nur lesen.

Das heißt, sie wird für zwei Zwecke benötigt:

  1. Bei einigen Dateisystemen gibt es keine (zuverlässige) Sperrung einer Datei, wenn eine Anwendung sie öffnet. Dies kann dazu führen, dass die Datei von zwei (oder mehr) Anwendungen zur Bearbeitung geöffnet wird (z.B. über ein Netzwerk), die dann unabhängig voneinander in die Datei schreiben, mit katastrophalen Folgen. Das Anlegen der Sperrdatei teilt in diesem Fall den anderen LibreOffice/OpenOffice (den beiden Anwendungen, die wissen, dass sie nach der Datei suchen müssen) mit, dass die Datei bereits in Verwendung ist.
  2. Außerdem enthält die Sperrdatei die Information, wer und wo die Datei geöffnet hat, was hilfreich ist, wenn ein Benutzer eine Datei bearbeiten möchte, die bereits von einem anderen Benutzer geöffnet wurde, und wenn er diese Information sieht, kann er den anderen Benutzer anrufen und ihn bitten, die Datei zu schließen.

Es kann vorkommen, dass die Sperrdatei nicht gelöscht werden kann, wenn Office oder das Betriebssystem blockiert.

Zum Beispiel könnte sie übrig geblieben sein, wenn LO abgestürzt ist, während eine Datei geöffnet war, so dass keine normales Beenden stattgefunden hat.

Die Sperrdatei bleibt dann im Verzeichnis stehen.

In diesem Fall wird die Datei nur im Lesemodus geöffnet.

Die Sperrdatei muss gelöscht werden, um den Bearbeitungsmodus wiederherzustellen.

Wenn Ihre Datei zum Beispiel MyFile.odt ist:

Suchen Sie nach einer Datei .~lock.MyFile.odt# im selben Verzeichnis.

Wenn dort die entsprechende Sperrdatei existiert, so ist sie ein Überbleibsel einer Bearbeitungssitzung, die aufgrund eines Fehlers nicht ordnungsgemäß geschlossen wurde.

Löschen Sie sie, bevor Sie MyFile.odt erneut öffnen.

In Windows ist die Sperrdatei eine versteckte Datei und Sie müssen Windows so einstellen, dass versteckte Dateien angezeigt werden.

Geben Sie in Ihrem Dateimanager ein %AppData% um die versteckten Dateien zu sehen, siehe auch Versteckte Dateien, Ordner und Laufwerke anzeigen.

1) Wenn Sie das nicht wollen, bleibt Ihnen nur die Möglichkeit, das Sperren ganz zu deaktivieren, 
 gehen Sie zu Extras ▸ Optionen ▸ LibreOffice ▸ Erweitert und klicken auf die Schaltfläche: Experteneinstellungen….
 Suchen Sie nach: UseLocking und stellen Sie  org.openoffice.Office.Common\Misc\UseLocking auf false.

Einfache Dateivervielfältigung

Im einfachsten Fall legt man eine Kopie der erstellten Datei an.

Liegt diese jedoch auf dem selben Datenträger wie das Original, können bei einem Defekt des Datenträgers beide Versionen der Datei verloren gehen.

Also ist es sinnvoll, eine Kopie der wichtigen Dateien auf einem externen Datenträgern zu speichern.

Kurzzeitspeicherung bzw. -Backup

Wenn Sie an einer Datei arbeiten, speichern Sie niemals direkt auf einem externen Datenträger der über USB angeschlossen ist.

USB ist relativ langsam (im Vergleich zur Datenübertragung in den Hauptspeicher) und Speichervorgänge sind "asynchron" - das heißt: Das Betriebssystem meldet einen abgeschlossenen Speichervorgang sobald alle Daten in einem Speicherpuffer (im Hauptspeicher) sind.

Das heißt aber noch nicht, dass die Daten auch bereits auf dem (USB-)Speicher abgebildet sind!

Denken Sie daran, dass ein Speicher-Stick oder eine externe Festplatte noch nicht alle Daten gespeichert hat, wenn der Dateimanager das Ende des Speichervorgangs signalisiert.

Benutzen Sie die Möglichkeiten Ihres Betriebssystem, mit der Funktion Hardware sicher entfernen und Medium auswerfen ▸ Medium auswerfen des Datenträgers.

Deshalb speichern Sie ihre Dateien zunächst immer grundsätzlich auf einem internen Laufwerk in Ihrem PC.

Anschließend können Sie für die kurzzeitige Speicherung oder Backup einen Speicherstick oder eine externe Festplatte verwenden.

Verwenden Sie z.B. Ihren Dateimanager um eine Datei vom internen Laufwerk auf einen Speicher-Stick oder externe Festplatte zu speichern.

 Hinweis 
 Beobachten Sie den Speicher-Stick oder die externe Festplatte, bis die Kontrollampe nicht mehr blinkt,
 bzw. das Betriebssystem den externen Speicher freigibt.

- Zum Seitenanfang -

Datensicherung

Eine schon ziemlich professionelle Datensicherung wird erreicht, wenn man für die Datensicherung

  1. ein Programm zur Datensicherung und
  2. externe Datenträger (externe FestplattenWikipedia logo v3.svg, NAS-ServerWikipedia logo v3.svg, CloudspeicherWikipedia logo v3.svg) verwendet.

Programm zur Datensicherung

Ein Programm zur Datensicherung hat den Vorteil, dass meist eine komplette Sicherung der Daten des Computers durchgeführt wird.

Dies erfordert Datenträger, die entsprechend groß genug sind, um all diese Daten zu speichern.

Programme zur Datensicherung werden auch kurz Backup-Programmme genannt.

Diese verfügen meist über weitreichende Funktionen, wie zum Beispiel:

  • die zeitliche Planung des Backups
  • Verwendung eines Backup-Schemas, wie z.B. inkrementelles Backup
  • mögliche Verschlüsselung des Backups
  • möglicher Passwort-Schutz
  • Validierung des Backups

- Zum Seitenanfang -

Zeit-/Mengenfaktor

Der Zeit-Mengenfaktor spielt für die Datensicherung eine wichtige Rolle.

Diesen sollten Sie davon abhängig machen wieviele Dateien Sie in einem bestimmten Zeitraum neu erstellen und in welchem Umfang.

Wenn Sie ein Vielschreiber sind oder komplexe Datenbanken bearbeiten, sollten Sie möglichst oft Ihre Daten sichern.

Dazu können Sie für Ihre Bedürfnisse alle oben angegebenen Möglickeiten verwenden.

Planung zur Datensicherung

Überlegen Sie sich genau, was für Sie der beste Ablauf ist, um Ihre Daten möglichst sicher zu halten.

Am besten Sie schreiben es mal für sich auf, wie Sie vorgehen möchten, machen Sie sich einen Plan zur Datensicherung.

Versuchen Sie, die Datensicherung zu automatisieren.

Machen Sie sich eine Checkliste der manuell vorzunehmenden Aktionen.

Siehe auch: Organisation auf dem PC - Dateiverwaltung

Restrisiko

Sie haben sicher schon gemerkt, ein kleines Restrisiko verbleibt immer, aber es ist sehr gering bei richtiger Datensicherung.

Sicher werden Sie die Datensicherung nicht nach jedem geschriebenen Wort veranlassen, sondern überlegen sich, was kann man mit einem angepaßten Aufwand wieder herstellen.

- Zum Seitenanfang -

Sichern des Benutzerprofils in regelmäßigen Abständen

Das Benutzerprofil ist der Ordner, in dem alle benutzerbezogenen Daten wie Erweiterungen, benutzerdefinierte Wörterbücher, Dokumentvorlagen usw. gespeichert sind.

Je mehr Sie daran Änderungen vornehmen, um so sinvoller ist ein Backup danach zu erstellen.

- Zum Seitenanfang -

Weitere Informationen

Versteckte Dateien

Versteckte Dateien, Ordner und Laufwerke anzeigen

Wie schon oben beschrieben, geben Sie in Ihrem Dateimanager ein %AppData% um die versteckten Dateien zu sehen.

Für eine dauerhafte Anzeige der versteckten Elemente:

Ausgeblendete Dateien und Ordner in Windows anzeigen

Windows 10

1. Öffnen Sie den Datei-Explorer über die Taskleiste.

2. Wählen Sie Ansicht ▸ Optionen ▸ Ordner-und Suchoptionen ändern aus.

3. Wählen Sie im Tab "Ansicht" und unter "Erweiterte Einstellungen" die Option "Versteckte Dateien, Ordner und Laufwerke anzeigen" und OK aus.

Windows 11

1. Öffnen Sie den Datei-Explorer über die Taskleiste.

2. Wählen Sie Ansicht ▸ Zeigen ▸ Ausgeblendete Elemente.

Oder klicken Sie auf das Symbol ThreePointIcon.png und wählen "Optionen" und wählen Sie im Tab "Ansicht" und unter "Erweiterte Einstellungen" die Option "Versteckte Dateien, Ordner und Laufwerke anzeigen" und OK aus.

Antivirenprogramm/Defender - Ausnahme für den kontrollierter Ordnerzugriff

Einrichten einer Ausnahme für den kontrollierten Ordnerzugriff von Defender für LibreOffice

Mögliche Drucker Fehlerbehebung unter LibreOffice

Bitte überprüfen Sie die hier gemachten Angaben für Ihren Drucker.

Herstellervorgaben

Von Welchem Hersteller ist der Drucker?

Welcher Druckertyp, -Modell verwenden Sie?

Ist es ein Multi-Funktions-Drucker?

Informationen zu Ihrem Drucker erhalten Sie im Handbuch des Druckers oder auf der Webseite des Druckerherstellers.

Wurde der Drucker mit seinen erforderlichen Komponenten im Betriebssystem installiert?

Hat der Drucker einen aktuellen Druckertreiber?

Verbindungen /Schnittstellen

Ist der Drucker eingeschaltet?

Hat der Drucker Verbindung zum PC?

Welche Verbindung hat der Drucker - USB, Wifi, Netzwerk?

Bei einer USB-Verbindung prüfen Sie die Steckverbinder am PC und Drucker.

Überprüfen Sie, ob der im Druckdialog ausgewählte Drucker die aktuell angeschlossene Version ist, z.B. wenn er über WiFi angeschlossen ist, aber ursprünglich über USB eingerichtet wurde, stellen Sie sicher, dass der über WiFi angeschlossene Drucker ausgewählt ist und nicht der USB.

Wenn es sich um einen Multi-Funktions-Drucker handelt, stellen Sie außerdem sicher, dass nicht der Faxdrucker ausgewählt ist.

Ist der Drucker als Standarddrucker im Betriebssystem angemeldet?

Haben Sie ausversehen ein Leerzeichen markiert? Dann heben Sie die Markierung auf.

Papier

Liegt genügend Papier im Drucker?

Wurde das richtige Papierfach am Drucker ausgewählt?

Wurde das Papier (Umschlag etc.) richtig eingelegt?

Tinte / Toner

Steht ausreichend Toner bzw. Tinte zur Verfügung?

Bei Tintendrucker, prüfen Sie, ob eine Druckkopfreinigung angestoßen werden muß.

Ist Ihre Tonerkassette in Ordnung, der Toner nicht verklebt.

Hier hilft unter Umständen die Tonerkassette zu entnehmen und vorsichtig zu schütteln.

Legen Sie altes Zeitungspapier darunter.

Erweiterte Prüfung

Können Sie aus anderen Anwendungen heraus drucken?

Ältere LibreOffice Version aus dem Archiv auswählen

 Achtung 
 Es wird dringend empfohlen, die neuesten unterstützten LibreOffice Versionen von de.libreoffice.org herunterzuladen und zu verwenden.
 Ältere Versionen werden nicht mehr gepflegt und können Sicherheitslücken und Risiken enthalten.

Ein Video-Link zum Thema: Ältere LibreOffice Version aus dem Archiv auswählen

Am Beispiel von Windows

Ältere Versionen von LibreOffice können Sie aus dem Archiv herunter laden.

Als Beispiel suchen Sie die Version 6.4.7.2, Windows 64 Bit, mit dem helppack /de.

Ältere LibreOffice Version aus dem Archiv auswählen, 6.4.7.2

Geben Sie im Internetbrowser den folgenden Link ein: tdf.io/archiv

Sie befinden sich nun auf der Starseite des LibreOffice-Archivs.

Hier sind alle bisherigen Versionen von LibreOffice verzeichnet und können ausgewählt werden.

Da es LibreOffice für unterschiedliche Betriebssysteme und Bit-Wertigkeiten gibt, werden Sie vom ersten Klick auf die Versionen stufenweise weitergeführt.

Die Seite beginnt mit Version 3.3.0.4.

Scrollen Sie nach unten um höhere Versionen anzeigen zu lassen.

Klicken Sie nun auf die gewünschte Versionsnummer.

In der nächsten Auswahl wählen Sie die von Ihnen gewünschte Betriebssystem-Bezeichnung.

In diesem Beispiel wählen Sie "win".

Die nächste Auswahl legt fest, ob 32 - oder 64 Bit.

Wählen Sie "x86_64/" für 64 Bit.

In der folgenden Auswahl sehen Sie nun das eigentliche Programm und unterschiedliche helppack-Dateien für diverse Sprachen.

Klicken Sie oben das Programm "LibreOffice_6.4.7.2_Win_x64.msi".

Der Download für das Programm LibreOffice Version 6.4.7.2, 64 Bit, beginnt.

Wenn der Download beendet ist klicken Sie weiter unten auf das helppack "LibreOffice_6.4.7.2_Win_x64_helppack_de.msi".

Wenn Sie Programm und helppack herunter geladen haben, können Sie auf Ihrem PC mit der Installation beginnen.

Links zu AskLibreOffice

Links zu AskLibreOffice.com [DE]

Erweiterung

Erweiterung (Extension)

Eine erweiterte Möglichkeit dafür bietet die Erweiterung (Extension) TimeStampBackup:

Wenn Sie statt des Speichern-Symbols oder des entsprechenden Menübefehls das von dieser Erweiterung bereitgestellte Symbol oder den entsprechenden Befehl verwenden, wird bei jedem Speichern eine Kopie des vorigen Stands unter einem einem eigenen Namen, der Datum und Uhrzeit enthält, gespeichert, so dass Sie eine Historie Ihrer gespeicherten Versionen zur Verfügung haben.

Organisation auf dem PC

Organisation auf dem PC - Dateiverwaltung

Dateiverwaltung

- Zum Seitenanfang -

Dokumentation / Handbücher

Hier finden Sie die Dokumentation / Handbücher:

Dokumentation / Handbücher

Noch Fragen?

Für Fragen zum Thema gehen Sie zu:

Ask.LibreOffice

Mitarbeit bei LibreOffice

Besuchen Sie uns auch auf der Seite

Dabei sein!

Spenden

LibreOffice ist freie Software und wird kostenfrei zur Verfügung gestellt.

Ihre Spende, die rein freiwillig ist, unterstützt unsere weltweite Gemeinschaft.

Wenn Ihnen die Software gefällt, freuen wir uns über eine Spende.

Link zum Video

Link zum Video:

Daten Desaster vermeiden – LibreOffice 6.4

- Zum Seitenanfang -